$$GETTING_STARTED$$ - %%projecttitle%%

CQG API 4.0 - Revised
Introduction
Send Feedback

Glossary Item Box

CQG API is created to make CQG data and functionality available to customer applications.

The CQG API is an automation server component that is very convenient to use from any application written on VB, C#, C++ or any other language, which supports automation technologies. With the advent of the CQG API product, customers are able to create their own customized systems using data that is available via CQG.

CQG API can be used to retrieve real-time market data on instruments (i.e., their quotes, dynamic properties), account and position data, and perform order management.

CQG API 4.0 introduces the functionality of historical data retrieval. You can retrieve timed bars, ticks, constant volume bars, TFlow bars, point and figure bars, user formulas (custom studies, conditions, QFormulas, and trading systems), data sources and data source symbols, tradable commodities, and custom sessions.

CQG API has an intuitive programming interface. Users who had worked with Excel and are familiar with Excel Object Model will quickly get used to this component.

CQG API is supplied as a part of the CQGIC package. In order for CQG API to work, CQGIC should be started on the computer.

© CQG Inc. All Rights Reserved.


%%phrase%%

Project Overview
Send Feedback

Glossary Item Box

Description

CQG 4.0 Type Library - Revised API

Classes

Class Module | Description
CQGAccounts | Represents a collection of CQGAccount objects.
CQGAccountSummaries | Represents a collection of CQGAccountSummary objects calculated for each currency in an account.
CQGAdvancedStudies | Represents a collection of CQGAdvancedStudy objects.
CQGAdvancedStudy | Represents a collection of CQGCurves objects.
CQGAdvancedStudyDefinitions | Represents a collection of CQGAdvancedStudyDefinition objects.
CQGAlgorithmicOrderDefinitions | Represents a collection of CQGAlgorithmicOrderDefinition objects.
CQGAlgorithmicOrderProperties | Represents a collection of CQGAlgorithmicOrderProperty objects.
CQGBarsTimestamps | Represents a collection of DateTimes
CQGChangedTradeEntries | Represents a collection of CQGChangedTradeEntry objects.
CQGChangedTradeExits | Represents a collection of CQGChangedTradeExit objects.
CQGCommodities | Represents a collection of commodity names.
CQGCommodityInstruments | Represents a collection of resolved instrument names.
CQGCondition | Represents a collection of CQGConditionResult objects. It is returned by the CQGCEL.RequestCondition method.
CQGConditionDefinitions | Represents a collection of CQGConditionDefinition objects.
CQGConditions | Represents a collection of CQGCondition objects
CQGConstantVolumeBars | Represents a collection of CQGConstantVolumeBar objects. It is returned by the CQGCEL.RequestConstantVolumeBars method. The CQGCEL.ConstantVolumeBarsResolved, CQGCEL.ConstantVolumeBarsAdded, and CQGCEL.ConstantVolumeBarsUpdated events can be fired for the CQGConstantVolumeBars.
CQGConstantVolumeBarsCollection | Represents a collection of CQGConstantVolumeBars objects.
CQGCurrencyRates | Represents a collection of CQGCurrencyRate objects.
CQGCurveDefinitions | Represents a collection of CQGCurveDefinition objects.
CQGCurveHeaders | Represents a collection of String - curve headers.
CQGCurves | Represents a collection of curves (Double).
CQGCustomStudies | Represents a collection of CQGCustomStudy objects.
CQGCustomStudy | Represents a collection of CQGCurves objects. It is returned by the CQGCEL.RequestCustomStudy method call. The CQGCEL.CustomStudyResolved, CQGCEL.CustomStudyAdded, and CQGCEL.CustomStudyUpdated events can be fired for the CQGCustomStudy.
CQGCustomStudyDefinitions | Represents a collection of CQGCustomStudy objects.
CQGDataSources | Represents a collection of CQGDataSource objects.
CQGDataSourceSymbols | Represents a collection of CQGDataSourceSymbol objects.
CQGDOMOrder | Represents class for managing a DOM order (the one that makes a DOM price volume)
CQGDOMOrders | Represents the collection of CQGDOMOrder
CQGDOMQuotes | Represents a collection of CQGQuote. Each CQGQuote in the collection represents one item of the DOM book. This is the default property.
CQGExchanges | Represents a collection of exchange names.
CQGExecutionPatternParameters | Represents collection of CQGExecutionPatternParameter objects.
CQGExpression | Represents a collection of CQGExpressionOutputs. Is returned by the CQGCEL.RequestExpression method call. The CQGCEL.ExpressionResolved, CQGCEL.ExpressionAdded, and CQGCEL.ExpressionUpdated events can be fired for the CQGExpression.
CQGExpressionOutputHeaders | Represents a collection of String - expression output headers.
CQGExpressionOutputs | Represents a collection of expression outputs.
CQGExpressions | Represents a collection of CQGExpression objects.
CQGFills | Represents a collection of CQGFill objects.
CQGGWTrades | Represents a collection of CQGGWTrade objects.
CQGHolidays | Represents a collection of CQGHoliday objects.
CQGInstrumentProperties | Represents a collection of instrument (dynamic and static) properties.
CQGInstruments | Represents a collection of CQGInstrument objects.
CQGInstrumentsGroups | Represents a collection of CQGInstrumentsGroup objects.
CQGIntegerCollection | Represents a collection of Integers.
CQGManualFills | Represents a collection of CQGManualFill objects
CQGManualFillsCollection | Represents a collection of CQGManualFills objects.
CQGModifiedProperties | Represents a collection of CQGModifiedProperty objects.
CQGOrderProperties | Represents a collection of order (dynamic and static) properties represented as CQGOrderProperty objects.
CQGOrders | Represents a collection of CQGOrder objects.
CQGOrdersRequest | Represents parameters for orders request
CQGParameterDefinitions | Represents a collection of CQGParameterDefinition objects.
CQGPointAndFigureBars | Represents a collection of CQGPointAndFigureBar objects.
CQGPointAndFigureBarsCollection | Represents a collection of CQGPointAndFigureBars objects.
CQGPositions | Represents a collection of CQGPosition objects.
CQGQFormulaDefinitions | Represents a collection of CQGQFormulaDefinition objects.
CQGQuotes | Represents a collection of CQGQuote objects.
CQGRangeBars | Represents a collection of CQGRangeBar
CQGRangeBarsCollection | Represents a collection of CQGRangeBars
CQGRenkoBars | Represents a collection of CQGRenkoBar
CQGRenkoBarsCollection | Represents a collection of CQGRenkoBars
CQGSessions | Represents a collection of CQGSession objects.
CQGSessionsCollection | Represents a collection of CQGSessions objects.
CQGStrategyDefinitions | Represents a collection of CQGStrategyDefinition objects.
CQGStrategyLegFills | Represents a collection of CQGStrategyLegFill for a strategy order.
CQGStrategyQuoteRequest | Represents a request for quotes (RFQ)
CQGStringCollection | Represents a collection of strings.
CQGSubMinuteBars | Represents a collection of CQGSubMinuteBar objects.
CQGSubMinuteBarsCollection | Represents a collection of CQGSubMinuteBars objects.
CQGTFlowBars | Represents a collection of CQGTFlowBar objects. Is returned by the CQGCEL.RequestTFlows method call.
CQGTFlowBarsCollection | Represents a collection of CQGTFlowBars objects.
CQGTicks | Represents a collection of CQGTick objects.
CQGTicksCollection | Represents a collection of CQGTicks objects.
CQGTimedBars | Represents a collection of CQGTimedBar objects.
CQGTimedBarsCollection | Represents a collection of CQGTimedBars objects.
CQGTradeEntries | Represents a collection of CQGTradeEntry objects.
CQGTradeExitDefinitions | Represents a collection of CQGTradeExitDefinition objects.
CQGTradeExits | Represents a collection of CQGTradeExit objects.
CQGTrades | Represents a collection of CQGTrade objects.
CQGTradingSystemBaseBarParameters | Represents a collection of CQGTradingSystemBaseBarParameter objects.
CQGTradingSystemDefinitions | Represents a collection of CQGTradingSystemDefinition objects.
CQGTradingSystems | Represents a collection of CQGTradingSystem objects.
CQGTradingSystemStatisticsCollection | Represents a collection of CQGTradingSystemStatistics.
CQGTradingSystemTradeDefinitions | Represents a collection of CQGTradingSystemTradeDefinition objects.
CQGTradingSystemTradesRow | Represents a collection of CQGTradingSystemTrade objects.
CQGTradingSystemTradesRows | Represents a collection of CQGTradingSystemTrade objects.
CQGTransactions | Represents a collection of CQGTransaction objects.
CQGYields | Represents a collection of CQGYield objects.
CQGYieldsCollection | Represents a collection of CQGYields objects.

Interfaces

Class Module | Description
CQGAccount | The CQGAccount interface encapsulates all of the information on a trading account along with its positions data.
CQGAccountSummary | The CQGAccountSummary interface represents statistical information calculated basing on account's positions. Each summary is calculated in a single currency.
CQGAdvancedStudyDefinition | Represents a definition of advanced study
CQGAdvancedStudyRequest | Represents parameters for advanced study request
CQGAlgorithmicOrderDefinition | Represents a definition of a algorithmic order property.
CQGAlgorithmicOrderParameters | Represents parameters of the algorithmic order. For a list of all members defined in this module, see CQGAlgorithmicOrderParameters members.
CQGAlgorithmicOrderProperty | Represents an algorithmic order property.
CQGAPIConfig | Gets/sets the value of a specified property. This is a default getter property. Defined various CQGAPIConfig options and parameter items. The CQGAPIConfig interface controls the behavior of CQG API.
CQGBracketOrder | Represents a class describing a bracket order.
CQGBracketOrderLeg | Represents a collection of bracket leg properties
CQGCEL | The CQGCEL encapsulates the main functionality of the CQG API. This is the central interface an object of which should be created by the user in order to use the CQG API features.
CQGChangedTradeEntry | This class contains trading system trade entry change information.
CQGChangedTradeExit | This class contains trading system trade exit change information.
CQGConditionDefinition | Represents a definition of condition.
CQGConditionRequest | Represents parameters used to formulate a condition request.
CQGConditionResult | Represents a condition result.
CQGConstantVolumeBar | Represents a single constant volume bar.
CQGConstantVolumeBarsRequest | Represents parameters used to formulate a constant volume bars request.
CQGCurrencyRate | The CQGCurrencyRate interface encapsulates the currency rate information for two specific currencies.
CQGCurveDefinition | Represents a definition of the curve.
CQGCustomStudyDefinition | Represents a definition of a custom study.
CQGCustomStudyRequest | Represents parameters used to formulate a custom study request.
CQGDataSource | Represents a data source.
CQGDataSourceSymbol | Represents a data source symbol.
CQGDirectEventsAccessor | This class is used to raise non-dispatch events to the API user. The API user should implement the corresponding interface and advise to this object to receive vtbl events.
CQGEnvironment | The CQGEnvironment is an informational interface, which stores the CQG API environment information. The CQGEnvironment includes information on versions, connection statuses, current times (on PC and on Exchange), internal status of CQGCEL, etc.
CQGError | The CQGError interface encapsulates the possible errors which may arise in CQG API.
CQGExecutionPattern | Represents a strategy execution pattern for a strategy order and its legs.
CQGExecutionPatternParameter | Represents a strategy execution pattern parameter.
CQGExpressionRequest | Represents parameters used to formulate an expression request.
CQGFill | The CQGFill interface encapsulates all the information on a fill.
CQGGWConnectionRequest | Represents parameters for gateway connection request
CQGGWTrade | Represents a class responsible for holding single trade's info
CQGHistoricalSessionsRequest | Represents parameters for historical sessions request.
CQGHoliday | Represents a single holiday of a session.
CQGInstrument | The CQGInstrument interface encapsulates all of the information on a trading instrument along with the corresponding functionality.
CQGInstrumentProperty | Implements an interface to manage the instrument's dynamic and static properties.
CQGInstrumentsGroup | Represents a group of instruments resolved using CQGInstrumentsGroupRequest.
CQGInstrumentsGroupRequest | Represents parameters used to formulate a request for a group of instruments.
CQGInstrumentSubscriptionRequest | Represents parameters used to formulate an instrument subscription request.
CQGLogger | This class provides logging functionality in CQG API.
CQGManualFill | Represents a manual fill.
CQGManualFillRequest | Represents parameters used to formulate a manual fill request.
CQGModifiedProperty | Represents a single modified order property.
CQGOrder | This class encapsulates the trading order notion.
CQGOrderActionRequest | Defines the interface of ICQGOrderActionRequest
CQGOrderChain | Represents a definition of order chain, which is used to place and modify compound orders of OCO type.
CQGOrderConstructor | The class constructs an order by properties set
CQGOrderModify | The CQGOrderModify is an object the user needs to create in order to specify order modification parameters.
CQGOrderProperty | Encapsulates information on an order property.
CQGOrdersQuery | Encapsulates the historical order query functionality.
CQGParameterDefinition | Represents a definition of user formula parameter.
CQGPointAndFigureBar | Represents a single point and figure bar.
CQGPointAndFigureBarsRequest | Represents parameters used to formulate a point and figure bars request.
CQGPosition | The CQGPosition interface encapsulates all the information on a position.
CQGPositionsStatement | Represents a class for managing positions statement.
CQGQFormulaDefinition | Represents a definition of QFormula.
CQGQuote | This class allows the user to manage instrument quotes.
CQGRangeBar | Represents class for a range bar
CQGRangeBarsRequest | Represents parameters for range bars request
CQGRemoteOpenAPISession | CQGRemoteOpenAPISession keeps properties connected with the remote Open API session
CQGRenkoBar | Represents class for a renko bar
CQGRenkoBarsRequest | Represents parameters for renko bars request
CQGSession | Represents information about an instrument's sessions or a custom session.
CQGStrategyDefinition | Represents a strategy definition.
CQGStrategyLegFill | Represents a leg fill for a strategy order.
CQGSubMinuteBar | Represents a single sub minute bar
CQGSubMinuteBarsRequest | Represents parameters for sub minute bars request
CQGSummariesStatement | Represents a class for managing summaries statement.
CQGTFlowBar | Represents a single TFlow bar.
CQGTFlowBarsRequest | Represents parameters used to formulate a TFlow bars request.
CQGTick | Represents a single tick.
CQGTicksRequest | Represents parameters used to formulate a ticks request.
CQGTimedBar | Represents a single timed bar.
CQGTimedBarsRequest | Represents parameters used to formulate a timed bars request.
CQGTrade | The CQGTrade interface encapsulates all the information on a trade.
CQGTradeEntry | Represents a trade entry.
CQGTradeEntryDefinition | Represents a definition of the trade entry.
CQGTradeExit | Represents a trade exit.
CQGTradeExitDefinition | Represents a definition of the trade exit.
CQGTradingSystem | Represents a trading system. Is returned by the CQGCEL.RequestTradingSystem method call.
CQGTradingSystemAddInfo | This interface is reserved for future use.
CQGTradingSystemBaseBarParameter | Represents a trading system base bar parameter.
CQGTradingSystemDefinition | Represents a definition of trading system.
CQGTradingSystemInsertInfo | Represents a definition of trading system.
CQGTradingSystemRelationAddInfo | This class contains information about the added relation between an entry and exit within the trading system.
CQGTradingSystemRemoveInfo | This class contains information about the updates made to the trading system. It is used by the CQGCEL.TradingSystemUpdateNotification event.
CQGTradingSystemRequest | Represents parameters used to formulate a trading system request.
CQGTradingSystemStatistics | Represents trading system statistics.
CQGTradingSystemStatisticsChangeInfo | This class contains information about the statistics change for a trading system.
CQGTradingSystemTrade | Represents a single trade of the trading system.
CQGTradingSystemTradeDefinition | Represents a definition of the trading system single trade.
CQGTradingSystemUpdateInfo | This class contains information about the updates made to the trading system. It is used by the CQGCEL.TradingSystemUpdateNotification event.
CQGTransaction | Represents a single order transaction
CQGYield | Represents class for a yield
CQGYieldsRequest | Represents parameters for yields request

Public Enumerations

Enumeration | Description
eAccountChangeType | Specifies the type of account/position change passed to the AccountChanged event.
eAccountMarginDetailing | Defines level of account margin info detailing
eAccountSubscriptionLevel | Specifies event subscription levels for accounts.
eAlgorithmicOrderPropertyType | Indicates the algorithmic order property type.
eBrickUnit | Specifies Renko 'Brick Unit' property value
eChangeType | Specifies the possible type of order change, passed as an argument to OrderChanged event.
ECompoundOrderType | Represends compound order type.
eConnectionStatus | Indicates the connection status of CQG data server or CQG gateway.
eCvbVolumeType | Indicates the constant volume bars' volume type.
eDailyBarClose | Specifies a daily bar close setting value that the system should use to calculate close
eDataSourceStatus | Indicates the data source status.
eDataSubscriptionLevel | Specifies the data subscription level for a CQGInstrument.
eDelayMode | Specifies an instrument's delay mode
eDOMandBBAType | Indicates DOM and BBA type.
eDOMUpdatesMode | Represents possible modes of DOM data updates. All modes depend on the value of the update period, which is set from configuration.
EExchangeState | Enumerates possible exchange states.
eExecutionPatternParameterType | Indicates execution pattern parameter types.
EExtendedSide | Specifies special/extended order side.
eFcmClass | Specifies the FCM class.
eFillEffect | Specifies whether the fill is opening/increasing or closing/reducing a position
eFillStatus | Represents possible statuses of the order.
eGapFilter | Defines gap filter of sub minute bars request
EGroupPropertySubscriptionLevel | Specifies the CQGInstrumentsGroupRequest.PropertyLevel value.
eGroupSubscriptionLevel | Indicates the subscription levels for instruments group.
eGWEnvChangeCode | Defines the CQG Gateway environment change types.
eHistoricalPeriod | Indicates historical periods.
eHistoricalSessionsRequestType | Indicates the request type of historical sessions.
eICConnectionStatus | Indicates the status of the CQGIC connection.
eInstrumentProperty | Defines all possible instrument properties.
eInstrumentType | Defines instrument type representations as bitmasks. Used in CQGCEL.RequestCommodityInstruments and CQGDataSourceSymbols.Type.
eLogSeverity | Specifies logging severity.
eManualFillsDataLevel | Specifies data subscription levels for manual fills.
eManualFillUpdateType | Specifies the manual fill's update type.
eMarketState | Indicates the market state (fast or not).
eNoGapRemoveFrom | Specifies No Gap 'Remove From' property value
eOpenCloseInstruction | Specifies whether the order is opening/increasing or closing/reducing a position
eOrderCancelationType | Specifies the order cancellation instruction type.
eOrderDuration | Specifies the possible durations of an order.
eOrderEvent | Specifies the possible order event (transaction) types received via OrderChanged event.
eOrderExecutionInstruction | Defines order execution instructions
eOrderLocalState | Defines local states of the order. 'Local' here means from CQG API point of view.
eOrderProperty | Specifies all possible and acceptable properties of an order.
eOrderSide | Identifies the order side notion in terms of buy and sell.
eOrderSideFilter | Specifies the orders side filter.
eOrderStatus | Defines the CQG Gateway statuses of the order.
eOrderStatusFilter | Specifies the order's CQGOrder.GWStatus filter's possible values, available for CQGCEL.QueryOrders method calls.
eOrderTrailingPeg | Order trailing peg, which defines user's preference for trailing after the market.
eOrderType | Specifies the available order types.
ePfBoxUnits | Indicates the point and figure box units.
ePfDataSource | Indicates the point and figure bar data source.
EPositionDay | Current/Previous day position for instruments with explicit position tracking type
ePositionDetailing | Defines the level of position information detailing.
ePositionSubscriptionLevel | Specifies the update subscription levels for an account's positions.
EPositionTrackingType | Position tracking type
ePriceMode | Specifies the available price modes for accounts and positions.
ePropertySubscriptionLevel | Specifies the property subscription level for CQGInstrument.
eQuoteSubscriptionLevel | Specifies the quote subscription level for CQGInstrument.
eQuoteType | Specifies all possible quote types.
eRangeUnit | Specifies Range 'Range Unit' property value
eReadyStatus | Indicates if the host application (MS Excel) is ready to handle events.
eReadyStatusCheck | Turns on/off the application's ready status checking.
eRequestStatus | Request status, used in orders query and historical requests.
eSessionFlag | Indicates session flag.
eSessionStatus | Used to specify remote Open API session status
eSessionWeekDays | Indicates the session working days.
eSpeculationType | Specifies order speculation type
EStartPoint | Start Point study parameter values for Range Bars.
eStrategyRequestStatus | Indicated the status of the Gateway strategy definition request.
eSymbolSessionType | Indicates the instrument session type.
eSymbolType | Indicates the symbol type.
eTfAggregation | Indicates the TFlow bar aggregation.
eTFlowRequestDomVolumeLevel | Specifies the level of DOM volume in TFlowBarsRequest.
eTickCorrectionType | Indicates the tick correction type.
eTickFilter | Specifies which ticks are being requested.
eTickPriceType | Indicates the tick price type.
eTicksRequestType | Indicates the request type of ticks.
eTimedBarsRequestOutputs | Specifies the outputs for timed bars request.
eTimeSeriesContinuationType | Indicates the time series continuation type.
eTimeSeriesSubscriptionLevel | Indicates the time series subscription level.
eTimeZone | Specifies all available time zones.
eTradeChangeCategory | Indicates the trading system trade change category.
eTradeSide | Indicates the trading system trade side.
eTradingSystemBaseBar | Specifies the trading system base bar type.
eTradingSystemBaseBarParameter | Specifies the Trading System base bar parameters.
eTradingSystemCommissionType | Indicates the type of the commission calculation used in the Trading System.
eTradingSystemStatistic | Indicates the trading system statistics.
eUserFormulaParameterType | Indicates the user formula parameter type.
eYieldCompound | Indicates the yield compound
eYieldModel | Indicates the yield model

Public UDTs

UDT | Description
CQGCELConfiguration | Defines various CQGCEL configuration options and parameters. Deprecated!


$$GETTING_STARTED$$ - %%projecttitle%%

Getting Started
Send Feedback

Glossary Item Box

This help document is the essential reference for developers who use CQG API functionality, and it is the exclusive source of CQG API product documentation.

It shows how to work with CQG API and helps you easily find the information you need.

The CQG API component help is a tool that you can use to display, search, and filter information based on your development needs.

The help is divided into the following parts:

Introduction

Contains basic information about CQG API.

Overview

Enlists the classes and enumerations available in CQG API.

Requirements

System and subscription requirements needed for CQG API development and usage.

Change Log

Enlists product changes in reverse chronological order.

Quick-Start Guide

Contains step-by-step guides to help you get started and do common CQG API tasks.

Usage Diagram

Illustrates the CQG API usage organization from a user application.

What's New?

Lists the new concepts added to CQG API in the current version.

Common Concepts

Provides common programming concepts for CQG API.

Interfaces

Represents the interfaces available in CQG API.

Collections

Represents the collections available in CQG API.

Structures

Represents the user-defined data types (structures) used in CQG API.

Enumerations

Represents the enumerations used in CQG API.

Samples Catalog

Describes the downloadable samples in a few common programming languages that cover many CQG API functionalities.

FAQ

Frequently asked questions by CQG API users.

Glossary

Describes financial terms for the non-trader.

Do you want to start working with CQG API right away? Refer to the Example section of CQGCEL.


%%ItemTitle%%

CQG API Documentation 4.0 - Revised
Requirements
Send Feedback

Glossary Item Box

CQG API is available to CQGNet Professional package subscribers.

The customer must have the corresponding API enablements turned on in order to be able to use the API.

Each enablement has an additional cost, having effect after the trial period, if any.

Using the CQG API requires the user to be logged into CQG Integrated Client. Note that the user application should be running on the same machine as the CQGIC.

Certain features of CQG API require the user to be logged into CQG Gateway as well.

The user code must be written in a programming language that supports automation technology, for example: C++, Visual Basic, VBA, .NET languages, Python.

System Requirements:

See at http://www.cqg.com/support/system-specifications


%%ItemTitle%%

CQG API Documentation 4.0 - Revised
CQG API 32-bit and 64-bit versions
Send Feedback

Glossary Item Box

CQG API is available as 32-bit and 64-bit COM server.

How to specify the version you want to use in the client code?

In most cases there is no special work is required. The COM will try to match CQG API server architecture to the client architecture. In other words, for a 32-bit client, COM will activate 32-bit version CQG API server; otherwise it will activate a 64-bit version of the server. Therefore, if the client code should use CQG API 64-bit version it should be built for x64 (Any CPU) platform.

Samples of CQG API 32-bit and 64-bit versions usage in the client code can be found on API web page.


%%ItemTitle%%

CQG API Documentation 4.0 - Revised
Frequently Asked Questions
Send Feedback

Glossary Item Box

  1. What model is used in CQG API?

    CQG API has asynchronous nature - i.e., when the user requests some information by calling a method, the requested information is not yet available upon the method’s return. When the requested information becomes available, a corresponding event is fired, which the user application shall catch to receive the requested information.

  2. Why CQG API is asynchronous?

    CQG API triggers information retrieval, which means that some time is needed to collect it.

    If it was synchronous, all calls to CQG API would be hanging until corresponding information was retrieved.

  3. Do I need to use a message loop in my application?

    Since CQG API's nature is asynchronous, you need to use message loop to prevent your application from ending.

  4. Does CQG API 64-bit version exist?
    See CQG API 32-bit and 64-bit versions topic.

  5. Is CQG API thread safe?
    No, it is not. It means that the calling of CQG API methods from different threads without synchronization can lead to undefined behavior.

  6. Why do I need to handle the DataError event?

    During request processing, errors might occur and the client-side is notified about them with the DataError event. This will have valuable information in many unpredictable situations, such as "CQGIC is not started".

  7. Is it enough to handle the DataError event only? Do I need additional error handling in my code?

    Some of the errors are reported synchronously and COM exceptions are thrown in such cases, which might be caught using error handlers.

  8. Why some events are received with additional parameter of CQGError type?

    If the returned data is somehow incomplete or some error has occurred during the request, the accompanying CQGError will describe what is wrong with it.

  9. I can’t find some order properties in the CQGOrder interface.

    The properties in the CQGOrder interface are limited to the most common and frequently used ones.
    You can access the rest of the available order properties from CQGOrder.CQGOrderProperties collection using the eOrderProperty enumeration as a key.

    Please note that some properties do not apply to all order types. For example, a market order does not have limit price.

  10. Why no CELStarted or DataError events are fired after creating CQGCEL object and calling its StartUp method?

    If you are using CQG API from MS Excel, you need to handle the CQGCEL.IsReady event and pass your current status (which can be obtained through Application.Ready property) to its readyStatus parameter.

    If you are using CQG API not from MS Excel, you need to:

    1. either handle the CQGCEL.IsReady event and pass the eReadyStatus.rsReady to its readyStatus parameter,
    2. or set the CQGCEL.CQGAPIConfig.ReadyStatusCheck property to eReadyStatusCheck.rscOff.
  11. Why I do not get DOM events?

    The default setting for CQGCEL.CQGAPIConfig.DefaultInstrumentSubscriptionLevel is eDataSubscriptionLevel.dsQuotesAndBBA. This means that DOM data will not be fetched by default. If you want to receive DOM values, you need to:

    1. either after subscription, change the CQGInstrument.DataSubscriptionLevel to eDataSubscriptionLevel.dsQuotesAndDOM
    2. or set the CQGCEL.CQGAPIConfig.DefaultInstrumentSubscriptionLevel property to eDataSubscriptionLevel.dsQuotesAndDOM before calling the CQGCEL.StartUp method.
  12. A DataError is received or a COM Error is thrown with the following description:
    "You are not enabled for retrieving data via CQG API. To enable this feature, please call CQG Customer Support."     What should I do?

    You are trying to use some features of CQG API, which require enablements you currently lack. Please find more information about the enablements in the Quick-Guide section of this document. Then contact the API Support to subscribe to the needed enablements.

  13. Why should I handle the CQGCEL.DataConnectionStatusChanged and CQGCEL.GWConnectionStatusChanged events?

    While you are working with CQG API, you need to monitor the data and gateway connection statuses. In order to work properly, CQG API functionalities require that the corresponding connection is up.

    For example,

    1. to subscribe and retrieve market data for an instrument data connection must be up, which can be monitored by handling the CQGCEL.DataConnectionStatusChanged event.
    2. to place an order and monitor its status or get account status information, you should check the gateway connection to be up by handling the CQGCEL.GWConnectionStatusChanged event.
  14. How can I pass Date values to CQGCEL methods' Variant arguments from Matlab?

    When you need to pass a VT_DATE type input to an ActiveX control method, you can use the MATLAB class COM.date.
    For example:

    d = COM.date(2007,12,21,15,30,05);

    You can use now to set the Value property to a date number:

    d.Value = now;

  15. How many CQGCEL instances can be run simultaneously?

    The maximum number of CQGCEL instances to run simultaneously is limited to ten. When this number is exceeded, the error with code 196 is reported via CQGCEL.DataError event with the following message:

    Cannot start API instance: maximum number of instances is exceeded.

  16. Why does the API memory footprint continuously increase when Ticks are requested with "Current Notify"?

    When you perform a Ticks request with its type set to trtCurrentNotify, all tick updates will be received and added to the already received ticks. (Those ticks can be accessed through CQGCEL.AllTicks.) In the meantime, data being received occupies more and more memory.

    The received ticks collection size can be limited with CQGTicksRequest.Limit property.

    Also, you may consider subscribing to an instrument to receive its real-time data, instead.

  17. Why do I receive extra records when I combine multiple sub expressions in my historical request?

    When you combine sub expressions that have some timescale deviation in one request, up to double the requested number of records may be returned, depending on the coincidence of their timestamps.

    Example:

    For a historical request formulated as following:

    SubExpression1 = Open(DD)

    SubExpression2 = CVLow(DD)

    RangeEnd = -5

    Intraday

    1 min

    The returned records may look like the following:

    Returned record | Timestamp | Open(DD) | CVLow(DD)
    1 | 10:01 | 4708 | 4706
    2 | 10:01 | 4706
    3 | 10:02 | 4706 | 4705
    4 | 10:02 | 4706
    5 | 10:03 | 4707
    6 | 10:04 | 4708 | 4707
    7 | 10:05 | 4707

    Here, you need to take into account that the RangeEnd specification has a different meaning for each of the sub expressions as following:

    • For the Open(DD), RangeEnd = -5 means the last five one-minute bars’ Open values will be returned;
    • And for the CVLow(DD), RangeEnd = -5 means the last five constant volume bars’ Low values will be returned.

    Note also, that each sub expression’s total number of returned records is five.

  18. CEL memory usage is growing by time. Is it a memory leak?

    CEL is a single-thread process. It keeps an events queue list and waits for the user application to process an event before it delivers the next one on list. In a scenario where the user application is delaying the processing of events, the queue may get really long—consuming a lot of memory.

    Solution: The event handler should be designed to be as efficient as possible. While for simple procedures (e.g., API samples) it is fine to combine some secondary tasks in the event handler, powerful applications should be designed so that event handling is separated from other functions.

    If you have already made sure that your application’s event handler is not the bottle neck, please report your problem to API Support for further investigation.

  19. There are requests that allow defining time interval for data receiving. For example, CQGTimedBarsRequest, CQGRenkoBarsRequest, etc.
    How to request data from specific time in the past to current time with future updates?

    You should set the following properties:

    • RangeStart property to specific time in the past;
    • RangeEnd to any time in future (for example, 1/1/2100);
    • IncludeEnd to True;
    • UpdatesEnabled to True.

    With these request settings, new bars will be received and updated.

  20. Why CQG IC is shut down automatically if it is connected to some exchanges?

    Some FCMs may enforce session timeout based on a designated period of inactivity for client applications.
    For more information regarding the relevant regulations, please see Guidelines for Reducing and Mitigating Hacking Risks Associated with Internet Trading.

  21. Is there any way to cancel requests? For example, CQGTimedBarsRequest, CQGTicksRequest , etc.

    Yes, there is Remove family methods that cancel corresponded requests. For example, RemoveTimedBars, RemoveTicks, etc.

  22. How to login to GW with a demo account?

    Use CQGCEL.GWLogon method with the following argument values: username_ = "DEMO" and password_ = "DEMO".

  23. I want to place orders, but I can't subscribe to instrument because I don't have real-time data, what should I do?
    Use APIConfiguration.NewInstrumentMode and CQGCEL.CreateInstrumentRequest method to subscribe to instrument.


%%ItemTitle%%

CQG API Documentation 4.0 - Revised
Glossary
Send Feedback

Glossary Item Box

This glossary is intended to be used by software developers who are unfamiliar with trading concepts.

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

American Options -
Options which can be exercised at any time prior to expiration.

Annual Charts -
See Yearly Charts.

Ask -
An expression indicating one's desire to sell a commodity at a given price, opposite of bid.

At-The-Money Strike -
The strike price which is closest to the underlying price.

Available Data -
Each contract or issue has intraday data and may also have historical data and/or options data.

To Top

Back-Testing –
A strategy is tested or optimized on historical data and then the strategy is applied to new data to see if the results are consistent.

Bar Average -
The Bar Average can be used in the evaluation of technical analyses. The Bar Average is the (High - Low - Close)/3.

Bar Charts -
Bar Charts are constructed of the Opening, Highest, Lowest, and Closing price that occurred during the Time Interval of the bar.

For Example, on a 30-Minute Bar Chart:

  • The Opening Price for a given 30-minute time interval appears as a dash on the left side of a bar.
  • The Highest Price reached during the 30-minute interval appears as the top of the bar.
  • The Lowest Price reached during the 30-minute interval appears as the bottom of the bar.
  • The Last Price or Closing Price at the end of the 30-minute interval appears as a dash on the right side of the bar.

Bid –
An expression indicating a desire to buy a commodity at a given price, opposite of ask.

Bid and Ask Prices –
Highest price and lowest price that an investor will pay for a tradable.

Black Box –
A proprietary, computerized trading system whose rules are not disclosed or readily accessible.

Bonds –
A long-term debt security with a stated interest rate and fixed due dates, issued by a corporation or a government, when interest and principal must be paid. There are many variations.

Broker –
A company or individual that executes futures and options orders on behalf of financial and commercial institutions and/or the general public.

Brokerage Fee –
A fee charged by a broker for executing a transaction.

Butterfly Spread –
The placing of two interdelivery spreads in opposite directions with the center delivery month common to both spreads.
To Top

Calendar Spread –
The purchase of one delivery month of a given futures contract and simultaneous sale of another delivery month of the same commodity on the same exchange. The purchase of either a call or put option and the simultaneous sale of the same type of option with typically the same strike price but with a different expiration month. Also referred to as a horizontal spread.

Call Option –
An option that gives the buyer the right, but not the obligation, to purchase (go "long") the underlying futures contract at the strike price on or before the expiration date.

Canceling Order –
An order that deletes a customer's previous order.

Candlestick Charts -
Candlestick charts are based on a Japanese charting method. Candlestick charts use the same data points as bar charts for each time interval. The difference lies in the way the data is represented.

The thick part of the Candlestick line is called the real body. It represents the range between that bar's opening price and closing price. An Up Candlestick occurs when the close is higher than the open; a Down Candlestick occurs when the close is lower than the open.

The thin lines above and/or below the real body are the shadows. These shadows represent the bar's price extremes. The peak of the upper shadow is the high of the bar and the bottom of the lower shadow is the low of the bar.

The real body is the essential price movement. The shadows are usually considered as extraneous price fluctuations. For additional information see Available Candlestick Formations.

Cash Commodity –
An actual physical commodity someone is buying or selling; e.g., wheat, gold, treasury bonds, etc.

Cash Contract –
A sales agreement for either immediate or future delivery of the actual product.

Charting –
The use of charts to analyze market behavior and anticipate future price movements. Those who use charting as a trading method plot such factors as high, low, and settlement prices, average price movements, volume, and open interest. Two basic price charts are bar charts and point-and-figure charts. Anticipating future price movement using historical prices, trading volume, open interest and other trading data to study price patterns.

Close -
The Daily Close is the official daily settlement from the exchange. The exchange clearinghouse determines a firm's net gains or losses, margin requirements, and the next day's price limits, based on each futures and options contract settlement price. If there is a closing range of prices, the settlement price is determined by averaging those prices. Also referred to as settle price.

The Bar Close is the last price trade at the end of each time interval.

Closed Trades –
Positions that have been either liquidated or offset.

Closing Range –
A range of prices at which buy and sell transactions took place during the market close.

Commission Fee –
A fee charged by a broker for executing a transaction. Also referred to as brokerage fee.

Continuation Charts -
Continuation Charts contain data for more than one contract. They follow the current lead contract through expiration, then follow the new lead contract.

Contract Month –
A specific month in which delivery may take place under the terms of a futures contract.

Contract Specific Charts -
Contract Specific Charts contain data for only one contract. They display price data for just the specified contract through expiration.

CQG API -
CQG’s Open API is an Application Programming Interface, which enables exporting CQG market data and analytics to external applications. It is a COM in-proc server, which provides object-oriented programming model usable from various programming languages.

CQG Symbols -
Each future or option contract, as well as each stock issue on the system, has a unique symbol. The foundation of these unique symbols is displayed in the CQG Symbols List.
CQG has established these symbols to represent each issue traded at the various international exchanges. When possible CQG symbols correspond to those used by the individual exchanges. However, exchange symbols may conflict with symbols and data formats used by other exchanges. When this occurs, alternative CQG symbols are used.

Crush Spread –
The purchase of soybean futures and the simultaneous sale of soybean oil and meal futures.

Customer Margin –
Within the futures industry, financial guarantees required of both buyers and sellers of futures contracts and sellers of options contracts to ensure fulfilling of contract obligations. FCMs are responsible for overseeing customer margin accounts. Margins are determined on the basis of market risk and contract value. Also referred to as performance-bond margin. Financial safeguards to ensure that clearing members (usually companies or corporations) perform on their customers' open futures and options contracts. Clearing margins are distinct from customer margins that individual buyers and sellers of futures and options contracts are required to deposit with brokers.
To Top

Daily Charts -
The term "daily" is used to describe those charts that are constructed of Daily Bars. Each Daily Bar contains the Open, High, Low, and Close that occurred during each trading day.

Daily Trading Limit –
The maximum price range set by the exchange cash day for a contract.

Day Traders –
Speculators who take positions in futures or options contracts and liquidate them prior to the close of the same trading day.

Delivery –
The transfer of the cash commodity from the seller of a futures contract to the buyer of a futures contract. Each futures exchange has specific procedures for delivery of a cash commodity. Some futures contracts, such as stock index contracts, are cash settled.

Delivery Day –
The day, when the buyer's clearing firm presents the delivery notice with a certified check for the amount due at the office of the seller's clearing firm.

Delivery Month –
A specific month in which delivery may take place under the terms of a futures contract. Also referred to as contract month.

Delta –
A measure of how much an option premium changes, given a unit change in the underlying futures price. Delta often is interpreted as the probability that the option will be in-the-money by expiration.

Demand, Law of –
The relationship between product demand and price.
To Top

Enablements -
Enablements control the services that are available on each CQG system. They include system defaults, exchanges, optional services, and screen allocation information. The enablements for each system are determined by the agreements made with your CQG marketing representative.

Equilibrium Price –
The market price at which the quantity supplied of a commodity equals the quantity demanded.

Eurodollars –
U.S. dollars on deposit with a bank outside of the United States and, consequently, outside the jurisdiction of the United States. The bank could be either a foreign bank or a subsidiary of a U.S. bank.

European Options -
Options which may only be exercised at expiration.

Exchanges -
The term Exchanges refers to the Exchanges and Data Contributors that are available on each system. A list of the currently available exchanges can be found by selecting Exchanges and Data Contributors in the CQG Symbols List.

Exercise –
The action taken by the holder of a call option if he wishes to purchase the underlying futures contract or by the holder of a put option if he wishes to sell the underlying futures contract.

Expiration -
The date and time after which an option may no longer be exercised.

Exercise Price –
The price at which the futures contract underlying a call or put option can be purchased (if a call) or sold (if a put). Also referred to as strike price.

Expiration Date –
Options on futures generally expire on a specific date during the month preceding the futures contract delivery month. For example, an option on a March futures contract expires in February but is referred to as a March option because its exercise would result in a March futures contract position.

Extrinsic Value –
The amount of money option buyer are willing to pay for an option in the anticipation that, over time, a change in the underlying futures price will cause the option to increase in value. In general, an option premium is the sum of time value and intrinsic value. Any amount by which an option premium exceeds the option's intrinsic value can be considered time value. Also referred to as time value.
To Top

Fill-or-Kill (FOK) –
A customer order that is a price limit order that must be filled immediately and completely or be canceled.

Fill-and-Kill (FAK) –
A customer order that is a price limit order that must be filled immediately and then canceled. This type allows partial fills.

Financial Instrument –
There are two basic types:

  1. a debt instrument, which is a loan with an agreement to pay back funds with interest;
  2. an equity security, which is share or stock in a company.

FOREX Market –
An over-the-counter market where buyers and sellers conduct foreign exchange business by telephone and other means of communication. Also referred to as foreign exchange market.

Fundamental Analysis –
A method of anticipating future price movement using supply and demand information.

Futures Commission Merchant (FCM) –
An individual or organization that solicits or accepts orders to buy or sell futures contracts or options on futures and accepts money or other assets from customers to support such orders. Also referred to as "commission house" or "wire house".

Futures Contract –
A legally binding agreement, made on the trading floor of a futures exchange, to buy or sell a commodity or financial instrument sometime in the future. Futures contracts are standardized according to the quality, quantity, and delivery time and location for each commodity. The only variable is price, which is discovered on an exchange trading floor.

Futures Exchange –
A central marketplace with established rules and regulations where buyers and sellers meet to trade futures and options on futures contracts.
To Top

GLOBEX –
A global after-hours electronic trading system.
To Top

Hedger –
An individual or company owning or planning to own a cash commodity, corn, soybeans, wheat, U.S. Treasury bonds, notes, bills etc. and concerned that the cost of the commodity may change before either buying or selling it in the cash market. A hedger achieves protection against changing cash prices by purchasing (selling)futures contracts of the same or similar commodity and later offsetting that position by selling (purchasing) futures contracts of the same quantity and type as the initial transaction.

Hedging –
The practice of offsetting the price risk inherent in any cash market position by taking an equal but opposite position in the futures market. Hedgers use the futures markets to protect their business from adverse price changes. Selling (Short) Hedge - Selling futures contracts to protect against possible declining prices of commodities that will be sold in the future. At the time the cash commodities are sold, the open futures position is closed by purchasing an equal number and type of futures contracts as those that were initially sold. and Purchasing (Long) Hedge - Buyer futures contracts to protect against a possible price increase of cash commodities that will e purchased in the future. At the time the cash commodities are bought, the open futures position is closed by selling an equal number and type of futures contracts as those that were initially purchased. Also referred to as a buying hedge.

High –
The Daily High is the highest price received during the trading day. It normally reflects the highest price that occurred during all trading sessions for the day.

The Bar High is the highest price received during each time interval. The True High indicates either the current bar's high or the previous bar's close, whichever is higher.

Holder –
The purchaser of either a call or put option. Option buyers receive the right, but not the obligation, to assume a futures position. Also referred to as the Option Buyer.
To Top

Implied Volatility -
The volatility level at which the theoretical value calculated by an options pricing model would be the same as the current option price.

Initial Margin –
The amount a futures market participant must deposit into his margin account at the time he places an order to buy or sell a futures contract.

Intercommodity Spread –
The purchase of a given delivery month of one futures market and the simultaneous sale of the same delivery month of a different, but related, futures market.

Interdelivery Spread –
The purchase of one delivery month of a given futures contract and simultaneous sale of another delivery month of the same commodity on the same exchange. Also referred to as an intramarket or calendar spread.

Interest Rate -
Refers the to risk-free interest rate as indicated by the yield on three-month U.S. Treasury securities.

Intermarket Spread –
The sale of a given delivery month of a futures contract on one exchange and the simultaneous purchase of the same delivery month and futures contract on another exchange.

In-The-Money Strike -
An exercise price that has intrinsic value now. For calls, that would include all strikes with less than the underlying price. For puts, it would encompass all strikes with a strike higher than the price of the underlying instrument.

Intraday Charts -
The term Intraday is used to describe those charts that are constructed of less than Daily Bars. These would include 1-minute, 5-minute, 60-minute, etc.

Each Intraday Bar contains the Open, High, Low, and Close by time interval that occurred during each trading day.

Intrinsic Value –
The amount by which an option is in-the-money. An option having intrinsic value. Out-of-the-money options have no intrinsic value.
To Top

Leverage –
The ability to control large dollar amounts of a commodity with a comparatively small amount of capital.

Limit Order –
An order in which the customer sets a limit on the price and/or time of execution.

Limits –
The maximum number of speculative futures contracts one can hold as determined by the Commodity Futures Trading Commission and/or the exchange upon which the contract is traded. Also referred to as trading limit. The maximum advance or decline from the previous day's settlement permitted for a contract in one trading session by the rules of the exchange.

Line Charts –
Line Charts are created by connecting a specified price for each time interval displayed. A typical line chart would display a line that connects the closing price for each time interval.

Liquidate –
Selling (or purchasing) futures contracts of the same delivery month purchased (or sold) during an earlier transaction or making (or taking) delivery of the cash commodity represented by the futures contract. Taking a second futures or options position opposite to the initial or opening position.

Lognormal Distributions of Price -
If prices were "normally" distributed, future prices from the current price would be distributed in the shape of the familiar "bell curve". However, because market prices can never go negative, the distribution curve for future prices is said to be lognormal.

Long –
One who has bought futures contracts or owns a cash commodity.

Low –
The Daily Low is the lowest price traded during the trading day. It normally reflects the lowest price that occurred during all trading sessions for the day.

The Bar Low is the lowest price received during each time interval.

The True Low is the lesser of the current bar's low or the previous bar's close.
To Top

Maintenance –
A set minimum margin (per outstanding futures contract) that a customer must maintain in his margin account.

Margin –
Financial safeguards to ensure that clearing members (usually companies or corporations) perform on their customers' open futures and options contracts. Clearing margins are distinct from customer margins that individual buyers and sellers of futures and options contracts are required to deposit with brokers. Within the futures industry, financial guarantees required of both buyers and sellers of futures contracts and sellers of options contracts to ensure fulfilling of contract obligations. FCMs are responsible for overseeing customer margin accounts. Margins are determined on the basis of market risk and contract value. Also referred to as performance-bond margin.

Margin Call –
A call from a clearinghouse to a clearing member, or from a brokerage firm to a customer, to bring margin deposits up to a required minimum level.

Market Order –
An order to buy or sell a futures contract of a given delivery month to be filled at the best possible price and as soon as possible.

Market Profile -
Market Profile Charts use alphabetical characters to plot the price activity that occurs during each 30-minute time interval (default).

The Market Profile assigns successive letters to each 30-minute time interval. The assigned letter is plotted on the Market Profile chart at each price traded during the 30-minute period. The resulting price distribution, and distributions for other trading days can be analyzed to determine market strength and weakness. For additional information, see the Market Profile Window in the Tutorial Advisor.

Midpoint -
The midpoint of a bar can be used in the evaluation of technical analysis studies. The midpoint is the { (High - Low) / 2 }.

Month Codes
The following codes are used to identify the individual contract months, cash, and spot contracts that are available on the system:

F | January | N | July | C | Cash
G | February | Q | August | X | Spot
H | March | U | September | ? | Lead Month
J | April | V | October | ?1 | Next Month
K | May | X | November | ?2 | Second Month, etc.
M | June | Z | December |  |

Ex: USZ06 indicates -

US = U.S. Treasury Bond (Chicago Board of Trade), Z = December, and 06 = 2006

Ex: US? indicates -

US = U.S. Treasury Bond (Chicago Board of Trade), ? = Lead Month Contract

Using the ? with a symbol eliminates the need to update chart and quote setups each time a contract expires. The system automatically displays the lead contract.

Monthly Charts
The term monthly is used to describe charts that are constructed of monthly bars.

Each monthly bar contains the Open, High, Low, and Close that occurred during each trading day.

Moving-Average Charts –
A statistical price analysis method of recognizing different price trends. A moving average is calculated by adding the prices for a predetermined number of days and then dividing by the number of days.
To Top

Non-timed bars –
Refer to bar data where the temporal aspect is not the primary determinant for creating individual bars. Unlike traditional time-based bar charts, constructed based on fixed time intervals, non-timed bars are generated using other criteria such as price range, constant volumes, trade flow, etc. The following requests are considered non-timed: CQGConstantVolumeBarsRequest, CQGRangeBarsRequest, CQGRenkoBarsRequest, CQGTFlowBarsRequest, and all non-timed study operators available via CQGAdvancedStudyRequest, CQGCustomStudyRequest, and CQGExpressionRequest.

Number of Iterations -
The number of times a calculation is performed. Generally, increasing the number of iterations improves the accuracy of a model but increasing the iterations also tends to make the total calculation slower.

Offset –
Taking a second futures or options position opposite to the initial or opening position. Selling (or purchasing) futures contracts of the same delivery month purchased (or sold) during an earlier transaction or making (or taking) delivery of the cash commodity represented by the futures contract.

Open -
The Daily Open is the first price received at the beginning of the first trading session of the trading day.
The Bar Open is the first price received at the beginning of each Time Interval.

Open Interest –
The total number of futures or options contracts of a given commodity that have not yet been offset by an opposite futures or option transaction nor fulfilled by delivery of the commodity or option exercise. Each open transaction has a buyer and a seller, but for calculation of open interest, only one side of the contract is counted.

Option –
A contract that conveys the right, but not the obligation, to buy or sell a particular item at a certain price for a limited time. Only the seller of the option is obligated to perform.

Optional Services -
Optional Services are those services that are available beyond the basic services or system enablements. They include supplemental CQG features and third party services such as news and market commentaries.

Contact your local CQG Sales representative for an explanation of the currently available Optional Services.

Option Class -
All options of the same type, i.e. all calls or all puts, on the same underlying instrument with the same expiration date.

Option Premium –
The price of an option the sum of money that the option buyer pays and the option seller receives for the rights granted by the option.

Option Spread –
The simultaneous purchase and sale of one or more options contracts, futures, and/or cash positions.

Option Type -
The designation of an option as either a call or a put.

Out-Of-The-Money Strike -
A strike that has currently has no intrinsic value. For calls, that would include strikes greater the than the current value of the underlying instrument. For puts, it would include all strikes less than the current value of the underlying.

To Top

Period -
Period usually refers to the number of bars used in the calculation of technical analysis studies.

Pit –
The area on the trading floor where futures and options on futures contracts are bought and sold. Pits are usually raised octagonal platforms with steps descending on the inside that permit buyers and sellers of contracts to see each other.

Point & Figure Charts –
These charts display price activity by plotting a column of X's on the chart at each price traded until a specified reversal amount occurs.

At the reversal price, the Point & Figure chart shifts to the left and begins plotting a column of O's on the chart at each price traded until a specified reversal amount occurs.

The process of alternately plotting X's and O's continues until the reversal amount is reached in each direction.

The resulting formation of X and O columns can be analyzed to determine market strength and weakness.

Portfolio -
Portfolios contain the issues to which conditions are applied. A portfolio can be an individual issue or a list of specific issues.

Position –
A market commitment. A buyer of a futures contract is said to have a long position and, conversely, a seller of futures contracts is said to have a short position.

Prices -
The following Prices can be used in Formulas and Technical Analyses:

  • Open
  • High
  • Low
  • Close
  • Midpoint (HL/2)
  • Bar Average (HLC/3)
  • True High
  • True Low
  • Range / True Range
  • Quarterly Charts
    The term Quarterly is used to describe those charts that are constructed of quarterly bars.

Each quarterly bar contains the Open, High, Low, and Close that occurred during each quarter.

Quarterly charts are also available on selected government and industry reports. These reports may contain only one value for each quarter.

Put Option –
An option that gives the option buyer the right but not the obligation to sell (go "short") the underlying futures contract at the strike price on or before the expiration date.
To Top

Range / True Range -
The Range is the distance the market moves from the current high to the current low.

The True Range is the greatest distance of:

  • Current High to Current Low
  • Previous Close to Current High
  • Previous Close to Current Low

Retransmission -
CQG retransmits past market data each evening. The retransmitted data is used to construct the charts on the CQG system. By retransmitting the data, each user is assured of receiving updated and accurate information.

CQG retransmits the data in the form of 5-minute, 30-minute, 60-minute, Daily, Weekly, and Monthly bars. The type and quantity of the retransmitted data varies from contract to contract. The more active contracts typically receive the most transmitted data.

The Time & Sales data files are relatively large since they contain each trade for each contract on the system. For this reason, the amount of Time & Sales data that is available at any given time may be limited to several days.

The duration of the charts that are constructed from Time & Sales data (1-9 Minute Bars) is limited by the amount of Time & Sales data available in the system. For example: With two days of Time & Sales data in the system, a 1-minute chart can display enough bar data to scroll through several screens; whereas a 9-minute chart may display only 1/9th of the number of bars.

Scalper –
A trader who trades for small, short-term profits during the course of a trading session, rarely carrying a position overnight.

Signals
A Signal can be an individual condition or it can be a combination of Conditions, Bar Values, Study Operators, Mathematical Operators, and Boolean Operators.

Short –
One who has sold futures contracts or plans to purchase a cash commodity. (verb) Selling futures contracts or initiating a cash forward contract sale without offsetting a particular market position.

Speculator –
A market participant who tries to profit from buying and selling futures and options contracts by anticipating future price movements. Speculators assume market price risk and add liquidity and capital to the futures markets.

Spreading –
The simultaneous buying and selling of two related markets in the expectation that a profit will be made when the position is offset. Examples include: buying one futures contract and selling another futures contract of the same commodity but different delivery month; buying and selling the same delivery month of the same commodity on different futures exchanges; buying a given delivery month of one futures market and selling the same delivery month of a different, but related, futures market.

Stock Index –
An indicator used to measure and report value changes in a selected group of stocks. How a particular stock index tracks the market depends on its composition the sampling of stocks, the weighing of individual stocks, and the method of averaging used to establish an index.

Stop Order –
An order to buy or sell when the market reaches a specified point. A stop order to buy becomes a market order when the futures contract trades (or is bid) at or above the stop price. A stop order to sell becomes a market order when the futures contract trades (or is offered) at or below the stop price.

Stop-Limit Order –
A variation of a stop order in which a trade must be executed at the exact price or better. If the order cannot be executed, it is held until the stated price or better is reached again.

Strike Price –
The price at which the futures contract underlying a call or put option can be purchased (if a call) or sold (if a put). Also referred to as exercise price.
To Top

Technical Analysis –
Anticipating future price movement using historical prices, trading volume, open interest and other trading data to study price patterns.

Theoretical Value -
The value of an option according to a mathematical model.

Tick –
The smallest allowable increment of price movement for a contract.

Time Interval Codes -
A Time Interval Code can be appended to a contract symbol to display a specific time interval.

,5 5-minute
,60 60-minute
,xx xx-minute (where xx=1 to 120 minutes
,D Daily (Contract Specific Chart)
,DC Daily (Continuation Chart)
,W Weekly (Continuation Chart)
,M Monthly (Continuation Chart)
,Q Quarterly (Continuation Chart)
,S Semi-Annual (Continuation Chart)
,A Annual (Yearly) (Continuation Chart)
,Y Yearly (Annual) (Continuation Chart)

Example: USZ99,D indicates -
US = U.S. Treasury Bond (Chicago Board of Trade),
Z = December
99 = 1999 and
D = Daily Chart

A time interval code can be entered without specifying a symbol. When this occurs, the system defaults to the currently displayed symbol.

Examples:

  • ,5 would display a 5 Minute Chart for the currently displayed symbol.
  • ,D would display a daily chart for the currently displayed symbol.

For intervals greater than daily, entering the time interval code twice designates a contract-specific chart instead of a continuation chart.
Examples:

  • ,WW would display a contract specific chart, where
  • ,W would display a continuation chart.

Time Limit Order –
A customer order that designates the time during which it can be executed.

Time Value –
The amount of money option buyer are willing to pay for an option in the anticipation that, over time, a change in the underlying futures price will cause the option to increase in value. In general, an option premium is the sum of time value and intrinsic value. Any amount by which an option premium exceeds the option's intrinsic value can be considered time value. Also referred to as extrinsic value.

Time and Sales Ticker –
System consisting of an online graphic service that transmits price and time information throughout the day.

Time-Stamped –
Part of the order-routing process in which the time of day is stamped on an order. An order is time-stamped when it is (1) received on the trading floor, and (2) completed.

Time Until Expiration -
The time remaining until an option expires. Measured in days or years.

Trading Day -
Most securities and commodities trade for a single session, lasting several hours each day, while others are traded during multiple sessions lasting many hours. Exchange trading systems, such as GLOBEX from the CME, offer around-the-clock trading for an increasing number of contracts.

CQG displays the trading day for each market, beginning with the morning opening in each market's primary trading location or beginning with the Exchange's established opening time. For selected contracts traded through the GLOBEX system, the CME has established an opening time coinciding with the opening of the Far Eastern markets.

For example: The CME has established that the opening time for Eurodollars is 14:00 CT, (2:00 PM CT). Therefore, the CQG daily chart for Eurodollars contains data from 14:00 to 13:59 (the close of the primary session) the following "day."

Trailing Stop –
A buy trailing stop order sets the stop price at a fixed amount above the market price with an attached "trailing" amount. As the market price drops, the stop price drops by the trail amount, but if the instrument price arises, the stop loss price doesn't change, and a market order is submitted when the stop price is hit.

Treasury Bill –
A Treasury bill is a short-term U.S. government obligation with an original maturity of one year or less. Unlike a bond or note, a bill does not pay a semi-annual, fixed rate coupon. A bill is typically issued at a price below its par value and is therefore a discounted instrument. The level of the discount depends on the level of prevailing interest rates. In general, the higher short-term interest rates are, the greater the discount. The return to an investor in bills is simply the difference between the issue price and par value.

Treasury Bond –
Government-debt security with a coupon and original maturity of more than 10 years. Interest is paid semiannually.

Treasury Note –
Government-debt security with a coupon and original maturity of one to 10 years.

True Highs/Lows -
True Highs are defined as the maximum of either the current bar's high or the previous bar's close.
True Lows are defined as the minimum of either the current bar's low or the previous bar's close.

Type -
Type usually refers to the type of moving average used in technical analysis calculations.
Type can be Simple, Smoothed, Centered, or Exponential.

To Top

Underlying Asset -
The specific stock, future or other contract to be delivered, when, and if, the option is exercised.

Underlying Contract Type -
The type of instrument covered by the option. Currently three types of options are available:

  • Equity
  • Currency
  • Futures

Underlying Price -
The price of the instrument which could be delivered upon exercise.

To Top

Volatility –
A measurement of the change in price over a given period. It is often expressed as a percentage and computed as the annualized standard deviation of the percentage change in daily price.

Volume –
The number of purchases or sales of a commodity futures contract made during a specific period of time, often the total transactions for one trading day.
To Top

Yield –
A measure of the annual return on an investment.

Yield Curve –
A chart in which the yield level is plot on the vertical axis and the term to maturity of debt instruments of similar credit worthiness is plotted on the horizontal axis. The yield curve is positive when long-term rates are higher than short-term rates; however, the yield curve is negative, or inverted, when long term rates are lower than short term rates.

Yield to Maturity –
The rate of return an investor receives if a fixed-income security is held to maturity.
To Top


%%ItemTitle%%

CQG API Documentation 4.0 - Revised
Change Log
Send Feedback

Glossary Item Box

To deliver new functionalities and improve the existing product, CQG periodically updates the CQG API. In most cases, these changes will run smoothly with existing user applications, however in some cases these applications must be modified to make them compatible with the new API.

In this page of the documentation, you will find a list of what was changed in which version of CQG API.

To ensure a smooth transition, upgrading users should start deploying a new CQG API by checking this page first.

Note:

All changes that may require code modification are in bold.

13x4

The following objects were added to introduce new functionality to CQG API:

  • CQGAPIConfig.PendingOrderActionEnabled property
  • CQGAlgorithmicOrderDefinition.DefaultValueIndex property
  • GetTickSizeFor and GetTickValueFor methods
  • ApplyDaylightSavingChanges.CQGAPIConfig property

12x3

  • eInstrumentProperty.ipWorkup enumeration was added.
  • New FAQ item: CEL memory usage is growing by time. Is it a memory leak?

12x2

No changes were introduced to CQG API.

12x1

The following objects were added to introduce new functionality to CQG API:

  • CQGFill.GWTrades and CQGFill.GWTradesCount properties
  • CQGGWTrade interface and CQGGWTrades collection
  • CQGTimedBar.ContractVolume, CQGTimedBar.CommodityVolume, CQGTimedBar.ContractTickVolume, CQGTimedBar.CommodityTickVolume, CQGTimedBar.ContractOpenInterest, CQGTimedBar.CommodityOpenInterest properties
  • New enumerators tbrContractVolume, tbrCommodityVolume, tbrContractTickVolume, tbrCommodityTickVolume, tbrContractOpenInterest, tbrCommodityOpenInterest added to the eTimedBarsRequestOutputs enumeration
  • CQGPointAndFigureBar.PFHigh and CQGPointAndFigureBar.PFLow were added and CQGPointAndFigureBar.High and CQGPointAndFigureBar.Low were modified

The following objects were removed:

  • CQGInstrument.YOI, CQGInstrument.TodayTotalVolume, CQGInstrument.YesterdayTotalVolume properties
  • eInsturmentProperty.ipYOI, eInsturmentProperty.ipTodayTotalVolum, eInsturmentProperty.ipYesterdayTotalVol enumerators

8x7

  • CQGAPIConfig.IncludeOrderTransactions property
  • The following order events are obsolete: oeQueueTimeout, oeCancelQueueTimeout, oeModifyQueueTimeout, oeInTransTmout, oeInModTmout, and oeInCanTmout. These will not be fired anymore.
  • eInstrumentProperty.ipFirstNoticeDate enumerator
  • CQGOrder.OrderCheckMark property and eOrderProperty.opOrderCheckMark enumerator

8x6

  • CQGCEL.CreateOrderChain, CQGCEL.PlaceCompoundOrder and CQGCEL.ModifyCompoundOrder methods and CQGOrderChain interface: provide OCO compound order functionality
  • ipFirstNoticeDay enumeration: provides information about an instrument's first notice day

8x5

  • CQGCEL.GWOTPLogon method: provides one time password functionality
  • CQGTFlowBarsRequest.DomAskVolumeLevel and CQGTFlowBarsRequest.DomBidVolumeLevel properties and eTFlowRequestDomVolumeLevel enumerator
  • CQGAlgorithmicOrderDefinition.Values property, CQGAlgorithmicOrderDefinition.AddValue method and eAlgorithmicOrderPropertyType.aoptBoolean, eAlgorithmicOrderPropertyType.aoptList enumerators
  • CQGPositions.ItemByIndex property
  • CQGInstrumentSubscriptionRequest interface
  • CQGPositionsStatement interface
  • CQGSummariesStatement interface
  • CQGConstantVolumeBar.TimestampOffset property, CQGCurves.TimestampOffset propety, CQGExpressionOutputs.TimestampOffset property, CQGPointAndFigureBar.TimestampOffset property, and CQGTFlowBar.TimestampOffset property interfaces.

8x4

  • CQGAPIConfig.NewInstrumentMode property
  • CQGAccountSummary.ProfitLoss method
  • CQGCEL methods: CreateInstrumentRequest, QueryPositionsStatement, QuerySummariesStatement, and RemoveInstrumentsGroup
  • CQGCEL Properties: AllExpressions, AllInstrumentsGroups, and AllTimedBars
  • CQGCEL events: PositionsStatementResolved and SummariesStatementResolved
  • TimestampOffset property for: CQGConstantVolumeBar, CQGPointAndFigureBar, CQGTFlowBar, CQGTradingSystemStatistics, CQGTradingSystemTrade, CQGCurves, CQGExpressionOutputs, and CQGTradingSystemTradesRow.
  • CQGInstrument properties: DOMStatus, ExchangeAbbreviation, ExchangeID, PropertyLevel, QuoteLevel, TickSizeFractionDenominator, and TickSizeFractionNumerator
  • CQGInstrumentSubscriptionRequest interface
  • CQGPosition.ManualFillsInvolved property
  • CQGPositionsStatement interface
  • CQGQuote.HasVolume property
  • CQGSession properties: ValidStartTime and ValidEndTime
  • CQGSummariesStatement interface
  • CQGTradingSystemBaseBarParameter interface
  • CQGTradingSystemBaseBarParameters collection
  • CQGTradingSystemRequest properties: BaseBarParameters and BaseBarType
  • CQGSessions properties: DescriptionStart, DescriptionEnd, DescriptionNumber, and Holidays.
  • eDataSourceStatus enumerator: dssDisabled
  • eInstrumentProperty enumerators: ipLeadingContractName, ipTickSizeFractionNumerator, and ipTickSizeFractionDenominator
  • eOrderProperty enumerator: opTradingExpression
  • ePropertySubscriptionLevel enumeration
  • eQuoteSubscriptionLevel enumeration
  • Enumerators for eQuoteType: qtIndicativeOpen, qtTodayMarker, and qtMarker
  • eTradingSystemBaseBar enumeration
  • eTradingSystemBaseBarParameter enumeration
  • CQGCEL.GWOPLogon method and CQGCEL.OTPRequired property

8x3

  • Added new functionality to manually add and edit transactions that actually were conducted from other systems. These are the objects that provide this functionality:
    • CQGCEL.CreateManualFillRequest method
    • CQGCEL.RequestManualFills method
    • CQGCEL.RequestManualFillUpdate method
    • CQGCEL.AllManualFills Property
    • CQGCEL.ManualFillChanged event
    • CQGCEL.ManualFillsResolved event
    • CQGCEL.ManualFillUpdateResolved event
    • CQGManualFill interface
    • CQGManualFills collection
    • CQGManualFillsCollection collection
    • CQGManualFillRequest interface
    • eManualFillsDataLevel enumeration
    • eManualFillUpdateType enumeration
  • New enumerators added to eOrderProperty: opLastFillTime and opCanceledTime
  • CQGTicksRequest.TickFilter property was added
  • CQGHoliday
  • CQGHolidays
  • CQGHistoricalSessionsRequest
  • CQGCEL.RequestHistoricalSessions method
  • CQGCEL.CreateHistoricalSessionsRequest method
  • CQGCEL.HistoricalSessionsResolved event
  • CQGSessions.DescriptionEnd, CQGSessions.DescriptionNumber, CQGSessions.DescriptionStart, CQGSessions.Holidays
  • eHistoricalSessionsRequestType enumeration
  • CQGOrder.CancelationInstruction and eOrderCancelationType

8x2870

  • Wherever the term "TradeFlow" was mentioned in object names, it was replaced by "TFlow".
    For example, CQGTradeFlowBar was renamed as CQGTFlowBar.
    Solution: Basically, replacing all TradeFlow by TFlow in your existing code will be sufficient.
  • The Following objects were added to introduce new functionality to CQG API:
    CQGTradeEntries collection
    CQGTradingSystemRelationAddInfo interface
    CQGCEL.TradingSystemTradeRelationAddNotification event
    CQGTradeEntry.RelatedExits property
    CQGTradeExit.RelatedEntries property
    CQGTradeExits.ItemByName property
    CQGTradingSystemTrade.IsActive property
    CQGTradingSystemTrade.Timestamp property
    CQGTradingSystemTrade.TradesRow property


%%ItemTitle%%

CQG API Documentation 4.0 - Revised
What's New?
Send Feedback

Glossary Item Box

Important Note:

Please check the Change Log page to find information about important/critical product updates.

In the latest version, synthetic spreading features were added to CQG API, allowing to:

  • Subscribe to new or existing (using QFormula's expression or number) synthetic strategies and get their market data.
  • Create and place synthetic strategy orders.
  • Monitor the synthetic strategy order status (hang, overfill, etc.)
  • Request existing synthetic strategy orders
  • Request historical data for synthetic strategies (CQGTimedBars, CQGConstantVolumeBars , CQGPointAndFigureBars, CQGCustomStudies, CQGConditions)
  • View QFormula expression and number

To improve the performance of real-time data delivery, the following functionalities were added to CQG API:

  • It is possible now to subscribe to a group of options at once, which is both much convenient and faster than subscribing to each option separately.
  • Previously, CQG API was only supporting non-dispatch events. Now, it is also possible to subscribe to vtbl events.
  • Now the user can configure the time duration, which CQG API spends on market data updates processing.


%%ItemTitle%%

CQG API Documentation 4.0 - Revised
What's New in CQG API 4.0 - Revised?
Send Feedback

Glossary Item Box

In current version of CQG API: version 4.0-Revised, the user can retrieve historical data, user formulas, data source related information, custom sessions information, tradable commodities, etc.

Some properties were revised as following. Please review your existing code for compliancy:

  • CQGOrder.GWOrderID changed its type from Long to String
  • CQGOrder.OriginalOrderID changed its type from Long to String
  • CQGOrders.Item property parameter's type was changed from Variant to String.
    Additionally, now CQGOrders.Item retrieves an order from the collection ONLY by its Gateway identifier (To retrieve by GUID see below).
  • CQGOrders.ItemByGuid property was added

  • CQGFill.FillID was renamed as CQGFill.Id and its type was changed from Long to String
  • CQGFill.RefFillID was renamed as CQGFill.RefFillId and its type was changed from Long to String
  • CQGFill.GWTradeID was renamed as CQGFill.GWTradeId and its type was changed from Long to String
  • CQGFills.Item property parameter's type was changed from Long to String

  • CQGTransaction.Id type was changed from Long to String
  • CQGTransactions.Item property parameter's type was changed from Long to String

Although there are so many interfaces and collections added to the API4.0-Revised, the Object Model got much simpler.

Below are listed the interfaces, which were recently added to the CQG API:

  • CQGAlgorithmicOrderDefinition
  • CQGAlgorithmicOrderParameters
  • CQGAlgorithmicOrderProperty
  • CQGChangedTradeEntry
  • CQGChangedTradeExit
  • CQGConditionDefinition
  • CQGConditionRequest
  • CQGConditionResult
  • CQGConstantVolumeBar
  • CQGConstantVolumeBarsRequest
  • CQGCurrencyRate
  • CQGCurveDefinition
  • CQGCustomStudyDefinition
  • CQGCustomStudyRequest
  • CQGDataSource
  • CQGDataSourceSymbol
  • CQGExpressionRequest
  • CQGModifiedProperty
  • CQGParameterDefinition
  • CQGPointAndFigureBar
  • CQGPointAndFigureBarsRequest
  • CQGQFormulaDefinition
  • CQGTick
  • CQGTicksRequest
  • CQGTimedBar
  • CQGTimedBarsRequest
  • CQGTradeEntry
  • CQGTradeEntryDefinition
  • CQGTradeExit
  • CQGTradeExitDefinition
  • CQGTFlowBar
  • CQGTFlowBarsRequest
  • CQGTradingSystem
  • CQGTradingSystemDefinition
  • CQGTradingSystemRequest
  • CQGTradingSystemStatistics
  • CQGTradingSystemStatisticsChangeInfo
  • CQGTradingSystemTrade
  • CQGTradingSystemTradeDefinition
  • CQGTradingSystemUpdateInfo
  • CQGTransaction

And these are the new collections:

  • CQGAlgorithmicOrderDefinitions
  • CQGAlgorithmicOrderProperties
  • CQGChangedTradeEntries
  • CQGChangedTradeExits
  • CQGCondition
  • CQGConditionDefinitions
  • CQGConditions
  • CQGConstantVolumeBars
  • CQGConstantVolumeBarsCollection
  • CQGCurrencyRates
  • CQGCurveDefinitions
  • CQGCurveHeaders
  • CQGCurves
  • CQGCustomStudies
  • CQGCustomStudy
  • CQGCustomStudyDefinitions
  • CQGDataSources
  • CQGDataSourceSymbols
  • CQGExpression
  • CQGExpressionOutputHeaders
  • CQGExpressionOutputs
  • CQGExpressions
  • CQGModifiedProperties
  • CQGParameterDefinitions
  • CQGPointAndFigureBars
  • CQGPointAndFiguresCollection
  • CQGQFormulaDefinitions
  • CQGSessionsCollection
  • CQGTicks
  • CQGTicksCollection
  • CQGTimedBars
  • CQGTimedBarsCollection
  • CQGTradeExitDefinitions
  • CQGTradeExits
  • CQGTFlowBars
  • CQGTFlowBarsCollection
  • CQGTradingSystemAddInfo
  • CQGTradingSystemDefinitions
  • CQGTradingSystems
  • CQGTradingSystemStatisticsCollection
  • CQGTradingSystemTradeDefinitions
  • CQGTradingSystemTradesRow
  • CQGTradingSystemTradesRows
  • CQGTradingSystemUpdateInfo
  • CQGTransactions


%%ItemTitle%%

CQG API Documentation 4.0 - Revised
CQG API Structure Categorized by Enablements
Send Feedback

Glossary Item Box

Each enablement embodies a list of features and functionalities available to CQG Integrated Client (CQGIC).

Please note that any limitation that applies to your CQGIC system is effective for CQG API.

To activate the CQG API enablements you need, please contact with CQG API Support.

The following section displays structural components of CQG API, catogorized by enablements.

To read a brief description about an object, hover the mouse cursor over it. To go to the object's page, click on it.

Core Interfaces

CQG API has several interfaces, which are independent of used features and hence independent of user enablements. They provide common information, allow configuration management and operation with supporting functionality.

CQGCEL
CQGAPIConfig
CQGEnvironment
CQGError
CQGLogger

CQG API Streaming

If enabled for the API Streaming; the user can access contract-specific info, session info, the list of data sources in CQGIC, symbols per data source, quotes updates—such as Best Ask and Bid, Settlement, Day high and low, etc.

The user can also access the same DOM data available to the CQG Integrated Client (real Gateway account is required).

Additionally, the user can get a list of contracts for a commodity and the list of tradable commodities for the current user, if connected to the Gateway.

Interfaces for working with the CQG API Streaming are:

Interfaces | Collections
CQGDataSource | CQGDataSources
CQGDataSourceSymbol | CQGDataSourceSymbols
CQGInstrument | CQGInstruments
CQGInstrumentProperty | CQGInstrumentProperties
 | CQGCommodities
 | CQGCommodityInstruments
CQGQuote | CQGQuotes
 | CQGDOMQuotes
CQGSession | CQGSessions
 | CQGSessionsCollection

CQG API Trading

Those users who have trading accounts via CQG can consider using API Trading as well. Besides placing, monitoring, and managing orders, it also allows getting information on accounts and positions.

This enablement requires:

  • Subscription to the API Streaming enablement
  • The user must be logged into the Gateway via CQG Integrated Client

Interfaces for working with the CQG API Trading are:

CQGCurrencyRate | CQGCurrencyRates
CQGAccount | CQGAccounts
CQGAccountSummary | CQGAccountSummaries
CQGPosition | CQGPositions
CQGTrade | CQGTrades
CQGFill | CQGFills
CQGOrder | CQGOrders
CQGOrderModify |
CQGOrderProperty | CQGOrderProperties
CQGOrdersQuery |

CQG API Historical

If enabled for CQG API Historical, the user can retrieve historical data available on the Charts window of the CQG Integrated Client.

It also allows the retrieval of user formula definitions, and custom sessions.

Data available to users who have this enablement is limited by:

  • 3000 60-minute or less intraday bars,
  • 300 greater than 60-minute timed intraday bars, as well as Daily or Weekly historical bars,
  • 5 days of non-timed bars, and
  • 2 days of ticks data.

If more data is required than what is returned, you might consider upgrading to the CQG API Extended Historical, CQG API Extended Historical Plus, or CQG API Historical Unlimited enablements (described below).

Interfaces for working with CQG API Historical are:

CQGAdvancedStudyRequest |
CQGAdvancedStudy | CQGAdvancedStudies
CQGAdvancedStudyDefinition | CQGAdvancedStudyDefinitions
CQGConditionDefinition | CQGConditionDefinitions
CQGConditionRequest |
CQGConditionResult | CQGCondition
 | CQGConditions
CQGConstantVolumeBarsRequest |
CQGConstantVolumeBar | CQGConstantVolumeBars
 | CQGConstantVolumeBarsCollection
CQGCurveDefinition | CQGCurveDefinitions
 | CQGCurveHeaders
 | CQGCurves
 | CQGCustomStudy
CQGCustomStudyDefinition | CQGCustomStudyDefinitions
CQGCustomStudyRequest |
 | CQGCustomStudies
CQGExpressionRequest |
 | CQGExpression
 | CQGExpressions
 | CQGExpressionOutputHeaders
 | CQGExpressionOutputs
CQGParameterDefinition | CQGParameterDefinitions
CQGPointAndFiguresRequest |
CQGPointAndFigure | CQGPointAndFigures
 | CQGPointAndFiguresCollection
CQGQFormulaDefinition | CQGQFormulaDefinitions
CQGSubMinuteBarsRequest |
CQGSubMinuteBar | CQGSubMinuteBars
 | CQGSubMinuteBarsCollection
CQGTicksRequest |
CQGTick | CQGTicks
 | CQGTicksCollection
CQGTimedBarsRequest |
CQGTimedBar | CQGTimedBars
 | CQGTimedBarsCollection
CQGTradeEntryDefinition |
CQGTradeEntry |
CQGTradeExitDefinition | CQGTradeExitDefinitions
CQGTradeExit | CQGTradeExits
CQGTradeFlowsRequest |
CQGTradeFlow | CQGTradeFlows
 | CQGTradeFlowsCollection
CQGTradingSystemDefinition | CQGTradingSystemDefinitions
CQGTradingSystemTradeDefinition | CQGTradingSystemTradeDefinitions
CQGTradingSystemRequest |
CQGTradingSystem | CQGTradingSystems
CQGTradingSystemStatistics | CQGTradingSystemStatisticsCollection
CQGTradingSystemTrade |
 | CQGTradingSystemTradesRow
 | CQGTradingSystemTradesRows
CQGChangedTradeEntry | CQGChangedTradeEntries
CQGChangedTradeExit | CQGChangedTradeExits
CQGYieldsRequest |
CQGYield | CQGYields
 | CQGYieldsCollection

CQG API Historical Extended

This enablement is the same as CQG API Historical, with its limitations reduced as following:

  • 10000 60-minute or less intraday bars,
  • 1000 greater than 60-minute timed intraday bars, as well as Daily or Weekly historical bars,
  • 10 days of non-timed bars, and
  • 2 days of ticks data.

CQG API Historical Extended Plus

Note: This enablement is only available for CQGIC versions 8x1901 or higher.

This enablement is the same as CQG API Historical, with its limitations further reduced as following:

  • 40000 60-minute or less intraday bars,
  • 4000 greater than 60-minute timed intraday bars, as well as Daily or Weekly historical bars,
  • 20 days of non-timed bars, and
  • 2 days of ticks data.

CQG API Historical Unlimited

This enablement is the same as CQG API Historical, but without its limitations.

Users enabled for CQG API Historical Unlimited can access all historical data available on CQG Servers.

The only point to notice here is that ticks are limited in this case by the number of ticks available in the CQG Integrated Client for that user; i.e., a user cannot get more ticks data from CQG API than from the CQG Integrated Client.

Interfaces for working with unlimited historical API are the same as for historical API.

API-3rd Party Study

When this enablement is activated, the user will be able to use the third-party studies in API that are already accessible to his CQGIC.

If disabled, whenever the user tries to access a third-party study the following error is displayed:

Access to the study_name via API is disabled.


%%ItemTitle%%

CQG API Documentation 4.0 - Revised
How To Get Real-Time Market Data
Send Feedback

Glossary Item Box

Enablements Required:
CQG API Streaming

  1. Create a new project.
  2. Add COM reference to CQG 4.0 Type Library - Revised.
  3. Create the CQGCEL object.
  4. Configure the CQGCEL object using CQGCEL.APIConfiguration.

    If your application is always available to receive CQGCEL events; set CQGAPIConfig.ReadyStatusCheck to rscOff.
    The ReadyStatusCheck is commonly used if the application has compute-intensive work and will not respond promptly or if it is used from MS Excel. In these cases, set CQGAPIConfig.ReadyStatusCheck to rscOn and handle the CQGCEL.IsReady event.

  5. Start the CQGCEL by calling the CQGCEL.Startup method.
  6. Wait for the CQGCEL.CELStarted event. If CQGIC is not started, a CQGCEL.DataError event will be fired, notifying about that.
  7. Handle the CQGCEL.DataConnectionStatusChanged event.
  8. If the CQGCEL.Environment.DataConnectionStatus is csConnectionUp, subscribe to the instrument you want to place orders on using the CQGCEL.NewInstrument method.
  9. When the instrument subscription succeeds, the CQGCEL.InstrumentSubscribed event is fired and a corresponding CQGInstrument object is created in the CQGInstruments collection.
  10. Whenever an update to the instrument is received, a CQGCEL.InstrumentChanged event will be fired with two collections of the updated quotes and instrument properties respectively.


%%ItemTitle%%

CQG API Documentation 4.0 - Revised
How to Place Orders
Send Feedback

Glossary Item Box

Enablements Required:
CQG API Streaming, CQG API Trading

  1. Create a new project.
  2. Add COM reference to CQG 4.0 Type Library - Revised.
  3. Create the CQGCEL object.
  4. Configure the CQGCEL object using CQGCEL.APIConfiguration.

    If your application is always available to receive CQGCEL events; set CQGAPIConfig.ReadyStatusCheck to rscOff.
    The ReadyStatusCheck is commonly used if the application has compute-intensive work and will not respond promptly or if it is used from MS Excel. In these cases, set CQGAPIConfig.ReadyStatusCheck to rscOn and handle the CQGCEL.IsReady event.

  5. Start the CQGCEL by calling the CQGCEL.Startup method.
  6. Wait for the CQGCEL.CELStarted event. If CQGIC is not started, a CQGCEL.DataError event will be fired, notifying about that.
  7. Handle the CQGCEL.DataConnectionStatusChanged event.
  8. Logon to GW using the CQGCEL.GWLogon method. Note: Use username_ = "DEMO" and password_ = "DEMO" for login to Gateway with a demo account.
  9. Handle the CQGCEL.GWConnectionStatusChanged event.
  10. After the CQGCEL.GWConnectionStatusChanged event returns csConnectionUp, set the AccountSubscriptionLevel to aslAccountUpdatesAndOrders.
  11. When the GW Account subscription level change succeeds, the CQGCEL.AccountChanged event is fired where the change parameter is actAccountsReloaded,and corresponding CQGAccount objects are created in the CQGAccounts collection.
  12. If the CQGCEL.Environment.DataConnectionStatus is csConnectionUp, using the CQGCEL.NewInstrument method, subscribe to the instrument you want to place orders on.
  13. When the instrument subscription succeeds, the CQGCEL.InstrumentSubscribed event is fired and a corresponding CQGInstrument object is created in the CQGInstruments collection.
  14. Whenever an update to the instrument is received, a CQGCEL.InstrumentChanged event will be fired with two collections of the updated quotes and instrument properties respectively.
  15. Create the order using the CQGCEL.CreateOrder method.
    1. If the orderType is otLimit the limit price is required.
    2. If the orderType is otStop the stop price is required.
    3. The parked parameter can be set for future activation of the order.
  16. Place the order by calling the CQGOrder.Place method.
  17. To get updates on the order’s status and fills, handle the CQGCEL.OrderChanged event.
    1. Orders are accessible from the CQGCEL.Orders collection.
    2. Orders are identified and can be retrieved by their GUID or GWOrderID properties.
  18. To cancel an order, call the CQGOrder.Cancel method.
    1. All orders can be cancelled by CQGCEL.CancelAllOrders method.
  19. To activate a parked order, call the CQGOrder.Activate method.
    1. All parked orders can be activated by calling the CQGCEL.ActivateAllOrders method.


%%ItemTitle%%

CQG API Documentation 4.0 - Revised
How to Get Trading Account Details (MVO, NLV, etc.)
Send Feedback

Glossary Item Box

Enablements Required:
CQG API Streaming, CQG API Trading

  1. Create a new project.
  2. Add COM reference to CQG 4.0 Type Library - Revised.
  3. Create the CQGCEL object.
  4. Configure the CQGCEL object using CQGCEL.APIConfiguration.

    If your application is always available to receive CQGCEL events; set CQGAPIConfig.ReadyStatusCheck to rscOff.
    The ReadyStatusCheck is commonly used if the application has compute-intensive work and will not respond promptly or if it is used from MS Excel. In these cases, set CQGAPIConfig.ReadyStatusCheck to rscOn and handle the CQGCEL.IsReady event.

  5. Start the CQGCEL by calling the CQGCEL.Startup method.
  6. Wait for the CQGCEL.CELStarted event. If CQGIC is not started, a CQGCEL.DataError event will be fired, notifying about that.
  7. Handle the CQGCEL.GWConnectionStatusChanged event. GW Connection status will be changed upon logging in/out of the Gateway account from within CQGIC.
  8. After the CQGCEL.GWConnectionStatusChanged event returns csConnectionUp, set the AccountSubscriptionLevel to aslAccountsAndUpdates.
  9. When the GW Account subscription level change succeeds, the CQGCEL.AccountChanged event is fired where the change parameter is actAccountsReloaded, and corresponding CQGAccount objects are created in the CQGAccounts collection.
  10. In order to have the account's OTE/MVO information calculated in real-time, set the CQGAccount.AutoSubscribeInstruments to True.
    1. To receive updates on positions for a particular account, set CQGAccount.PositionSubcriptionLevel property for that account to pslSnapshotAndUpdates.
    2. To receive updates on positions for all accounts; before calling the CQGCEL.Startup method, set APIConfiguration.DefPositionSubscriptionLevel to pslSnapshotAndUpdates.
    3. You can receive the account’sOTE/MVO values through the CQGAccountSummary interface.
    4. You can also receive a position’s OTE/MVO values through the CQGPosition interface.
    5. When the data connection is down, OTE/MVO will not be updated. Handle the CQGCEL.DataConnectionStatusChanged event to notify the user about that.
  11. When the position subscription level change succeeds, the CQGCEL.AccountChanged event is fired where the change parameter is actPositionsReloaded,and corresponding CQGPosition objects are created in the CQGAccount.CQGPositions collection.
  12. Handle the CQGCEL.AccountChanged event to monitor the account and position properties.


%%ItemTitle%%

CQG API Documentation 4.0 - Revised
Usage Diagram
Send Feedback

Glossary Item Box

Here is a diagram representing the control flow between an application using CQG API and the CQGCEL module.

Click on blocks to go to appropriate sections of this documentation.

CQG API Usage Diagram CQGCEL.Startup MethodCQGAPIConfig InterfaceCQGCEL.CELStarted EventCQGCEL.CELStarted EventCQGCEL.Shutdown MethodCQGCEL InterfaceSee the Example section of CQGCEL InterfaceSee the Example section of CQGCEL InterfaceExample: CQGCEL.NewInstrument MethodExample: CQGCEL.RemoveInstrument MethodExample: CQGCEL.InstrumentSubscribed EventExample: CQGCEL.Instruments Property


%%ItemTitle%%

CQG API Documentation 4.0 - Revised
Error Codes
Send Feedback

Glossary Item Box

The data errors that might be encountered during CQG API operation are described below:

Code | Description
102 | Object is disposed. No method can be called.
103* | Failed to start Quote Agent.
104 | Failed to convert time to the user time zone.
105* | You are not enabled for retrieving data via CQG API. To enable this feature, please call CQG Customer Support.
106 | CQG API is running. The configuration cannot be changed on the fly.
107 | Failed to create an instance of com object.
108 | Incorrect price value is passed.
109 | Failed to create the waker window.
110 | The logger parameters must be positive values.
111* | Failed to start Query Agent.
114 | Failed to start Order Agent.
117 | Invalid leg index is supplied.
118 | DOM updates period must be a non-negative value.
121 | Incorrect "days before" argument supplied.
125* | CQGIC is not started.
127 | Account subscription level is too low to perform the requested task.
128 | The order is already placed.
129 | The order status prevents its modification.
130 | Order related error occurred.
131* | Failed to request timed bars.
132 | The order status prevents its activation.
133 | The order property is invalid for this order type.
134 | Order side value does not correspond to order side configuration setting.
135 | Quantity negative value does not correspond to order side configuration setting.
137 | The order status prevents its cancellation.
138 | A valid account must be specified in order queries.
139 | Such property does not exist for the specified order type.
140 | Editable part of UEName does not conform to requirements.
141 | The order property is read-only.
142* | Failed to request ticks.
143 | Failed to request orders.
146 | This method is not supported.
147 | User formulas not found.
150 | No data sources available.
151 | No data source symbols available.
152 | Symbol name cannot be empty.
153 | Failed to request tradable commodities.
154 | Data source abbreviation cannot be empty.
155 | No custom sessions available.
156 | Failed to request data source symbols.
157* | Failed to request constant volume bars.
158* | Failed to request point and figure bars.
159* | Failed to request TFlow bars.
162* | Failed to request trading system.
163* | Failed to request condition.
164* | Failed to request expression.
165 | Unexpected error.
166* | Failed to connect to CQGIC.
167* | Your system is configured incorrectly. Version incompatibility problem.
168 | Owner of CQGError object is disposed.
196* | Failed to start API instance: maximum number of instances is exceeded.
199* | Unable to retrieve positions for the account.
200* | Unknown error occurred during accounts request processing.
202* | You are not logged on to CQG Gateway. Please log on and try again.
203* | You are not authorized to access accounts and positions information. Contact CQG Customer Support for assistance.
204* | Unable to retrieve currency rates from FCM.
301 | Good Till Date timestamp should exist only for GTD type durations.
302 | Instrument name is required to place an order.
303 | User-friendly name is required to place an order.
304 | Account ID is required to place/modify an order.
305 | Order type is illegal. Only market, limit, stop, stop-limit, trailing stop, trailing stop-limit orders are supported.
306 | Quantity is required to place an order.
307 | Limit price is required to place limit, stop-limit, trailing stop-limit orders.
308 | Stop price is required to place stop, stop-limit, trailing stop, trailing stop-limit orders.
309 | Trailing offset is required to place trailing stop, trailing stop-limit orders.
310 | Order ID is required to modify the order.
311 | Duration type value is illegal.
313* | CQGIC traffic limit is exceeded.
314* | Unknown error occurred during order request processing.
315 | QTS is applicable only for stop and stop/limit orders.
316 | Visible quantity should be specified if and only if iceberg is set or contract is Fixed Income.
317 | Trigger quantity should be specified if and only if QTS is set.
318 | Aggressiveness is applicable only for FI contracts.
319 | Query orders limit exceeded.

(*) A DataError event can be fired containing this error.


%%ItemTitle%%

CQG API Documentation 4.0 - Revised
Invalid Objects
Send Feedback

Glossary Item Box

There are some cases when Nothing should be passed as an event argument, for example when the AccountChanged event is fired with actPositionsReloaded type, the position parameter of the event should be Nothing (Null). If the user application is an ATL Client, an exception will be thrown in such cases.

Starting from v 3.0, CQG API proposes a workaround for this problem: if you use it from an ATL Client, you can notify the CQG API about it via UsedFromATLClient property of CQG API Configuration. In that case, a special instance of corresponding object will be passed as an event argument. For example, in case of CQGPosition: a special not valid instance of CQGPosition will be passed.

Such objects can be differentiated via IsValid Method of CQGCEL.

Note: If you try to access any property/method of such instances, an exception will be thrown.


%%ItemTitle%%

CQG API Documentation 4.0 - Revised
Accessing non-existent collection items
Send Feedback

Glossary Item Box

In the early CQG API (versions 1.0, 1.1) accessing a non-existent collection item resulted in throwing an exception, the way it is usually done in Visual Basic collections.

Starting from version 3.0, CQG API can be adjusted to return "Nothing" in such cases.

The exception method remains, but now users can choose their preferred method.

When a non-existent item is accessed, depending on the CollectionsThrowException setting specified in CQGAPIConfig, the collection will do one of the following:

1. Return "Nothing" if CollectionsThrowException = False

2. Throw an "out-of-bounds" exception if CollectionsThrowException = True


%%ItemTitle%%

CQG API Documentation 4.0 - Revised
Request Interfaces
Send Feedback

Glossary Item Box

The revised API utilizes a new approach to provide historical data.

  1. Create a request object by calling the corresponding CQGCEL method (for example, CQGCEL.CreateConditionRequest).
  2. The request object is created and filled with default/empty values (for example, CQGConditionRequest).
  3. Fill/modify the request object as you need.
  4. Execute the request by calling the corresponding CQGCEL method (for example, CQGCEL.RequestCondition).
  5. The request results are stored in the corresponding collection (for example, CQGCondition).
  6. When further updates occur, the request status changes accordingly (rsInProgress, rsSuccess, rsFailed, rsCanceled)

In this table, you may find the Request interfaces along with their corresponding creation and execution methods and their results collections:

Creating an Empty Request Object | Modifying the Request Object | Executing the Request | Collection Holding the Results
CQGCEL.CreateConditionRequest | CQGConditionRequest | CQGCEL.RequestCondition | CQGCondition
CQGCEL.CreateConstantVolumeBarsRequest | CQGConstantVolumeBarsRequest | CQGCEL.RequestConstantVolumeBars | CQGConstantVolumeBars
CQGCEL.CreateCustomStudyRequest | CQGCustomStudyRequest | CQGCEL.RequestCustomStudy | CQGCustomStudy
CQGCEL.CreateExpressionRequest | CQGExpressionRequest | CQGCEL.RequestExpression | CQGExpression
CQGCEL.CreatePointAndFiguresRequest | CQGPointAndFiguresRequest | CQGCEL.RequestPointAndFigures | CQGPointAndFigures
CQGCEL.CreateTicksRequest | CQGTicksRequest | CQGCEL.RequestTicks | CQGTicks
CQGCEL.CreateTimedBarsRequest | CQGTimedBarsRequest | CQGCEL.RequestTimedBars | CQGTimedBars
CQGCEL.CreateTFlowBarsRequest | CQGTFlowBarsRequest | CQGCEL.RequestTFlowBars | CQGTFlowBars
CQGCEL.CreateTradingSystemRequest | CQGTradingSystemRequest | CQGCEL.RequestTradingSystem | CQGTradingSystem


%%ItemTitle%%

CQG API Documentation 4.0 - Revised
Study Strings
Send Feedback

Glossary Item Box

These study strings can be used to formulate the CQGExpressionRequest.AddSubExpression method's sub_expression parameter.

Please note that strings must be entered in one line.

Study Name | String Entry
Basic Charting
Bar
Open | Open(DJI)
High | High(DJI)
Low | Low(DJI)
Close | Close(DJI)
Mid | Mid(DJI)
HLC3 | HLC3(DJI)
Avg | Avg(DJI)
TrueHigh | TRUHI(DJI)
TrueLow | TRULO(DJI)
Range | Range(DJI)
TrueRange | TRURNG(DJI)
Missing Bar Count | MBCnt(DJI)
ConstantVolume Bar
CVOpen | CVOpen(DJI)
CVHigh | CVHigh(DJI)
CVLow | CVLow(DJI)
CVClose | CVClose(DJI)
CVMid | CVMid(DJI)
CVHLC3 | CVHLC3(DJI)
CVAvg | CVAvg(DJI)
CVTrueHigh | CVTrueHigh(DJI)
CVTrueLow | CVTrueLow(DJI)
CVRange | CVRange(DJI)
CVTrueRange | CVTrueRange(DJI)
Equalize Sessions
ESOpen | ESOpen(DJI,Display:=Bar)
ESHigh | ESHigh(DJI,Display:=Bar)
ESLow | ESLow(DJI,Display:=Bar)
ESClose | ESClose(DJI,Display:=Bar)
ESMid | ESMid(DJI,Display:=Bar)
ESHLC3 | ESHLC3(DJI,Display:=Bar)
ESAvg | ESAvg(DJI,Display:=Bar)
ESRange | ESRange(DJI,Display:=Bar)
Fill Gap
FGOpen | FGOpen(DJI,Display:=Bar)
FGHigh | FGHigh(DJI,Display:=Bar)
FGLow | FGLow(DJI,Display:=Bar)
FGClose | FGClose(DJI,Display:=Bar)
FGMid | FGMid(DJI,Display:=Bar)
FGHLC3 | FGHLC3(DJI,Display:=Bar)
FGAvg | FGAvg(DJI,Display:=Bar)
FGRange | FGRange(DJI,Display:=Bar)
NoGap Bar
NGOpen | NGOpen(DJI,RemoveFrom:=#2)
NGHigh | NGHigh(DJI,RemoveFrom:=#2)
NGLow | NGLow(DJI,RemoveFrom:=#2)
NGClose | NGClose(DJI,RemoveFrom:=#2)
NGMid | NGMid(DJI,RemoveFrom:=#2)
NGHLC3 | NGHLC3(DJI,RemoveFrom:=#2)
NGAvg | NGAvg(DJI,RemoveFrom:=#2)
NGTrueHigh | NGTrueHigh(DJI,RemoveFrom:=2)
NGTrueLow | NGTrueLow(DJI,RemoveFrom:=2)
NGRange | NGRange(DJI,RemoveFrom:=2)
NGTrueRange | NGTrueRange(DJI,RemoveFrom:=2)
Percent Bar
PCOpen | PCOpen(DJI,Base:=20,BaseType:=0)
PCHigh | PCHigh(DJI,Base:=20,BaseType:=0)
PCLow | PCLow(DJI,Base:=20,BaseType:=0)
PCClose | PCClose(DJI,Base:=20,BaseType:=0)
PCMid | PCMid(DJI,Base:=20,BaseType:=0)
PCHLC3 | PCHLC3(DJI,Base:=20,BaseType:=0)
PCAvg | PCAvg(DJI,Base:=20,BaseType:=0)
PCTrueHigh | PCTrueHigh(DJI,Base:=20,BaseType:=0)
PCTrueLow | PCTrueLow(DJI,Base:=20,BaseType:=0)
PCRange | PCRange(DJI,Base:=20,BaseType:=0)
PCTrueRange | PCTrueRange(DJI,Base:=20,BaseType:=0)
Point and Figure Bar
PFMid | PFMid(DJI)
PFHigh | PFHigh(DJI,BoxSize:=1,Reversal:=3)
PFLow | PFLow(DJI,BoxSize:=1,Reversal:=3)
PFUp | PFUp(DJI,BoxSize:=1,Reversal:=3)
TickChart Bar
Tick | Tick(DJI,FlatTicks:=1)
TFlow
TFlow | TFlow(DJI)
TFlow On Balance Volume | TFOBV(DJI)
VolOl Bar
Vol | Vol(DJI)[-2]
TickVol | TickVol(DJI)
Yield Bar
YieldOpen | YieldOpen(US)
YieldHigh | YieldHigh(US)
YieldLow | YieldLow(US)
YieldClose | YieldClose(US)
YieldMid | YieldMid(US)
YieldHLC3 | YieldHLC3(US)
YieldAvg | YieldAvg(US)
YieldTrueHigh | YieldTrueHigh(US)
YieldTrueLow | YieldTrueLow(US)
YieldRange | YieldRange(US)
YieldTrueRange | YieldTrueRange(US)
Basic Studies
Acc Dist
Accumulation/Distribution | A_D(DJI)[0]
Acc Swing
Accumulative Swing Index | ASI(DJI,PriceLimit:=300)[0]
ADX
Average Directional Movement Index | ADX(DJI,Period1:=4)[0]
Average True Range of ADX | ADXATR(DJI,Period1:=4)[0]
Average True Range
Average True Range | ATR(DJI,Type:=Sim,Period:=10)
Bollinger Bands
BBnd MA | BMA(DJI,InputChoice:=Close,MAType:=Sim,Period1:=20)[0]
BBnd High | BHI(DJI,InputChoice:=Close,MAType:=Sim,Period1:=20,Percent:=2.00)[0]
BBnd Low | BLO(DJI,InputChoice:=Close,MAType:=Sim,Period1:=20,Percent:=2.00)[0]
Bollinger Diff
BDif | BDIF(DJI,InputChoice:=Close,MAType:=Sim,Period1:=8,Percent:=1)[0]
CandleStick
CandleStick Formations | CSForm(DJI,Trend1:=5,Trend2:=5,...,Trend8:=5, Range7:=5,Range8:=5,...,Range12:=5)[0]
Channel
Chnl High | CHI(DJI,Period1:=4)[0]
Chnl Low | CLO(DJI,Period1:=4)[0]
CCI
Commodity Channel Index | CCI(DJI,InputChoice:=Open,Period1:=10)[0]
Directional Movement Index
DMI Up | DMIu(DJI,Period1:=10)[0]
DMI Down | DMId(DJI,Period1:=10)[0]
Average True Range | DMIATR(DJI,Period1:=10)[0]
Directional Movement Index Diff
DMI Diff | DDIF(DJI,Period1:=10)[0]
Average True Range | DDIFATR(DJI,Period1:=10)[0]
Elliot Wave
EW Major | EWM(DJI,BarCount:=300)[0]
EW Intermediate | EWI(DJI,BarCount:=300)[0]
EW Channel 1 | EWCh1(DJI,BarCount:=300)[-3]
EW Channel 2 | EWCh2(DJI,BarCount:=300)[0]
EW Channel 3 | EWCh3(DJI,BarCount:=300)[0]
EW PTI | EWPTI(DJI,BarCount:=300)[0]
EW Prj | EWPrj(DJI,BarCount:=300)[0]
Historical Volatility
HVol | HVOL(DJI,InputChoice:=Close,HvolType:=Percent,Period:=10)[0]
Keltner Channel
Kelt Center Line | KCen(DJI,InputChoice:=Close,MAType:=Exp,Period:=21)[0]
Kelt High | KHi(DJI,InputChoice:=Close,MAType:=Exp,Period:=21,MAType1:=Smo,Percent:=0)[0]
Kelt Low | KLo(DJI,InputChoice:=Close,MAType:=Exp,Period:=21,MAType1:=Smo,Percent:=0)[0]
Level
Level High | HiLevel(DJI,InputChoice1:=High,Period1:=20)[0]
Level Low | LoLevel(DJI,InputChoice2:=Low,Period2:=20)[0]
Momentum
Mom | Mom(DJI,InputChoice:=Close,Period:=10)[0]
Moving Average
MA | MA(DJI,InputChoice:=Close,MAType:=Sim,Period:=21)[0]
MA Top Envelope: | MATE(DJI,InputChoice:=Close,MAType:=Sim,Period:=21,Percent:=10)[0]
MA Bottom Envelope: | MABE(DJI,InputChoice:=Close,MAType:=Sim,Period:=21,Percent:=10)[0]
Adaptive Moving Average
Adaptive Moving Average | AMA(DJI,Offset:=0,ERPeriod:=10,FastPeriod:=2,SlowPeriod:=30)
Moving Average Convergence/Divergence
MACD | MACD(DJI,InputChoice:=Close,Period1:=13,Period2:=26)[0]
MACDA | MACDA(DJI,InputChoice:=Close,Period1:=13,Period2:=26,Period3:=9)[0]
Moving Average Cross
Moving Average Cross | Max(DJI,Period:=21)
Moving Linear Regression
Moving Linear Regression | MLR(DJI,Period:=22)
On Balance Volume
OBV | OBV(DJI,InputChoice:=Close)[0]
On Balance Volume, Fancy
FOBV | FOBV(DJI)[0]
Oscillator
OSC | Osc(DJI,InputChoice1:=Close,MAType1:=Sim,Period1:=4, InputChoice2:=Close,MAType2:=Sim,Period2:=8)[0]
Oscillator - MA of Oscillator
OSC - MA OSC | OsMA(DJI,InputChoice1:=Close,MAType1:=Sim,Period1:=4, InputChoice2:=Close,MAType2:=Sim,Period2:=8,MAType3:=Sim,Period3:=3)[0]
Oscillator 1 - Oscillator 2
OSC1 - OSC2 | OsD(DJI,InputChoice1:=Close,MAType1:=Sim,Period1:=4, InputChoice2:=Close, MAType2:=Sim,Period2:=8,InputChoice3:=Close, MAType3:=Sim,Period3:=8, InputChoice4:=Close,MAType4:=Sim,Period4:=16)[0]
Oscillator Cross
Oscillator Cross | OSC(DJI,MA1Type:=Sim,MA1Period:=4,MA2Period:=8,MA1Type:=Sim,Price:=Close)
Aroon Oscillator
Aroon Oscillator | AroonOsc(DJI,Period:=14)
Parabolic
Para | Para(DJI,StepValue:=0.020)[0]
Peak
Peak HiPeak | HiPeak(DJI,InputChoice1:=High,Max1:=Max,Thresh1:=Thresh, Reset1:=XA,LLev1:=LLev,RLev1:=RRlev)[0]
Peak HiCount | HiCount(DJI,InputChoice1:=High,Max1:=Max,Thresh1:=Thresh, Reset1:=XA,LLev1:=LLev,RLev1:=RRlev)[0]
Peak LoPeak | LoPeak(DJI,InputChoice2:=Low,Max2:=Max,Thresh2:=Thresh, Reset2:=XB,LLev2:=LLev,RLev2:=RRlev)[0]
Peak LoCount | LoCount(DJI,InputChoice2:=Low,Max2:=Max,Thresh2:=Thresh, Reset2:=XB,LLev2:=LLev,RLev2:=RRlev)[0]
Percent R
%R | PCR(DJI,InputChoice:=Close,Period:=10)[0]
Rank
Rank | Rank(DJI,Period:=100)
Rate Of Change
ROC | ROC(DJI,InputChoice:=Close,Period:=10)[0]
Relative Strength Index
RSI | RSI(DJI,InputChoice:=Close,Period:=9)[0]
Reversal
Reversal | Rev(DJI,Bars:=1000,Rev:=1)
Square Root Deviation
Sq. Root Dev. | SQRTDV(DJI,InputChoice:=Close,MAType:=Smo,Period1:=8)[0]
Standard Deviation
Std. Dev. | STDDEV(DJI,InputChoice:=Close,Period1:=8)[0]
Stochastics, Fast
Fast %K | FSK(DJI,InputChoice:=Close,Period1:=10)[0]
Fast %D | FSD(DJI,InputChoice:=Close,MAType1:=Smo,Period1:=10,Period2:=3)[0]
Stochastics, Slow
Slow %K (Fast %D) | SSK(DJI,InputChoice:=Close,MAType1:=Smo,Period1:=10,Period2:=3)[0]
Slow %D | SSD(DJI,InputChoice:=Close,MAType1:=Smo,Period1:=10, MAType2:=Smo,Period2:=3,Period3:=3)[0]
Summation
Summation over Period | Sum(DJI,Period:=8)[0]
Accumulation | Accum(DJI)[0]
Triple Exponential
Trix | Trx(DJI,InputChoice:=Close,Period:=5)[0]
Volatility
Volatility | Volat(DJI,Period1:=3)[0]
ZigZag
ZigZag | ZZ(DJI)
Special enablements are required for use of these studies:
Tom Joseph Optimized Bands
OB MA | OBMA(DJI,InputChoice:=Close,Period1:=21)[0]
OB HI | OBHI(DJI,InputChoice:=Close,Period1:=21)[0]
OB LO | OBLO(DJI,InputChoice:=Close,Period1:=21)[0]


%%PageItemTitle%%

CQGAccount Interface
See Also Members Send Feedback

Glossary Item Box

Description

The CQGAccount interface encapsulates all of the information on a trading account along with its positions data.

Object Model

CQGAccount InterfaceCQGStringCollection CollectionCQGCEL InterfaceCQGAccountSummaries CollectionCQGAccountSummary InterfaceCQGOrders CollectionCQGOrder InterfaceCQGOrders CollectionCQGOrder InterfaceCQGPositions CollectionCQGPosition InterfaceCQGAccountSummary Interface

Example

See the usage of CQGAccount object in the AccountChanged event's example section.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGAccount Members


%%PageItemTitle%% $$Members$$

CQGAccount Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property AccountMarginDetailing | Gets account margin detailing level
Public Property AuthorizedTraders | Returns the collection of traders authorized for the account
Public Property AutoSubscribeInstruments | Gets/sets current "auto-subscribe instruments" flag. When the "auto-subscribe instruments" flag is set to True, CQG API automatically requests subscription for each instrument on which current account has a position.
Public Property CEL | Returns the corresponding CQGCEL object.
Public Property CurrencySummaries | Returns the collection of account summaries, one for each account currency.
Public Property DateOfLastStatement | Returns the date of last statement received from the FCM.
Public Property FcmAccountID | Returns the account identifier set by FCM.
Public Property FcmClass | Returns the FCM class.
Public Property FcmID | Returns the FCM identifier.
Public Property FcmName | Returns the FCM name.
Public Property GWAccountID | Returns the account identifier set by CQG Gateway.
Public Property GWAccountName | Returns the CQG Gateway account name.
Public Property InternalOrders | Returns the collection of orders placed for current account from within this CQG API instance.
Public Property MarginCredit | Returns margin credit
Public Property MarginExcess | Returns margin excess
Public Property Orders | Returns the collection containing all active orders placed for current account.
Public Property Positions | Returns the collection of available positions for the current account.
Public Property PositionSubcriptionLevel | Gets/sets the position subscription level for the current account.
Public Property ReportingCurrency | Returns the ISO code of the account's reporting currency.
Public Property ServerTimestamp | Returns timestamp of the last change (server time, converted to the configured time zone). Each account change event forces this property to change its value.
Public Property Summary | Returns the account summary calculated based on account's positions.
Public Property SuppressNotAvailableValues | Whether NA values should be suppressed in TotalPurchasingPower and MarginExcess calculating or not (by default).
Public Property Timestamp | Returns the last response reception timestamp. When a property is updated, CQG API records the information reception time in the Timestamp property (using local time). Each account change event forces this property to change its value.
Public Property TotalMarginValue | Returns total margin value
Public Property TotalPurchasingPower | Returns total purchasing power

See Also

CQGAccount Interface


%%PageItemTitle%%

AccountMarginDetailing Property
See Also Send Feedback
CQGAccount Interface : AccountMarginDetailing Property

Glossary Item Box

Description

Gets account margin detailing level

Property type

Read-write property

Syntax

Visual Basic
Public Property AccountMarginDetailing As eAccountMarginDetailing

See Also

CQGAccount Interface | CQGAccount Members


%%PageItemTitle%%

AuthorizedTraders Property
CQGAccount Interface : AuthorizedTraders Property

Glossary Item Box

Description

Returns the collection of traders authorized for the account

Property type

Read-only property

Syntax

Visual Basic
Public Property AuthorizedTraders As CQGStringCollection

See Also

CQGAccount Interface | CQGAccount Members


%%PageItemTitle%%

AutoSubscribeInstruments Property
CQGAccount Interface : AutoSubscribeInstruments Property

Glossary Item Box

Description

Gets/sets current "auto-subscribe instruments" flag.

When the "auto-subscribe instruments" flag is set to True, CQG API automatically requests subscription for each instrument on which current account has a position.

Property type

Read-write property

Syntax

Visual Basic
Public Property AutoSubscribeInstruments As Boolean

Return Type

True: Instruments referenced by positions will be auto-subscribed.

False: (Default) No instruments are automatically subscribed (may still be subscribed manually).

Remarks

  • In order to have the account's OTE/MVO information calculated and ready in real-time, all the instruments on which the account has positions should be subscribed. Setting this flag to True allows to perform the subscription automatically.
  • Depending on PriceMode setting of the configuration, you may need a different data subscription level for the subscribed instrument. If you need the Asks and Bids information, you need to keep the instrument subscription levels set to dsQuotesAndBBA.
  • This operation is asynchronous—instrument subscriptions and quote retrieval may take some time, during which the OTE/MVO value remains invalid.
  • Some instruments might not be available/enabled. In this case MVO/OTE will not be available.

Example

See the usage of AutoSubscribeInstruments property in the AccountChanged event's example section.

See Also

CQGAccount Interface | CQGAccount Members | CQGInstrument Interface | NewInstrument Method | InstrumentSubscribed Event


%%PageItemTitle%%

CEL Property
CQGAccount Interface : CEL Property

Glossary Item Box

Description

Returns the corresponding CQGCEL object.

Property type

Read-only property

Syntax

Visual Basic
Public Property CEL As CQGCEL

Return Type

CQGCEL object, to which this CQGAccount belongs

Remarks

This property will be convenient for those who are familiar with the VBA specific Parent option.

Example

See the usage of CQGAccount properties in the AccountChanged event's example section.

See Also

CQGAccount Interface | CQGAccount Members | CQGCEL Interface


%%PageItemTitle%%

CurrencySummaries Property
CQGAccount Interface : CurrencySummaries Property

Glossary Item Box

Description

Returns the collection of account summaries, one for each account currency.

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrencySummaries As CQGAccountSummaries

Return Type

Account summaries collection, represented as CQGAccountSummaries

Remarks

  • This collection contains a single CQGAccountSummary object per each currency, in which the account has a position.
  • No adjustment is performed between currencies. Therefore, the CQGAccountSummary object retrieved for the reporting currency does not contain the same values as the account main summary. Moreover, if the account does not have a position based on the reporting currency, then the CurrencySummaries collection will not contain an object for the reporting currency.
  • If all instruments for all positions are not subscribed yet, or there is no information on currency rates, all calculations will return invalid values.

Example

See the usage of CQGAccount properties in the AccountChanged event's example section.

See Also

CQGAccount Interface | CQGAccount Members | Summary Property


%%PageItemTitle%%

DateOfLastStatement Property
CQGAccount Interface : DateOfLastStatement Property

Glossary Item Box

Description

Returns the date of last statement received from the FCM.

Property type

Read-only property

Syntax

Visual Basic
Public Property DateOfLastStatement As Date

Return Type

Date variable, representing the time when last statement was received

Example

See the usage of CQGAccount properties in the AccountChanged event's example section.

See Also

CQGAccount Interface | CQGAccount Members


%%PageItemTitle%%

FcmAccountID Property
CQGAccount Interface : FcmAccountID Property

Glossary Item Box

Description

Returns the account identifier set by FCM.

Property type

Read-only property

Syntax

Visual Basic
Public Property FcmAccountID As String

Return Type

Account identifier, represented as String

Remarks

This identifier is unique per FCM.

Example

See the usage of CQGAccount properties in the AccountChanged event's example section.

See Also

CQGAccount Interface | CQGAccount Members | FcmID Property


%%PageItemTitle%%

FcmClass Property
CQGAccount Interface : FcmClass Property

Glossary Item Box

Description

Returns the FCM class.

Property type

Read-only property

Syntax

Visual Basic
Public Property FcmClass As eFcmClass

Return Type

FCM class, represented as eFcmClass

See Also

CQGAccount Interface | CQGAccount Members | eFcmClass Enumeration


%%PageItemTitle%%

FcmID Property
CQGAccount Interface : FcmID Property

Glossary Item Box

Description

Returns the FCM identifier.

Property type

Read-only property

Syntax

Visual Basic
Public Property FcmID As Long

Return Type

FCM identifier represented as Long

Remarks

Two accounts from the same FCM have the same FCM identifiers. The pair fcmID : FcmAccountID is unique over the CQG system.

Example

See the usage of CQGAccount properties in the AccountChanged event's example section.

See Also

CQGAccount Interface | CQGAccount Members | FcmAccountID Property


%%PageItemTitle%%

FcmName Property
CQGAccount Interface : FcmName Property

Glossary Item Box

Description

Returns the FCM name.

Property type

Read-only property

Syntax

Visual Basic
Public Property FcmName As String

Return Type

FCM name, represented as String

See Also

CQGAccount Interface | CQGAccount Members


%%PageItemTitle%%

GWAccountID Property
CQGAccount Interface : GWAccountID Property

Glossary Item Box

Description

Returns the account identifier set by CQG Gateway.

Property type

Read-only property

Syntax

Visual Basic
Public Property GWAccountID As Long

Return Type

CQG Gateway account identifier represented as Long

Remarks

When a new account is added to the CQG system it gets a unique Gateway identification number.

Example

See the usage of CQGAccount properties in the AccountChanged event's example section.

See Also

CQGAccount Interface | CQGAccount Members


%%PageItemTitle%%

GWAccountName Property
CQGAccount Interface : GWAccountName Property

Glossary Item Box

Description

Returns the CQG Gateway account name.

Property type

Read-only property

Syntax

Visual Basic
Public Property GWAccountName As String

Return Type

Account name stored at the CQG Gateway represented as String

Remarks

This represents the customer specified account name registered at the CQG system while opening the account.

Example

See the usage of GWAccountName property in the OnQueryProgress event's example section.

See Also

CQGAccount Interface | CQGAccount Members


%%PageItemTitle%%

InternalOrders Property
CQGAccount Interface : InternalOrders Property

Glossary Item Box

Description

Returns the collection of orders placed for current account from within this CQG API instance.

Property type

Read-only property

Syntax

Visual Basic
Public Property InternalOrders As CQGOrders

Return Type

CQGOrders collection containing the internal orders of the account.

Remarks

This collection is a subset of the CQGCEL InternalOrders collection. It contains orders referring only to the current account.

In the Remarks section of the InternalOrders Property are given the possible cases of collection orders addition and removal.

This collection is also a subset of CQGAccount.Orders collection. It contains only orders placed from within this CQG API instance.

Example

See the usage of InternalOrders property in the PrepareModify method's example section.

See Also

CQGAccount Interface | CQGAccount Members | CQGOrders Collection | CQGOrder Interface | OrderChanged Event | CQGOrdersQuery Interface


%%PageItemTitle%%

MarginCredit Property
CQGAccount Interface : MarginCredit Property

Glossary Item Box

Description

Returns margin credit

Property type

Read-only property

Syntax

Visual Basic
Public Property MarginCredit As Double

See Also

CQGAccount Interface | CQGAccount Members


%%PageItemTitle%%

MarginExcess Property
CQGAccount Interface : MarginExcess Property

Glossary Item Box

Description

Returns margin excess

Property type

Read-only property

Syntax

Visual Basic
Public Property MarginExcess As Double

See Also

CQGAccount Interface | CQGAccount Members


%%PageItemTitle%%

Orders Property
CQGAccount Interface : Orders Property

Glossary Item Box

Description

Returns the collection containing all active orders placed for current account.

Property type

Read-only property

Syntax

Visual Basic
Public Property Orders As CQGOrders

Return Type

CQGOrders collection containing all orders placed for the account.

Remarks

This collection is a subset of the CQGCEL Orders collection. It contains orders referring only to the current account.

Remarks section of CQGCEL Orders has additional information about orders inclusion and removal.

Example

See the usage of Orders property in the PrepareModify method's example section.

See Also

CQGAccount Interface | CQGAccount Members | Orders Property | InternalOrders Property | CQGOrder Interface | CQGOrders Collection | OrderChanged Event | CQGOrdersQuery Interface


%%PageItemTitle%%

Positions Property
CQGAccount Interface : Positions Property

Glossary Item Box

Description

Returns the collection of available positions for the current account.

Property type

Read-only property

Syntax

Visual Basic
Public Property Positions As CQGPositions

Return Type

CQGPositions collection containing current positions of the account

Remarks

The content of this collection depends on the account's PositionSubcriptionLevel property setting. See remarks for details.

If the subscription level is configured to receive the positions updates, then a new item is added to the collection each time an account obtains new position.

The liquidated positions are not removed from the collection until the end of the trading day. To distinguish the liquidated positions check their Quantity Property. It will be 0 in that case.

Example

See the usage of CQGAccount properties in the AccountChanged event's example section.

See Also

CQGAccount Interface | CQGAccount Members | CQGPosition Interface | CQGPositions Collection


%%PageItemTitle%%

PositionSubcriptionLevel Property
CQGAccount Interface : PositionSubcriptionLevel Property

Glossary Item Box

Description

Gets/sets the position subscription level for the current account.

Property type

Read-write property

Syntax

Visual Basic
Public Property PositionSubcriptionLevel As ePositionSubscriptionLevel

Return Type

Current subscription level represented as ePositionSubscriptionLevel

Remarks

For each account, the setting of this property controls:

  • the content of the Positions collection,
  • the AccountChanged events fired for this account

For details, see the description of ePositionSubscriptionLevel Enumeration.

On startup and accounts reload, this property is reset to the default value for all accounts.

The default value of position subscription level can be set by the DefPositionSubscriptionLevel property of CQG API Configuration.

User can change the position subscription level any time. When the value of this property is changed to pslNoPositions from another value, the positions are not removed from Positions collection.

Note: Changing the subscription level is an asynchronous process, which means that the results are not available immediately.

Example

See the usage of CQGAccount properties in the AccountChanged event's example section.

See Also

CQGAccount Interface | CQGAccount Members | DefPositionSubscriptionLevel Property | CQGPosition Interface | CQGPositions Collection


%%PageItemTitle%%

ReportingCurrency Property
CQGAccount Interface : ReportingCurrency Property

Glossary Item Box

Description

Returns the ISO code of the account's reporting currency.

Property type

Read-only property

Syntax

Visual Basic
Public Property ReportingCurrency As String

Return Type

Reporting currency ISO code represented as String

Remarks

Reporting currency is set by FCM when the account is opened.

Example

See the usage of CQGAccount properties in the AccountChanged event's example section.

See Also

CQGAccount Interface | CQGAccount Members


%%PageItemTitle%%

ServerTimestamp Property
CQGAccount Interface : ServerTimestamp Property

Glossary Item Box

Description

Returns timestamp of the last change (server time, converted to the configured time zone).
Each account change event forces this property to change its value.

Property type

Read-only property

Syntax

Visual Basic
Public Property ServerTimestamp As Date

Return Type

Date variable containing the server timestamp

Remarks

The timestamp is converted to the timezone, previously configured by the user.

If no timezone configuration was made, the timestamp is converted to UTC.

Example

See the usage of CQGAccount properties in the AccountChanged event's example section.

See Also

CQGAccount Interface | CQGAccount Members


%%PageItemTitle%%

Summary Property
CQGAccount Interface : Summary Property

Glossary Item Box

Description

Returns the account summary calculated based on account's positions.

Property type

Read-only property

Syntax

Visual Basic
Public Property Summary As CQGAccountSummary

Return Type

Account summary represented as CQGAccountSummary

Remarks

This property is calculated based on the account's existing summaries for different currencies, converted to the account’s reporting currency.

Each currency’s summary is adjusted by the currency rate to the reporting currency of current FCM, and then summed up.

Note: All the calculations will return invalid values, if at least one position’s instrument is not subscribed yet or there is no information on currency rates.

Example

See the usage of Summary property in the AccountChanged event's example section.

See Also

CQGAccount Interface | CQGAccount Members


%%PageItemTitle%%

SuppressNotAvailableValues Property
CQGAccount Interface : SuppressNotAvailableValues Property

Glossary Item Box

Description

Whether NA values should be suppressed in TotalPurchasingPower and MarginExcess calculating or not (by default).

Property type

Read-write property

Syntax

Visual Basic
Public Property SuppressNotAvailableValues As Boolean

Remarks

Property setter applies new value to Summary and each summary from CurrencySummaries (see CQGAccountSummary.SuppressNotAvailableValues).

See Also

CQGAccount Interface | CQGAccount Members | CQGAccountSummary Interface


%%PageItemTitle%%

Timestamp Property
CQGAccount Interface : Timestamp Property

Glossary Item Box

Description

Returns the last response reception timestamp.

When a property is updated, CQG API records the information reception time in the Timestamp property (using local time).

Each account change event forces this property to change its value.

Property type

Read-only property

Syntax

Visual Basic
Public Property Timestamp As Date

Return Type

Date variable containing the local timestamp

Remarks

The timestamp is converted to the timezone previously configured by the user.

If no timezone configuration was made, the timestamp is converted to UTC.

Example

See the usage of CQGAccount properties in the AccountChanged event's example section.

See Also

CQGAccount Interface | CQGAccount Members


%%PageItemTitle%%

TotalMarginValue Property
CQGAccount Interface : TotalMarginValue Property

Glossary Item Box

Description

Returns total margin value

Property type

Read-only property

Syntax

Visual Basic
Public Property TotalMarginValue As Double

See Also

CQGAccount Interface | CQGAccount Members


%%PageItemTitle%%

TotalPurchasingPower Property
CQGAccount Interface : TotalPurchasingPower Property

Glossary Item Box

Description

Returns total purchasing power

Property type

Read-only property

Syntax

Visual Basic
Public Property TotalPurchasingPower As Double

See Also

CQGAccount Interface | CQGAccount Members


%%PageItemTitle%%

CQGAccountSummary Interface
See Also Members Send Feedback

Glossary Item Box

Description

The CQGAccountSummary interface represents statistical information calculated basing on account's positions. Each summary is calculated in a single currency.

Object Model

CQGAccountSummary InterfaceCQGAccount Interface

Remarks

The properties of CQGAccountSummary interface which are calculated on the fly are available only when corresponding positions' instruments are subscribed, i.e. instruments of those positions which are included in the calculation of current CQGAccountSummary.

Example

See the usage of CQGAccountSummary object in the AccountChanged event's example section.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGAccountSummary Members


%%PageItemTitle%% $$Members$$

CQGAccountSummary Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method Balance | Returns the account balance.
Public Method CashExcess | Returns the account historical cash excess. Historical here means that the most recent cash excess that can be obtained is yesterday's close.
Public Method Collaterals | Returns the account collaterals, which were declared in the last statement.
Public Method InitialMargin | Returns the account historical initial margin. Historical here means that the most recent initial margin that can be obtained is yesterday's close.
Public Method MaintenanceMargin | Returns account historical maintenance margin. Historical here means that the most recent maintenance margin that can be obtained is yesterday's close.
Public Method MVO | Returns the account Market Value Option.
Public Method NLV | Returns account Net Liquidity Value.
Public Method OTE | Returns the Open Trade Equity for the account.
Public Method ProfitLoss | Returns the account's profit/loss value.
Public Method UPL | Returns the account Unrealized Profit/Loss value.

Public Properties

Public Property Account | Returns the corresponding CQGAccount object.
Public Property CurrencyName | Returns the ISO currency code of the summary.
Public Property ManualFillsInvolved | Returns the flag that indicates whether the manual fills are involved in account summary calculation or not.
Public Property SuppressNotAvailableValues | Whether N/A values should be suppressed in summary calculating or not. Value is False by default.

See Also

CQGAccountSummary Interface


%%PageItemTitle%%

Balance Method
day_

The desired day represented as Long:

day_ = 0 (Default): Means "today/current"

day_ > 0: Means "historical value for the specified day back": day_ = 1 (one day back) i.e. "yesterday close", 2 (two days back) i.e. "the day-before-yesterday close" etc.

CQGAccountSummary Interface : Balance Method

Glossary Item Box

Description

Returns the account balance.

Syntax

Visual Basic
Public Function Balance( _
   Optional ByVal day_ As Long = 0 _
) As Double

Parameters

day_

The desired day represented as Long:

day_ = 0 (Default): Means "today/current"

day_ > 0: Means "historical value for the specified day back": day_ = 1 (one day back) i.e. "yesterday close", 2 (two days back) i.e. "the day-before-yesterday close" etc.

Return Type

Balance value represented as Double.

If the requested day_ parameter is 0, the returned value will be based on the current positions.

If the requested day_ parameter is higher than 0, the "close balance" of the requested day will be returned.

If no data is available for the requested day an invalid value will be returned.

Remarks

If the account summary was requested through CQGCEL.QuerySummariesStatement, (which has its Date_ parameter specified) day_ will be ignored.

Note: In this release only one day back (i.e., "yesterday close") value is available.

The balance calculation for the current day adds the previous day's close and the current profit loss. It means that balance calculation requires market data for each instrument in the positions. To subscribe to the necessary market data automatically, set CQGAccount.AutoSubscribeInstruments property value to True and CQGAccount.PositionSubcriptionLevel to ePositionSubscriptionLevel.pslSnapshotAndUpdates.

Example

See the usage of Balance method in the AccountChanged event's example section.

See Also

CQGAccountSummary Interface | CQGAccountSummary Members


%%PageItemTitle%%

CashExcess Method
day_

The desired day represented as Long:

day_ = 1 (Default): Means "yesterday close"

day_ > 1: Means "historical value for the specified day back": 2 (two days back) i.e. "the day-before-yesterday close" etc.

CQGAccountSummary Interface : CashExcess Method

Glossary Item Box

Description

Returns the account historical cash excess.

Historical here means that the most recent cash excess that can be obtained is yesterday's close.

Syntax

Visual Basic
Public Function CashExcess( _
   Optional ByVal day_ As Long = 1 _
) As Double

Parameters

day_

The desired day represented as Long:

day_ = 1 (Default): Means "yesterday close"

day_ > 1: Means "historical value for the specified day back": 2 (two days back) i.e. "the day-before-yesterday close" etc.

Return Type

Cash excess value represented as Double.

If the requested day_ parameter is 1, yesterday close cash excess will be returned.

If the requested day_ parameter is larger than 1, the "close cash excess" of the requested day will be returned.

If no data is available for the requested day an invalid value will be returned.

Remarks

If the account summary was requested through CQGCEL.QuerySummariesStatement, (which has its Date_ parameter specified) day_ will be ignored.

Note: In this release only one day back (i.e., "yesterday close") value is available.

Example

See the usage of CQGAccountSummary methods in the AccountChanged event's example section.

See Also

CQGAccountSummary Interface | CQGAccountSummary Members


%%PageItemTitle%%

Collaterals Method
day_

Specifies the number of days back.

The parameter is reserved for future use. Currently the only valid value is 1, which is the default.

CQGAccountSummary Interface : Collaterals Method

Glossary Item Box

Description

Returns the account collaterals, which were declared in the last statement.

Syntax

Visual Basic
Public Function Collaterals( _
   Optional ByVal day_ As Long = 1 _
) As Double

Parameters

day_

Specifies the number of days back.

The parameter is reserved for future use. Currently the only valid value is 1, which is the default.

Return Type

Collaterals, represented as Double

Remarks

If the account summary was requested through CQGCEL.QuerySummariesStatement, (which has its Date_ parameter specified) day_ will be ignored.

Example

See the usage of CQGAccountSummary methods in the AccountChanged event's example section.

See Also

CQGAccountSummary Interface | CQGAccountSummary Members


%%PageItemTitle%%

InitialMargin Method
day_

The desired day represented as Long:

day_ = 1 (Default): Means "yesterday close"

day_ > 1: Means "historical value for the specified day back": day_ = 2 (two days back) i.e. "the day-before-yesterday close" etc.

CQGAccountSummary Interface : InitialMargin Method

Glossary Item Box

Description

Returns the account historical initial margin.

Historical here means that the most recent initial margin that can be obtained is yesterday's close.

Syntax

Visual Basic
Public Function InitialMargin( _
   Optional ByVal day_ As Long = 1 _
) As Double

Parameters

day_

The desired day represented as Long:

day_ = 1 (Default): Means "yesterday close"

day_ > 1: Means "historical value for the specified day back": day_ = 2 (two days back) i.e. "the day-before-yesterday close" etc.

Return Type

Initial margin value represented as Double.

If the requested day_ parameter is 1, yesterday close initial margin will be returned.

If the requested day_ parameter is higher than 1, the "close initial margin" of the requested day will be returned.

If no data is available for the requested day an invalid value will be returned.

Remarks

If the account summary was requested through CQGCEL.QuerySummariesStatement, (which has its Date_ parameter specified) day_ will be ignored.

Note: In this release only one day back (i.e., "yesterday close") value is available.

Example

See the usage of CQGAccountSummary methods in the AccountChanged event's example section.

See Also

CQGAccountSummary Interface | CQGAccountSummary Members


%%PageItemTitle%%

MaintenanceMargin Method
day_

The desired day represented as Long:

day_ = 1 (Default): Means "yesterday close"

day_ > 1: Means "historical value for the specified day back": day_ = 2 (two days back) i.e. "the day-before-yesterday close" etc.

CQGAccountSummary Interface : MaintenanceMargin Method

Glossary Item Box

Description

Returns account historical maintenance margin.

Historical here means that the most recent maintenance margin that can be obtained is yesterday's close.

Syntax

Visual Basic
Public Function MaintenanceMargin( _
   Optional ByVal day_ As Long = 1 _
) As Double

Parameters

day_

The desired day represented as Long:

day_ = 1 (Default): Means "yesterday close"

day_ > 1: Means "historical value for the specified day back": day_ = 2 (two days back) i.e. "the day-before-yesterday close" etc.

Return Type

Maintenance margin value represented as Double.

If the requested day_ parameter is 1, yesterday close maintenance margin will be returned.

If the requested day_ parameter is higher than 1, the "close maintenance margin" of the requested day will be returned.

If no data is available for the requested day an invalid value will be returned.

Remarks

If the account summary was requested through CQGCEL.QuerySummariesStatement, (which has its Date_ parameter specified) day_ will be ignored.

Note: In this release only one day back (i.e., "yesterday close") value is available.

Example

See the usage of CQGAccountSummary methods in the AccountChanged event's example section.

See Also

CQGAccountSummary Interface | CQGAccountSummary Members


%%PageItemTitle%%

MVO Method
day_

The desired day represented as Long:

day_ = 0 (Default): Means "today/current"

day_ > 0: Means "historical value for the specified day back": day_ = 1 (one day back) i.e. "yesterday close", 2 (two days back) i.e. "the day-before-yesterday close" etc.

CQGAccountSummary Interface : MVO Method

Glossary Item Box

Description

Returns the account Market Value Option.

Syntax

Visual Basic
Public Function MVO( _
   Optional ByVal day_ As Long = 0 _
) As Double

Parameters

day_

The desired day represented as Long:

day_ = 0 (Default): Means "today/current"

day_ > 0: Means "historical value for the specified day back": day_ = 1 (one day back) i.e. "yesterday close", 2 (two days back) i.e. "the day-before-yesterday close" etc.

Return Type

MVO value represented as Double.

If the requested day_ parameter is 0, the returned value will be based on the current positions.

If the requested day_ parameter is higher than 0, the "close MVO" of the requested day will be returned

If no data is available for the requested day an invalid value` will be returned.

Remarks

If the account summary was requested through CQGCEL.QuerySummariesStatement, (which has its Date_ parameter specified) day_ will be ignored.

Note: In this release, in addition to the current value, only one day back (i.e., "yesterday close") is available.

Example

See the usage of MVO method in the AccountChanged event's example section.

See Also

CQGAccountSummary Interface | CQGAccountSummary Members


%%PageItemTitle%%

NLV Method
day_

The desired day represented as Long:

day_ = 0 (Default): Means "today/current"

day_ > 0: Means "historical value for the specified day back": day_ = 1 (one day back) i.e. "yesterday close", 2 (two days back) i.e. "the day-before-yesterday close" etc.

CQGAccountSummary Interface : NLV Method

Glossary Item Box

Description

Returns account Net Liquidity Value.

Syntax

Visual Basic
Public Function NLV( _
   Optional ByVal day_ As Long = 0 _
) As Double

Parameters

day_

The desired day represented as Long:

day_ = 0 (Default): Means "today/current"

day_ > 0: Means "historical value for the specified day back": day_ = 1 (one day back) i.e. "yesterday close", 2 (two days back) i.e. "the day-before-yesterday close" etc.

Return Type

NLV value represented as Double.

If the requested day_ parameter is 0, the returned value will be based on the current positions.

If the requested day_ parameter is higher than 0, the "close NLV" of the requested day will be returned.

If no data is available for the requested day an invlaid value will be returned.

Remarks

If the account summary was requested through CQGCEL.QuerySummariesStatement, (which has its Date_ parameter specified) day_ will be ignored.

Note: In this release, in addition to the current value, only one day back (i.e., "yesterday close") is available.

Example

See the usage of CQGAccountSummary methods in the AccountChanged event's example section.

See Also

CQGAccountSummary Interface | CQGAccountSummary Members


%%PageItemTitle%%

OTE Method
day_

The desired day represented as Long:

day_ = 0 (Default): Means "today/current"

day_ > 0: Means "historical value for the specified day back": day_ = 1 (one day back) i.e. "yesterday close", 2 (two days back) i.e. "the day-before-yesterday close" etc.

CQGAccountSummary Interface : OTE Method

Glossary Item Box

Description

Returns the Open Trade Equity for the account.

Syntax

Visual Basic
Public Function OTE( _
   Optional ByVal day_ As Long = 0 _
) As Double

Parameters

day_

The desired day represented as Long:

day_ = 0 (Default): Means "today/current"

day_ > 0: Means "historical value for the specified day back": day_ = 1 (one day back) i.e. "yesterday close", 2 (two days back) i.e. "the day-before-yesterday close" etc.

Return Type

OTE value represented as Double.

If the requested day_ parameter is 0, the returned value will be based on the current positions.

If the requested day_ parameter is higher than 0, the "close OTE" of the requested day will be returned.

If no data is available for the requested day an invalid value will be returned.

Remarks

If the account summary was requested through CQGCEL.QuerySummariesStatement, (which has its Date_ parameter specified) day_ will be ignored.

Note: In this release, in addition to the current value, only one day back (i.e., "yesterday close") is available.

Example

See the usage of OTE method in the AccountChanged event's example section.

See Also

CQGAccountSummary Interface | CQGAccountSummary Members


%%PageItemTitle%%

ProfitLoss Method
day_

The desired day represented as Long:

day_ = 0 (Default): Returns the 'current' value, which depends on current positions and quotes.

day_ > 0: Returns the historical profit/loss value, where 1 means "yesterday close" value, etc.

CQGAccountSummary Interface : ProfitLoss Method

Glossary Item Box

Description

Returns the account's profit/loss value.

Syntax

Visual Basic
Public Function ProfitLoss( _
   Optional ByVal day_ As Long = 1 _
) As Double

Parameters

day_

The desired day represented as Long:

day_ = 0 (Default): Returns the 'current' value, which depends on current positions and quotes.

day_ > 0: Returns the historical profit/loss value, where 1 means "yesterday close" value, etc.

Return Type

Profit and loss value, represented as Double.

If the requested day parameter is 0, the current profit and loss value will be returned.

If the requested day parameter is larger than 0, the close profit and loss of the requested day will be returned.

If no data is available for the requested day an invalid value will be returned.

Remarks

If the account summary was requested through CQGCEL.QuerySummariesStatement, (which has its Date_ parameter specified) day_ will be ignored.

See Also

CQGAccountSummary Interface | CQGAccountSummary Members


%%PageItemTitle%%

UPL Method
day_

The desired day represented as Long:

day_ = 0 (Default): Means "today/current"

day_ > 0: Means "historical value for the specified day back": day_ = 1 (one day back) i.e. "yesterday close", 2 (two days back) i.e. "the day-before-yesterday close" etc.

CQGAccountSummary Interface : UPL Method

Glossary Item Box

Description

Returns the account Unrealized Profit/Loss value.

Syntax

Visual Basic
Public Function UPL( _
   Optional ByVal day_ As Long = 0 _
) As Double

Parameters

day_

The desired day represented as Long:

day_ = 0 (Default): Means "today/current"

day_ > 0: Means "historical value for the specified day back": day_ = 1 (one day back) i.e. "yesterday close", 2 (two days back) i.e. "the day-before-yesterday close" etc.

Return Type

UPL value represented as Double.

If the requested day parameter is 0, the returned value will be based on the current positions.

If the requested day parameter is higher than 0, the "close UPL" of the requested day will be returned.

If no data is available for the requested day an invalid value will be returned.

Remarks

If the account summary was requested through CQGCEL.QuerySummariesStatement, (which has its Date_ parameter specified) day_ will be ignored.

Note: In this release, in addition to the current value, only one day back (i.e., "yesterday close") is available.

Example

See the usage of CQGAccountSummary methods in the AccountChanged event's example section.

See Also

CQGAccountSummary Interface | CQGAccountSummary Members


%%PageItemTitle%%

Account Property
CQGAccountSummary Interface : Account Property

Glossary Item Box

Description

Returns the corresponding CQGAccount object.

Property type

Read-only property

Syntax

Visual Basic
Public Property Account As CQGAccount

Return Type

CQGAccount object to which this CQGAccountSummary belongs

Remarks

This property will be convenient for those who are familiar with the VBA specific Parent option.

Example

See the usage of CQGAccountSummary properties in the AccountChanged event's example section.

See Also

CQGAccountSummary Interface | CQGAccountSummary Members


%%PageItemTitle%%

CurrencyName Property
CQGAccountSummary Interface : CurrencyName Property

Glossary Item Box

Description

Returns the ISO currency code of the summary.

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrencyName As String

Return Type

Currency ISO code represented as String

Remarks

The property identifies the currency in which all values of the summary are calculated.

Example

See the usage of CQGAccountSummary properties in the AccountChanged event's example section.

See Also

CQGAccountSummary Interface | CQGAccountSummary Members


%%PageItemTitle%%

ManualFillsInvolved Property
CQGAccountSummary Interface : ManualFillsInvolved Property

Glossary Item Box

Description

Returns the flag that indicates whether the manual fills are involved in account summary calculation or not.

Property type

Read-only property

Syntax

Visual Basic
Public Property ManualFillsInvolved As Boolean

Return Type

True if manual fills are involved, False otherwise

Remarks

See Also

CQGAccountSummary Interface | CQGAccountSummary Members | CQGManualFills Collection | CQGManualFillRequest Interface


%%PageItemTitle%%

SuppressNotAvailableValues Property
CQGAccountSummary Interface : SuppressNotAvailableValues Property

Glossary Item Box

Description

Whether N/A values should be suppressed in summary calculating or not. Value is False by default.

Property type

Read-write property

Syntax

Visual Basic
Public Property SuppressNotAvailableValues As Boolean

Remarks

By default, API returns an invalid value if at least a single operand in the calculated summary value is N/A. Set this property value to True to skip such operands and continue the calculation.

Example: there are three open positions for three different instruments. There is no access to market data for one of the instruments. By default, CQGAccountSummary.Balance(0) call will return an invalid value. If the property value is True, API will skip the unavailable profit loss value and calculate the balance using only available ones.

See Also

CQGAccountSummary Interface | CQGAccountSummary Members


%%PageItemTitle%%

CQGAdvancedStudyDefinition Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a definition of advanced study

Object Model

CQGAdvancedStudyDefinition InterfaceCQGCurveDefinitions CollectionCQGCurveDefinition InterfaceCQGParameterDefinitions CollectionCQGParameterDefinition Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGAdvancedStudyDefinition Members


%%PageItemTitle%% $$Members$$

CQGAdvancedStudyDefinition Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Abbreviation | Returns the advanced study abbreviation
Public Property CurveDefinitions | Returns the all curves definitions
Public Property Name | Returns the advanced study name
Public Property ParameterDefinitions | Returns the all parameters definitions

See Also

CQGAdvancedStudyDefinition Interface


%%PageItemTitle%%

Abbreviation Property
CQGAdvancedStudyDefinition Interface : Abbreviation Property

Glossary Item Box

Description

Returns the advanced study abbreviation

Property type

Read-only property

Syntax

Visual Basic
Public Property Abbreviation As String

See Also

CQGAdvancedStudyDefinition Interface | CQGAdvancedStudyDefinition Members


%%PageItemTitle%%

CurveDefinitions Property
CQGAdvancedStudyDefinition Interface : CurveDefinitions Property

Glossary Item Box

Description

Returns the all curves definitions

Property type

Read-only property

Syntax

Visual Basic
Public Property CurveDefinitions As CQGCurveDefinitions

See Also

CQGAdvancedStudyDefinition Interface | CQGAdvancedStudyDefinition Members


%%PageItemTitle%%

Name Property
CQGAdvancedStudyDefinition Interface : Name Property

Glossary Item Box

Description

Returns the advanced study name

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

CQGAdvancedStudyDefinition Interface | CQGAdvancedStudyDefinition Members


%%PageItemTitle%%

ParameterDefinitions Property
CQGAdvancedStudyDefinition Interface : ParameterDefinitions Property

Glossary Item Box

Description

Returns the all parameters definitions

Property type

Read-only property

Syntax

Visual Basic
Public Property ParameterDefinitions As CQGParameterDefinitions

See Also

CQGAdvancedStudyDefinition Interface | CQGAdvancedStudyDefinition Members


%%PageItemTitle%%

CQGAdvancedStudyRequest Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents parameters for advanced study request

Object Model

CQGAdvancedStudyRequest InterfaceCQGAdvancedStudyDefinition Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGAdvancedStudyRequest Members


%%PageItemTitle%% $$Members$$

CQGAdvancedStudyRequest Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method IncludeCurve | Includes the specified curve (advanced study output) to be present in the requested advanced study
Public Method IsCurveIncluded | Returns whether the specified curve (advanced study output) is currently included

Public Properties

Public Property BaseExpression | Sets the base expression which will be used in advanced study request (required)
Public Property Continuation | Sets the continuation type which will be used in advanced study request
Public Property DaysBeforeExpiration | Sets the number of days prior to expiration the rollover will occur to be used in advanced study request
Public Property Definition | Returns the advanced study definition
Public Property EqualizeCloses | Sets the equalize closes flag which will be used in advanced study request
Public Property HistoricalPeriod | Sets the historical period which will be used in advanced study request
Public Property IncludeEnd | Sets the include end flag which will be used in advanced study request
Public Property IntradayPeriod | Sets the intraday period which will be used in advanced study request
Public Property Parameter | Sets the parameter value which will be used in advanced study request
Public Property RangeEnd | Sets the range end which will be used in advanced study request (required)
Public Property RangeStart | Sets the range start which will be used in advanced study request (required)
Public Property RecalcPeriod | Sets the recalculation period which will be used in advanced study request
Public Property SessionFlags | Sets the session flags which will be used in advanced study request
Public Property SessionsFilter | Sets the sessions filter which will be used in advanced study request
Public Property SubscriptionLevel | Sets the subscription level which will be used in advanced study request
Public Property UpdatesEnabled | Sets the updates enabled flag which will be used in advanced study request

See Also

CQGAdvancedStudyRequest Interface


%%PageItemTitle%%

IncludeCurve Method
curve_key

Curve number or curve name

CQGAdvancedStudyRequest Interface : IncludeCurve Method

Glossary Item Box

Description

Includes the specified curve (advanced study output) to be present in the requested advanced study

Syntax

Visual Basic
Public Sub IncludeCurve( _
   ByVal curve_key As Variant _
)

Parameters

curve_key

Curve number or curve name

See Also

CQGAdvancedStudyRequest Interface | CQGAdvancedStudyRequest Members


%%PageItemTitle%%

IsCurveIncluded Method
curve_key

Curve number or curve name

CQGAdvancedStudyRequest Interface : IsCurveIncluded Method

Glossary Item Box

Description

Returns whether the specified curve (advanced study output) is currently included

Syntax

Visual Basic
Public Function IsCurveIncluded( _
   ByVal curve_key As Variant _
) As Boolean

Parameters

curve_key

Curve number or curve name

See Also

CQGAdvancedStudyRequest Interface | CQGAdvancedStudyRequest Members


%%PageItemTitle%%

BaseExpression Property
CQGAdvancedStudyRequest Interface : BaseExpression Property

Glossary Item Box

Description

Sets the base expression which will be used in advanced study request (required)

Property type

Read-write property

Syntax

Visual Basic
Public Property BaseExpression As String

See Also

CQGAdvancedStudyRequest Interface | CQGAdvancedStudyRequest Members


%%PageItemTitle%%

Continuation Property
CQGAdvancedStudyRequest Interface : Continuation Property

Glossary Item Box

Description

Sets the continuation type which will be used in advanced study request

Property type

Read-write property

Syntax

Visual Basic
Public Property Continuation As eTimeSeriesContinuationType

See Also

CQGAdvancedStudyRequest Interface | CQGAdvancedStudyRequest Members


%%PageItemTitle%%

DaysBeforeExpiration Property
CQGAdvancedStudyRequest Interface : DaysBeforeExpiration Property

Glossary Item Box

Description

Sets the number of days prior to expiration the rollover will occur to be used in advanced study request

Property type

Read-write property

Syntax

Visual Basic
Public Property DaysBeforeExpiration As Long

See Also

CQGAdvancedStudyRequest Interface | CQGAdvancedStudyRequest Members


%%PageItemTitle%%

Definition Property
CQGAdvancedStudyRequest Interface : Definition Property

Glossary Item Box

Description

Returns the advanced study definition

Property type

Read-only property

Syntax

Visual Basic
Public Property Definition As CQGAdvancedStudyDefinition

See Also

CQGAdvancedStudyRequest Interface | CQGAdvancedStudyRequest Members


%%PageItemTitle%%

EqualizeCloses Property
CQGAdvancedStudyRequest Interface : EqualizeCloses Property

Glossary Item Box

Description

Sets the equalize closes flag which will be used in advanced study request

Property type

Read-write property

Syntax

Visual Basic
Public Property EqualizeCloses As Boolean

See Also

CQGAdvancedStudyRequest Interface | CQGAdvancedStudyRequest Members


%%PageItemTitle%%

HistoricalPeriod Property
CQGAdvancedStudyRequest Interface : HistoricalPeriod Property

Glossary Item Box

Description

Sets the historical period which will be used in advanced study request

Property type

Read-write property

Syntax

Visual Basic
Public Property HistoricalPeriod As eHistoricalPeriod

See Also

CQGAdvancedStudyRequest Interface | CQGAdvancedStudyRequest Members


%%PageItemTitle%%

IncludeEnd Property
CQGAdvancedStudyRequest Interface : IncludeEnd Property

Glossary Item Box

Description

Sets the include end flag which will be used in advanced study request

Property type

Read-write property

Syntax

Visual Basic
Public Property IncludeEnd As Boolean

Remarks

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGAdvancedStudyRequest Interface | CQGAdvancedStudyRequest Members


%%PageItemTitle%%

IntradayPeriod Property
CQGAdvancedStudyRequest Interface : IntradayPeriod Property

Glossary Item Box

Description

Sets the intraday period which will be used in advanced study request

Property type

Read-write property

Syntax

Visual Basic
Public Property IntradayPeriod As Long

See Also

CQGAdvancedStudyRequest Interface | CQGAdvancedStudyRequest Members


%%PageItemTitle%%

Parameter Property
key_

Parameter key

CQGAdvancedStudyRequest Interface : Parameter Property

Glossary Item Box

Description

Sets the parameter value which will be used in advanced study request

Property type

Read-write property

Syntax

Visual Basic
Public Property Parameter( _
   ByVal key_ As Variant _
) As Variant

Parameters

key_

Parameter key

Return Type

Parameter value

See Also

CQGAdvancedStudyRequest Interface | CQGAdvancedStudyRequest Members


%%PageItemTitle%%

RangeEnd Property
CQGAdvancedStudyRequest Interface : RangeEnd Property

Glossary Item Box

Description

Sets the range end which will be used in advanced study request (required)

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeEnd As Variant

Remarks

Only Date and integer are allowed for types of RangeStart/RangeEnd properties.

  • If the type is Date, RangeStart/RangeEnd represent date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode). Non-timed bar requests process date/time range values with a precision of up to minutes.
  • All combinations of Date and integer can apply for these properties, except integer/Date.
  • If RangeEnd type is integer, then it represents the count of records prior to RangeStart to be requested, so it must be a negative value.
  • If RangeEnd is date, it must be further in time than RangeStart.

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGAdvancedStudyRequest Interface | CQGAdvancedStudyRequest Members


%%PageItemTitle%%

RangeStart Property
CQGAdvancedStudyRequest Interface : RangeStart Property

Glossary Item Box

Description

Sets the range start which will be used in advanced study request (required)

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeStart As Variant

Remarks

Only Date and integer are allowed for types of RangeStart/RangeEnd properties:

  • All combinations of Date and Integer can apply for these properties, except Integer/Date.
  • If type is Date, RangeStart represents date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode). Non-timed bar requests process date/time range values with a precision of up to minutes.
  • If type is Integer, RangeStart represents the current condition's result number (0 is the current condition result number, negative numbers represent condition results in the past, positive numbers - in the future).
  • If the type of RangeStart is integer, it shall be 0 (denoting "current").

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGAdvancedStudyRequest Interface | CQGAdvancedStudyRequest Members


%%PageItemTitle%%

RecalcPeriod Property
CQGAdvancedStudyRequest Interface : RecalcPeriod Property

Glossary Item Box

Description

Sets the recalculation period which will be used in advanced study request

Property type

Read-write property

Syntax

Visual Basic
Public Property RecalcPeriod As Long

See Also

CQGAdvancedStudyRequest Interface | CQGAdvancedStudyRequest Members


%%PageItemTitle%%

SessionFlags Property
CQGAdvancedStudyRequest Interface : SessionFlags Property

Glossary Item Box

Description

Sets the session flags which will be used in advanced study request

Property type

Read-write property

Syntax

Visual Basic
Public Property SessionFlags As eSessionFlag

See Also

CQGAdvancedStudyRequest Interface | CQGAdvancedStudyRequest Members


%%PageItemTitle%%

SessionsFilter Property
CQGAdvancedStudyRequest Interface : SessionsFilter Property

Glossary Item Box

Description

Sets the sessions filter which will be used in advanced study request

Property type

Read-write property

Syntax

Visual Basic
Public Property SessionsFilter As Variant

See Also

CQGAdvancedStudyRequest Interface | CQGAdvancedStudyRequest Members


%%PageItemTitle%%

SubscriptionLevel Property
CQGAdvancedStudyRequest Interface : SubscriptionLevel Property

Glossary Item Box

Description

Sets the subscription level which will be used in advanced study request

Property type

Read-write property

Syntax

Visual Basic
Public Property SubscriptionLevel As eTimeSeriesSubscriptionLevel

See Also

CQGAdvancedStudyRequest Interface | CQGAdvancedStudyRequest Members


%%PageItemTitle%%

UpdatesEnabled Property
CQGAdvancedStudyRequest Interface : UpdatesEnabled Property

Glossary Item Box

Description

Sets the updates enabled flag which will be used in advanced study request

Property type

Read-write property

Syntax

Visual Basic
Public Property UpdatesEnabled As Boolean

See Also

CQGAdvancedStudyRequest Interface | CQGAdvancedStudyRequest Members


%%PageItemTitle%%

CQGAlgorithmicOrderDefinition Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a definition of a algorithmic order property.

Object Model

CQGAlgorithmicOrderDefinition InterfaceCQGStringCollection Collection

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGAlgorithmicOrderDefinition Members


%%PageItemTitle%% $$Members$$

CQGAlgorithmicOrderDefinition Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method AddValue

Adds a definition value to the collection, if the property type is list.

Public Properties

Public Property DefaultValue | Sets/gets the default value of the property.
Public Property DefaultValueIndex | Sets the default value index if property type is list
Public Property Name | Sets/gets the name of the property.
Public Property Type | Gets/sets the type of the property.
Public Property Unit | Gets/sets the unit (like 'number of contracts', 'percents', etc.) of the property.
Public Property Values | Returns values of the algorithmic order definition if the property type is list.

See Also

CQGAlgorithmicOrderDefinition Interface


%%PageItemTitle%%

AddValue Method
value_

The value to be added to the algorithmic order definition list, represented as String

CQGAlgorithmicOrderDefinition Interface : AddValue Method

Glossary Item Box

Description

Adds a definition value to the collection, if the property type is list.

Syntax

Visual Basic
Public Sub AddValue( _
   ByVal value_ As String _
)

Parameters

value_

The value to be added to the algorithmic order definition list, represented as String

Remarks

This property is not valid if the algorithmic order property type is not aoptList.

See Also

CQGAlgorithmicOrderDefinition Interface | CQGAlgorithmicOrderDefinition Members | eAlgorithmicOrderPropertyType Enumeration | Type Property


%%PageItemTitle%%

DefaultValue Property
CQGAlgorithmicOrderDefinition Interface : DefaultValue Property

Glossary Item Box

Description

Sets/gets the default value of the property.

Property type

Read-write property

Syntax

Visual Basic
Public Property DefaultValue As Variant

Return Type

Default value, represented as Variant

Remarks

This property is not valid if algorithmic order property type is aoptList.

See Also

CQGAlgorithmicOrderDefinition Interface | CQGAlgorithmicOrderDefinition Members


%%PageItemTitle%%

DefaultValueIndex Property
CQGAlgorithmicOrderDefinition Interface : DefaultValueIndex Property

Glossary Item Box

Description

Sets the default value index if property type is list

Property type

Read-write property

Syntax

Visual Basic
Public Property DefaultValueIndex As Long

See Also

CQGAlgorithmicOrderDefinition Interface | CQGAlgorithmicOrderDefinition Members


%%PageItemTitle%%

Name Property
CQGAlgorithmicOrderDefinition Interface : Name Property

Glossary Item Box

Description

Sets/gets the name of the property.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name As String

Return Type

Property name, represented as String

See Also

CQGAlgorithmicOrderDefinition Interface | CQGAlgorithmicOrderDefinition Members


%%PageItemTitle%%

Type Property
CQGAlgorithmicOrderDefinition Interface : Type Property

Glossary Item Box

Description

Gets/sets the type of the property.

Property type

Read-write property

Syntax

Visual Basic
Public Property Type As eAlgorithmicOrderPropertyType

Return Type

Property type, represented as eAlgorithmicOrderPropertyType

See Also

CQGAlgorithmicOrderDefinition Interface | CQGAlgorithmicOrderDefinition Members


%%PageItemTitle%%

Unit Property
CQGAlgorithmicOrderDefinition Interface : Unit Property

Glossary Item Box

Description

Gets/sets the unit (like 'number of contracts', 'percents', etc.) of the property.

Property type

Read-write property

Syntax

Visual Basic
Public Property Unit As String

Return Type

Measurement unit, represented as String

See Also

CQGAlgorithmicOrderDefinition Interface | CQGAlgorithmicOrderDefinition Members


%%PageItemTitle%%

Values Property
CQGAlgorithmicOrderDefinition Interface : Values Property

Glossary Item Box

Description

Returns values of the algorithmic order definition if the property type is list.

Property type

Read-only property

Syntax

Visual Basic
Public Property Values As CQGStringCollection

Return Type

Collection of the algorithmic order definition values, represented as CQGStringCollection

Remarks

This property is not valid if algorithmic order property type is not aoptList.

See Also

CQGAlgorithmicOrderDefinition Interface | CQGAlgorithmicOrderDefinition Members


%%PageItemTitle%%

CQGAlgorithmicOrderParameters Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents parameters of the algorithmic order.

For a list of all members defined in this module, see CQGAlgorithmicOrderParameters members.

Object Model

CQGAlgorithmicOrderParameters Interface

Remarks

These parameters are used to create and place CQGOrder-s for this algorithmic order type.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGAlgorithmicOrderParameters Members


%%PageItemTitle%% $$Members$$

CQGAlgorithmicOrderParameters Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property DurationType | The duration of the order.
Public Property ExecutionInstructions | Returns the execution instructions of the order.
Public Property ExecutionPattern | Returns the execution pattern of the synthetic strategy order.
Public Property GTD | The good-till-date value of the order.
Public Property GWAccountID | CQG Gateway identifier of the account, to which this order belongs.
Public Property InstrumentName | The full name of the instrument, on which this order is placed.
Public Property OpenCloseInstruction | Returns open/close instruction of the order
Public Property Parked | This property specifies whether the order is parked or not.
Public Property PreferredTrailingPeg | Returns the preferred trailing peg.
Public Property Price | Price of the order.
Public Property Quantity | The quantity of the order.
Public Property QuantityFractional | Returns the fractional quantity of the order
Public Property Side | The side of the order.
Public Property SpeculationType | Returns speculation type of the order
Public Property StopLimitPrice | Returns the limit price of the StopLimit order.
Public Property TrailingOffset | Returns the offset of the trailing order.
Public Property TriggerQuantity | Returns the DOM quantity threshold of the QTS order.
Public Property Type | The type of the order.
Public Property VisibleQuantity | Returns visible quantity of the Iceberg order.

See Also

CQGAlgorithmicOrderParameters Interface


%%PageItemTitle%%

DurationType Property
CQGAlgorithmicOrderParameters Interface : DurationType Property

Glossary Item Box

Description

The duration of the order.

Property type

Read-only property

Syntax

Visual Basic
Public Property DurationType As eOrderDuration

Return Type

Order duration, represented as eOrderDuration

See Also

CQGAlgorithmicOrderParameters Interface | CQGAlgorithmicOrderParameters Members


%%PageItemTitle%%

ExecutionInstructions Property
CQGAlgorithmicOrderParameters Interface : ExecutionInstructions Property

Glossary Item Box

Description

Returns the execution instructions of the order.

Property type

Read-only property

Syntax

Visual Basic
Public Property ExecutionInstructions As eOrderExecutionInstruction

Return Type

Execution instructions, represented as eOrderExecutionInstruction

See Also

CQGAlgorithmicOrderParameters Interface | CQGAlgorithmicOrderParameters Members


%%PageItemTitle%%

ExecutionPattern Property
CQGAlgorithmicOrderParameters Interface : ExecutionPattern Property

Glossary Item Box

Description

Returns the execution pattern of the synthetic strategy order.

Property type

Read-only property

Syntax

Visual Basic
Public Property ExecutionPattern As String

Return Type

Execution pattern, represented as String

See Also

CQGAlgorithmicOrderParameters Interface | CQGAlgorithmicOrderParameters Members


%%PageItemTitle%%

GTD Property
CQGAlgorithmicOrderParameters Interface : GTD Property

Glossary Item Box

Description

The good-till-date value of the order.

Property type

Read-only property

Syntax

Visual Basic
Public Property GTD As Date

Return Type

Good-till-date value, represented as Date

Remarks

This property is available if order CQGAlgorithmicOrderParameters.DurationType is odGoodTillDate.

See Also

CQGAlgorithmicOrderParameters Interface | CQGAlgorithmicOrderParameters Members


%%PageItemTitle%%

GWAccountID Property
CQGAlgorithmicOrderParameters Interface : GWAccountID Property

Glossary Item Box

Description

CQG Gateway identifier of the account, to which this order belongs.

Property type

Read-only property

Syntax

Visual Basic
Public Property GWAccountID As Long

Return Type

CQG Gateway account identifier, represented as Long

See Also

CQGAlgorithmicOrderParameters Interface | CQGAlgorithmicOrderParameters Members


%%PageItemTitle%%

InstrumentName Property
CQGAlgorithmicOrderParameters Interface : InstrumentName Property

Glossary Item Box

Description

The full name of the instrument, on which this order is placed.

Property type

Read-only property

Syntax

Visual Basic
Public Property InstrumentName As String

Return Type

Instrument name, represented as String

See Also

CQGAlgorithmicOrderParameters Interface | CQGAlgorithmicOrderParameters Members


%%PageItemTitle%%

OpenCloseInstruction Property
CQGAlgorithmicOrderParameters Interface : OpenCloseInstruction Property

Glossary Item Box

Description

Returns open/close instruction of the order

Property type

Read-only property

Syntax

Visual Basic
Public Property OpenCloseInstruction As eOpenCloseInstruction

See Also

CQGAlgorithmicOrderParameters Interface | CQGAlgorithmicOrderParameters Members


%%PageItemTitle%%

Parked Property
CQGAlgorithmicOrderParameters Interface : Parked Property

Glossary Item Box

Description

This property specifies whether the order is parked or not.

Property type

Read-only property

Syntax

Visual Basic
Public Property Parked As Boolean

Return Type

True if the order is parked, False otherwise

See Also

CQGAlgorithmicOrderParameters Interface | CQGAlgorithmicOrderParameters Members


%%PageItemTitle%%

PreferredTrailingPeg Property
CQGAlgorithmicOrderParameters Interface : PreferredTrailingPeg Property

Glossary Item Box

Description

Returns the preferred trailing peg.

Property type

Read-only property

Syntax

Visual Basic
Public Property PreferredTrailingPeg As eOrderTrailingPeg

Return Type

Preferred trailing peg, represented as eOrderTrailingPeg

See Also

CQGAlgorithmicOrderParameters Interface | CQGAlgorithmicOrderParameters Members


%%PageItemTitle%%

Price Property
CQGAlgorithmicOrderParameters Interface : Price Property

Glossary Item Box

Description

Price of the order.

Property type

Read-only property

Syntax

Visual Basic
Public Property Price As Double

Return Type

Order price, represented as Double

Remarks

The limit or stop price of the order depends on CQGAlgorithmicOrderParameters.Type.

See Also

CQGAlgorithmicOrderParameters Interface | CQGAlgorithmicOrderParameters Members


%%PageItemTitle%%

Quantity Property
CQGAlgorithmicOrderParameters Interface : Quantity Property

Glossary Item Box

Description

The quantity of the order.

Property type

Read-only property

Syntax

Visual Basic
Public Property Quantity As Long

Return Type

Order quantity, represented as Long

Remarks

If the setting of CQGAPIConfig.UseOrderSide is set to False, the side of the order should also be taken into account when setting this property.

See Also

CQGAlgorithmicOrderParameters Interface | CQGAlgorithmicOrderParameters Members


%%PageItemTitle%%

QuantityFractional Property
CQGAlgorithmicOrderParameters Interface : QuantityFractional Property

Glossary Item Box

Description

Returns the fractional quantity of the order

Property type

Read-only property

Syntax

Visual Basic
Public Property QuantityFractional As Decimal

See Also

CQGAlgorithmicOrderParameters Interface | CQGAlgorithmicOrderParameters Members


%%PageItemTitle%%

Side Property
CQGAlgorithmicOrderParameters Interface : Side Property

Glossary Item Box

Description

The side of the order.

Property type

Read-only property

Syntax

Visual Basic
Public Property Side As eOrderSide

Return Type

Order side, represented as eOrderSide

Remarks

If the setting of CQGAPIConfig.UseOrderSide is set to False, the side of the order should be given via CQGAlgorithmicOrderParameters.Quantity property sign.

See Also

CQGAlgorithmicOrderParameters Interface | CQGAlgorithmicOrderParameters Members


%%PageItemTitle%%

SpeculationType Property
CQGAlgorithmicOrderParameters Interface : SpeculationType Property

Glossary Item Box

Description

Returns speculation type of the order

Property type

Read-only property

Syntax

Visual Basic
Public Property SpeculationType As eSpeculationType

See Also

CQGAlgorithmicOrderParameters Interface | CQGAlgorithmicOrderParameters Members


%%PageItemTitle%%

StopLimitPrice Property
CQGAlgorithmicOrderParameters Interface : StopLimitPrice Property

Glossary Item Box

Description

Returns the limit price of the StopLimit order.

Property type

Read-only property

Syntax

Visual Basic
Public Property StopLimitPrice As Double

Return Type

Limit price, represented as Double

See Also

CQGAlgorithmicOrderParameters Interface | CQGAlgorithmicOrderParameters Members


%%PageItemTitle%%

TrailingOffset Property
CQGAlgorithmicOrderParameters Interface : TrailingOffset Property

Glossary Item Box

Description

Returns the offset of the trailing order.

Property type

Read-only property

Syntax

Visual Basic
Public Property TrailingOffset As Double

Return Type

Trailing offset, represented as Double

See Also

CQGAlgorithmicOrderParameters Interface | CQGAlgorithmicOrderParameters Members


%%PageItemTitle%%

TriggerQuantity Property
CQGAlgorithmicOrderParameters Interface : TriggerQuantity Property

Glossary Item Box

Description

Returns the DOM quantity threshold of the QTS order.

Property type

Read-only property

Syntax

Visual Basic
Public Property TriggerQuantity As Long

Return Type

DOM quantity threshold, represented as Long

See Also

CQGAlgorithmicOrderParameters Interface | CQGAlgorithmicOrderParameters Members


%%PageItemTitle%%

Type Property
CQGAlgorithmicOrderParameters Interface : Type Property

Glossary Item Box

Description

The type of the order.

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As eOrderType

Return Type

Order type, represented as eOrderType

Remarks

The cutom order can only be of otMarket, otLimit, or otStop types.

See Also

CQGAlgorithmicOrderParameters Interface | CQGAlgorithmicOrderParameters Members


%%PageItemTitle%%

VisibleQuantity Property
CQGAlgorithmicOrderParameters Interface : VisibleQuantity Property

Glossary Item Box

Description

Returns visible quantity of the Iceberg order.

Property type

Read-only property

Syntax

Visual Basic
Public Property VisibleQuantity As Long

Return Type

Iceberg visible quantity, represented as Long

See Also

CQGAlgorithmicOrderParameters Interface | CQGAlgorithmicOrderParameters Members


%%PageItemTitle%%

CQGAlgorithmicOrderProperty Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents an algorithmic order property.

Object Model

CQGAlgorithmicOrderProperty Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGAlgorithmicOrderProperty Members


%%PageItemTitle%% $$Members$$

CQGAlgorithmicOrderProperty Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Name | Returns the name of the property.
Public Property Value | Returns the value of the property.

See Also

CQGAlgorithmicOrderProperty Interface


%%PageItemTitle%%

Name Property
CQGAlgorithmicOrderProperty Interface : Name Property

Glossary Item Box

Description

Returns the name of the property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

Return Type

Property name, represented as String

See Also

CQGAlgorithmicOrderProperty Interface | CQGAlgorithmicOrderProperty Members


%%PageItemTitle%%

Value Property
CQGAlgorithmicOrderProperty Interface : Value Property

Glossary Item Box

Description

Returns the value of the property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Value As Variant

Return Type

Property value, represented as Variant

See Also

CQGAlgorithmicOrderProperty Interface | CQGAlgorithmicOrderProperty Members


%%PageItemTitle%%

CQGAPIConfig Interface
See Also Members Send Feedback

Glossary Item Box

Description

Gets/sets the value of a specified property. This is a default getter property.
Defined various CQGAPIConfig options and parameter items.

The CQGAPIConfig interface controls the behavior of CQG API.

Object Model

CQGAPIConfig InterfaceCQGStringCollection Collection

Remarks

Starting from v. 3.0, the CQG API configuration is managed through CQGAPIConfig.

In former versions, the CQGCELConfiguration Structure was used for the same purpose. Now it is deprecated and remains solely for backward compatibility.

Example

See the usage of CQGAPIConfig object in the AccountChanged event's example section.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGAPIConfig Members


%%PageItemTitle%% $$Members$$

CQGAPIConfig Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method AddRemoteOpenAPIServer | Adds additional remote server address
Public Method ClearRemoteOpenAPIServers | Clears the collection of additional remote servers

Public Properties

Public Property AccountMarginAndPositionsThrottleInterval | Gets account margin and positions real time information throttle time interval in ms
Public Property AgeToDeleteLogFileDays | Gets age to delete log files in days
Public Property ApplyDaylightSavingChanges | Gets flag indicating whether to automatically adjust time for daylight saving changes.
Public Property CollectionsThrowException | Controls the behavior of CQG API when a non-existent member of a collection is accessed. The default value is True.
Public Property DefaultAccountMarginDetailing | Gets default value for account margin detailing
Public Property DefaultInstrumentBBAType | Specifies the default instrument best bid/ask (BBA) type. The default value is dbtCombined.
Public Property DefaultInstrumentSubscriptionLevel | Specifies the default instrument subscription level. The default value is dsQuotesAndBBA.
Public Property DefPositionSubscriptionLevel | Specifies the default position subscription level for accounts. The default value is pslNoPositions.
Public Property DOMUpdatesMode | Mode of DOM update sending. The default value is domUMDynamic.
Public Property DOMUpdatesPeriod | Time period indicating the time interval for DOM update sending. The default value is 0.
Public Property FireEventOnChangedPrices | Controls the CQG API behavior regarding the firing of AccountChanged events on each price change. The default value is False.
Public Property GatewayEnabled | Enables/disables the gateway functionality in CQG API. The default value for this property is True (i.e., Gateway functionality is enabled).
Public Property IncludeOrderTransactions | Returns if transactions should be included or not while performing orders query
Public Property LogSeverity | Logging severity. The default value is lsFatal.
Public Property MaxLogFileCount | Maximum number of log files. The default value is 10.
Public Property MaxLogFileDuration | The property is deprecated.
Public Property MaxLogFileSize | Maximum size of a log file in KB. The default value is 10240.
Public Property MessageProcessingTimeout | Sets/gets the message processing timeout interval in milliseconds. The default value for this property is 32.
Public Property MetaDataEnabled | This property is reserved for future usage. The default value is False.
Public Property NewInstrumentChangeMode | Specifies whether the InstrumentChanged event will work in old or new mode. The default value is False.
Public Property NewInstrumentMode | Specifies whether instrument subscription is set to new or old mode. The default value is False.
Public Property NonsynchronizedData | Controls the behavior of data processing in CQG API. When enabled, data delivery to CQG API becomes non-synchronized. Doing so may enhance the performance. The default value for this property is False.
Public Property PendingOrderActionEnabled | Gets flag identifying whether to enable pending order action functionality.
Public Property PositionDetailing | This property specifies the position detailing level of accounts, i.e. the amount of information on trades that user wants to receive. The default value is pdNoTrades.
Public Property PriceMode | Controls the calculation method of accounts/positions trade specific data. The default value is pmTradesOnly.
Public Property ProviderPassword | This property is intended for internal use only.
Public Property QueryAllAuthorizedTraders | Gets flag indicating whether to automatically request all authorized traders or not.
Public Property ReadyStatusCheck | Specifies whether application ready status checking should be enabled or not. The default value is rscOn.
Public Property RemoteOpenAPILoginService | Gets remote Open API login service address
Public Property RemoteOpenAPIServer | Specifies the remote CQG API server address. The default value is empty string (local CQG IC will be used).
Public Property RemoteOpenAPIServers | Gets the collection of additional remote server addresses
Public Property ReplaceLoginSession | Gets replace login session flag
Public Property SkipAlgorithmIDCheckForManualOrders | Whether an algorithm id check for not manually placed orders should be skipped or not. Default value is False.
Public Property SnapshotPeriod | Sets the snapshot update interval. This property regulates the update interval for instrument quotes, properties and DOM; as well as all historical data updates except for ticks. The default value is 0.
Public Property StrategyManagerEnabled | Gets flag indicating whether to request strategy manager enablement.
Public Property TimeZoneCode | The timezone code to adjust all reported dates to. The default value is UTC time.
Public Property TrackInstrumentRolls | Controls whether instrument rolls are tracked or not. The default value is False.
Public Property UsedFromATLClient | Specifies whether the CQG API is being used from an ATL Client Application or not. The default value is False.
Public Property UseOrderSide | Specifies the object's side identification method. The default value is False.

See Also

CQGAPIConfig Interface


%%PageItemTitle%%

AddRemoteOpenAPIServer Method
server_address

Remote server address

CQGAPIConfig Interface : AddRemoteOpenAPIServer Method

Glossary Item Box

Description

Adds additional remote server address

Syntax

Visual Basic
Public Sub AddRemoteOpenAPIServer( _
   ByVal server_address As String _
)

Parameters

server_address

Remote server address

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

ClearRemoteOpenAPIServers Method
CQGAPIConfig Interface : ClearRemoteOpenAPIServers Method

Glossary Item Box

Description

Clears the collection of additional remote servers

Syntax

Visual Basic
Public Sub ClearRemoteOpenAPIServers()

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

AccountMarginAndPositionsThrottleInterval Property
CQGAPIConfig Interface : AccountMarginAndPositionsThrottleInterval Property

Glossary Item Box

Description

Gets account margin and positions real time information throttle time interval in ms

Property type

Read-write property

Syntax

Visual Basic
Public Property AccountMarginAndPositionsThrottleInterval As Long

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

AgeToDeleteLogFileDays Property
CQGAPIConfig Interface : AgeToDeleteLogFileDays Property

Glossary Item Box

Description

Gets age to delete log files in days

Property type

Read-write property

Syntax

Visual Basic
Public Property AgeToDeleteLogFileDays As Long

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

ApplyDaylightSavingChanges Property
CQGAPIConfig Interface : ApplyDaylightSavingChanges Property

Glossary Item Box

Description

Gets flag indicating whether to automatically adjust time for daylight saving changes.

Property type

Read-write property

Syntax

Visual Basic
Public Property ApplyDaylightSavingChanges As Boolean

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

CollectionsThrowException Property
CQGAPIConfig Interface : CollectionsThrowException Property

Glossary Item Box

Description

Controls the behavior of CQG API when a non-existent member of a collection is accessed.

The default value is True.

Property type

Read-write property

Syntax

Visual Basic
Public Property CollectionsThrowException As Boolean

Return Type

If True an exception is thrown.

If False Nothing is returned.

Remarks

See Accessing non-existent collection items for details.

Example

See the usage of CollectionsThrowException property in the AccountChanged event's example section.

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

DefaultAccountMarginDetailing Property
CQGAPIConfig Interface : DefaultAccountMarginDetailing Property

Glossary Item Box

Description

Gets default value for account margin detailing

Property type

Read-write property

Syntax

Visual Basic
Public Property DefaultAccountMarginDetailing As eAccountMarginDetailing

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

DefaultInstrumentBBAType Property
CQGAPIConfig Interface : DefaultInstrumentBBAType Property

Glossary Item Box

Description

Specifies the default instrument best bid/ask (BBA) type.

The default value is dbtCombined.

Property type

Read-write property

Syntax

Visual Basic
Public Property DefaultInstrumentBBAType As eDOMandBBAType

Return Type

Default instrument BBA type represented as a bitmask of eDOMandBBAType

Remarks

Allows to configure the initial BBA type of subscribed instruments.

See Also

CQGAPIConfig Interface | CQGAPIConfig Members | CQGInstrument.BBAType Property | eDOMandBBAType Enumeration


%%PageItemTitle%%

DefaultInstrumentSubscriptionLevel Property
CQGAPIConfig Interface : DefaultInstrumentSubscriptionLevel Property

Glossary Item Box

Description

Specifies the default instrument subscription level.

The default value is dsQuotesAndBBA.

Property type

Read-write property

Syntax

Visual Basic
Public Property DefaultInstrumentSubscriptionLevel As eDataSubscriptionLevel

Return Type

Default instrument subscription level represented as eDataSubscriptionLevel

Remarks

Allows to configure the initial data subscription level of subscribed instruments.

Example

See the usage of CQGAPIConfig properties in the AccountChanged event's example section.

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

DefPositionSubscriptionLevel Property
CQGAPIConfig Interface : DefPositionSubscriptionLevel Property

Glossary Item Box

Description

Specifies the default position subscription level for accounts.

The default value is pslNoPositions.

Property type

Read-write property

Syntax

Visual Basic
Public Property DefPositionSubscriptionLevel As ePositionSubscriptionLevel

Return Type

Position subscription level represented as ePositionSubscriptionLevel

Remarks

When accounts are initially loaded or reloaded (See eAccountChangeType Enumeration), their position subscription levels are reset to default.

This property allows to set the default value for positions subscription level, i.e. in case accounts are reloaded their position subscription levels will be set to the desired value.

Other than defining the default value here, you can set position subscription levels for each account separately through PositionSubcriptionLevel Property.

For details on position subscription level see description of ePositionSubscriptionLevel Enumeration.

Example

See the usage of DefPositionSubscriptionLevel property in the AccountChanged event's example section.

See Also

CQGAPIConfig Interface | CQGAPIConfig Members | CQGAccount.PositionSubcriptionLevel Property


%%PageItemTitle%%

DOMUpdatesMode Property
CQGAPIConfig Interface : DOMUpdatesMode Property

Glossary Item Box

Description

Mode of DOM update sending.

The default value is domUMDynamic.

Property type

Read-write property

Syntax

Visual Basic
Public Property DOMUpdatesMode As eDOMUpdatesMode

Return Type

Update sending mode, represented as eDOMUpdatesMode

Remarks

The period of DOM updates is configured through DOMUpdatesPeriod property.

Example

See the usage of CQGAPIConfig properties in the AccountChanged event's example section.

See Also

CQGAPIConfig Interface | CQGAPIConfig Members | CQGCELConfiguration UDT


%%PageItemTitle%%

DOMUpdatesPeriod Property
CQGAPIConfig Interface : DOMUpdatesPeriod Property

Glossary Item Box

Description

Time period indicating the time interval for DOM update sending.

The default value is 0.

Property type

Read-write property

Syntax

Visual Basic
Public Property DOMUpdatesPeriod As Long

Return Type

Update period in milliseconds represented as Long

Remarks

Updates will be received according to the DOMUpdatesMode property value.

If SnapshotPeriod is greater than the DOMUpdatesPeriod, the SnapshotPeriod's value will be used as the period of DOM updates instead.

Example

See the usage of CQGAPIConfig properties in the AccountChanged event's example section.

See Also

CQGAPIConfig Interface | CQGAPIConfig Members | CQGCELConfiguration UDT | CQGAPIConfig.DOMUpdatesMode Property


%%PageItemTitle%%

FireEventOnChangedPrices Property
CQGAPIConfig Interface : FireEventOnChangedPrices Property

Glossary Item Box

Description

Controls the CQG API behavior regarding the firing of AccountChanged events on each price change.

The default value is False.

Property type

Read-write property

Syntax

Visual Basic
Public Property FireEventOnChangedPrices As Boolean

Return Type

True if events should be fired, False otherwise.

Remarks

Even if this property is set to True, the user will get the events only for those positions which instruments are subscribed and set to DataSubscriptionLevel higher than dsNone.

Note: setting this property to True is very verbose. Do not set it unless you really need it.

Example

See the usage of CQGAPIConfig properties in the AccountChanged event's example section.

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

GatewayEnabled Property
CQGAPIConfig Interface : GatewayEnabled Property

Glossary Item Box

Description

Enables/disables the gateway functionality in CQG API.

The default value for this property is True (i.e., Gateway functionality is enabled).

Property type

Read-write property

Syntax

Visual Basic
Public Property GatewayEnabled As Boolean

Return Type

True if the gateway functionality is enabled, false otherwise

Remarks

When the gateway is enabled, the maximum number of simultaneous CQG API instances is limited to five. Therefore, if the gateway is not necessary, disabling it will remove that limitation.

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

IncludeOrderTransactions Property
CQGAPIConfig Interface : IncludeOrderTransactions Property

Glossary Item Box

Description

Returns if transactions should be included or not while performing orders query

Property type

Read-write property

Syntax

Visual Basic
Public Property IncludeOrderTransactions As Boolean

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

LogSeverity Property
CQGAPIConfig Interface : LogSeverity Property

Glossary Item Box

Description

Logging severity.

The default value is lsFatal.

Property type

Read-write property

Syntax

Visual Basic
Public Property LogSeverity As eLogSeverity

Return Type

Severity represented as eLogSeverity

Example

See the usage of CQGAPIConfig properties in the AccountChanged event's example section.

See Also

CQGAPIConfig Interface | CQGAPIConfig Members | CQGCELConfiguration UDT


%%PageItemTitle%%

MaxLogFileCount Property
CQGAPIConfig Interface : MaxLogFileCount Property

Glossary Item Box

Description

Maximum number of log files.

The default value is 10.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxLogFileCount As Long

Return Type

Log files number represented as Long

Example

See the usage of CQGAPIConfig properties in the AccountChanged event's example section.

See Also

CQGAPIConfig Interface | CQGAPIConfig Members | CQGCELConfiguration UDT


%%PageItemTitle%%

MaxLogFileDuration Property
CQGAPIConfig Interface : MaxLogFileDuration Property

Glossary Item Box

Description

The property is deprecated.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxLogFileDuration As Date

Return Type

The log file duration time period represented as Date

Example

See the usage of CQGAPIConfig properties in the AccountChanged event's example section.

See Also

CQGAPIConfig Interface | CQGAPIConfig Members | CQGCELConfiguration UDT


%%PageItemTitle%%

MaxLogFileSize Property
CQGAPIConfig Interface : MaxLogFileSize Property

Glossary Item Box

Description

Maximum size of a log file in KB.

The default value is 10240.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxLogFileSize As Long

Return Type

Log file size represented as Long

Example

See the usage of CQGAPIConfig properties in the AccountChanged event's example section.

See Also

CQGAPIConfig Interface | CQGAPIConfig Members | CQGCELConfiguration UDT


%%PageItemTitle%%

MessageProcessingTimeout Property
CQGAPIConfig Interface : MessageProcessingTimeout Property

Glossary Item Box

Description

Sets/gets the message processing timeout interval in milliseconds.

The default value for this property is 32.

Property type

Read-write property

Syntax

Visual Basic
Public Property MessageProcessingTimeout As Long

Return Type

Message processing timeout in milliseconds, represented as Long

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

MetaDataEnabled Property
CQGAPIConfig Interface : MetaDataEnabled Property

Glossary Item Box

Description

This property is reserved for future usage.

The default value is False.

Property type

Read-write property

Syntax

Visual Basic
Public Property MetaDataEnabled As Boolean

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

NewInstrumentChangeMode Property
CQGAPIConfig Interface : NewInstrumentChangeMode Property

Glossary Item Box

Description

Specifies whether the InstrumentChanged event will work in old or new mode.

The default value is False.

Property type

Read-write property

Syntax

Visual Basic
Public Property NewInstrumentChangeMode As Boolean

Return Type

True if the mode is new, False otherwise.

Remarks

In old version of CQG API the collections that were passed to the InstrumentChanged event kept the new values of the changed quotes/properties. CQG API v.3.0 and higher behaves the same way if this property is set to False.

Starting from CQG API v.3.0 the collections can keep the old values in the argument collections. In order to use this approach user should set this property to True.

Example

See the usage of NewInstrumentChangeMode property in the AccountChanged event's example section.

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

NewInstrumentMode Property
CQGAPIConfig Interface : NewInstrumentMode Property

Glossary Item Box

Description

Specifies whether instrument subscription is set to new or old mode.

The default value is False.

Property type

Read-write property

Syntax

Visual Basic
Public Property NewInstrumentMode As Boolean

Return Type

True if the instrument mode is new, False otherwise.

Remarks

This new instruments subscriptiption mode allows to specify precisely what kind of instrument data is needed making the application lighter on system resources. For example it is possible to subscribe to quotes and/or properties, as well as subscribe to DOM data separately.

When set to True, the following interfaces, methods, and enumerations should be used for instrument subscription:

  • CreateInstrumentRequest
  • CQGInstrumentSubscriptionRequest
  • ePropertySubscriptionLevel, eQuoteSubscriptionLevel

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

NonsynchronizedData Property
CQGAPIConfig Interface : NonsynchronizedData Property

Glossary Item Box

Description

Controls the behavior of data processing in CQG API.

When enabled, data delivery to CQG API becomes non-synchronized. Doing so may enhance the performance.

The default value for this property is False.

Property type

Read-write property

Syntax

Visual Basic
Public Property NonsynchronizedData As Boolean

Return Type

True if data delivery is non-synchronized, false otherwise

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

PendingOrderActionEnabled Property
CQGAPIConfig Interface : PendingOrderActionEnabled Property

Glossary Item Box

Description

Gets flag identifying whether to enable pending order action functionality.

Property type

Read-write property

Syntax

Visual Basic
Public Property PendingOrderActionEnabled As Boolean

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

PositionDetailing Property
CQGAPIConfig Interface : PositionDetailing Property

Glossary Item Box

Description

This property specifies the position detailing level of accounts, i.e. the amount of information on trades that user wants to receive.

The default value is pdNoTrades.

Property type

Read-write property

Syntax

Visual Basic
Public Property PositionDetailing As ePositionDetailing

Return Type

The detailing represented as ePositionDetailing

Remarks

This setting does not control the events, it only controls the provided information. It means that if an account's PositionSubcriptionLevel Property is set to pslNoPositions, user will not get any trade information either.

For details on position detailing see description of ePositionDetailing Enumeration.

Example

See the usage of PositionDetailing property in the AccountChanged event's example section.

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

PriceMode Property
CQGAPIConfig Interface : PriceMode Property

Glossary Item Box

Description

Controls the calculation method of accounts/positions trade specific data.

The default value is pmTradesOnly.

Property type

Read-write property

Syntax

Visual Basic
Public Property PriceMode As ePriceMode

Return Type

The price mode represented as ePriceMode

Remarks

This setting is the same for all accounts and positions.

Can be either Best Ask/Best Bid or the Last Trade.

See ePriceMode Enumeration for details.

Example

See the usage of PriceMode property in the AccountChanged event's example section.

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

ProviderPassword Property
CQGAPIConfig Interface : ProviderPassword Property

Glossary Item Box

Description

This property is intended for internal use only.

Property type

Read-write property

Syntax

Visual Basic
Public Property ProviderPassword As String

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

QueryAllAuthorizedTraders Property
CQGAPIConfig Interface : QueryAllAuthorizedTraders Property

Glossary Item Box

Description

Gets flag indicating whether to automatically request all authorized traders or not.

Property type

Read-write property

Syntax

Visual Basic
Public Property QueryAllAuthorizedTraders As Boolean

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

ReadyStatusCheck Property
CQGAPIConfig Interface : ReadyStatusCheck Property

Glossary Item Box

Description

Specifies whether application ready status checking should be enabled or not.

The default value is rscOn.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReadyStatusCheck As eReadyStatusCheck

Return Type

The state represented as eReadyStatus

Remarks

If you use CQG API from an Excel macros, set this property to True.

If CQG API is being used from any other type of application, set this property to False.

See the Remarks section of IsReady event for details.

Example

See the usage of CQGAPIConfig properties in the AccountChanged event's example section.

See Also

CQGAPIConfig Interface | CQGAPIConfig Members | CQGCELConfiguration UDT


%%PageItemTitle%%

RemoteOpenAPILoginService Property
CQGAPIConfig Interface : RemoteOpenAPILoginService Property

Glossary Item Box

Description

Gets remote Open API login service address

Property type

Read-write property

Syntax

Visual Basic
Public Property RemoteOpenAPILoginService As String

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

RemoteOpenAPIServer Property
CQGAPIConfig Interface : RemoteOpenAPIServer Property

Glossary Item Box

Description

Specifies the remote CQG API server address.

The default value is empty string (local CQG IC will be used).

Property type

Read-write property

Syntax

Visual Basic
Public Property RemoteOpenAPIServer As String

Return Type

Remote server address, represented as String

Remarks

This fuctionality requires the "Remote API" enablement.

When connected to a remote server, all trading functionality of CQG API will be disabled.

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

RemoteOpenAPIServers Property
CQGAPIConfig Interface : RemoteOpenAPIServers Property

Glossary Item Box

Description

Gets the collection of additional remote server addresses

Property type

Read-only property

Syntax

Visual Basic
Public Property RemoteOpenAPIServers As CQGStringCollection

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

ReplaceLoginSession Property
CQGAPIConfig Interface : ReplaceLoginSession Property

Glossary Item Box

Description

Gets replace login session flag

Property type

Read-write property

Syntax

Visual Basic
Public Property ReplaceLoginSession As Boolean

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

SkipAlgorithmIDCheckForManualOrders Property
CQGAPIConfig Interface : SkipAlgorithmIDCheckForManualOrders Property

Glossary Item Box

Description

Whether an algorithm id check for not manually placed orders should be skipped or not. Default value is False.

Property type

Read-write property

Syntax

Visual Basic
Public Property SkipAlgorithmIDCheckForManualOrders As Boolean

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

SnapshotPeriod Property
CQGAPIConfig Interface : SnapshotPeriod Property

Glossary Item Box

Description

Sets the snapshot update interval.

This property regulates the update interval for instrument quotes, properties and DOM; as well as all historical data updates except for ticks.

The default value is 0.

Property type

Read-write property

Syntax

Visual Basic
Public Property SnapshotPeriod As Long

Return Type

The update interval in milliseconds, represented as Long

Remarks

If the value is less than 1, the update is performed on every change. This is the default value.

If the value is larger than 0, the snapshot mode is activated and the updates are received on the specified intervals.

If eDOMUpdatesMode is set to domUMSnapshot, DOM will be updated in the background as specified by DOMUpdatesPeriod; but the available DOM snapshot will be delivered only when the SnapshotPeriod is elapsed.

In other words, if:

  • SnapshotPeriod < DOMUpdatePeriod: DOM data will be updated with the latest available data, until DOMUpdatePeriod is elapsed and new DOM data is received, then when the next SnapshotPeriod is elapsed, updated DOM will be available.
  • SnapshotPeriod > DOMUpdatePeriod: DOM data will be updated but not available until SnapshotPeriod is elapsed.
  • SnapshotPeriod = DOMUpdatePeriod: DOM data will be updated with the available DOM each time the SnapshotPeriod is elapsed.

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

StrategyManagerEnabled Property
CQGAPIConfig Interface : StrategyManagerEnabled Property

Glossary Item Box

Description

Gets flag indicating whether to request strategy manager enablement.

Property type

Read-write property

Syntax

Visual Basic
Public Property StrategyManagerEnabled As Boolean

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

TimeZoneCode Property
CQGAPIConfig Interface : TimeZoneCode Property

Glossary Item Box

Description

The timezone code to adjust all reported dates to.

The default value is UTC time.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeZoneCode As eTimeZone

Return Type

Timezone code represented as eTimeZone

Example

See the usage of CQGAPIConfig properties in the AccountChanged event's example section.

See Also

CQGAPIConfig Interface | CQGAPIConfig Members | CQGCELConfiguration UDT


%%PageItemTitle%%

TrackInstrumentRolls Property
CQGAPIConfig Interface : TrackInstrumentRolls Property

Glossary Item Box

Description

Controls whether instrument rolls are tracked or not.

The default value is False.

Property type

Read-write property

Syntax

Visual Basic
Public Property TrackInstrumentRolls As Boolean

Remarks

If this property is True, then the API tracks instrument rolls. It means the following:

If NewInstrument is called with symbol prefix (e.g. EP) or symbol prefix with relative month (EP?1), then InstrumentResolved and InstrumentSubscribed events are raised each time when an instrument roll is occured.

If the property is False, then nothing happened in case instrument roll.

Available since 19x3 CQG IC version.

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

UsedFromATLClient Property
CQGAPIConfig Interface : UsedFromATLClient Property

Glossary Item Box

Description

Specifies whether the CQG API is being used from an ATL Client Application or not.

The default value is False.

Property type

Read-write property

Syntax

Visual Basic
Public Property UsedFromATLClient As Boolean

Return Type

True if the application is an ATL Client, False otherwise.

Remarks

If you use CQG API from an ATL Client, set this property to True.

If CQG API is being used from any other type of application, set this property to False.

See Invalid Objects for details.

Example

See the usage of CQGAPIConfig properties in the AccountChanged event's example section.

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

UseOrderSide Property
CQGAPIConfig Interface : UseOrderSide Property

Glossary Item Box

Description

Specifies the object's side identification method.

The default value is False.

Property type

Read-write property

Syntax

Visual Basic
Public Property UseOrderSide As Boolean

Return Type

True if eOrderSide is to be used, False otherwise.

Remarks

Some interfaces included starting from v.3.0 have "sides", i.e. for trades it is buy/sell, for positions it is long/short.

In CQG API, there are two possible ways of identifying sides:

  • Using the Order Side notion:
    if the trade, fill, order is buy or position is long, the Side properties of corresponding objects return osdBuy;
    if the trade, fill, order is sell or position is short, the Side properties of corresponding objects return osdSell.

In this case Quantity properties of these objects are always positive.

  • Using signed quantities:
    if the trade, fill, order is buy or position is long, the Quantity properties of corresponding objects are positive;
    if the trade, fill, order is sell or position is short, the Quantity properties of corresponding objects are negative.

In this case Side properties of these objects are always osdUndefined.

Example

See the usage of UseOrderSide property in the AccountChanged event's example section.

See Also

CQGAPIConfig Interface | CQGAPIConfig Members


%%PageItemTitle%%

CQGBracketOrder Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a class describing a bracket order.

Object Model

CQGBracketOrder InterfaceCQGOrder InterfaceCQGBracketOrderLeg InterfaceCQGBracketOrderLeg Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGBracketOrder Members | CQGBracketOrderLeg Interface


%%PageItemTitle%% $$Members$$

CQGBracketOrder Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method Cancel | Cancels the bracket order
Public Method Place | Places the bracket order

Public Properties

Public Property CanBeCanceled | Returns the bracket order availability for cancellation.
Public Property IncludeStopLossOrder | Flag identifying inclusion of stop-loss order (true by default)
Public Property IncludeTargetOrder | Flag identifying inclusion of target order (true by default)
Public Property MainOrder | Main leg of the bracket order
Public Property PartialFillsHandling | Indicates whether compound order execution shall happen on a partial fill or complete fill (true by default)
Public Property StopLossLeg | Stop-loss leg of the bracket order
Public Property TargetLeg | Profit leg of the bracket order

See Also

CQGBracketOrder Interface | CQGBracketOrderLeg Interface


%%PageItemTitle%%

Cancel Method
CQGBracketOrder Interface : Cancel Method

Glossary Item Box

Description

Cancels the bracket order

Syntax

Visual Basic
Public Sub Cancel()

Remarks

This method only works while main order has not been filled. Use CanBeCanceled property to verify that it is possible to cancel bracket order.

If you want to cancel legs you should cancel those orders directly. Orders can be accessed from global orders collection using ItemByGuid search and CQGBracketOrderLeg.GUID property as search value.

See Also

CQGBracketOrder Interface | CQGBracketOrder Members | Orders Property | GUID Property


%%PageItemTitle%%

Place Method
CQGBracketOrder Interface : Place Method

Glossary Item Box

Description

Places the bracket order

Syntax

Visual Basic
Public Sub Place()

Remarks

Main order should be in order status osNotSent.

See Also

CQGBracketOrder Interface | CQGBracketOrder Members


%%PageItemTitle%%

CanBeCanceled Property
CQGBracketOrder Interface : CanBeCanceled Property

Glossary Item Box

Description

Returns the bracket order availability for cancellation.

Property type

Read-only property

Syntax

Visual Basic
Public Property CanBeCanceled As Boolean

See Also

CQGBracketOrder Interface | CQGBracketOrder Members


%%PageItemTitle%%

IncludeStopLossOrder Property
CQGBracketOrder Interface : IncludeStopLossOrder Property

Glossary Item Box

Description

Flag identifying inclusion of stop-loss order (true by default)

Property type

Read-write property

Syntax

Visual Basic
Public Property IncludeStopLossOrder As Boolean

See Also

CQGBracketOrder Interface | CQGBracketOrder Members


%%PageItemTitle%%

IncludeTargetOrder Property
CQGBracketOrder Interface : IncludeTargetOrder Property

Glossary Item Box

Description

Flag identifying inclusion of target order (true by default)

Property type

Read-write property

Syntax

Visual Basic
Public Property IncludeTargetOrder As Boolean

See Also

CQGBracketOrder Interface | CQGBracketOrder Members


%%PageItemTitle%%

MainOrder Property
CQGBracketOrder Interface : MainOrder Property

Glossary Item Box

Description

Main leg of the bracket order

Property type

Read-write property

Syntax

Visual Basic
Public Property MainOrder As CQGOrder

See Also

CQGBracketOrder Interface | CQGBracketOrder Members


%%PageItemTitle%%

PartialFillsHandling Property
CQGBracketOrder Interface : PartialFillsHandling Property

Glossary Item Box

Description

Indicates whether compound order execution shall happen on a partial fill or complete fill (true by default)

Property type

Read-write property

Syntax

Visual Basic
Public Property PartialFillsHandling As Boolean

See Also

CQGBracketOrder Interface | CQGBracketOrder Members


%%PageItemTitle%%

StopLossLeg Property
CQGBracketOrder Interface : StopLossLeg Property

Glossary Item Box

Description

Stop-loss leg of the bracket order

Property type

Read-write property

Syntax

Visual Basic
Public Property StopLossLeg As CQGBracketOrderLeg

See Also

CQGBracketOrder Interface | CQGBracketOrder Members


%%PageItemTitle%%

TargetLeg Property
CQGBracketOrder Interface : TargetLeg Property

Glossary Item Box

Description

Profit leg of the bracket order

Property type

Read-write property

Syntax

Visual Basic
Public Property TargetLeg As CQGBracketOrderLeg

See Also

CQGBracketOrder Interface | CQGBracketOrder Members


%%PageItemTitle%%

CQGBracketOrderLeg Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of bracket leg properties

Object Model

CQGBracketOrderLeg Interface

Remarks

Order duration values (opDurationType, opDurationType and opGTTTime properties) are inherited from CQGBracketOrder.MainOrder.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGBracketOrderLeg Members | CQGBracketOrder Interface


%%PageItemTitle%% $$Members$$

CQGBracketOrderLeg Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property GUID | Leg order unique ID, corresponds to CQGOrder.GUID (opGUID order property). Value is generated automatically on object creation.
Public Property LimitOffset | Leg's limit offset from the main order's fill price.
Public Property LimitPrice | Leg limit price
Public Property OrderType | Leg order type
Public Property StopOffset | Leg's stop offset from the main order's fill price.
Public Property StopPrice | Leg stop price

See Also

CQGBracketOrderLeg Interface | CQGBracketOrder Interface


%%PageItemTitle%%

GUID Property
CQGBracketOrderLeg Interface : GUID Property

Glossary Item Box

Description

Leg order unique ID, corresponds to CQGOrder.GUID (opGUID order property). Value is generated automatically on object creation.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID As String

See Also

CQGBracketOrderLeg Interface | CQGBracketOrderLeg Members


%%PageItemTitle%%

LimitOffset Property
CQGBracketOrderLeg Interface : LimitOffset Property

Glossary Item Box

Description

Leg's limit offset from the main order's fill price.

Property type

Read-write property

Syntax

Visual Basic
Public Property LimitOffset As Long

Remarks

Setting limit offset will change limit price to zero and vice versa.

See Also

CQGBracketOrderLeg Interface | CQGBracketOrderLeg Members


%%PageItemTitle%%

LimitPrice Property
CQGBracketOrderLeg Interface : LimitPrice Property

Glossary Item Box

Description

Leg limit price

Property type

Read-write property

Syntax

Visual Basic
Public Property LimitPrice As Double

Remarks

Setting limit price will change limit offset to zero and vice versa.

See Also

CQGBracketOrderLeg Interface | CQGBracketOrderLeg Members


%%PageItemTitle%%

OrderType Property
CQGBracketOrderLeg Interface : OrderType Property

Glossary Item Box

Description

Leg order type

Property type

Read-only property

Syntax

Visual Basic
Public Property OrderType As eOrderType

See Also

CQGBracketOrderLeg Interface | CQGBracketOrderLeg Members


%%PageItemTitle%%

StopOffset Property
CQGBracketOrderLeg Interface : StopOffset Property

Glossary Item Box

Description

Leg's stop offset from the main order's fill price.

Property type

Read-write property

Syntax

Visual Basic
Public Property StopOffset As Long

Remarks

Setting stop offset will change stop price to zero and vice versa.

See Also

CQGBracketOrderLeg Interface | CQGBracketOrderLeg Members


%%PageItemTitle%%

StopPrice Property
CQGBracketOrderLeg Interface : StopPrice Property

Glossary Item Box

Description

Leg stop price

Property type

Read-write property

Syntax

Visual Basic
Public Property StopPrice As Double

Remarks

Setting stop price will change stop offset to zero and vice versa.

See Also

CQGBracketOrderLeg Interface | CQGBracketOrderLeg Members


%%PageItemTitle%%

CQGCEL Interface
See Also Members Send Feedback

Glossary Item Box

Description

The CQGCEL encapsulates the main functionality of the CQG API.

This is the central interface an object of which should be created by the user in order to use the CQG API features.

Object Model

CQGCEL InterfaceCQGAccounts CollectionCQGAccount InterfaceCQGAdvancedStudies CollectionCQGAdvancedStudy CollectionCQGConditions CollectionCQGCondition CollectionCQGConstantVolumeBarsCollection CollectionCQGConstantVolumeBars CollectionCQGCustomStudies CollectionCQGCustomStudy CollectionCQGExpressions CollectionCQGExpression CollectionCQGInstrumentsGroups CollectionCQGInstrumentsGroup InterfaceCQGManualFillsCollection CollectionCQGManualFills CollectionCQGPointAndFigureBarsCollection CollectionCQGPointAndFigureBars CollectionCQGRangeBarsCollection CollectionCQGRangeBars CollectionCQGRenkoBarsCollection CollectionCQGRenkoBars CollectionCQGStrategyDefinitions CollectionCQGStrategyDefinition InterfaceCQGSubMinuteBarsCollection CollectionCQGSubMinuteBars CollectionCQGTFlowBarsCollection CollectionCQGTFlowBars CollectionCQGTicksCollection CollectionCQGTicks CollectionCQGTimedBarsCollection CollectionCQGTimedBars CollectionCQGTradingSystems CollectionCQGTradingSystem InterfaceCQGYieldsCollection CollectionCQGYields CollectionCQGAPIConfig InterfaceCQGCELConfiguration UDTCQGAccounts CollectionCQGAccount InterfaceCQGAdvancedStudyRequest InterfaceCQGAlgorithmicOrderDefinitions CollectionCQGAlgorithmicOrderDefinition InterfaceCQGBracketOrder InterfaceCQGConditionRequest InterfaceCQGConstantVolumeBarsRequest InterfaceCQGCustomStudyRequest InterfaceCQGExecutionPattern InterfaceCQGExpressionRequest InterfaceCQGGWConnectionRequest InterfaceCQGHistoricalSessionsRequest InterfaceCQGInstrumentSubscriptionRequest InterfaceCQGInstrumentsGroupRequest InterfaceCQGManualFillRequest InterfaceCQGOrder InterfaceCQGOrderActionRequest InterfaceCQGOrder InterfaceCQGOrderChain InterfaceCQGOrderConstructor InterfaceCQGOrdersRequest ObjectCQGPointAndFigureBarsRequest InterfaceCQGRangeBarsRequest InterfaceCQGRenkoBarsRequest InterfaceCQGOrder InterfaceCQGOrder InterfaceCQGOrderConstructor InterfaceCQGStrategyQuoteRequest ObjectCQGSubMinuteBarsRequest InterfaceCQGTFlowBarsRequest InterfaceCQGTicksRequest InterfaceCQGTimedBarsRequest InterfaceCQGTradingSystemRequest InterfaceCQGYieldsRequest InterfaceCQGCurrencyRates CollectionCQGCurrencyRate InterfaceCQGStrategyDefinition InterfaceCQGStrategyDefinition InterfaceCQGDirectEventsAccessor InterfaceCQGEnvironment InterfaceCQGInstruments CollectionCQGInstrument InterfaceCQGOrders CollectionCQGOrder InterfaceCQGLogger InterfaceCQGOrders CollectionCQGOrder InterfaceCQGOrdersQuery InterfaceCQGAdvancedStudy CollectionCQGCurves CollectionCQGBarsTimestamps CollectionCQGCondition CollectionCQGConditionResult InterfaceCQGConstantVolumeBars CollectionCQGConstantVolumeBar InterfaceCQGCustomStudy CollectionCQGCurves CollectionCQGExpression CollectionCQGExpressionOutputs CollectionCQGOrdersQuery InterfaceCQGPointAndFigureBars CollectionCQGPointAndFigureBar InterfaceCQGRangeBars CollectionCQGRangeBar InterfaceCQGRenkoBars CollectionCQGRenkoBar InterfaceCQGSubMinuteBars CollectionCQGSubMinuteBar InterfaceCQGTFlowBars CollectionCQGTFlowBar InterfaceCQGTicks CollectionCQGTick InterfaceCQGTimedBars CollectionCQGTimedBar InterfaceCQGTradingSystem InterfaceCQGYields CollectionCQGYield Interface

Example

The Excel macro example below shows how to initialize/shutdown CQGCEL and handle it's events.

To execute the code, you need to add CQGCEL as reference into your project.
VB
C#
Option Explicit
' CQGCEL instance declaration
Public WithEvents cel As CQGCEL
Private Sub Workbook_Open()
    ' Initialize CQGCEL instance.
    On Error Goto ErrHandler
    Set cel = New CQGCEL
    cel.Startup

    Exit Sub
ErrHandler:
    If Err.Number <> 0 Then
        MsgBox "Error occurred during CEL initialization. " & _
                Err.Description
    End If
End Sub
Private Sub Workbook_BeforeClose(Cancel As Boolean)
    ' Shutdown the CQGCEL instance.
    cel.Shutdown
End Sub
Private Sub CEL_CELStarted()
    ' Create new instrument after CEL is started up
    cel.NewInstrument "DD"
End Sub
' START of CQGCEL event handlers.
Private Sub cel_InstrumentChanged(ByVal Instrument As CQG.ICQGInstrument, _
                                    ByVal Quotes As CQG.ICQGQuotes, _
                                    ByVal Props As CQG.ICQGInstrumentProperties)
    ' You'll get here if "DD" Instrument data is changed.
    cel.Logger.Log "Instrument Data Changed : " & Instrument.FullName, lsInfo
End Sub
Private Sub cel_InstrumentSubscribed(ByVal Symbl As String, ByVal Instrument As CQG.ICQGInstrument)
    ' You'll get here if "DD" Instrument is subscribed.
    cel.Logger.Log "Instrument Data Changed : " & Symbl, lsInfo
End Sub
Private Sub cel_IncorrectSymbol(ByVal Symbl As String)
    ' You'll get here if "DD" Instrument is not subscribed.
    cel.Logger.Log "INCORRECT SYMBOL: " & Symbl, lsError
End Sub
Private Sub cel_IsReady(ReadyStatus As CQG.eReadyStatus)
    ' CQGCEL asks Excel whether it's ready for event processing.
    ReadyStatus = IIf(Application.Ready, rsReady, rsNotReady)
End Sub
Private Sub cel_DataError(ByVal Obj As Object, ByVal ErrorDescription As String)
    cel.Logger.Log "ERROR : " & ErrorDescription, lsError
End Sub
' END of CQGCEL event handlers.
using System ;
using CQG ;
using System.Runtime.InteropServices ;
namespace Sample
{
   class TestCQGCEL
   {
      // CQGCEL instance declaration.
      public CQGCEL cel = null ;
      public TestCQGCEL()
      {
         // Initialize CQGCEL instance.
         try
         {
            cel = new CQGCEL() ;
            // Attach event handlers.
            cel.InstrumentChanged += new _ICQGCELEvents_InstrumentChangedEventHandler( cel_InstrumentChanged ) ;
            cel.InstrumentSubscribed += new _ICQGCELEvents_InstrumentSubscribedEventHandler( cel_InstrumentSubscribed ) ;
            cel.IncorrectSymbol += new _ICQGCELEvents_IncorrectSymbolEventHandler( cel_IncorrectSymbol ) ;
            cel.CELStarted += new _ICQGCELEvents_CELStartedEventHandler( cel_CELStarted ) ;
            cel.IsReady += new _ICQGCELEvents_IsReadyEventHandler( cel_IsReady ) ;
            cel.DataError += new _ICQGCELEvents_DataErrorEventHandler( cel_DataError ) ;
            cel.Startup() ;
         }
         catch( COMException ex )
         {
            Console.WriteLine( "Error occurred during CEL initialization. " + ex.Message );
         }
      }
      ~TestCQGCEL()
      {
         // Shutdown the CQGCEL instance.
         cel.Shutdown() ;
      }
      #region CQGCEL event handlers
      private void cel_InstrumentChanged(CQGInstrument Instrument, CQGQuotes Quotes, CQGInstrumentProperties props)
      {
         // You'll get here if "DD" Instrument data is changed.
         cel.Logger.Log( "Instrument Data Changed : " + Instrument.FullName, eLogSeverity.lsInfo ) ;
      }
      private void cel_InstrumentSubscribed(string Symbl, CQGInstrument Instrument)
      {
         // You'll get here if "DD" Instrument is subscribed.
         cel.Logger.Log( "Instrument Data Changed : " + Symbl, eLogSeverity.lsInfo ) ;
      }
      private void cel_IncorrectSymbol(string Symbl)
      {
         // You'll get here if "DD" Instrument is subscribed.
         cel.Logger.Log( "INCORRECT SYMBOL: " + Symbl, eLogSeverity.lsError ) ;
      }
      private void cel_CELStarted()
      {
         // Create new instrument after CEL is started up
         cel.NewInstrument( "DD" ) ;
      }
      private void cel_IsReady(out eReadyStatus ReadyStatus)
      {
         // We are always ready to handle CQGCEL events.
         ReadyStatus = eReadyStatus.rsReady ;
      }
      private void cel_DataError(object Obj, string ErrorDescription)
      {
         cel.Logger.Log( "ERROR : " + ErrorDescription , eLogSeverity.lsError ) ;
         System.Windows.Forms.Application.Exit() ;
      }
      #endregion
      [STAThread]
      static void Main(string[] args)
      {
         TestCQGCEL test = new TestCQGCEL();
         // Start Application. Will work until some error occurred.
         System.Windows.Forms.Application.Run() ;
      }
   }
}

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGCEL Members


%%PageItemTitle%% $$Members$$

CQGCEL Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method ActivateAllOrders | Activates a set of parked orders. The selection of the orders to be activated is performed based on the passed arguments. If no argument is passed all currently existing parked orders are activated.
Public Method ActivateAllOrdersEx | Activate all orders
Public Method CancelAllOrders | Cancels a set of orders. The selection of the orders to be cancelled is performed based on the passed arguments. If no argument is passed all currently existing orders are cancelled.
Public Method CancelAllOrdersEx | Cancels all orders
Public Method ChangePassword | Changes the password which is used for remote Open API user authentication
Public Method ChangeRemoteOpenAPIServer | Changes current remote Open API server
Public Method CreateAccountsCollection | Creates an empty collection of accounts
Public Method CreateAdvancedStudyRequest | Creates new CQGAdvancedStudyRequest object based on advanced study name
Public Method CreateAlgorithmicOrderDefinitions | Creates a collection of algorithmic order properties' definitions.
Public Method CreateBracketOrder | Creates a new bracket order
Public Method CreateConditionRequest | Creates a new CQGConditionRequest object based on the condition name.
Public Method CreateConstantVolumeBarsRequest | Creates a new CQGConstantVolumeBarsRequest object.
Public Method CreateCustomStudyRequest | Creates a new CQGCustomStudyRequest object based on the custom study name or abbreviation.
Public Method CreateExecutionPattern | Creates an empty or default strategy execution pattern.
Public Method CreateExpressionRequest | Creates a new CQGExpressionRequest object.
Public Method CreateGWConnectionRequest | Creates new CQGGWConnectionRequest object
Public Method CreateHistoricalSessionsRequest | Creates new CQGHistoricalSessionsRequest object.
Public Method CreateInstrumentRequest | Creates a new CQGInstrumentSubscriptionRequest object.
Public Method CreateInstrumentsGroupRequest | Creates an instruments group request object. Returns the corresponding CQGInstrumentsGroupRequest object to specify group request parameters.
Public Method CreateManualFillRequest | Creates a new manual fill request with the default parameters or with the given prototype manual fill parameters.
Public Method CreateOrder | Creates an order object.
Public Method CreateOrderActionRequest | Creates new CQGOrderActionRequest object
Public Method CreateOrderByInstrumentName | This method creates a new order with the specified parameters. The result of this method is the same as the one from CQGCEL.CreateOrder, however it allows to create an order by providing the full instrument name without prior need to subscribe to the instrument.
Public Method CreateOrderChain | Creates empty order chain
Public Method CreateOrderConstructor | Creates a new CQGOrderConstructor object for regular orders
Public Method CreateOrdersRequest | Creates new CQGOrdersRequest object
Public Method CreatePointAndFigureBarsRequest | Creates a new CQGPointAndFigureBarsRequest object.
Public Method CreateQFormula | Starts an asynchronous query for QFormula creation.
Public Method CreateRangeBarsRequest | Creates new CQGRenkoBarsRequest object
Public Method CreateRenkoBarsRequest | Creates new CQGRenkoBarsRequest object
Public Method CreateStrategyOrder | Creates new strategy order with specified parameters.
Public Method CreateStrategyOrderByExpression | Creates a new strategy order object by specified strategy expression or QFormula name/number.
Public Method CreateStrategyOrderConstructor | Creates a new CQGOrderConstructor object for strategy orders
Public Method CreateStrategyQuoteRequest | Creates a new CQGStrategyQuoteRequest object
Public Method CreateSubMinuteBarsRequest | Creates new CQGSubMinuteBarsRequest object
Public Method CreateTFlowBarsRequest | Creates a new CQGTFlowBarsRequest object.
Public Method CreateTicksRequest | Creates a new CQGTicksRequest object.
Public Method CreateTimedBarsRequest | Creates a new CQGTimedBarsRequest object.
Public Method CreateTradingSystemRequest | Creates a new CQGTradingSystemRequest object based on the trading system name.
Public Method CreateYieldsRequest | Creates new CQGYieldsRequest object
Public Method DefineStrategy | Method is obsolete. Use DefineStrategyEx instead.
Public Method DefineStrategyEx | Requests for the strategy definition on CQG Gateway.
Public Method DeleteQFormula | Starts an asynchronous query for QFormula deletion.
Public Method GWLogoff | Logoff from the Gateway.
Public Method GWLogon | Login to Gateway with the specified username and password.
Public Method GWOTPLogon | Log in to Gateway with specified username, password and OneTimePassword
Public Method InvokeStrategyQuoteRequest | Invokes quotes request for strategies (UDS) from GW
Public Method IsValid | Checks if the argument has a valid value.
Public Method LogOn | Log on to LoginDB via login service and startup CEL if remote Open API user passes the authentication
Public Method ModifyCompoundOrder | Obsolete method, please use ModifyCompoundOrderEx instead.
Public Method ModifyCompoundOrderEx | Async request to modify compound order. Modification currently supports only adding new parts (legs) to the existing active compound order.
Public Method NewInstrument | Resolves the given symbol and subscribes to the instrument.
Public Method Obsolete140 | Obsolete method
Public Method Obsolete141 | Obsolete method
Public Method Obsolete142 | Obsolete method
Public Method Obsolete143 | Obsolete method
Public Method Obsolete144 | Obsolete method
Public Method PlaceCompoundOrder | Obsolete method, please use PlaceCompoundOrderEx instead.
Public Method PlaceCompoundOrderEx | Async request to place compound order.
Public Method QueryOrders | Sends a historical orders information query. The query is constructed based on the passed arguments.
Public Method QueryPositionsStatement | Sends an asynchronous query for account positions statement. The query is constructed based on the passed arguments.
Public Method QuerySummariesStatement | Sends an asynchronous query for account summaries statement. The query is constructed based on the passed arguments.
Public Method RegisterAlgorithmicOrder | Registers an algorithmic order type.
Public Method RemoveAdvancedStudy | Unsubscribe from and remove the CQGAdvancedStudy from CQGAdvancedStudies
Public Method RemoveAllAdvancedStudies | Unsubscribe/remove all advanced studies
Public Method RemoveAllConditions | Unsubscribes/removes all conditions.
Public Method RemoveAllConstantVolumeBars | Unsubscribes/removes all constant volume bars.
Public Method RemoveAllCustomStudies | Unsubscribes/removes all custom studies.
Public Method RemoveAllExpressions | Unsubscribes/removes all expressions.
Public Method RemoveAllInstruments | Unsubscribes and removes all currently resolved instruments from the Instruments collection.
Public Method RemoveAllPointAndFigureBars | Unsubscribes/removes all point and figure bars.
Public Method RemoveAllRangeBars | Unsubscribe/remove all range bars
Public Method RemoveAllRenkoBars | Unsubscribe/remove all renko bars
Public Method RemoveAllSubMinuteBars | Unsubscribe/remove all sub minute bars
Public Method RemoveAllTFlowBars | Unsubscribes/removes all TFlow bars.
Public Method RemoveAllTicks | Unsubscribes/removes all ticks.
Public Method RemoveAllTimedBars | Unsubscribes/removes all timed bars.
Public Method RemoveAllTradingSystems | Unsubscribes/removes all trading systems.
Public Method RemoveAllYields | Unsubscribe/remove all yields
Public Method RemoveCondition | Unsubscribes from and removes the CQGCondition from the CQGConditions collection.
Public Method RemoveConstantVolumeBars | Unsubscribes from and removes a CQGConstantVolumeBars from the CQGConstantVolumeBarsCollection.
Public Method RemoveCustomStudy | Unsubscribes from and removes a CQGCustomStudy from the CQGCustomStudies.
Public Method RemoveExpression | Unsubscribes from and removes the CQGExpression from CQGExpressions.
Public Method RemoveInstrument | Unsubscribes and removes the Instrument from the Instruments collection.
Public Method RemoveInstrumentsGroup | Removes a group of instruments.
Public Method RemovePointAndFigureBars | Unsubscribes from and removes a CQGPointAndFigureBars from the CQGPointAndFigureBarsCollection.
Public Method RemoveRangeBars | Unsubscribe from and remove the CQGRangeBars from CQGRangeBarsCollection
Public Method RemoveRenkoBars | Unsubscribe from and remove the CQGRenkoBars from CQGRenkoBarsCollection
Public Method RemoveSubMinuteBars | Unsubscribe from and remove the CQGSubMinuteBars from CQGSubMinuteBarsCollection
Public Method RemoveTFlowBars | Unsubscribes from and removes a CQGTFlowBars from the CQGTFlowBarsCollection.
Public Method RemoveTicks | Stops request that produced the CQGTicks object and removes the object from CQGTicksCollection.
Public Method RemoveTimedBars | Unsubscribes from and removes a CQGTimedBars from the CQGTimedBarsCollection.
Public Method RemoveTradingSystem | Unsubscribes from and removes the CQGTradingSystem from CQGTradingSystems.
Public Method RemoveYields | Unsubscribe from and remove the CQGYields from CQGYieldsCollection
Public Method RequestAdvancedStudy | Starts an asynchronous request for advanced study
Public Method RequestAdvancedStudyDefinitions | Starts an asynchronous query for advanced study definitions
Public Method RequestBarsTimestamps | Starts an asynchronous query for timed bars timestamps.
Public Method RequestCommodityInstruments | Requests a list of instrument names corresponding to the specified commodity.
Public Method RequestCondition | Starts an asynchronous request for condition.
Public Method RequestConditionDefinitions | Starts an asynchronous query for condition definitions.
Public Method RequestConstantVolumeBars | Starts an asynchronous request for constant volume bars.
Public Method RequestCustomSessions | Starts an asynchronous query for all custom sessions available in CQGIC.
Public Method RequestCustomStudy | Starts an asynchronous request for custom study.
Public Method RequestCustomStudyDefinitions | Starts an asynchronous query for custom study definitions.
Public Method RequestDataSources | Starts an asynchronous query for data sources.
Public Method RequestDataSourceSymbols | Starts an asynchronous query for symbols of a data source.
Public Method RequestExpression | Starts an asynchronous request for an expression.
Public Method RequestGWConnection | Starts a gateway connection request
Public Method RequestHistoricalSessions | Starts an asynchronous request for historical sessions.
Public Method RequestInstrumentsGroup | Requests a group of instruments.
Public Method RequestManualFills | Starts an asynchronous query of manual fills for a gateway account.
Public Method RequestManualFillUpdate | Executes the given manual fill request.
Public Method RequestOrders | Performs orders querying
Public Method RequestPointAndFigureBars | Starts an asynchronous request for a point and figure bars.
Public Method RequestQFormulaDefinition | Starts an asynchronous query for QFormula definition by QFormula name or number.
Public Method RequestQFormulaDefinitions | Starts an asynchronous query for QFormula definitions.
Public Method RequestRangeBars | Starts an asynchronous request for range bars
Public Method RequestRenkoBars | Starts an asynchronous request for renko bars
Public Method RequestSubMinuteBars | Starts an asynchronous request for sub minute bars
Public Method RequestTFlowBars | Starts an asynchronous request for TFlow bars.
Public Method RequestTicks | Starts an asynchronous request for ticks.
Public Method RequestTimedBars | Starts an asynchronous request for timed bars.
Public Method RequestTradableCommodities | Starts an asynchronous query for tradable commodities.
Public Method RequestTradableExchanges | Starts an asynchronous query for tradable exchanges.
Public Method RequestTradingSystem | Starts an asynchronous request for trading system.
Public Method RequestTradingSystemDefinitions | Starts an asynchronous query for trading system definitions.
Public Method RequestYields | Starts an asynchronous request for yields
Public Method Shutdown | Shuts down the CQG API.
Public Method Startup | Starts up the CQG API.
Public Method SubscribeNewInstrument | Resolves a new instrument and subscribe to it asynchronously.
Public Method TerminateCQGIC | Terminates or restarts the local CQGIC.
Public Method UnregisterAlgorithmicOrder | Unregisters the algorithmic order types by its GUID.

Public Properties

Public Property Accounts | Returns the collection of accounts that belong to the current trader logon name.
Public Property AccountSubscriptionLevel | Gets/sets the account subscription level.
Public Property AllAdvancedStudies | Returns collection of advanced studies requested only by this instance of CEL
Public Property AllConditions | Returns collection of conditions requested only by this instance of CEL.
Public Property AllConstantVolumeBars | Returns collection of constant volume bars requested only by this instance of CEL.
Public Property AllCustomStudies | Returns collection of custom studies requested only by this instance of CEL.
Public Property AllExpressions | Returns a collection of all expressions that were requested during this instance of CQGCEL.
Public Property AllInstrumentsGroups | Returns the collection of instruments groups.
Public Property AllManualFills | Gets the collection of all manual fills.
Public Property AllPointAndFigureBars | Returns the collection of point and figure bars requested only by this instance of CEL.
Public Property AllRangeBars | Returns collection of CQGRangeBars requested only by this instance of CEL
Public Property AllRenkoBars | Returns collection of CQGRenkoBars requested only by this instance of CEL
Public Property AllStrategyDefinitions | Returns all strategy definitions.
Public Property AllSubMinuteBars | Returns collection of CQGSubMinuteBar bars requested only by this instance of CEL
Public Property AllTFlowBars | Returns collection of TFlow bars, requested only by this instance of CEL.
Public Property AllTicks | Returns the collection of ticks requested only by this instance of CEL.
Public Property AllTimedBars | Returns a collection of all timed bars that were requested during this instance of CQGCEL.
Public Property AllTradingSystems | Returns the collection of trading systems requested only by this instance of CEL.
Public Property AllYields | Returns collection of yields requested only by this instance of CEL
Public Property APIConfiguration | Controls the CQG API current configuration.
Public Property Configuration | Gets/sets the current configuration of CQGCEL. Deprecated. Deprecated! In CQG API v.3.0 and higher a new interface was introduced for configuration management: CQGAPIConfig. However this structure is still preserved for backward compatibility.
Public Property CurrencyRates | Returns the collection of currency rates from all FCMs.
Public Property DirectEventsAccessor | Returns the CQGDirectEventsAccessor object used to raise non-dispatch (i.e., vtbl) events.
Public Property Environment | Returns the CQGCEL environment information.
Public Property Instruments | Returns the collection of currently resolved instruments.
Public Property InternalOrders | Returns the collection of orders placed for all accounts from within this CQG API instance.
Public Property IsStarted | This property returns the current status of CQGCEL startup process.
Public Property Logger | Returns the Logger object of CQGCEL.
Public Property Orders | Returns the collection of all accounts orders available from current CQG API session.
Public Property OTPRequired | Returns whether the Gateway requires a one-time password or not.

Events

Public Event AccountChanged

This event is fired when the account or position information is changed.

Public Event AdvancedStudyAdded | Fired when CQGCurves item is added to the end of CQGAdvancedStudy
Public Event AdvancedStudyDefinitionsResolved | Fired when the definitions of advanced studies are resolved
Public Event AdvancedStudyInserted | Fired when CQGCurves item is inserted
Public Event AdvancedStudyRemoved | Fired when CQGCurves item is removed
Public Event AdvancedStudyResolved | Fired when the advanced study (CQGAdvancedStudy) is resolved
Public Event AdvancedStudyUpdated | Fired when CQGCurves item is updated
Public Event AlgorithmicOrderPlaced

This event is fired when an algorithmic order is placed from CQGIC.

Public Event AlgorithmicOrderRegistrationComplete

This event is fired when the algorithmic order registration is completed (suceeded or failed).

Public Event AllOrdersCanceled

This event is fired when all orders are cancelled only from within CQG IC.

Public Event AuthenticationStatusChanged | Fired when remote API client authentication status is changed
Public Event BarsTimestampsResolved

This event is fired when the collection of timed bars timestamps (CQGBarsTimestamps) is resolved or when some error has occurred during the timed bars timestamps request processing.

Public Event CELStarted

This event is fired when the CQGCEL object is successfully started up.

Public Event CommodityInstrumentsResolved

This event is fired when a previously requested commodity symbol is resolved into the instruments list.

Public Event ConditionAdded

This event is fired when CQGConditionResult item is added to the end of the CQGCondition.

Public Event ConditionDefinitionsResolved

This event is fired when condition definitions are resolved or when some error has occurred during the request processing.

Public Event ConditionInserted

This event is fired when a CQGConditionResult item is inserted.

Public Event ConditionRemoved

This event is fired when a CQGConditionResult item is removed.

Public Event ConditionResolved

This event is fired when the condition (CQGCondition) is resolved or when some error has occurred during the condition request processing.

Public Event ConditionUpdated

This event is fired when a CQGConditionResult item is updated.

Public Event ConstantVolumeBarsAdded

This event is fired when a CQGConstantVolumeBar item is added to the end of CQGConstantVolumeBars.

Public Event ConstantVolumeBarsInserted

This event is fired when a CQGConstantVolumeBar item is inserted to the CQGConstantVolumeBars collection.

Public Event ConstantVolumeBarsRemoved

This event is fired when a CQGConstantVolumeBar item is removed from the CQGConstantVolumeBars collection.

Public Event ConstantVolumeBarsResolved

This event is fired when the collection of constant volume bars (CQGConstantVolumeBars) is resolved or when some error has occurred during the constant volume bars request processing.

Public Event ConstantVolumeBarsUpdated

This event is fired when the CQGConstantVolumeBar item is updated.

Public Event CurrencyRatesChanged

This event is fired when an FCM changes a currency rate.

Public Event CustomSessionsResolved

This event is fired as a response to a custom sessions request either when the collection is resolved or when an error has occurred during the request processing.

Public Event CustomStudyAdded

This event is fired when a CQGCurves item is added to the end of CQGCustomStudy.

Public Event CustomStudyDefinitionsResolved

This event is fired when the definitions of custom studies are resolved or when some error has occurred during the request processing.

Public Event CustomStudyInserted

This event is fired when a CQGCurves item is inserted.

Public Event CustomStudyRemoved

This event is fired when a CQGCurves item is removed.

Public Event CustomStudyResolved

This event is fired when the custom study (CQGCustomStudy) is resolved or when some error has occurred during the custom studies request processing.

Public Event CustomStudyUpdated

This event is fired when the CQGCurves item is updated.

Public Event DataConnectionStatusChanged

This event is fired when some changes occurred in the connection with the CQG data server.

Public Event DataError

This event is fired when CQGCEL detects some abnormal discrepancy between data expected and data received.

Public Event DataSourcesResolved

This event is fired as a response to a data sources request either when the collection is resolved or when an error has occurred during the request processing.

Public Event DataSourceSymbolsResolved

This event is fired as a response to a data source symbols request either when the collection is resolved or when an error has occurred during the request processing.

Public Event ExpressionAdded

This event is fired when a CQGExpressionOutputs item is added to the end of CQGExpression.

Public Event ExpressionInserted

This event is fired when a CQGExpression item is inserted to the CQGExpressions collection.

Public Event ExpressionRemoved

This event is fired when a CQGExpression item is removed from the CQGExpressions collection.

Public Event ExpressionResolved

This event is fired when the expression (CQGExpression) is resolved or when some error has occurred during the expression request processing.

Public Event ExpressionUpdated

This event is fired when a CQGExpressionOutputs item is updated.

Public Event GWConnectionStatusChanged

This event is fired when the status of the connection with the CQG Gateway is changed.

Public Event GWEnvironmentChanged

This event is fired when a CQG Gateway environment change occurs.

Public Event HistoricalSessionsResolved

Fired when the historical sessions (CQGSessionsCollection) are resolved or when some error has occurred during processing the historical sessions request.

Public Event ICConnectionStatusChanged

This event is fired when the CQGIC connection status has been changed.

Public Event IncorrectSymbol

This event is fired when a not tradable symbol name is passed to the NewInstrument method.

Deprecated. Use InstrumentResolved instead.

Public Event InstrumentChanged

This event is fired when any of the instrument quotes or dynamic instrument properties are changed.

Public Event InstrumentDOMChanged

This event is fired when instrument's DOM* is updated.

Public Event InstrumentResolved

This event is fired when a new instrument is resolved and subscribed or a resolution process failed.

Public Event InstrumentsGroupChanged

This event is fired when the instruments group was changed. Instrument was added or removed from the group.

Public Event InstrumentsGroupResolved

This event is fired when the instruments group subscription is completed with either success or failure.

Public Event InstrumentSubscribed

This event is fired when a new instrument is resolved and subscribed.

Deprecated. Use InstrumentResolved instead.

Public Event IsReady

This event was added especially to be used in Excel macros. It is fired every time before any other event is fired to check the Excel readiness to receive user events.

Generally it can be used for similar purposes from other host applications to control event flow by informing CQG API about readiness to receive events.

Public Event LineTimeChanged

This event is fired once every second to synchronize with the exchange.

Public Event ManualFillChanged

This event is fired when a new manual fill was added, some manual fill properties were changed, or the manual fill was removed only if subscription data level for appropriate request was requested with updates notifications.

Public Event ManualFillsResolved

This event is fired when the list of manual fills request is resolved or when some error has occurred during manual fills request processing.

Public Event ManualFillUpdateResolved

This event is fired when the manual fill request is resolved or when some error has occurred during manual fills processing.

Public Event Obsolete104 | Obsolete method
Public Event Obsolete105 | Obsolete method
Public Event Obsolete106 | Obsolete method
Public Event Obsolete107 | Obsolete method
Public Event Obsolete108 | Obsolete method
Public Event OnIdle

This event is fired when CQGCEL has nothing to do.

Public Event OnQueryProgress

This event is fired if a query has some progress: either new results arrived or its status is changed.

Public Event OrderChanged

This event is fired when a new order is added to the collection, the order status is changed, or the order is removed from the collection.

Public Event PasswordChanged | Fired when remote API client change password request is resolved
Public Event PointAndFigureBarsAdded

This event is fired when a CQGPointAndFigureBar item is added to the end of CQGPointAndFigureBars.

Public Event PointAndFigureBarsInserted

This event is fired when a CQGPointAndFigureBar item is inserted to the CQGPointAndFigureBars collection.

Public Event PointAndFigureBarsRemoved

This event is fired when a CQGPointAndFigureBar item is removed from the CQGPointAndFigureBars collection.

Public Event PointAndFigureBarsResolved

This event is fired when the collection of point and figure bars (CQGPointAndFigureBars) is resolved or when some error has occurred during the point and figure bars request processing.

Public Event PointAndFigureBarsUpdated

This event is fired when the CQGPointAndFigureBar item is updated.

Public Event PositionsStatementResolved

This event is fired when the positions statement (CQGPositionsStatement) is resolved or when some error has occurred while processing the positions statement request.

Public Event QFormulaCreated

This event is fired when new QFormula is created or when some error has occurred during the request processing.

Public Event QFormulaDefinitionResolved

Obsolete. Please use QFormulaDefinitionResolvedEx instead.

Public Event QFormulaDefinitionResolvedEx | Fired when requested by name or number CQGQFormulaDefinition is resolved.
Public Event QFormulaDefinitionsResolved

This event is fired when the definitions of QFormulas are resolved or when some error has occurred during the request processing.

Public Event QFormulaDeleted

This event is fired when QFormula is deleted or when some error has occurred during the request processing.

Public Event RangeBarsAdded | Fired when CQGRangeBar item is added to the end of CQGRangeBars
Public Event RangeBarsInserted | Fired when CQGRangeBar item is inserted
Public Event RangeBarsRemoved | Fired when CQGRangeBar item is removed
Public Event RangeBarsResolved | Fired when the collection of range bars (CQGRangeBars) is resolved
Public Event RangeBarsUpdated | Fired when CQGRangeBar item is updated
Public Event RenkoBarsAdded | Fired when CQGRenkoBar item is added to the end of CQGRenkoBars
Public Event RenkoBarsInserted | Fired when CQGRenkoBar item is inserted
Public Event RenkoBarsRemoved | Fired when CQGRenkoBar item is removed
Public Event RenkoBarsResolved | Fired when the collection of renko bars (CQGRenkoBars) is resolved
Public Event RenkoBarsUpdated | Fired when CQGRenkoBar item is updated
Public Event StrategyDefinitionProgress

This event is fired, when the strategy definition status is changed or when some error has occurred during the request processing.

Public Event StrategyQuoteRequestResolved | Fired when a quote request is completed with success/fail.
Public Event SubMinuteBarsAdded

This event is fired when a CQGSubMinuteBar item is added to the end of CQGSubMinuteBars.

Public Event SubMinuteBarsInserted

This event is fired when a CQGSubMinuteBar item is inserted to the CQGSubMinuteBars collection.

Public Event SubMinuteBarsRemoved

This event is fired when a CQGSubMinuteBar item is removed from the CQGSubMinuteBars collection.

Public Event SubMinuteBarsResolved

This event is fired when the collection of sub minute bars (CQGSubMinuteBars) is resolved or when some error has occurred during the sub minute bars request processing.

Public Event SubMinuteBarsUpdated

This event is fired when a CQGSubMinuteBar item is updated

Public Event SummariesStatementResolved

This event is fired when the summaries statement (CQGSummariesStatement) is resolved or when some error has occurred while processing the summaries statement request.

Public Event TFlowBarsAdded

This event is fired when a CQGTFlowBar item is added to the end of CQGTFlowBars.

Public Event TFlowBarsInserted

This event is fired when a CQGTFlowBar item is inserted to the CQGTFlowBars collection.

Public Event TFlowBarsRemoved

This event is fired when a CQGTFlowBar item is removed from the CQGTFlowBars collection.

Public Event TFlowBarsResolved

This event is fired when the collection of TFlow bars (CQGTFlowBars) is resolved or when some error occured during TFlow bars request processing.

Public Event TFlowBarsUpdated

This event is fired when a CQGTFlowBar item is updated.

Public Event TicksAdded

This event is fired when CQGTick items are added to the CQGTicks collection.

Public Event TicksRemoved

This event is fired when CQGTick item is removed from the CQGTicks collection.

Public Event TicksResolved

This event is fired when the CQGTicks collection is resolved or when some error has occurred during the ticks request processing.

Public Event TimedBarsAdded

This event is fired when a CQGTimedBar item is added to the end of CQGTimedBars.

Public Event TimedBarsInserted

This event is fired when a CQGTimedBar item is inserted to the CQGTimedBars collection.

Public Event TimedBarsRemoved

This event is fired when a CQGTimedBar item is removed from the CQGTimedBars collection.

Public Event TimedBarsResolved

This event is fired when the collection of timed bars (CQGTimedBars) is resolved or when some error has occurred during the timed bars request processing.

Public Event TimedBarsUpdated

This event is fired when a CQGTimedBar item is updated.

Public Event TradableCommoditiesResolved

This event is fired as a response to a tradable commodities request either when the collection is resolved or when an error has occurred during the request processing.

Public Event TradableExchangesResolved

This event is fired as a response to a tradable exchanges request either when the collection is resolved or when an error has occurred during the request processing.

Public Event TradingSystemAddNotification

This event is fired when trade row and/or statistics are added to the trading system.

Public Event TradingSystemDefinitionsResolved

This event is fired when the definitions of trading systems are resolved or when some error has occurred during request processing.

Public Event TradingSystemInsertNotification

This event is fired when trade row and/or statistics are inserted to the trading system.

Public Event TradingSystemRemoveNotification

This event is fired when trade row and/or statistics are removed to the trading system.

Public Event TradingSystemResolved

This event is fired when the trading system (CQGTradingSystem) is resolved or when some error has occurred while processing the trading system request.

Public Event TradingSystemTradeRelationAddNotification

This event is fired, when a relation between trade entry/exit is added to a trading system.

Public Event TradingSystemUpdateNotification

This event is fired when trade row and/or statistics are updated in a trading system.

Public Event YieldsAdded

This event is fired when a CQGYield item is added to the end of CQGYields.

Public Event YieldsInserted

This event is fired when a CQGYield item is inserted to the CQGYields collection.

Public Event YieldsRemoved

This event is fired when a CQGYield item is removed from the CQGYields collection.

Public Event YieldsResolved

This event is fired when the collection of yields (CQGYields) is resolved or when some error has occurred during the yields request processing.

Public Event YieldsUpdated

This event is fired when a CQGYield item is updated.

See Also

CQGCEL Interface


%%PageItemTitle%%

ActivateAllOrders Method
cqg_account
An optional CQGAccount object representing the account parked orders of which to activate.
cqg_instrument

An optional CQGInstrument object representing the instrument on which the parked order should have been placed in order to be activated by this method call.

from_all_traders
An optional flag identifying whether the parked orders from all traders should be activated.
order_side
Identifies the side of the parked orders to be activated. The parameter is optional.
CQGCEL Interface : ActivateAllOrders Method

Glossary Item Box

Description

Activates a set of parked orders.

The selection of the orders to be activated is performed based on the passed arguments. If no argument is passed all currently existing parked orders are activated.

Syntax

Visual Basic
Public Sub ActivateAllOrders( _
   Optional ByVal cqg_account As CQGAccount = 0, _
   Optional ByVal cqg_instrument As CQGInstrument = 0, _
   Optional ByVal from_all_traders As Boolean = False, _
   Optional ByVal order_side As eOrderSide = osdUndefined _
)

Parameters

cqg_account
An optional CQGAccount object representing the account parked orders of which to activate.
cqg_instrument

An optional CQGInstrument object representing the instrument on which the parked order should have been placed in order to be activated by this method call.

from_all_traders
An optional flag identifying whether the parked orders from all traders should be activated.
order_side
Value | Description
osdBuy Side properties return this value if CQGAPIConfig.UseOrderSide is set to True.

Depending on the owner, osdBuy value is returned in case of:

  • the object is a CQGTrade referring to a buy trade
  • the object is a CQGPosition referring to a long position.

  • the object is a CQGOrder referring to an order of buy type.
  • the object is a CQGFill referring to a fill of buy type.
osdSell Side properties return this value if CQGAPIConfig.UseOrderSide is set to True.

Depending on the owner, osdSell value is returned in case of:

  • the object is a CQGTrade referring to a sell trade
  • the object is a CQGPosition referring to a short position.

  • the object is a CQGOrder referring to an order of sell type.
  • the object is a CQGFill referring to a fill of sell type.
osdUndefined | Side properties return this value if CQGAPIConfig.UseOrderSide is set to False.
Identifies the side of the parked orders to be activated. The parameter is optional.

Remarks

This method works in asynchronous mode, which means that it returns after the request is sent, but without waiting for its results.

If the order is not parked and the user tries to activate it, an exception will be thrown.

This method changes the order status to osInOrderBook. The change will be reported via OrderChanged event.

Example

See the usage of CQGCEL methods in the OrderChanged event's example section.

See Also

CQGCEL Interface | CQGCEL Members | CQGOrder Interface | Activate Method


%%PageItemTitle%%

ActivateAllOrdersEx Method
cqg_order_action_request
CQGOrderActionRequest instance
CQGCEL Interface : ActivateAllOrdersEx Method

Glossary Item Box

Description

Activate all orders

Syntax

Visual Basic
Public Sub ActivateAllOrdersEx( _
   ByVal cqg_order_action_request As CQGOrderActionRequest _
)

Parameters

cqg_order_action_request
CQGOrderActionRequest instance

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

CancelAllOrders Method
cqg_account

An optional CQGAccount object representing the account orders of which to cancel.

cqg_instrument

An optional CQGInstrument object representing the instrument on which the order should have been placed in order to be cancelled by this method call.

from_all_traders

An optional flag identifying whether the orders from all traders should be cancelled.

parked_

An optional flag identifying which orders should be cancelled:
- if True, the parked orders will be cancelled
- if False, all orders except the parked ones will be cancelled

order_side
Identifies the side of the orders to be cancelled. The parameter is optional
CQGCEL Interface : CancelAllOrders Method

Glossary Item Box

Description

Cancels a set of orders.

The selection of the orders to be cancelled is performed based on the passed arguments. If no argument is passed all currently existing orders are cancelled.

Syntax

Visual Basic
Public Sub CancelAllOrders( _
   Optional ByVal cqg_account As CQGAccount = 0, _
   Optional ByVal cqg_instrument As CQGInstrument = 0, _
   Optional ByVal from_all_traders As Boolean = False, _
   Optional ByVal parked_ As Boolean = False, _
   Optional ByVal order_side As eOrderSide = osdUndefined _
)

Parameters

cqg_account

An optional CQGAccount object representing the account orders of which to cancel.

cqg_instrument

An optional CQGInstrument object representing the instrument on which the order should have been placed in order to be cancelled by this method call.

from_all_traders

An optional flag identifying whether the orders from all traders should be cancelled.

parked_

An optional flag identifying which orders should be cancelled:
- if True, the parked orders will be cancelled
- if False, all orders except the parked ones will be cancelled

order_side
Value | Description
osdBuy Side properties return this value if CQGAPIConfig.UseOrderSide is set to True.

Depending on the owner, osdBuy value is returned in case of:

  • the object is a CQGTrade referring to a buy trade
  • the object is a CQGPosition referring to a long position.

  • the object is a CQGOrder referring to an order of buy type.
  • the object is a CQGFill referring to a fill of buy type.
osdSell Side properties return this value if CQGAPIConfig.UseOrderSide is set to True.

Depending on the owner, osdSell value is returned in case of:

  • the object is a CQGTrade referring to a sell trade
  • the object is a CQGPosition referring to a short position.

  • the object is a CQGOrder referring to an order of sell type.
  • the object is a CQGFill referring to a fill of sell type.
osdUndefined | Side properties return this value if CQGAPIConfig.UseOrderSide is set to False.
Identifies the side of the orders to be cancelled. The parameter is optional

Remarks

This method works in asynchronous mode, which means that it returns after the request is sent, but without waiting for its results.

This method triggers several order status changes. The final status is osCancelled. Each status change will be reported via OrderChanged event.

Example

See the usage of CQGCEL methods in the OrderChanged event's example section.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

CancelAllOrdersEx Method
cqg_order_action_request
CQGOrderActionRequest instance
CQGCEL Interface : CancelAllOrdersEx Method

Glossary Item Box

Description

Cancels all orders

Syntax

Visual Basic
Public Sub CancelAllOrdersEx( _
   ByVal cqg_order_action_request As CQGOrderActionRequest _
)

Parameters

cqg_order_action_request
CQGOrderActionRequest instance

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

ChangePassword Method
username_

User name

old_password
Old password
new_password
New password
CQGCEL Interface : ChangePassword Method

Glossary Item Box

Description

Changes the password which is used for remote Open API user authentication

Syntax

Visual Basic
Public Sub ChangePassword( _
   ByVal username_ As String, _
   ByVal old_password As String, _
   ByVal new_password As String _
)

Parameters

username_

User name

old_password
Old password
new_password
New password

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

ChangeRemoteOpenAPIServer Method
server_address
Remote Open API server address
CQGCEL Interface : ChangeRemoteOpenAPIServer Method

Glossary Item Box

Description

Changes current remote Open API server

Syntax

Visual Basic
Public Sub ChangeRemoteOpenAPIServer( _
   ByVal server_address As String _
)

Parameters

server_address
Remote Open API server address

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

CreateAccountsCollection Method
CQGCEL Interface : CreateAccountsCollection Method

Glossary Item Box

Description

Creates an empty collection of accounts

Syntax

Visual Basic
Public Function CreateAccountsCollection() As CQGAccounts

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

CreateAdvancedStudyRequest Method
name_or_abbr
Requested advanced study name or abbreviation
CQGCEL Interface : CreateAdvancedStudyRequest Method

Glossary Item Box

Description

Creates new CQGAdvancedStudyRequest object based on advanced study name

Syntax

Visual Basic
Public Function CreateAdvancedStudyRequest( _
   ByVal name_or_abbr As String _
) As CQGAdvancedStudyRequest

Parameters

name_or_abbr
Requested advanced study name or abbreviation

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

CreateAlgorithmicOrderDefinitions Method
CQGCEL Interface : CreateAlgorithmicOrderDefinitions Method

Glossary Item Box

Description

Creates a collection of algorithmic order properties' definitions.

Syntax

Visual Basic
Public Function CreateAlgorithmicOrderDefinitions() As CQGAlgorithmicOrderDefinitions

Return Type

Collection of algorithmic order definitions, represented as CQGAlgorithmicOrderDefinitions

Remarks

This collection should be filled and passed to the RegisterAlgorithmicOrder method to register an algorithmic order.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

CreateBracketOrder Method
cqg_order
stoploss_order_type
CQGCEL Interface : CreateBracketOrder Method

Glossary Item Box

Description

Creates a new bracket order

Syntax

Visual Basic
Public Function CreateBracketOrder( _
   ByVal cqg_order As CQGOrder, _
   Optional ByVal stoploss_order_type As eOrderType = otStop _
) As CQGBracketOrder

Parameters

cqg_order
stoploss_order_type
Value Description
otLimit

Limit order.

otMarket

Market order.

otStop

Stop order.

otStopLimit

Stop Limit order.

otUndefined

Undefined order type.

Remarks

Stop-loss order type can only be either otStop or otStopLimit.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

CreateConditionRequest Method
condition_name

Indicates the requested condition's name.

CQGCEL Interface : CreateConditionRequest Method

Glossary Item Box

Description

Creates a new CQGConditionRequest object based on the condition name.

Syntax

Visual Basic
Public Function CreateConditionRequest( _
   ByVal condition_name As String _
) As CQGConditionRequest

Parameters

condition_name

Indicates the requested condition's name.

Remarks

An exception will be thrown if no condition exists with the specified name.

The CQGConditionRequest.BaseExpression, CQGConditionRequest.RangeStart, CQGConditionRequest.RangeEnd properties, as well as all CQGConditionRequest.Parameter-s do not have default values and must be provided before passing the CQGConditionRequest object to the CQGCEL.RequestCondition method.

See Also

CQGCEL Interface | CQGCEL Members | CQGConditionRequest Interface | RequestCondition Method


%%PageItemTitle%%

CreateConstantVolumeBarsRequest Method
CQGCEL Interface : CreateConstantVolumeBarsRequest Method

Glossary Item Box

Description

Creates a new CQGConstantVolumeBarsRequest object.

Syntax

Visual Basic
Public Function CreateConstantVolumeBarsRequest() As CQGConstantVolumeBarsRequest

Remarks

The CQGConstantVolumeBarsRequest.Symbol, CQGConstantVolumeBarsRequest.RangeStart, CQGConstantVolumeBarsRequest.RangeEnd properties do not have default values and must be provided before passing the CQGConstantVolumeBarsRequest object to the RequestConstantVolumeBars method.

See Also

CQGCEL Interface | CQGCEL Members | CQGConstantVolumeBarsRequest Interface | RequestConstantVolumeBars Method


%%PageItemTitle%%

CreateCustomStudyRequest Method
name_or_abbr

The requested custom study name or abbreviation

CQGCEL Interface : CreateCustomStudyRequest Method

Glossary Item Box

Description

Creates a new CQGCustomStudyRequest object based on the custom study name or abbreviation.

Syntax

Visual Basic
Public Function CreateCustomStudyRequest( _
   ByVal name_or_abbr As String _
) As CQGCustomStudyRequest

Parameters

name_or_abbr

The requested custom study name or abbreviation

Remarks

An exception will be thrown if no custom study exists with the specified name or abbreviation.

The CQGCustomStudyRequest.BaseExpression, CQGCustomStudyRequest.RangeStart, CQGCustomStudyRequest.RangeEnd properties, as well as all CQGCustomStudyRequest.Parameter-s do not have default values and must be provided before passing the CQGCustomStudyRequest object to the RequestCustomStudy method.

See Also

CQGCEL Interface | CQGCEL Members | CQGCustomStudyRequest Interface | RequestCustomStudy Method


%%PageItemTitle%%

CreateExecutionPattern Method
cqg_definition

Strategy definition, for which the default pattern should be created

order_type

Type of the order, for which the default pattern should be created

CQGCEL Interface : CreateExecutionPattern Method

Glossary Item Box

Description

Creates an empty or default strategy execution pattern.

Syntax

Visual Basic
Public Function CreateExecutionPattern( _
   Optional ByVal cqg_definition As CQGStrategyDefinition = 0, _
   Optional ByVal order_type As eOrderType = otUndefined _
) As CQGExecutionPattern

Parameters

cqg_definition

Strategy definition, for which the default pattern should be created

order_type
Value Description
otLimit

Limit order.

otMarket

Market order.

otStop

Stop order.

otStopLimit

Stop Limit order.

otUndefined

Undefined order type.

Type of the order, for which the default pattern should be created

Return Type

A CQGExecutionPattern Object object, which represents the newly created execution pattern.

Remarks

If no parameter is specified an empty pattern is created; otherwise, a default pattern is created.

Note, that both parameters should be specified to create the default pattern, otherwise an exception will be thrown.

See Also

CQGCEL Interface | CQGCEL Members | CQGStrategyDefinition Interface | eOrderType | CQGExecutionPattern Interface


%%PageItemTitle%%

CreateExpressionRequest Method
CQGCEL Interface : CreateExpressionRequest Method

Glossary Item Box

Description

Creates a new CQGExpressionRequest object.

Syntax

Visual Basic
Public Function CreateExpressionRequest() As CQGExpressionRequest

See Also

CQGCEL Interface | CQGCEL Members | CQGExpressionRequest Interface | RequestExpression Method


%%PageItemTitle%%

CreateGWConnectionRequest Method
CQGCEL Interface : CreateGWConnectionRequest Method

Glossary Item Box

Description

Creates new CQGGWConnectionRequest object

Syntax

Visual Basic
Public Function CreateGWConnectionRequest() As CQGGWConnectionRequest

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

CreateHistoricalSessionsRequest Method
CQGCEL Interface : CreateHistoricalSessionsRequest Method

Glossary Item Box

Description

Creates new CQGHistoricalSessionsRequest object.

Syntax

Visual Basic
Public Function CreateHistoricalSessionsRequest() As CQGHistoricalSessionsRequest

Remarks

In order to use the created object to call the RequestHistoricalSessions method, CQGHistoricalSessionsRequest.Symbol, CQGHistoricalSessionsRequest.Type property values must be provided.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

CreateInstrumentRequest Method
CQGCEL Interface : CreateInstrumentRequest Method

Glossary Item Box

Description

Creates a new CQGInstrumentSubscriptionRequest object.

Syntax

Visual Basic
Public Function CreateInstrumentRequest() As CQGInstrumentSubscriptionRequest

Remarks

This method should be used if CQGAPIConfig.NewInstrumentMode is set to True, otherwise use the NewInstrument method.

This method allows metadata only subscriptions.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

CreateInstrumentsGroupRequest Method
CQGCEL Interface : CreateInstrumentsGroupRequest Method

Glossary Item Box

Description

Creates an instruments group request object.

Returns the corresponding CQGInstrumentsGroupRequest object to specify group request parameters.

Syntax

Visual Basic
Public Function CreateInstrumentsGroupRequest() As CQGInstrumentsGroupRequest

Return Type

The corresponding request object, represented as CQGInstrumentsGroupRequest

See Also

CQGCEL Interface | CQGCEL Members | CQGInstrumentsGroupRequest Interface | RequestInstrumentsGroup Method


%%PageItemTitle%%

CreateManualFillRequest Method
update_type

Specifies the update type for the request.

manual_fill

The prototype manual fill object, represented as CQGManualFill.

The created manual fill request will have its fields copied from this object.

CQGCEL Interface : CreateManualFillRequest Method

Glossary Item Box

Description

Creates a new manual fill request with the default parameters or with the given prototype manual fill parameters.

Syntax

Visual Basic
Public Function CreateManualFillRequest( _
   ByVal update_type As eManualFillUpdateType, _
   Optional ByVal manual_fill As CQGManualFill = 0 _
) As CQGManualFillRequest

Parameters

update_type
Value Description
mfutAdd

Add manual fill.

mfutDelete

Remove manual fill.

mfutModify

Change manual fill.

Specifies the update type for the request.

manual_fill

The prototype manual fill object, represented as CQGManualFill.

The created manual fill request will have its fields copied from this object.

Remarks

In order to function, this method requires that the user is logged on to CQG gateway.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

CreateOrder Method
order_type
The type of order which is to be created.
cqg_instrument
The CQGInstrument object on which the order is to be created.
cqg_account
The CQGAccount object for which the order is to be created.
order_quantity

The quantity value of the order which is to be created.

Note: If the UseOrderSide setting is set to False the side of the order should be reflected by the quantity sign.

order_side
The side of order which is to be created. The parameter is optional.
limit_price
The limit price of the order which is to be created if the orders of current type have a limit price. The parameter is optional.
stop_price
The stop price of the order which is to be created if the orders of current type have a stop price. The parameter is optional.
ue_name_part
The part of user friendly name of the order to be created which can be given by user. The rest of the UEName is generated automatically. The parameter is optional.
CQGCEL Interface : CreateOrder Method

Glossary Item Box

Description

Creates an order object.

Syntax

Visual Basic
Public Function CreateOrder( _
   ByVal order_type As eOrderType, _
   ByVal cqg_instrument As CQGInstrument, _
   ByVal cqg_account As CQGAccount, _
   ByVal order_quantity As Long, _
   Optional ByVal order_side As eOrderSide = osdUndefined, _
   Optional ByVal limit_price As Double = 0, _
   Optional ByVal stop_price As Double = 0, _
   Optional ByVal ue_name_part As String = "" _
) As CQGOrder

Parameters

order_type
Value Description
otLimit

Limit order.

otMarket

Market order.

otStop

Stop order.

otStopLimit

Stop Limit order.

otUndefined

Undefined order type.

The type of order which is to be created.
cqg_instrument
The CQGInstrument object on which the order is to be created.
cqg_account
The CQGAccount object for which the order is to be created.
order_quantity

The quantity value of the order which is to be created.

Note: If the UseOrderSide setting is set to False the side of the order should be reflected by the quantity sign.

order_side
Value | Description
osdBuy Side properties return this value if CQGAPIConfig.UseOrderSide is set to True.

Depending on the owner, osdBuy value is returned in case of:

  • the object is a CQGTrade referring to a buy trade
  • the object is a CQGPosition referring to a long position.

  • the object is a CQGOrder referring to an order of buy type.
  • the object is a CQGFill referring to a fill of buy type.
osdSell Side properties return this value if CQGAPIConfig.UseOrderSide is set to True.

Depending on the owner, osdSell value is returned in case of:

  • the object is a CQGTrade referring to a sell trade
  • the object is a CQGPosition referring to a short position.

  • the object is a CQGOrder referring to an order of sell type.
  • the object is a CQGFill referring to a fill of sell type.
osdUndefined | Side properties return this value if CQGAPIConfig.UseOrderSide is set to False.
The side of order which is to be created. The parameter is optional.
limit_price
The limit price of the order which is to be created if the orders of current type have a limit price. The parameter is optional.
stop_price
The stop price of the order which is to be created if the orders of current type have a stop price. The parameter is optional.
ue_name_part
The part of user friendly name of the order to be created which can be given by user. The rest of the UEName is generated automatically. The parameter is optional.

Return Type

A CQGOrder object which represents the newly created order.

Remarks

Depending on its type, the order can be either placed as is or some properties should be set before actual placing.

Some of the properties can be modified after order creation and before the order is placed. For more information see the CQGOrder and CQGOrderProperties objects.

The status of the order is set to osNotSent and its state to olsNotSent before the CQGOrder.Place method is called.

Example

See the usage of CreateOrder method in the OrderChanged event's example section.

See Also

CQGCEL Interface | CQGCEL Members | CQGOrder Interface


%%PageItemTitle%%

CreateOrderActionRequest Method
CQGCEL Interface : CreateOrderActionRequest Method

Glossary Item Box

Description

Creates new CQGOrderActionRequest object

Syntax

Visual Basic
Public Function CreateOrderActionRequest() As CQGOrderActionRequest

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

CreateOrderByInstrumentName Method
order_type

Type of the order

The CQGOrder.Properties collection depends on the order type.

Depending on it, calling the CQGOrder.PrepareModify method will return different results.

instrument_name

The detailed instrument name to be be used when creating the order. For example, F.US.EP.M20, C.US.CLE.U21.100 (U21 is September 2021; 100 is a strike), C.US.CLE.M20.N100 (M20 is June 2020; N100 is a negative strike: -100).

The full instrument name (e.g. F.US.EPZ16) is also supported for backward compatibility, but its using is depricated.

cqg_account
The account on which the order will be place.
order_quantity

This parameter can be signed or unsigned - depending on the CQGAPIConfig.UseOrderSide settings.

order_side

Side of the order

Not used if CQGAPIConfig.UseOrderSide is set to false.

limit_price

The limit price of the order

stop_price

The stop price of the order

ue_name_part

Part of the user-friendly name.

Other parts of UEName are automatically generated.

CQGCEL Interface : CreateOrderByInstrumentName Method

Glossary Item Box

Description

This method creates a new order with the specified parameters.

The result of this method is the same as the one from CQGCEL.CreateOrder, however it allows to create an order by providing the full instrument name without prior need to subscribe to the instrument.

Syntax

Visual Basic
Public Function CreateOrderByInstrumentName( _
   ByVal order_type As eOrderType, _
   ByVal instrument_name As String, _
   ByVal cqg_account As CQGAccount, _
   ByVal order_quantity As Long, _
   Optional ByVal order_side As eOrderSide = osdUndefined, _
   Optional ByVal limit_price As Double = 0, _
   Optional ByVal stop_price As Double = 0, _
   Optional ByVal ue_name_part As String = "" _
) As CQGOrder

Parameters

order_type
Value Description
otLimit

Limit order.

otMarket

Market order.

otStop

Stop order.

otStopLimit

Stop Limit order.

otUndefined

Undefined order type.

Type of the order

The CQGOrder.Properties collection depends on the order type.

Depending on it, calling the CQGOrder.PrepareModify method will return different results.

instrument_name

The detailed instrument name to be be used when creating the order. For example, F.US.EP.M20, C.US.CLE.U21.100 (U21 is September 2021; 100 is a strike), C.US.CLE.M20.N100 (M20 is June 2020; N100 is a negative strike: -100).

The full instrument name (e.g. F.US.EPZ16) is also supported for backward compatibility, but its using is depricated.

cqg_account
The account on which the order will be place.
order_quantity

This parameter can be signed or unsigned - depending on the CQGAPIConfig.UseOrderSide settings.

order_side
Value | Description
osdBuy Side properties return this value if CQGAPIConfig.UseOrderSide is set to True.

Depending on the owner, osdBuy value is returned in case of:

  • the object is a CQGTrade referring to a buy trade
  • the object is a CQGPosition referring to a long position.

  • the object is a CQGOrder referring to an order of buy type.
  • the object is a CQGFill referring to a fill of buy type.
osdSell Side properties return this value if CQGAPIConfig.UseOrderSide is set to True.

Depending on the owner, osdSell value is returned in case of:

  • the object is a CQGTrade referring to a sell trade
  • the object is a CQGPosition referring to a short position.

  • the object is a CQGOrder referring to an order of sell type.
  • the object is a CQGFill referring to a fill of sell type.
osdUndefined | Side properties return this value if CQGAPIConfig.UseOrderSide is set to False.

Side of the order

Not used if CQGAPIConfig.UseOrderSide is set to false.

limit_price

The limit price of the order

stop_price

The stop price of the order

ue_name_part

Part of the user-friendly name.

Other parts of UEName are automatically generated.

Return Type

Returns the newly created CQGOrder object if successful, otherwise throws an exception.

Example

The example below shows how to place market order using this method.

VB
C#
Option Explicit
Private WithEvents cel As CQGCEL
'...
m_CEL.APIConfiguration.UseOrderSide = False
Dim account As CQGAccount = m_CEL.Accounts.ItemByIndex(0)
Dim orderQuantity As Integer = -1 ' Negative value means a sell order
Dim order As CQG.CQGOrder
order = m_CEL.CreateOrderByInstrumentName(CQG.eOrderType.otMarket, "F.US.EPZ16", account, orderQuantity)
order.Place()
CQGCEL m_CEL = new CQGCEL();
//...
m_CEL.APIConfiguration.UseOrderSide = false;
CQGAccount account = m_CEL.Accounts.ItemByIndex[0];
int orderQuantity = -1; // Negative value means a sell order
CQGOrder order = m_CEL.CreateOrderByInstrumentName(eOrderType.otMarket, "F.US.EPZ16", account, orderQuantity);
order.Place();

See Also

CQGCEL Interface | CQGCEL Members | CQGOrder Interface


%%PageItemTitle%%

CreateOrderChain Method
CQGCEL Interface : CreateOrderChain Method

Glossary Item Box

Description

Creates empty order chain

Syntax

Visual Basic
Public Function CreateOrderChain() As CQGOrderChain

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

CreateOrderConstructor Method
order_type
OrderSide
CQGCEL Interface : CreateOrderConstructor Method

Glossary Item Box

Description

Creates a new CQGOrderConstructor object for regular orders

Syntax

Visual Basic
Public Function CreateOrderConstructor( _
   ByVal order_type As eOrderType, _
   ByVal OrderSide As eOrderSide _
) As CQGOrderConstructor

Parameters

order_type
Value Description
otLimit

Limit order.

otMarket

Market order.

otStop

Stop order.

otStopLimit

Stop Limit order.

otUndefined

Undefined order type.

OrderSide
Value | Description
osdBuy Side properties return this value if CQGAPIConfig.UseOrderSide is set to True.

Depending on the owner, osdBuy value is returned in case of:

  • the object is a CQGTrade referring to a buy trade
  • the object is a CQGPosition referring to a long position.

  • the object is a CQGOrder referring to an order of buy type.
  • the object is a CQGFill referring to a fill of buy type.
osdSell Side properties return this value if CQGAPIConfig.UseOrderSide is set to True.

Depending on the owner, osdSell value is returned in case of:

  • the object is a CQGTrade referring to a sell trade
  • the object is a CQGPosition referring to a short position.

  • the object is a CQGOrder referring to an order of sell type.
  • the object is a CQGFill referring to a fill of sell type.
osdUndefined | Side properties return this value if CQGAPIConfig.UseOrderSide is set to False.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

CreateOrdersRequest Method
CQGCEL Interface : CreateOrdersRequest Method

Glossary Item Box

Description

Creates new CQGOrdersRequest object

Syntax

Visual Basic
Public Function CreateOrdersRequest() As CQGOrdersRequest

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

CreatePointAndFigureBarsRequest Method
CQGCEL Interface : CreatePointAndFigureBarsRequest Method

Glossary Item Box

Description

Creates a new CQGPointAndFigureBarsRequest object.

Syntax

Visual Basic
Public Function CreatePointAndFigureBarsRequest() As CQGPointAndFigureBarsRequest

Remarks

The CQGPointAndFigureBarsRequest.Symbol, CQGPointAndFigureBarsRequest.RangeStart, and CQGPointAndFigureBarsRequest.RangeEnd properties do not have default values and must be provided before passing the CQGPointAndFigureBarsRequest object to the CQGCEL.RequestPointAndFiguresBars method.

See Also

CQGCEL Interface | CQGCEL Members | CQGPointAndFigureBarsRequest Interface | RequestPointAndFigureBars Method


%%PageItemTitle%%

CreateQFormula Method
qformula_name
Name of the new QFormula.
qformula_expression
Expression of the new QFormula
qformula_number
Number of the new QFormula. Optional, defaults to -1. All values <= 0 are considired as QFormula w/o number.
CQGCEL Interface : CreateQFormula Method

Glossary Item Box

Description

Starts an asynchronous query for QFormula creation.

Syntax

Visual Basic
Public Sub CreateQFormula( _
   ByVal qformula_name As String, _
   ByVal qformula_expression As String, _
   Optional ByVal qformula_number As Long = -1 _
)

Parameters

qformula_name
Name of the new QFormula.
qformula_expression
Expression of the new QFormula
qformula_number
Number of the new QFormula. Optional, defaults to -1. All values <= 0 are considired as QFormula w/o number.

Remarks

The outcome of the request, as well as any errors, are reported via QFormulaCreated event, which is fired only once per request.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

CreateRangeBarsRequest Method
CQGCEL Interface : CreateRangeBarsRequest Method

Glossary Item Box

Description

Creates new CQGRenkoBarsRequest object

Syntax

Visual Basic
Public Function CreateRangeBarsRequest() As CQGRangeBarsRequest

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

CreateRenkoBarsRequest Method
CQGCEL Interface : CreateRenkoBarsRequest Method

Glossary Item Box

Description

Creates new CQGRenkoBarsRequest object

Syntax

Visual Basic
Public Function CreateRenkoBarsRequest() As CQGRenkoBarsRequest

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

CreateStrategyOrder Method
order_type

Type of the order.

The CQGOrder.Properties collection depends on it.

The otStopLimit order type is not supported.

cqg_definition

Strategy definition that should be used to place the order.

The CQGStrategyDefinition.Status property value should be srsPending or srsSuccess, otherwise an exception will be thrown.

cqg_account

Account that should be used to place the order

cqg_accounts

Additional accounts, on which order legs should be placed.

Is not supported yet; hence, Nothing should be passed.

order_quantity

Order quantity. Signed or unsigned - depends on CQGAPIConfig.UseOrderSide setting.

order_side

Side of the order. Not used if CQGAPIConfig.UseOrderSide is set to false.

limit_price
Limit price for the order
stop_price
Stop price for the order
ue_name_part

Part of the user-friendly name.

Other parts of UEName are automatically generated.

CQGCEL Interface : CreateStrategyOrder Method

Glossary Item Box

Description

Creates new strategy order with specified parameters.

Syntax

Visual Basic
Public Function CreateStrategyOrder( _
   ByVal order_type As eOrderType, _
   ByVal cqg_definition As CQGStrategyDefinition, _
   ByVal cqg_account As CQGAccount, _
   ByVal cqg_accounts As CQGAccounts, _
   ByVal order_quantity As Long, _
   Optional ByVal order_side As eOrderSide = osdUndefined, _
   Optional ByVal limit_price As Double = -2147483647, _
   Optional ByVal stop_price As Double = -2147483647, _
   Optional ByVal ue_name_part As String = "" _
) As CQGOrder

Parameters

order_type
Value Description
otLimit

Limit order.

otMarket

Market order.

otStop

Stop order.

otStopLimit

Stop Limit order.

otUndefined

Undefined order type.

Type of the order.

The CQGOrder.Properties collection depends on it.

The otStopLimit order type is not supported.

cqg_definition

Strategy definition that should be used to place the order.

The CQGStrategyDefinition.Status property value should be srsPending or srsSuccess, otherwise an exception will be thrown.

cqg_account

Account that should be used to place the order

cqg_accounts

Additional accounts, on which order legs should be placed.

Is not supported yet; hence, Nothing should be passed.

order_quantity

Order quantity. Signed or unsigned - depends on CQGAPIConfig.UseOrderSide setting.

order_side
Value | Description
osdBuy Side properties return this value if CQGAPIConfig.UseOrderSide is set to True.

Depending on the owner, osdBuy value is returned in case of:

  • the object is a CQGTrade referring to a buy trade
  • the object is a CQGPosition referring to a long position.

  • the object is a CQGOrder referring to an order of buy type.
  • the object is a CQGFill referring to a fill of buy type.
osdSell Side properties return this value if CQGAPIConfig.UseOrderSide is set to True.

Depending on the owner, osdSell value is returned in case of:

  • the object is a CQGTrade referring to a sell trade
  • the object is a CQGPosition referring to a short position.

  • the object is a CQGOrder referring to an order of sell type.
  • the object is a CQGFill referring to a fill of sell type.
osdUndefined | Side properties return this value if CQGAPIConfig.UseOrderSide is set to False.

Side of the order. Not used if CQGAPIConfig.UseOrderSide is set to false.

limit_price
Limit price for the order
stop_price
Stop price for the order
ue_name_part

Part of the user-friendly name.

Other parts of UEName are automatically generated.

Return Type

A CQGOrder object which represents the newly created order.

Remarks

Important Note: The eOrderProperty.opExecutionPattern property must be set for the strategy order, otherwise, the order will not be placed.

Depending on its type, the order can be either placed as is or some properties should be set before actual placing.

Some of the properties can be modified after order creation and before the order is placed. For more information see the CQGOrder and CQGOrderProperties objects.

The status of the order is set to osNotSent and its state to olsNotSent before the CQGOrder.Place method is called.

See Also

CQGCEL Interface | CQGCEL Members | eOrderType Enumeration | CQGStrategyDefinition Interface | CQGAccount Interface | CQGAccounts Collection | eOrderSide Enumeration | CQGOrder.Properties Property


%%PageItemTitle%%

CreateStrategyOrderByExpression Method
order_type
Type of the order
expression_string

Strategy definition expression or QFormula name/number.

The QFormula name should be passed in the following format: "Q.Q_Formula_Name" (for example, "Q.MyFormula").

The QFormula number should be passed in the following format: "QQ_Formula_Number" (for example, "Q8").

cqg_account
The order will be placed by this account
cqg_accounts
Auxiliary accounts for strategy order
order_quantity
Order quantity. Signed or unsigned - depends on UseOrderSide Property
order_side
Side of the order
limit_price
Limit price for the order
stop_price
Stop price for the order
ue_name_part
Part of user friendly name
CQGCEL Interface : CreateStrategyOrderByExpression Method

Glossary Item Box

Description

Creates a new strategy order object by specified strategy expression or QFormula name/number.

Syntax

Visual Basic
Public Function CreateStrategyOrderByExpression( _
   ByVal order_type As eOrderType, _
   ByVal expression_string As String, _
   ByVal cqg_account As CQGAccount, _
   ByVal cqg_accounts As CQGAccounts, _
   ByVal order_quantity As Long, _
   Optional ByVal order_side As eOrderSide = osdUndefined, _
   Optional ByVal limit_price As Double = -2147483647, _
   Optional ByVal stop_price As Double = -2147483647, _
   Optional ByVal ue_name_part As String = "" _
) As CQGOrder

Parameters

order_type
Value Description
otLimit

Limit order.

otMarket

Market order.

otStop

Stop order.

otStopLimit

Stop Limit order.

otUndefined

Undefined order type.

Type of the order
expression_string

Strategy definition expression or QFormula name/number.

The QFormula name should be passed in the following format: "Q.Q_Formula_Name" (for example, "Q.MyFormula").

The QFormula number should be passed in the following format: "QQ_Formula_Number" (for example, "Q8").

cqg_account
The order will be placed by this account
cqg_accounts
Auxiliary accounts for strategy order
order_quantity
Order quantity. Signed or unsigned - depends on UseOrderSide Property
order_side
Value | Description
osdBuy Side properties return this value if CQGAPIConfig.UseOrderSide is set to True.

Depending on the owner, osdBuy value is returned in case of:

  • the object is a CQGTrade referring to a buy trade
  • the object is a CQGPosition referring to a long position.

  • the object is a CQGOrder referring to an order of buy type.
  • the object is a CQGFill referring to a fill of buy type.
osdSell Side properties return this value if CQGAPIConfig.UseOrderSide is set to True.

Depending on the owner, osdSell value is returned in case of:

  • the object is a CQGTrade referring to a sell trade
  • the object is a CQGPosition referring to a short position.

  • the object is a CQGOrder referring to an order of sell type.
  • the object is a CQGFill referring to a fill of sell type.
osdUndefined | Side properties return this value if CQGAPIConfig.UseOrderSide is set to False.
Side of the order
limit_price
Limit price for the order
stop_price
Stop price for the order
ue_name_part
Part of user friendly name

Return Type

New order with specified parameters

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

CreateStrategyOrderConstructor Method
order_type
OrderSide
CQGCEL Interface : CreateStrategyOrderConstructor Method

Glossary Item Box

Description

Creates a new CQGOrderConstructor object for strategy orders

Syntax

Visual Basic
Public Function CreateStrategyOrderConstructor( _
   ByVal order_type As eOrderType, _
   ByVal OrderSide As eOrderSide _
) As CQGOrderConstructor

Parameters

order_type
Value Description
otLimit

Limit order.

otMarket

Market order.

otStop

Stop order.

otStopLimit

Stop Limit order.

otUndefined

Undefined order type.

OrderSide
Value | Description
osdBuy Side properties return this value if CQGAPIConfig.UseOrderSide is set to True.

Depending on the owner, osdBuy value is returned in case of:

  • the object is a CQGTrade referring to a buy trade
  • the object is a CQGPosition referring to a long position.

  • the object is a CQGOrder referring to an order of buy type.
  • the object is a CQGFill referring to a fill of buy type.
osdSell Side properties return this value if CQGAPIConfig.UseOrderSide is set to True.

Depending on the owner, osdSell value is returned in case of:

  • the object is a CQGTrade referring to a sell trade
  • the object is a CQGPosition referring to a short position.

  • the object is a CQGOrder referring to an order of sell type.
  • the object is a CQGFill referring to a fill of sell type.
osdUndefined | Side properties return this value if CQGAPIConfig.UseOrderSide is set to False.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

CreateStrategyQuoteRequest Method
Account

Account that should be used to make the request for quotes (RFQ)

Symbol
Symbol name for which the quotes are requested. For example, UDS(C.US.CLEK175050-C.US.CLEK175100, BullC)
CQGCEL Interface : CreateStrategyQuoteRequest Method

Glossary Item Box

Description

Creates a new CQGStrategyQuoteRequest object

Syntax

Visual Basic
Public Function CreateStrategyQuoteRequest( _
   ByVal Account As CQGAccount, _
   ByVal Symbol As String _
) As CQGStrategyQuoteRequest

Parameters

Account

Account that should be used to make the request for quotes (RFQ)

Symbol
Symbol name for which the quotes are requested. For example, UDS(C.US.CLEK175050-C.US.CLEK175100, BullC)

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

CreateSubMinuteBarsRequest Method
CQGCEL Interface : CreateSubMinuteBarsRequest Method

Glossary Item Box

Description

Creates new CQGSubMinuteBarsRequest object

Syntax

Visual Basic
Public Function CreateSubMinuteBarsRequest() As CQGSubMinuteBarsRequest

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

CreateTFlowBarsRequest Method
CQGCEL Interface : CreateTFlowBarsRequest Method

Glossary Item Box

Description

Creates a new CQGTFlowBarsRequest object.

Syntax

Visual Basic
Public Function CreateTFlowBarsRequest() As CQGTFlowBarsRequest

Remarks

The CQGTFlowBarsRequest.Symbol, CQGTFlowBarsRequest.RangeStart, and CQGTFlowBarsRequest.RangeEnd properties do not have default values and must be provided before passing the CQGTFlowBarsRequest object to the CQGCEL.RequestTFlowBars method.

Example

See Also

CQGCEL Interface | CQGCEL Members | CQGTFlowBarsRequest Interface | CQGCEL.RequestTFlowBars Method


%%PageItemTitle%%

CreateTicksRequest Method
CQGCEL Interface : CreateTicksRequest Method

Glossary Item Box

Description

Creates a new CQGTicksRequest object.

Syntax

Visual Basic
Public Function CreateTicksRequest() As CQGTicksRequest

Remarks

The CQGTicksRequest.Symbol and the CQGTicksRequest.Type properties do not have default values and must be provided before passing the CQGTicksRequest object to the CQGCEL.RequestTicks method.

If Type is trtSinceTime or trtSinceTimeNotify, CQGTicksRequest.RangeStart shall be provided too.

If Type is trtTimeRange, CQGTicksRequest.RangeEnd shall be provided too.

See Also

CQGCEL Interface | CQGCEL Members | CQGCEL.RequestTicks Method | CQGTicksRequest Interface


%%PageItemTitle%%

CreateTimedBarsRequest Method
CQGCEL Interface : CreateTimedBarsRequest Method

Glossary Item Box

Description

Creates a new CQGTimedBarsRequest object.

Syntax

Visual Basic
Public Function CreateTimedBarsRequest() As CQGTimedBarsRequest

Remarks

The CQGTimedBarsRequest.Symbol, CQGTimedBarsRequest.RangeStart, and CQGTimedBarsRequest.RangeEnd properties do not have default values and must be provided before passing the CQGTimedBarsRequest object to the CQGCEL.RequestTimedBars method.

In addition, either the CQGTimedBarsRequest.IntradayPeriod or the CQGTimedBarsRequest.HistoricalPeriod must be provided too.

See Also

CQGCEL Interface | CQGCEL Members | CQGTimedBarsRequest Interface | CQGCEL.RequestTimedBars Method


%%PageItemTitle%%

CreateTradingSystemRequest Method
name_or_abbr

The requested trading system name or abbreviation

CQGCEL Interface : CreateTradingSystemRequest Method

Glossary Item Box

Description

Creates a new CQGTradingSystemRequest object based on the trading system name.

Syntax

Visual Basic
Public Function CreateTradingSystemRequest( _
   ByVal name_or_abbr As String _
) As CQGTradingSystemRequest

Parameters

name_or_abbr

The requested trading system name or abbreviation

Remarks

An exception will be thrown if no trading system exists with the specified name or abbreviation.

The CQGTradingSystemRequest.BaseExpression, CQGTradingSystemRequest.RangeStart, CQGTradingSystemRequest.RangeEnd properties do not have default values and must be provided before passing the CQGTradingSystemRequest object to the CQGCEL.RequestTradingSystem method.

See Also

CQGCEL Interface | CQGCEL Members | RequestTradingSystem Method | CQGTradingSystemRequest Interface


%%PageItemTitle%%

CreateYieldsRequest Method
CQGCEL Interface : CreateYieldsRequest Method

Glossary Item Box

Description

Creates new CQGYieldsRequest object

Syntax

Visual Basic
Public Function CreateYieldsRequest() As CQGYieldsRequest

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

DefineStrategy Method
request_string_

—

CQGCEL Interface : DefineStrategy Method

Glossary Item Box

Description

Method is obsolete. Use DefineStrategyEx instead.

Syntax

Visual Basic
Public Function DefineStrategy( _
   ByVal request_string_ As String _
) As CQGStrategyDefinition

Parameters

request_string_

—

Return Type

—

Remarks

—

See Also

CQGCEL Interface | CQGCEL Members | CQGStrategyDefinition Interface


%%PageItemTitle%%

DefineStrategyEx Method
expression_string

Spread expression or QFormula name/number.

The QFormula name should be passed in the following format: "Q.Q_Formula_Name" (for example, "Q.MyFormula").

The QFormula number should be passed in the following format: "QQ_Formula_Number" (for example, "Q8").

cqg_account
CQG trading account, type of CQGAccount, for proper strategy registration on CQG Gateway.
CQGCEL Interface : DefineStrategyEx Method

Glossary Item Box

Description

Requests for the strategy definition on CQG Gateway.

Syntax

Visual Basic
Public Function DefineStrategyEx( _
   ByVal expression_string As String, _
   ByVal cqg_account As CQGAccount _
) As CQGStrategyDefinition

Parameters

expression_string

Spread expression or QFormula name/number.

The QFormula name should be passed in the following format: "Q.Q_Formula_Name" (for example, "Q.MyFormula").

The QFormula number should be passed in the following format: "QQ_Formula_Number" (for example, "Q8").

cqg_account
CQG trading account, type of CQGAccount, for proper strategy registration on CQG Gateway.

Return Type

A CQGStrategyDefinition object, represented as CQGStrategyDefinition.

Remarks

An exception will be thrown if an asynchronous request could not be made.

Otherwise, returns a CQGStrategyDefinition object, which doesn't contain any data yet and which status is eStrategyRequestStatus.srsNotActive.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

DeleteQFormula Method
qformula_name_or_number

Expression to find and delete QFormula by.

Expression can be name or number of QFormula. Name can be passed with or without prefix "Q.".

Number should be formatted as "QNumber".

For example, for QFormula "Q.Crack" with number 17 next inputs are valid:

  • "Q.Crack"
  • "Crack"
  • "Q17"
CQGCEL Interface : DeleteQFormula Method

Glossary Item Box

Description

Starts an asynchronous query for QFormula deletion.

Syntax

Visual Basic
Public Sub DeleteQFormula( _
   ByVal qformula_name_or_number As String _
)

Parameters

qformula_name_or_number

Expression to find and delete QFormula by.

Expression can be name or number of QFormula. Name can be passed with or without prefix "Q.".

Number should be formatted as "QNumber".

For example, for QFormula "Q.Crack" with number 17 next inputs are valid:

  • "Q.Crack"
  • "Crack"
  • "Q17"

Remarks

The outcome of the request, as well as any errors, are reported via QFormulaDeleted event, which is fired only once per request.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

GWLogoff Method
CQGCEL Interface : GWLogoff Method

Glossary Item Box

Description

Logoff from the Gateway.

Syntax

Visual Basic
Public Sub GWLogoff()

Example

The method work depends on GatewayEnabled property value.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

GWLogon Method
username_

Gateway account username

password_

Gateway account password

CQGCEL Interface : GWLogon Method

Glossary Item Box

Description

Login to Gateway with the specified username and password.

Syntax

Visual Basic
Public Sub GWLogon( _
   ByVal username_ As String, _
   ByVal password_ As String _
)

Parameters

username_

Gateway account username

password_

Gateway account password

Remarks

The method work depends on GatewayEnabled property value.

Use username_ = "DEMO" and password_ = "DEMO" for login to Gateway with a demo account.

See Also

CQGCEL Interface | CQGCEL Members | GWOTPLogon


%%PageItemTitle%%

GWOTPLogon Method
username_

Gateway account username

password_

Gateway account password

otpassword_
One-time password
CQGCEL Interface : GWOTPLogon Method

Glossary Item Box

Description

Log in to Gateway with specified username, password and OneTimePassword

Syntax

Visual Basic
Public Sub GWOTPLogon( _
   ByVal username_ As String, _
   ByVal password_ As String, _
   ByVal otpassword_ As String _
)

Parameters

username_

Gateway account username

password_

Gateway account password

otpassword_
One-time password

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

InvokeStrategyQuoteRequest Method
cqg_strategy_quote_request
Request for quotes (RFQ)
CQGCEL Interface : InvokeStrategyQuoteRequest Method

Glossary Item Box

Description

Invokes quotes request for strategies (UDS) from GW

Syntax

Visual Basic
Public Sub InvokeStrategyQuoteRequest( _
   ByVal cqg_strategy_quote_request As CQGStrategyQuoteRequest _
)

Parameters

cqg_strategy_quote_request
Request for quotes (RFQ)

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

IsValid Method
value_or_object
Input data of any type represented as Variant
CQGCEL Interface : IsValid Method

Glossary Item Box

Description

Checks if the argument has a valid value.

Syntax

Visual Basic
Public Function IsValid( _
   ByVal value_or_object As Variant _
) As Boolean

Parameters

value_or_object
Input data of any type represented as Variant

Return Type

True if data is valid, False otherwise.

Remarks

Currently the method checks Long, String, and Double values for validity.
Starting from v.3.0 this method also checks for validity the objects returned by CQG API. See Invalid Objects for details.

Example

The validity of the instrument property checking Copy Code
Dim TickValue As String
TickValue = IIf(CEL.IsValid(instrument.TickValue), CStr(instrument.TickValue), "N/A")

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

LogOn Method
username_
User name used for authentication
password_
Password used for authentication
CQGCEL Interface : LogOn Method

Glossary Item Box

Description

Log on to LoginDB via login service and startup CEL if remote Open API user passes the authentication

Syntax

Visual Basic
Public Sub LogOn( _
   ByVal username_ As String, _
   ByVal password_ As String _
)

Parameters

username_
User name used for authentication
password_
Password used for authentication

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

ModifyCompoundOrder Method
compound_order_id

compound_order_guid
order_chain

CQGCEL Interface : ModifyCompoundOrder Method

Glossary Item Box

Description

Obsolete method, please use ModifyCompoundOrderEx instead.

Syntax

Visual Basic
Public Sub ModifyCompoundOrder( _
   ByVal compound_order_id As String, _
   ByVal compound_order_guid As String, _
   ByVal order_chain As CQGOrderChain _
)

Parameters

compound_order_id

compound_order_guid
order_chain

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

ModifyCompoundOrderEx Method
compound_order_id
ID of compound order that is beeing modified. Compound order ID can be retreived via opCompoundOrderID order property from any compound order part (leg).
compound_order_type
order_chain
New parts (legs) to add to the existing active compound order.
CQGCEL Interface : ModifyCompoundOrderEx Method

Glossary Item Box

Description

Async request to modify compound order. Modification currently supports only adding new parts (legs) to the existing active compound order.

Syntax

Visual Basic
Public Sub ModifyCompoundOrderEx( _
   ByVal compound_order_id As String, _
   ByVal compound_order_type As ECompoundOrderType, _
   ByVal order_chain As CQGOrderChain _
)

Parameters

compound_order_id
ID of compound order that is beeing modified. Compound order ID can be retreived via opCompoundOrderID order property from any compound order part (leg).
compound_order_type
Value | Description
coOCO | Order-Cancels-Orders type. The order consists of several parts (legs, orders from CQGOrderChain). If one part (leg) of the order is executed, then all other parts (legs) are canceled.
coOPO | Order-Places-Order type. The order consists of several parts (legs, orders from CQGOrderChain). Initially, only the first part (leg) is active (in a working state) and all others are in a waiting state (corresponds to osContingent order status). When the active part (leg) is executed, all other parts (legs) become active.
order_chain
New parts (legs) to add to the existing active compound order.

See Also

CQGCEL Interface | CQGCEL Members | PlaceCompoundOrderEx Method


%%PageItemTitle%%

NewInstrument Method
symbol_

Symbol to resolve in one of the following formats:

  • symbol prefix (e.g. EP)
  • symbol prefix with month (EPZ)
  • symbol prefix with month and year (EPZ7)
  • symbol prefix with relative month (EP?1)
  • full or short option instrument name (C.EPF1617650 or C.EP_F16.17650)
CQGCEL Interface : NewInstrument Method

Glossary Item Box

Description

Resolves the given symbol and subscribes to the instrument.

Syntax

Visual Basic
Public Sub NewInstrument( _
   ByVal symbol_ As String _
)

Parameters

symbol_

Symbol to resolve in one of the following formats:

  • symbol prefix (e.g. EP)
  • symbol prefix with month (EPZ)
  • symbol prefix with month and year (EPZ7)
  • symbol prefix with relative month (EP?1)
  • full or short option instrument name (C.EPF1617650 or C.EP_F16.17650)

Remarks

The method works in asynchronous mode, i.e. the method just triggers the request in the CQGCEL without waiting for its results.

InstrumentResolved event is fired as a result of the method call.

An exception will be thrown if symbol is empty string.

Depricated:

If the symbol is valid, the result will come with the InstrumentSubscribed event.

If the symbol is not valid, the IncorrectSymbol event will be fired.

Note: Only tradable instruments are considered to be valid.

It is a good practice to cancel the request as soon as it becomes unnecessary. Such approach allows using memory resources more optimal.

Call RemoveInstrument for request cancelling.

Example

See the usage of the NewInstrument method in CQGCEL Example.

See Also

CQGCEL Interface | CQGCEL Members | CQGInstrument Interface


%%PageItemTitle%%

Obsolete140 Method
CQGCEL Interface : Obsolete140 Method

Glossary Item Box

Description

Obsolete method

Syntax

Visual Basic
Public Sub Obsolete140()

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

Obsolete141 Method
CQGCEL Interface : Obsolete141 Method

Glossary Item Box

Description

Obsolete method

Syntax

Visual Basic
Public Sub Obsolete141()

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

Obsolete142 Method
CQGCEL Interface : Obsolete142 Method

Glossary Item Box

Description

Obsolete method

Syntax

Visual Basic
Public Sub Obsolete142()

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

Obsolete143 Method
CQGCEL Interface : Obsolete143 Method

Glossary Item Box

Description

Obsolete method

Syntax

Visual Basic
Public Sub Obsolete143()

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

Obsolete144 Method
CQGCEL Interface : Obsolete144 Method

Glossary Item Box

Description

Obsolete method

Syntax

Visual Basic
Public Sub Obsolete144()

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

PlaceCompoundOrder Method
order_chain
CQGCEL Interface : PlaceCompoundOrder Method

Glossary Item Box

Description

Obsolete method, please use PlaceCompoundOrderEx instead.

Syntax

Visual Basic
Public Sub PlaceCompoundOrder( _
   ByVal order_chain As CQGOrderChain _
)

Parameters

order_chain

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

PlaceCompoundOrderEx Method
compound_order_type
order_chain
Parts (legs) of the compound order.
CQGCEL Interface : PlaceCompoundOrderEx Method

Glossary Item Box

Description

Async request to place compound order.

Syntax

Visual Basic
Public Sub PlaceCompoundOrderEx( _
   ByVal compound_order_type As ECompoundOrderType, _
   ByVal order_chain As CQGOrderChain _
)

Parameters

compound_order_type
Value | Description
coOCO | Order-Cancels-Orders type. The order consists of several parts (legs, orders from CQGOrderChain). If one part (leg) of the order is executed, then all other parts (legs) are canceled.
coOPO | Order-Places-Order type. The order consists of several parts (legs, orders from CQGOrderChain). Initially, only the first part (leg) is active (in a working state) and all others are in a waiting state (corresponds to osContingent order status). When the active part (leg) is executed, all other parts (legs) become active.
order_chain
Parts (legs) of the compound order.

Remarks

Every compound order has own GUID. Value is assigned to each order part (leg) using CQGOrderChain.GUID property from order_chain parameter.

Compound order GUID will be available from opCompoundOrderGUID order part (leg) property after first OrderChanged event raising.

Every compound order has own (Gateway) ID. Value is assigned to each order part (leg) by server and can be accessed via opCompoundOrderID order property.

See Also

CQGCEL Interface | CQGCEL Members | ModifyCompoundOrderEx Method


%%PageItemTitle%%

QueryOrders Method
cqg_account
A CQGAccount object representing the account historical orders of which should be retrieved.
cqg_instrument
An optional CQGInstrument object representing the instrument the historical orders on which should be retrieved.
status_filter
Order status filter allowing to select the historical orders by their statuses. This parameter is optional.
date_

A Date variable, specifying the day of the requested orders.

The date parameter applies only on orders that are in their final state.

Notes:

  • If the other filters are set so that the working orders are going to be retrieved as well, all working orders will be retrieved regardless of the Date value.
  • If the date is not specified, the current date will be used.
  • If date exceeds the user-limit, an error will be thrown.
order_side
Identifies the side of the historical orders to be retrieved. The parameter is optional
CQGCEL Interface : QueryOrders Method

Glossary Item Box

Description

Sends a historical orders information query. The query is constructed based on the passed arguments.

Syntax

Visual Basic
Public Function QueryOrders( _
   ByVal cqg_account As CQGAccount, _
   Optional ByVal cqg_instrument As CQGInstrument = 0, _
   Optional ByVal status_filter As eOrderStatusFilter = osfAll, _
   Optional ByVal date_ As Date = "12/30/1899 12:00:00 AM", _
   Optional ByVal order_side As eOrderSide = osdUndefined _
) As CQGOrdersQuery

Parameters

cqg_account
A CQGAccount object representing the account historical orders of which should be retrieved.
cqg_instrument
An optional CQGInstrument object representing the instrument the historical orders on which should be retrieved.
status_filter
Value | Description
osfAll | Orders with any Gateway status.
osfCanceled | Cancelled orders.
osfException

Orders with errors or rejected orders.

osfFilled

Orders that have at least 1 fill.

osfFinal | Final orders, i.e. orders, Gateway statuses of which are one of the following: osRejectGW, osRejectFCM, osExpired, osCanceled, osFilled, osBusted, osParked, osInTransitTimeout.
osfNotFinal

Not final orders, i.e. orders, Gateway statuses of which are one of the following: osInOrderBook, osInTransit, osActiveAt, osContingent, osDisconnected, osInCancel, osInModify.

osfParked

Parked and contingent orders.

Order status filter allowing to select the historical orders by their statuses. This parameter is optional.
date_

A Date variable, specifying the day of the requested orders.

The date parameter applies only on orders that are in their final state.

Notes:

  • If the other filters are set so that the working orders are going to be retrieved as well, all working orders will be retrieved regardless of the Date value.
  • If the date is not specified, the current date will be used.
  • If date exceeds the user-limit, an error will be thrown.
order_side
Value | Description
osdBuy Side properties return this value if CQGAPIConfig.UseOrderSide is set to True.

Depending on the owner, osdBuy value is returned in case of:

  • the object is a CQGTrade referring to a buy trade
  • the object is a CQGPosition referring to a long position.

  • the object is a CQGOrder referring to an order of buy type.
  • the object is a CQGFill referring to a fill of buy type.
osdSell Side properties return this value if CQGAPIConfig.UseOrderSide is set to True.

Depending on the owner, osdSell value is returned in case of:

  • the object is a CQGTrade referring to a sell trade
  • the object is a CQGPosition referring to a short position.

  • the object is a CQGOrder referring to an order of sell type.
  • the object is a CQGFill referring to a fill of sell type.
osdUndefined | Side properties return this value if CQGAPIConfig.UseOrderSide is set to False.
Identifies the side of the historical orders to be retrieved. The parameter is optional

Return Type

The query object represented as CQGOrdersQuery

Remarks

This method works in asynchronous mode, i.e. its results are not available after the method return.

The order progress will be notified via OnQueryProgress event.

Example

See the usage of QueryOrders method in the OnQueryProgress event's example section.

See Also

CQGCEL Interface | CQGCEL Members | CQGOrders Collection | CQGCEL.OnQueryProgress Event | CQGOrdersQuery Interface


%%PageItemTitle%%

QueryPositionsStatement Method
gw_account_id

Account Gateway id, for which the statement is requested

date_

Date, for which the statement is requested. The special value 1 January 3000 00:00:00 UTC must be provided in case a position statement request for a current day

CQGCEL Interface : QueryPositionsStatement Method

Glossary Item Box

Description

Sends an asynchronous query for account positions statement. The query is constructed based on the passed arguments.

Syntax

Visual Basic
Public Sub QueryPositionsStatement( _
   ByVal gw_account_id As Long, _
   ByVal date_ As Date _
)

Parameters

gw_account_id

Account Gateway id, for which the statement is requested

date_

Date, for which the statement is requested. The special value 1 January 3000 00:00:00 UTC must be provided in case a position statement request for a current day

Remarks

The outcome of the request, as well as any errors, are reported via the PositionsStatementResolved event, which is fired only once per request.

Please, note that every CQGPosition from resolved CQGPositionsStatement will have invalid values in all current price dependent members (MVO, OTE, ProfitLoss and UPL) since this method does not make instrument subscription internally.

Read about CQGAccount's AutoSubscribeInstruments property to see how to request positions with valid MVO, OTE, ProfitLoss and UPL values.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

QuerySummariesStatement Method
gw_account_id
Account Gateway id, for which the statement is requested
date_
Date, for which the statement is requested
CQGCEL Interface : QuerySummariesStatement Method

Glossary Item Box

Description

Sends an asynchronous query for account summaries statement. The query is constructed based on the passed arguments.

Syntax

Visual Basic
Public Sub QuerySummariesStatement( _
   ByVal gw_account_id As Long, _
   ByVal date_ As Date _
)

Parameters

gw_account_id
Account Gateway id, for which the statement is requested
date_
Date, for which the statement is requested

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RegisterAlgorithmicOrder Method
guid_

GUID for the order type being registered

name_

Name of the order type being registered

abbrv_

Abbreviation of the order type being registered

description_

Description of the order type being registered

definitions_

Collection of the parameter definitions for the order type being registered

icon_index

Index of the icon in CQGIC, which will be used for the order type being registered

CQGCEL Interface : RegisterAlgorithmicOrder Method

Glossary Item Box

Description

Registers an algorithmic order type.

Syntax

Visual Basic
Public Sub RegisterAlgorithmicOrder( _
   ByVal guid_ As String, _
   ByVal name_ As String, _
   ByVal abbrv_ As String, _
   ByVal description_ As String, _
   ByVal definitions_ As CQGAlgorithmicOrderDefinitions, _
   Optional ByVal icon_index As Long = 0 _
)

Parameters

guid_

GUID for the order type being registered

name_

Name of the order type being registered

abbrv_

Abbreviation of the order type being registered

description_

Description of the order type being registered

definitions_

Collection of the parameter definitions for the order type being registered

icon_index

Index of the icon in CQGIC, which will be used for the order type being registered

Remarks

If the passed GUID already has an algorithmic order registered for and all of the other parameters match, the registration will succeed, otherwise it will fail.

The registration status is accessible via AlgorithmicOrderRegistrationComplete event.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RemoveAdvancedStudy Method
cqg_advanced_study
CQGAdvancedStudy to remove
CQGCEL Interface : RemoveAdvancedStudy Method

Glossary Item Box

Description

Unsubscribe from and remove the CQGAdvancedStudy from CQGAdvancedStudies

Syntax

Visual Basic
Public Sub RemoveAdvancedStudy( _
   ByVal cqg_advanced_study As CQGAdvancedStudy _
)

Parameters

cqg_advanced_study
CQGAdvancedStudy to remove

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RemoveAllAdvancedStudies Method
CQGCEL Interface : RemoveAllAdvancedStudies Method

Glossary Item Box

Description

Unsubscribe/remove all advanced studies

Syntax

Visual Basic
Public Sub RemoveAllAdvancedStudies()

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RemoveAllConditions Method
CQGCEL Interface : RemoveAllConditions Method

Glossary Item Box

Description

Unsubscribes/removes all conditions.

Syntax

Visual Basic
Public Sub RemoveAllConditions()

See Also

CQGCEL Interface | CQGCEL Members | CQGConditions Collection


%%PageItemTitle%%

RemoveAllConstantVolumeBars Method
CQGCEL Interface : RemoveAllConstantVolumeBars Method

Glossary Item Box

Description

Unsubscribes/removes all constant volume bars.

Syntax

Visual Basic
Public Sub RemoveAllConstantVolumeBars()

See Also

CQGCEL Interface | CQGCEL Members | CQGConstantVolumeBars Collection


%%PageItemTitle%%

RemoveAllCustomStudies Method
CQGCEL Interface : RemoveAllCustomStudies Method

Glossary Item Box

Description

Unsubscribes/removes all custom studies.

Syntax

Visual Basic
Public Sub RemoveAllCustomStudies()

See Also

CQGCEL Interface | CQGCEL Members | CQGCustomStudies Collection


%%PageItemTitle%%

RemoveAllExpressions Method
CQGCEL Interface : RemoveAllExpressions Method

Glossary Item Box

Description

Unsubscribes/removes all expressions.

Syntax

Visual Basic
Public Sub RemoveAllExpressions()

See Also

CQGCEL Interface | CQGCEL Members | CQGExpressions Collection


%%PageItemTitle%%

RemoveAllInstruments Method
CQGCEL Interface : RemoveAllInstruments Method

Glossary Item Box

Description

Unsubscribes and removes all currently resolved instruments from the Instruments collection.

Syntax

Visual Basic
Public Sub RemoveAllInstruments()

Remarks

After the RemoveAllInstruments method is called, no InstrumentChanged events are fired and all of the previously received CQGInstrument object references become invalid.

This method works in synchronous mode; i.e. after the method return, no instruments will be in the Instruments collection

This method removes all subscribed instruments including those which were subscribed via AutoSubscribeInstruments setting. In CQG API v. 3.0 and higher it may result in unavailability of account summaries and position properties.

Example

See the usage of CQGCEL methods in the OrderChanged event's example section.

See the usage of RemoveAllInstruments method in the CQGCEL Example example section.

See Also

CQGCEL Interface | CQGCEL Members | CQGInstrument Interface


%%PageItemTitle%%

RemoveAllPointAndFigureBars Method
CQGCEL Interface : RemoveAllPointAndFigureBars Method

Glossary Item Box

Description

Unsubscribes/removes all point and figure bars.

Syntax

Visual Basic
Public Sub RemoveAllPointAndFigureBars()

See Also

CQGCEL Interface | CQGCEL Members | CQGPointAndFigureBars Collection


%%PageItemTitle%%

RemoveAllRangeBars Method
CQGCEL Interface : RemoveAllRangeBars Method

Glossary Item Box

Description

Unsubscribe/remove all range bars

Syntax

Visual Basic
Public Sub RemoveAllRangeBars()

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RemoveAllRenkoBars Method
CQGCEL Interface : RemoveAllRenkoBars Method

Glossary Item Box

Description

Unsubscribe/remove all renko bars

Syntax

Visual Basic
Public Sub RemoveAllRenkoBars()

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RemoveAllSubMinuteBars Method
CQGCEL Interface : RemoveAllSubMinuteBars Method

Glossary Item Box

Description

Unsubscribe/remove all sub minute bars

Syntax

Visual Basic
Public Sub RemoveAllSubMinuteBars()

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RemoveAllTFlowBars Method
CQGCEL Interface : RemoveAllTFlowBars Method

Glossary Item Box

Description

Unsubscribes/removes all TFlow bars.

Syntax

Visual Basic
Public Sub RemoveAllTFlowBars()

See Also

CQGCEL Interface | CQGCEL Members | CQGTFlowBars Collection


%%PageItemTitle%%

RemoveAllTicks Method
CQGCEL Interface : RemoveAllTicks Method

Glossary Item Box

Description

Unsubscribes/removes all ticks.

Syntax

Visual Basic
Public Sub RemoveAllTicks()

See Also

CQGCEL Interface | CQGCEL Members | CQGTicks Collection


%%PageItemTitle%%

RemoveAllTimedBars Method
CQGCEL Interface : RemoveAllTimedBars Method

Glossary Item Box

Description

Unsubscribes/removes all timed bars.

Syntax

Visual Basic
Public Sub RemoveAllTimedBars()

See Also

CQGCEL Interface | CQGCEL Members | CQGTimedBars Collection


%%PageItemTitle%%

RemoveAllTradingSystems Method
CQGCEL Interface : RemoveAllTradingSystems Method

Glossary Item Box

Description

Unsubscribes/removes all trading systems.

Syntax

Visual Basic
Public Sub RemoveAllTradingSystems()

See Also

CQGCEL Interface | CQGCEL Members | CQGTradingSystems Collection


%%PageItemTitle%%

RemoveAllYields Method
CQGCEL Interface : RemoveAllYields Method

Glossary Item Box

Description

Unsubscribe/remove all yields

Syntax

Visual Basic
Public Sub RemoveAllYields()

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RemoveCondition Method
cqg_condition
The CQGCondition object to remove
CQGCEL Interface : RemoveCondition Method

Glossary Item Box

Description

Unsubscribes from and removes the CQGCondition from the CQGConditions collection.

Syntax

Visual Basic
Public Sub RemoveCondition( _
   ByVal cqg_condition As CQGCondition _
)

Parameters

cqg_condition
The CQGCondition object to remove

See Also

CQGCEL Interface | CQGCEL Members | CQGCondition Collection | CQGConditions Collection


%%PageItemTitle%%

RemoveConstantVolumeBars Method
cqg_constant_volume_bars

The CQGConstantVolumeBars object to remove

CQGCEL Interface : RemoveConstantVolumeBars Method

Glossary Item Box

Description

Unsubscribes from and removes a CQGConstantVolumeBars from the CQGConstantVolumeBarsCollection.

Syntax

Visual Basic
Public Sub RemoveConstantVolumeBars( _
   ByVal cqg_constant_volume_bars As CQGConstantVolumeBars _
)

Parameters

cqg_constant_volume_bars

The CQGConstantVolumeBars object to remove

See Also

CQGCEL Interface | CQGCEL Members | CQGConstantVolumeBars Collection | CQGConstantVolumeBarsCollection Collection


%%PageItemTitle%%

RemoveCustomStudy Method
cqg_custom_study
The CQGCustomStudy to remove
CQGCEL Interface : RemoveCustomStudy Method

Glossary Item Box

Description

Unsubscribes from and removes a CQGCustomStudy from the CQGCustomStudies.

Syntax

Visual Basic
Public Sub RemoveCustomStudy( _
   ByVal cqg_custom_study As CQGCustomStudy _
)

Parameters

cqg_custom_study
The CQGCustomStudy to remove

See Also

CQGCEL Interface | CQGCEL Members | CQGCustomStudy Collection | CQGCustomStudies Collection


%%PageItemTitle%%

RemoveExpression Method
cqg_expression

The CQGExpression to remove.

CQGCEL Interface : RemoveExpression Method

Glossary Item Box

Description

Unsubscribes from and removes the CQGExpression from CQGExpressions.

Syntax

Visual Basic
Public Sub RemoveExpression( _
   ByVal cqg_expression As CQGExpression _
)

Parameters

cqg_expression

The CQGExpression to remove.

See Also

CQGCEL Interface | CQGCEL Members | CQGExpression Collection | CQGExpressions Collection


%%PageItemTitle%%

RemoveInstrument Method
cqg_instrument
The CQGInstrument object received from the Instruments collection
CQGCEL Interface : RemoveInstrument Method

Glossary Item Box

Description

Unsubscribes and removes the Instrument from the Instruments collection.

Syntax

Visual Basic
Public Sub RemoveInstrument( _
   ByVal cqg_instrument As CQGInstrument _
)

Parameters

cqg_instrument
The CQGInstrument object received from the Instruments collection

Remarks

After the RemoveInstrument method is called, no InstrumentChanged events are fired on the Instrument, and the previously received CQGInstrument object reference becomes invalid.

The method works in synchronous mode; i.e. after the method return, the instrument will not be in the Instruments collection.

Note: in CQG API v. 3.0 and higher this method call may result in unavailability of account summaries and position properties.

Example

See the usage of CQGCEL methods in the OrderChanged event's example section.

See Also

CQGCEL Interface | CQGCEL Members | CQGInstrument Interface


%%PageItemTitle%%

RemoveInstrumentsGroup Method
instruments_group

Instruments group to be removed, represented as CQGInstrumentsGroup

CQGCEL Interface : RemoveInstrumentsGroup Method

Glossary Item Box

Description

Removes a group of instruments.

Syntax

Visual Basic
Public Sub RemoveInstrumentsGroup( _
   ByVal instruments_group As CQGInstrumentsGroup _
)

Parameters

instruments_group

Instruments group to be removed, represented as CQGInstrumentsGroup

Remarks

This is a synchronous request.

It is possible to access all resolved instrument groups via CQGCEL.AllInstrumentsGroups Property.

See Also

CQGCEL Interface | CQGCEL Members | CQGInstrumentsGroup Interface | AllInstrumentsGroups Property | RequestInstrumentsGroup Method


%%PageItemTitle%%

RemovePointAndFigureBars Method
cqg_point_and_figure_bars
The CQGPointAndFigureBars to remove
CQGCEL Interface : RemovePointAndFigureBars Method

Glossary Item Box

Description

Unsubscribes from and removes a CQGPointAndFigureBars from the CQGPointAndFigureBarsCollection.

Syntax

Visual Basic
Public Sub RemovePointAndFigureBars( _
   ByVal cqg_point_and_figure_bars As CQGPointAndFigureBars _
)

Parameters

cqg_point_and_figure_bars
The CQGPointAndFigureBars to remove

See Also

CQGCEL Interface | CQGCEL Members | CQGPointAndFigureBars Collection | CQGPointAndFigureBarsCollection Collection


%%PageItemTitle%%

RemoveRangeBars Method
cqg_renko_bars
CQGRangeBars to remove
CQGCEL Interface : RemoveRangeBars Method

Glossary Item Box

Description

Unsubscribe from and remove the CQGRangeBars from CQGRangeBarsCollection

Syntax

Visual Basic
Public Sub RemoveRangeBars( _
   ByVal cqg_renko_bars As CQGRangeBars _
)

Parameters

cqg_renko_bars
CQGRangeBars to remove

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RemoveRenkoBars Method
cqg_renko_bars
CQGRenkoBars to remove
CQGCEL Interface : RemoveRenkoBars Method

Glossary Item Box

Description

Unsubscribe from and remove the CQGRenkoBars from CQGRenkoBarsCollection

Syntax

Visual Basic
Public Sub RemoveRenkoBars( _
   ByVal cqg_renko_bars As CQGRenkoBars _
)

Parameters

cqg_renko_bars
CQGRenkoBars to remove

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RemoveSubMinuteBars Method
cqg_subminute_bars
CQGSubMinuteBars to remove
CQGCEL Interface : RemoveSubMinuteBars Method

Glossary Item Box

Description

Unsubscribe from and remove the CQGSubMinuteBars from CQGSubMinuteBarsCollection

Syntax

Visual Basic
Public Sub RemoveSubMinuteBars( _
   ByVal cqg_subminute_bars As CQGSubMinuteBars _
)

Parameters

cqg_subminute_bars
CQGSubMinuteBars to remove

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RemoveTFlowBars Method
cqg_tflow_bars
CQGTFlowBars to remove
CQGCEL Interface : RemoveTFlowBars Method

Glossary Item Box

Description

Unsubscribes from and removes a CQGTFlowBars from the CQGTFlowBarsCollection.

Syntax

Visual Basic
Public Sub RemoveTFlowBars( _
   ByVal cqg_tflow_bars As CQGTFlowBars _
)

Parameters

cqg_tflow_bars
CQGTFlowBars to remove

See Also

CQGCEL Interface | CQGCEL Members | CQGTFlowBars Collection | CQGTFlowBarsCollection Collection


%%PageItemTitle%%

RemoveTicks Method
cqg_ticks
Specifies the particular CQGTicks to remove
CQGCEL Interface : RemoveTicks Method

Glossary Item Box

Description

Stops request that produced the CQGTicks object and removes the object from CQGTicksCollection.

Syntax

Visual Basic
Public Sub RemoveTicks( _
   ByVal cqg_ticks As CQGTicks _
)

Parameters

cqg_ticks
Specifies the particular CQGTicks to remove

See Also

CQGCEL Interface | CQGCEL Members | CQGTicks Collection | CQGTicksCollection Collection


%%PageItemTitle%%

RemoveTimedBars Method
cqg_timed_bars
The CQGTimedBars to remove
CQGCEL Interface : RemoveTimedBars Method

Glossary Item Box

Description

Unsubscribes from and removes a CQGTimedBars from the CQGTimedBarsCollection.

Syntax

Visual Basic
Public Sub RemoveTimedBars( _
   ByVal cqg_timed_bars As CQGTimedBars _
)

Parameters

cqg_timed_bars
The CQGTimedBars to remove

See Also

CQGCEL Interface | CQGCEL Members | CQGTimedBars Collection | CQGTimedBarsCollection Collection


%%PageItemTitle%%

RemoveTradingSystem Method
cqg_trading_system
The CQGTradingSystem to remove.
CQGCEL Interface : RemoveTradingSystem Method

Glossary Item Box

Description

Unsubscribes from and removes the CQGTradingSystem from CQGTradingSystems.

Syntax

Visual Basic
Public Sub RemoveTradingSystem( _
   ByVal cqg_trading_system As CQGTradingSystem _
)

Parameters

cqg_trading_system
The CQGTradingSystem to remove.

See Also

CQGCEL Interface | CQGCEL Members | CQGTradingSystem Interface | CQGTradingSystems Collection


%%PageItemTitle%%

RemoveYields Method
cqg_yields
CQGYields to remove
CQGCEL Interface : RemoveYields Method

Glossary Item Box

Description

Unsubscribe from and remove the CQGYields from CQGYieldsCollection

Syntax

Visual Basic
Public Sub RemoveYields( _
   ByVal cqg_yields As CQGYields _
)

Parameters

cqg_yields
CQGYields to remove

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RequestAdvancedStudy Method
cqg_advanced_study_request
Specifies advanced study request
CQGCEL Interface : RequestAdvancedStudy Method

Glossary Item Box

Description

Starts an asynchronous request for advanced study

Syntax

Visual Basic
Public Function RequestAdvancedStudy( _
   ByVal cqg_advanced_study_request As CQGAdvancedStudyRequest _
) As CQGAdvancedStudy

Parameters

cqg_advanced_study_request
Specifies advanced study request

Remarks

It is a good practice to cancel the request as soon as it becomes unnecessary. Such approach allows using memory resources more optimal.

Call RemoveAdvancedStudy for request cancelling.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RequestAdvancedStudyDefinitions Method
CQGCEL Interface : RequestAdvancedStudyDefinitions Method

Glossary Item Box

Description

Starts an asynchronous query for advanced study definitions

Syntax

Visual Basic
Public Sub RequestAdvancedStudyDefinitions()

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RequestBarsTimestamps Method
cqg_timestamps_request

Specifies the timed bars request object, which contains all parameters as properties, represented as CQGTimedBarsRequest.

Notes:

Values provided for properties that are not required are ignored.

If values are not provided for properties that are required, an exception will be thrown.

CQGCEL Interface : RequestBarsTimestamps Method

Glossary Item Box

Description

Starts an asynchronous query for timed bars timestamps.

Syntax

Visual Basic
Public Function RequestBarsTimestamps( _
   ByVal cqg_timestamps_request As CQGTimedBarsRequest _
) As CQGBarsTimestamps

Parameters

cqg_timestamps_request

Specifies the timed bars request object, which contains all parameters as properties, represented as CQGTimedBarsRequest.

Notes:

Values provided for properties that are not required are ignored.

If values are not provided for properties that are required, an exception will be thrown.

Remarks

An exception will be thrown if an asynchronous request could not be made.

Otherwise, returns a CQGBarsTimestamps object, which doesn't contain any timed bars timestamps yet and status is rsInProgress.

The outcome of the query, as well as any errors, are reported via the BarsTimestampsResolved event, which is fired only once per query.

See Also

CQGCEL Interface | CQGCEL Members | CQGTimedBarsRequest Interface | CQGBarsTimestamps Collection | CQGCEL.BarsTimestampsResolved Event


%%PageItemTitle%%

RequestCommodityInstruments Method
commodity_name
commodity symbol name
instrument_types

Instrument type bitmask represented as eInstrumentType.

This parameter can include any combination of the instrument types. Its value controls the contents of the collection returned by the CommodityInstrumentsResolved Event.

tradable_only

If set to False, all instrument names corresponding to the given instrumentTypes filter will be resolved.

If set to True, only tradable instrument names corresponding to the given instrumentTypes filter will be resolved.

The default value for this parameter is False.

CQGCEL Interface : RequestCommodityInstruments Method

Glossary Item Box

Description

Requests a list of instrument names corresponding to the specified commodity.

Syntax

Visual Basic
Public Sub RequestCommodityInstruments( _
   ByVal commodity_name As String, _
   ByVal instrument_types As eInstrumentType, _
   Optional ByVal tradable_only As Boolean = False _
)

Parameters

commodity_name
commodity symbol name
instrument_types
Value | Description
itAllInstruments | Represents all instrument types.
itAllOptions | Represents Option Call and Option Put instrument types.
itFuture | Represents Futures instrument type.
itOptionCall | Represents Option Call instrument type.
itOptionPut | Represents Option Put instrument type.
itOther | Represents other (not explicitly listed in the enumeration) instrument types, such as cash, indices, currencies, reports etc.
itStock | Represents Stock instrument type.
itSyntheticStrategy | Represents synthetic strategy instrument type.
itTreasure | Represents Treasury instrument type.
itUndefined | Undefined type.

Instrument type bitmask represented as eInstrumentType.

This parameter can include any combination of the instrument types. Its value controls the contents of the collection returned by the CommodityInstrumentsResolved Event.

tradable_only

If set to False, all instrument names corresponding to the given instrumentTypes filter will be resolved.

If set to True, only tradable instrument names corresponding to the given instrumentTypes filter will be resolved.

The default value for this parameter is False.

Remarks

This method works in asynchronous mode, i.e. the method just triggers the request in the CQGCEL without waiting for its results. The result will come with the CommodityInstrumentsResolved event.

Example

See the usage of the RequestCommodityInstruments method in CommodityInstrumentsResolved Example.

See Also

CQGCEL Interface | CQGCEL Members | CQGCEL.CommodityInstrumentsResolved Event | eInstrumentType Enumeration | CQGCEL.RequestTradableCommodities Method


%%PageItemTitle%%

RequestCondition Method
cqg_condition_request

Specifies a condition request, which contains all of the parameters as properties.

CQGCEL Interface : RequestCondition Method

Glossary Item Box

Description

Starts an asynchronous request for condition.

Syntax

Visual Basic
Public Function RequestCondition( _
   ByVal cqg_condition_request As CQGConditionRequest _
) As CQGCondition

Parameters

cqg_condition_request

Specifies a condition request, which contains all of the parameters as properties.

Remarks

In case values are provided to cqg_condition_request properties where not required, that values are ignored.

In case values are not provided to cqg_condition_request properties where they are required, an exception will be thrown.

An exception will be thrown if asynchronous request could not be made.

Otherwise, returns CQGCondition object which doesn't contain any condition results yet and status is rsInProgress.

Notes:

It is a good practice to cancel the request as soon as it becomes unnecessary. Such approach allows using memory resources more optimal.

Call RemoveCondition for request cancelling.

See Also

CQGCEL Interface | CQGCEL Members | CQGConditionRequest Interface | CQGCondition Collection


%%PageItemTitle%%

RequestConditionDefinitions Method
CQGCEL Interface : RequestConditionDefinitions Method

Glossary Item Box

Description

Starts an asynchronous query for condition definitions.

Syntax

Visual Basic
Public Sub RequestConditionDefinitions()

Remarks

The outcome of the request, as well as any errors, are reported via ConditionDefinitionsResolved event, which is fired only once per request.

See Also

CQGCEL Interface | CQGCEL Members | CQGCEL.ConditionDefinitionsResolved Event


%%PageItemTitle%%

RequestConstantVolumeBars Method
cqg_constant_volume_bars_request

Specifies constant volume bars request, which contains all parameters as properties.

Notes:

Values provided for properties that are not required are ignored.

If values are not provided for properties that are required, an exception will be thrown.

CQGCEL Interface : RequestConstantVolumeBars Method

Glossary Item Box

Description

Starts an asynchronous request for constant volume bars.

Syntax

Visual Basic
Public Function RequestConstantVolumeBars( _
   ByVal cqg_constant_volume_bars_request As CQGConstantVolumeBarsRequest _
) As CQGConstantVolumeBars

Parameters

cqg_constant_volume_bars_request

Specifies constant volume bars request, which contains all parameters as properties.

Notes:

Values provided for properties that are not required are ignored.

If values are not provided for properties that are required, an exception will be thrown.

Remarks

An exception will be thrown if asynchronous request could not be made.

Otherwise, returns a CQGConstantVolumeBars object which doesn't contain any CVBs yet and status is rsInProgress.

Notes:

It is a good practice to cancel the request as soon as it becomes unnecessary. Such approach allows using memory resources more optimal.

Call RemoveConstantVolumeBars for request cancelling.

See Also

CQGCEL Interface | CQGCEL Members | CQGConstantVolumeBarsRequest Interface | CQGConstantVolumeBars Collection


%%PageItemTitle%%

RequestCustomSessions Method
CQGCEL Interface : RequestCustomSessions Method

Glossary Item Box

Description

Starts an asynchronous query for all custom sessions available in CQGIC.

Syntax

Visual Basic
Public Sub RequestCustomSessions()

Remarks

The outcome of the request, as well as any errors, are reported via CustomSessionsResolved event, which is fired only once per request.

Note:

To view/modify a custom session's settings in CQGIC:

  • Open a chart.
  • Right-click on the main title bar and select Show Menu.
  • From the menu select ChartSetup > Chart Preferences...
  • In the Sessions tab select the required custom session from the dropdown menu.

Example

See the usage of RequestCustomSessions method in the CustomSessionsResolved event's example section.

See Also

CQGCEL Interface | CQGCEL Members | CQGCEL.CustomSessionsResolved Event | CQGSession Interface | CQGSessions Collection | CQGSessionsCollection Collection


%%PageItemTitle%%

RequestCustomStudy Method
cqg_custom_study_request

Specifies custom study request, which contains all the parameters as properties.

Notes:

Values provided for properties that are not required are ignored.

If values are not provided for properties that are required, an exception will be thrown.

CQGCEL Interface : RequestCustomStudy Method

Glossary Item Box

Description

Starts an asynchronous request for custom study.

Syntax

Visual Basic
Public Function RequestCustomStudy( _
   ByVal cqg_custom_study_request As CQGCustomStudyRequest _
) As CQGCustomStudy

Parameters

cqg_custom_study_request

Specifies custom study request, which contains all the parameters as properties.

Notes:

Values provided for properties that are not required are ignored.

If values are not provided for properties that are required, an exception will be thrown.

Remarks

An exception will be thrown if asynchronous request could not be made.

Otherwise, returns CQGCustomStudy object which doesn't contain any curves yet and status is rsInProgress.

Notes:

It is a good practice to cancel the request as soon as it becomes unnecessary. Such approach allows using memory resources more optimal.

Call RemoveCustomStudy for request cancelling.

See Also

CQGCEL Interface | CQGCEL Members | CQGCustomStudyRequest Interface | CQGCustomStudy Collection


%%PageItemTitle%%

RequestCustomStudyDefinitions Method
CQGCEL Interface : RequestCustomStudyDefinitions Method

Glossary Item Box

Description

Starts an asynchronous query for custom study definitions.

Syntax

Visual Basic
Public Sub RequestCustomStudyDefinitions()

Remarks

The outcome of the request, as well as any errors, are reported via the CustomStudyDefinitionsResolved event, which is fired only once per request.

Example

See Also

CQGCEL Interface | CQGCEL Members | CQGCEL.CustomStudyDefinitionsResolved Event


%%PageItemTitle%%

RequestDataSources Method
CQGCEL Interface : RequestDataSources Method

Glossary Item Box

Description

Starts an asynchronous query for data sources.

Syntax

Visual Basic
Public Sub RequestDataSources()

Remarks

The outcome of the request, as well as any errors, are reported via the DataSourcesResolved event, which is fired only once per request.

Returned data sources are the financial data providers available in CQGIC.

Example

See the usage of RequestDataSources method in the DataSourcesResolved event's example section.

See Also

CQGCEL Interface | CQGCEL Members | CQGCEL.DataSourcesResolved Event | CQGDataSources Collection | CQGCEL.RequestDataSourceSymbols Method


%%PageItemTitle%%

RequestDataSourceSymbols Method
data_source_abbreviation

Name of the data source, which symbol list is requested.

CQGDataSources.Abbreviation can be used as an argument.

If dataSourceName is empty, an exception will be thrown.

CQGCEL Interface : RequestDataSourceSymbols Method

Glossary Item Box

Description

Starts an asynchronous query for symbols of a data source.

Syntax

Visual Basic
Public Sub RequestDataSourceSymbols( _
   ByVal data_source_abbreviation As String _
)

Parameters

data_source_abbreviation

Name of the data source, which symbol list is requested.

CQGDataSources.Abbreviation can be used as an argument.

If dataSourceName is empty, an exception will be thrown.

Remarks

The outcome of the request, as well as any errors, are reported via the DataSourceSymbolsResolved event, which is fired only once per request.

Example

See the usage of RequestDataSourceSymbols method in the DataSourcesResolved event's example section.

See Also

CQGCEL Interface | CQGCEL Members | CQGCEL.DataSourceSymbolsResolved Event | CQGDataSourceSymbols Collection | CQGCEL.RequestDataSources Method


%%PageItemTitle%%

RequestExpression Method
cqg_expression_request

Specifies the expression request, which contains all the parameters as properties.

Notes:

Values provided for properties that are not required are ignored.

If values are not provided for properties that are required, an exception will be thrown.

CQGCEL Interface : RequestExpression Method

Glossary Item Box

Description

Starts an asynchronous request for an expression.

Syntax

Visual Basic
Public Function RequestExpression( _
   ByVal cqg_expression_request As CQGExpressionRequest _
) As CQGExpression

Parameters

cqg_expression_request

Specifies the expression request, which contains all the parameters as properties.

Notes:

Values provided for properties that are not required are ignored.

If values are not provided for properties that are required, an exception will be thrown.

Remarks

An exception will be thrown if asynchronous request could not be made.

Otherwise, returns the CQGExpression object, which doesn't contain any expression yet and which status is rsInProgress.

Notes:

It is a good practice to cancel the request as soon as it becomes unnecessary. Such approach allows using memory resources more optimal.

Call RemoveExpression for request cancelling.

See Also

CQGCEL Interface | CQGCEL Members | CQGExpressionRequest Interface | CQGExpression Collection


%%PageItemTitle%%

RequestGWConnection Method
cqg_gw_connection_request
Specifies the gateway connection request, which contains all the parameters as properties.
CQGCEL Interface : RequestGWConnection Method

Glossary Item Box

Description

Starts a gateway connection request

Syntax

Visual Basic
Public Sub RequestGWConnection( _
   ByVal cqg_gw_connection_request As CQGGWConnectionRequest _
)

Parameters

cqg_gw_connection_request
Specifies the gateway connection request, which contains all the parameters as properties.

Remarks

If values are not provided for properties that are required, an exception will be thrown.

The method work depends on GatewayEnabled property value.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RequestHistoricalSessions Method
cqg_historical_sessions_request

Specifies the historical sessions request, which contains all the parameters as properties.

Notes:

Values provided for properties that are not required are ignored.

If values are not provided for properties that are required, an exception will be thrown.

CQGCEL Interface : RequestHistoricalSessions Method

Glossary Item Box

Description

Starts an asynchronous request for historical sessions.

Syntax

Visual Basic
Public Sub RequestHistoricalSessions( _
   ByVal cqg_historical_sessions_request As CQGHistoricalSessionsRequest _
)

Parameters

cqg_historical_sessions_request

Specifies the historical sessions request, which contains all the parameters as properties.

Notes:

Values provided for properties that are not required are ignored.

If values are not provided for properties that are required, an exception will be thrown.

Remarks

The outcome of request, as well as any errors, are reported via HistoricalSessionsResolved event, which is fired only once per request.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RequestInstrumentsGroup Method
group_request

The requested instruments group object; represented as CQGInstrumentsGroupRequest.

Use CQGCEL.CreateInstrumentsGroupRequest Method to create request object.

trace_group_changes

If the value is True:

  • All changes in resolved groups (such as added or removed contracts) are reported via CQGCEL.InstrumentsGroupChanged Event.
  • All instruments in group are subscribed to real-time changes which are reported via CQGCEL.InstrumentChanged Event.
CQGCEL Interface : RequestInstrumentsGroup Method

Glossary Item Box

Description

Requests a group of instruments.

Syntax

Visual Basic
Public Sub RequestInstrumentsGroup( _
   ByVal group_request As CQGInstrumentsGroupRequest, _
   ByVal trace_group_changes As Boolean _
)

Parameters

group_request

The requested instruments group object; represented as CQGInstrumentsGroupRequest.

Use CQGCEL.CreateInstrumentsGroupRequest Method to create request object.

trace_group_changes

If the value is True:

  • All changes in resolved groups (such as added or removed contracts) are reported via CQGCEL.InstrumentsGroupChanged Event.
  • All instruments in group are subscribed to real-time changes which are reported via CQGCEL.InstrumentChanged Event.

Remarks

This request is asynchronous. The execution result is reported via CQGCEL.InstrumentsGroupResolved event.

The request result is represented by the CQGInstrumentsGroup object. It is possible to access all resolved instrument groups via CQGCEL.AllInstrumentsGroups Property.

It is a good practice to cancel the request as soon as it becomes unnecessary. Such an approach allows using memory resources more optimal.

Use RemoveInstrumentsGroup to cancel request and remove resolved CQGInstrumentsGroup.

See Also

CQGCEL Interface | CQGCEL Members | CQGInstrumentsGroupRequest Interface | InstrumentsGroupResolved Event | InstrumentsGroupChanged Event | CQGInstrumentsGroup Interface | AllInstrumentsGroups Property | RemoveInstrumentsGroup Method


%%PageItemTitle%%

RequestManualFills Method
gw_account_id

Identifies the Gateway account to be used for the request.

update_level

Specifies the subscription level for the request updates, represented as eManualFillUpdateType.

CQGCEL Interface : RequestManualFills Method

Glossary Item Box

Description

Starts an asynchronous query of manual fills for a gateway account.

Syntax

Visual Basic
Public Sub RequestManualFills( _
   ByVal gw_account_id As Long, _
   ByVal update_level As eManualFillsDataLevel _
)

Parameters

gw_account_id

Identifies the Gateway account to be used for the request.

update_level
Value Description
mfdlSnapshot

Only current values of manual fills will be received.

mfdlSnapshotAndUpdates

All current values of manual fills as well as notifications about their changes will be received.

Specifies the subscription level for the request updates, represented as eManualFillUpdateType.

Remarks

In order to function, this method requires that the user is logged on to CQG gateway.

The outcome of the request, as well as any errors, are reported via the ManualFillsResolved event, which is fired only once per request.

Every time the RequestManualFills method is called for a specified account, it will replace the old data (collection, manual fills) with the new resolved data.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RequestManualFillUpdate Method
cqg_manual_fill_request

The manual fill request object to be executed

CQGCEL Interface : RequestManualFillUpdate Method

Glossary Item Box

Description

Executes the given manual fill request.

Syntax

Visual Basic
Public Sub RequestManualFillUpdate( _
   ByVal cqg_manual_fill_request As CQGManualFillRequest _
)

Parameters

cqg_manual_fill_request

The manual fill request object to be executed

Remarks

In order to function, this method requires that the user is logged on to CQG gateway.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RequestOrders Method
orders_request

Specifies a orders request, which contains all of the parameters as properties.

CQGCEL Interface : RequestOrders Method

Glossary Item Box

Description

Performs orders querying

Syntax

Visual Basic
Public Function RequestOrders( _
   ByVal orders_request As CQGOrdersRequest _
) As CQGOrdersQuery

Parameters

orders_request

Specifies a orders request, which contains all of the parameters as properties.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RequestPointAndFigureBars Method
cqg_point_and_figure_bars_request

Specifies the point and figure bars request, which contains all the parameters as properties.

Notes:

Values provided for properties that are not required are ignored.

If values are not provided for properties that are required, an exception will be thrown.

CQGCEL Interface : RequestPointAndFigureBars Method

Glossary Item Box

Description

Starts an asynchronous request for a point and figure bars.

Syntax

Visual Basic
Public Function RequestPointAndFigureBars( _
   ByVal cqg_point_and_figure_bars_request As CQGPointAndFigureBarsRequest _
) As CQGPointAndFigureBars

Parameters

cqg_point_and_figure_bars_request

Specifies the point and figure bars request, which contains all the parameters as properties.

Notes:

Values provided for properties that are not required are ignored.

If values are not provided for properties that are required, an exception will be thrown.

Remarks

An exception will be thrown if an asynchronous request could not be made.

Otherwise, returns CQGPointAndFigureBars object, which doesn't contain any PFs yet and which status is rsInProgress.

Notes:

It is a good practice to cancel the request as soon as it becomes unnecessary. Such approach allows using memory resources more optimal.

Call RemovePointAndFigureBars for request cancelling.

See Also

CQGCEL Interface | CQGCEL Members | CQGPointAndFigureBarsRequest Interface | CQGPointAndFigureBars Collection


%%PageItemTitle%%

RequestQFormulaDefinition Method
qformula_expression

Expression can be name or number of QFormula. Name can be passed with or without prefix "Q.".

Number should be formatted as "QNumber".

For example, for QFormula "Q.Crack" with number 17 next inputs are valid:

  • "Q.Crack"
  • "Crack"
  • "Q17"
CQGCEL Interface : RequestQFormulaDefinition Method

Glossary Item Box

Description

Starts an asynchronous query for QFormula definition by QFormula name or number.

Syntax

Visual Basic
Public Sub RequestQFormulaDefinition( _
   ByVal qformula_expression As String _
)

Parameters

qformula_expression

Expression can be name or number of QFormula. Name can be passed with or without prefix "Q.".

Number should be formatted as "QNumber".

For example, for QFormula "Q.Crack" with number 17 next inputs are valid:

  • "Q.Crack"
  • "Crack"
  • "Q17"

Remarks

The outcome of the request, as well as any errors, are reported via the QFormulaDefinitionResolved event, which is fired only once per request.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RequestQFormulaDefinitions Method
CQGCEL Interface : RequestQFormulaDefinitions Method

Glossary Item Box

Description

Starts an asynchronous query for QFormula definitions.

Syntax

Visual Basic
Public Sub RequestQFormulaDefinitions()

Remarks

The outcome of the request, as well as any errors, are reported via the QFormulaDefinitionsResolved event, which is fired only once per request.

See Also

CQGCEL Interface | CQGCEL Members | CQGCEL.QFormulaDefinitionsResolved Event


%%PageItemTitle%%

RequestRangeBars Method
cqg_renko_bars_request

Specifies a range bars request, which contains all of the parameters as properties.

CQGCEL Interface : RequestRangeBars Method

Glossary Item Box

Description

Starts an asynchronous request for range bars

Syntax

Visual Basic
Public Function RequestRangeBars( _
   ByVal cqg_renko_bars_request As CQGRangeBarsRequest _
) As CQGRangeBars

Parameters

cqg_renko_bars_request

Specifies a range bars request, which contains all of the parameters as properties.

Remarks

It is a good practice to cancel the request as soon as it becomes unnecessary. Such approach allows using memory resources more optimal.

Call RemoveRangeBars for request cancelling.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RequestRenkoBars Method
cqg_renko_bars_request

Specifies a renko bars request, which contains all of the parameters as properties.

CQGCEL Interface : RequestRenkoBars Method

Glossary Item Box

Description

Starts an asynchronous request for renko bars

Syntax

Visual Basic
Public Function RequestRenkoBars( _
   ByVal cqg_renko_bars_request As CQGRenkoBarsRequest _
) As CQGRenkoBars

Parameters

cqg_renko_bars_request

Specifies a renko bars request, which contains all of the parameters as properties.

Remarks

It is a good practice to cancel the request as soon as it becomes unnecessary. Such approach allows using memory resources more optimal.

Call RemoveRenkoBars for request cancelling.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RequestSubMinuteBars Method
cqg_subminute_bars_request

Specifies subminute bars request, which contains all the parameters as properties.

Notes:

Values provided for properties that are not required are ignored.

If values are not provided for properties that are required, an exception will be thrown.

CQGCEL Interface : RequestSubMinuteBars Method

Glossary Item Box

Description

Starts an asynchronous request for sub minute bars

Syntax

Visual Basic
Public Function RequestSubMinuteBars( _
   ByVal cqg_subminute_bars_request As CQGSubMinuteBarsRequest _
) As CQGSubMinuteBars

Parameters

cqg_subminute_bars_request

Specifies subminute bars request, which contains all the parameters as properties.

Notes:

Values provided for properties that are not required are ignored.

If values are not provided for properties that are required, an exception will be thrown.

Remarks

An exception will be thrown if an asynchronous request could not be made.

Otherwise, returns a CQGSubMinuteBars object which doesn't contain any timed bars yet and status is rsInProgress.

Notes:

It is a good practice to cancel the request as soon as it becomes unnecessary. Such approach allows using memory resources more optimal.

Call RemoveSubMinuteBars for request cancelling.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RequestTFlowBars Method
cqg_tflow_bars_request

Specifies the TFlow bars request, which contains all the parameters as properties.

Notes:

Values provided for properties that are not required are ignored.

If values are not provided for properties that are required, an exception will be thrown.

CQGCEL Interface : RequestTFlowBars Method

Glossary Item Box

Description

Starts an asynchronous request for TFlow bars.

Syntax

Visual Basic
Public Function RequestTFlowBars( _
   ByVal cqg_tflow_bars_request As CQGTFlowBarsRequest _
) As CQGTFlowBars

Parameters

cqg_tflow_bars_request

Specifies the TFlow bars request, which contains all the parameters as properties.

Notes:

Values provided for properties that are not required are ignored.

If values are not provided for properties that are required, an exception will be thrown.

Remarks

An exception will be thrown if asynchronous request could not be made.

Otherwise, returns the CQGTFlowBars object, which doesn't contain any TFlow bars yet and which status is rsInProgress.

Notes:

It is a good practice to cancel the request as soon as it becomes unnecessary. Such approach allows using memory resources more optimal.

Call RemoveTFlowBars for request cancelling.

See Also

CQGCEL Interface | CQGCEL Members | CQGTFlowBarsRequest Interface | CQGTFlowBar Interface | CQGTFlowBars Collection | CQGCEL.CreateTFlowBarsRequest Method


%%PageItemTitle%%

RequestTicks Method
cqg_ticks_request

Specifies the ticks request, which contains all the parameters as properties.

Notes:

Values provided for properties that are not required are ignored.

If values are not provided for properties that are required, an exception will be thrown.

CQGCEL Interface : RequestTicks Method

Glossary Item Box

Description

Starts an asynchronous request for ticks.

Syntax

Visual Basic
Public Function RequestTicks( _
   ByVal cqg_ticks_request As CQGTicksRequest _
) As CQGTicks

Parameters

cqg_ticks_request

Specifies the ticks request, which contains all the parameters as properties.

Notes:

Values provided for properties that are not required are ignored.

If values are not provided for properties that are required, an exception will be thrown.

Remarks

An exception will be thrown if an asynchronous request could not be made.

Otherwise, returns CQGTicks object, which doesn't contain any ticks yet and which status is rsInProgress.

Notes:

It is a good practice to cancel the request as soon as it becomes unnecessary. Such approach allows using memory resources more optimal.

Call RemoveTicks for request cancelling.

Example

See Also

CQGCEL Interface | CQGCEL Members | CQGTicksRequest Interface | CQGTicks Collection | CQGTick Interface


%%PageItemTitle%%

RequestTimedBars Method
cqg_timed_bars_request

Specifies timed bars request, which contains all the parameters as properties.

Notes:

Values provided for properties that are not required are ignored.

If values are not provided for properties that are required, an exception will be thrown.

CQGCEL Interface : RequestTimedBars Method

Glossary Item Box

Description

Starts an asynchronous request for timed bars.

Syntax

Visual Basic
Public Function RequestTimedBars( _
   ByVal cqg_timed_bars_request As CQGTimedBarsRequest _
) As CQGTimedBars

Parameters

cqg_timed_bars_request

Specifies timed bars request, which contains all the parameters as properties.

Notes:

Values provided for properties that are not required are ignored.

If values are not provided for properties that are required, an exception will be thrown.

Remarks

An exception will be thrown if an asynchronous request could not be made.

Otherwise, returns a CQGTimedBars object which doesn't contain any timed bars yet and status is rsInProgress.

Notes:

It is a good practice to cancel the request as soon as it becomes unnecessary. Such approach allows using memory resources more optimal.

Call RemoveTimedBars for request cancelling.

See Also

CQGCEL Interface | CQGCEL Members | CQGTimedBarsRequest Interface | CQGTimedBars Collection | CQGTimedBar Interface


%%PageItemTitle%%

RequestTradableCommodities Method
gw_account_id

Gateway account ID, for which tradable commodities are requested, represented as Long.

If the gw_account_id is not specified or it is zero, all tradable commodities for all gateway accounts the current trader is assigned to, will be requested.

Otherwise, only commodities that are allowed to be traded by the active gateway account with gw_account_id , will be requested.

For more details on account identifiers, see CQGAccount.GWAccountID.

CQGCEL Interface : RequestTradableCommodities Method

Glossary Item Box

Description

Starts an asynchronous query for tradable commodities.

Syntax

Visual Basic
Public Sub RequestTradableCommodities( _
   Optional ByVal gw_account_id As Long = 0 _
)

Parameters

gw_account_id

Gateway account ID, for which tradable commodities are requested, represented as Long.

If the gw_account_id is not specified or it is zero, all tradable commodities for all gateway accounts the current trader is assigned to, will be requested.

Otherwise, only commodities that are allowed to be traded by the active gateway account with gw_account_id , will be requested.

For more details on account identifiers, see CQGAccount.GWAccountID.

Remarks

Requires the user to be logged on to the CQG gateway.

The outcome of the request, as well as any errors, are reported via TradableCommoditiesResolved event, which is fired only once per request.

Example

See the usage of RequestTradableCommodities method in the TradableCommoditiesResolved event's example section.

See Also

CQGCEL Interface | CQGCEL Members | TradableCommoditiesResolved Event | CQGCommodities Collection | CQGAccount.GWAccountID Property


%%PageItemTitle%%

RequestTradableExchanges Method
gw_account_id

Gateway account ID, for which tradable exchanges are requested, represented as Long.

If the gw_account_id is not specified or it is zero, all tradable exchanges for all gateway accounts the current trader is assigned to, will be requested.

Otherwise, only exchanges that are allowed to be traded by the active gateway account with gw_account_id , will be requested.

For more details on account identifiers, see CQGAccount.GWAccountID.

CQGCEL Interface : RequestTradableExchanges Method

Glossary Item Box

Description

Starts an asynchronous query for tradable exchanges.

Syntax

Visual Basic
Public Sub RequestTradableExchanges( _
   Optional ByVal gw_account_id As Long = 0 _
)

Parameters

gw_account_id

Gateway account ID, for which tradable exchanges are requested, represented as Long.

If the gw_account_id is not specified or it is zero, all tradable exchanges for all gateway accounts the current trader is assigned to, will be requested.

Otherwise, only exchanges that are allowed to be traded by the active gateway account with gw_account_id , will be requested.

For more details on account identifiers, see CQGAccount.GWAccountID.

Remarks

Requires the user to be logged on to the CQG gateway.

The outcome of the request, as well as any errors, are reported via TradableExchangesResolved event, which is fired only once per request.

See Also

CQGCEL Interface | CQGCEL Members | CQGCEL.TradableExchangesResolved Event | CQGExchanges Collection | CQGAccount.GWAccountID Property


%%PageItemTitle%%

RequestTradingSystem Method
cqg_trading_system_request

Specifies trading system request, which contains all parameters as properties.

Notes:

Values provided for properties that are not required are ignored.

If values are not provided for properties that are required, an exception will be thrown.

CQGCEL Interface : RequestTradingSystem Method

Glossary Item Box

Description

Starts an asynchronous request for trading system.

Syntax

Visual Basic
Public Function RequestTradingSystem( _
   ByVal cqg_trading_system_request As CQGTradingSystemRequest _
) As CQGTradingSystem

Parameters

cqg_trading_system_request

Specifies trading system request, which contains all parameters as properties.

Notes:

Values provided for properties that are not required are ignored.

If values are not provided for properties that are required, an exception will be thrown.

Remarks

An exception will be thrown if asynchronous request could not be made.

Otherwise, returns CQGTradingSystem object, which doesn't contain any trading systems yet and status is rsInProgress.

Notes:

It is a good practice to cancel the request as soon as it becomes unnecessary. Such approach allows using memory resources more optimal.

Call RemoveTradingSystem for request cancelling.

See Also

CQGCEL Interface | CQGCEL Members | CQGTradingSystemRequest Interface | CQGTradingSystems Collection


%%PageItemTitle%%

RequestTradingSystemDefinitions Method
CQGCEL Interface : RequestTradingSystemDefinitions Method

Glossary Item Box

Description

Starts an asynchronous query for trading system definitions.

Syntax

Visual Basic
Public Sub RequestTradingSystemDefinitions()

Remarks

The outcome of request, as well as any errors, are reported via TradingSystemDefinitionsResolved event, which is fired only once per request.

See Also

CQGCEL Interface | CQGCEL Members | CQGCEL.TradingSystemDefinitionsResolved Event


%%PageItemTitle%%

RequestYields Method
cqg_yields_request
Request parameters
CQGCEL Interface : RequestYields Method

Glossary Item Box

Description

Starts an asynchronous request for yields

Syntax

Visual Basic
Public Function RequestYields( _
   ByVal cqg_yields_request As CQGYieldsRequest _
) As CQGYields

Parameters

cqg_yields_request
Request parameters

Remarks

Notes:

It is a good practice to cancel the request as soon as it becomes unnecessary. Such approach allows using memory resources more optimal.

Call RemoveYields for request cancelling.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

Shutdown Method
CQGCEL Interface : Shutdown Method

Glossary Item Box

Description

Shuts down the CQG API.

Syntax

Visual Basic
Public Sub Shutdown()

Remarks

Shutdown should be called after the work of the user application is finished and there is no need for the CQG API functionality any more.

This method works in synchronous mode; i.e. after the method return, no more calls to CQGCEL will work unless the Startup method is called again.

Example

See the usage of the Shutdown method in CQGCEL Example.

See Also

CQGCEL Interface | CQGCEL Members | CQGCEL.Startup Method


%%PageItemTitle%%

Startup Method
CQGCEL Interface : Startup Method

Glossary Item Box

Description

Starts up the CQG API.

Syntax

Visual Basic
Public Sub Startup()

Remarks

This method works in asynchronous mode; i.e. after the method return, the CQG API functionality will not be available until the CELStarted event is fired.

Startup should be called first after the creation of CQGCEL object. If the initialization fails a DataError event will be fired.

Example

See the usage of the Startup method in CQGCEL Example.

See Also

CQGCEL Interface | CQGCEL Members | CQGCEL.Shutdown Method


%%PageItemTitle%%

SubscribeNewInstrument Method
instrument_request

Instrument request object, represented as CQGInstrumentSubscriptionRequest

CQGCEL Interface : SubscribeNewInstrument Method

Glossary Item Box

Description

Resolves a new instrument and subscribe to it asynchronously.

Syntax

Visual Basic
Public Sub SubscribeNewInstrument( _
   ByVal instrument_request As CQGInstrumentSubscriptionRequest _
)

Parameters

instrument_request

Instrument request object, represented as CQGInstrumentSubscriptionRequest

Remarks

This method should be used if CQGAPIConfig.NewInstrumentMode is set to True, otherwise use the NewInstrument method.

The method works in asynchronous mode, i.e. the method just triggers the request in the CQGCEL without waiting for its results.

InstrumentResolved event is fired as a result of the method call.

Depricated:

If the symbol is valid, the result will come with the InstrumentSubscribed event.

If the symbol is not valid, the IncorrectSymbol event will be fired.

An exception will be thrown if symbol is empty string.

It is a good practice to cancel the request as soon as it becomes unnecessary. Such approach allows using memory resources more optimal.

Call RemoveInstrument for request cancelling.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

TerminateCQGIC Method
start_again
Whether CQGIC should start again after termination or not
CQGCEL Interface : TerminateCQGIC Method

Glossary Item Box

Description

Terminates or restarts the local CQGIC.

Syntax

Visual Basic
Public Sub TerminateCQGIC( _
   Optional ByVal start_again As Boolean = False _
)

Parameters

start_again
Whether CQGIC should start again after termination or not

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

UnregisterAlgorithmicOrder Method
guid_

GUID of the algorithmic order type

CQGCEL Interface : UnregisterAlgorithmicOrder Method

Glossary Item Box

Description

Unregisters the algorithmic order types by its GUID.

Syntax

Visual Basic
Public Sub UnregisterAlgorithmicOrder( _
   ByVal guid_ As String _
)

Parameters

guid_

GUID of the algorithmic order type

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

Accounts Property
CQGCEL Interface : Accounts Property

Glossary Item Box

Description

Returns the collection of accounts that belong to the current trader logon name.

Property type

Read-only property

Syntax

Visual Basic
Public Property Accounts As CQGAccounts

Return Type

CQGAccounts collection containing all accounts that belong to current trader in CQG System.

Remarks

The collection remains empty while the AccountSubscriptionLevel property is set to aslNone, which is the default. However if aslNone is set back after another value (see AccountSubscriptionLevel for details), the collection will not be emptied. It will remain as it was before this setting.

The number of items in the collection cannot be changed on the fly. Even if a change has occurred in the CQG System, it will be reflected in CQG API only when an AccountChanged event is fired with actAccountsReloaded change type, i.e. only upon Gateway relogon.

Example

See the usage of Accounts property in the AccountChanged event's example section.

See Also

CQGCEL Interface | CQGCEL Members | CQGAccount Interface | eAccountSubscriptionLevel Enumeration


%%PageItemTitle%%

AccountSubscriptionLevel Property
CQGCEL Interface : AccountSubscriptionLevel Property

Glossary Item Box

Description

Gets/sets the account subscription level.

Property type

Read-write property

Syntax

Visual Basic
Public Property AccountSubscriptionLevel As eAccountSubscriptionLevel

Return Type

Current subscription level represented as eAccountSubscriptionLevel.

Remarks

This property controls the account data delivery mode.

If the user does not need data given by CQG API in v.3.0 and higher, he/she can turn off that functionality by setting this property to aslNone.

Note: This property setting will succeed only after the user is logged on to the CQG Gateway in CQGIC and a corresponding GWConnectionStatusChanged with csConnectionUp event is received in CQG API.

See eAccountSubscriptionLevel Enumeration for details.

Note: If the user tries to change this property to something other than 'aslNone' while the connection is down, a corresponding DataError event will be fired.

In order to use order functionality the AccountSubscriptionLevel property of CQGCEL should be set to aslAccountUpdatesAndOrders

Example

See the usage of AccountSubscriptionLevel property in the AccountChanged event's example section.

See Also

CQGCEL Interface | CQGCEL Members | eAccountSubscriptionLevel Enumeration


%%PageItemTitle%%

AllAdvancedStudies Property
CQGCEL Interface : AllAdvancedStudies Property

Glossary Item Box

Description

Returns collection of advanced studies requested only by this instance of CEL

Property type

Read-only property

Syntax

Visual Basic
Public Property AllAdvancedStudies As CQGAdvancedStudies

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

AllConditions Property
CQGCEL Interface : AllConditions Property

Glossary Item Box

Description

Returns collection of conditions requested only by this instance of CEL.

Property type

Read-only property

Syntax

Visual Basic
Public Property AllConditions As CQGConditions

Return Type

The collection of requested conditions, represented as CQGConditions

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

AllConstantVolumeBars Property
CQGCEL Interface : AllConstantVolumeBars Property

Glossary Item Box

Description

Returns collection of constant volume bars requested only by this instance of CEL.

Property type

Read-only property

Syntax

Visual Basic
Public Property AllConstantVolumeBars As CQGConstantVolumeBarsCollection

Return Type

The collection of requested constant volume bars, represented as CQGConstantVolumeBarsCollection

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

AllCustomStudies Property
CQGCEL Interface : AllCustomStudies Property

Glossary Item Box

Description

Returns collection of custom studies requested only by this instance of CEL.

Property type

Read-only property

Syntax

Visual Basic
Public Property AllCustomStudies As CQGCustomStudies

Return Type

The collection of requested custom studies, represented as CQGCustomStudies

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

AllExpressions Property
CQGCEL Interface : AllExpressions Property

Glossary Item Box

Description

Returns a collection of all expressions that were requested during this instance of CQGCEL.

Property type

Read-only property

Syntax

Visual Basic
Public Property AllExpressions As CQGExpressions

Return Type

Collection of expressions, represented as CQGExpressions

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

AllInstrumentsGroups Property
CQGCEL Interface : AllInstrumentsGroups Property

Glossary Item Box

Description

Returns the collection of instruments groups.

Property type

Read-only property

Syntax

Visual Basic
Public Property AllInstrumentsGroups As CQGInstrumentsGroups

Return Type

The collection of instruments groups, represented as CQGInstrumentsGroups Object

See Also

CQGCEL Interface | CQGCEL Members | CQGInstrumentsGroup Interface | RequestInstrumentsGroup Method | RemoveInstrumentsGroup Method


%%PageItemTitle%%

AllManualFills Property
CQGCEL Interface : AllManualFills Property

Glossary Item Box

Description

Gets the collection of all manual fills.

Property type

Read-only property

Syntax

Visual Basic
Public Property AllManualFills As CQGManualFillsCollection

Return Type

All manual fills collection, represented as CQGManualFillsCollection

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

AllPointAndFigureBars Property
CQGCEL Interface : AllPointAndFigureBars Property

Glossary Item Box

Description

Returns the collection of point and figure bars requested only by this instance of CEL.

Property type

Read-only property

Syntax

Visual Basic
Public Property AllPointAndFigureBars As CQGPointAndFigureBarsCollection

Return Type

The collection of requested point and figure bars, represented as CQGPointAndFigureBarsCollection

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

AllRangeBars Property
CQGCEL Interface : AllRangeBars Property

Glossary Item Box

Description

Returns collection of CQGRangeBars requested only by this instance of CEL

Property type

Read-only property

Syntax

Visual Basic
Public Property AllRangeBars As CQGRangeBarsCollection

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

AllRenkoBars Property
CQGCEL Interface : AllRenkoBars Property

Glossary Item Box

Description

Returns collection of CQGRenkoBars requested only by this instance of CEL

Property type

Read-only property

Syntax

Visual Basic
Public Property AllRenkoBars As CQGRenkoBarsCollection

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

AllStrategyDefinitions Property
CQGCEL Interface : AllStrategyDefinitions Property

Glossary Item Box

Description

Returns all strategy definitions.

Property type

Read-only property

Syntax

Visual Basic
Public Property AllStrategyDefinitions As CQGStrategyDefinitions

Return Type

All strategy definitions, represented as CQGStrategyDefinitions collection

See Also

CQGCEL Interface | CQGCEL Members | CQGStrategyDefinitions Collection | CQGStrategyDefinition Interface


%%PageItemTitle%%

AllSubMinuteBars Property
CQGCEL Interface : AllSubMinuteBars Property

Glossary Item Box

Description

Returns collection of CQGSubMinuteBar bars requested only by this instance of CEL

Property type

Read-only property

Syntax

Visual Basic
Public Property AllSubMinuteBars As CQGSubMinuteBarsCollection

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

AllTFlowBars Property
CQGCEL Interface : AllTFlowBars Property

Glossary Item Box

Description

Returns collection of TFlow bars, requested only by this instance of CEL.

Property type

Read-only property

Syntax

Visual Basic
Public Property AllTFlowBars As CQGTFlowBarsCollection

Return Type

All requested TFlow bars, represented as CQGTFlowBarsCollection

See Also

CQGCEL Interface | CQGCEL Members | CQGTFlowBar Interface


%%PageItemTitle%%

AllTicks Property
CQGCEL Interface : AllTicks Property

Glossary Item Box

Description

Returns the collection of ticks requested only by this instance of CEL.

Property type

Read-only property

Syntax

Visual Basic
Public Property AllTicks As CQGTicksCollection

Return Type

The collection of requested ticks, represented as CQGTicksCollection

See Also

CQGCEL Interface | CQGCEL Members | CQGTick Interface


%%PageItemTitle%%

AllTimedBars Property
CQGCEL Interface : AllTimedBars Property

Glossary Item Box

Description

Returns a collection of all timed bars that were requested during this instance of CQGCEL.

Property type

Read-only property

Syntax

Visual Basic
Public Property AllTimedBars As CQGTimedBarsCollection

Return Type

Collection of timed bars, represented as CQGTimedBarsCollection Object

See Also

CQGCEL Interface | CQGCEL Members | CQGTimedBar Interface


%%PageItemTitle%%

AllTradingSystems Property
CQGCEL Interface : AllTradingSystems Property

Glossary Item Box

Description

Returns the collection of trading systems requested only by this instance of CEL.

Property type

Read-only property

Syntax

Visual Basic
Public Property AllTradingSystems As CQGTradingSystems

Return Type

The collection of requested trading systems, represented as CQGTradingSystems

See Also

CQGCEL Interface | CQGCEL Members | CQGTradingSystem Interface


%%PageItemTitle%%

AllYields Property
CQGCEL Interface : AllYields Property

Glossary Item Box

Description

Returns collection of yields requested only by this instance of CEL

Property type

Read-only property

Syntax

Visual Basic
Public Property AllYields As CQGYieldsCollection

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

APIConfiguration Property
CQGCEL Interface : APIConfiguration Property

Glossary Item Box

Description

Controls the CQG API current configuration.

Property type

Read-only property

Syntax

Visual Basic
Public Property APIConfiguration As CQGAPIConfig

Return Type

Current configuration of CQG API represented as CQGAPIConfig.

Remarks

Configuration settings can be changed only when CQGCEL is not started.

If the configuration is to be changed during CQGCEL's work, first call the Shutdown Method, make your changes and then call the Startup Method.

This property is added as a replacement for Configuration property, which is still preserved for backward compatibility.

However in new applications it is advised to use this property, because new features are added only here.

Example

See the usage of APIConfiguration property in the AccountChanged event's example section.

See Also

CQGCEL Interface | CQGCEL Members | CQGAPIConfig Interface


%%PageItemTitle%%

Configuration Property
CQGCEL Interface : Configuration Property

Glossary Item Box

Description

Gets/sets the current configuration of CQGCEL. Deprecated.

Deprecated!

In CQG API v.3.0 and higher a new interface was introduced for configuration management: CQGAPIConfig. However this structure is still preserved for backward compatibility.

Property type

Read-write property

Syntax

Visual Basic
Public Property Configuration As CQGCELConfiguration

Return Type

Gets or sets the current configuration of the CQGCEL object represented as the CQGCELConfiguration structure.

Remarks

Configuration can be changed while the CQGCEL is not started. If the configuration is to be changed during CQGCEL's work, first call Shutdown Method, make your changes, and then call Startup Method.

Deprecated! Use APIConfiguration instead.

See Also

CQGCEL Interface | CQGCEL Members | CQGCELConfiguration UDT


%%PageItemTitle%%

CurrencyRates Property
CQGCEL Interface : CurrencyRates Property

Glossary Item Box

Description

Returns the collection of currency rates from all FCMs.

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrencyRates As CQGCurrencyRates

Return Type

Currency rates represented as CQGCurrencyRates Collection

Remarks

The currency rates are obtained from FCMs by CQG.

If currency rate is changed at any FCM, it will be reflected in the collection and a CurrencyRatesChanged event will be fired to notify the user about the recent changes.

Note: The currency rates information is available only if the user is logged on to the CQG Gateway. It means that the collection is empty or out-dated if the AccountSubscriptionLevel value is set to aslNone, or if the Gateway connection is down.

Example

See the usage of CurrencyRates property in the CurrencyRatesChanged event's example section.

See Also

CQGCEL Interface | CQGCEL Members | CQGCurrencyRates Collection | CQGCurrencyRate Interface | CQGCEL.CurrencyRatesChanged Event


%%PageItemTitle%%

DirectEventsAccessor Property
CQGCEL Interface : DirectEventsAccessor Property

Glossary Item Box

Description

Returns the CQGDirectEventsAccessor object used to raise non-dispatch (i.e., vtbl) events.

Property type

Read-only property

Syntax

Visual Basic
Public Property DirectEventsAccessor As CQGDirectEventsAccessor

Return Type

The corresponding CQGDirectEventsAccessor object.

See Also

CQGCEL Interface | CQGCEL Members | CQGDirectEventsAccessor Interface


%%PageItemTitle%%

Environment Property
CQGCEL Interface : Environment Property

Glossary Item Box

Description

Returns the CQGCEL environment information.

Property type

Read-only property

Syntax

Visual Basic
Public Property Environment As CQGEnvironment

Return Type

Current environment information as CQGEnvironment object

Remarks

Environment includes information on CQGCEL(CQG API module version), CQGCEL environment (such as CQGIC version, Line Time), CQGCEL internal status (pending messages) etc.

Example

See the example section of the LineTimeChanged event.

See Also

CQGCEL Interface | CQGCEL Members | CQGEnvironment Interface


%%PageItemTitle%%

Instruments Property
CQGCEL Interface : Instruments Property

Glossary Item Box

Description

Returns the collection of currently resolved instruments.

Property type

Read-only property

Syntax

Visual Basic
Public Property Instruments As CQGInstruments

Return Type

CQGInstruments collection containing all instruments that were previously resolved

Remarks

The Instruments property returns a collection of instruments, which were previously resolved and subscribed. It also contains instruments that were subscribed, and then their subscription level was set to dsNone.

An instrument is removed from this collection only by calling the RemoveInstrument or RemoveAllInstruments methods.

In CQG API version 3.0 and higher instruments that were subscribed via AutoSubscribeInstruments setting are also included in this collection.

Example

The example demonstrates how to get the moment, when two instruments are valid and it is possible to work with a spread. The example demonstrates the usage of the CQGCEL.Instruments collection element access technique using the instrument's full name.

VB
C#
Private Sub cel_InstrumentSubscribed(ByVal Symbl As String, ByVal Instrument As CQG.ICQGInstrument)
    On Error Goto NoInstrumentInCollection
    Dim instrum As CQGInstrument
    If Instrument.FullName = "F.US.CL05Z" Then
        ' The very next line may throw an exception
        instrum = cel.Instruments("F.US.CL05X")
        ' If we got here - then two instruments are subscribed and it's possible to operate with spread.
        ' Use here instrum and Instrument variables to display spread data.
    End If
    Exit Sub
NoInstrumentInCollection:
    ' There's no instrument "F.US.CL05X" in cel.Instruments collection
End Sub
Private Sub cel_IncorrectSymbol(ByVal Symbl As String)
    ' Incorrect symbol (Symbl) is passed to NewInstrument function
End Sub
private void cel_InstrumentSubscribed(string Symbl, CQGInstrument Instrument)
{
    CQGInstrument instrum ;
    if( Instrument.FullName == "F.US.CL05Z" )
    {
        try
        {
           instrum = cel.Instruments["F.US.CL05X"] ;
           // If we got here - then two instruments are subscribed and it's possible to operate with spread.
           // Use here instrum and Instrument variables to display spread data
        }
        catch( COMException )
        {
           // There's no instrument "F.US.CL05X" in cel.Instruments collection
           return ;
        }
    }
}

private void cel_IncorrectSymbol(string Symbl)
{
    // Incorrect symbol (Symbl) is passed to NewInstrument function
}

See Also

CQGCEL Interface | CQGCEL Members | CQGInstruments Collection | CQGInstrument Interface


%%PageItemTitle%%

InternalOrders Property
CQGCEL Interface : InternalOrders Property

Glossary Item Box

Description

Returns the collection of orders placed for all accounts from within this CQG API instance.

Property type

Read-only property

Syntax

Visual Basic
Public Property InternalOrders As CQGOrders

Return Type

CQGOrders collection containing the internal orders of all accounts.

Remarks

An order is added to this collection when it is placed from within current CQG API instance, regardless of the account.

This collection is a subset of Orders collection.

See the Remarks section of Orders Property for details on collection orders removal and manual addition.

Example

See the usage of CQGCEL properties in the PrepareModify method's example section.

See Also

CQGCEL Interface | CQGCEL Members | CQGOrder Interface | CQGOrders Collection | CQGCEL.OrderChanged Event | CQGOrdersQuery Interface


%%PageItemTitle%%

IsStarted Property
CQGCEL Interface : IsStarted Property

Glossary Item Box

Description

This property returns the current status of CQGCEL startup process.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsStarted As Boolean

Return Type

True if CQGCEL is started, False otherwise

Remarks

This property allows to find out if CELStarted Event is already fired.

Example

The property using Copy Code
If Not ThisWorkbook.CEL.IsStarted Then
    Exit Sub
End If

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

Logger Property
CQGCEL Interface : Logger Property

Glossary Item Box

Description

Returns the Logger object of CQGCEL.

Property type

Read-only property

Syntax

Visual Basic
Public Property Logger As CQGLogger

Return Type

CQGLogger object that allows logging operations

Example

See an example of the CQGLogger usage in CQGCEL Example

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

Orders Property
CQGCEL Interface : Orders Property

Glossary Item Box

Description

Returns the collection of all accounts orders available from current CQG API session.

Property type

Read-only property

Syntax

Visual Basic
Public Property Orders As CQGOrders

Return Type

CQGOrders collection containing all available orders of all accounts of current logged on CQG user.

Remarks

Order functionality becomes available if the AccountSubscriptionLevel property of CQGCEL is set to aslAccountUpdatesAndOrders.

An order is included in the collection in the following cases:

  • it is placed from current CQG API instance
  • it is/was placed for current account from any other source (including other CQG API instances). In this case an order is added only if its status is changed during current CQG API session.

An order which is placed from within current CQG API instance is called internal.

An order which is placed outside of current CQG API instance is called historical or external.

An order for which OrderChanged events are being fired are called active.

User can manually add orders to the collection using AddToLiveOrders method of CQGOrders collection. Usually it is done for collections obtained via QueryOrders calls.

Orders are removed from the collection in following cases:

  • Orders in the final state (i.e. filled, rejected, cancelled etc.) are removed from the collection after 48 hrs. An OrderChanged event is fired before the removal.
  • Orders that were timed out are removed immediately after corresponding OrderChanged event is fired.

Example

See the usage of CQGCEL properties in the PrepareModify method's example section.

See Also

CQGCEL Interface | CQGCEL Members | CQGOrders Collection | CQGOrder Interface | CQGOrdersQuery Interface | CQGCEL.OrderChanged Event | CQGCEL.InternalOrders Property


%%PageItemTitle%%

OTPRequired Property
CQGCEL Interface : OTPRequired Property

Glossary Item Box

Description

Returns whether the Gateway requires a one-time password or not.

Property type

Read-only property

Syntax

Visual Basic
Public Property OTPRequired As Boolean

Return Type

True, if one-time password is required; False, otherwise

Remarks

This property is updated only when the Gateway connection status is changed.

See Also

CQGCEL Interface | CQGCEL Members | CQGCEL.GWConnectionStatusChanged Event | CQGCEL.GWOTPLogon Method


%%PageItemTitle%%

AccountChanged Event
change_type
Account change type which allows to differentiate the occurred changes
cqg_account

A CQGAccount object representing the account to which the current change refers.

If the change type is actAccountsReloaded this parameter will be either Nothing or a not valid instance of CQGAccount. See Invalid Object for details.

cqg_position

A CQGPosition object representing the position to which the current change refers.

If the change type is actAccountsReloaded, actAccountChanged or actPositionsReloaded this parameter will be either Nothing or a not valid instance of CQGPosition. See Invalid Object for details.

CQGCEL Interface : AccountChanged Event

Glossary Item Box

Description

This event is fired when the account or position information is changed.

Syntax

Visual Basic
Public Event AccountChanged( _
   ByVal change_type As eAccountChangeType, _
   ByVal cqg_account As CQGAccount, _
   ByVal cqg_position As CQGPosition _
)

Parameters

change_type
Value Description
actAccountChanged

An account-specific change occurred, e.g. date of last statement is changed.

After an event of this type, another AccountChange event of actPositionsReloaded type will be fired.

An event of this type is also fired for each account if the account subscription level is set from aslAccountsOnly to aslAccountsAndUpdates.

actAccountsReloaded

All accounts are reloaded.

This change type is passed in two cases:

  • when the user logs on to CQG Gateway from CQGIC
  • when the user programmatically switches initial account subscription level to aslNone and then back.
actPositionAdded A new position is created.

For example, due to trading new instruments.

actPositionChanged A position-specific change occurred, e.g. position quantity or price is changed.

The number of fired events of this type depends on the FireEventOnChangedPrices configuration setting.

See the FireEventsOnChangedPrices configuration setting for possible options of controlling the flow of position changed events.

actPositionsReloaded
  • All positions of an account are reloaded.

    There are many cases when this change type is passed. For example:

    • when we change position subscription level from pslNoPositions to any other value
    • when an account-specific change occurs for the current account
    • when CQG Gateway environment change occurs, etc.
actTradersReloaded

Authorized traders of accounts are reloaded.

Account change type which allows to differentiate the occurred changes
cqg_account

A CQGAccount object representing the account to which the current change refers.

If the change type is actAccountsReloaded this parameter will be either Nothing or a not valid instance of CQGAccount. See Invalid Object for details.

cqg_position

A CQGPosition object representing the position to which the current change refers.

If the change type is actAccountsReloaded, actAccountChanged or actPositionsReloaded this parameter will be either Nothing or a not valid instance of CQGPosition. See Invalid Object for details.

Remarks

If account subscription level is set to aslNone no AccountChanged event will be fired.

For account-specific changes:

If account subscription level is set to aslAccountsOnly only one AccountChanged event will be fired, and that upon the subscription level change.

If account subscription level is set to aslAccountsAndUpdates, an AccountChanged event will be fired on each change.

AccountChanged event firing for position-specific changes is controlled on account level and can be configured for each account separately.

Note: if a currency rate is changed obviously it will lead to re-calculations of account summaries. However in this situation only CurrencyRatesChanged event will be fired. The corresponding account changes will be available upon access to account summaries.

Example

The examples below show how to track accounts and positions changes via CQG API.

VB
C#
Option Explicit
Private WithEvents cel As CQGCEL
Private ReadyFlagExists As Boolean

' Called when workbook is opened
Private Sub Workbook_Open()
    ' Create CQG API instance
    Set cel = New CQGCEL

    ' Configure it
    cel.APIConfiguration.CollectionsThrowException = False
    cel.APIConfiguration.DefPositionSubscriptionLevel = pslSnapshotAndUpdates
    cel.APIConfiguration.NewInstrumentChangeMode = True
    cel.APIConfiguration.PositionDetailing = pdAllTrades
    cel.APIConfiguration.PriceMode = pmTradesOnly
    cel.APIConfiguration.UseOrderSide = False

    cel.Startup

    'Check if ready flag exists in excel
    Dim ExcelMajorVersion As Integer
    ExcelMajorVersion = CInt(Left$(Application.Version, InStr(Application.Version, ".") - 1))

    If ExcelMajorVersion > 9 Then ' Excel 2002 and higher
        ReadyFlagExists = True
    Else
        ReadyFlagExists = False
    End If
End Sub

' Called before workbook is going to be closed
Private Sub Workbook_BeforeClose(Cancel As Boolean)
    cel.Shutdown
    Set cel = Nothing
End Sub

' CQG API event handlers
Private Sub cel_AccountChanged(ByVal change As CQG.eAccountChangeType, ByVal Account As CQG.ICQGAccount, ByVal position As CQG.ICQGPosition)

    Dim trade As CQGTrade

    ' Account/Position is changed
    Select Case change
        Case actAccountsReloaded
            Dim acc As CQGAccount
            For Each acc In cel.Accounts
                ' Print balance of all
                If cel.IsValid(acc.Summary.Balance) Then
                    Debug.Print "Account yesterday balance is " & acc.Summary.Balance(1)
                End If
                ' We need all open poisition instruments to be autosubscribed
                acc.AutoSubscribeInstruments = True
            Next acc

        Case actPositionAdded
                Debug.Print "New position on " & position.InstrumentName & " is added."
                Debug.Print "Account Positions number is " & Account.Positions.Count

        Case actPositionChanged
            If Not position.Instrument Is Nothing Then

                If (position.Instrument.InstrumentType And itAllOptions) = 0 Then
                    If cel.IsValid(position.OTE) Then
                        Debug.Print "Position OTE is " & position.OTE
                    End If
                Else
                    If cel.IsValid(position.MVO) Then
                        Debug.Print "Position MVO is " & position.MVO
                    End If
                End If

                Debug.Print "Number of open trades on " & position.Instrument.FullName & " is " & position.OpenTrades.Count
                For Each trade In position.OpenTrades
                    Debug.Print "Open Trade quantity is " & trade.Quantity
                Next

            End If
        Case Else
            ' Not processed
    End Select
End Sub

Private Sub cel_CELStarted()
    ' Everything is OK with enablements
    Debug.Print "CEL Version : " + cel.Environment.CELVersion
End Sub

Private Sub cel_GWConnectionStatusChanged(ByVal newStatus As CQG.eConnectionStatus)
    Dim status As String
    Select Case newStatus
        Case csConnectionDelayed
            status = "Delayed"
        Case csConnectionDown
            status = "Down"
        Case csConnectionUp
            status = "Up"
            ' Request accounts update functionality
            cel.AccountSubscriptionLevel = aslAccountsAndUpdates
        Case Else
            status = "Unknown"
    End Select

    Debug.Print "GW Connection Status changed to " + status
End Sub

Private Sub cel_InstrumentSubscribed(ByVal symbl As String, ByVal Instrument As CQG.ICQGInstrument)
    Debug.Print "There is a position on " + Instrument.FullName + ". Now the instrument is subscribed"
End Sub

Private Sub cel_IsReady(readyStatus As CQG.eReadyStatus)
    If ReadyFlagExists Then ' Excel 2002 and higher
        ' ready status should reflect Application.Ready value
        readyStatus = IIf(Application.Ready, rsReady, rsNotReady)
    Else
        readyStatus = rsReady
    End If
End Sub

Private Sub cel_DataError(ByVal obj As Object, ByVal errorDescription As String)
    ' Some error occurred

    MsgBox errorDescription

    ' Terminate application
    Close
End Sub
using System;
using System.Runtime.InteropServices;
using CQG;

namespace Sample
{
    class APIConfigSample : IDisposable
    {
        // CQGCEL instance declaration.
        private CQGCEL cel = new CQGCELClass();

        // Used to determine is the object manualy disposed.
        private bool disposed = false;

        public APIConfigSample()
        {
            // Initialize CQGCEL instance.
            try
            {
                // Configure CEL.
                cel.APIConfiguration.ReadyStatusCheck = eReadyStatusCheck.rscOff;
                cel.APIConfiguration.CollectionsThrowException = false;
                cel.APIConfiguration.DefPositionSubscriptionLevel = ePositionSubscriptionLevel.pslSnapshotAndUpdates;
                cel.APIConfiguration.NewInstrumentChangeMode = true;
                cel.APIConfiguration.PositionDetailing = ePositionDetailing.pdAllTrades;
                cel.APIConfiguration.PriceMode = ePriceMode.pmTradesOnly;
                cel.APIConfiguration.UseOrderSide = false;

                // Register to CEL's events.
                cel.CELStarted += new _ICQGCELEvents_CELStartedEventHandler(cel_CELStarted);
                cel.DataError += new _ICQGCELEvents_DataErrorEventHandler(cel_DataError);
                cel.GWConnectionStatusChanged += new _ICQGCELEvents_GWConnectionStatusChangedEventHandler(cel_GWConnectionStatusChanged);
                cel.InstrumentSubscribed += new _ICQGCELEvents_InstrumentSubscribedEventHandler(cel_InstrumentSubscribed);
                cel.AccountChanged += new _ICQGCELEvents_AccountChangedEventHandler(cel_AccountChanged);

                cel.Startup();
             }
             catch( COMException ex )
             {
                Console.WriteLine( "Error occurred during CEL initialization. {0}", ex.Message );
             }
        }

        ~APIConfigSample()
        {
            Dispose(false);
        }

        #region CEL Event Handlers

        void cel_CELStarted()
        {
            // Everything is OK with enablements.
            Console.WriteLine("CEL Version : {0}", cel.Environment.CELVersion);
        }

        void cel_DataError(object obj, string errorDescription)
        {
            // Some error occurred.
            cel.Logger.Log("ERROR : " + errorDescription, eLogSeverity.lsError);

            // Terminate application.
            System.Windows.Forms.Application.Exit();
        }

        void cel_GWConnectionStatusChanged(eConnectionStatus newStatus)
        {
            string status;
            switch (newStatus)
            {
                case eConnectionStatus.csConnectionDelayed:
                    status = "Delayed";

                    break;
                case eConnectionStatus.csConnectionDown:
                    status = "Down";

                    break;
                case eConnectionStatus.csConnectionUp:
                    status = "Up";

                    // Request accounts update functionality.
                    cel.AccountSubscriptionLevel = eAccountSubscriptionLevel.aslAccountsAndUpdates;

                    break;
                default:
                    status = "Unknown";

                    break;
            }

            Console.WriteLine("GW Connection Status changed to " + status);
        }

        void cel_InstrumentSubscribed(string symbl, CQGInstrument Instrument)
        {
            Console.WriteLine("There is a position on " + Instrument.FullName + ". Now the instrument is subscribed.");
        }

        private void cel_AccountChanged(eAccountChangeType change, CQGAccount Account, CQGPosition position)
        {
            // Account/Position is changed.
            switch (change)
            {
                case eAccountChangeType.actAccountsReloaded :
                    foreach (ICQGAccount acc in cel.Accounts)
                    {
                        // Print balance of all.
                        if (cel.IsValid(acc.Summary.Balance(1)))
                        {
                            Console.WriteLine("Account Balance is : {0}", acc.Summary.Balance(1));
                            Console.WriteLine("Account Positions number is : {0}", acc.Positions.Count);
                        }

                        // We need all open poisition instruments to be auto subscribed.
                        acc.AutoSubscribeInstruments = true;
                    }

                    break;
                case eAccountChangeType.actPositionAdded :
                    Console.WriteLine(position.Instrument.FullName);

                    break;
                case eAccountChangeType.actPositionChanged :
                    if (position.Instrument != null)
                    {
                        if ((position.Instrument.InstrumentType & eInstrumentType.itAllOptions) == 0)
                        {
                            if (cel.IsValid(position.OTE))
                            {
                                Console.WriteLine("Position OTE is : {0}", position.OTE);
                            }
                        }
                        else
                        {
                            if (cel.IsValid(position.MVO))
                            {
                                Console.WriteLine("Position MVO is : {0}", position.MVO);
                            }
                        }

                        Console.WriteLine("Number of open trades on {0} is {1}.", position.Instrument.FullName, position.OpenTrades.Count);
                        foreach (CQGTrade trade in position.OpenTrades)
                        {
                            Console.WriteLine("Open Trade quantity is : {0}", trade.Quantity);
                        }
                    }

                    break;
                default :
                    // Not processed.

                    break;
            }
        }
        #endregion

        #region IDisposable Members

        public void Dispose()
        {
            Dispose(true);

            GC.SuppressFinalize(this);
        }

        #endregion

        #region Private Methods

        private void Dispose(bool disposing)
        {
            // Check to see if Dispose has already been called.
            if (!this.disposed)
            {
                // If disposing equals true, dispose all managed
                // and unmanaged resources.
                if (disposing)
                {
                    // Dispose managed resources.
                }

                // If disposing is false,
                // only the following code is executed.
                cel.Shutdown();
            }
            disposed = true;
        }

        #endregion

        [STAThread]
        static void Main(string[] args)
        {
            APIConfigSample test = new APIConfigSample();

            // Start Application. Will work until some error occurred.
            System.Windows.Forms.Application.Run();
        }
    }
}

See Also

CQGCEL Interface | CQGCEL Members | CQGAccount Interface | CQGPosition Interface | CQGCEL.AccountSubscriptionLevel Property | CQGCEL.PositionSubcriptionLevel Property


%%PageItemTitle%%

AdvancedStudyAdded Event
cqg_advanced_study
Reference to added advanced study
CQGCEL Interface : AdvancedStudyAdded Event

Glossary Item Box

Description

Fired when CQGCurves item is added to the end of CQGAdvancedStudy

Syntax

Visual Basic
Public Event AdvancedStudyAdded( _
   ByVal cqg_advanced_study As CQGAdvancedStudy _
)

Parameters

cqg_advanced_study
Reference to added advanced study

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

AdvancedStudyDefinitionsResolved Event
cqg_advanced_study_definitions
Collection of advanced study definitions
cqg_error
Object describing last error occurred during the request processing
CQGCEL Interface : AdvancedStudyDefinitionsResolved Event

Glossary Item Box

Description

Fired when the definitions of advanced studies are resolved

Syntax

Visual Basic
Public Event AdvancedStudyDefinitionsResolved( _
   ByVal cqg_advanced_study_definitions As CQGAdvancedStudyDefinitions, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_advanced_study_definitions
Collection of advanced study definitions
cqg_error
Object describing last error occurred during the request processing

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

AdvancedStudyInserted Event
cqg_advanced_study
Reference to inserted advanced study
index_
Specifies the updated curve index
CQGCEL Interface : AdvancedStudyInserted Event

Glossary Item Box

Description

Fired when CQGCurves item is inserted

Syntax

Visual Basic
Public Event AdvancedStudyInserted( _
   ByVal cqg_advanced_study As CQGAdvancedStudy, _
   ByVal index_ As Long _
)

Parameters

cqg_advanced_study
Reference to inserted advanced study
index_
Specifies the updated curve index

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

AdvancedStudyRemoved Event
cqg_advanced_study
Reference to removed advanced study
index_
Specifies the removed curve index
CQGCEL Interface : AdvancedStudyRemoved Event

Glossary Item Box

Description

Fired when CQGCurves item is removed

Syntax

Visual Basic
Public Event AdvancedStudyRemoved( _
   ByVal cqg_advanced_study As CQGAdvancedStudy, _
   ByVal index_ As Long _
)

Parameters

cqg_advanced_study
Reference to removed advanced study
index_
Specifies the removed curve index

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

AdvancedStudyResolved Event
cqg_advanced_study
Reference to resolved advanced study
cqg_error
Object describing last error occurred during processing advanced study request
CQGCEL Interface : AdvancedStudyResolved Event

Glossary Item Box

Description

Fired when the advanced study (CQGAdvancedStudy) is resolved

Syntax

Visual Basic
Public Event AdvancedStudyResolved( _
   ByVal cqg_advanced_study As CQGAdvancedStudy, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_advanced_study
Reference to resolved advanced study
cqg_error
Object describing last error occurred during processing advanced study request

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

AdvancedStudyUpdated Event
cqg_advanced_study
Reference to changed advanced study
index_
Specifies the updated curve index
CQGCEL Interface : AdvancedStudyUpdated Event

Glossary Item Box

Description

Fired when CQGCurves item is updated

Syntax

Visual Basic
Public Event AdvancedStudyUpdated( _
   ByVal cqg_advanced_study As CQGAdvancedStudy, _
   ByVal index_ As Long _
)

Parameters

cqg_advanced_study
Reference to changed advanced study
index_
Specifies the updated curve index

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

AlgorithmicOrderPlaced Event
guid_
GUID of the algorithmic order type
main_params
CQGAlgorithmicOrderParameters object, representing main parameters of the placing order.
custom_props
CQGAlgorithmicOrderProperties object, representing the order custom parameters.
CQGCEL Interface : AlgorithmicOrderPlaced Event

Glossary Item Box

Description

This event is fired when an algorithmic order is placed from CQGIC.

Syntax

Visual Basic
Public Event AlgorithmicOrderPlaced( _
   ByVal guid_ As String, _
   ByVal main_params As CQGAlgorithmicOrderParameters, _
   ByVal custom_props As CQGAlgorithmicOrderProperties _
)

Parameters

guid_
GUID of the algorithmic order type
main_params
CQGAlgorithmicOrderParameters object, representing main parameters of the placing order.
custom_props
CQGAlgorithmicOrderProperties object, representing the order custom parameters.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

AlgorithmicOrderRegistrationComplete Event
guid_

GUID of the algorithmic order type, the registration status of which is changed

cqg_error

CQGError object describing the last error occurred during the algorithmic order registration.

If no error has occurred, the parameter value is either Nothing or invalid error object depending on the UsedFromATLClient setting of the configuration.

The parameter can be checked for validity via the CQGCEL.IsValid method.

CQGCEL Interface : AlgorithmicOrderRegistrationComplete Event

Glossary Item Box

Description

This event is fired when the algorithmic order registration is completed (suceeded or failed).

Syntax

Visual Basic
Public Event AlgorithmicOrderRegistrationComplete( _
   ByVal guid_ As String, _
   ByVal cqg_error As CQGError _
)

Parameters

guid_

GUID of the algorithmic order type, the registration status of which is changed

cqg_error

CQGError object describing the last error occurred during the algorithmic order registration.

If no error has occurred, the parameter value is either Nothing or invalid error object depending on the UsedFromATLClient setting of the configuration.

The parameter can be checked for validity via the CQGCEL.IsValid method.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

AllOrdersCanceled Event
order_side

Order side filter applied to order cancelation

gw_account_ids

Collection of Gateway account identifiers, whose orders were canceled or empty if all accounts were affected

instrument_names

Collection of instruments in C.CC.NAME format or empty if all instruments were affected

CQGCEL Interface : AllOrdersCanceled Event

Glossary Item Box

Description

This event is fired when all orders are cancelled only from within CQG IC.

Syntax

Visual Basic
Public Event AllOrdersCanceled( _
   ByVal order_side As eOrderSideFilter, _
   ByVal gw_account_ids As CQGIntegerCollection, _
   ByVal instrument_names As CQGStringCollection _
)

Parameters

order_side
Value | Description
osftAll | Both buy and sell orders
osftBuy

Buy orders

osftSell | Sell orders

Order side filter applied to order cancelation

gw_account_ids

Collection of Gateway account identifiers, whose orders were canceled or empty if all accounts were affected

instrument_names

Collection of instruments in C.CC.NAME format or empty if all instruments were affected

Remarks

This event can be used by users as a notification to cancel their Algorithmic Orders.

See Also

CQGCEL Interface | CQGCEL Members | CQGAlgorithmicOrderDefinition Interface


%%PageItemTitle%%

AuthenticationStatusChanged Event
new_status
New authentication status.
cqg_error

CQGError object describing the last error occurred during authentication process. CQGCEL.IsValid(Invalid_Error) returns False.

CQGCEL Interface : AuthenticationStatusChanged Event

Glossary Item Box

Description

Fired when remote API client authentication status is changed

Syntax

Visual Basic
Public Event AuthenticationStatusChanged( _
   ByVal new_status As eSessionStatus, _
   ByVal cqg_error As CQGError _
)

Parameters

new_status
Value | Description
ssAlreadyLoggedIn | User is already logged in
ssAuthorizationFailed | User authorization failed
ssInternalSystemError | Internal error
ssNoAvailableDataServers | There were no available data servers for the client request
ssNoAvailableLoginService | Login service is not available
ssNoAvailableMetadataServers | There were no available metadata servers for the client request
ssNoAvailableROMNumbers | No ROM numbers are available in CQGT client pool for CQGT authentication request to succeed
ssNoRemoteAPIPermission | Client doesn't have enablement to access Remote API
ssNotAuthenticated | User is not authenticated
ssNotEnabled | Client is not enabled
ssSuccess | Successful result
New authentication status.
cqg_error

CQGError object describing the last error occurred during authentication process. CQGCEL.IsValid(Invalid_Error) returns False.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

BarsTimestampsResolved Event
cqg_bars_timestamps

Reference to resolved CQGBarsTimestamps

cqg_error

CQGError object describing the last error occurred during processing the timed bars request or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

CQGCEL Interface : BarsTimestampsResolved Event

Glossary Item Box

Description

This event is fired when the collection of timed bars timestamps (CQGBarsTimestamps) is resolved or when some error has occurred during the timed bars timestamps request processing.

Syntax

Visual Basic
Public Event BarsTimestampsResolved( _
   ByVal cqg_bars_timestamps As CQGBarsTimestamps, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_bars_timestamps

Reference to resolved CQGBarsTimestamps

cqg_error

CQGError object describing the last error occurred during processing the timed bars request or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

CELStarted Event
CQGCEL Interface : CELStarted Event

Glossary Item Box

Description

This event is fired when the CQGCEL object is successfully started up.

Syntax

Visual Basic
Public Event CELStarted()

Remarks

When the user calls the Startup method it returns immediately, without waiting for the results. The reaction is sent via the CELStarted event. After this event is fired the CQG API functionality is available to the user.

You can use the IsStarted Property event to check the CQGCEL status.

If CQGCEL fails to start for some reason a corresponding DataError event will be fired.

Example

See an implementation of the CELStarted event handler in CQGCEL Example.

See Also

CQGCEL Interface | CQGCEL Members | CQCEL. Startup Method | CQGCEL.IsStarted Property


%%PageItemTitle%%

CommodityInstrumentsResolved Event
commodity_name
The commodity symbol that was requested by the user in the corresponding RequestCommodityInstruments method call.
instrument_types
Instrument type bitmask that was set by the user in corresponding RequestCommodityInstruments method call.
cqg_commodity_intruments

A collection, which contains names of instruments corresponding to the requested commodity and filtered by the bitmask set in RequestCommodityInstruments Method.

For example, the returned instrument name for the commodity "EP", will have the following format: "F.EPH7".

CQGCEL Interface : CommodityInstrumentsResolved Event

Glossary Item Box

Description

This event is fired when a previously requested commodity symbol is resolved into the instruments list.

Syntax

Visual Basic
Public Event CommodityInstrumentsResolved( _
   ByVal commodity_name As String, _
   ByVal instrument_types As eInstrumentType, _
   ByVal cqg_commodity_intruments As CQGCommodityInstruments _
)

Parameters

commodity_name
The commodity symbol that was requested by the user in the corresponding RequestCommodityInstruments method call.
instrument_types
Value | Description
itAllInstruments | Represents all instrument types.
itAllOptions | Represents Option Call and Option Put instrument types.
itFuture | Represents Futures instrument type.
itOptionCall | Represents Option Call instrument type.
itOptionPut | Represents Option Put instrument type.
itOther | Represents other (not explicitly listed in the enumeration) instrument types, such as cash, indices, currencies, reports etc.
itStock | Represents Stock instrument type.
itSyntheticStrategy | Represents synthetic strategy instrument type.
itTreasure | Represents Treasury instrument type.
itUndefined | Undefined type.
Instrument type bitmask that was set by the user in corresponding RequestCommodityInstruments method call.
cqg_commodity_intruments

A collection, which contains names of instruments corresponding to the requested commodity and filtered by the bitmask set in RequestCommodityInstruments Method.

For example, the returned instrument name for the commodity "EP", will have the following format: "F.EPH7".

Remarks

If the requested symbol name is invalid the instrumentNames collection will be empty.

Example

The examples below show how to request a symbol list, handle its resolution event, and operate with the received collection.

VB
CS
Const ColNumber = 1
Private Sub CEL_CELStarted()
    ' Request commodity instrument names list after CEL is started up
    ' here we request Futures, Option Call and Option Put instruments
    CEL.RequestCommodityInstruments "DD", itFuture Or itAllOptions
End Sub
Private Sub CEL_CommodityInstrumentsResolved(ByVal commodityName As String, _
                                             ByVal instrumentTypes As eInstrumentType, _
                                             ByVal instrumentNames As CQG.ICQGCommodityInstruments)
   Dim InstrumentName As String
   Dim RowNumber As Integer
   RowNumber = 1
   'iterate through the resolved instrument names collection
   For Each InstrumentName In instrumentNames
        ' Subscribe to each instrument in the collection
        CEL.NewInstrument InstrumentName
        ' print each instrument name on the active sheet
        ActiveSheet.Cells(RowNumber, ColNumber) = InstrumentName
        RowNumber = RowNumber + 1
    Next
End Sub
#region CQG API event handlers

private void cel_CELStarted()
{
    // Request commodity instrument names list after CEL is started up
    // here we request Futures, Option Call and Option Put instruments
    cel.RequestCommodityInstruments( "DD",
        eInstrumentType.itFuture | eInstrumentType.itAllOptions) ;
}

private void cel_CommodityInstrumentsResolved(string commodityName,
                                                                eInstrumentType instrumentTypes,
                                                                    CQGCommodityInstruments instrumentNames)
{
    // Iterate through the resolved instrument names collection
    foreach( string instrumentName in instrumentNames )
    {
        // Subscribe to each instrument in the collection
        cel.NewInstrument( instrumentName ) ;

        // Print each instrument name on the console
        Console.WriteLine( instrumentName ) ;
    }
}

#endregion

See Also

CQGCEL Interface | CQGCEL Members | CQGCEL.RequestCommodityInstruments Method | CQGCommodityInstruments Collection


%%PageItemTitle%%

ConditionAdded Event
cqg_condition

Reference to changed CQGCondition.

CQGCEL Interface : ConditionAdded Event

Glossary Item Box

Description

This event is fired when CQGConditionResult item is added to the end of the CQGCondition.

Syntax

Visual Basic
Public Event ConditionAdded( _
   ByVal cqg_condition As CQGCondition _
)

Parameters

cqg_condition

Reference to changed CQGCondition.

See Also

CQGCEL Interface | CQGCEL Members | CQGCondition Collection | CQGConditionResult Interface


%%PageItemTitle%%

ConditionDefinitionsResolved Event
cqg_condition_definitions

Collection of condition definitions.

If an error occured, the collection is empty.

cqg_error

CQGError object describing last error occurred during the request processing or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

CQGCEL Interface : ConditionDefinitionsResolved Event

Glossary Item Box

Description

This event is fired when condition definitions are resolved or when some error has occurred during the request processing.

Syntax

Visual Basic
Public Event ConditionDefinitionsResolved( _
   ByVal cqg_condition_definitions As CQGConditionDefinitions, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_condition_definitions

Collection of condition definitions.

If an error occured, the collection is empty.

cqg_error

CQGError object describing last error occurred during the request processing or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

See Also

CQGCEL Interface | CQGCEL Members | CQGConditionDefinitions Collection


%%PageItemTitle%%

ConditionInserted Event
cqg_condition

Reference to inserted CQGCondition

index_

Specifies the inserted CQGConditionResult index

CQGCEL Interface : ConditionInserted Event

Glossary Item Box

Description

This event is fired when a CQGConditionResult item is inserted.

Syntax

Visual Basic
Public Event ConditionInserted( _
   ByVal cqg_condition As CQGCondition, _
   ByVal index_ As Long _
)

Parameters

cqg_condition

Reference to inserted CQGCondition

index_

Specifies the inserted CQGConditionResult index

See Also

CQGCEL Interface | CQGCEL Members | CQGConditionResult Interface | CQGCondition Collection


%%PageItemTitle%%

ConditionRemoved Event
cqg_condition

Reference to removed CQGCondition

index_

Specifies the removed CQGConditionResult index

CQGCEL Interface : ConditionRemoved Event

Glossary Item Box

Description

This event is fired when a CQGConditionResult item is removed.

Syntax

Visual Basic
Public Event ConditionRemoved( _
   ByVal cqg_condition As CQGCondition, _
   ByVal index_ As Long _
)

Parameters

cqg_condition

Reference to removed CQGCondition

index_

Specifies the removed CQGConditionResult index

See Also

CQGCEL Interface | CQGCEL Members | CQGConditionResult Interface | CQGCondition Collection


%%PageItemTitle%%

ConditionResolved Event
cqg_condition

Reference to the resolved CQGCondition

cqg_error

CQGError object describing the last error occurred during processing condition request or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

CQGCEL Interface : ConditionResolved Event

Glossary Item Box

Description

This event is fired when the condition (CQGCondition) is resolved or when some error has occurred during the condition request processing.

Syntax

Visual Basic
Public Event ConditionResolved( _
   ByVal cqg_condition As CQGCondition, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_condition

Reference to the resolved CQGCondition

cqg_error

CQGError object describing the last error occurred during processing condition request or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

See Also

CQGCEL Interface | CQGCEL Members | CQGCondition Collection


%%PageItemTitle%%

ConditionUpdated Event
cqg_condition

Reference to changed CQGCondition

index_

Specifies the updated CQGConditionResult index

CQGCEL Interface : ConditionUpdated Event

Glossary Item Box

Description

This event is fired when a CQGConditionResult item is updated.

Syntax

Visual Basic
Public Event ConditionUpdated( _
   ByVal cqg_condition As CQGCondition, _
   ByVal index_ As Long _
)

Parameters

cqg_condition

Reference to changed CQGCondition

index_

Specifies the updated CQGConditionResult index

See Also

CQGCEL Interface | CQGCEL Members | CQGCondition Collection | CQGConditionResult Interface


%%PageItemTitle%%

ConstantVolumeBarsAdded Event
cqg_constant_volume_bars

Reference to added CQGConstantVolumeBars.

CQGCEL Interface : ConstantVolumeBarsAdded Event

Glossary Item Box

Description

This event is fired when a CQGConstantVolumeBar item is added to the end of CQGConstantVolumeBars.

Syntax

Visual Basic
Public Event ConstantVolumeBarsAdded( _
   ByVal cqg_constant_volume_bars As CQGConstantVolumeBars _
)

Parameters

cqg_constant_volume_bars

Reference to added CQGConstantVolumeBars.

See Also

CQGCEL Interface | CQGCEL Members | CQGConstantVolumeBar Interface | CQGConstantVolumeBars Collection


%%PageItemTitle%%

ConstantVolumeBarsInserted Event
cqg_constant_volume_bars

Reference to the CQGConstantVolumeBars collection the constant volume bar is inserted to

index_

Specifies the inserted CQGConstantVolumeBar's index

CQGCEL Interface : ConstantVolumeBarsInserted Event

Glossary Item Box

Description

This event is fired when a CQGConstantVolumeBar item is inserted to the CQGConstantVolumeBars collection.

Syntax

Visual Basic
Public Event ConstantVolumeBarsInserted( _
   ByVal cqg_constant_volume_bars As CQGConstantVolumeBars, _
   ByVal index_ As Long _
)

Parameters

cqg_constant_volume_bars

Reference to the CQGConstantVolumeBars collection the constant volume bar is inserted to

index_

Specifies the inserted CQGConstantVolumeBar's index

See Also

CQGCEL Interface | CQGCEL Members | CQGConstantVolumeBars Collection | CQGConstantVolumeBar Interface


%%PageItemTitle%%

ConstantVolumeBarsRemoved Event
cqg_constant_volume_bars

Reference to the CQGConstantVolumeBars collection the constant volume bar is removed from

index_

Specifies the removed CQGConstantVolumeBar's index

CQGCEL Interface : ConstantVolumeBarsRemoved Event

Glossary Item Box

Description

This event is fired when a CQGConstantVolumeBar item is removed from the CQGConstantVolumeBars collection.

Syntax

Visual Basic
Public Event ConstantVolumeBarsRemoved( _
   ByVal cqg_constant_volume_bars As CQGConstantVolumeBars, _
   ByVal index_ As Long _
)

Parameters

cqg_constant_volume_bars

Reference to the CQGConstantVolumeBars collection the constant volume bar is removed from

index_

Specifies the removed CQGConstantVolumeBar's index

See Also

CQGCEL Interface | CQGCEL Members | CQGConstantVolumeBar Interface | CQGConstantVolumeBars Collection


%%PageItemTitle%%

ConstantVolumeBarsResolved Event
cqg_constant_volume_bars

Reference to resolved CQGConstantVolumeBars

cqg_error
CQGError object describing last error occurred during processing constant volume bars request
or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

CQGCEL Interface : ConstantVolumeBarsResolved Event

Glossary Item Box

Description

This event is fired when the collection of constant volume bars (CQGConstantVolumeBars) is resolved or when some error has occurred during the constant volume bars request processing.

Syntax

Visual Basic
Public Event ConstantVolumeBarsResolved( _
   ByVal cqg_constant_volume_bars As CQGConstantVolumeBars, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_constant_volume_bars

Reference to resolved CQGConstantVolumeBars

cqg_error
CQGError object describing last error occurred during processing constant volume bars request
or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

See Also

CQGCEL Interface | CQGCEL Members | CQGConstantVolumeBars Collection


%%PageItemTitle%%

ConstantVolumeBarsUpdated Event
cqg_constant_volume_bars

Reference to changed CQGConstantVolumeBars

index_

Specifies the updated CQGConstantVolumeBar index

CQGCEL Interface : ConstantVolumeBarsUpdated Event

Glossary Item Box

Description

This event is fired when the CQGConstantVolumeBar item is updated.

Syntax

Visual Basic
Public Event ConstantVolumeBarsUpdated( _
   ByVal cqg_constant_volume_bars As CQGConstantVolumeBars, _
   ByVal index_ As Long _
)

Parameters

cqg_constant_volume_bars

Reference to changed CQGConstantVolumeBars

index_

Specifies the updated CQGConstantVolumeBar index

See Also

CQGCEL Interface | CQGCEL Members | CQGConstantVolumeBar Interface | CQGConstantVolumeBars Collection


%%PageItemTitle%%

CurrencyRatesChanged Event
cqg_currency_rates
Collection of changed currency rates represented as CQGCurrencyRates.
CQGCEL Interface : CurrencyRatesChanged Event

Glossary Item Box

Description

This event is fired when an FCM changes a currency rate.

Syntax

Visual Basic
Public Event CurrencyRatesChanged( _
   ByVal cqg_currency_rates As CQGCurrencyRates _
)

Parameters

cqg_currency_rates
Collection of changed currency rates represented as CQGCurrencyRates.

Remarks

No CurrencyRatesChanged event is fired if account subscription level is set to aslNone.

Note: if currency rate is changed, account summaries will be recalculated. However no AccountChanged event will be fired in that case.

Example

The following example shows the usage of currency rates via CQG API.

VB
CS
Private Sub CEL_CurrencyRatesChanged(ByVal CurrencyRates As CQGCurrencyRates)
    Dim rate As CQGCurrencyRate
    For Each rate In CurrencyRates
        Debug.Print rate.rate & " rate was declared by FCM #" & rate.fcmID & " for " & rate.CurrencyName & " and " & rate.BaseCurrencyName & " currencies."
    Next
End Sub
void cel_CurrencyRatesChanged(CQGCurrencyRates CurrencyRates)
{
    foreach (CQGCurrencyRate rate in CurrencyRates)
    {
        Console.WriteLine("{0} rate was declared by FCM #{1} for {2} and {3} currencies.", rate.Rate, rate.fcmID, rate.CurrencyName, rate.BaseCurrencyName);
    }
}

See Also

CQGCEL Interface | CQGCEL Members | CQGCurrencyRate Interface | CQGCurrencyRates Collection


%%PageItemTitle%%

CustomSessionsResolved Event
cqg_sessions_collection

Collection of resolved custom sessions.

If an error has occurred, the collection will be empty.

cqg_error

CQGError object representing the error occurred during the custom sessions request.

If no error has occurred, the parameter value is either Nothing or invalid error object depending on the UsedFromATLClient setting of the configuration.

The parameter can be checked for validity via the CQGCEL.IsValid method.

CQGCEL Interface : CustomSessionsResolved Event

Glossary Item Box

Description

This event is fired as a response to a custom sessions request either when the collection is resolved or when an error has occurred during the request processing.

Syntax

Visual Basic
Public Event CustomSessionsResolved( _
   ByVal cqg_sessions_collection As CQGSessionsCollection, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_sessions_collection

Collection of resolved custom sessions.

If an error has occurred, the collection will be empty.

cqg_error

CQGError object representing the error occurred during the custom sessions request.

If no error has occurred, the parameter value is either Nothing or invalid error object depending on the UsedFromATLClient setting of the configuration.

The parameter can be checked for validity via the CQGCEL.IsValid method.

Remarks

For more information about custom sessions see this article in CQG Charting User Guide.

Example

The examples below show how to request custom sessions via CQG API.

VB
C#
Option Explicit
Private WithEvents CEL As CQGCEL
Private Sub Form_Load()
    ' Initialize CQGCEL instance.
    On Error Goto errHndl
    Set CEL = New CQGCEL
    CEL.APIConfiguration.CollectionsThrowException = False
    ' Disable application readiness checking
    CEL.APIConfiguration.ReadyStatusCheck = rscOff
    CEL.Startup
    Exit Sub
errHndl:
    MsgBox "Error occurred during CEL initialization. " & Err.Description
End Sub
Private Sub Form_Unload(Cancel As Integer)
    On Error Goto errHndl
    CEL.Shutdown
    Exit Sub
errHndl:
    MsgBox "Error occurred during CEL initialization. " & Err.Description
End Sub
' Event is fired when the CQGCEL object is successfully started up
Private Sub CEL_CELStarted()
    Debug.Print "CEL Version : " & CEL.Environment.CELVersion
End Sub
' Event is fired when error occures in CQGCEL execution
Private Sub cel_DataError(ByVal obj As Object, ByVal errorDescription As String)
    ' Print the error description
    Debug.Print "Data Error : " & errorDescription
End Sub
' Event is fired when some changes occurred in the connection
' with the CQG data server
Private Sub CEL_DataConnectionStatusChanged(ByVal newStatus As CQG.eConnectionStatus)
    Dim status As String
    Select Case newStatus
        Case csConnectionDelayed
            status = "Delayed"
        Case csConnectionDown
            status = "Down"
        Case csConnectionUp
            status = "Up"
    End Select
    Debug.Print "Data Connection Status changed to " & status
    If newStatus = csConnectionUp Then
        RequestCustomSessions
    End If
End Sub
' This function requests all available custom sessions
Private Sub RequestCustomSessions()
    Debug.Print "Requesting custom sessions"
    CEL.RequestCustomSessions
End Sub
' Event is fired when requested sessions collection is resolved
' or an error has occurred during the request processing
Private Sub CEL_CustomSessionsResolved(ByVal sessionsCollection As CQG.ICQGSessionsCollection, ByVal cqgErr As CQG.ICQGError)
    Dim ss As CQGSessions
    Dim s As CQGSession
    Debug.Print "Custom sessions resolved"
    If Not cqgErr Is Nothing Then
        Debug.Print "Error occured during custom sessions request : " & cqgErr.Description
        Exit Sub
    End If
    ' Print requested sessions data
    For Each ss In sessionsCollection
        Debug.Print "Sessions name : " & ss.Name & ", type : " & ss.Type
        For Each s In ss
            Debug.Print vbTab & "Session name : " & s.Name
            Debug.Print vbTab & "Session time range : " & s.StartTime & " - " & s.EndTime
            Debug.Print vbTab & "Working days :"
            If ((s.WorkingWeekDays And eSessionWeekDays.swdSunday) = eSessionWeekDays.swdSunday) Then
                Debug.Print String(2, vbTab) & "Sunday"
            End If
            If ((s.WorkingWeekDays And eSessionWeekDays.swdMonday) = eSessionWeekDays.swdMonday) Then
                Debug.Print String(2, vbTab) & "Monday"
            End If
            If ((s.WorkingWeekDays And eSessionWeekDays.swdTuesday) = eSessionWeekDays.swdTuesday) Then
                Debug.Print String(2, vbTab) & "Tuesday"
            End If
            If ((s.WorkingWeekDays And eSessionWeekDays.swdWednesday) = eSessionWeekDays.swdWednesday) Then
                Debug.Print String(2, vbTab) & "Wednesday"
            End If
            If ((s.WorkingWeekDays And eSessionWeekDays.swdThursday) = eSessionWeekDays.swdThursday) Then
                Debug.Print String(2, vbTab) & "Thursday"
            End If
            If ((s.WorkingWeekDays And eSessionWeekDays.swdFriday) = eSessionWeekDays.swdFriday) Then
                Debug.Print String(2, vbTab) & "Friday"
            End If
            If ((s.WorkingWeekDays And eSessionWeekDays.swdSaturday) = eSessionWeekDays.swdSaturday) Then
                Debug.Print String(2, vbTab) & "Saturday"
            End If
        Next
    Next
End Sub
using System;
using System.Runtime.InteropServices;
using CQG;

namespace Samples
{
    class CustomSessions : IDisposable
    {
        // CQGCEL instance declaration
        private CQGCEL cel = new CQGCELClass();

        // Used to determine is the object manualy disposed
        private bool disposed = false;

        public CustomSessions()
        {
            // Initialize CQGCEL instance
            try
            {
                // Configure CEL
                cel.APIConfiguration.ReadyStatusCheck = eReadyStatusCheck.rscOff;
                cel.APIConfiguration.CollectionsThrowException = false;

                // Register to CEL's events
                cel.CELStarted += new _ICQGCELEvents_CELStartedEventHandler(cel_CELStarted);
                cel.DataError += new _ICQGCELEvents_DataErrorEventHandler(cel_DataError);
                cel.DataConnectionStatusChanged += new _ICQGCELEvents_DataConnectionStatusChangedEventHandler(cel_DataConnectionStatusChanged);
                cel.CustomSessionsResolved += new _ICQGCELEvents_CustomSessionsResolvedEventHandler(cel_CustomSessionsResolved);

                cel.Startup();
            }
            catch (COMException ex)
            {
                Console.WriteLine( "Error occurred during CEL initialization. {0}", ex.Message );
            }
        }

        ~CustomSessions()
        {
            Dispose(false);
        }

        #region CEL Event Handlers

        // Event is fired when the CQGCEL object is successfully started up
        void cel_CELStarted()
        {
            Console.WriteLine("CEL Version : {0}", cel.Environment.CELVersion);
        }

        // Event is fired when error occures in CQGCEL execution
        void cel_DataError(object obj, string errorDescription)
        {
            // Some error occurred
            Console.WriteLine("Data Error : " + errorDescription);
        }

        // Event is fired when some changes occurred in the connection
        // with the CQG data server
        void cel_DataConnectionStatusChanged(eConnectionStatus newStatus)
        {
            string status;
            switch (newStatus)
            {
                case eConnectionStatus.csConnectionDelayed:
                    status = "Delayed";
                    break;

                case eConnectionStatus.csConnectionDown:
                    status = "Down";
                    break;

                case eConnectionStatus.csConnectionUp:
                    status = "Up";
                    break;

                default:
                    status = "Unknown";
                    break;
            }
            Console.WriteLine("Data Connection Status changed to " + status);

            if (newStatus == eConnectionStatus.csConnectionUp)
            {
                RequestCustomSessions();
            }
        }

        // This function requests all available custom sessions
        void RequestCustomSessions()
        {
            Console.WriteLine("Requesting custom sessions");
            cel.RequestCustomSessions();
        }

        // Event is fired when requested sessions collection is resolved
        // or an error has occurred during the request processing
        void cel_CustomSessionsResolved(CQGSessionsCollection sessionsCollection, CQGError err)
        {
            if (err != null)
            {
                Console.WriteLine("Error occured during custom sessions request : {0}", err.Description);
                return;
            }

            // Print requested sessions data
            foreach (CQGSessions ss in sessionsCollection)
            {
                Console.WriteLine("Sessions name : {0}, type : {1}", ss.Name, ss.Type);

                foreach (CQGSession s in ss)
                {
                    Console.WriteLine("\t Session name : {0}", s.Name);
                    Console.WriteLine("\t Session time range : {0} - {1}", s.StartTime, s.EndTime);
                    Console.WriteLine("\t Working days :");

                    if ((s.WorkingWeekDays & eSessionWeekDays.swdSunday) == eSessionWeekDays.swdSunday)
                    {
                        Console.WriteLine("\t\t Sunday");
                    }
                    if ((s.WorkingWeekDays & eSessionWeekDays.swdMonday) == eSessionWeekDays.swdMonday)
                    {
                        Console.WriteLine("\t\t Monday");
                    }
                    if ((s.WorkingWeekDays & eSessionWeekDays.swdTuesday) == eSessionWeekDays.swdTuesday)
                    {
                        Console.WriteLine("\t\t Tuesday");
                    }
                    if ((s.WorkingWeekDays & eSessionWeekDays.swdWednesday) == eSessionWeekDays.swdWednesday)
                    {
                        Console.WriteLine("\t\t Wednesday");
                    }
                    if ((s.WorkingWeekDays & eSessionWeekDays.swdThursday) == eSessionWeekDays.swdThursday)
                    {
                        Console.WriteLine("\t\t Thursday");
                    }
                    if ((s.WorkingWeekDays & eSessionWeekDays.swdFriday) == eSessionWeekDays.swdFriday)
                    {
                        Console.WriteLine("\t\t Friday");
                    }
                    if ((s.WorkingWeekDays & eSessionWeekDays.swdSaturday) == eSessionWeekDays.swdSaturday)
                    {
                        Console.WriteLine("\t\t Saturday");
                    }
                }
            }
        }

        #endregion

        #region IDisposable Members

        public void Dispose()
        {
            Dispose(true);

            GC.SuppressFinalize(this);
        }

        #endregion

        #region Private Methods

        private void Dispose(bool disposing)
        {
            // Check to see if Dispose has already been called
            if (!this.disposed)
            {
                // If disposing equals true, dispose all managed
                // and unmanaged resources
                if (disposing)
                {
                    // Dispose managed resources
                }

                // If disposing is false,
                // only the following code is executed
                try
                {
                    cel.Shutdown();
                }
                catch
                { }
            }
            disposed = true;
        }

        #endregion
    }
}

See Also

CQGCEL Interface | CQGCEL Members | CQGSession Interface | CQGSessions Collection | CQGSessionsCollection Collection | CQGError Interface | CQGCEL.RequestCustomSessions Method | CQGAPIConfig.UsedFromATLClient Property


%%PageItemTitle%%

CustomStudyAdded Event
cqg_custom_study

Reference to the changed CQGCustomStudy.

CQGCEL Interface : CustomStudyAdded Event

Glossary Item Box

Description

This event is fired when a CQGCurves item is added to the end of CQGCustomStudy.

Syntax

Visual Basic
Public Event CustomStudyAdded( _
   ByVal cqg_custom_study As CQGCustomStudy _
)

Parameters

cqg_custom_study

Reference to the changed CQGCustomStudy.

See Also

CQGCEL Interface | CQGCEL Members | CQGCurves Collection | CQGCustomStudy Collection


%%PageItemTitle%%

CustomStudyDefinitionsResolved Event
cqg_custom_study_definitions

Collection of custom study definitions.

If an error has occurred, the collection will be empty.

cqg_error

CQGError object describing the last error occurred during the request processing or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

CQGCEL Interface : CustomStudyDefinitionsResolved Event

Glossary Item Box

Description

This event is fired when the definitions of custom studies are resolved or when some error has occurred during the request processing.

Syntax

Visual Basic
Public Event CustomStudyDefinitionsResolved( _
   ByVal cqg_custom_study_definitions As CQGCustomStudyDefinitions, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_custom_study_definitions

Collection of custom study definitions.

If an error has occurred, the collection will be empty.

cqg_error

CQGError object describing the last error occurred during the request processing or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

See Also

CQGCEL Interface | CQGCEL Members | CQGCustomStudyDefinitions Collection | CQGCustomStudyDefinition Interface


%%PageItemTitle%%

CustomStudyInserted Event
cqg_custom_study

Reference to the inserted CQGCustomStudy

index_

Specifies the inserted CQGCustomStudy's index

CQGCEL Interface : CustomStudyInserted Event

Glossary Item Box

Description

This event is fired when a CQGCurves item is inserted.

Syntax

Visual Basic
Public Event CustomStudyInserted( _
   ByVal cqg_custom_study As CQGCustomStudy, _
   ByVal index_ As Long _
)

Parameters

cqg_custom_study

Reference to the inserted CQGCustomStudy

index_

Specifies the inserted CQGCustomStudy's index

See Also

CQGCEL Interface | CQGCEL Members | CQGCustomStudy Collection | CQGCurves Collection


%%PageItemTitle%%

CustomStudyRemoved Event
cqg_custom_study

Reference to the removed CQGCustomStudy

index_

Specifies the removed CQGCustomStudy's index

CQGCEL Interface : CustomStudyRemoved Event

Glossary Item Box

Description

This event is fired when a CQGCurves item is removed.

Syntax

Visual Basic
Public Event CustomStudyRemoved( _
   ByVal cqg_custom_study As CQGCustomStudy, _
   ByVal index_ As Long _
)

Parameters

cqg_custom_study

Reference to the removed CQGCustomStudy

index_

Specifies the removed CQGCustomStudy's index

See Also

CQGCEL Interface | CQGCEL Members | CQGCustomStudy Collection | CQGCurves Collection


%%PageItemTitle%%

CustomStudyResolved Event
cqg_custom_study

Reference to the resolved CQGCustomStudy

If an error has occurred, the collection will be empty.

cqg_error

CQGError object describing the last error occurred during the request processing or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

CQGCEL Interface : CustomStudyResolved Event

Glossary Item Box

Description

This event is fired when the custom study (CQGCustomStudy) is resolved or when some error has occurred during the custom studies request processing.

Syntax

Visual Basic
Public Event CustomStudyResolved( _
   ByVal cqg_custom_study As CQGCustomStudy, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_custom_study

Reference to the resolved CQGCustomStudy

If an error has occurred, the collection will be empty.

cqg_error

CQGError object describing the last error occurred during the request processing or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

See Also

CQGCEL Interface | CQGCEL Members | CQGCustomStudy Collection


%%PageItemTitle%%

CustomStudyUpdated Event
cqg_custom_study

Reference to changed CQGCustomStudy

index_

Specifies the updated CQGCurves index

CQGCEL Interface : CustomStudyUpdated Event

Glossary Item Box

Description

This event is fired when the CQGCurves item is updated.

Syntax

Visual Basic
Public Event CustomStudyUpdated( _
   ByVal cqg_custom_study As CQGCustomStudy, _
   ByVal index_ As Long _
)

Parameters

cqg_custom_study

Reference to changed CQGCustomStudy

index_

Specifies the updated CQGCurves index

See Also

CQGCEL Interface | CQGCEL Members | CQGCustomStudy Collection | CQGCurves Collection


%%PageItemTitle%%

DataConnectionStatusChanged Event
new_status

Indicates connection status.

CQGCEL Interface : DataConnectionStatusChanged Event

Glossary Item Box

Description

This event is fired when some changes occurred in the connection with the CQG data server.

Syntax

Visual Basic
Public Event DataConnectionStatusChanged( _
   ByVal new_status As eConnectionStatus _
)

Parameters

new_status
Value | Description
csConnectionDelayed | Connection is delayed.
csConnectionDown | Connection is down.
csConnectionNotLoggedOn | Connected but not logged on Gateway.
csConnectionTrouble | Trouble with Gateway connection.
csConnectionUp | Connection is up.

Indicates connection status.

Remarks

If the connection status is down no instrument updates will be fired by CQGCEL.

Example

See implementation of CQGCEL event handlers in CQGCEL Example.

See Also

CQGCEL Interface | CQGCEL Members | eConnectionStatus Enumeration


%%PageItemTitle%%

DataError Event
cqg_error

Object where the error occurred.

Starting from CQG API v.3.0: CQGError object representing the current error.

error_description
Description of the error
CQGCEL Interface : DataError Event

Glossary Item Box

Description

This event is fired when CQGCEL detects some abnormal discrepancy between data expected and data received.

Syntax

Visual Basic
Public Event DataError( _
   ByVal cqg_error As Object, _
   ByVal error_description As String _
)

Parameters

cqg_error

Object where the error occurred.

Starting from CQG API v.3.0: CQGError object representing the current error.

error_description
Description of the error

Remarks

This event is also fired when CQGCEL startup fails.
For a list of error codes defined in CQG API see the Error Codes table.

Example

See implementation of DataError event handler in CQGCEL Example.

For its usage in CQG API v. 3.0, see the implementation of DataError event handler in the AccountChanged Event's example section.

See Also

CQGCEL Interface | CQGCEL Members | CQGError Interface | CQGEnvironment.LastError Property


%%PageItemTitle%%

DataSourcesResolved Event
cqg_data_sources

Contains resolved data sources.

It will be empty if an error has occurred.

cqg_error

CQGError object representing the error occurred during the data source request.

If no error has occurred, the parameter value is either Nothing or invalid error object depending on the UsedFromATLClient setting of the configuration.

The parameter can be checked for validity via the CQGCEL.IsValid method.

CQGCEL Interface : DataSourcesResolved Event

Glossary Item Box

Description

This event is fired as a response to a data sources request either when the collection is resolved or when an error has occurred during the request processing.

Syntax

Visual Basic
Public Event DataSourcesResolved( _
   ByVal cqg_data_sources As CQGDataSources, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_data_sources

Contains resolved data sources.

It will be empty if an error has occurred.

cqg_error

CQGError object representing the error occurred during the data source request.

If no error has occurred, the parameter value is either Nothing or invalid error object depending on the UsedFromATLClient setting of the configuration.

The parameter can be checked for validity via the CQGCEL.IsValid method.

Example

The examples below show how to request data sources via CQG API.

VB
CS
Option Explicit
Private WithEvents CEL As CQGCEL
Private Sub Form_Load()
    ' Initialize CQGCEL instance.
    On Error Goto errHndl
    Set CEL = New CQGCEL
    CEL.APIConfiguration.CollectionsThrowException = False
    ' Disable application readiness checking
    CEL.APIConfiguration.ReadyStatusCheck = rscOff
    CEL.Startup
    Exit Sub
errHndl:
    MsgBox "Error occurred during CEL initialization. " & Err.Description
End Sub
Private Sub Form_Unload(Cancel As Integer)
    On Error Goto errHndl
    CEL.Shutdown
    Exit Sub
errHndl:
    MsgBox "Error occurred during CEL initialization. " & Err.Description
End Sub
' Event is fired when the CQGCEL object is successfully started up
Private Sub CEL_CELStarted()
    Debug.Print "CEL Version : " & CEL.Environment.CELVersion
End Sub
' Event is fired when error occures in CQGCEL execution
Private Sub cel_DataError(ByVal obj As Object, ByVal errorDescription As String)
    ' Print the error description
    Debug.Print "Data Error : " & errorDescription
End Sub
' Event is fired when some changes occurred in the connection
' with the CQG data server
Private Sub CEL_DataConnectionStatusChanged(ByVal newStatus As CQG.eConnectionStatus)
    Dim status As String
    Select Case newStatus
        Case csConnectionDelayed
            status = "Delayed"
        Case csConnectionDown
            status = "Down"
        Case csConnectionUp
            status = "Up"
    End Select
    Debug.Print "Data Connection Status changed to " & status
    If newStatus = csConnectionUp Then
        RequestDataSources
    End If
End Sub
' This function requests for available data sources
Private Sub RequestDataSources()
    Debug.Print "Requesting data sources"
    CEL.RequestDataSources
End Sub
' Event is fired when requested data sources collection is resolved
' or when an error has occurred during the request processing
Private Sub CEL_DataSourcesResolved(ByVal dataSources As CQG.ICQGDataSources, _
                                    ByVal cqgErr As CQG.ICQGError)
    Dim i As Long
    If Not cqgErr Is Nothing Then
        Debug.Print "Error occured during data sources request : " & cqgErr.Description
        Exit Sub
    End If
    Debug.Print "Data sources resolved"
    ' Print data for each data source
    Debug.Print "Data sources :"
    For i = 0 To dataSources.Count - 1
        Debug.Print vbTab & "Name : " & dataSources.Name(i)
        Debug.Print vbTab & "Abbreviation : " & dataSources.Abbreviation(i)
        Debug.Print vbTab & "Status : " & dataSources.status(i)
        Debug.Print vbTab & "Contains futures : " & _
                    IIf(dataSources.Type(i) And dstFutures = dstFutures, _
                    "Yes", "No")
    Next
    ' Request available symbols for first data source
    If dataSources.Count > 0 Then
        CEL.RequestDataSourceSymbols dataSources.Abbreviation(0)
    End If
End Sub
' Event is fired when requested symbols collection for specified data source is resolved
' or when an error has occurred during the request processing
Private Sub CEL_DataSourceSymbolsResolved(ByVal dataSourceName As String, _
                                          ByVal dataSourceSymbols As CQG.ICQGDataSourceSymbols, _
                                          ByVal cqgErr As CQG.ICQGError)
    Dim i As Long
    If Not cqgErr Is Nothing Then
        Debug.Print "Error occured during data source symbols request : " & cqgErr.Description
        Exit Sub
    End If
    Debug.Print "Data source " & dataSourceName & " symbols :"
    For i = 0 To dataSourceSymbols.Count - 1
        Debug.Print vbTab & "Abbreviation : " & dataSourceSymbols.Abbreviation(i)
        Debug.Print vbTab & "Description : " & dataSourceSymbols.Description(i)
        Debug.Print vbTab & "Type : " & dataSourceSymbols.Type(i)
    Next
End Sub
using System;
using System.Runtime.InteropServices;
using CQG;

namespace Samples
{
    class DataSources : IDisposable
    {
        // CQGCEL instance declaration
        private CQGCEL cel = new CQGCELClass();

        // Used to determine is the object manualy disposed
        private bool disposed = false;

        public DataSources()
        {
            // Initialize CQGCEL instance
            try
            {
                // Configure CEL
                cel.APIConfiguration.ReadyStatusCheck = eReadyStatusCheck.rscOff;
                cel.APIConfiguration.CollectionsThrowException = false;

                // Register to CEL's events
                cel.CELStarted += new _ICQGCELEvents_CELStartedEventHandler(cel_CELStarted);
                cel.DataError += new _ICQGCELEvents_DataErrorEventHandler(cel_DataError);
                cel.DataConnectionStatusChanged += new _ICQGCELEvents_DataConnectionStatusChangedEventHandler(cel_DataConnectionStatusChanged);
                cel.DataSourcesResolved += new _ICQGCELEvents_DataSourcesResolvedEventHandler(cel_DataSourcesResolved);
                cel.DataSourceSymbolsResolved += new _ICQGCELEvents_DataSourceSymbolsResolvedEventHandler(cel_DataSourceSymbolsResolved);

                cel.Startup();
            }
            catch (COMException ex)
            {
                Console.WriteLine( "Error occurred during CEL initialization. {0}", ex.Message );
            }
        }

        ~DataSources()
        {
            Dispose(false);
        }

        #region CEL Event Handlers

        // Event is fired when the CQGCEL object is successfully started up
        void cel_CELStarted()
        {
            Console.WriteLine("CEL Version : {0}", cel.Environment.CELVersion);
        }

        // Event is fired when error occures in CQGCEL execution
        void cel_DataError(object obj, string errorDescription)
        {
            // Some error occurred
            Console.WriteLine("Data Error : " + errorDescription);
         }

        // Event is fired when some changes occurred in the connection
        // with the CQG data server
        void cel_DataConnectionStatusChanged(eConnectionStatus newStatus)
        {
            string status;
            switch (newStatus)
            {
                case eConnectionStatus.csConnectionDelayed:
                    status = "Delayed";
                    break;

                case eConnectionStatus.csConnectionDown:
                    status = "Down";
                    break;

                case eConnectionStatus.csConnectionUp:
                    status = "Up";
                    break;

                default:
                    status = "Unknown";
                    break;
            }
            Console.WriteLine("Data Connection Status changed to " + status);

            if (newStatus == eConnectionStatus.csConnectionUp)
            {
                RequestDataSources();
            }
        }

        // This function requests for available data sources
        void RequestDataSources()
        {
            Console.WriteLine("Requesting data sources");
            cel.RequestDataSources();
        }

        // Event is fired when requested data sources collection is resolved
        // or when an error has occurred during the request processing
        void cel_DataSourcesResolved(CQGDataSources dataSources, CQGError err)
        {
            if (err != null)
            {
                Console.WriteLine("Error occured during data sources request : {0}", err.Description);
                return;
            }

            Console.WriteLine("Data sources resolved");

            // Print data for each data source
            Console.WriteLine("Data sources :");
            for (int i = 0; i < dataSources.Count; i++)
            {
                Console.WriteLine("\t Name : {0}", dataSources[i]);
                Console.WriteLine("\t Abbreviation : {0}", dataSources.get_Abbreviation(i));
                Console.WriteLine("\t Status : {0}", dataSources.get_Status(i));
                if ((dataSources.get_Type(i) & eDataSourceType.dstFutures) == eDataSourceType.dstFutures)
                {
                    Console.WriteLine("\t Contains futures : Yes");
                }
                else
                {
                    Console.WriteLine("\t Contains futures : No");
                }
            }

            // Request available symbols for first data source
            if (dataSources.Count > 0)
            {
                cel.RequestDataSourceSymbols(dataSources.get_Abbreviation(0));
            }
        }

        // Event is fired when requested symbols collection for specified data source is resolved
        // or when an error has occurred during the request processing
        void cel_DataSourceSymbolsResolved(string dataSourceName, CQGDataSourceSymbols dataSourceSymbols, CQGError err)
        {
            if (err != null)
            {
                Console.WriteLine("Error occured during data source symbols request : {0}", err.Description);
                return;
            }

            Console.WriteLine("Data source {0} symbols :", dataSourceName);
            for (int i = 0; i < dataSourceSymbols.Count; i++)
            {
                Console.WriteLine("\t Abbreviation : {0}", dataSourceSymbols.get_Abbreviation(i));
                Console.WriteLine("\t Description : {0}", dataSourceSymbols.get_Description(i));
                Console.WriteLine("\t Type : {0}", dataSourceSymbols.get_Type(i));
            }
        }

        #endregion

        #region IDisposable Members

        public void Dispose()
        {
            Dispose(true);

            GC.SuppressFinalize(this);
        }

        #endregion

        #region Private Methods

        private void Dispose(bool disposing)
        {
            // Check to see if Dispose has already been called
            if (!this.disposed)
            {
                // If disposing equals true, dispose all managed
                // and unmanaged resources
                if (disposing)
                {
                    // Dispose managed resources
                }

                // If disposing is false,
                // only the following code is executed
                try
                {
                    cel.Shutdown();
                }
                catch
                { }
            }
            disposed = true;
        }

        #endregion
    }
}

See Also

CQGCEL Interface | CQGCEL Members | CQGCEL.RequestDataSources Method | CQGDataSources Collection | CQGError Interface | CQGAPIConfig.UsedFromATLClient Property


%%PageItemTitle%%

DataSourceSymbolsResolved Event
data_source_abbreviation

Name of the data source, which symbols are resolved.

It is the value of dataSourceName which was passed to the corresponding RequestDataSourceSymbols method.

cqg_data_source_symbols

Contains resolved data sources symbols.

It will be empty if an error has occurred.

cqg_error

CQGError object representing the error occurred during the data source symbols request.

If no error has occurred, the parameter value is either Nothing or invalid error object depending on the UsedFromATLClient setting of the configuration.

The parameter can be checked for validity via the CQGCEL.IsValid method.

CQGCEL Interface : DataSourceSymbolsResolved Event

Glossary Item Box

Description

This event is fired as a response to a data source symbols request either when the collection is resolved or when an error has occurred during the request processing.

Syntax

Visual Basic
Public Event DataSourceSymbolsResolved( _
   ByVal data_source_abbreviation As String, _
   ByVal cqg_data_source_symbols As CQGDataSourceSymbols, _
   ByVal cqg_error As CQGError _
)

Parameters

data_source_abbreviation

Name of the data source, which symbols are resolved.

It is the value of dataSourceName which was passed to the corresponding RequestDataSourceSymbols method.

cqg_data_source_symbols

Contains resolved data sources symbols.

It will be empty if an error has occurred.

cqg_error

CQGError object representing the error occurred during the data source symbols request.

If no error has occurred, the parameter value is either Nothing or invalid error object depending on the UsedFromATLClient setting of the configuration.

The parameter can be checked for validity via the CQGCEL.IsValid method.

Remarks

See the usage of DataSourceSymbolsResolved event in the DataSourcesResolved event's example section.

Example

See the usage of DataSourceSymbolsResolved event in the DataSourcesResolved event's example section.

See Also

CQGCEL Interface | CQGCEL Members | CQGCEL.RequestDataSourceSymbols Method | CQGDataSourceSymbols Collection | CQGError Interface | CQGAPIConfig Interface | CQGCEL.APIConfiguration Property | CQGAPIConfig.UsedFromATLClient Property


%%PageItemTitle%%

ExpressionAdded Event
cqg_expression

Reference to changed CQGExpression.

CQGCEL Interface : ExpressionAdded Event

Glossary Item Box

Description

This event is fired when a CQGExpressionOutputs item is added to the end of CQGExpression.

Syntax

Visual Basic
Public Event ExpressionAdded( _
   ByVal cqg_expression As CQGExpression _
)

Parameters

cqg_expression

Reference to changed CQGExpression.

See Also

CQGCEL Interface | CQGCEL Members | CQGExpression Collection | CQGExpressionOutputs Collection


%%PageItemTitle%%

ExpressionInserted Event
cqg_expression

Reference to the CQGExpressions collection the expression is inserted to

index_

Specifies the inserted CQGExpressions's index

CQGCEL Interface : ExpressionInserted Event

Glossary Item Box

Description

This event is fired when a CQGExpression item is inserted to the CQGExpressions collection.

Syntax

Visual Basic
Public Event ExpressionInserted( _
   ByVal cqg_expression As CQGExpression, _
   ByVal index_ As Long _
)

Parameters

cqg_expression

Reference to the CQGExpressions collection the expression is inserted to

index_

Specifies the inserted CQGExpressions's index

See Also

CQGCEL Interface | CQGCEL Members | CQGExpression Collection | CQGExpressions Collection


%%PageItemTitle%%

ExpressionRemoved Event
cqg_expression

Reference to the CQGExpressions collection the expression is removed from

index_

Specifies the removed CQGExpression's index

CQGCEL Interface : ExpressionRemoved Event

Glossary Item Box

Description

This event is fired when a CQGExpression item is removed from the CQGExpressions collection.

Syntax

Visual Basic
Public Event ExpressionRemoved( _
   ByVal cqg_expression As CQGExpression, _
   ByVal index_ As Long _
)

Parameters

cqg_expression

Reference to the CQGExpressions collection the expression is removed from

index_

Specifies the removed CQGExpression's index

See Also

CQGCEL Interface | CQGCEL Members | CQGExpressions Collection | CQGExpression Collection


%%PageItemTitle%%

ExpressionResolved Event
cqg_expression

Reference to resolved CQGExpression

cqg_error

CQGError object describing the last error occurred during the expression request processing or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

CQGCEL Interface : ExpressionResolved Event

Glossary Item Box

Description

This event is fired when the expression (CQGExpression) is resolved or when some error has occurred during the expression request processing.

Syntax

Visual Basic
Public Event ExpressionResolved( _
   ByVal cqg_expression As CQGExpression, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_expression

Reference to resolved CQGExpression

cqg_error

CQGError object describing the last error occurred during the expression request processing or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

See Also

CQGCEL Interface | CQGCEL Members | CQGExpression Collection | CQGExpressions Collection


%%PageItemTitle%%

ExpressionUpdated Event
cqg_expression

Reference to changed CQGExpression

index_

Specifies the updated CQGExpressionOutputs index

CQGCEL Interface : ExpressionUpdated Event

Glossary Item Box

Description

This event is fired when a CQGExpressionOutputs item is updated.

Syntax

Visual Basic
Public Event ExpressionUpdated( _
   ByVal cqg_expression As CQGExpression, _
   ByVal index_ As Long _
)

Parameters

cqg_expression

Reference to changed CQGExpression

index_

Specifies the updated CQGExpressionOutputs index

See Also

CQGCEL Interface | CQGCEL Members | CQGExpression Collection | CQGExpressionOutputs Collection


%%PageItemTitle%%

GWConnectionStatusChanged Event
new_status
The current status of the connection with CQG Gateway.
CQGCEL Interface : GWConnectionStatusChanged Event

Glossary Item Box

Description

This event is fired when the status of the connection with the CQG Gateway is changed.

Syntax

Visual Basic
Public Event GWConnectionStatusChanged( _
   ByVal new_status As eConnectionStatus _
)

Parameters

new_status
Value | Description
csConnectionDelayed | Connection is delayed.
csConnectionDown | Connection is down.
csConnectionNotLoggedOn | Connected but not logged on Gateway.
csConnectionTrouble | Trouble with Gateway connection.
csConnectionUp | Connection is up.
The current status of the connection with CQG Gateway.

Remarks

The functionality of CQG API v.3.0 becomes available when a GWConnectionStatusChanged event with csConnectionUp argument is fired.

Note that the user should manually set the account subscription level in order to use it. This is true for all cases: even if the connection was lost during the CQG API work, after connection is up again the account subscription level will be reset to aslNone. User should set it again to the desired value. Note that it will also reset the PositionSubcriptionLevel to the default value for all accounts.

While the CQG Gateway connection status is down, no v.3.0 functionality is available and a corresponding DataError event will be fired if the user tries to use it.

Example

See the implementation of GWConnectionStatusChanged event handling in the AccountChanged event's example section.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

GWEnvironmentChanged Event
event_code

The CQG Gateway environment change type.

account_id

A CQGAccount object representing the account to which the current change refers.

If the change is not account-specific, this parameter will be either Nothing or a not valid instance of CQGAccount. See Invalid Object for details.

phase_
Reserved for future use
CQGCEL Interface : GWEnvironmentChanged Event

Glossary Item Box

Description

This event is fired when a CQG Gateway environment change occurs.

Syntax

Visual Basic
Public Event GWEnvironmentChanged( _
   ByVal event_code As eGWEnvChangeCode, _
   ByVal account_id As Long, _
   ByVal phase_ As Long _
)

Parameters

event_code
Value | Description
eccBalanceChanged

Previous close balance is changed.

eccManualStatementChanged

Manual statement change.

eccNewStatement

New statement.

eccPositionChanged | Previous close position is changed.

The CQG Gateway environment change type.

account_id

A CQGAccount object representing the account to which the current change refers.

If the change is not account-specific, this parameter will be either Nothing or a not valid instance of CQGAccount. See Invalid Object for details.

phase_
Reserved for future use

Remarks

Generally the CQG Gateway environment changes trigger a big amount of positions reload. User should be aware that after this event, a number of AccountChanged events with actAccountChanged and actPositionsReloaded types will be fired.

Example

See the implementation of CQGCEL events handling in the AccountChanged event's example section.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

HistoricalSessionsResolved Event
cqg_historical_sessions

Reference to the historical sessions collection

cqg_historical_sessions_request
Reference to CQGHistoricalSessionsRequest
cqg_error

CQGError object describing the last error occurred during the historical sessions request processing or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

CQGCEL Interface : HistoricalSessionsResolved Event

Glossary Item Box

Description

Fired when the historical sessions (CQGSessionsCollection) are resolved or when some error has occurred during processing the historical sessions request.

Syntax

Visual Basic
Public Event HistoricalSessionsResolved( _
   ByVal cqg_historical_sessions As CQGSessionsCollection, _
   ByVal cqg_historical_sessions_request As CQGHistoricalSessionsRequest, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_historical_sessions

Reference to the historical sessions collection

cqg_historical_sessions_request
Reference to CQGHistoricalSessionsRequest
cqg_error

CQGError object describing the last error occurred during the historical sessions request processing or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

Remarks

The CQGSessionsCollection resolved through cqg_historical_sessions represents a CQGSessions collection, which contains all session data accessible through CQGIC's [More > New Data Browser > Session Info] interface:

Each Session Description section describes session details for a given time period, including:

  • Start and end date/time
  • Active trading days
  • Holidays

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

ICConnectionStatusChanged Event
new_status

Indicates the status change that has been occurred.

CQGCEL Interface : ICConnectionStatusChanged Event

Glossary Item Box

Description

This event is fired when the CQGIC connection status has been changed.

Syntax

Visual Basic
Public Event ICConnectionStatusChanged( _
   ByVal new_status As eICConnectionStatus _
)

Parameters

new_status
Value Description
iccsExited

Indicates that the CQGIC has been shut down.

Indicates the status change that has been occurred.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

IncorrectSymbol Event
symbol_
String describing the error.
The name of the incorrect symbol, i.e., what was passed to the NewInstrument method.
CQGCEL Interface : IncorrectSymbol Event

Glossary Item Box

Description

This event is fired when a not tradable symbol name is passed to the NewInstrument method.

Deprecated. Use InstrumentResolved instead.

Syntax

Visual Basic
Public Event IncorrectSymbol( _
   ByVal symbol_ As String _
)

Parameters

symbol_
String describing the error.
The name of the incorrect symbol, i.e., what was passed to the NewInstrument method.

Remarks

This event may be fired in two cases: if there is no such symbol in CQG System or the symbol is present but the user is not enabled to it.

Example

See example of InstrumentSubscribed event.

See Also

CQGCEL Interface | CQGCEL Members | CQGCEL.InstrumentSubscribed Event


%%PageItemTitle%%

InstrumentChanged Event
cqg_instrument

Name of updated instrument.

cqg_quotes

Collection of changed quotes.

The contents of cqg_quotes depends on how the CQGAPIConfig.NewInstrumentChangeMode property is set, as the following:

  • If CQGAPIConfig.NewInstrumentChangeMode is set to True:
    cqg_quotes contains prior values and current values must be obtained from CQGInstrument.Quotes; or explicitly using CQGInstrument.Trade, CQGInstrument.Bid, and CQGInstrument.Ask properties.
    However, cqg_quotes must be used to determine, which values have changed.
  • If CQGAPIConfig.NewInstrumentChangeMode is set to False:
    cqg_quotes contains the current values.
cqg_instrument_properties

Collection of changed dynamic properties.

CQGCEL Interface : InstrumentChanged Event

Glossary Item Box

Description

This event is fired when any of the instrument quotes or dynamic instrument properties are changed.

Syntax

Visual Basic
Public Event InstrumentChanged( _
   ByVal cqg_instrument As CQGInstrument, _
   ByVal cqg_quotes As CQGQuotes, _
   ByVal cqg_instrument_properties As CQGInstrumentProperties _
)

Parameters

cqg_instrument

Name of updated instrument.

cqg_quotes

Collection of changed quotes.

The contents of cqg_quotes depends on how the CQGAPIConfig.NewInstrumentChangeMode property is set, as the following:

  • If CQGAPIConfig.NewInstrumentChangeMode is set to True:
    cqg_quotes contains prior values and current values must be obtained from CQGInstrument.Quotes; or explicitly using CQGInstrument.Trade, CQGInstrument.Bid, and CQGInstrument.Ask properties.
    However, cqg_quotes must be used to determine, which values have changed.
  • If CQGAPIConfig.NewInstrumentChangeMode is set to False:
    cqg_quotes contains the current values.
cqg_instrument_properties

Collection of changed dynamic properties.

Remarks

This event will not be fired if the data subscription level of the instrument is set to dsNone. All other data subscription level settings control the information that will be sent via the InstrumentChanged event.

If the data subscription level is set to dsQuotes, trades information and dynamic properties about trades will be delivered to the user. Updates of asks or bids will not be available.

To receive ask/bid updates, set the subscription level to dsQuotesAndBBA.

In order to receive DOM data updates set subscription level to dsQuotesAndDOM

In versions earlier than v. 3.0, the Quotes and props parameters contained collections with new values of the changed quotes/properties. Starting from CQG API v.3.0 the content can be configured to contain the old values of the changed quotes/properties. See NewInstrumentChangeMode for details.

Example

This example demonstrates how to handle the InstrumentChanged event and how to use CQGInstrumentProperties and CQGQuotes collection objects.

See the implementation of CQGCEL events handling in the AccountChanged event's example section.

VB
C#
Private Sub cel_InstrumentChanged(ByVal Instrument As CQG.ICQGInstrument, _
                                    ByVal Quotes As CQG.ICQGQuotes, _
                                    ByVal Props As CQG.ICQGInstrumentProperties)
    Dim cellName As String
    Dim cellRow As Integer
    Dim currentQuote As CQGQuote
    ' Processing updated quotes.
    For Each currentQuote In Quotes
        cellRow = GetQuoteRowByType(currentQuote.Type)
        ' Fill updated quote name into some Excel cell.
        cellName = "C" & CStr(cellRow)
        Range(cellName) = currentQuote.Name
        ' Fill updated quote price data into some Excel cell.
        cellName = "D" & CStr(cellRow)
        Range(cellName) = IIf(currentQuote.IsValid, currentQuote.Price, "Unavailable")
        ' Fill updated quote volume data into some Excel cell.
        cellName = "E" & CStr(cellRow)
        Range(cellName) = IIf(currentQuote.IsValid, currentQuote.Volume, "Unavailable")
    Next
    Dim currentInstrumentProp As CQGInstrumentProperty
    ' Processing updated properties.
    For Each currentInstrumentProp In Props
        cellRow = GetInstrumentPropertyRowByType(currentInstrumentProp.Type)
        ' Fill updated instrument property name into some Excel cell.
        cellName = "G" & CStr(cellRow)
        Range(cellName) = currentInstrumentProp.Name
        ' Fill updated quote price data into some Excel cell.
        cellName = "H" & CStr(cellRow)
        Range(cellName) = currentInstrumentProp.Value
    Next
End Sub
Private Function GetQuoteRowByType(Qt As eQuoteType) As Integer
    Dim quoteRowIndex As Integer
        quoteRowIndex = CInt(Qt) + 1
    GetQuoteRowByType = quoteRowIndex
End Function
Private Function GetInstrumentPropertyRowByType(It As eInstrumentProperty) As Integer
    Dim instrumentPropertyRowIndex As Integer
        instrumentPropertyRowIndex = CInt(It) + 1
    GetInstrumentPropertyRowByType = instrumentPropertyRowIndex
End Function
private void m_cel_InstrumentChanged(CQGInstrument Instrument,
                                        CQGQuotes Quotes,
                                            CQGInstrumentProperties Props)
{
    // Processing updated quotes.
    foreach( CQGQuote currentQuote in Quotes )
    {
        // Write updated quote name to console.
        Console.WriteLine( currentQuote.Name + " : " ) ;
        // Write updated quote price data to console.
        Console.WriteLine( ( currentQuote.IsValid ) ? currentQuote.Price.ToString() : "Unavailable") ;
        // Write updated quote volume data to console.
        Console.WriteLine( ( currentQuote.IsValid ) ? currentQuote.Volume.ToString() : "Unavailable" ) ;
    }

    // Processing updated properties.
    foreach( CQGInstrumentProperty currentInstrumentProp in Props )
    {
        // Write updated instrument property name into to console.
        Console.WriteLine( currentInstrumentProp.Name ) ;
        // Write updated quote price data to console.
        Console.WriteLine( currentInstrumentProp.Value.ToString() ) ;
    }
}

See Also

CQGCEL Interface | CQGCEL Members | CQGInstrument Interface | CQGInstrumentProperties Collection | CQGQuotes Collection


%%PageItemTitle%%

InstrumentDOMChanged Event
cqg_instrument

Changed instrument: its DOMAsks and DOMBids collections contain new DOM book

prev_asks

Collection of asks from previous DOM book

prev_bids

Collection of bids from previous DOM book

CQGCEL Interface : InstrumentDOMChanged Event

Glossary Item Box

Description

This event is fired when instrument's DOM* is updated.

Syntax

Visual Basic
Public Event InstrumentDOMChanged( _
   ByVal cqg_instrument As CQGInstrument, _
   ByVal prev_asks As CQGDOMQuotes, _
   ByVal prev_bids As CQGDOMQuotes _
)

Parameters

cqg_instrument

Changed instrument: its DOMAsks and DOMBids collections contain new DOM book

prev_asks

Collection of asks from previous DOM book

prev_bids

Collection of bids from previous DOM book

Remarks

In order to receive this event for an instrument, its data subscription level should be set to dsQuotesAndDOM.

Mode and frequency of DOM update firing can be changed from CQGAPIConfig.DOMUpdatesMode and CQGAPIConfig.DOMUpdatesPeriod properties.

When the event is fired for the first time the prevAsks and prevBids collections are empty.

Note: Not all the instruments have DOM support. In case such instrument's subscription level is set to dsQuotesAndDOM this event will be fired only once and all DOM collections (instrument.DOMAsks, instrument.DOMBids, prevAsks and prevBids) will be empty.

*DOM goes for depth of market

Example

These examples show the handling of InstrumentDOMChanged event. Here is also shown how to get the best ask/bid of the new DOM book.

VB
C#
Private Sub cel_InstrumentDOMChanged(ByVal Instrument As CQG.ICQGInstrument, _
                                    ByVal prevAsks As CQG.ICQGDOMQuotes, _
                                    ByVal prevBids As CQG.ICQGDOMQuotes)
    'Get the best ask of current DOM book
    Dim BestAsk As CQGQuote
    Set BestAsk = Instrument.DOMAsks(0)
    'Get the best bid of current DOM book
    Dim BestBid As CQGQuote
    Set BestBid = Instrument.DOMBids(0)
End Sub
private void cel_InstrumentDOMChanged(CQGInstrument Instrument, CQGDOMQuotes prevAsks, CQGDOMQuotes prevBids)
{
    //Get the best ask of current DOM book
    CQGQuote BestAsk = Instrument.DOMAsks[0];

    //Get the best bid of current DOM book
    CQGQuote BestBid = Instrument.DOMBids[0];
}

See Also

CQGCEL Interface | CQGCEL Members | CQGCELConfiguration UDT | CQGDOMQuotes Collection


%%PageItemTitle%%

InstrumentResolved Event
Symbol
the commodity symbol that was requested by user in NewInstrument method
cqg_instrument

resolved CQGInstrument object

cqg_error

CQGError object describing the last error occurred during processing the new instrument request or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

CQGCEL Interface : InstrumentResolved Event

Glossary Item Box

Description

This event is fired when a new instrument is resolved and subscribed or a resolution process failed.

Syntax

Visual Basic
Public Event InstrumentResolved( _
   ByVal Symbol As String, _
   ByVal cqg_instrument As CQGInstrument, _
   ByVal cqg_error As CQGError _
)

Parameters

Symbol
the commodity symbol that was requested by user in NewInstrument method
cqg_instrument

resolved CQGInstrument object

cqg_error

CQGError object describing the last error occurred during processing the new instrument request or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

InstrumentsGroupChanged Event
change_type

Group change type

instruments_group

Changed group of instruments

instruments_names

The list of changed (removed/added) instruments' names

CQGCEL Interface : InstrumentsGroupChanged Event

Glossary Item Box

Description

This event is fired when the instruments group was changed. Instrument was added or removed from the group.

Syntax

Visual Basic
Public Event InstrumentsGroupChanged( _
   ByVal change_type As eChangeType, _
   ByVal instruments_group As CQGInstrumentsGroup, _
   ByVal instruments_names As CQGStringCollection _
)

Parameters

change_type
Value | Description
ctAdded | New order is added and is already in the collection.
ctChanged | The order is changed.
ctRemoved | The order is removed from the collection.

Group change type

instruments_group

Changed group of instruments

instruments_names

The list of changed (removed/added) instruments' names

See Also

CQGCEL Interface | CQGCEL Members | eChangeType Enumeration | CQGInstrumentsGroup Interface | CQGStringCollection Collection | RemoveInstrumentsGroup Method | RequestInstrumentsGroup Method | AllInstrumentsGroups Property


%%PageItemTitle%%

InstrumentsGroupResolved Event
instruments_group

Group of the subscribed instruments

cqg_error
CQGError object describing the error occurred during registration if it fails, or Nothing/Invalid_Error in case of succeed.

CQGCEL.IsValid(Invalid_Error) returns False.

CQGCEL Interface : InstrumentsGroupResolved Event

Glossary Item Box

Description

This event is fired when the instruments group subscription is completed with either success or failure.

Syntax

Visual Basic
Public Event InstrumentsGroupResolved( _
   ByVal instruments_group As CQGInstrumentsGroup, _
   ByVal cqg_error As CQGError _
)

Parameters

instruments_group

Group of the subscribed instruments

cqg_error
CQGError object describing the error occurred during registration if it fails, or Nothing/Invalid_Error in case of succeed.

CQGCEL.IsValid(Invalid_Error) returns False.

See Also

CQGCEL Interface | CQGCEL Members | CQGError Interface | CQGCEL.IsValid Method | CQGInstrumentsGroup Interface | AllInstrumentsGroups Property | RequestInstrumentsGroup Method | RemoveInstrumentsGroup Method


%%PageItemTitle%%

InstrumentSubscribed Event
symbol_
the commodity symbol that was requested by user in NewInstrument method
cqg_instrument

resolved CQGInstrument object

CQGCEL Interface : InstrumentSubscribed Event

Glossary Item Box

Description

This event is fired when a new instrument is resolved and subscribed.

Deprecated. Use InstrumentResolved instead.

Syntax

Visual Basic
Public Event InstrumentSubscribed( _
   ByVal symbol_ As String, _
   ByVal cqg_instrument As CQGInstrument _
)

Parameters

symbol_
the commodity symbol that was requested by user in NewInstrument method
cqg_instrument

resolved CQGInstrument object

Remarks

InstrumentSubscribed is also fired if a duplicate resolution is attempted. In that case the Instrument parameter returns the same object as it returned the first time.

Example

The example shows how to access CQGInstrument properties immediately after it is subscribed.

VB
C#
Private Const strSomeTagName As String = "AlreadySubscribed"
Private Sub cel_InstrumentSubscribed(ByVal Symbl As String, _
                                        ByVal Instrument As CQG.ICQGInstrument)
    If Instrument.Tag(strSomeTagName) = True Then
       ' Instrument was already subscribed once
    Else
       Instrument.Tag(strSomeTagName) = True
       ' Instrument subscribed first time
    End If
    ' Here we tell CQGCEL to send us ask/bid change notifications along
    ' with quote changes
    Instrument.DataSubscriptionLevel = dsQuotesAndBBA
    Range("B5") = Symbl
    Range("B6") = Instrument.Description
    Range("B7") = Instrument.YearString
    Range("C7") = Instrument.MonthChar
End Sub
Private Sub cel_IncorrectSymbol(ByVal Symbl As String)
    ' Incorrect symbol (Symbl) is passed to NewInstrument function
End Sub
const string strSomeTagName = "AlreadySubscribed" ;

private void cel_InstrumentSubscribed(string Symbl, CQGInstrument Instrument)
{
    if( Instrument == null )
    {
        // Failed to subscribe instrument
        return ;
    }

    if( Instrument.get_Tag( strSomeTagName ) == true )
    {
       // Instrument was already subscribed once
    }
    else
    {
       Instrument.set_Tag( strSomeTagName , true ) ;
       // Instrument subscribed first time
    }
    // Here we tell CQGCEL to send us ask/bid change notifications along
    // with quote changes
    Instrument.DataSubscriptionLevel = eDataSubscriptionLevel.dsQuotesAndBBA ;
    Console.WriteLine( Symbl ) ;
    Console.WriteLine( Instrument.Description ) ;
    Console.WriteLine( Instrument.YearString ) ;
    Console.WriteLine( Instrument.MonthChar ) ;
}

private void cel_IncorrectSymbol(string Symbl)
{
    // Incorrect symbol (Symbl) is passed to NewInstrument function
}

See Also

CQGCEL Interface | CQGCEL Members | CQGCEL.NewInstrument Method | CQGInstrument Interface | CQGCEL.IncorrectSymbol Event


%%PageItemTitle%%

IsReady Event
ready_status

readyStatus should reflect the Excel.Application.Ready flag. If Application.Ready is True, then readyStatus should be assigned rsReady. If Application.Ready is False then readyStatus should be assigned rsNotReady.

If CQGCEL gets rsBusy or rsNotReady, the attempt is repeated after the timeout, until CQGCEL gets rsReady and becomes able to process its own events.

CQGCEL Interface : IsReady Event

Glossary Item Box

Description

This event was added especially to be used in Excel macros. It is fired every time before any other event is fired to check the Excel readiness to receive user events.

Generally it can be used for similar purposes from other host applications to control event flow by informing CQG API about readiness to receive events.

Syntax

Visual Basic
Public Event IsReady( _
   ByRef ready_status As eReadyStatus _
)

Parameters

ready_status
Value Description
rsBusy

The host application (MS Excel) is in edit mode.

rsNotReady

The host application (MS Excel) isn't ready (when Application.Ready = False).

rsReady

The host application (MS Excel) is ready (when Application.Ready = True).

readyStatus should reflect the Excel.Application.Ready flag. If Application.Ready is True, then readyStatus should be assigned rsReady. If Application.Ready is False then readyStatus should be assigned rsNotReady.

If CQGCEL gets rsBusy or rsNotReady, the attempt is repeated after the timeout, until CQGCEL gets rsReady and becomes able to process its own events.

Remarks

The firing of this event is controlled by the CQGAPIConfig.ReadyStatusCheck property. If its ReadyStatusChecked member is set to rscOn IsReady will be fired; if ReadyStatusChecked is set to rscOff IsReady won't be fired.

If you are using OfficeXP and higher you should correctly handle IsReady event and ready status check configuration should be set to rscOn.

All implementations except Excel macros can set ready status check configuration to rscOff in order not to handle IsReady events.

The IsReady event was added taking into account Excel's Application.Ready flag, which reflects the Excel readiness to receive user events. Sometimes Excel just does not "get" user events but stays silent. In this case, the user has no means to know did his event pass or no. The IsReady event can be used to avoid such cases.

Important: DoEvents should not be called in this event handler.

Example

See implementation of IsReady event handler in CQGCEL Example.

IsReady event handling in Office 2000 Copy Code
Private Sub cel_IsReady(readyStatus As CQG.eReadyStatus)
    ' Office 2000 does not have Application.Ready flag,
    ' hence always return rsReady
    readyStatus = rsReady
End Sub

How to programmatically retrieve Excel version Copy Code
Private Function IsReadyFlagExist() As Boolean
    'Get excel major version
    Dim ExcelMajorVersion As Integer
    ExcelMajorVersion = CInt(Left$(Application.Version, InStr(Application.Version, ".") - 1))
    If ExcelMajorVersion > 9 Then ' Excel 2002 and higher
        IsReadyFlagExist = True
    Else
        IsReadyFlagExist = False
    End If
End Function

See Also

CQGCEL Interface | CQGCEL Members | eReadyStatus Enumeration | eReadyStatusCheck Enumeration | CQGAPIConfig.ReadyStatusCheck Property


%%PageItemTitle%%

LineTimeChanged Event
new_line_time
date containing the line time (time on the current exchange) converted to the timezone previously set by the user
CQGCEL Interface : LineTimeChanged Event

Glossary Item Box

Description

This event is fired once every second to synchronize with the exchange.

Syntax

Visual Basic
Public Event LineTimeChanged( _
   ByVal new_line_time As Date _
)

Parameters

new_line_time
date containing the line time (time on the current exchange) converted to the timezone previously set by the user

Remarks

Line time is converted to the user timezone set in TimeZoneCode property. If no timezone is set by the user, the time is converted to UTC.

Example

The example demonstrates how to handle the LineTimeChanged event and how to use CQGEnvironment object. The example assumes, that CQG API is instantiated, started, and some instruments are created.

VB
C#
Option Explicit
' CQGCEL instance declaration
Public WithEvents cel As CQGCEL
Private Function ConnectionStatusToString(Cs As eConnectionStatus) As String
    Select Case Cs
        Case csConnectionDelayed
            ConnectionStatusToString = "Delayed"
        Case csConnectionDown
            ConnectionStatusToString = "Down"
        Case csConnectionUp
            ConnectionStatusToString = "Up"
    End Select
End Function
Private Sub cel_LineTimeChanged(ByVal NewLineTime As Date)
    Range("A7") = "CQGCEL Version"
    Range("B7") = cel.Environment.CELVersion
    Range("A8") = "CQGIC Version"
    Range("B8") = cel.Environment.CQGVersion
    Range("A9") = "Data Connection Status"
    Range("B9") = ConnectionStatusToString(cel.Environment.DataConnectionStatus)
    Range("A10") = "Line Time"
    Range("B10") = CStr(cel.Environment.LineTime)
    Range("A11") = "Local Time"
    Range("B11") = CStr(cel.Environment.LocalTime)
    Range("A12") = "Messages Pending"
    Range("B12") = cel.Environment.MessagesPending
End Sub
private string ConnectionStatusToString( eConnectionStatus Cs )
{
   switch( Cs )
   {
      case eConnectionStatus.csConnectionDelayed :
         return "Delayed" ;
      case eConnectionStatus.csConnectionDown :
         return "Down" ;
      case eConnectionStatus.csConnectionUp :
         return "Up" ;
   }
   return "" ;
}

private void cel_LineTimeChanged(DateTime NewLineTime)
{
   Console.Write( "CQGCEL Version : " ) ;
   Console.WriteLine( cel.Environment.CELVersion ) ;
   Console.Write( "CQGIC Version : " ) ;
   Console.WriteLine( cel.Environment.CQGVersion ) ;
   Console.Write( "Data Connection Status : " ) ;
   Console.WriteLine( ConnectionStatusToString( cel.Environment.DataConnectionStatus ) ) ;
   Console.Write( "Line Time : " ) ;
   Console.WriteLine( cel.Environment.LineTime.ToString() ) ;
   Console.Write( "Local Time : " ) ;
   Console.WriteLine( cel.Environment.LocalTime.ToString() ) ;
   Console.Write( "Messages Pending : " ) ;
   Console.WriteLine( cel.Environment.MessagesPending ) ;
}

See Also

CQGCEL Interface | CQGCEL Members | CQGCELConfiguration UDT


%%PageItemTitle%%

ManualFillChanged Event
cqg_manual_fill

Specifies the changed manual fill instance, represented as CQGManualFill

modify_type
Manual fills update type
CQGCEL Interface : ManualFillChanged Event

Glossary Item Box

Description

This event is fired when a new manual fill was added, some manual fill properties were changed, or the manual fill was removed only if subscription data level for appropriate request was requested with updates notifications.

Syntax

Visual Basic
Public Event ManualFillChanged( _
   ByVal cqg_manual_fill As CQGManualFill, _
   ByVal modify_type As eManualFillUpdateType _
)

Parameters

cqg_manual_fill

Specifies the changed manual fill instance, represented as CQGManualFill

modify_type
Value Description
mfutAdd

Add manual fill.

mfutDelete

Remove manual fill.

mfutModify

Change manual fill.

Manual fills update type

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

ManualFillsResolved Event
cqg_manual_fills

Specifies the collection of manual fills.

If an error has occurred, the collection is empty.

cqg_error

Specifies the CQGError object describing the last error occurred during the processing of manual fills request or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

CQGCEL Interface : ManualFillsResolved Event

Glossary Item Box

Description

This event is fired when the list of manual fills request is resolved or when some error has occurred during manual fills request processing.

Syntax

Visual Basic
Public Event ManualFillsResolved( _
   ByVal cqg_manual_fills As CQGManualFills, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_manual_fills

Specifies the collection of manual fills.

If an error has occurred, the collection is empty.

cqg_error

Specifies the CQGError object describing the last error occurred during the processing of manual fills request or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

ManualFillUpdateResolved Event
cqg_manual_fill_request

Specifies the corresponding CQGManualFillRequest object.

cqg_error

Specifies the CQGError object describing the last error occurred during the processing of manual fills request or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

CQGCEL Interface : ManualFillUpdateResolved Event

Glossary Item Box

Description

This event is fired when the manual fill request is resolved or when some error has occurred during manual fills processing.

Syntax

Visual Basic
Public Event ManualFillUpdateResolved( _
   ByVal cqg_manual_fill_request As CQGManualFillRequest, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_manual_fill_request

Specifies the corresponding CQGManualFillRequest object.

cqg_error

Specifies the CQGError object describing the last error occurred during the processing of manual fills request or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

Remarks

  • If this event is a response to an addition request, the returned request object is already modified to include the TradeId of the added manual object.
  • When the requested manual fill is executed, it will be announced through the CQGCEL.ManualFillChanged.

See Also

CQGCEL Interface | CQGCEL Members | CQGCEL.IsValid Method


%%PageItemTitle%%

Obsolete104 Event
CQGCEL Interface : Obsolete104 Event

Glossary Item Box

Description

Obsolete method

Syntax

Visual Basic
Public Event Obsolete104()

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

Obsolete105 Event
CQGCEL Interface : Obsolete105 Event

Glossary Item Box

Description

Obsolete method

Syntax

Visual Basic
Public Event Obsolete105()

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

Obsolete106 Event
CQGCEL Interface : Obsolete106 Event

Glossary Item Box

Description

Obsolete method

Syntax

Visual Basic
Public Event Obsolete106()

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

Obsolete107 Event
CQGCEL Interface : Obsolete107 Event

Glossary Item Box

Description

Obsolete method

Syntax

Visual Basic
Public Event Obsolete107()

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

Obsolete108 Event
CQGCEL Interface : Obsolete108 Event

Glossary Item Box

Description

Obsolete method

Syntax

Visual Basic
Public Event Obsolete108()

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

OnIdle Event
CQGCEL Interface : OnIdle Event

Glossary Item Box

Description

This event is fired when CQGCEL has nothing to do.

Syntax

Visual Basic
Public Event OnIdle()

Remarks

The application may consider using OnIdle to update the UI or call DoEvents to propagate pending Excel UI events. It is especially useful when the host application is Excel.
Note that this event is fired, even when IsReady returns that Excel is not ready.

Example

See implementation of CQGCEL event handlers in CQGCEL Example.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

OnQueryProgress Event
cqg_orders_query

The CQGOrdersQuery object, to which the change refers.

This is the same object that was returned by QueryOrders

cqg_error

CQGError object representing the last error occurred, while processing this order query.

If no error has occurred, the parameter value is either Nothing or invalid error object depending on the UsedFromATLClient setting of the configuration.

The parameter can be checked for validity via the CQGCEL.IsValid method.

CQGCEL Interface : OnQueryProgress Event

Glossary Item Box

Description

This event is fired if a query has some progress: either new results arrived or its status is changed.

Syntax

Visual Basic
Public Event OnQueryProgress( _
   ByVal cqg_orders_query As CQGOrdersQuery, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_orders_query

The CQGOrdersQuery object, to which the change refers.

This is the same object that was returned by QueryOrders

cqg_error

CQGError object representing the last error occurred, while processing this order query.

If no error has occurred, the parameter value is either Nothing or invalid error object depending on the UsedFromATLClient setting of the configuration.

The parameter can be checked for validity via the CQGCEL.IsValid method.

Remarks

The results of a query are received via this event. There may be more than one event due to the fact that results can be sent via more than one chunk of orders.

Results are represented as CQGOrders collection available in Orders property of CQGOrdersQuery object.

If the results were sent via more than one chunk the last arrived chunk is available from LastChunk property and also all previously received chunks, including the last one, are already added to the Orders collection of current query.

Example

The examples below show how to query orders via CQG API.

VB
C#
Option Explicit
Private WithEvents cel As CQGCEL
Private ReadyFlagExists As Boolean

' Called when workbook is opened
Private Sub Workbook_Open()
    ' Create CQG API instance
    Set cel = New CQGCEL
    ' Configure it
    cel.APIConfiguration.CollectionsThrowException = False
    cel.APIConfiguration.DefPositionSubscriptionLevel = pslSnapshotAndUpdates
    cel.APIConfiguration.NewInstrumentChangeMode = True
    cel.APIConfiguration.PositionDetailing = pdAllTrades
    cel.APIConfiguration.PriceMode = pmTradesOnly
    cel.APIConfiguration.UseOrderSide = False
    cel.Startup
    'Check if ready flag exists in excel
    Dim ExcelMajorVersion As Integer
    ExcelMajorVersion = CInt(Left$(Application.Version, InStr(Application.Version, ".") - 1))
    If ExcelMajorVersion > 9 Then ' Excel 2002 and higher
        ReadyFlagExists = True
    Else
        ReadyFlagExists = False
    End If
End Sub
' Called before workbook is going to be closed
Private Sub Workbook_BeforeClose(Cancel As Boolean)
    cel.Shutdown
    Set cel = Nothing
End Sub
' CQG API event handlers
Private Sub cel_GWConnectionStatusChanged(ByVal newStatus As CQG.eConnectionStatus)
    Dim status As String
    Select Case newStatus
        Case csConnectionDelayed
            status = "Delayed"
        Case csConnectionDown
            status = "Down"
        Case csConnectionUp
            status = "Up"
            ' Request accounts and orders functionality
            cel.AccountSubscriptionLevel = aslAccountUpdatesAndOrders
    End Select
    Debug.Print "GW Connection Status changed to " + status
End Sub
Private Sub cel_AccountChanged(ByVal change As CQG.eAccountChangeType, ByVal Account As CQG.ICQGAccount, ByVal position As CQG.ICQGPosition)
    ' Request instument
    If change = actAccountsReloaded Then cel.NewInstrument "EP"
End Sub
Private Sub cel_InstrumentSubscribed(ByVal symbl As String, ByVal Instrument As CQG.ICQGInstrument)
    ' EP subscribed, let's request all working orders on EP, placed on all accounts
    Dim query As CQGOrdersQuery
    Dim acc As CQGAccount
    For Each acc In cel.Accounts
        Set query = cel.QueryOrders(acc, Instrument, osfNotFinal)
        Debug.Print "Not final orders are requested for account " & acc.GWAccountName
    Next
End Sub
Private Sub cel_OnQueryProgress(ByVal query As CQG.ICQGOrdersQuery, ByVal Error As CQG.ICQGError)
    ' We have a chunk of requested historical orders
    Debug.Print "Orders chunk for query " & query.QueryID & " received."
    Dim order As CQGOrder
    For Each order In query.LastChunk
        Debug.Print " GW Account Name = " & order.Account.GWAccountName
        Debug.Print " Is Final - " & order.IsFinal
        Debug.Print " Instrument Name - " & order.InstrumentName
        Debug.Print " Quantity - " & order.Quantity
    Next
    If query.status = rsInProgress Then
        Debug.Print "Waiting for next chunk"
    ElseIf query.status = rsSuccess Then
        Debug.Print "No more chunks for this query"
    End If
End Sub
Private Sub cel_IsReady(readyStatus As CQG.eReadyStatus)
    If ReadyFlagExists Then ' Excel 2002 and higher
        ' ready status should reflect Application.Ready value
        readyStatus = IIf(Application.Ready, rsReady, rsNotReady)
    Else
        readyStatus = rsReady
    End If
End Sub
Private Sub cel_DataError(ByVal obj As Object, ByVal errorDescription As String)
    Dim fullErr As String
    If TypeName(obj.Owner) = "CQGOrdersQuery" Then
        Dim query As CQGOrdersQuery
        Set query = obj.Owner
        fullErr = "Query " + query.QueryID + " failed, "
    End If
    fullErr = fullErr + errorDescription
    MsgBox fullErr
    ' Terminate application
    Close
End Sub
using System;
using System.Runtime.InteropServices;
using CQG;

namespace Sample
{
    class OrdersQuerySample : IDisposable
    {
        // CQGCEL instance declaration.
        private CQGCEL cel = new CQGCELClass();

        // Used to determine is the object manualy disposed.
        private bool disposed = false;

        public OrdersQuerySample()
        {
            // Initialize CQGCEL instance.
            try
            {
                // Configure CEL.
                cel.APIConfiguration.ReadyStatusCheck = eReadyStatusCheck.rscOff;
                cel.APIConfiguration.CollectionsThrowException = false;
                cel.APIConfiguration.DefPositionSubscriptionLevel = ePositionSubscriptionLevel.pslSnapshotAndUpdates;
                cel.APIConfiguration.NewInstrumentChangeMode = true;
                cel.APIConfiguration.PositionDetailing = ePositionDetailing.pdAllTrades;
                cel.APIConfiguration.PriceMode = ePriceMode.pmTradesOnly;
                cel.APIConfiguration.UseOrderSide = false;

                // Register to CEL's events.
                cel.CELStarted += new _ICQGCELEvents_CELStartedEventHandler(cel_CELStarted);
                cel.DataError += new _ICQGCELEvents_DataErrorEventHandler(cel_DataError);
                cel.GWConnectionStatusChanged += new _ICQGCELEvents_GWConnectionStatusChangedEventHandler(cel_GWConnectionStatusChanged);
                cel.InstrumentSubscribed += new _ICQGCELEvents_InstrumentSubscribedEventHandler(cel_InstrumentSubscribed);
                cel.AccountChanged += new _ICQGCELEvents_AccountChangedEventHandler(cel_AccountChanged);
                cel.OnQueryProgress += new _ICQGCELEvents_OnQueryProgressEventHandler(cel_OnQueryProgress);

                cel.Startup();
            }
            catch (COMException ex)
            {
                Console.WriteLine("Error occurred during CEL initialization. {0}", ex.Message);
            }
        }

        ~OrdersQuerySample()
        {
            Dispose(false);
        }

        #region CEL Event Handlers

        void cel_CELStarted()
        {
            // Everything is OK with enablements.
            Console.WriteLine("CEL Version : {0}", cel.Environment.CELVersion);
        }

        void cel_DataError(object obj, string errorDescription)
        {
            // Some error occurred.
            string fullErr = "";
            CQGError objErr = (CQGError)obj;

            if (objErr.Owner.GetType().Name == "CQGOrdersQuery")
            {
                CQGOrdersQuery query = (CQGOrdersQuery)objErr.Owner;
                fullErr = "Query " + query.QueryID + " failed, ";
            }
            fullErr = fullErr + errorDescription;
            Console.WriteLine(fullErr);

            cel.Logger.Log("ERROR : " + errorDescription, eLogSeverity.lsError);

            // Terminate application.
            System.Windows.Forms.Application.Exit();
        }

        void cel_GWConnectionStatusChanged(eConnectionStatus newStatus)
        {
            string status;

            switch (newStatus)
            {
                case eConnectionStatus.csConnectionDelayed:
                    status = "Delayed";

                    break;
                case eConnectionStatus.csConnectionDown:
                    status = "Down";

                    break;
                case eConnectionStatus.csConnectionUp:
                    status = "Up";

                    // Request accounts and orders functionality.
                    cel.AccountSubscriptionLevel = eAccountSubscriptionLevel.aslAccountsAndUpdates;

                    break;
                default:
                    status = "Unknown";

                    break;
            }

            Console.WriteLine("GW Connection Status changed to " + status);
        }

        void cel_InstrumentSubscribed(string symbl, CQGInstrument Instrument)
        {
            // EP subscribed, let's request all working orders on EP, placed on all accounts.
            CQGOrdersQuery query;
            foreach (CQGAccount acc in cel.Accounts)
            {
                query = cel.QueryOrders(acc, Instrument, eOrderStatusFilter.osfNotFinal, DateTime.MinValue , eOrderSide.osdUndefined);
                Console.WriteLine("Not final orders are requested for account {0}", acc.GWAccountName);
            }
        }

        void cel_AccountChanged(eAccountChangeType change, CQGAccount Account, CQGPosition position)
        {
            // Request instument.
            if (change == eAccountChangeType.actAccountsReloaded)
            {
                cel.NewInstrument("EP");
            }
        }

        void cel_OnQueryProgress(CQGOrdersQuery query, CQGError error)
        {
            // We have a chunk of requested historical orders.
            Console.WriteLine("Orders chunk for query {0} received.", query.QueryID);
            foreach (CQGOrder order in query.LastChunk)
            {
                Console.WriteLine("GW Account Name - {0}", order.Account.GWAccountName);
                Console.WriteLine("Is Final - {0}", order.IsFinal);
                Console.WriteLine("Instrument Name - {0}", order.InstrumentName);
                Console.WriteLine("Quantity - {0}", order.Quantity);
            }

            if (query.Status == eRequestStatus.rsInProgress)
            {
                Console.WriteLine("Waiting for the next chunk.");
            }
            else if(query.Status == eRequestStatus.rsSuccess)
            {
                Console.WriteLine("No more chunks for this query.");
            }
        }

        #endregion

        #region IDisposable Members

        public void Dispose()
        {
            Dispose(true);

            GC.SuppressFinalize(this);
        }

        #endregion

        #region Private Methods

        private void Dispose(bool disposing)
        {
            // Check to see if Dispose has already been called.
            if (!this.disposed)
            {
                // If disposing equals true, dispose all managed
                // and unmanaged resources.
                if (disposing)
                {
                    // Dispose managed resources.
                }

                // If disposing is false,
                // only the following code is executed.
                cel.Shutdown();
            }
            disposed = true;
        }

        #endregion

        [STAThread]
        static void Main(string[] args)
        {
            OrdersQuerySample test = new OrdersQuerySample();

            // Start Application. Will work until some error occurred.
            System.Windows.Forms.Application.Run();
        }
    }
}

See Also

CQGCEL Interface | CQGCEL Members | CQGOrdersQuery Interface | CQGOrders Collection | CQGCEL.QueryOrders Method


%%PageItemTitle%%

OrderChanged Event
change_type

The type of the occurred change.

The actual change can be traced through LastEvent property of the order.

cqg_order

CQGOrder object representing the order to which the change refers.

old_properties
CQGOrderProperties collection representing old values of all order properties.
cqg_fill

CQGFill object representing the last fill of the order, i.e. the last item of order's Fills collection.

If there was no fill, Nothing or invalid fill object is passed depending on the UsedFromATLClient setting of the configuration.

cqg_error

CQGError object representing either an error sent by CQG Gateway or an intermediate error. If the error is final the same instance of CQGError will be set to order's LastError property.

If no error has occurred, the parameter value is either Nothing or invalid error object depending on the UsedFromATLClient setting of the configuration.

The parameter can be checked for validity via the CQGCEL.IsValid method.

CQGCEL Interface : OrderChanged Event

Glossary Item Box

Description

This event is fired when a new order is added to the collection, the order status is changed, or the order is removed from the collection.

Syntax

Visual Basic
Public Event OrderChanged( _
   ByVal change_type As eChangeType, _
   ByVal cqg_order As CQGOrder, _
   ByVal old_properties As CQGOrderProperties, _
   ByVal cqg_fill As CQGFill, _
   ByVal cqg_error As CQGError _
)

Parameters

change_type
Value | Description
ctAdded | New order is added and is already in the collection.
ctChanged | The order is changed.
ctRemoved | The order is removed from the collection.

The type of the occurred change.

The actual change can be traced through LastEvent property of the order.

cqg_order

CQGOrder object representing the order to which the change refers.

old_properties
CQGOrderProperties collection representing old values of all order properties.
cqg_fill

CQGFill object representing the last fill of the order, i.e. the last item of order's Fills collection.

If there was no fill, Nothing or invalid fill object is passed depending on the UsedFromATLClient setting of the configuration.

cqg_error

CQGError object representing either an error sent by CQG Gateway or an intermediate error. If the error is final the same instance of CQGError will be set to order's LastError property.

If no error has occurred, the parameter value is either Nothing or invalid error object depending on the UsedFromATLClient setting of the configuration.

The parameter can be checked for validity via the CQGCEL.IsValid method.

Remarks

In order to receive order events the AccountSubscriptionLevel property of CQGCEL should be set to aslAccountUpdatesAndOrders.

Example

The examples below show how to place orders via CQG API.

VB
C#
Option Explicit
Private WithEvents cel As CQGCEL
Private ReadyFlagExists As Boolean

' Called when workbook is opened
Private Sub Workbook_Open()
    ' Create CQG API instance
    Set cel = New CQGCEL
    ' Configure it
    cel.APIConfiguration.CollectionsThrowException = False
    cel.APIConfiguration.DefPositionSubscriptionLevel = pslSnapshotAndUpdates
    cel.APIConfiguration.UseOrderSide = True
    cel.Startup
    'Check if ready flag exists in excel
    Dim ExcelMajorVersion As Integer
    ExcelMajorVersion = CInt(Left$(Application.Version, InStr(Application.Version, ".") - 1))
    If ExcelMajorVersion > 9 Then ' Excel 2002 and higher
        ReadyFlagExists = True
    Else
        ReadyFlagExists = False
    End If
End Sub
' Called before workbook is going to be closed
Private Sub Workbook_BeforeClose(Cancel As Boolean)
    cel.Shutdown
    Set cel = Nothing
End Sub
' CQG API event handlers
Private Sub cel_GWConnectionStatusChanged(ByVal newStatus As CQG.eConnectionStatus)
    Dim status As String
    Select Case newStatus
        Case csConnectionDelayed
            status = "Delayed"
        Case csConnectionDown
            status = "Down"
        Case csConnectionUp
            status = "Up"
            ' Request accounts and orders functionality
            cel.AccountSubscriptionLevel = aslAccountUpdatesAndOrders
    End Select
    Debug.Print "GW Connection Status changed to " + status
End Sub
Private Sub cel_AccountChanged(ByVal change As CQG.eAccountChangeType, ByVal account As CQG.ICQGAccount, ByVal position As CQG.ICQGPosition)
    ' Request instument
    If change = actAccountsReloaded Then cel.NewInstrument "EP"
End Sub
Private Sub cel_InstrumentSubscribed(ByVal symbl As String, ByVal instrument As CQG.ICQGInstrument)
    ' EP subscribed, let's place single parked market order on EP for each account
    Dim Order As CQGOrder
    Dim acc As CQGAccount
    Dim qty As Long
    Dim isParked As Boolean
    qty = 1
    isParked = True
    For Each acc In cel.Accounts
        Set Order = cel.CreateOrder(eOrderType.otMarket, instrument, acc, qty, eOrderSide.osdBuy, _
                                    ueNamePart:="Mine #" & qty)
        If isParked Then
            Order.Properties(opParked).Value = True
            Debug.Print "Parked market order is created for " & acc.GWAccountName & " account"
        Else
            Debug.Print "Market order is created for " & acc.GWAccountName & " account"
        End If
        Debug.Print "Instrument - " & instrument.FullName
        Debug.Print "Quantity - " & qty
        Order.Place
        Debug.Print "Order " & Order.UEName & " is placed"
        qty = qty + 1
        isParked = Not isParked
    Next
End Sub
Private Sub cel_OrderChanged(ByVal change As CQG.eChangeType, ByVal Order As CQG.ICQGOrder, _
                             ByVal oldProperties As CQG.ICQGOrderProperties, ByVal fill As CQG.ICQGFill, _
                             ByVal objError As CQG.ICQGError)
        If Not objError Is Nothing Then
            Debug.Print "An error occured while processing the order " & Order.GWOrderID & ": " _
                        & objError.Description
        End If
        Select Case change
        Case eChangeType.ctAdded
            Debug.Print "Order " & Order.GWOrderID & " is added."
            PrintOrder Order, fill
        Case eChangeType.ctChanged
            PrintOrder Order, fill
        Case Else
            Debug.Print "Order " & Order.GWOrderID & " is removed."
        End Select
End Sub
Private Sub cel_IsReady(readyStatus As CQG.eReadyStatus)
    If ReadyFlagExists Then ' Excel 2002 and higher
        ' ready status should reflect Application.Ready value
        readyStatus = IIf(Application.Ready, rsReady, rsNotReady)
    Else
        readyStatus = rsReady
    End If
End Sub
Private Sub cel_DataError(ByVal obj As Object, ByVal errorDescription As String)
    ' Print the error description
    MsgBox obj.Description
    ' Terminate application
    Close
End Sub
' Represents Order Gateway Status as String
Public Function OrderStatusToString(orderState As eOrderStatus) As String
    Select Case orderState
        Case eOrderStatus.osActiveAt
            OrderStatusToString = "ActiveAt"
        Case eOrderStatus.osBusted
             OrderStatusToString = "Busted"
        Case eOrderStatus.osCanceled
             OrderStatusToString = "Canceled"
        Case eOrderStatus.osContingent
            OrderStatusToString = "Contingent"
        Case eOrderStatus.osDisconnected
             OrderStatusToString = "Disconnected"
        Case eOrderStatus.osExpired
             OrderStatusToString = "Expired"
        Case eOrderStatus.osFilled
            OrderStatusToString = "Filled"
        Case eOrderStatus.osInCancel
             OrderStatusToString = "InCancel"
        Case eOrderStatus.osInClient
             OrderStatusToString = "InClient"
        Case eOrderStatus.osInModify
            OrderStatusToString = "InModify"
        Case eOrderStatus.osInOrderBook
             OrderStatusToString = "InOrderBook"
        Case eOrderStatus.osInTransit
             OrderStatusToString = "InTransit"
        Case eOrderStatus.osInTransitTimeout
            OrderStatusToString = "InTransitTimeout"
        Case eOrderStatus.osNotSent
             OrderStatusToString = "NotSent"
        Case eOrderStatus.osParked
             OrderStatusToString = "Parked"
        Case eOrderStatus.osRejectFCM
            OrderStatusToString = "RejectFCM"
        Case eOrderStatus.osRejectGW
             OrderStatusToString = "RejectGW"
    End Select
End Function
' Prints order information in Debug window
Private Sub PrintOrder(Order As CQG.ICQGOrder, ByVal fill As CQG.ICQGFill)
        Debug.Print "Order " & Order.GWOrderID & ":"
        Debug.Print "Status - " & OrderStatusToString(Order.GWStatus)
        Debug.Print "Account - " & Order.account.GWAccountName
        Debug.Print "Instrument - " & Order.InstrumentName
        Debug.Print "Order Side - " & IIf(Order.Side = osdBuy, "Buy", "Sell")
        Debug.Print "Quantity - " & Order.quantity
        Debug.Print "Filled Quantity - " & Order.FilledQuantity
        Debug.Print "Place Time - " & Order.PlaceTime
        If fill Is Nothing Then
            ' Order hasn't filled yet.
            Debug.Print "Current Fill Price - N/A"
        Else
            ' Order is filled.
            Debug.Print "Current Fill Price - " & fill.Price
        End If
End Sub
using System;
using System.Runtime.InteropServices;
using CQG;

namespace Sample
{
    class OrdersPlacingSample : IDisposable
    {
        // CQGCEL instance declaration.
        private CQGCEL cel = new CQGCELClass();

        // Used to determine is the object manualy disposed.
        private bool disposed = false;

        public OrdersPlacingSample()
        {
            // Initialize CQGCEL instance.
            try
            {
                // Configure CEL.
                cel.APIConfiguration.ReadyStatusCheck = eReadyStatusCheck.rscOff;
                cel.APIConfiguration.CollectionsThrowException = false;
                cel.APIConfiguration.DefPositionSubscriptionLevel = ePositionSubscriptionLevel.pslSnapshotAndUpdates;
                cel.APIConfiguration.UseOrderSide = true;

                // Register to CEL's events.
                cel.CELStarted += new _ICQGCELEvents_CELStartedEventHandler(cel_CELStarted);
                cel.DataError += new _ICQGCELEvents_DataErrorEventHandler(cel_DataError);
                cel.GWConnectionStatusChanged += new _ICQGCELEvents_GWConnectionStatusChangedEventHandler(cel_GWConnectionStatusChanged);
                cel.InstrumentSubscribed += new _ICQGCELEvents_InstrumentSubscribedEventHandler(cel_InstrumentSubscribed);
                cel.AccountChanged += new _ICQGCELEvents_AccountChangedEventHandler(cel_AccountChanged);
                cel.OrderChanged += new _ICQGCELEvents_OrderChangedEventHandler(cel_OrderChanged);

                cel.Startup();
            }
            catch (COMException ex)
            {
                Console.WriteLine("Error occurred during CEL initialization. {0}", ex.Message);
            }
        }

        ~OrdersPlacingSample()
        {
            Dispose(false);
        }

        #region CEL Event Handlers

        void cel_CELStarted()
        {
            // Everything is OK with enablements.
            Console.WriteLine("CEL Version : {0}", cel.Environment.CELVersion);
        }

        void cel_DataError(object obj, string errorDescription)
        {
            // Some error occurred.
            cel.Logger.Log("ERROR : " + errorDescription, eLogSeverity.lsError);

            // Terminate application.
            System.Windows.Forms.Application.Exit();
        }

        void cel_GWConnectionStatusChanged(eConnectionStatus newStatus)
        {
            string status;
            switch (newStatus)
            {
                case eConnectionStatus.csConnectionDelayed:
                    status = "Delayed";

                    break;
                case eConnectionStatus.csConnectionDown:
                    status = "Down";

                    break;
                case eConnectionStatus.csConnectionUp:
                    status = "Up";

                    // Request accounts and orders functionality.
                    cel.AccountSubscriptionLevel = eAccountSubscriptionLevel.aslAccountUpdatesAndOrders;

                    break;
                default:
                    status = "Unknown";

                    break;
            }

            Console.WriteLine("GW Connection Status changed to " + status);
        }

        void cel_InstrumentSubscribed(string symbl, CQGInstrument Instrument)
        {
            // EP subscribed, let's place single parked market order on EP for each account.
            CQGOrder order;
            int qty = 1;
            bool isParked = true;

            foreach (CQGAccount acc in cel.Accounts)
            {
                order = cel.CreateOrder(eOrderType.otMarket, Instrument, acc, qty, eOrderSide.osdBuy, 0, 0, "Mine #" + qty);

                if (isParked)
                {
                    order.Properties[eOrderProperty.opParked].Value = true;
                    Console.WriteLine("Parked marked order is created for {0} account", acc.GWAccountName);
                }
                else
                {
                    Console.WriteLine("Marked order is created for {0} account", acc.GWAccountName);
                }
                Console.WriteLine("Instrument - {0}", Instrument.FullName);
                Console.WriteLine("Quantity - {0}", qty);
                Console.WriteLine("Side - Buy");

                order.Place();

                Console.WriteLine("Order {0} is placed.", order.UEName);
                qty = qty + 1;
                isParked = !isParked;
            }

            Console.WriteLine("There is a position on " + Instrument.FullName + ". Now the instrument is subscribed.");
        }

        void cel_AccountChanged(eAccountChangeType change, CQGAccount Account, CQGPosition position)
        {
            // Request instument.
            if (change == eAccountChangeType.actAccountsReloaded)
            {
                cel.NewInstrument("EP");
            }
        }

        void cel_OrderChanged(eChangeType change, CQGOrder Order, CQGOrderProperties oldProperties, CQGFill fill, CQGError objError)
        {
            if (objError != null)
            {
                Console.WriteLine("An error occured while processing the order {0} : {1}", Order, objError.Description);
            }

            switch (change)
            {
                case eChangeType.ctAdded:
                    Console.WriteLine("Order {0} is added.", Order.GWOrderID);

                    break;
                case eChangeType.ctChanged:
                    PrintOrder(Order, fill);

                    break;
                case eChangeType.ctRemoved:
                    Console.WriteLine("Order {0} is removed.", Order.GWOrderID);

                    break;
                default:
                    Console.WriteLine("Order {0} change is unknown.", Order.GWOrderID);

                    break;
            }
        }

        #endregion

        #region IDisposable Members

        public void Dispose()
        {
            Dispose(true);

            GC.SuppressFinalize(this);
        }

        #endregion

        #region Private Methods

        private void Dispose(bool disposing)
        {
            // Check to see if Dispose has already been called.
            if (!this.disposed)
            {
                // If disposing equals true, dispose all managed
                // and unmanaged resources.
                if (disposing)
                {
                    // Dispose managed resources.
                }

                // If disposing is false,
                // only the following code is executed.
                cel.Shutdown();
            }
            disposed = true;
        }

        private void PrintOrder(CQGOrder order, CQGFill fill)
        {
            Console.WriteLine("Order {0} :", order.GWOrderID);
            Console.WriteLine("Status - {0}", OrderStatusToString(order.GWStatus));
            Console.WriteLine("Account - {0}", order.Account.GWAccountName);
            Console.WriteLine("Instrument - {0}", order.InstrumentName);
            Console.WriteLine("Order Side - {0}", order.Side == eOrderSide.osdBuy ? "Buy" : "Sell");
            Console.WriteLine("Quantity - {0}", order.Quantity);
            Console.WriteLine("Filled Quantity - {0}", order.FilledQuantity);
            Console.WriteLine("Place Time - {0}", order.PlaceTime);
            Console.WriteLine("Current Fill Price - {0}", fill == null ? "N/A" : fill.get_Price(0).ToString());
        }

        private string OrderStatusToString(eOrderStatus orderStatus)
        {
            switch (orderStatus)
            {
                case eOrderStatus.osActiveAt:
                    return "ActiveAt";

                case eOrderStatus.osBusted:
                    return "Busted";

                case eOrderStatus.osCanceled:
                    return "Canceled";

                case eOrderStatus.osContingent:
                    return "Contingent";

                case eOrderStatus.osDisconnected:
                    return "Disconnected";

                case eOrderStatus.osExpired:
                    return "Expired";

                case eOrderStatus.osFilled:
                    return "Filled";

                case eOrderStatus.osInCancel:
                    return "InCancel";

                case eOrderStatus.osInClient:
                    return "InClient";

                case eOrderStatus.osInModify:
                    return "InModify";

                case eOrderStatus.osInOrderBook:
                    return "InOrderBook";

                case eOrderStatus.osInTransit:
                    return "InTransit";

                case eOrderStatus.osInTransitTimeout:
                    return "InTransitTimeout";

                case eOrderStatus.osNotSent:
                    return "NotSent";

                case eOrderStatus.osParked:
                    return "Parked";

                case eOrderStatus.osRejectFCM:
                    return "RejectFCM";

                case eOrderStatus.osRejectGW:
                    return "RejectGW";

                default:
                    return "Unknown";
            }
        }

        #endregion

        [STAThread]
        static void Main(string[] args)
        {
            OrdersPlacingSample test = new OrdersPlacingSample();
            // Start Application. Will work until some error occurred.
            System.Windows.Forms.Application.Run();
        }
    }
}

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

PasswordChanged Event
request_status
Change password request status
cqg_error
CQGError object describing last error occurred during authentication process or Nothing/Invalid_Error in case of no error. CQGCEL.IsValid(Invalid_Error) returns False.
CQGCEL Interface : PasswordChanged Event

Glossary Item Box

Description

Fired when remote API client change password request is resolved

Syntax

Visual Basic
Public Event PasswordChanged( _
   ByVal request_status As eSessionStatus, _
   ByVal cqg_error As CQGError _
)

Parameters

request_status
Value | Description
ssAlreadyLoggedIn | User is already logged in
ssAuthorizationFailed | User authorization failed
ssInternalSystemError | Internal error
ssNoAvailableDataServers | There were no available data servers for the client request
ssNoAvailableLoginService | Login service is not available
ssNoAvailableMetadataServers | There were no available metadata servers for the client request
ssNoAvailableROMNumbers | No ROM numbers are available in CQGT client pool for CQGT authentication request to succeed
ssNoRemoteAPIPermission | Client doesn't have enablement to access Remote API
ssNotAuthenticated | User is not authenticated
ssNotEnabled | Client is not enabled
ssSuccess | Successful result
Change password request status
cqg_error
CQGError object describing last error occurred during authentication process or Nothing/Invalid_Error in case of no error. CQGCEL.IsValid(Invalid_Error) returns False.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

PointAndFigureBarsAdded Event
cqg_point_and_figure_bars

Reference to the changed CQGPointAndFigureBars.

CQGCEL Interface : PointAndFigureBarsAdded Event

Glossary Item Box

Description

This event is fired when a CQGPointAndFigureBar item is added to the end of CQGPointAndFigureBars.

Syntax

Visual Basic
Public Event PointAndFigureBarsAdded( _
   ByVal cqg_point_and_figure_bars As CQGPointAndFigureBars _
)

Parameters

cqg_point_and_figure_bars

Reference to the changed CQGPointAndFigureBars.

See Also

CQGCEL Interface | CQGCEL Members | CQGConstantVolumeBar Interface | CQGConstantVolumeBars Collection


%%PageItemTitle%%

PointAndFigureBarsInserted Event
cqg_point_and_figure_bars

Reference to the CQGPointAndFigureBars collection the point and figure bar is inserted to

index_

Specifies the inserted CQGPointAndFigureBar's index

CQGCEL Interface : PointAndFigureBarsInserted Event

Glossary Item Box

Description

This event is fired when a CQGPointAndFigureBar item is inserted to the CQGPointAndFigureBars collection.

Syntax

Visual Basic
Public Event PointAndFigureBarsInserted( _
   ByVal cqg_point_and_figure_bars As CQGPointAndFigureBars, _
   ByVal index_ As Long _
)

Parameters

cqg_point_and_figure_bars

Reference to the CQGPointAndFigureBars collection the point and figure bar is inserted to

index_

Specifies the inserted CQGPointAndFigureBar's index

See Also

CQGCEL Interface | CQGCEL Members | CQGConstantVolumeBars Collection | CQGConstantVolumeBar Interface


%%PageItemTitle%%

PointAndFigureBarsRemoved Event
cqg_point_and_figure_bars

Reference to the CQGPointAndFigureBars collection the point and figure bar is removed from

index_

Specifies the removed CQGPointAndFigureBar's index

CQGCEL Interface : PointAndFigureBarsRemoved Event

Glossary Item Box

Description

This event is fired when a CQGPointAndFigureBar item is removed from the CQGPointAndFigureBars collection.

Syntax

Visual Basic
Public Event PointAndFigureBarsRemoved( _
   ByVal cqg_point_and_figure_bars As CQGPointAndFigureBars, _
   ByVal index_ As Long _
)

Parameters

cqg_point_and_figure_bars

Reference to the CQGPointAndFigureBars collection the point and figure bar is removed from

index_

Specifies the removed CQGPointAndFigureBar's index

See Also

CQGCEL Interface | CQGCEL Members | CQGConstantVolumeBar Interface | CQGConstantVolumeBars Collection


%%PageItemTitle%%

PointAndFigureBarsResolved Event
cqg_point_and_figure_bars

Reference to the resolved CQGPointAndFigureBars

cqg_error
CQGError object describing the last error occurred during the point and figure bars request processing or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

CQGCEL Interface : PointAndFigureBarsResolved Event

Glossary Item Box

Description

This event is fired when the collection of point and figure bars (CQGPointAndFigureBars) is resolved or when some error has occurred during the point and figure bars request processing.

Syntax

Visual Basic
Public Event PointAndFigureBarsResolved( _
   ByVal cqg_point_and_figure_bars As CQGPointAndFigureBars, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_point_and_figure_bars

Reference to the resolved CQGPointAndFigureBars

cqg_error
CQGError object describing the last error occurred during the point and figure bars request processing or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

See Also

CQGCEL Interface | CQGCEL Members | CQGConstantVolumeBars Collection


%%PageItemTitle%%

PointAndFigureBarsUpdated Event
cqg_point_and_figure_bars

Reference to the changed CQGPointAndFigureBars

index_

Specifies the updated CQGPointAndFigureBar index

CQGCEL Interface : PointAndFigureBarsUpdated Event

Glossary Item Box

Description

This event is fired when the CQGPointAndFigureBar item is updated.

Syntax

Visual Basic
Public Event PointAndFigureBarsUpdated( _
   ByVal cqg_point_and_figure_bars As CQGPointAndFigureBars, _
   ByVal index_ As Long _
)

Parameters

cqg_point_and_figure_bars

Reference to the changed CQGPointAndFigureBars

index_

Specifies the updated CQGPointAndFigureBar index

See Also

CQGCEL Interface | CQGCEL Members | CQGConstantVolumeBar Interface | CQGConstantVolumeBars Collection


%%PageItemTitle%%

PositionsStatementResolved Event
cqg_positions_statement

Reference to the resolved CQGPositionsStatement

cqg_error

CQGError object describing the last error occurred while processing the positions statement request or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

CQGCEL Interface : PositionsStatementResolved Event

Glossary Item Box

Description

This event is fired when the positions statement (CQGPositionsStatement) is resolved or when some error has occurred while processing the positions statement request.

Syntax

Visual Basic
Public Event PositionsStatementResolved( _
   ByVal cqg_positions_statement As CQGPositionsStatement, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_positions_statement

Reference to the resolved CQGPositionsStatement

cqg_error

CQGError object describing the last error occurred while processing the positions statement request or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

Remarks

Please, note that every CQGPosition from resolved CQGPositionsStatement will have invalid values in all current price dependent members (MVO, OTE, ProfitLoss and UPL) since QueryPositionsStatement does not make instrument subscription internally.

Read about CQGAccount's AutoSubscribeInstruments property to see how to request positions with valid MVO, OTE, ProfitLoss and UPL values.

See Also

CQGCEL Interface | CQGCEL Members | CQGPositionsStatement Interface


%%PageItemTitle%%

QFormulaCreated Event
cqg_qformula_name
QFormula name that was passed as parameter of CreateQFormula request.
cqg_qformula_definition
Definition of created QFormula. Value is null in case if creation failed.
cqg_error

CQGError object, describing the last error occurred during processing request.

If no error has occurred, the parameter value is either Nothing or invalid error depending on the UsedFromATLClient setting of the configuration.

The parameter can be checked for validity via the CQGCEL.IsValid method.

CQGCEL Interface : QFormulaCreated Event

Glossary Item Box

Description

This event is fired when new QFormula is created or when some error has occurred during the request processing.

Syntax

Visual Basic
Public Event QFormulaCreated( _
   ByVal cqg_qformula_name As String, _
   ByVal cqg_qformula_definition As CQGQFormulaDefinition, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_qformula_name
QFormula name that was passed as parameter of CreateQFormula request.
cqg_qformula_definition
Definition of created QFormula. Value is null in case if creation failed.
cqg_error

CQGError object, describing the last error occurred during processing request.

If no error has occurred, the parameter value is either Nothing or invalid error depending on the UsedFromATLClient setting of the configuration.

The parameter can be checked for validity via the CQGCEL.IsValid method.

Remarks

Request is considered successful if cqg_qformula_definition is valid.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

QFormulaDefinitionResolved Event
cqg_qformula_definition
cqg_error
CQGCEL Interface : QFormulaDefinitionResolved Event

Glossary Item Box

Description

Obsolete. Please use QFormulaDefinitionResolvedEx instead.

Syntax

Visual Basic
Public Event QFormulaDefinitionResolved( _
   ByVal cqg_qformula_definition As CQGQFormulaDefinition, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_qformula_definition
cqg_error

See Also

CQGCEL Interface | CQGCEL Members | QFormulaDefinitionResolvedEx Event


%%PageItemTitle%%

QFormulaDefinitionResolvedEx Event
cqg_qformula_request_expr

Request parameter that was used by user in RequestQFormulaDefinition method.

cqg_qformula_definition

Resolved QFormula definition.

If error has occured, object is null.

cqg_error

CQGError object describing last error occurred during the request processing or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

CQGCEL Interface : QFormulaDefinitionResolvedEx Event

Glossary Item Box

Description

Fired when requested by name or number CQGQFormulaDefinition is resolved.

Syntax

Visual Basic
Public Event QFormulaDefinitionResolvedEx( _
   ByVal cqg_qformula_request_expr As String, _
   ByVal cqg_qformula_definition As CQGQFormulaDefinition, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_qformula_request_expr

Request parameter that was used by user in RequestQFormulaDefinition method.

cqg_qformula_definition

Resolved QFormula definition.

If error has occured, object is null.

cqg_error

CQGError object describing last error occurred during the request processing or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

Remarks

Event is fired on RequestFormulaDefinition request completion.

Note, cqg_qfomula_definition is valid only inside event, object will be disposed after event completion.

See Also

CQGCEL Interface | CQGCEL Members | RequestQFormulaDefinition Method


%%PageItemTitle%%

QFormulaDefinitionsResolved Event
cqg_qformula_definitions

Collection of QFormula definitions.

If an error has occurred, the collection is empty.

cqg_error

CQGError object describing last error occurred during the request processing or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

CQGCEL Interface : QFormulaDefinitionsResolved Event

Glossary Item Box

Description

This event is fired when the definitions of QFormulas are resolved or when some error has occurred during the request processing.

Syntax

Visual Basic
Public Event QFormulaDefinitionsResolved( _
   ByVal cqg_qformula_definitions As CQGQFormulaDefinitions, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_qformula_definitions

Collection of QFormula definitions.

If an error has occurred, the collection is empty.

cqg_error

CQGError object describing last error occurred during the request processing or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

See Also

CQGCEL Interface | CQGCEL Members | CQGQFormulaDefinitions Collection


%%PageItemTitle%%

QFormulaDeleted Event
cqg_qformula_name_or_number
Expression that was used to delete QFormula.
cqg_error

CQGError object, describing the last error occurred during processing request.

If no error has occurred, the parameter value is either Nothing or invalid error depending on the UsedFromATLClient setting of the configuration.

The parameter can be checked for validity via the CQGCEL.IsValid method.

CQGCEL Interface : QFormulaDeleted Event

Glossary Item Box

Description

This event is fired when QFormula is deleted or when some error has occurred during the request processing.

Syntax

Visual Basic
Public Event QFormulaDeleted( _
   ByVal cqg_qformula_name_or_number As String, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_qformula_name_or_number
Expression that was used to delete QFormula.
cqg_error

CQGError object, describing the last error occurred during processing request.

If no error has occurred, the parameter value is either Nothing or invalid error depending on the UsedFromATLClient setting of the configuration.

The parameter can be checked for validity via the CQGCEL.IsValid method.

Remarks

Request is considered successful if cqg_error is invalid.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RangeBarsAdded Event
cqg_range_bars

Reference to the changed CQGRangeBars

CQGCEL Interface : RangeBarsAdded Event

Glossary Item Box

Description

Fired when CQGRangeBar item is added to the end of CQGRangeBars

Syntax

Visual Basic
Public Event RangeBarsAdded( _
   ByVal cqg_range_bars As CQGRangeBars _
)

Parameters

cqg_range_bars

Reference to the changed CQGRangeBars

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RangeBarsInserted Event
cqg_range_bars

Reference to the CQGRangeBars collection the bar is inserted to

index_
Zero-based index of item in the collection
CQGCEL Interface : RangeBarsInserted Event

Glossary Item Box

Description

Fired when CQGRangeBar item is inserted

Syntax

Visual Basic
Public Event RangeBarsInserted( _
   ByVal cqg_range_bars As CQGRangeBars, _
   ByVal index_ As Long _
)

Parameters

cqg_range_bars

Reference to the CQGRangeBars collection the bar is inserted to

index_
Zero-based index of item in the collection

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RangeBarsRemoved Event
cqg_range_bars

Reference to the CQGRangeBars collection the bar is removed from

index_
Zero-based index of item in the collection
CQGCEL Interface : RangeBarsRemoved Event

Glossary Item Box

Description

Fired when CQGRangeBar item is removed

Syntax

Visual Basic
Public Event RangeBarsRemoved( _
   ByVal cqg_range_bars As CQGRangeBars, _
   ByVal index_ As Long _
)

Parameters

cqg_range_bars

Reference to the CQGRangeBars collection the bar is removed from

index_
Zero-based index of item in the collection

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RangeBarsResolved Event
cqg_range_bars

Reference to the resolved CQGRangeBars

cqg_error
CQGError object describing the last error occurred during the point and figure bars request processing or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False

CQGCEL Interface : RangeBarsResolved Event

Glossary Item Box

Description

Fired when the collection of range bars (CQGRangeBars) is resolved

Syntax

Visual Basic
Public Event RangeBarsResolved( _
   ByVal cqg_range_bars As CQGRangeBars, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_range_bars

Reference to the resolved CQGRangeBars

cqg_error
CQGError object describing the last error occurred during the point and figure bars request processing or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RangeBarsUpdated Event
cqg_range_bars

Reference to the changed CQGRangeBars

index_
Zero-based index of item in the collection
CQGCEL Interface : RangeBarsUpdated Event

Glossary Item Box

Description

Fired when CQGRangeBar item is updated

Syntax

Visual Basic
Public Event RangeBarsUpdated( _
   ByVal cqg_range_bars As CQGRangeBars, _
   ByVal index_ As Long _
)

Parameters

cqg_range_bars

Reference to the changed CQGRangeBars

index_
Zero-based index of item in the collection

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RenkoBarsAdded Event
cqg_renko_bars

Reference to the changed CQGRenkoBars

CQGCEL Interface : RenkoBarsAdded Event

Glossary Item Box

Description

Fired when CQGRenkoBar item is added to the end of CQGRenkoBars

Syntax

Visual Basic
Public Event RenkoBarsAdded( _
   ByVal cqg_renko_bars As CQGRenkoBars _
)

Parameters

cqg_renko_bars

Reference to the changed CQGRenkoBars

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RenkoBarsInserted Event
cqg_renko_bars

Reference to the CQGRenkoBars collection the bar is inserted to

index_
Zero-based index of item in the collection
CQGCEL Interface : RenkoBarsInserted Event

Glossary Item Box

Description

Fired when CQGRenkoBar item is inserted

Syntax

Visual Basic
Public Event RenkoBarsInserted( _
   ByVal cqg_renko_bars As CQGRenkoBars, _
   ByVal index_ As Long _
)

Parameters

cqg_renko_bars

Reference to the CQGRenkoBars collection the bar is inserted to

index_
Zero-based index of item in the collection

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RenkoBarsRemoved Event
cqg_renko_bars

Reference to the CQGRenkoBars collection the bar is removed from

index_
Zero-based index of item in the collection
CQGCEL Interface : RenkoBarsRemoved Event

Glossary Item Box

Description

Fired when CQGRenkoBar item is removed

Syntax

Visual Basic
Public Event RenkoBarsRemoved( _
   ByVal cqg_renko_bars As CQGRenkoBars, _
   ByVal index_ As Long _
)

Parameters

cqg_renko_bars

Reference to the CQGRenkoBars collection the bar is removed from

index_
Zero-based index of item in the collection

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RenkoBarsResolved Event
cqg_renko_bars

Reference to the resolved CQGRenkoBars

cqg_error

CQGError object describing the last error occurred during processing the Renko bars request or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

CQGCEL Interface : RenkoBarsResolved Event

Glossary Item Box

Description

Fired when the collection of renko bars (CQGRenkoBars) is resolved

Syntax

Visual Basic
Public Event RenkoBarsResolved( _
   ByVal cqg_renko_bars As CQGRenkoBars, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_renko_bars

Reference to the resolved CQGRenkoBars

cqg_error

CQGError object describing the last error occurred during processing the Renko bars request or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

RenkoBarsUpdated Event
cqg_renko_bars

Reference to the changed CQGRenkoBars

index_
Zero-based index of item in the collection
CQGCEL Interface : RenkoBarsUpdated Event

Glossary Item Box

Description

Fired when CQGRenkoBar item is updated

Syntax

Visual Basic
Public Event RenkoBarsUpdated( _
   ByVal cqg_renko_bars As CQGRenkoBars, _
   ByVal index_ As Long _
)

Parameters

cqg_renko_bars

Reference to the changed CQGRenkoBars

index_
Zero-based index of item in the collection

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

StrategyDefinitionProgress Event
cqg_definition

Reference to resolved CQGStrategyDefinition

cqg_error

CQGError object, describing the last error occurred during processing request.

If no error has occurred, the parameter value is either Nothing or invalid error depending on the UsedFromATLClient setting of the configuration.

The parameter can be checked for validity via the CQGCEL.IsValid method.

CQGCEL Interface : StrategyDefinitionProgress Event

Glossary Item Box

Description

This event is fired, when the strategy definition status is changed or when some error has occurred during the request processing.

Syntax

Visual Basic
Public Event StrategyDefinitionProgress( _
   ByVal cqg_definition As CQGStrategyDefinition, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_definition

Reference to resolved CQGStrategyDefinition

cqg_error

CQGError object, describing the last error occurred during processing request.

If no error has occurred, the parameter value is either Nothing or invalid error depending on the UsedFromATLClient setting of the configuration.

The parameter can be checked for validity via the CQGCEL.IsValid method.

See Also

CQGCEL Interface | CQGCEL Members | CQGStrategyDefinition Interface | CQGError Interface | CQGCEL.IsValid Method


%%PageItemTitle%%

StrategyQuoteRequestResolved Event
cqg_strategy_quote_request
Reference to resolved CQGStrategyQuoteRequest
result
The request result
cqg_error

CQGError object describing the last error occurred during processing the strategy quote request or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

CQGCEL Interface : StrategyQuoteRequestResolved Event

Glossary Item Box

Description

Fired when a quote request is completed with success/fail.

Syntax

Visual Basic
Public Event StrategyQuoteRequestResolved( _
   ByVal cqg_strategy_quote_request As CQGStrategyQuoteRequest, _
   ByVal result As Boolean, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_strategy_quote_request
Reference to resolved CQGStrategyQuoteRequest
result
The request result
cqg_error

CQGError object describing the last error occurred during processing the strategy quote request or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

SubMinuteBarsAdded Event
cqg_subminute_bars

Reference to the changed CQGSubMinuteBars

CQGCEL Interface : SubMinuteBarsAdded Event

Glossary Item Box

Description

This event is fired when a CQGSubMinuteBar item is added to the end of CQGSubMinuteBars.

Syntax

Visual Basic
Public Event SubMinuteBarsAdded( _
   ByVal cqg_subminute_bars As CQGSubMinuteBars _
)

Parameters

cqg_subminute_bars

Reference to the changed CQGSubMinuteBars

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

SubMinuteBarsInserted Event
cqg_subminute_bars

Reference to the CQGSubMinuteBars collection the sub minute bar is inserted to

index_

Specifies the inserted CQGSubMinuteBar's index

CQGCEL Interface : SubMinuteBarsInserted Event

Glossary Item Box

Description

This event is fired when a CQGSubMinuteBar item is inserted to the CQGSubMinuteBars collection.

Syntax

Visual Basic
Public Event SubMinuteBarsInserted( _
   ByVal cqg_subminute_bars As CQGSubMinuteBars, _
   ByVal index_ As Long _
)

Parameters

cqg_subminute_bars

Reference to the CQGSubMinuteBars collection the sub minute bar is inserted to

index_

Specifies the inserted CQGSubMinuteBar's index

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

SubMinuteBarsRemoved Event
cqg_subminute_bars

Reference to the CQGSubMinuteBars collection the sub minute bar is removed from

index_

Specifies the inserted CQGSubMinuteBar's index

CQGCEL Interface : SubMinuteBarsRemoved Event

Glossary Item Box

Description

This event is fired when a CQGSubMinuteBar item is removed from the CQGSubMinuteBars collection.

Syntax

Visual Basic
Public Event SubMinuteBarsRemoved( _
   ByVal cqg_subminute_bars As CQGSubMinuteBars, _
   ByVal index_ As Long _
)

Parameters

cqg_subminute_bars

Reference to the CQGSubMinuteBars collection the sub minute bar is removed from

index_

Specifies the inserted CQGSubMinuteBar's index

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

SubMinuteBarsResolved Event
cqg_subminute_bars

Reference to the resolved CQGSubMinuteBars

cqg_error

CQGError object describing the last error occurred during processing the timed bars request or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

CQGCEL Interface : SubMinuteBarsResolved Event

Glossary Item Box

Description

This event is fired when the collection of sub minute bars (CQGSubMinuteBars) is resolved or when some error has occurred during the sub minute bars request processing.

Syntax

Visual Basic
Public Event SubMinuteBarsResolved( _
   ByVal cqg_subminute_bars As CQGSubMinuteBars, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_subminute_bars

Reference to the resolved CQGSubMinuteBars

cqg_error

CQGError object describing the last error occurred during processing the timed bars request or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

SubMinuteBarsUpdated Event
cqg_subminute_bars

Reference to the changed CQGSubMinuteBars

index_

Specifies the updated CQGSubMinuteBar's index

CQGCEL Interface : SubMinuteBarsUpdated Event

Glossary Item Box

Description

This event is fired when a CQGSubMinuteBar item is updated

Syntax

Visual Basic
Public Event SubMinuteBarsUpdated( _
   ByVal cqg_subminute_bars As CQGSubMinuteBars, _
   ByVal index_ As Long _
)

Parameters

cqg_subminute_bars

Reference to the changed CQGSubMinuteBars

index_

Specifies the updated CQGSubMinuteBar's index

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

SummariesStatementResolved Event
cqg_summaries_statement

Reference to the resolved CQGSummariesStatement

cqg_error

CQGError object describing the last error occurred while processing the summaries statement request or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

CQGCEL Interface : SummariesStatementResolved Event

Glossary Item Box

Description

This event is fired when the summaries statement (CQGSummariesStatement) is resolved or when some error has occurred while processing the summaries statement request.

Syntax

Visual Basic
Public Event SummariesStatementResolved( _
   ByVal cqg_summaries_statement As CQGSummariesStatement, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_summaries_statement

Reference to the resolved CQGSummariesStatement

cqg_error

CQGError object describing the last error occurred while processing the summaries statement request or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

See Also

CQGCEL Interface | CQGCEL Members | CQGSummariesStatement Interface


%%PageItemTitle%%

TFlowBarsAdded Event
cqg_tflow_bars

Reference to changed CQGTFlowBars

CQGCEL Interface : TFlowBarsAdded Event

Glossary Item Box

Description

This event is fired when a CQGTFlowBar item is added to the end of CQGTFlowBars.

Syntax

Visual Basic
Public Event TFlowBarsAdded( _
   ByVal cqg_tflow_bars As CQGTFlowBars _
)

Parameters

cqg_tflow_bars

Reference to changed CQGTFlowBars

See Also

CQGCEL Interface | CQGCEL Members | CQGTFlowBar Interface | CQGTFlowBars Collection


%%PageItemTitle%%

TFlowBarsInserted Event
cqg_tflow_bars

Reference to the CQGTFlowBars collection the TFlow bar is inserted to

index_

Specifies the inserted CQGTFlowBar's index

CQGCEL Interface : TFlowBarsInserted Event

Glossary Item Box

Description

This event is fired when a CQGTFlowBar item is inserted to the CQGTFlowBars collection.

Syntax

Visual Basic
Public Event TFlowBarsInserted( _
   ByVal cqg_tflow_bars As CQGTFlowBars, _
   ByVal index_ As Long _
)

Parameters

cqg_tflow_bars

Reference to the CQGTFlowBars collection the TFlow bar is inserted to

index_

Specifies the inserted CQGTFlowBar's index

See Also

CQGCEL Interface | CQGCEL Members | CQGTFlowBar Interface | CQGTFlowBars Collection


%%PageItemTitle%%

TFlowBarsRemoved Event
cqg_tflow_bars

Reference to the CQGTFlowBars collection the TFlow bar is removed from

index_

Specifies the removed CQGTFlowBar's index

CQGCEL Interface : TFlowBarsRemoved Event

Glossary Item Box

Description

This event is fired when a CQGTFlowBar item is removed from the CQGTFlowBars collection.

Syntax

Visual Basic
Public Event TFlowBarsRemoved( _
   ByVal cqg_tflow_bars As CQGTFlowBars, _
   ByVal index_ As Long _
)

Parameters

cqg_tflow_bars

Reference to the CQGTFlowBars collection the TFlow bar is removed from

index_

Specifies the removed CQGTFlowBar's index

See Also

CQGCEL Interface | CQGCEL Members | CQGTFlowBar Interface | CQGTFlowBars Collection


%%PageItemTitle%%

TFlowBarsResolved Event
cqg_tflow_bars

Reference to resolved CQGTFlowBars

cqg_error

CQGError object describing the last error occurred during processing the TFlow bars request or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

CQGCEL Interface : TFlowBarsResolved Event

Glossary Item Box

Description

This event is fired when the collection of TFlow bars (CQGTFlowBars) is resolved or when some error occured during TFlow bars request processing.

Syntax

Visual Basic
Public Event TFlowBarsResolved( _
   ByVal cqg_tflow_bars As CQGTFlowBars, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_tflow_bars

Reference to resolved CQGTFlowBars

cqg_error

CQGError object describing the last error occurred during processing the TFlow bars request or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

See Also

CQGCEL Interface | CQGCEL Members | CQGTFlowBars Collection | CQGTFlowBar Interface


%%PageItemTitle%%

TFlowBarsUpdated Event
cqg_tflow_bars

Reference to changed CQGTFlowBars

index_

specifies the updated CQGTFlowBar index

CQGCEL Interface : TFlowBarsUpdated Event

Glossary Item Box

Description

This event is fired when a CQGTFlowBar item is updated.

Syntax

Visual Basic
Public Event TFlowBarsUpdated( _
   ByVal cqg_tflow_bars As CQGTFlowBars, _
   ByVal index_ As Long _
)

Parameters

cqg_tflow_bars

Reference to changed CQGTFlowBars

index_

specifies the updated CQGTFlowBar index

See Also

CQGCEL Interface | CQGCEL Members | CQGTFlowBars Collection | CQGTFlowBar Interface


%%PageItemTitle%%

TicksAdded Event
cqg_ticks

Reference to the changed CQGTicks

added_ticks_count

Specifies the number of added ticks towards the end of CQGTicks

CQGCEL Interface : TicksAdded Event

Glossary Item Box

Description

This event is fired when CQGTick items are added to the CQGTicks collection.

Syntax

Visual Basic
Public Event TicksAdded( _
   ByVal cqg_ticks As CQGTicks, _
   ByVal added_ticks_count As Long _
)

Parameters

cqg_ticks

Reference to the changed CQGTicks

added_ticks_count

Specifies the number of added ticks towards the end of CQGTicks

See Also

CQGCEL Interface | CQGCEL Members | CQGTick Interface | CQGTicks Collection


%%PageItemTitle%%

TicksRemoved Event
cqg_ticks

Reference to the CQGTicks collection the tick is removed from.

index_

Specifies the removed CQGTick's index.

CQGCEL Interface : TicksRemoved Event

Glossary Item Box

Description

This event is fired when CQGTick item is removed from the CQGTicks collection.

Syntax

Visual Basic
Public Event TicksRemoved( _
   ByVal cqg_ticks As CQGTicks, _
   ByVal index_ As Long _
)

Parameters

cqg_ticks

Reference to the CQGTicks collection the tick is removed from.

index_

Specifies the removed CQGTick's index.

Remarks

The event is fired only if CQGTicksRequest.Limit property is set.

Available since 19x3 CQG IC version.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

TicksResolved Event
cqg_ticks

Reference to resolved CQGTicks

cqg_error

CQGError object describing the last error occurred during the ticks request processing or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

CQGCEL Interface : TicksResolved Event

Glossary Item Box

Description

This event is fired when the CQGTicks collection is resolved or when some error has occurred during the ticks request processing.

Syntax

Visual Basic
Public Event TicksResolved( _
   ByVal cqg_ticks As CQGTicks, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_ticks

Reference to resolved CQGTicks

cqg_error

CQGError object describing the last error occurred during the ticks request processing or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

Remarks

The ticks.Status represents the new status of the query.

If ticks.Status is rsSuccess, further changes to ticks may be reported with the TicksAdded event.

If ticks.Status is rsFailed or rsCanceled, no further events on ticks will be fired.

See Also

CQGCEL Interface | CQGCEL Members | CQGTicks Collection | CQGTick Interface


%%PageItemTitle%%

TimedBarsAdded Event
cqg_timed_bars

Reference to the changed CQGTimedBars

CQGCEL Interface : TimedBarsAdded Event

Glossary Item Box

Description

This event is fired when a CQGTimedBar item is added to the end of CQGTimedBars.

Syntax

Visual Basic
Public Event TimedBarsAdded( _
   ByVal cqg_timed_bars As CQGTimedBars _
)

Parameters

cqg_timed_bars

Reference to the changed CQGTimedBars

See Also

CQGCEL Interface | CQGCEL Members | CQGTimedBar Interface | CQGTimedBars Collection


%%PageItemTitle%%

TimedBarsInserted Event
cqg_timed_bars

Reference to the CQGTimedBars collection the timed bar is inserted to

index_

Specifies the inserted CQGTimedBar's index

CQGCEL Interface : TimedBarsInserted Event

Glossary Item Box

Description

This event is fired when a CQGTimedBar item is inserted to the CQGTimedBars collection.

Syntax

Visual Basic
Public Event TimedBarsInserted( _
   ByVal cqg_timed_bars As CQGTimedBars, _
   ByVal index_ As Long _
)

Parameters

cqg_timed_bars

Reference to the CQGTimedBars collection the timed bar is inserted to

index_

Specifies the inserted CQGTimedBar's index

See Also

CQGCEL Interface | CQGCEL Members | CQGTimedBar Interface | CQGTimedBars Collection


%%PageItemTitle%%

TimedBarsRemoved Event
cqg_timed_bars

Reference to the CQGTimedBars collection the timed bar is removed from

index_

Specifies the removed CQGTimedBar's index

CQGCEL Interface : TimedBarsRemoved Event

Glossary Item Box

Description

This event is fired when a CQGTimedBar item is removed from the CQGTimedBars collection.

Syntax

Visual Basic
Public Event TimedBarsRemoved( _
   ByVal cqg_timed_bars As CQGTimedBars, _
   ByVal index_ As Long _
)

Parameters

cqg_timed_bars

Reference to the CQGTimedBars collection the timed bar is removed from

index_

Specifies the removed CQGTimedBar's index

See Also

CQGCEL Interface | CQGCEL Members | CQGTimedBar Interface | CQGTimedBars Collection


%%PageItemTitle%%

TimedBarsResolved Event
cqg_timed_bars

Reference to resolved CQGTimedBars

cqg_error

CQGError object describing the last error occurred during processing the timed bars request or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

CQGCEL Interface : TimedBarsResolved Event

Glossary Item Box

Description

This event is fired when the collection of timed bars (CQGTimedBars) is resolved or when some error has occurred during the timed bars request processing.

Syntax

Visual Basic
Public Event TimedBarsResolved( _
   ByVal cqg_timed_bars As CQGTimedBars, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_timed_bars

Reference to resolved CQGTimedBars

cqg_error

CQGError object describing the last error occurred during processing the timed bars request or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

See Also

CQGCEL Interface | CQGCEL Members | CQGTimedBars Collection


%%PageItemTitle%%

TimedBarsUpdated Event
cqg_timed_bars

Reference to the changed CQGTimedBars

index_

Specifies the updated CQGTimedBar's index

CQGCEL Interface : TimedBarsUpdated Event

Glossary Item Box

Description

This event is fired when a CQGTimedBar item is updated.

Syntax

Visual Basic
Public Event TimedBarsUpdated( _
   ByVal cqg_timed_bars As CQGTimedBars, _
   ByVal index_ As Long _
)

Parameters

cqg_timed_bars

Reference to the changed CQGTimedBars

index_

Specifies the updated CQGTimedBar's index

See Also

CQGCEL Interface | CQGCEL Members | CQGTimedBar Interface | CQGTimedBars Collection


%%PageItemTitle%%

TradableCommoditiesResolved Event
gw_account_id

Gateway account ID, for which tradable commodity names were requested, represented as Long

  • The gw_account_id that was passed to the corresponding RequestTradableCommodities call.
  • 0 if nothing was passed.
    • cqg_commodities

    Collection of the tradable commodities.

    If an error has occurred, the collection will be empty.

    cqg_error
    CQGError object representing the error occurred while processing the tradable commodities request.

    If no error has occurred, the parameter value is either Nothing or invalid error object depending on the UsedFromATLClient setting of the configuration.

    The parameter can be checked for validity via the CQGCEL.IsValid method.

    CQGCEL Interface : TradableCommoditiesResolved Event

    Glossary Item Box

    Description

    This event is fired as a response to a tradable commodities request either when the collection is resolved or when an error has occurred during the request processing.

    Syntax

    Visual Basic
    Public Event TradableCommoditiesResolved( _
   ByVal gw_account_id As Long, _
   ByVal cqg_commodities As CQGCommodities, _
   ByVal cqg_error As CQGError _
)

    Parameters

    gw_account_id

    Gateway account ID, for which tradable commodity names were requested, represented as Long

  • The gw_account_id that was passed to the corresponding RequestTradableCommodities call.
  • 0 if nothing was passed.
    • cqg_commodities

    Collection of the tradable commodities.

    If an error has occurred, the collection will be empty.

    cqg_error
    CQGError object representing the error occurred while processing the tradable commodities request.

    If no error has occurred, the parameter value is either Nothing or invalid error object depending on the UsedFromATLClient setting of the configuration.

    The parameter can be checked for validity via the CQGCEL.IsValid method.

    Example

    The examples below show how to request tradable commodities via CQG API.

    VB
    CS
    Option Explicit
Private WithEvents CEL As CQGCEL
Private Sub Form_Load()
' Initialize CQGCEL instance.
On Error Goto errHndl
Set CEL = New CQGCEL
CEL.APIConfiguration.CollectionsThrowException = False
' Disable application readiness checking
CEL.APIConfiguration.ReadyStatusCheck = rscOff
CEL.Startup
Exit Sub
errHndl:
MsgBox "Error occurred during CEL initialization. " & Err.Description
End Sub
Private Sub Form_Unload(Cancel As Integer)
On Error Goto errHndl
CEL.Shutdown
Exit Sub
errHndl:
MsgBox "Error occurred during CEL initialization. " & Err.Description
End Sub
' Event is fired when the CQGCEL object is successfully started up
Private Sub CEL_CELStarted()
Debug.Print "CEL Version : " & CEL.Environment.CELVersion
End Sub
' Event is fired when error occures in CQGCEL execution
Private Sub cel_DataError(ByVal obj As Object, ByVal errorDescription As String)
' Print the error description
Debug.Print "Data Error : " & errorDescription
End Sub
' Event is fired when some changes occurred in the connection with the CQG data server
Private Sub CEL_DataConnectionStatusChanged(ByVal newStatus As CQG.eConnectionStatus)
Dim status As String
Select Case newStatus
Case csConnectionDelayed
status = "Delayed"
Case csConnectionDown
status = "Down"
Case csConnectionUp
status = "Up"
End Select
Debug.Print "Data Connection Status changed to " & status
End Sub
' Event is fired when the status of the connection with the CQG Gateway is changed
Private Sub CEL_GWConnectionStatusChanged(ByVal newStatus As CQG.eConnectionStatus)
Dim status As String
Select Case newStatus
Case csConnectionDelayed
status = "Delayed"
Case csConnectionDown
status = "Down"
Case csConnectionUp
status = "Up"
' Changing subscription level sends request for accounts
CEL.AccountSubscriptionLevel = aslAccountsOnly
End Select
Debug.Print "GW Connection Status changed to " & status
End Sub
' Event is fired when the account or position information is changed
Private Sub CEL_AccountChanged(ByVal change As CQG.eAccountChangeType, _
ByVal Account As CQG.ICQGAccount, _
ByVal position As CQG.ICQGPosition)
If change = eAccountChangeType.actAccountsReloaded Then
RequestAllTradeableCommodities
End If
End Sub
' This function requests all tradeable commodities for each account
Private Sub RequestAllTradeableCommodities()
Dim acc As CQGAccount
For Each acc In CEL.Accounts
Debug.Print "Request tradeable commodities for account : " & _
acc.GWAccountName
CEL.RequestTradableCommodities acc.GWAccountID
Next
End Sub
' Event is fired when the list of tradable commodity names is resolved
' or when some error has occurred while request processing
Private Sub CEL_TradableCommoditiesResolved(ByVal GWAccountID As Long, _
ByVal commodityNames As CQG.ICQGCommodities, _
ByVal cqgErr As CQG.ICQGError)
Dim i As Long
If Not cqgErr Is Nothing Then
Debug.Print "Error occured during tradeable commodities request : " & cqgErr.Description
Exit Sub
End If
Debug.Print "Tradeable commodities resolved for account : " & _
CEL.Accounts(GWAccountID).GWAccountName
For i = 0 To commodityNames.Count - 1
Debug.Print vbTab & commodityNames(i)
Next
End Sub
    using System;
using System.Runtime.InteropServices;
using CQG;
namespace Samples
{
   class TradableCommoditiesResolved : IDisposable
   {
      // CQGCEL instance declaration
      private CQGCEL cel = new CQGCELClass();
      // Used to determine is the object manualy disposed
      private bool disposed = false;
      public TradableCommoditiesResolved()
      {
         // Initialize CQGCEL instance
         try
         {
            // Configure CEL
            cel.APIConfiguration.ReadyStatusCheck = eReadyStatusCheck.rscOff;
            cel.APIConfiguration.CollectionsThrowException = false;
            // Register to CEL's events
            cel.CELStarted += new _ICQGCELEvents_CELStartedEventHandler(cel_CELStarted);
            cel.DataError += new _ICQGCELEvents_DataErrorEventHandler(cel_DataError);
            cel.DataConnectionStatusChanged += new _ICQGCELEvents_DataConnectionStatusChangedEventHandler(cel_DataConnectionStatusChanged);
            cel.GWConnectionStatusChanged += new _ICQGCELEvents_GWConnectionStatusChangedEventHandler(cel_GWConnectionStatusChanged);
            cel.AccountChanged += new _ICQGCELEvents_AccountChangedEventHandler(cel_AccountChanged);
            cel.TradableCommoditiesResolved += new _ICQGCELEvents_TradableCommoditiesResolvedEventHandler(cel_TradableCommoditiesResolved);
            cel.Startup();
         }
         catch (COMException ex)
         {
            Console.WriteLine("Error occurred during CEL initialization. {0}", ex.Message);
         }
      }
      ~TradableCommoditiesResolved()
      {
         Dispose(false);
      }
      #region CEL Event Handlers

      // Event is fired when the CQGCEL object is successfully started up
      void cel_CELStarted()
      {
         Console.WriteLine("CEL Version : {0}", cel.Environment.CELVersion);
      }

      // Event is fired when error occures in CQGCEL execution
      void cel_DataError(object obj, string errorDescription)
      {
         // Some error occurred
         Console.WriteLine("Data Error : " + errorDescription);
      }

      // Event is fired when some changes occurred in the connection
      // with the CQG data server
      void cel_DataConnectionStatusChanged(eConnectionStatus newStatus)
      {
         string status;
         switch (newStatus)
         {
            case eConnectionStatus.csConnectionDelayed:
               status = "Delayed";
               break;
            case eConnectionStatus.csConnectionDown:
               status = "Down";
               break;
            case eConnectionStatus.csConnectionUp:
               status = "Up";
               break;
            default:
               status = "Unknown";
               break;
         }

         Console.WriteLine("Data Connection Status changed to " + status);
      }
      // Event is fired when the status of the connection with the
      // CQG Gateway is changed
      void cel_GWConnectionStatusChanged(eConnectionStatus newStatus)
      {
         string status;
         switch (newStatus)
         {
            case eConnectionStatus.csConnectionDelayed:
               status = "Delayed";
               break;
            case eConnectionStatus.csConnectionDown:
               status = "Down";
               break;
            case eConnectionStatus.csConnectionUp:
               status = "Up";
               // Changing subscription level sends request for accounts
               cel.AccountSubscriptionLevel = eAccountSubscriptionLevel.aslAccountsOnly;
               break;
            default:
               status = "Unknown";
               break;
         }

         Console.WriteLine("GW Connection Status changed to " + status);
      }

      // Event is fired when the account or position information is changed
      void cel_AccountChanged(eAccountChangeType change, CQGAccount Account, CQGPosition position)
      {
         if (change == eAccountChangeType.actAccountsReloaded)
         {
            RequestAllTradeableCommodities();
         }
      }

      // This function requests all tradeable commodities for each account
      void RequestAllTradeableCommodities()
      {
         foreach (CQGAccount acc in cel.Accounts)
         {
            Console.WriteLine("Request tradeable commodities for account : {0}",
            acc.GWAccountName);
            cel.RequestTradableCommodities(acc.GWAccountID);
         }
      }

      // Event is fired when the list of tradable commodity names is resolved
      // or when some error has occurred while request processing
      void cel_TradableCommoditiesResolved(int GWAccountID, CQGCommodities commodityNames, CQGError err)
      {
         if (err != null)
         {
            Console.WriteLine("Error occured during tradeable commodities request : {0}",
            err.Description);
            return;
         }

         Console.WriteLine("Tradeable commodities resolved for account : {0}", cel.Accounts[GWAccountID].GWAccountName);
         for (int i = 0; i < commodityNames.Count; i++)
         {
            Console.WriteLine("\t {0}", commodityNames[i]);
         }
      }

      #endregion

      #region IDisposable Members

      public void Dispose()
      {
         Dispose(true);
         GC.SuppressFinalize(this);
      }

      #endregion

      #region Private Methods

      private void Dispose(bool disposing)
      {
         // Check to see if Dispose has already been called
         if (!this.disposed)
         {
            // If disposing equals true, dispose all managed
            // and unmanaged resources
            if (disposing)
            {
               // Dispose managed resources
            }
            // If disposing is false,
            // only the following code is executed
            try
            {
               cel.Shutdown();
            }
            catch
            { }
         }
         disposed = true;
      }
      #endregion
   }
}

    See Also

    CQGCEL Interface | CQGCEL Members | CQGCEL.RequestTradableCommodities Method | CQGCommodities Collection | CQGError Interface | CQGCEL.IsValid Method | CQGAPIConfig.UsedFromATLClient Property


%%PageItemTitle%%

TradableExchangesResolved Event
gw_account_id

Gateway account ID, for which tradable exchange names were requested, represented as Long

  • The gw_account_id that was passed to the corresponding RequestTradableExchanges call.
  • 0 if nothing was passed.
    • cqg_exchanges

    Collection of the tradable exchages.

    If an error has occurred, the collection will be empty.

    cqg_error
    CQGError object representing the error occurred while processing the tradable exchanges request.

    If no error has occurred, the parameter value is either Nothing or invalid error object depending on the UsedFromATLClient setting of the configuration.

    The parameter can be checked for validity via the CQGCEL.IsValid method.

    CQGCEL Interface : TradableExchangesResolved Event

    Glossary Item Box

    Description

    This event is fired as a response to a tradable exchanges request either when the collection is resolved or when an error has occurred during the request processing.

    Syntax

    Visual Basic
    Public Event TradableExchangesResolved( _
   ByVal gw_account_id As Long, _
   ByVal cqg_exchanges As CQGExchanges, _
   ByVal cqg_error As CQGError _
)

    Parameters

    gw_account_id

    Gateway account ID, for which tradable exchange names were requested, represented as Long

  • The gw_account_id that was passed to the corresponding RequestTradableExchanges call.
  • 0 if nothing was passed.
    • cqg_exchanges

    Collection of the tradable exchages.

    If an error has occurred, the collection will be empty.

    cqg_error
    CQGError object representing the error occurred while processing the tradable exchanges request.

    If no error has occurred, the parameter value is either Nothing or invalid error object depending on the UsedFromATLClient setting of the configuration.

    The parameter can be checked for validity via the CQGCEL.IsValid method.

    See Also

    CQGCEL Interface | CQGCEL Members | RequestTradableExchanges Method | CQGExchanges Collection | CQGCEL.IsValid Method | CQGAPIConfig.UsedFromATLClient Property


%%PageItemTitle%%

TradingSystemAddNotification Event
cqg_trading_system

Reference to the changed CQGTradingSystem

cqg_trading_system_add_info

Object containing information about the addition made to the trading system since the last notification

CQGCEL Interface : TradingSystemAddNotification Event

Glossary Item Box

Description

This event is fired when trade row and/or statistics are added to the trading system.

Syntax

Visual Basic
Public Event TradingSystemAddNotification( _
   ByVal cqg_trading_system As CQGTradingSystem, _
   ByVal cqg_trading_system_add_info As CQGTradingSystemAddInfo _
)

Parameters

cqg_trading_system

Reference to the changed CQGTradingSystem

cqg_trading_system_add_info

Object containing information about the addition made to the trading system since the last notification

See Also

CQGCEL Interface | CQGCEL Members | CQGTradingSystem Interface


%%PageItemTitle%%

TradingSystemDefinitionsResolved Event
cqg_trading_system_definitions

Collection of trading system definitions.

If an error has occurred, the collection is empty

cqg_error

CQGError object describing the last error occurred during the request processing or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

CQGCEL Interface : TradingSystemDefinitionsResolved Event

Glossary Item Box

Description

This event is fired when the definitions of trading systems are resolved or when some error has occurred during request processing.

Syntax

Visual Basic
Public Event TradingSystemDefinitionsResolved( _
   ByVal cqg_trading_system_definitions As CQGTradingSystemDefinitions, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_trading_system_definitions

Collection of trading system definitions.

If an error has occurred, the collection is empty

cqg_error

CQGError object describing the last error occurred during the request processing or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

See Also

CQGCEL Interface | CQGCEL Members | CQGTradingSystemDefinitions Collection


%%PageItemTitle%%

TradingSystemInsertNotification Event
cqg_trading_system

Reference to the changed CQGTradingSystem

cqg_trading_system_insert_info

Object containing information about the insertion made to the trading system since the last notification

CQGCEL Interface : TradingSystemInsertNotification Event

Glossary Item Box

Description

This event is fired when trade row and/or statistics are inserted to the trading system.

Syntax

Visual Basic
Public Event TradingSystemInsertNotification( _
   ByVal cqg_trading_system As CQGTradingSystem, _
   ByVal cqg_trading_system_insert_info As CQGTradingSystemInsertInfo _
)

Parameters

cqg_trading_system

Reference to the changed CQGTradingSystem

cqg_trading_system_insert_info

Object containing information about the insertion made to the trading system since the last notification

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

TradingSystemRemoveNotification Event
cqg_trading_system

Reference to the changed CQGTradingSystem

cqg_trading_system_remove_info

Object containing information about the removal made to the trading system since the last notification

CQGCEL Interface : TradingSystemRemoveNotification Event

Glossary Item Box

Description

This event is fired when trade row and/or statistics are removed to the trading system.

Syntax

Visual Basic
Public Event TradingSystemRemoveNotification( _
   ByVal cqg_trading_system As CQGTradingSystem, _
   ByVal cqg_trading_system_remove_info As CQGTradingSystemRemoveInfo _
)

Parameters

cqg_trading_system

Reference to the changed CQGTradingSystem

cqg_trading_system_remove_info

Object containing information about the removal made to the trading system since the last notification

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

TradingSystemResolved Event
cqg_trading_system

Reference to the resolved CQGTradingSystem

cqg_error

CQGError object describing the last error occurred while processing the trading system request or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

CQGCEL Interface : TradingSystemResolved Event

Glossary Item Box

Description

This event is fired when the trading system (CQGTradingSystem) is resolved or when some error has occurred while processing the trading system request.

Syntax

Visual Basic
Public Event TradingSystemResolved( _
   ByVal cqg_trading_system As CQGTradingSystem, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_trading_system

Reference to the resolved CQGTradingSystem

cqg_error

CQGError object describing the last error occurred while processing the trading system request or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

See Also

CQGCEL Interface | CQGCEL Members | CQGTradingSystem Interface


%%PageItemTitle%%

TradingSystemTradeRelationAddNotification Event
cqg_trading_system

Specifies the trading system to which the relation was added

cqg_trading_system_relation_add_info

Object containing information about the relation added to the trading system since the last notification

CQGCEL Interface : TradingSystemTradeRelationAddNotification Event

Glossary Item Box

Description

This event is fired, when a relation between trade entry/exit is added to a trading system.

Syntax

Visual Basic
Public Event TradingSystemTradeRelationAddNotification( _
   ByVal cqg_trading_system As CQGTradingSystem, _
   ByVal cqg_trading_system_relation_add_info As CQGTradingSystemRelationAddInfo _
)

Parameters

cqg_trading_system

Specifies the trading system to which the relation was added

cqg_trading_system_relation_add_info

Object containing information about the relation added to the trading system since the last notification

See Also

CQGCEL Interface | CQGCEL Members | CQGTradingSystemAddInfo Interface | CQGTradingSystem Interface


%%PageItemTitle%%

TradingSystemUpdateNotification Event
cqg_trading_system

Reference to the changed CQGTradingSystem

cqg_trading_system_update_info

Object containing information about the update made to the trading system since the last notification

CQGCEL Interface : TradingSystemUpdateNotification Event

Glossary Item Box

Description

This event is fired when trade row and/or statistics are updated in a trading system.

Syntax

Visual Basic
Public Event TradingSystemUpdateNotification( _
   ByVal cqg_trading_system As CQGTradingSystem, _
   ByVal cqg_trading_system_update_info As CQGTradingSystemUpdateInfo _
)

Parameters

cqg_trading_system

Reference to the changed CQGTradingSystem

cqg_trading_system_update_info

Object containing information about the update made to the trading system since the last notification

See Also

CQGCEL Interface | CQGCEL Members | CQGTradingSystem Interface | CQGTradingSystemUpdateInfo Interface


%%PageItemTitle%%

YieldsAdded Event
cqg_yields

Reference to the changed CQGYields

CQGCEL Interface : YieldsAdded Event

Glossary Item Box

Description

This event is fired when a CQGYield item is added to the end of CQGYields.

Syntax

Visual Basic
Public Event YieldsAdded( _
   ByVal cqg_yields As CQGYields _
)

Parameters

cqg_yields

Reference to the changed CQGYields

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

YieldsInserted Event
cqg_yields

Reference to the CQGYields collection the yield is inserted to

index_
Specifies the inserted CQGYield's index
CQGCEL Interface : YieldsInserted Event

Glossary Item Box

Description

This event is fired when a CQGYield item is inserted to the CQGYields collection.

Syntax

Visual Basic
Public Event YieldsInserted( _
   ByVal cqg_yields As CQGYields, _
   ByVal index_ As Long _
)

Parameters

cqg_yields

Reference to the CQGYields collection the yield is inserted to

index_
Specifies the inserted CQGYield's index

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

YieldsRemoved Event
cqg_yields

Reference to the CQGYields collection the yield is removed from

index_

Specifies the removed CQGYield's index

CQGCEL Interface : YieldsRemoved Event

Glossary Item Box

Description

This event is fired when a CQGYield item is removed from the CQGYields collection.

Syntax

Visual Basic
Public Event YieldsRemoved( _
   ByVal cqg_yields As CQGYields, _
   ByVal index_ As Long _
)

Parameters

cqg_yields

Reference to the CQGYields collection the yield is removed from

index_

Specifies the removed CQGYield's index

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

YieldsResolved Event
cqg_yields

Reference to resolved CQGYields

cqg_error

CQGError object describing the last error occurred during processing the yields request or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

CQGCEL Interface : YieldsResolved Event

Glossary Item Box

Description

This event is fired when the collection of yields (CQGYields) is resolved or when some error has occurred during the yields request processing.

Syntax

Visual Basic
Public Event YieldsResolved( _
   ByVal cqg_yields As CQGYields, _
   ByVal cqg_error As CQGError _
)

Parameters

cqg_yields

Reference to resolved CQGYields

cqg_error

CQGError object describing the last error occurred during processing the yields request or Nothing/Invalid_Error in case of no error.

CQGCEL.IsValid(Invalid_Error) returns False.

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

YieldsUpdated Event
cqg_yields

Reference to the changed CQGYields

index_

Specifies the updated CQGYield's index

CQGCEL Interface : YieldsUpdated Event

Glossary Item Box

Description

This event is fired when a CQGYield item is updated.

Syntax

Visual Basic
Public Event YieldsUpdated( _
   ByVal cqg_yields As CQGYields, _
   ByVal index_ As Long _
)

Parameters

cqg_yields

Reference to the changed CQGYields

index_

Specifies the updated CQGYield's index

See Also

CQGCEL Interface | CQGCEL Members


%%PageItemTitle%%

CQGChangedTradeEntry Interface
See Also Members Send Feedback

Glossary Item Box

Description

This class contains trading system trade entry change information.

Object Model

CQGChangedTradeEntry InterfaceCQGTradeEntry Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGChangedTradeEntry Members


%%PageItemTitle%% $$Members$$

CQGChangedTradeEntry Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property ChangeCategory | Returns the categories of changes made to the trade entry since the last notification, as a composition of eTradeChangeCategory values.
Public Property TradeEntry | Returns the corresponding trade entry.

See Also

CQGChangedTradeEntry Interface


%%PageItemTitle%%

ChangeCategory Property
CQGChangedTradeEntry Interface : ChangeCategory Property

Glossary Item Box

Description

Returns the categories of changes made to the trade entry since the last notification, as a composition of eTradeChangeCategory values.

Property type

Read-only property

Syntax

Visual Basic
Public Property ChangeCategory As eTradeChangeCategory

See Also

CQGChangedTradeEntry Interface | CQGChangedTradeEntry Members | eTradeChangeCategory Enumeration


%%PageItemTitle%%

TradeEntry Property
CQGChangedTradeEntry Interface : TradeEntry Property

Glossary Item Box

Description

Returns the corresponding trade entry.

Property type

Read-only property

Syntax

Visual Basic
Public Property TradeEntry As CQGTradeEntry

See Also

CQGChangedTradeEntry Interface | CQGChangedTradeEntry Members | CQGTradeEntry Interface


%%PageItemTitle%%

CQGChangedTradeExit Interface
See Also Members Send Feedback

Glossary Item Box

Description

This class contains trading system trade exit change information.

Object Model

CQGChangedTradeExit InterfaceCQGTradeExit Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGChangedTradeExit Members


%%PageItemTitle%% $$Members$$

CQGChangedTradeExit Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property ChangeCategory | Returns the categories of changes made to the trade exit since the last notification, as a composition of eTradeChangeCategory values.
Public Property TradeExit | Returns the corresponding trade exit.

See Also

CQGChangedTradeExit Interface


%%PageItemTitle%%

ChangeCategory Property
CQGChangedTradeExit Interface : ChangeCategory Property

Glossary Item Box

Description

Returns the categories of changes made to the trade exit since the last notification, as a composition of eTradeChangeCategory values.

Property type

Read-only property

Syntax

Visual Basic
Public Property ChangeCategory As eTradeChangeCategory

See Also

CQGChangedTradeExit Interface | CQGChangedTradeExit Members | eTradeChangeCategory Enumeration


%%PageItemTitle%%

TradeExit Property
CQGChangedTradeExit Interface : TradeExit Property

Glossary Item Box

Description

Returns the corresponding trade exit.

Property type

Read-only property

Syntax

Visual Basic
Public Property TradeExit As CQGTradeExit

Return Type

The corresponding CQGTradeExit object

See Also

CQGChangedTradeExit Interface | CQGChangedTradeExit Members


%%PageItemTitle%%

CQGConditionDefinition Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a definition of condition.

Object Model

CQGConditionDefinition InterfaceCQGParameterDefinitions CollectionCQGParameterDefinition Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGConditionDefinition Members


%%PageItemTitle%% $$Members$$

CQGConditionDefinition Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Name | Returns the condition name.
Public Property ParameterDefinitions | Returns the definitions of all parameters.

See Also

CQGConditionDefinition Interface


%%PageItemTitle%%

Name Property
CQGConditionDefinition Interface : Name Property

Glossary Item Box

Description

Returns the condition name.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

Return Type

Condition's name, represented as String

See Also

CQGConditionDefinition Interface | CQGConditionDefinition Members


%%PageItemTitle%%

ParameterDefinitions Property
CQGConditionDefinition Interface : ParameterDefinitions Property

Glossary Item Box

Description

Returns the definitions of all parameters.

Property type

Read-only property

Syntax

Visual Basic
Public Property ParameterDefinitions As CQGParameterDefinitions

Return Type

Parameter definitions collection, represented as CQGParameterDefinitions

See Also

CQGConditionDefinition Interface | CQGConditionDefinition Members | CQGParameterDefinitions Collection


%%PageItemTitle%%

CQGConditionRequest Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents parameters used to formulate a condition request.

Object Model

CQGConditionRequest InterfaceCQGConditionDefinition Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGConditionRequest Members


%%PageItemTitle%% $$Members$$

CQGConditionRequest Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property BaseExpression | Sets/gets the base expression, which will be used to formulate the condition request (Required).
Public Property Continuation | Gets/sets the continuation type, which will be used to formulate the condition request. The default value is tsctNoContinuation.
Public Property DaysBeforeExpiration | Sets/gets the number of days prior to expiration, when the rollover will occur, to be used to formulate the condition request. The default value for this property is 0.
Public Property Definition | Returns the condition definition.
Public Property EqualizeCloses | Gets/sets the equalize closes flag, which will be used to formulate the condition request. The default value for this property is True.
Public Property HistoricalPeriod | Gets/sets the historical period, which will be used to formulate the condition request. The default value for this property is hpUndefined.
Public Property IncludeEnd | Gets/sets the include end flag, which will be used to formulate the condition request. The default value for this property is False.
Public Property IntradayPeriod | Gets/sets the intraday period, which will be used to formulate the condition request.
Public Property Parameter | Sets/gets the parameter value, which will be used to formulate the condition request.
Public Property RangeEnd | Gets/sets the range end, which will be used to formulate the condition request (required).
Public Property RangeStart | Gets/sets the range start, which will be used to formulate the condition request (required).
Public Property RecalcPeriod | Sets/gets the recalculation period (in seconds), which will be used to formulate the condition request. The default value for this property is 60.
Public Property SessionFlags | Gets/sets the session flags, which will be used to formulate the condition request. The default value for this property is sfUndefined.
Public Property SessionsFilter | Sets/gets the sessions filter, which will be used to formulate the condition request. The default value for this property is 0.
Public Property SubscriptionLevel | Returns the subscription level, which will be used in the condition request. The default value for this property is tslEachBar.
Public Property UpdatesEnabled | Gets/sets the updates enabled flag, which will be used to formulate the condition request. The default value for this property is False.

See Also

CQGConditionRequest Interface


%%PageItemTitle%%

BaseExpression Property
CQGConditionRequest Interface : BaseExpression Property

Glossary Item Box

Description

Sets/gets the base expression, which will be used to formulate the condition request (Required).

Property type

Read-write property

Syntax

Visual Basic
Public Property BaseExpression As String

Return Type

The base expression, represented as String

See Also

CQGConditionRequest Interface | CQGConditionRequest Members


%%PageItemTitle%%

Continuation Property
CQGConditionRequest Interface : Continuation Property

Glossary Item Box

Description

Gets/sets the continuation type, which will be used to formulate the condition request.

The default value is tsctNoContinuation.

Property type

Read-write property

Syntax

Visual Basic
Public Property Continuation As eTimeSeriesContinuationType

Return Type

Continuation type, represented as eTimeSeriesContinuationType

Remarks

See the eTimeSeriesContinuationType enumeration for possible values.

See Also

CQGConditionRequest Interface | CQGConditionRequest Members | eTimeSeriesContinuationType Enumeration


%%PageItemTitle%%

DaysBeforeExpiration Property
CQGConditionRequest Interface : DaysBeforeExpiration Property

Glossary Item Box

Description

Sets/gets the number of days prior to expiration, when the rollover will occur, to be used to formulate the condition request.

The default value for this property is 0.

Property type

Read-write property

Syntax

Visual Basic
Public Property DaysBeforeExpiration As Long

Return Type

Number of days prior to the expiration, represented as Long

Remarks

This property is required and must have a positive value, when the Continuation property indicates an adjusted continuation.

If the continuation is not adjusted, this property has no effect.

See Also

CQGConditionRequest Interface | CQGConditionRequest Members | CQGConditionRequest.Continuation Property


%%PageItemTitle%%

Definition Property
CQGConditionRequest Interface : Definition Property

Glossary Item Box

Description

Returns the condition definition.

Property type

Read-only property

Syntax

Visual Basic
Public Property Definition As CQGConditionDefinition

Return Type

The condition definition, represented as CQGConditionDefition object

See Also

CQGConditionRequest Interface | CQGConditionRequest Members | CQGConditionDefinition Interface


%%PageItemTitle%%

EqualizeCloses Property
CQGConditionRequest Interface : EqualizeCloses Property

Glossary Item Box

Description

Gets/sets the equalize closes flag, which will be used to formulate the condition request.

The default value for this property is True.

Property type

Read-write property

Syntax

Visual Basic
Public Property EqualizeCloses As Boolean

Return Type

True (default), if closes should be equalized; False, otherwise

Remarks

This property has effect only when the Continuation property indicates an active or adjusted continuation.

See Also

CQGConditionRequest Interface | CQGConditionRequest Members | CQGConditionRequest.Continuation Property


%%PageItemTitle%%

HistoricalPeriod Property
CQGConditionRequest Interface : HistoricalPeriod Property

Glossary Item Box

Description

Gets/sets the historical period, which will be used to formulate the condition request.

The default value for this property is hpUndefined.

Property type

Read-write property

Syntax

Visual Basic
Public Property HistoricalPeriod As eHistoricalPeriod

Return Type

Historical period, represented as eHistoricalPeriod

See Also

CQGConditionRequest Interface | CQGConditionRequest Members


%%PageItemTitle%%

IncludeEnd Property
CQGConditionRequest Interface : IncludeEnd Property

Glossary Item Box

Description

Gets/sets the include end flag, which will be used to formulate the condition request.

The default value for this property is False.

Property type

Read-write property

Syntax

Visual Basic
Public Property IncludeEnd As Boolean

Return Type

True, if end flag should be encluded; False (default), otherwise

Remarks

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGConditionRequest Interface | CQGConditionRequest Members


%%PageItemTitle%%

IntradayPeriod Property
CQGConditionRequest Interface : IntradayPeriod Property

Glossary Item Box

Description

Gets/sets the intraday period, which will be used to formulate the condition request.

Property type

Read-write property

Syntax

Visual Basic
Public Property IntradayPeriod As Long

Return Type

Intraday period, represented as Long

See Also

CQGConditionRequest Interface | CQGConditionRequest Members


%%PageItemTitle%%

Parameter Property
key_

Parameter name or parameter index

CQGConditionRequest Interface : Parameter Property

Glossary Item Box

Description

Sets/gets the parameter value, which will be used to formulate the condition request.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parameter( _
   ByVal key_ As Variant _
) As Variant

Parameters

key_

Parameter name or parameter index

Return Type

Parameter value, represented as Variant

See Also

CQGConditionRequest Interface | CQGConditionRequest Members


%%PageItemTitle%%

RangeEnd Property
CQGConditionRequest Interface : RangeEnd Property

Glossary Item Box

Description

Gets/sets the range end, which will be used to formulate the condition request (required).

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeEnd As Variant

Return Type

Range end, represented as Variant

Remarks

Only Date and integer are allowed for types of RangeStart/RangeEnd properties.

  • If the type is Date, RangeStart/RangeEnd represent date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode). Non-timed bar requests process date/time range values with a precision of up to minutes.
  • All combinations of Date and integer can apply for these properties, except integer/Date.
  • If RangeEnd type is integer, then it represents the count of records prior to RangeStart to be requested, so it must be a negative value.
  • If RangeEnd is date, it must be further in time than RangeStart.

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGConditionRequest Interface | CQGConditionRequest Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

RangeStart Property
CQGConditionRequest Interface : RangeStart Property

Glossary Item Box

Description

Gets/sets the range start, which will be used to formulate the condition request (required).

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeStart As Variant

Return Type

Range start, represented as Variant

Remarks

Only Date and integer are allowed for types of RangeStart/RangeEnd properties:

  • All combinations of Date and Integer can apply for these properties, except Integer/Date.
  • If type is Date, RangeStart represents date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode). Non-timed bar requests process date/time range values with a precision of up to minutes.
  • If type is Integer, RangeStart represents the current condition's result number (0 is the current condition result number, negative numbers represent condition results in the past, positive numbers - in the future).
  • If the type of RangeStart is integer, it shall be 0 (denoting "current").

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGConditionRequest Interface | CQGConditionRequest Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

RecalcPeriod Property
CQGConditionRequest Interface : RecalcPeriod Property

Glossary Item Box

Description

Sets/gets the recalculation period (in seconds), which will be used to formulate the condition request.

The default value for this property is 60.

Property type

Read-write property

Syntax

Visual Basic
Public Property RecalcPeriod As Long

Return Type

Recalculation period in seconds, represented as Long

Remarks

Only positive values are allowed for this property.

See Also

CQGConditionRequest Interface | CQGConditionRequest Members


%%PageItemTitle%%

SessionFlags Property
CQGConditionRequest Interface : SessionFlags Property

Glossary Item Box

Description

Gets/sets the session flags, which will be used to formulate the condition request.

The default value for this property is sfUndefined.

Property type

Read-write property

Syntax

Visual Basic
Public Property SessionFlags As eSessionFlag

Return Type

Session flags, represented as eSessionFlag

Remarks

See eSessionFlag enumeration for possible values.

See Also

CQGConditionRequest Interface | CQGConditionRequest Members | eSessionFlag Enumeration


%%PageItemTitle%%

SessionsFilter Property
CQGConditionRequest Interface : SessionsFilter Property

Glossary Item Box

Description

Sets/gets the sessions filter, which will be used to formulate the condition request.

The default value for this property is 0.

Property type

Read-write property

Syntax

Visual Basic
Public Property SessionsFilter As Variant

Return Type

Sessions filter, represented as Variant.

Remarks

Only String and integer are considered for SessionsFilter type.

  • If type is integer, SessionsFilter represents session number.
    Special values: 0 represents primary sessions only, 31 represents all sessions.
  • If type is String, SessionsFilter represents custom session name.
    Special values: "all" and "primaryOnly" are equivalent to 31 and 0, respectively.
  • If other types are used for SessionsFilter, SessionsFilter is ignored.

See Also

CQGConditionRequest Interface | CQGConditionRequest Members


%%PageItemTitle%%

SubscriptionLevel Property
CQGConditionRequest Interface : SubscriptionLevel Property

Glossary Item Box

Description

Returns the subscription level, which will be used in the condition request.

The default value for this property is tslEachBar.

Property type

Read-write property

Syntax

Visual Basic
Public Property SubscriptionLevel As eTimeSeriesSubscriptionLevel

Return Type

Subscription level, represented as eTimeSeriesSubscriptionLevel

See Also

CQGConditionRequest Interface | CQGConditionRequest Members | eTimeSeriesSubscriptionLevel Enumeration


%%PageItemTitle%%

UpdatesEnabled Property
CQGConditionRequest Interface : UpdatesEnabled Property

Glossary Item Box

Description

Gets/sets the updates enabled flag, which will be used to formulate the condition request.

The default value for this property is False.

Property type

Read-write property

Syntax

Visual Basic
Public Property UpdatesEnabled As Boolean

Return Type

True, if updates are enabled; False (default), otherwise.

See Also

CQGConditionRequest Interface | CQGConditionRequest Members


%%PageItemTitle%%

CQGConditionResult Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a condition result.

Object Model

CQGConditionResult Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGConditionResult Members


%%PageItemTitle%% $$Members$$

CQGConditionResult Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Timestamp | Returns the timestamp, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
Public Property Value | Returns the result value. This is the default property.

See Also

CQGConditionResult Interface


%%PageItemTitle%%

Timestamp Property
CQGConditionResult Interface : Timestamp Property

Glossary Item Box

Description

Returns the timestamp, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

Property type

Read-only property

Syntax

Visual Basic
Public Property Timestamp As Date

Return Type

Timestamp, represented as Dat

See Also

CQGConditionResult Interface | CQGConditionResult Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

Value Property
CQGConditionResult Interface : Value Property

Glossary Item Box

Description

Returns the result value.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Value As Boolean

Return Type

The value of condition result.

See Also

CQGConditionResult Interface | CQGConditionResult Members


%%PageItemTitle%%

CQGConstantVolumeBar Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a single constant volume bar.

Object Model

CQGConstantVolumeBar Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGConstantVolumeBar Members


%%PageItemTitle%% $$Members$$

CQGConstantVolumeBar Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property ActualVolume | Returns the actual volume of the constant volume bar.
Public Property ActualVolumeFractional | Returns the fractional actual volume
Public Property AskVolume | Returns the actual volume of the constant volume bar.
Public Property AskVolumeFractional | Returns the fractional ask volume
Public Property Avg | Returns the average value of the constant volume bar.
Public Property BidVolume | Returns the bid volume of the constant volume bar.
Public Property BidVolumeFractional | Returns the fractional bid volume
Public Property Close | Returns the close value of the constant volume bar.
Public Property High | Returns the high value of the constant volume bar.
Public Property HLC3 | Returns the ((High+Low+Close)/3) value of the constant volume bar.
Public Property Low | Returns the low value of the constant volume bar.
Public Property Mid | Returns the mid-point value of the constant volume bar.
Public Property Open | Returns the open value of the constant volume bar.
Public Property Range | Returns the range value of the constant volume bar.
Public Property TickVolume | Returns the tick volume of the constant volume bar.
Public Property Timestamp | Returns the timestamp, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
Public Property TimestampOffset | Returns the timestamp offset, which is used to identify various ConstantVolumeBar objects that have the same timestamp.
Public Property TrueHigh | Returns the true high value of the constant volume bar.
Public Property TrueLow | Returns the true low value of the constant volume bar.
Public Property TrueRange | Returns the true low value of the constant volume bar.

See Also

CQGConstantVolumeBar Interface


%%PageItemTitle%%

ActualVolume Property
CQGConstantVolumeBar Interface : ActualVolume Property

Glossary Item Box

Description

Returns the actual volume of the constant volume bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property ActualVolume As Long

Return Type

Actual volume, represented as Long

See Also

CQGConstantVolumeBar Interface | CQGConstantVolumeBar Members


%%PageItemTitle%%

ActualVolumeFractional Property
CQGConstantVolumeBar Interface : ActualVolumeFractional Property

Glossary Item Box

Description

Returns the fractional actual volume

Property type

Read-only property

Syntax

Visual Basic
Public Property ActualVolumeFractional As Double

See Also

CQGConstantVolumeBar Interface | CQGConstantVolumeBar Members


%%PageItemTitle%%

AskVolume Property
CQGConstantVolumeBar Interface : AskVolume Property

Glossary Item Box

Description

Returns the actual volume of the constant volume bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property AskVolume As Long

Return Type

Actual volume, represented as Long

See Also

CQGConstantVolumeBar Interface | CQGConstantVolumeBar Members


%%PageItemTitle%%

AskVolumeFractional Property
CQGConstantVolumeBar Interface : AskVolumeFractional Property

Glossary Item Box

Description

Returns the fractional ask volume

Property type

Read-only property

Syntax

Visual Basic
Public Property AskVolumeFractional As Double

See Also

CQGConstantVolumeBar Interface | CQGConstantVolumeBar Members


%%PageItemTitle%%

Avg Property
CQGConstantVolumeBar Interface : Avg Property

Glossary Item Box

Description

Returns the average value of the constant volume bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property Avg As Double

Return Type

Average, represented as Double

See Also

CQGConstantVolumeBar Interface | CQGConstantVolumeBar Members


%%PageItemTitle%%

BidVolume Property
CQGConstantVolumeBar Interface : BidVolume Property

Glossary Item Box

Description

Returns the bid volume of the constant volume bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property BidVolume As Long

Return Type

Bid volume, represented as Long

See Also

CQGConstantVolumeBar Interface | CQGConstantVolumeBar Members


%%PageItemTitle%%

BidVolumeFractional Property
CQGConstantVolumeBar Interface : BidVolumeFractional Property

Glossary Item Box

Description

Returns the fractional bid volume

Property type

Read-only property

Syntax

Visual Basic
Public Property BidVolumeFractional As Double

See Also

CQGConstantVolumeBar Interface | CQGConstantVolumeBar Members


%%PageItemTitle%%

Close Property
CQGConstantVolumeBar Interface : Close Property

Glossary Item Box

Description

Returns the close value of the constant volume bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property Close As Double

Return Type

Close, represented as Double

See Also

CQGConstantVolumeBar Interface | CQGConstantVolumeBar Members


%%PageItemTitle%%

High Property
CQGConstantVolumeBar Interface : High Property

Glossary Item Box

Description

Returns the high value of the constant volume bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property High As Double

Return Type

High, represented as Double

See Also

CQGConstantVolumeBar Interface | CQGConstantVolumeBar Members


%%PageItemTitle%%

HLC3 Property
CQGConstantVolumeBar Interface : HLC3 Property

Glossary Item Box

Description

Returns the ((High+Low+Close)/3) value of the constant volume bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property HLC3 As Double

Return Type

Result of ((High+Low+Close)/3), represented as Double

See Also

CQGConstantVolumeBar Interface | CQGConstantVolumeBar Members


%%PageItemTitle%%

Low Property
CQGConstantVolumeBar Interface : Low Property

Glossary Item Box

Description

Returns the low value of the constant volume bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property Low As Double

Return Type

Low, represented as Double

See Also

CQGConstantVolumeBar Interface | CQGConstantVolumeBar Members


%%PageItemTitle%%

Mid Property
CQGConstantVolumeBar Interface : Mid Property

Glossary Item Box

Description

Returns the mid-point value of the constant volume bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property Mid As Double

Return Type

Mid-point, represented as Double

See Also

CQGConstantVolumeBar Interface | CQGConstantVolumeBar Members


%%PageItemTitle%%

Open Property
CQGConstantVolumeBar Interface : Open Property

Glossary Item Box

Description

Returns the open value of the constant volume bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property Open As Double

Return Type

Open, represented as Double

See Also

CQGConstantVolumeBar Interface | CQGConstantVolumeBar Members


%%PageItemTitle%%

Range Property
CQGConstantVolumeBar Interface : Range Property

Glossary Item Box

Description

Returns the range value of the constant volume bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property Range As Double

Return Type

Range, represented as Double

See Also

CQGConstantVolumeBar Interface | CQGConstantVolumeBar Members


%%PageItemTitle%%

TickVolume Property
CQGConstantVolumeBar Interface : TickVolume Property

Glossary Item Box

Description

Returns the tick volume of the constant volume bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property TickVolume As Long

Return Type

Tick volume, represented as Long

See Also

CQGConstantVolumeBar Interface | CQGConstantVolumeBar Members


%%PageItemTitle%%

Timestamp Property
CQGConstantVolumeBar Interface : Timestamp Property

Glossary Item Box

Description

Returns the timestamp, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

Property type

Read-only property

Syntax

Visual Basic
Public Property Timestamp As Date

Return Type

Timestamp, represented as Date

See Also

CQGConstantVolumeBar Interface | CQGConstantVolumeBar Members


%%PageItemTitle%%

TimestampOffset Property
CQGConstantVolumeBar Interface : TimestampOffset Property

Glossary Item Box

Description

Returns the timestamp offset, which is used to identify various ConstantVolumeBar objects that have the same timestamp.

Property type

Read-only property

Syntax

Visual Basic
Public Property TimestampOffset As Long

Return Type

Timestamp offset, represented as Long

Remarks

The TimestampOffset value grows for subsequent objects. It resets when the timestamp is changed.

See Also

CQGConstantVolumeBar Interface | CQGConstantVolumeBar Members


%%PageItemTitle%%

TrueHigh Property
CQGConstantVolumeBar Interface : TrueHigh Property

Glossary Item Box

Description

Returns the true high value of the constant volume bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property TrueHigh As Double

Return Type

True high , represented as Double

See Also

CQGConstantVolumeBar Interface | CQGConstantVolumeBar Members


%%PageItemTitle%%

TrueLow Property
CQGConstantVolumeBar Interface : TrueLow Property

Glossary Item Box

Description

Returns the true low value of the constant volume bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property TrueLow As Double

Return Type

True low, represented as Double

See Also

CQGConstantVolumeBar Interface | CQGConstantVolumeBar Members


%%PageItemTitle%%

TrueRange Property
CQGConstantVolumeBar Interface : TrueRange Property

Glossary Item Box

Description

Returns the true low value of the constant volume bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property TrueRange As Double

Return Type

True low, represented as Double

See Also

CQGConstantVolumeBar Interface | CQGConstantVolumeBar Members


%%PageItemTitle%%

CQGConstantVolumeBarsRequest Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents parameters used to formulate a constant volume bars request.

Object Model

CQGConstantVolumeBarsRequest Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGConstantVolumeBarsRequest Members


%%PageItemTitle%% $$Members$$

CQGConstantVolumeBarsRequest Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Continuation | Sets/gets the continuation type, which will be used to formulate the constant volume bars request. The default value is tsctNoContinuation.
Public Property DaysBeforeExpiration | Sets/gets the number of days prior to expiration, when the rollover will occur, to be used to formulate the constant volume bars request. The default value for this property is 0.
Public Property EqualizeCloses | Sets/gets the equalize closes flag, which will be used to formulate the constant volume bars request. The default value for this property is True.
Public Property IncludeEnd | Sets/gets the include end flag, which will be used to formulate the constant volume bars request. The default value for this property is False.
Public Property IncludeFlatTicks | Sets/gets the include flat ticks flag, which will be used to formulate the constant volume bars request. The default value is True.
Public Property RangeEnd | Sets/gets the range end, which will be used to formulate the constant volume bars request (required).
Public Property RangeStart | Sets/gets the range start, which will be used to formulate the constant volume bars request (required).
Public Property RecalcPeriod | Sets/gets the recalculation period (in seconds), which will be used to formulate the constant volume bars request. The default value for this property is 60.
Public Property SessionFlags | Sets/gets the session flags, which will be used to formulate the constant volume bars request. The default value for this property is sfUndefined.
Public Property SessionsFilter | Sets/gets the sessions filter, which will be used to formulate the constant volume bars request. The default value for this property is 0.
Public Property SubscriptionLevel | Returns the subscription level, which will be used in the constant volume bars request. The default value for this property is tslEachBar.
Public Property Symbol | Sets/gets the symbol, which will be used to formulate the constant volume bars request (required).
Public Property UpdatesEnabled | Sets/gets the updates enabled flag, which will be used to formulate the constant volume bars request. The default value is False.
Public Property VolumeLevel | Gets/sets the volume level, which will be used to form the constant volume bars request. The default value is 10.
Public Property VolumeLevelFractional | Gets/sets the fractional volume level, which will be used to form the constant volume bars request. The default value is 10.
Public Property VolumeType | Sets/gets the volume type, which will be used to formulate the constant volume bars request. The default value is cvbvtTicks.

See Also

CQGConstantVolumeBarsRequest Interface


%%PageItemTitle%%

Continuation Property
CQGConstantVolumeBarsRequest Interface : Continuation Property

Glossary Item Box

Description

Sets/gets the continuation type, which will be used to formulate the constant volume bars request.

The default value is tsctNoContinuation.

Property type

Read-write property

Syntax

Visual Basic
Public Property Continuation As eTimeSeriesContinuationType

Return Type

Continuation type, represented as eTimeSeriesContinuationType enumeration

Remarks

See eTimeSeriesContinuationType enumeration for possible values.

See Also

CQGConstantVolumeBarsRequest Interface | CQGConstantVolumeBarsRequest Members | eTimeSeriesContinuationType Enumeration


%%PageItemTitle%%

DaysBeforeExpiration Property
CQGConstantVolumeBarsRequest Interface : DaysBeforeExpiration Property

Glossary Item Box

Description

Sets/gets the number of days prior to expiration, when the rollover will occur, to be used to formulate the constant volume bars request.

The default value for this property is 0.

Property type

Read-write property

Syntax

Visual Basic
Public Property DaysBeforeExpiration As Long

Return Type

Number of days prior to expiration, represented as Long

Remarks

This property is required and must have a positive value, when the Continuation property indicates an adjusted continuation.

If the continuation is not adjusted, this property has no effect.

See Also

CQGConstantVolumeBarsRequest Interface | CQGConstantVolumeBarsRequest Members


%%PageItemTitle%%

EqualizeCloses Property
CQGConstantVolumeBarsRequest Interface : EqualizeCloses Property

Glossary Item Box

Description

Sets/gets the equalize closes flag, which will be used to formulate the constant volume bars request.

The default value for this property is True.

Property type

Read-write property

Syntax

Visual Basic
Public Property EqualizeCloses As Boolean

Return Type

True (default), if closes should be equalized; False, otherwise

Remarks

This flag is only effective, when Continuation indicates an active or adjusted continuation.

This property has effect only when the Continuation property indicates an active or adjusted continuation.

See Also

CQGConstantVolumeBarsRequest Interface | CQGConstantVolumeBarsRequest Members


%%PageItemTitle%%

IncludeEnd Property
CQGConstantVolumeBarsRequest Interface : IncludeEnd Property

Glossary Item Box

Description

Sets/gets the include end flag, which will be used to formulate the constant volume bars request.

The default value for this property is False.

Property type

Read-write property

Syntax

Visual Basic
Public Property IncludeEnd As Boolean

Return Type

True, if end tick is included; False (default), otherwise

Remarks

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGConstantVolumeBarsRequest Interface | CQGConstantVolumeBarsRequest Members


%%PageItemTitle%%

IncludeFlatTicks Property
CQGConstantVolumeBarsRequest Interface : IncludeFlatTicks Property

Glossary Item Box

Description

Sets/gets the include flat ticks flag, which will be used to formulate the constant volume bars request.

The default value is True.

Property type

Read-write property

Syntax

Visual Basic
Public Property IncludeFlatTicks As Boolean

Return Type

True (default), if the flat ticks are included; False, otherwise

See Also

CQGConstantVolumeBarsRequest Interface | CQGConstantVolumeBarsRequest Members


%%PageItemTitle%%

RangeEnd Property
CQGConstantVolumeBarsRequest Interface : RangeEnd Property

Glossary Item Box

Description

Sets/gets the range end, which will be used to formulate the constant volume bars request (required).

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeEnd As Variant

Return Type

Range end, represented as Variant

Remarks

Only Date and integer are allowed for types of RangeStart/RangeEnd properties.

  • If the type is Date, RangeStart/RangeEnd represent date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode). Non-timed bar requests process date/time range values with a precision of up to minutes.
  • All combinations of Date and integer can apply for these properties, except integer/Date.
  • If RangeEnd type is integer, then it represents the count of records prior to RangeStart to be requested, so it must be a negative value.
  • If RangeEnd is date, it must be further in time than RangeStart.

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGConstantVolumeBarsRequest Interface | CQGConstantVolumeBarsRequest Members


%%PageItemTitle%%

RangeStart Property
CQGConstantVolumeBarsRequest Interface : RangeStart Property

Glossary Item Box

Description

Sets/gets the range start, which will be used to formulate the constant volume bars request (required).

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeStart As Variant

Return Type

Range start, represented as Variant

Remarks

Only Date and integer are allowed for types of RangeStart/RangeEnd properties:

  • All combinations of Date and Integer can apply for these properties, except Integer/Date.
  • If type is Date, RangeStart represents date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode). Non-timed bar requests process date/time range values with a precision of up to minutes.
  • If type is Integer, RangeStart represents the current condition's result number (0 is the current condition result number, negative numbers represent condition results in the past, positive numbers - in the future).
  • If the type of RangeStart is integer, it shall be 0 (denoting "current").

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGConstantVolumeBarsRequest Interface | CQGConstantVolumeBarsRequest Members


%%PageItemTitle%%

RecalcPeriod Property
CQGConstantVolumeBarsRequest Interface : RecalcPeriod Property

Glossary Item Box

Description

Sets/gets the recalculation period (in seconds), which will be used to formulate the constant volume bars request.

The default value for this property is 60.

Property type

Read-write property

Syntax

Visual Basic
Public Property RecalcPeriod As Long

Return Type

Recalculation period in seconds, represented as Long

Remarks

Only positive values are allowed for this property.

See Also

CQGConstantVolumeBarsRequest Interface | CQGConstantVolumeBarsRequest Members


%%PageItemTitle%%

SessionFlags Property
CQGConstantVolumeBarsRequest Interface : SessionFlags Property

Glossary Item Box

Description

Sets/gets the session flags, which will be used to formulate the constant volume bars request.

The default value for this property is sfUndefined.

Property type

Read-write property

Syntax

Visual Basic
Public Property SessionFlags As eSessionFlag

Return Type

Session flags, represented as eSessionFlag

Remarks

See the eSessionFlag enumeration for possible values.

See Also

CQGConstantVolumeBarsRequest Interface | CQGConstantVolumeBarsRequest Members


%%PageItemTitle%%

SessionsFilter Property
CQGConstantVolumeBarsRequest Interface : SessionsFilter Property

Glossary Item Box

Description

Sets/gets the sessions filter, which will be used to formulate the constant volume bars request.

The default value for this property is 0.

Property type

Read-write property

Syntax

Visual Basic
Public Property SessionsFilter As Variant

Return Type

Sessions filter, represented as Variant

Remarks

Only String and integer are considered for SessionsFilter type.

  • If type is integer, SessionsFilter represents session number.
    Special values: 0 represents primary sessions only, 31 represents all sessions.
  • If type is String, SessionsFilter represents custom session name.
    Special values: "all" and "primaryOnly" are equivalent to 31 and 0, respectively.
  • If other types are used for SessionsFilter, SessionsFilter is ignored.

See Also

CQGConstantVolumeBarsRequest Interface | CQGConstantVolumeBarsRequest Members


%%PageItemTitle%%

SubscriptionLevel Property
CQGConstantVolumeBarsRequest Interface : SubscriptionLevel Property

Glossary Item Box

Description

Returns the subscription level, which will be used in the constant volume bars request.

The default value for this property is tslEachBar.

Property type

Read-write property

Syntax

Visual Basic
Public Property SubscriptionLevel As eTimeSeriesSubscriptionLevel

Return Type

Subscription level, represented as eTimeSeriesSubscriptionLevel

See Also

CQGConstantVolumeBarsRequest Interface | CQGConstantVolumeBarsRequest Members | eTimeSeriesSubscriptionLevel Enumeration


%%PageItemTitle%%

Symbol Property
CQGConstantVolumeBarsRequest Interface : Symbol Property

Glossary Item Box

Description

Sets/gets the symbol, which will be used to formulate the constant volume bars request (required).

Property type

Read-write property

Syntax

Visual Basic
Public Property Symbol As String

Return Type

Symbol used in the constant volume bars request, represented as String

Remarks

This property cannot be an empty string.

e.g. "EP"

See Also

CQGConstantVolumeBarsRequest Interface | CQGConstantVolumeBarsRequest Members


%%PageItemTitle%%

UpdatesEnabled Property
CQGConstantVolumeBarsRequest Interface : UpdatesEnabled Property

Glossary Item Box

Description

Sets/gets the updates enabled flag, which will be used to formulate the constant volume bars request.

The default value is False.

Property type

Read-write property

Syntax

Visual Basic
Public Property UpdatesEnabled As Boolean

Return Type

True, if the updates are enabled; False (default), otherwise

See Also

CQGConstantVolumeBarsRequest Interface | CQGConstantVolumeBarsRequest Members


%%PageItemTitle%%

VolumeLevel Property
CQGConstantVolumeBarsRequest Interface : VolumeLevel Property

Glossary Item Box

Description

Gets/sets the volume level, which will be used to form the constant volume bars request.

The default value is 10.

Property type

Read-write property

Syntax

Visual Basic
Public Property VolumeLevel As Long

Return Type

Volume level, represented as Long

See Also

CQGConstantVolumeBarsRequest Interface | CQGConstantVolumeBarsRequest Members


%%PageItemTitle%%

VolumeLevelFractional Property
CQGConstantVolumeBarsRequest Interface : VolumeLevelFractional Property

Glossary Item Box

Description

Gets/sets the fractional volume level, which will be used to form the constant volume bars request.

The default value is 10.

Property type

Read-write property

Syntax

Visual Basic
Public Property VolumeLevelFractional As Double

Return Type

Volume level, represented as Double

See Also

CQGConstantVolumeBarsRequest Interface | CQGConstantVolumeBarsRequest Members


%%PageItemTitle%%

VolumeType Property
CQGConstantVolumeBarsRequest Interface : VolumeType Property

Glossary Item Box

Description

Sets/gets the volume type, which will be used to formulate the constant volume bars request.

The default value is cvbvtTicks.

Property type

Read-write property

Syntax

Visual Basic
Public Property VolumeType As eCvbVolumeType

Return Type

Volume type, represented as eCvbVolumeType

Remarks

See the eCvbVolumeType enumeration for possible values.

See Also

CQGConstantVolumeBarsRequest Interface | CQGConstantVolumeBarsRequest Members


%%PageItemTitle%%

CQGCurrencyRate Interface
See Also Members Send Feedback

Glossary Item Box

Description

The CQGCurrencyRate interface encapsulates the currency rate information for two specific currencies.

Object Model

CQGCurrencyRate InterfaceCQGCEL Interface

Example

See the usage of CQGCurrencyRate object in the CurrencyRatesChanged event's example section.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGCurrencyRate Members


%%PageItemTitle%% $$Members$$

CQGCurrencyRate Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property BaseCurrencyName | ISO currency code for the base currency.
Public Property CEL | Returns the corresponding CQGCEL object.
Public Property CurrencyName | ISO currency code for the currency.
Public Property FcmID | Returns the identifier of FCM that offered this currency rate.
Public Property Rate | The currency rate value which is calculated as ratio of currency to base currency.
Public Property RateInverse | Gets rate, as currency / base_currency, for reverse conversions by dividing
Public Property ServerTimestamp | Timestamp of last change (server time, converted to the configured time zone). Each currency rate change event forces this property to change its value.
Public Property Timestamp | Returns the last response reception timestamp. When a property is updated, CQG API records the information reception time in the Timestamp property (using local time). Each currency rate change event forces this property to change its value.

See Also

CQGCurrencyRate Interface


%%PageItemTitle%%

BaseCurrencyName Property
CQGCurrencyRate Interface : BaseCurrencyName Property

Glossary Item Box

Description

ISO currency code for the base currency.

Property type

Read-only property

Syntax

Visual Basic
Public Property BaseCurrencyName As String

Return Type

Currency code represented as String

Example

See the usage of CQGCurrencyRate properties in the CurrencyRatesChanged event's example section.

See Also

CQGCurrencyRate Interface | CQGCurrencyRate Members


%%PageItemTitle%%

CEL Property
CQGCurrencyRate Interface : CEL Property

Glossary Item Box

Description

Returns the corresponding CQGCEL object.

Property type

Read-only property

Syntax

Visual Basic
Public Property CEL As CQGCEL

Return Type

CQGCEL object to which this currency rate object belongs

Remarks

This property will be convenient for those who are familiar with the VBA specific Parent option.

Example

See the usage of CQGCurrencyRate properties in the CurrencyRatesChanged event's example section.

See Also

CQGCurrencyRate Interface | CQGCurrencyRate Members


%%PageItemTitle%%

CurrencyName Property
CQGCurrencyRate Interface : CurrencyName Property

Glossary Item Box

Description

ISO currency code for the currency.

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrencyName As String

Return Type

Currency code represented as String

Example

See the usage of CQGCurrencyRate properties in the CurrencyRatesChanged event's example section.

See Also

CQGCurrencyRate Interface | CQGCurrencyRate Members


%%PageItemTitle%%

FcmID Property
CQGCurrencyRate Interface : FcmID Property

Glossary Item Box

Description

Returns the identifier of FCM that offered this currency rate.

Property type

Read-only property

Syntax

Visual Basic
Public Property FcmID As Long

Return Type

FCM identifier represented as Long

Example

See the usage of CQGCurrencyRate properties in the CurrencyRatesChanged event's example section.

See Also

CQGCurrencyRate Interface | CQGCurrencyRate Members


%%PageItemTitle%%

Rate Property
CQGCurrencyRate Interface : Rate Property

Glossary Item Box

Description

The currency rate value which is calculated as ratio of currency to base currency.

Property type

Read-only property

Syntax

Visual Basic
Public Property Rate As Double

Return Type

Currency/base currency ratio represented as Double

Remarks

The same currency may have different rates at different FCMs.

Example

See the usage of CQGCurrencyRate properties in the CurrencyRatesChanged event's example section.

See Also

CQGCurrencyRate Interface | CQGCurrencyRate Members


%%PageItemTitle%%

RateInverse Property
CQGCurrencyRate Interface : RateInverse Property

Glossary Item Box

Description

Gets rate, as currency / base_currency, for reverse conversions by dividing

Property type

Read-only property

Syntax

Visual Basic
Public Property RateInverse As Double

See Also

CQGCurrencyRate Interface | CQGCurrencyRate Members


%%PageItemTitle%%

ServerTimestamp Property
CQGCurrencyRate Interface : ServerTimestamp Property

Glossary Item Box

Description

Timestamp of last change (server time, converted to the configured time zone).
Each currency rate change event forces this property to change its value.

Property type

Read-only property

Syntax

Visual Basic
Public Property ServerTimestamp As Date

Return Type

Date variable containing the server timestamp

Remarks

The timestamp is converted to the timezone, previously configured by the user.

If no timezone configuration was made the timestamp is converted to UTC.

Example

See the usage of CQGCurrencyRate properties in the CurrencyRatesChanged event's example section.

See Also

CQGCurrencyRate Interface | CQGCurrencyRate Members


%%PageItemTitle%%

Timestamp Property
CQGCurrencyRate Interface : Timestamp Property

Glossary Item Box

Description

Returns the last response reception timestamp.

When a property is updated, CQG API records the information reception time in the Timestamp property (using local time).

Each currency rate change event forces this property to change its value.

Property type

Read-only property

Syntax

Visual Basic
Public Property Timestamp As Date

Return Type

Date variable containing the local timestamp

Remarks

The timestamp is converted to the timezone previously configured by user.

If no timezone configuration was made, the timestamp is converted to UTC.

Example

See the usage of CQGCurrencyRate properties in the CurrencyRatesChanged event's example section.

See Also

CQGCurrencyRate Interface | CQGCurrencyRate Members


%%PageItemTitle%%

CQGCurveDefinition Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a definition of the curve.

Object Model

CQGCurveDefinition Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGCurveDefinition Members


%%PageItemTitle%% $$Members$$

CQGCurveDefinition Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Name

Returns the curve name.

See Also

CQGCurveDefinition Interface


%%PageItemTitle%%

Name Property
CQGCurveDefinition Interface : Name Property

Glossary Item Box

Description

Returns the curve name.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

Return Type

Curve name, represented as String

See Also

CQGCurveDefinition Interface | CQGCurveDefinition Members


%%PageItemTitle%%

CQGCustomStudyDefinition Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a definition of a custom study.

Object Model

CQGCustomStudyDefinition InterfaceCQGCurveDefinitions CollectionCQGCurveDefinition InterfaceCQGParameterDefinitions CollectionCQGParameterDefinition Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGCustomStudyDefinition Members


%%PageItemTitle%% $$Members$$

CQGCustomStudyDefinition Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Abbreviation | Returns the custom study abbreviation.
Public Property CurveDefinitions | Returns all curve definitions.
Public Property Name | Returns the custom study name.
Public Property ParameterDefinitions | Returns all parameter definitions.

See Also

CQGCustomStudyDefinition Interface


%%PageItemTitle%%

Abbreviation Property
CQGCustomStudyDefinition Interface : Abbreviation Property

Glossary Item Box

Description

Returns the custom study abbreviation.

Property type

Read-only property

Syntax

Visual Basic
Public Property Abbreviation As String

Return Type

Custom study abbreviation, represented as String

See Also

CQGCustomStudyDefinition Interface | CQGCustomStudyDefinition Members


%%PageItemTitle%%

CurveDefinitions Property
CQGCustomStudyDefinition Interface : CurveDefinitions Property

Glossary Item Box

Description

Returns all curve definitions.

Property type

Read-only property

Syntax

Visual Basic
Public Property CurveDefinitions As CQGCurveDefinitions

Return Type

Curve definitions, represented as CQGCurveDefinitions collection

See Also

CQGCustomStudyDefinition Interface | CQGCustomStudyDefinition Members


%%PageItemTitle%%

Name Property
CQGCustomStudyDefinition Interface : Name Property

Glossary Item Box

Description

Returns the custom study name.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

Return Type

Custom study name, represented as String

See Also

CQGCustomStudyDefinition Interface | CQGCustomStudyDefinition Members


%%PageItemTitle%%

ParameterDefinitions Property
CQGCustomStudyDefinition Interface : ParameterDefinitions Property

Glossary Item Box

Description

Returns all parameter definitions.

Property type

Read-only property

Syntax

Visual Basic
Public Property ParameterDefinitions As CQGParameterDefinitions

Return Type

Parameter definitions, represented as CQGParameterDefinitions collection

See Also

CQGCustomStudyDefinition Interface | CQGCustomStudyDefinition Members | CQGParameterDefinitions Collection


%%PageItemTitle%%

CQGCustomStudyRequest Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents parameters used to formulate a custom study request.

Object Model

CQGCustomStudyRequest InterfaceCQGCustomStudyDefinition Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGCustomStudyRequest Members


%%PageItemTitle%% $$Members$$

CQGCustomStudyRequest Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method IncludeCurve | Includes the specified curve (custom study output) to be present in the requested custom study.
Public Method IsCurveIncluded | Checks if the specified curve (custom study output) is currently included.

Public Properties

Public Property BaseExpression | Sets/gets the base expression, which will be used to formulate the custom study request (required).
Public Property Continuation | Sets/gets the base expression, which will be used to formulate the custom study request (required).
Public Property DaysBeforeExpiration | Sets/gets the number of days prior to expiration, when the rollover will occur, to be used to formulate the custom study request. The default value for this property is 0.
Public Property Definition | Returns the custom study definition.
Public Property EqualizeCloses | Sets/gets the equalize closes flag, which will be used to formulate the custom study request. The default value for this property is True.
Public Property HistoricalPeriod | Sets/gets the historical period, which will be used to formulate the custom study request. The default value for this property is hpUndefined.
Public Property IncludeEnd | Sets/gets the include end flag, which will be used to formulate the custom study request. The default value for this property is False.
Public Property IntradayPeriod | Sets/gets the intraday period, which will be used to formulate the custom study request.
Public Property Parameter | Sets/gets the parameter value, which will be used to formulate the custom study request.
Public Property RangeEnd | Sets/gets the range end, which will be used to formulate the custom study request (required).
Public Property RangeStart | Sets/gets the range start, which will be used to formulate the custom study request (required).
Public Property RecalcPeriod | Sets/gets the recalculation period (in seconds), which will be used to formulate the custom study request. The default value for this property is 60.
Public Property SessionFlags | Sets/gets the session flags, which will be used to formulate the custom study request. The default value for this property is sfUndefined.
Public Property SessionsFilter | Sets/gets the sessions filter, which will be used to formulate the custom study request. The default value for this property is 0.
Public Property SubscriptionLevel | Sets/gets the subscription level, which will be used to formulate the custom study request. The default value for this property is tslEachBar.
Public Property UpdatesEnabled | Sets/gets the updates enabled flag, which will be used to formulate the custom study request. The default value for this property is False.

See Also

CQGCustomStudyRequest Interface


%%PageItemTitle%%

IncludeCurve Method
curve_key

Curve number or curve name, must be either an integer or string

CQGCustomStudyRequest Interface : IncludeCurve Method

Glossary Item Box

Description

Includes the specified curve (custom study output) to be present in the requested custom study.

Syntax

Visual Basic
Public Sub IncludeCurve( _
   ByVal curve_key As Variant _
)

Parameters

curve_key

Curve number or curve name, must be either an integer or string

Remarks

The call will throw an exception in case of incorrect type, non-existent curve number or name.

Upon the creation of CQGCustomStudyRequest instance, all curves are included by default.

If the IncludeCurve method is called on an instance, where all curves are already included, all curves become excluded except the one specified by curve_key.

Otherwise, curve_key is included in addition to the already-included other curves.

See Also

CQGCustomStudyRequest Interface | CQGCustomStudyRequest Members


%%PageItemTitle%%

IsCurveIncluded Method
curve_key

Curve number or curve name, must be either integer value or string

CQGCustomStudyRequest Interface : IsCurveIncluded Method

Glossary Item Box

Description

Checks if the specified curve (custom study output) is currently included.

Syntax

Visual Basic
Public Function IsCurveIncluded( _
   ByVal curve_key As Variant _
) As Boolean

Parameters

curve_key

Curve number or curve name, must be either integer value or string

Return Type

True, if the curve is included; False, otherwise

Remarks

The call will throw an exception in case of incorrect type, non-existent curve number or name.

See Also

CQGCustomStudyRequest Interface | CQGCustomStudyRequest Members


%%PageItemTitle%%

BaseExpression Property
CQGCustomStudyRequest Interface : BaseExpression Property

Glossary Item Box

Description

Sets/gets the base expression, which will be used to formulate the custom study request (required).

Property type

Read-write property

Syntax

Visual Basic
Public Property BaseExpression As String

Return Type

Base expression, represented as String

See Also

CQGCustomStudyRequest Interface | CQGCustomStudyRequest Members


%%PageItemTitle%%

Continuation Property
CQGCustomStudyRequest Interface : Continuation Property

Glossary Item Box

Description

Sets/gets the base expression, which will be used to formulate the custom study request (required).

Property type

Read-write property

Syntax

Visual Basic
Public Property Continuation As eTimeSeriesContinuationType

Return Type

Base expression, represented as String

See Also

CQGCustomStudyRequest Interface | CQGCustomStudyRequest Members | eTimeSeriesContinuationType Enumeration


%%PageItemTitle%%

DaysBeforeExpiration Property
CQGCustomStudyRequest Interface : DaysBeforeExpiration Property

Glossary Item Box

Description

Sets/gets the number of days prior to expiration, when the rollover will occur, to be used to formulate the custom study request.

The default value for this property is 0.

Property type

Read-write property

Syntax

Visual Basic
Public Property DaysBeforeExpiration As Long

Return Type

Number of days prior to expiration, represented as Long

Remarks

This property is required and must have a positive value, when the Continuation property indicates an adjusted continuation.

If the continuation is not adjusted, this property has no effect.

See Also

CQGCustomStudyRequest Interface | CQGCustomStudyRequest Members | CQGCustomStudyRequest.Continuation Property


%%PageItemTitle%%

Definition Property
CQGCustomStudyRequest Interface : Definition Property

Glossary Item Box

Description

Returns the custom study definition.

Property type

Read-only property

Syntax

Visual Basic
Public Property Definition As CQGCustomStudyDefinition

Return Type

Custom study definition, represented as CQGCustomStudyDefinition object

See Also

CQGCustomStudyRequest Interface | CQGCustomStudyRequest Members | CQGCustomStudyDefinition Interface


%%PageItemTitle%%

EqualizeCloses Property
CQGCustomStudyRequest Interface : EqualizeCloses Property

Glossary Item Box

Description

Sets/gets the equalize closes flag, which will be used to formulate the custom study request.

The default value for this property is True.

Property type

Read-write property

Syntax

Visual Basic
Public Property EqualizeCloses As Boolean

Return Type

True (default), if closes should be equalized; False, otherwise

Remarks

This property has effect only when the Continuation property indicates an active or adjusted continuation.

See Also

CQGCustomStudyRequest Interface | CQGCustomStudyRequest Members | CQGCustomStudyRequest.Continuation Property


%%PageItemTitle%%

HistoricalPeriod Property
CQGCustomStudyRequest Interface : HistoricalPeriod Property

Glossary Item Box

Description

Sets/gets the historical period, which will be used to formulate the custom study request.

The default value for this property is hpUndefined.

Property type

Read-write property

Syntax

Visual Basic
Public Property HistoricalPeriod As eHistoricalPeriod

Return Type

Historical period, represented as eHistoricalPeriod

See Also

CQGCustomStudyRequest Interface | CQGCustomStudyRequest Members | eHistoricalPeriod Enumeration


%%PageItemTitle%%

IncludeEnd Property
CQGCustomStudyRequest Interface : IncludeEnd Property

Glossary Item Box

Description

Sets/gets the include end flag, which will be used to formulate the custom study request.

The default value for this property is False.

Property type

Read-write property

Syntax

Visual Basic
Public Property IncludeEnd As Boolean

Return Type

True, if end should be included; False (default), otherwise

Remarks

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGCustomStudyRequest Interface | CQGCustomStudyRequest Members


%%PageItemTitle%%

IntradayPeriod Property
CQGCustomStudyRequest Interface : IntradayPeriod Property

Glossary Item Box

Description

Sets/gets the intraday period, which will be used to formulate the custom study request.

Property type

Read-write property

Syntax

Visual Basic
Public Property IntradayPeriod As Long

Return Type

Intraday period, represented as Long

See Also

CQGCustomStudyRequest Interface | CQGCustomStudyRequest Members


%%PageItemTitle%%

Parameter Property
key_

Parameter name or parameter index

CQGCustomStudyRequest Interface : Parameter Property

Glossary Item Box

Description

Sets/gets the parameter value, which will be used to formulate the custom study request.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parameter( _
   ByVal key_ As Variant _
) As Variant

Parameters

key_

Parameter name or parameter index

Return Type

Parameter value, represented as Variant

See Also

CQGCustomStudyRequest Interface | CQGCustomStudyRequest Members


%%PageItemTitle%%

RangeEnd Property
CQGCustomStudyRequest Interface : RangeEnd Property

Glossary Item Box

Description

Sets/gets the range end, which will be used to formulate the custom study request (required).

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeEnd As Variant

Return Type

Range end, represented as Variant

Remarks

Only Date and integer are allowed for types of RangeStart/RangeEnd properties.

  • If the type is Date, RangeStart/RangeEnd represent date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode). Non-timed bar requests process date/time range values with a precision of up to minutes.
  • All combinations of Date and integer can apply for these properties, except integer/Date.
  • If RangeEnd type is integer, then it represents the count of records prior to RangeStart to be requested, so it must be a negative value.
  • If RangeEnd is date, it must be further in time than RangeStart.

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGCustomStudyRequest Interface | CQGCustomStudyRequest Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

RangeStart Property
CQGCustomStudyRequest Interface : RangeStart Property

Glossary Item Box

Description

Sets/gets the range start, which will be used to formulate the custom study request (required).

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeStart As Variant

Return Type

Range start, represented as Variant

Remarks

Only Date and integer are allowed for types of RangeStart/RangeEnd properties:

  • All combinations of Date and Integer can apply for these properties, except Integer/Date.
  • If type is Date, RangeStart represents date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode). Non-timed bar requests process date/time range values with a precision of up to minutes.
  • If type is Integer, RangeStart represents the current condition's result number (0 is the current condition result number, negative numbers represent condition results in the past, positive numbers - in the future).
  • If the type of RangeStart is integer, it shall be 0 (denoting "current").

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGCustomStudyRequest Interface | CQGCustomStudyRequest Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

RecalcPeriod Property
CQGCustomStudyRequest Interface : RecalcPeriod Property

Glossary Item Box

Description

Sets/gets the recalculation period (in seconds), which will be used to formulate the custom study request.

The default value for this property is 60.

Property type

Read-write property

Syntax

Visual Basic
Public Property RecalcPeriod As Long

Return Type

Recalculation period in seconds, represented as Long

Remarks

Only positive values are allowed for this property.

See Also

CQGCustomStudyRequest Interface | CQGCustomStudyRequest Members


%%PageItemTitle%%

SessionFlags Property
CQGCustomStudyRequest Interface : SessionFlags Property

Glossary Item Box

Description

Sets/gets the session flags, which will be used to formulate the custom study request.

The default value for this property is sfUndefined.

Property type

Read-write property

Syntax

Visual Basic
Public Property SessionFlags As eSessionFlag

Return Type

Session flags, represented as eSessionFlag Enumeration

Remarks

See eSessionFlag enumeration for possible values.

See Also

CQGCustomStudyRequest Interface | CQGCustomStudyRequest Members | eSessionFlag Enumeration


%%PageItemTitle%%

SessionsFilter Property
CQGCustomStudyRequest Interface : SessionsFilter Property

Glossary Item Box

Description

Sets/gets the sessions filter, which will be used to formulate the custom study request.

The default value for this property is 0.

Property type

Read-write property

Syntax

Visual Basic
Public Property SessionsFilter As Variant

Return Type

Sessions filter, represented as Variant

Remarks

Only String and integer are considered for SessionsFilter type.

  • If type is integer, SessionsFilter represents session number.
    Special values: 0 represents primary sessions only, 31 represents all sessions.
  • If type is String, SessionsFilter represents custom session name.
    Special values: "all" and "primaryOnly" are equivalent to 31 and 0, respectively.
  • If other types are used for SessionsFilter, SessionsFilter is ignored.

See Also

CQGCustomStudyRequest Interface | CQGCustomStudyRequest Members


%%PageItemTitle%%

SubscriptionLevel Property
CQGCustomStudyRequest Interface : SubscriptionLevel Property

Glossary Item Box

Description

Sets/gets the subscription level, which will be used to formulate the custom study request.

The default value for this property is tslEachBar.

Property type

Read-write property

Syntax

Visual Basic
Public Property SubscriptionLevel As eTimeSeriesSubscriptionLevel

Return Type

Subscription level, represented as eTimeSeriesSubscriptionLevel

See Also

CQGCustomStudyRequest Interface | CQGCustomStudyRequest Members | eTimeSeriesSubscriptionLevel Enumeration


%%PageItemTitle%%

UpdatesEnabled Property
CQGCustomStudyRequest Interface : UpdatesEnabled Property

Glossary Item Box

Description

Sets/gets the updates enabled flag, which will be used to formulate the custom study request.

The default value for this property is False.

Property type

Read-write property

Syntax

Visual Basic
Public Property UpdatesEnabled As Boolean

Return Type

True, if the updates are enabled; False (default), otherwise

See Also

CQGCustomStudyRequest Interface | CQGCustomStudyRequest Members


%%PageItemTitle%%

CQGDataSource Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a data source.

Object Model

CQGDataSource Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGDataSource Members


%%PageItemTitle%% $$Members$$

CQGDataSource Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Abbreviation | Returns the data source abbreviation.
Public Property Name | Returns the data source name. This is the default property.
Public Property Status | Returns the data source status.
Public Property SymbolTypes | Returns the symbol types this data source provides.

See Also

CQGDataSource Interface


%%PageItemTitle%%

Abbreviation Property
CQGDataSource Interface : Abbreviation Property

Glossary Item Box

Description

Returns the data source abbreviation.

Property type

Read-only property

Syntax

Visual Basic
Public Property Abbreviation As String

Return Type

Data source abbreviation, represented as String

See Also

CQGDataSource Interface | CQGDataSource Members


%%PageItemTitle%%

Name Property
CQGDataSource Interface : Name Property

Glossary Item Box

Description

Returns the data source name.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

Return Type

Data source name, represented as String

See Also

CQGDataSource Interface | CQGDataSource Members


%%PageItemTitle%%

Status Property
CQGDataSource Interface : Status Property

Glossary Item Box

Description

Returns the data source status.

Property type

Read-only property

Syntax

Visual Basic
Public Property Status As eDataSourceStatus

Return Type

Data source status, represented as eDataSourceStatus

Remarks

See eDataSourceStatus for possible return values.

See Also

CQGDataSource Interface | CQGDataSource Members | eDataSourceStatus Enumeration


%%PageItemTitle%%

SymbolTypes Property
CQGDataSource Interface : SymbolTypes Property

Glossary Item Box

Description

Returns the symbol types this data source provides.

Property type

Read-only property

Syntax

Visual Basic
Public Property SymbolTypes As eSymbolType

Return Type

Symbol types, represented as eSymbolType

Remarks

The return value is a composition of eSymbolType values.

See Also

CQGDataSource Interface | CQGDataSource Members | eSymbolType Enumeration


%%PageItemTitle%%

CQGDataSourceSymbol Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a data source symbol.

Object Model

CQGDataSourceSymbol Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGDataSourceSymbol Members


%%PageItemTitle%% $$Members$$

CQGDataSourceSymbol Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Abbreviation | Returns the symbol abbreviation. This is the default property.
Public Property Description | Returns the symbol description.
Public Property Type | Returns the symbol type.

See Also

CQGDataSourceSymbol Interface


%%PageItemTitle%%

Abbreviation Property
CQGDataSourceSymbol Interface : Abbreviation Property

Glossary Item Box

Description

Returns the symbol abbreviation.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Abbreviation As String

Return Type

Symbol abbreviation, represented as String

See Also

CQGDataSourceSymbol Interface | CQGDataSourceSymbol Members


%%PageItemTitle%%

Description Property
CQGDataSourceSymbol Interface : Description Property

Glossary Item Box

Description

Returns the symbol description.

Property type

Read-only property

Syntax

Visual Basic
Public Property Description As String

Return Type

Symbol description, represented as String

See Also

CQGDataSourceSymbol Interface | CQGDataSourceSymbol Members


%%PageItemTitle%%

Type Property
CQGDataSourceSymbol Interface : Type Property

Glossary Item Box

Description

Returns the symbol type.

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As eSymbolType

Return Type

Symbol type, represented as eSymbolType

Remarks

The return value is a composition of eSymbolType values.

See Also

CQGDataSourceSymbol Interface | CQGDataSourceSymbol Members | eSymbolType Enumeration


%%PageItemTitle%%

CQGDirectEventsAccessor Interface
See Also Members Send Feedback

Glossary Item Box

Description

This class is used to raise non-dispatch events to the API user.

The API user should implement the corresponding interface and advise to this object to receive vtbl events.

Object Model

CQGDirectEventsAccessor Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGDirectEventsAccessor Members


%%PageItemTitle%% $$Members$$

CQGDirectEventsAccessor Interface Members
See Also Overview Send Feedback

Glossary Item Box

Events

Public Event CELStarted | Refer to CQGCEL.CELStarted Event.
Public Event CommodityInstrumentsResolved | Refer to CQGCEL.CommodityInstrumentsResolved Event.
Public Event CurrencyRatesChanged | Refer to CQGCEL.CurrencyRatesChanged Event.
Public Event DataConnectionStatusChanged | Refer to CQGCEL.DataConnectionStatusChanged Event.
Public Event DataError | Refer to CQGCEL.DataError Event.
Public Event GWConnectionStatusChanged | Refer to CQGCEL.GWConnectionStatusChanged Event.
Public Event IncorrectSymbol | Refer to CQGCEL.IncorrectSymbol Event.
Public Event InstrumentChanged | Refer to CQGCEL.InstrumentChanged Event.
Public Event InstrumentDOMChanged | Refer to CQGCEL.InstrumentDOMChanged Event.
Public Event InstrumentsGroupChanged | Refer to CQGCEL.InstrumentsGroupChanged Event.
Public Event InstrumentsGroupResolved | Refer to CQGCEL.InstrumentsGroupResolved Event.
Public Event InstrumentSubscribed | Refer to CQGCEL.InstrumentSubscribed Event.
Public Event IsReady | Refer to CQGCEL.IsReady Event.
Public Event LineTimeChanged | Refer to CQGCEL.LineTimeChanged Event.
Public Event OnIdle | Refer to CQGCEL.OnIdle Event.

See Also

CQGDirectEventsAccessor Interface


%%PageItemTitle%%

CELStarted Event
CQGDirectEventsAccessor Interface : CELStarted Event

Glossary Item Box

Description

Refer to CQGCEL.CELStarted Event.

Syntax

Visual Basic
Public Event CELStarted()

See Also

CQGDirectEventsAccessor Interface | CQGDirectEventsAccessor Members | CQGCEL.CELStarted Event


%%PageItemTitle%%

CommodityInstrumentsResolved Event
commodity_name
The commodity symbol that was requested by the user in the corresponding RequestCommodityInstruments method call.
instrument_types
Instrument type bitmask that was set by the user in corresponding RequestCommodityInstruments method call.
cqg_commodity_intruments
A collection, which contains names of instruments corresponding to the requested commodity and filtered by the bitmask set in RequestCommodityInstruments Method.
For example, the returned instrument name for the commodity "EP", will have the following format: "F.EPH7".
CQGDirectEventsAccessor Interface : CommodityInstrumentsResolved Event

Glossary Item Box

Description

Refer to CQGCEL.CommodityInstrumentsResolved Event.

Syntax

Visual Basic
Public Event CommodityInstrumentsResolved( _
   ByVal commodity_name As String, _
   ByVal instrument_types As eInstrumentType, _
   ByVal cqg_commodity_intruments As CQGCommodityInstruments _
)

Parameters

commodity_name
The commodity symbol that was requested by the user in the corresponding RequestCommodityInstruments method call.
instrument_types
Value | Description
itAllInstruments | Represents all instrument types.
itAllOptions | Represents Option Call and Option Put instrument types.
itFuture | Represents Futures instrument type.
itOptionCall | Represents Option Call instrument type.
itOptionPut | Represents Option Put instrument type.
itOther | Represents other (not explicitly listed in the enumeration) instrument types, such as cash, indices, currencies, reports etc.
itStock | Represents Stock instrument type.
itSyntheticStrategy | Represents synthetic strategy instrument type.
itTreasure | Represents Treasury instrument type.
itUndefined | Undefined type.
Instrument type bitmask that was set by the user in corresponding RequestCommodityInstruments method call.
cqg_commodity_intruments
A collection, which contains names of instruments corresponding to the requested commodity and filtered by the bitmask set in RequestCommodityInstruments Method.
For example, the returned instrument name for the commodity "EP", will have the following format: "F.EPH7".

See Also

CQGDirectEventsAccessor Interface | CQGDirectEventsAccessor Members | CQGCEL.CommodityInstrumentsResolved Event | CQGCEL.RequestCommodityInstruments Method


%%PageItemTitle%%

CurrencyRatesChanged Event
cqg_currency_rates
Collection of changed currency rates represented as CQGCurrencyRates.
CQGDirectEventsAccessor Interface : CurrencyRatesChanged Event

Glossary Item Box

Description

Refer to CQGCEL.CurrencyRatesChanged Event.

Syntax

Visual Basic
Public Event CurrencyRatesChanged( _
   ByVal cqg_currency_rates As CQGCurrencyRates _
)

Parameters

cqg_currency_rates
Collection of changed currency rates represented as CQGCurrencyRates.

Remarks

No CurrencyRatesChanged event is fired if account subscription level is set to aslNone.

Note: if currency rate is changed, account summaries will be recalculated. However no AccountChanged event will be fired in that case.

See Also

CQGDirectEventsAccessor Interface | CQGDirectEventsAccessor Members | CQGCEL.CurrencyRatesChanged Event


%%PageItemTitle%%

DataConnectionStatusChanged Event
new_status

Indicates connection status.

CQGDirectEventsAccessor Interface : DataConnectionStatusChanged Event

Glossary Item Box

Description

Refer to CQGCEL.DataConnectionStatusChanged Event.

Syntax

Visual Basic
Public Event DataConnectionStatusChanged( _
   ByVal new_status As eConnectionStatus _
)

Parameters

new_status
Value | Description
csConnectionDelayed | Connection is delayed.
csConnectionDown | Connection is down.
csConnectionNotLoggedOn | Connected but not logged on Gateway.
csConnectionTrouble | Trouble with Gateway connection.
csConnectionUp | Connection is up.

Indicates connection status.

Remarks

If the connection status is down no instrument updates will be fired by CQGCEL.

See Also

CQGDirectEventsAccessor Interface | CQGDirectEventsAccessor Members | CQGCEL.DataConnectionStatusChanged Event


%%PageItemTitle%%

DataError Event
cqg_error

Object where the error occurred.

Starting from CQG API v.3.0: CQGError object representing the current error.

error_description

Description of current error.

CQGDirectEventsAccessor Interface : DataError Event

Glossary Item Box

Description

Refer to CQGCEL.DataError Event.

Syntax

Visual Basic
Public Event DataError( _
   ByVal cqg_error As Object, _
   ByVal error_description As String _
)

Parameters

cqg_error

Object where the error occurred.

Starting from CQG API v.3.0: CQGError object representing the current error.

error_description

Description of current error.

See Also

CQGDirectEventsAccessor Interface | CQGDirectEventsAccessor Members | CQGCEL.DataError Event


%%PageItemTitle%%

GWConnectionStatusChanged Event
new_status
The current status of the connection with CQG Gateway.
CQGDirectEventsAccessor Interface : GWConnectionStatusChanged Event

Glossary Item Box

Description

Refer to CQGCEL.GWConnectionStatusChanged Event.

Syntax

Visual Basic
Public Event GWConnectionStatusChanged( _
   ByVal new_status As eConnectionStatus _
)

Parameters

new_status
Value | Description
csConnectionDelayed | Connection is delayed.
csConnectionDown | Connection is down.
csConnectionNotLoggedOn | Connected but not logged on Gateway.
csConnectionTrouble | Trouble with Gateway connection.
csConnectionUp | Connection is up.
The current status of the connection with CQG Gateway.

Remarks

The functionality of CQG API v.3.0 becomes available when a GWConnectionStatusChanged event with csConnectionUp argument is fired.

Note that the user should manually set the account subscription level in order to use it. This is true for all cases: even if the connection was lost during the CQG API work, after connection is up again the account subscription level will be reset to aslNone. User should set it again to the desired value. Note that it will also reset the PositionSubcriptionLevel to the default value for all accounts.

While the CQG Gateway connection status is down, no v.3.0 functionality is available and a corresponding DataError event will be fired if the user tries to use it.

See Also

CQGDirectEventsAccessor Interface | CQGDirectEventsAccessor Members | CQGCEL.GWConnectionStatusChanged Event


%%PageItemTitle%%

IncorrectSymbol Event
symbol_

String describing the error.

The name of the incorrect symbol, i.e., what was passed to the NewInstrument method.

CQGDirectEventsAccessor Interface : IncorrectSymbol Event

Glossary Item Box

Description

Refer to CQGCEL.IncorrectSymbol Event.

Syntax

Visual Basic
Public Event IncorrectSymbol( _
   ByVal symbol_ As String _
)

Parameters

symbol_

String describing the error.

The name of the incorrect symbol, i.e., what was passed to the NewInstrument method.

See Also

CQGDirectEventsAccessor Interface | CQGDirectEventsAccessor Members | CQGCEL.IncorrectSymbol Event


%%PageItemTitle%%

InstrumentChanged Event
cqg_instrument

Name of updated instrument.

cqg_quotes

Collection of changed quotes.

  • If CQGAPIConfig.NewInstrumentChangeMode is set to True:
    cqg_quotes contains prior values and current values must be obtained from CQGInstrument.Quotes; or explicitly using CQGInstrument.Trade, CQGInstrument.Bid, and CQGInstrument.Ask properties.
    However, cqg_quotes must be used to determine, which values have changed.
  • If CQGAPIConfig.NewInstrumentChangeMode is set to False:
  • cqg_quotes contains the current values.
cqg_instrument_properties

Collection of changed dynamic properties.

CQGDirectEventsAccessor Interface : InstrumentChanged Event

Glossary Item Box

Description

Refer to CQGCEL.InstrumentChanged Event.

Syntax

Visual Basic
Public Event InstrumentChanged( _
   ByVal cqg_instrument As CQGInstrument, _
   ByVal cqg_quotes As CQGQuotes, _
   ByVal cqg_instrument_properties As CQGInstrumentProperties _
)

Parameters

cqg_instrument

Name of updated instrument.

cqg_quotes

Collection of changed quotes.

  • If CQGAPIConfig.NewInstrumentChangeMode is set to True:
    cqg_quotes contains prior values and current values must be obtained from CQGInstrument.Quotes; or explicitly using CQGInstrument.Trade, CQGInstrument.Bid, and CQGInstrument.Ask properties.
    However, cqg_quotes must be used to determine, which values have changed.
  • If CQGAPIConfig.NewInstrumentChangeMode is set to False:
  • cqg_quotes contains the current values.
cqg_instrument_properties

Collection of changed dynamic properties.

See Also

CQGDirectEventsAccessor Interface | CQGDirectEventsAccessor Members | CQGCEL.InstrumentChanged Event


%%PageItemTitle%%

InstrumentDOMChanged Event
cqg_instrument

Changed instrument: its DOMAsks and DOMBids collections contain new DOM book

prev_asks

Collection of asks from previous DOM book

prev_bids

Collection of bids from previous DOM book

CQGDirectEventsAccessor Interface : InstrumentDOMChanged Event

Glossary Item Box

Description

Refer to CQGCEL.InstrumentDOMChanged Event.

Syntax

Visual Basic
Public Event InstrumentDOMChanged( _
   ByVal cqg_instrument As CQGInstrument, _
   ByVal prev_asks As CQGDOMQuotes, _
   ByVal prev_bids As CQGDOMQuotes _
)

Parameters

cqg_instrument

Changed instrument: its DOMAsks and DOMBids collections contain new DOM book

prev_asks

Collection of asks from previous DOM book

prev_bids

Collection of bids from previous DOM book

See Also

CQGDirectEventsAccessor Interface | CQGDirectEventsAccessor Members | CQGCEL.InstrumentDOMChanged Event


%%PageItemTitle%%

InstrumentsGroupChanged Event
change_type

Group change type

instruments_group

Changed group of instruments

instruments_names

The list of changed (removed/added) instruments' names

CQGDirectEventsAccessor Interface : InstrumentsGroupChanged Event

Glossary Item Box

Description

Refer to CQGCEL.InstrumentsGroupChanged Event.

Syntax

Visual Basic
Public Event InstrumentsGroupChanged( _
   ByVal change_type As eChangeType, _
   ByVal instruments_group As CQGInstrumentsGroup, _
   ByVal instruments_names As CQGStringCollection _
)

Parameters

change_type
Value | Description
ctAdded | New order is added and is already in the collection.
ctChanged | The order is changed.
ctRemoved | The order is removed from the collection.

Group change type

instruments_group

Changed group of instruments

instruments_names

The list of changed (removed/added) instruments' names

See Also

CQGDirectEventsAccessor Interface | CQGDirectEventsAccessor Members | CQGCEL.InstrumentsGroupChanged Event


%%PageItemTitle%%

InstrumentsGroupResolved Event
instruments_group

Group of the subscribed instruments

cqg_error

CQGError object describing the error occurred during registration if it fails, or Nothing/Invalid_Error in case of succeed.

CQGCEL.IsValid(Invalid_Error) returns False.

CQGDirectEventsAccessor Interface : InstrumentsGroupResolved Event

Glossary Item Box

Description

Refer to CQGCEL.InstrumentsGroupResolved Event.

Syntax

Visual Basic
Public Event InstrumentsGroupResolved( _
   ByVal instruments_group As CQGInstrumentsGroup, _
   ByVal cqg_error As CQGError _
)

Parameters

instruments_group

Group of the subscribed instruments

cqg_error

CQGError object describing the error occurred during registration if it fails, or Nothing/Invalid_Error in case of succeed.

CQGCEL.IsValid(Invalid_Error) returns False.

See Also

CQGDirectEventsAccessor Interface | CQGDirectEventsAccessor Members | CQGCEL.InstrumentsGroupResolved Event


%%PageItemTitle%%

InstrumentSubscribed Event
symbol_
the commodity symbol that was requested by user in NewInstrument method
cqg_instrument

resolved CQGInstrument object

CQGDirectEventsAccessor Interface : InstrumentSubscribed Event

Glossary Item Box

Description

Refer to CQGCEL.InstrumentSubscribed Event.

Syntax

Visual Basic
Public Event InstrumentSubscribed( _
   ByVal symbol_ As String, _
   ByVal cqg_instrument As CQGInstrument _
)

Parameters

symbol_
the commodity symbol that was requested by user in NewInstrument method
cqg_instrument

resolved CQGInstrument object

Remarks

InstrumentSubscribed is also fired if a duplicate resolution is attempted. In that case the Instrument parameter returns the same object as it returned the first time.

See Also

CQGDirectEventsAccessor Interface | CQGDirectEventsAccessor Members | CQGCEL.InstrumentSubscribed Event


%%PageItemTitle%%

IsReady Event
ready_status

readyStatus should reflect the Excel.Application.Ready flag. If Application.Ready is True, then readyStatus should be assigned rsReady. If Application.Ready is False then readyStatus should be assigned rsNotReady.

If CQGCEL gets rsBusy or rsNotReady, the attempt is repeated after the timeout, until CQGCEL gets rsReady and becomes able to process its own events.

CQGDirectEventsAccessor Interface : IsReady Event

Glossary Item Box

Description

Refer to CQGCEL.IsReady Event.

Syntax

Visual Basic
Public Event IsReady( _
   ByRef ready_status As eReadyStatus _
)

Parameters

ready_status
Value Description
rsBusy

The host application (MS Excel) is in edit mode.

rsNotReady

The host application (MS Excel) isn't ready (when Application.Ready = False).

rsReady

The host application (MS Excel) is ready (when Application.Ready = True).

readyStatus should reflect the Excel.Application.Ready flag. If Application.Ready is True, then readyStatus should be assigned rsReady. If Application.Ready is False then readyStatus should be assigned rsNotReady.

If CQGCEL gets rsBusy or rsNotReady, the attempt is repeated after the timeout, until CQGCEL gets rsReady and becomes able to process its own events.

See Also

CQGDirectEventsAccessor Interface | CQGDirectEventsAccessor Members | CQGCEL.IsReady Event


%%PageItemTitle%%

LineTimeChanged Event
new_line_time
Date containing the line time (time on the current exchange) converted to the timezone previously set by the user
CQGDirectEventsAccessor Interface : LineTimeChanged Event

Glossary Item Box

Description

Refer to CQGCEL.LineTimeChanged Event.

Syntax

Visual Basic
Public Event LineTimeChanged( _
   ByVal new_line_time As Date _
)

Parameters

new_line_time
Date containing the line time (time on the current exchange) converted to the timezone previously set by the user

Remarks

Line time is converted to the user timezone set in TimeZoneCode property. If no timezone is set by the user, the time is converted to UTC.

See Also

CQGDirectEventsAccessor Interface | CQGDirectEventsAccessor Members | CQGCEL.LineTimeChanged Event


%%PageItemTitle%%

OnIdle Event
CQGDirectEventsAccessor Interface : OnIdle Event

Glossary Item Box

Description

Refer to CQGCEL.OnIdle Event.

Syntax

Visual Basic
Public Event OnIdle()

See Also

CQGDirectEventsAccessor Interface | CQGDirectEventsAccessor Members | CQGCEL.OnIdle Event


%%PageItemTitle%%

CQGEnvironment Interface
See Also Members Send Feedback

Glossary Item Box

Description

The CQGEnvironment is an informational interface, which stores the CQG API environment information.

The CQGEnvironment includes information on versions, connection statuses, current times (on PC and on Exchange), internal status of CQGCEL, etc.

Object Model

CQGEnvironment InterfaceCQGCEL InterfaceCQGError InterfaceCQGRemoteOpenAPISession Interface

Example

See the usage of CQGOrder object in the LineTimeChanged event's example section.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGEnvironment Members


%%PageItemTitle%% $$Members$$

CQGEnvironment Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property CEL | Returns the corresponding CQGCEL object.
Public Property CELVersion | Returns the current CQG API version.
Public Property CQGSerialNumber | Returns the CQGIC Serial Number.
Public Property CQGVersion | Returns the CQGIC version.
Public Property DataConnectionStatus | Returns the status of the connection with the CQG data server.
Public Property GWConnectionStatus | Returns the status of the connection with CQG Gateway.
Public Property GWLogonName | Returns the trader name, which is currently used to logon to the CQG Gateway.
Public Property LastError | Returns the last data error which occurred in CQG API.
Public Property LineTime | Returns the current time on the exchange, converted to the previously configured timezone.
Public Property LocalTime | Returns the computer current time converted to previously configured timezone.
Public Property MessagesPending | Returns the number of pending messages in the message queue.
Public Property OrdersPending | Property is deprecated.
Public Property RemoteOpenAPISession | Gets remote Open API connection properties

See Also

CQGEnvironment Interface


%%PageItemTitle%%

CEL Property
CQGEnvironment Interface : CEL Property

Glossary Item Box

Description

Returns the corresponding CQGCEL object.

Property type

Read-only property

Syntax

Visual Basic
Public Property CEL As CQGCEL

Return Type

CQGCEL object to which this CQGEnvironment belongs.

Remarks

This property will be convenient for those who are used to use the VBA specific Parent option.

Example

For the CQGEnvironment properties usage see the example section of LineTimeChanged event.

See Also

CQGEnvironment Interface | CQGEnvironment Members | CQGCEL Interface


%%PageItemTitle%%

CELVersion Property
CQGEnvironment Interface : CELVersion Property

Glossary Item Box

Description

Returns the current CQG API version.

Property type

Read-only property

Syntax

Visual Basic
Public Property CELVersion As String

Return Type

CQG API version string.

Example

See the example section of LineTimeChanged event.

See Also

CQGEnvironment Interface | CQGEnvironment Members


%%PageItemTitle%%

CQGSerialNumber Property
CQGEnvironment Interface : CQGSerialNumber Property

Glossary Item Box

Description

Returns the CQGIC Serial Number.

Property type

Read-only property

Syntax

Visual Basic
Public Property CQGSerialNumber As Long

Return Type

CQGIC serial number represented as Long

Remarks

CQGIC serial number is unique for each CQGIC subscription.

In CQGIC you can find your version number by checking the System Status information.

Example

See the usage of CQGEnvironment properties in the LineTimeChanged event's example section.

See Also

CQGEnvironment Interface | CQGEnvironment Members


%%PageItemTitle%%

CQGVersion Property
CQGEnvironment Interface : CQGVersion Property

Glossary Item Box

Description

Returns the CQGIC version.

Property type

Read-only property

Syntax

Visual Basic
Public Property CQGVersion As String

Return Type

CQGIC software version represented as String

Remarks

In CQGIC you can find your version number by checking the System Status information.

Example

See the usage of CQGEnvironment properties in the LineTimeChanged event's example section.

See Also

CQGEnvironment Interface | CQGEnvironment Members


%%PageItemTitle%%

DataConnectionStatus Property
CQGEnvironment Interface : DataConnectionStatus Property

Glossary Item Box

Description

Returns the status of the connection with the CQG data server.

Property type

Read-only property

Syntax

Visual Basic
Public Property DataConnectionStatus As eConnectionStatus

Return Type

Current status represented as eConnectionStatus.

Remarks

When the connection status is changed, the DataConnectionStatusChanged event is fired.

Example

See the example section of LineTimeChanged event.

See Also

CQGEnvironment Interface | CQGEnvironment Members


%%PageItemTitle%%

GWConnectionStatus Property
CQGEnvironment Interface : GWConnectionStatus Property

Glossary Item Box

Description

Returns the status of the connection with CQG Gateway.

Property type

Read-only property

Syntax

Visual Basic
Public Property GWConnectionStatus As eConnectionStatus

Return Type

Current connection status represented as eConnectionStatus

Remarks

When the connection status is changed, the GWConnectionStatusChanged event is fired.

Example

See the usage of CQGEnvironment properties in the LineTimeChanged event's example section.

See Also

CQGEnvironment Interface | CQGEnvironment Members


%%PageItemTitle%%

GWLogonName Property
CQGEnvironment Interface : GWLogonName Property

Glossary Item Box

Description

Returns the trader name, which is currently used to logon to the CQG Gateway.

Property type

Read-only property

Syntax

Visual Basic
Public Property GWLogonName As String

Return Type

Trader login name represented as String.

Empty string if the user is not logged on to CQG Gateway.

Remarks

Note: Logging on to the CQGIC is different from logging on to the CQG Gateway.

You log on to CQGIC using your CQGIC user name upon CQGIC startup.

You log on to the CQG Gateway using your trader logon name when you want to place orders, etc.

Example

See the usage of CQGEnvironment properties in the LineTimeChanged event's example section.

See Also

CQGEnvironment Interface | CQGEnvironment Members


%%PageItemTitle%%

LastError Property
CQGEnvironment Interface : LastError Property

Glossary Item Box

Description

Returns the last data error which occurred in CQG API.

Property type

Read-only property

Syntax

Visual Basic
Public Property LastError As CQGError

Return Type

Last error object represented as CQGError

Remarks

While there is no error the value of this property remains Nothing.

When an error occurs in CQG API a DataError event is fired, passing the error object as argument.

Example

See the usage of CQGEnvironment properties in the LineTimeChanged event's example section.

See Also

CQGEnvironment Interface | CQGEnvironment Members


%%PageItemTitle%%

LineTime Property
CQGEnvironment Interface : LineTime Property

Glossary Item Box

Description

Returns the current time on the exchange, converted to the previously configured timezone.

Property type

Read-only property

Syntax

Visual Basic
Public Property LineTime As Date

Return Type

Date variable filled with data received from the exchange.

Remarks

If no timezone is configured by the user, the exchange time is converted to UTC.

LineTime property is updated every second when the LineTimeChanged event is fired.

Example

See the example section of LineTimeChanged event.

See Also

CQGEnvironment Interface | CQGEnvironment Members


%%PageItemTitle%%

LocalTime Property
CQGEnvironment Interface : LocalTime Property

Glossary Item Box

Description

Returns the computer current time converted to previously configured timezone.

Property type

Read-only property

Syntax

Visual Basic
Public Property LocalTime As Date

Return Type

Date variable filled with PC local time.

Remarks

If no timezone is configured by the user, the local time is converted to UTC.

LocalTime property is updated on access.

Example

See the example section of the LineTimeChanged event.

See Also

CQGEnvironment Interface | CQGEnvironment Members


%%PageItemTitle%%

MessagesPending Property
CQGEnvironment Interface : MessagesPending Property

Glossary Item Box

Description

Returns the number of pending messages in the message queue.

Property type

Read-only property

Syntax

Visual Basic
Public Property MessagesPending As Long

Return Type

Current number of messages in the queue represented as Long

Remarks

All responses from the CQGCEL pass through the message queue.

Example

See the example section of the LineTimeChanged event.

See Also

CQGEnvironment Interface | CQGEnvironment Members


%%PageItemTitle%%

OrdersPending Property
CQGEnvironment Interface : OrdersPending Property

Glossary Item Box

Description

Property is deprecated.

Property type

Read-only property

Syntax

Visual Basic
Public Property OrdersPending As Long

Return Type

E_NOTIMPL COM error.

See Also

CQGEnvironment Interface | CQGEnvironment Members


%%PageItemTitle%%

RemoteOpenAPISession Property
CQGEnvironment Interface : RemoteOpenAPISession Property

Glossary Item Box

Description

Gets remote Open API connection properties

Property type

Read-only property

Syntax

Visual Basic
Public Property RemoteOpenAPISession As CQGRemoteOpenAPISession

See Also

CQGEnvironment Interface | CQGEnvironment Members


%%PageItemTitle%%

CQGError Interface
See Also Members Send Feedback

Glossary Item Box

Description

The CQGError interface encapsulates the possible errors which may arise in CQG API.

Object Model

CQGError Interface

Remarks

When an error occurs during CQG API work, the user will be notified about it via DataError event.

The last occurred error will be available from CQGEnvironment.LastError.

For a list of error codes defined in CQG API see the Error Codes table.

Example

See the usage of CQGError object in the OnQueryProgress event's example section.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGError Members


%%PageItemTitle%% $$Members$$

CQGError Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Code | Returns the error code value. This is the default property.
Public Property Description | Returns description of current error.
Public Property Owner | Returns the object, which has thrown the current error.

See Also

CQGError Interface


%%PageItemTitle%%

Code Property
CQGError Interface : Code Property

Glossary Item Box

Description

Returns the error code value.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Code As Long

Return Type

Error code represented as Long

Remarks

For a list of error codes see the Error Codes table.

Example

See the usage of CQGError properties in the OnQueryProgress event's example section.

See Also

CQGError Interface | CQGError Members


%%PageItemTitle%%

Description Property
CQGError Interface : Description Property

Glossary Item Box

Description

Returns description of current error.

Property type

Read-only property

Syntax

Visual Basic
Public Property Description As String

Return Type

Error description represented as String

Example

See the usage of CQGError properties in the OnQueryProgress event's example section.

See Also

CQGError Interface | CQGError Members


%%PageItemTitle%%

Owner Property
CQGError Interface : Owner Property

Glossary Item Box

Description

Returns the object, which has thrown the current error.

Property type

Read-only property

Syntax

Visual Basic
Public Property Owner As Object

Return Type

An object of any type declared in CQG API depending on the source of current error.

Example

See the usage of CQGError properties in the OnQueryProgress event's example section.

See Also

CQGError Interface | CQGError Members


%%PageItemTitle%%

CQGExecutionPattern Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a strategy execution pattern for a strategy order and its legs.

Object Model

CQGExecutionPattern InterfaceCQGExecutionPatternParameters CollectionCQGExecutionPatternParameter Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGExecutionPattern Members


%%PageItemTitle%% $$Members$$

CQGExecutionPattern Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Parameters | Returns the collection of execution pattern common parameters.
Public Property PatternString | Returns the string representation of the execution pattern.

See Also

CQGExecutionPattern Interface


%%PageItemTitle%%

Parameters Property
CQGExecutionPattern Interface : Parameters Property

Glossary Item Box

Description

Returns the collection of execution pattern common parameters.

Property type

Read-only property

Syntax

Visual Basic
Public Property Parameters As CQGExecutionPatternParameters

Return Type

Collection of execution pattern parameters, represented as CQGExecutionPatternParameters

See Also

CQGExecutionPattern Interface | CQGExecutionPattern Members | CQGExecutionPatternParameters Collection


%%PageItemTitle%%

PatternString Property
CQGExecutionPattern Interface : PatternString Property

Glossary Item Box

Description

Returns the string representation of the execution pattern.

Property type

Read-only property

Syntax

Visual Basic
Public Property PatternString As String

Return Type

Execution pattern string, represented as String

See Also

CQGExecutionPattern Interface | CQGExecutionPattern Members


%%PageItemTitle%%

CQGExecutionPatternParameter Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a strategy execution pattern parameter.

Object Model

CQGExecutionPatternParameter InterfaceCQGExecutionPatternParameters CollectionCQGExecutionPatternParameter Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGExecutionPatternParameter Members


%%PageItemTitle%% $$Members$$

CQGExecutionPatternParameter Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Name | Returns the name of the parameter.
Public Property Parameters | Returns the sub-parameters of this parameter.
Public Property Type | Returns the type of the parameter.
Public Property Value | Sets/gets the value of the parameter.

See Also

CQGExecutionPatternParameter Interface


%%PageItemTitle%%

Name Property
CQGExecutionPatternParameter Interface : Name Property

Glossary Item Box

Description

Returns the name of the parameter.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

Return Type

Parameter name, represented as String

See Also

CQGExecutionPatternParameter Interface | CQGExecutionPatternParameter Members


%%PageItemTitle%%

Parameters Property
CQGExecutionPatternParameter Interface : Parameters Property

Glossary Item Box

Description

Returns the sub-parameters of this parameter.

Property type

Read-only property

Syntax

Visual Basic
Public Property Parameters As CQGExecutionPatternParameters

Return Type

The sub-parameters collection, represented as CQGExecutionPatternParameters

Remarks

This property should be used if the parameter type is epptObject, epptCollection, or epptCollectionItem.

If the parameter type is epptCollection, then only parameters of epptCollectionItem type are allowed as sub-parameters.

See Also

CQGExecutionPatternParameter Interface | CQGExecutionPatternParameter Members | CQGExecutionPatternParameters Collection | eExecutionPatternParameterType Enumeration


%%PageItemTitle%%

Type Property
CQGExecutionPatternParameter Interface : Type Property

Glossary Item Box

Description

Returns the type of the parameter.

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As eExecutionPatternParameterType

Return Type

Parameter type, represented as eExecutionPatternParameterType

See Also

CQGExecutionPatternParameter Interface | CQGExecutionPatternParameter Members | eExecutionPatternParameterType Enumeration


%%PageItemTitle%%

Value Property
CQGExecutionPatternParameter Interface : Value Property

Glossary Item Box

Description

Sets/gets the value of the parameter.

Property type

Read-write property

Syntax

Visual Basic
Public Property Value As String

Return Type

Parameter value, represented as String

Remarks

This property should not be used if the parameter type is epptObject, epptCollection, or epptCollectionItem.

See Also

CQGExecutionPatternParameter Interface | CQGExecutionPatternParameter Members


%%PageItemTitle%%

CQGExpressionRequest Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents parameters used to formulate an expression request.

Object Model

CQGExpressionRequest Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGExpressionRequest Members


%%PageItemTitle%% $$Members$$

CQGExpressionRequest Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method AddSubExpression

Adds a new sub-expression to the expression.

Public Properties

Public Property Continuation | Sets/gets the continuation type, which will be used to formulate the expression request. The default value is tsctNoContinuation.
Public Property DaysBeforeExpiration | Sets/gets the number of days prior to expiration, when the rollover will occur, to be used to formulate the expression request. The default value for this property is 0.
Public Property EqualizeCloses | Gets/sets the equalize closes flag, which will be used to formulate the expression request. The default value for this property is True.
Public Property HistoricalPeriod | Sets/gets the historical period, which will be used to formulate the expression request. The default value for this property is hpUndefined.
Public Property IncludeEnd | Sets/gets the include end flag, which will be used to formulate the expression request. The default value for this property is False.
Public Property IntradayPeriod | Sets/gets the intraday period, which will be used to formulate the expression request.
Public Property RangeEnd | Sets/gets the range end, which will be used to formulate the expression request (required).
Public Property RangeStart | Sets/gets the range start, which will be used to formulate the expression request (required).
Public Property RecalcPeriod | Sets/gets the recalculation period (in seconds), which will be used to formulate the expression request. The default value for this property is 60.
Public Property SessionFlags | Sets/gets the session flags, which will be used to formulate the expression request. The default value for this property is sfUndefined.
Public Property SessionsFilter | Sets/gets the sessions filter, which will be used to formulate the expression request. The default value for this property is 0.
Public Property SubExpression | Returns the sub-expression by its index.
Public Property SubExpressionAlias | Returns the sub-expression alias by its index.
Public Property SubExpressionCount | Returns the number of sub-expressions in the CQGExpressionRequest.
Public Property SubscriptionLevel | Sets/gets the subscription level, which will be used to formulate the expression request. The default value for this property is tslEachBar.
Public Property UpdatesEnabled | Gets/sets the updates enabled flag, which will be used to formulate the expression request. The default value for this property is False.

See Also

CQGExpressionRequest Interface


%%PageItemTitle%%

AddSubExpression Method
sub_expression

The sub-expression string.

Please refer to the CQG Studies page for more information on how to formulate a sub-expression.

alias_

Sub-expression's alias (optional).

If not provided, it will be generated from sub_expression.

Aliases are case-insensitive.

Duplicate aliases in the same request are not allowed.

CQGExpressionRequest Interface : AddSubExpression Method

Glossary Item Box

Description

Adds a new sub-expression to the expression.

Syntax

Visual Basic
Public Sub AddSubExpression( _
   ByVal sub_expression As String, _
   Optional ByVal alias_ As String = "" _
)

Parameters

sub_expression

The sub-expression string.

Please refer to the CQG Studies page for more information on how to formulate a sub-expression.

alias_

Sub-expression's alias (optional).

If not provided, it will be generated from sub_expression.

Aliases are case-insensitive.

Duplicate aliases in the same request are not allowed.

Remarks

An exception will be thrown if sub_expression is empty.

An exception will be thrown if the provided or generated alias duplicates (case-insensitively) an existing alias in the expression request.

See Also

CQGExpressionRequest Interface | CQGExpressionRequest Members


%%PageItemTitle%%

Continuation Property
CQGExpressionRequest Interface : Continuation Property

Glossary Item Box

Description

Sets/gets the continuation type, which will be used to formulate the expression request.

The default value is tsctNoContinuation.

Property type

Read-write property

Syntax

Visual Basic
Public Property Continuation As eTimeSeriesContinuationType

Return Type

Continuation type, represented as eTimeSeriesContinuationType

Remarks

See eTimeSeriesContinuationType enumeration for possible values.

See Also

CQGExpressionRequest Interface | CQGExpressionRequest Members | eTimeSeriesContinuationType Enumeration


%%PageItemTitle%%

DaysBeforeExpiration Property
CQGExpressionRequest Interface : DaysBeforeExpiration Property

Glossary Item Box

Description

Sets/gets the number of days prior to expiration, when the rollover will occur, to be used to formulate the expression request.

The default value for this property is 0.

Property type

Read-write property

Syntax

Visual Basic
Public Property DaysBeforeExpiration As Long

Return Type

Number of days prior to expiration, represented as Long

Remarks

This property has effect only when the Continuation property indicates an adjusted continuation.

See Also

CQGExpressionRequest Interface | CQGExpressionRequest Members | CQGExpressionRequest.Continuation Property


%%PageItemTitle%%

EqualizeCloses Property
CQGExpressionRequest Interface : EqualizeCloses Property

Glossary Item Box

Description

Gets/sets the equalize closes flag, which will be used to formulate the expression request.

The default value for this property is True.

Property type

Read-write property

Syntax

Visual Basic
Public Property EqualizeCloses As Boolean

Return Type

True (default), if closes should be equalized; False, otherwise

Remarks

This property has effect only when the Continuation property indicates an active or adjusted continuation.

See Also

CQGExpressionRequest Interface | CQGExpressionRequest Members | CQGExpressionRequest.Continuation Property


%%PageItemTitle%%

HistoricalPeriod Property
CQGExpressionRequest Interface : HistoricalPeriod Property

Glossary Item Box

Description

Sets/gets the historical period, which will be used to formulate the expression request.

The default value for this property is hpUndefined.

Property type

Read-write property

Syntax

Visual Basic
Public Property HistoricalPeriod As eHistoricalPeriod

Return Type

Historical period, represented as eHistoricalPeriod

See Also

CQGExpressionRequest Interface | CQGExpressionRequest Members | eHistoricalPeriod Enumeration


%%PageItemTitle%%

IncludeEnd Property
CQGExpressionRequest Interface : IncludeEnd Property

Glossary Item Box

Description

Sets/gets the include end flag, which will be used to formulate the expression request.

The default value for this property is False.

Property type

Read-write property

Syntax

Visual Basic
Public Property IncludeEnd As Boolean

Return Type

True, if end should be included; False (default), otherwise

Remarks

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGExpressionRequest Interface | CQGExpressionRequest Members


%%PageItemTitle%%

IntradayPeriod Property
CQGExpressionRequest Interface : IntradayPeriod Property

Glossary Item Box

Description

Sets/gets the intraday period, which will be used to formulate the expression request.

Property type

Read-write property

Syntax

Visual Basic
Public Property IntradayPeriod As Long

Return Type

Intraday period, represented as Long

See Also

CQGExpressionRequest Interface | CQGExpressionRequest Members


%%PageItemTitle%%

RangeEnd Property
CQGExpressionRequest Interface : RangeEnd Property

Glossary Item Box

Description

Sets/gets the range end, which will be used to formulate the expression request (required).

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeEnd As Variant

Return Type

Range end, represented as Variant

Remarks

Only Date and integer are allowed for types of RangeStart/RangeEnd properties.

  • If the type is Date, RangeStart/RangeEnd represent date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode). Non-timed bar requests process date/time range values with a precision of up to minutes.
  • All combinations of Date and integer can apply for these properties, except integer/Date.
  • If RangeEnd type is integer, then it represents the count of records prior to RangeStart to be requested, so it must be a negative value.
  • If RangeEnd is date, it must be further in time than RangeStart.

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGExpressionRequest Interface | CQGExpressionRequest Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

RangeStart Property
CQGExpressionRequest Interface : RangeStart Property

Glossary Item Box

Description

Sets/gets the range start, which will be used to formulate the expression request (required).

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeStart As Variant

Return Type

Range start, represented as Variant

Remarks

Only Date and integer are allowed for types of RangeStart/RangeEnd properties:

  • All combinations of Date and Integer can apply for these properties, except Integer/Date.
  • If type is Date, RangeStart represents date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode). Non-timed bar requests process date/time range values with a precision of up to minutes.
  • If type is Integer, RangeStart represents the current condition's result number (0 is the current condition result number, negative numbers represent condition results in the past, positive numbers - in the future).
  • If the type of RangeStart is integer, it shall be 0 (denoting "current").

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGExpressionRequest Interface | CQGExpressionRequest Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

RecalcPeriod Property
CQGExpressionRequest Interface : RecalcPeriod Property

Glossary Item Box

Description

Sets/gets the recalculation period (in seconds), which will be used to formulate the expression request.

The default value for this property is 60.

Property type

Read-write property

Syntax

Visual Basic
Public Property RecalcPeriod As Long

Return Type

Recalculation period in seconds, represented as Long

Remarks

Only positive values are allowed for this property.

See Also

CQGExpressionRequest Interface | CQGExpressionRequest Members


%%PageItemTitle%%

SessionFlags Property
CQGExpressionRequest Interface : SessionFlags Property

Glossary Item Box

Description

Sets/gets the session flags, which will be used to formulate the expression request.

The default value for this property is sfUndefined.

Property type

Read-write property

Syntax

Visual Basic
Public Property SessionFlags As eSessionFlag

Return Type

Session flags, represented as eSessionFlag

Remarks

See the eSessionFlag enumeration for possible values.

See Also

CQGExpressionRequest Interface | CQGExpressionRequest Members | eSessionFlag Enumeration


%%PageItemTitle%%

SessionsFilter Property
CQGExpressionRequest Interface : SessionsFilter Property

Glossary Item Box

Description

Sets/gets the sessions filter, which will be used to formulate the expression request.

The default value for this property is 0.

Property type

Read-write property

Syntax

Visual Basic
Public Property SessionsFilter As Variant

Return Type

Sessions filter, represented as Variant

Remarks

Only String and integer are considered for SessionsFilter type.

  • If type is integer, SessionsFilter represents session number.
    Special values: 0 represents primary sessions only, 31 represents all sessions.
  • If type is String, SessionsFilter represents custom session name.
    Special values: "all" and "primaryOnly" are equivalent to 31 and 0, respectively.
  • If other types are used for SessionsFilter, SessionsFilter is ignored.

See Also

CQGExpressionRequest Interface | CQGExpressionRequest Members


%%PageItemTitle%%

SubExpression Property
index_
Zero-based sequential index of sub-expression
CQGExpressionRequest Interface : SubExpression Property

Glossary Item Box

Description

Returns the sub-expression by its index.

Property type

Read-only property

Syntax

Visual Basic
Public Property SubExpression( _
   ByVal index_ As Long _
) As

Parameters

index_
Zero-based sequential index of sub-expression

Return Type

Sub-expression, represented as String

See Also

CQGExpressionRequest Interface | CQGExpressionRequest Members


%%PageItemTitle%%

SubExpressionAlias Property
index_
Zero-based sequential index of sub-expression
CQGExpressionRequest Interface : SubExpressionAlias Property

Glossary Item Box

Description

Returns the sub-expression alias by its index.

Property type

Read-only property

Syntax

Visual Basic
Public Property SubExpressionAlias( _
   ByVal index_ As Long _
) As String

Parameters

index_
Zero-based sequential index of sub-expression

Return Type

Sub-expression alias, represented as String

See Also

CQGExpressionRequest Interface | CQGExpressionRequest Members


%%PageItemTitle%%

SubExpressionCount Property
CQGExpressionRequest Interface : SubExpressionCount Property

Glossary Item Box

Description

Returns the number of sub-expressions in the CQGExpressionRequest.

Property type

Read-only property

Syntax

Visual Basic
Public Property SubExpressionCount As Long

Return Type

Number of sub-expressions, represented as Long

See Also

CQGExpressionRequest Interface | CQGExpressionRequest Members


%%PageItemTitle%%

SubscriptionLevel Property
CQGExpressionRequest Interface : SubscriptionLevel Property

Glossary Item Box

Description

Sets/gets the subscription level, which will be used to formulate the expression request.

The default value for this property is tslEachBar.

Property type

Read-write property

Syntax

Visual Basic
Public Property SubscriptionLevel As eTimeSeriesSubscriptionLevel

Return Type

Subscription level, represented as eTimeSeriesSubscriptionLevel

See Also

CQGExpressionRequest Interface | CQGExpressionRequest Members | eTimeSeriesSubscriptionLevel Enumeration


%%PageItemTitle%%

UpdatesEnabled Property
CQGExpressionRequest Interface : UpdatesEnabled Property

Glossary Item Box

Description

Gets/sets the updates enabled flag, which will be used to formulate the expression request.

The default value for this property is False.

Property type

Read-write property

Syntax

Visual Basic
Public Property UpdatesEnabled As Boolean

Return Type

True, if the updates are enabled; False (default), otherwise

See Also

CQGExpressionRequest Interface | CQGExpressionRequest Members


%%PageItemTitle%%

CQGFill Interface
See Also Members Send Feedback

Glossary Item Box

Description

The CQGFill interface encapsulates all the information on a fill.

Object Model

CQGFill InterfaceCQGGWTrades CollectionCQGGWTrade InterfaceCQGOrder Interface

Remarks

Fills have the notion of legs. Any fill has at least one leg. If the order instrument is spread, the number of legs will be more than one.

All fill properties are adjusted to the leg notion by accepting indexes; where the index 1 implies the first leg, index 2 implies the second, etc.

Index 0 gives the actual value of the spread. If there was only one leg, contents of fill properties with index 0 and index 1 will be equal.

Example

See the usage of CQGFill object in the OrderChanged event's example section.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGFill Members


%%PageItemTitle%% $$Members$$

CQGFill Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Aggressive | Returns the aggressiveness for the fill's leg.
Public Property Commission | Gets commission charged for a fill
Public Property CommissionCurrency | Gets fill commission currency (ISO code of currency used to express commission)
Public Property Currency | Returns the fill's leg currency.
Public Property DisplayPrice | Returns the display price of the fill's leg.
Public Property ExchangeTradeDate | Gets exchange trade date
Public Property GWTradeId | Returns the Gateway trade identifier of the fill's leg.
Public Property GWTrades | Gets the collection of trades for the specified leg
Public Property GWTradesCount | Returns GWTrades count for specified leg
Public Property Id | Returns the CQG Gateway fill identifier.
Public Property InstrumentName | Returns the instrument full name of the fill's leg.
Public Property LegCount | Returns the actual number of legs for the current fill.
Public Property Order | Returns the corresponding CQGOrder object.
Public Property Price | Returns the fill price for the leg.
Public Property Quantity | Returns the filled quantity of the leg.
Public Property QuantityFractional | Gets a fill fractional quantity
Public Property RefFillId | Returns the identifier of the referenced fill.
Public Property ServerTimestamp | Timestamp of the last change (server time, converted to the configured time zone). Each fill change forces this property to change its value.
Public Property Side | Returns the side of fill's leg.
Public Property StatementDate | Gets statement date for the fill
Public Property Status | Returns the status of the fill.
Public Property Timestamp | Returns the last response reception timestamp. When a property is updated, CQG API records the information reception time in the Timestamp property (using local time). Each fill change forces this property to change its value.

See Also

CQGFill Interface


%%PageItemTitle%%

Aggressive Property
leg_
The leg to get data for
CQGFill Interface : Aggressive Property

Glossary Item Box

Description

Returns the aggressiveness for the fill's leg.

Property type

Read-only property

Syntax

Visual Basic
Public Property Aggressive( _
   Optional ByVal leg_ As Long = 0 _
) As Boolean

Parameters

leg_
The leg to get data for

Return Type

True if aggressive, False otherwise.

Remarks

This property is valid only for legs and not for the whole CQGFill.

Example

See the usage of CQGFill properties in the OrderChanged event's example section.

See Also

CQGFill Interface | CQGFill Members


%%PageItemTitle%%

Commission Property
CQGFill Interface : Commission Property

Glossary Item Box

Description

Gets commission charged for a fill

Property type

Read-only property

Syntax

Visual Basic
Public Property Commission As Double

See Also

CQGFill Interface | CQGFill Members


%%PageItemTitle%%

CommissionCurrency Property
CQGFill Interface : CommissionCurrency Property

Glossary Item Box

Description

Gets fill commission currency (ISO code of currency used to express commission)

Property type

Read-only property

Syntax

Visual Basic
Public Property CommissionCurrency As String

See Also

CQGFill Interface | CQGFill Members


%%PageItemTitle%%

Currency Property
leg_
The leg to get data for
CQGFill Interface : Currency Property

Glossary Item Box

Description

Returns the fill's leg currency.

Property type

Read-only property

Syntax

Visual Basic
Public Property Currency( _
   Optional ByVal leg_ As Long = 0 _
) As String

Parameters

leg_
The leg to get data for

Return Type

The ISO code of the currency represented as String.

Remarks

This property is valid only for legs and not for the whole CQGFill.

Example

See the usage of CQGFill properties in the OrderChanged event's example section.

See Also

CQGFill Interface | CQGFill Members


%%PageItemTitle%%

DisplayPrice Property
leg_
The leg to get data for
CQGFill Interface : DisplayPrice Property

Glossary Item Box

Description

Returns the display price of the fill's leg.

Property type

Read-only property

Syntax

Visual Basic
Public Property DisplayPrice( _
   Optional ByVal leg_ As Long = 0 _
) As String

Parameters

leg_
The leg to get data for

Return Type

The display price represented as String.

Remarks

This property is valid only for legs and not for the whole CQGFill.

Example

See the usage of CQGFill properties in the OrderChanged event's example section.

See Also

CQGFill Interface | CQGFill Members


%%PageItemTitle%%

ExchangeTradeDate Property
leg_
The leg to get data for
CQGFill Interface : ExchangeTradeDate Property

Glossary Item Box

Description

Gets exchange trade date

Property type

Read-only property

Syntax

Visual Basic
Public Property ExchangeTradeDate( _
   Optional ByVal leg_ As Long = 0 _
) As Date

Parameters

leg_
The leg to get data for

See Also

CQGFill Interface | CQGFill Members


%%PageItemTitle%%

GWTradeId Property
leg_
The leg to get data for
CQGFill Interface : GWTradeId Property

Glossary Item Box

Description

Returns the Gateway trade identifier of the fill's leg.

Property type

Read-only property

Syntax

Visual Basic
Public Property GWTradeId( _
   Optional ByVal leg_ As Long = 0 _
) As String

Parameters

leg_
The leg to get data for

Return Type

Trade identifier, represented as String

invalid value if no trade exists.

Remarks

This property is valid only for legs and not for the whole CQGFill.

Example

See the usage of CQGFill properties in the OrderChanged event's example section.

See Also

CQGFill Interface | CQGFill Members


%%PageItemTitle%%

GWTrades Property
leg_
The leg to get data for
CQGFill Interface : GWTrades Property

Glossary Item Box

Description

Gets the collection of trades for the specified leg

Property type

Read-only property

Syntax

Visual Basic
Public Property GWTrades( _
   Optional ByVal leg_ As Long = 0 _
) As CQGGWTrades

Parameters

leg_
The leg to get data for

See Also

CQGFill Interface | CQGFill Members


%%PageItemTitle%%

GWTradesCount Property
leg_
The leg to get data for
CQGFill Interface : GWTradesCount Property

Glossary Item Box

Description

Returns GWTrades count for specified leg

Property type

Read-only property

Syntax

Visual Basic
Public Property GWTradesCount( _
   ByVal leg_ As Long _
) As Long

Parameters

leg_
The leg to get data for

See Also

CQGFill Interface | CQGFill Members


%%PageItemTitle%%

Id Property
CQGFill Interface : Id Property

Glossary Item Box

Description

Returns the CQG Gateway fill identifier.

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

Return Type

Fill identifier, represented as String

Example

See the usage of CQGFill properties in the OrderChanged event's example section.

See Also

CQGFill Interface | CQGFill Members


%%PageItemTitle%%

InstrumentName Property
leg_
The leg to get data for
CQGFill Interface : InstrumentName Property

Glossary Item Box

Description

Returns the instrument full name of the fill's leg.

Property type

Read-only property

Syntax

Visual Basic
Public Property InstrumentName( _
   Optional ByVal leg_ As Long = 0 _
) As String

Parameters

leg_
The leg to get data for

Return Type

Instrument full name represented as String

Example

See the usage of CQGFill properties in the OrderChanged event's example section.

See Also

CQGFill Interface | CQGFill Members


%%PageItemTitle%%

LegCount Property
CQGFill Interface : LegCount Property

Glossary Item Box

Description

Returns the actual number of legs for the current fill.

Property type

Read-only property

Syntax

Visual Basic
Public Property LegCount As Long

Return Type

Number of legs represented as Long

Remarks

This property gives the actual number of fill legs.

It was described in the remarks section of CQGFill that user can get common information by giving 0 as an argument to fill's properties. But that is not a separate leg and it is not included in the LegCount. So if this property returns 4, then user can get information on each leg by giving indexes from 1 to 4. At the same time he/she can get spread info by giving index = 0.

For orders on spread instruments, there will be more than one leg.

For outright orders, there will be only one leg.

Example

See the usage of CQGFill properties in the OrderChanged event's example section.

See Also

CQGFill Interface | CQGFill Members


%%PageItemTitle%%

Order Property
CQGFill Interface : Order Property

Glossary Item Box

Description

Returns the corresponding CQGOrder object.

Property type

Read-only property

Syntax

Visual Basic
Public Property Order As CQGOrder

Return Type

CQGOrder object to which this fill belongs

Remarks

This property will be convenient for those who are familiar with the VBA specific Parent option.

Example

See the usage of CQGFill properties in the OrderChanged event's example section.

See Also

CQGFill Interface | CQGFill Members


%%PageItemTitle%%

Price Property
leg_
The leg to get data for
CQGFill Interface : Price Property

Glossary Item Box

Description

Returns the fill price for the leg.

Property type

Read-only property

Syntax

Visual Basic
Public Property Price( _
   Optional ByVal leg_ As Long = 0 _
) As Double

Parameters

leg_
The leg to get data for

Return Type

Fill's leg price represented as Double

Remarks

This property is valid for legs and for the whole CQGFill as well.

Example

See the usage of Price property in the OrderChanged event's example section.

See Also

CQGFill Interface | CQGFill Members


%%PageItemTitle%%

Quantity Property
leg_
The leg to get data for
CQGFill Interface : Quantity Property

Glossary Item Box

Description

Returns the filled quantity of the leg.

Property type

Read-only property

Syntax

Visual Basic
Public Property Quantity( _
   Optional ByVal leg_ As Long = 0 _
) As Long

Parameters

leg_
The leg to get data for

Return Type

Quantity represented as Long.

The quantity will be signed if UseOrderSide setting of CQG API Configuration is set to False.

Remarks

This property is valid for legs and for the whole CQGFill as well.

Example

See the usage of CQGFill properties in the OrderChanged event's example section.

See Also

CQGFill Interface | CQGFill Members


%%PageItemTitle%%

QuantityFractional Property
leg_
CQGFill Interface : QuantityFractional Property

Glossary Item Box

Description

Gets a fill fractional quantity

Property type

Read-only property

Syntax

Visual Basic
Public Property QuantityFractional( _
   Optional ByVal leg_ As Long = 0 _
) As Decimal

Parameters

leg_

See Also

CQGFill Interface | CQGFill Members


%%PageItemTitle%%

RefFillId Property
CQGFill Interface : RefFillId Property

Glossary Item Box

Description

Returns the identifier of the referenced fill.

Property type

Read-only property

Syntax

Visual Basic
Public Property RefFillId As String

Return Type

The referenced fill identifier, represented as String

Remarks

If the current fill overrides some older fill for this order, this property points to the overridden one.

The same applies to the overridden fill: it will refer (through this property) to it's overriding fill. Both fills will be present in the collection. The currently real fill can be determined via Status property.

Example

See the usage of CQGFill properties in the OrderChanged event's example section.

See Also

CQGFill Interface | CQGFill Members


%%PageItemTitle%%

ServerTimestamp Property
CQGFill Interface : ServerTimestamp Property

Glossary Item Box

Description

Timestamp of the last change (server time, converted to the configured time zone).
Each fill change forces this property to change its value.

Property type

Read-only property

Syntax

Visual Basic
Public Property ServerTimestamp As Date

Return Type

Date variable containing the server timestamp

Remarks

The timestamp is converted to the timezone, previously configured by the user.

If no timezone configuration was made, the timestamp is converted to UTC.

Example

See the usage of CQGFill properties in the OrderChanged event's example section.

See Also

CQGFill Interface | CQGFill Members


%%PageItemTitle%%

Side Property
leg_
The leg to get data for
CQGFill Interface : Side Property

Glossary Item Box

Description

Returns the side of fill's leg.

Property type

Read-only property

Syntax

Visual Basic
Public Property Side( _
   Optional ByVal leg_ As Long = 0 _
) As eOrderSide

Parameters

leg_
The leg to get data for

Return Type

The side of the leg represented as eOrderSide..

The value will be osdUndefined if UseOrderSide setting of CQG API Configuration is set to False.

Remarks

This property is valid for legs and for the whole CQGFill as well.

Example

See the usage of CQGFill properties in the OrderChanged event's example section.

See Also

CQGFill Interface | CQGFill Members


%%PageItemTitle%%

StatementDate Property
leg_
The leg to get data for
CQGFill Interface : StatementDate Property

Glossary Item Box

Description

Gets statement date for the fill

Property type

Read-only property

Syntax

Visual Basic
Public Property StatementDate( _
   Optional ByVal leg_ As Long = 0 _
) As Date

Parameters

leg_
The leg to get data for

See Also

CQGFill Interface | CQGFill Members


%%PageItemTitle%%

Status Property
CQGFill Interface : Status Property

Glossary Item Box

Description

Returns the status of the fill.

Property type

Read-only property

Syntax

Visual Basic
Public Property Status As eFillStatus

Return Type

The status, represented as eFillStatus.

Example

See the usage of CQGFill properties in the OrderChanged event's example section.

See Also

CQGFill Interface | CQGFill Members


%%PageItemTitle%%

Timestamp Property
CQGFill Interface : Timestamp Property

Glossary Item Box

Description

Returns the last response reception timestamp.

When a property is updated, CQG API records the information reception time in the Timestamp property (using local time).

Each fill change forces this property to change its value.

Property type

Read-only property

Syntax

Visual Basic
Public Property Timestamp As Date

Return Type

Date variable containing the local timestamp

Remarks

The timestamp is converted to the timezone previously configured by the user.

If no timezone configuration was made, the timestamp is converted to UTC.

Example

See the usage of CQGFill properties in the OrderChanged event's example section.

See Also

CQGFill Interface | CQGFill Members


%%PageItemTitle%%

CQGGWConnectionRequest Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents parameters for gateway connection request

Object Model

CQGGWConnectionRequest Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGGWConnectionRequest Members


%%PageItemTitle%% $$Members$$

CQGGWConnectionRequest Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Host | Host
Public Property Login | Login (required)
Public Property OTPassword | One-time password
Public Property Password | Password (required)
Public Property PortNumber | Port number

See Also

CQGGWConnectionRequest Interface


%%PageItemTitle%%

Host Property
CQGGWConnectionRequest Interface : Host Property

Glossary Item Box

Description

Host

Property type

Read-write property

Syntax

Visual Basic
Public Property Host As String

See Also

CQGGWConnectionRequest Interface | CQGGWConnectionRequest Members


%%PageItemTitle%%

Login Property
CQGGWConnectionRequest Interface : Login Property

Glossary Item Box

Description

Login (required)

Property type

Read-write property

Syntax

Visual Basic
Public Property Login As String

See Also

CQGGWConnectionRequest Interface | CQGGWConnectionRequest Members


%%PageItemTitle%%

OTPassword Property
CQGGWConnectionRequest Interface : OTPassword Property

Glossary Item Box

Description

One-time password

Property type

Read-write property

Syntax

Visual Basic
Public Property OTPassword As String

See Also

CQGGWConnectionRequest Interface | CQGGWConnectionRequest Members


%%PageItemTitle%%

Password Property
CQGGWConnectionRequest Interface : Password Property

Glossary Item Box

Description

Password (required)

Property type

Read-write property

Syntax

Visual Basic
Public Property Password As String

See Also

CQGGWConnectionRequest Interface | CQGGWConnectionRequest Members


%%PageItemTitle%%

PortNumber Property
CQGGWConnectionRequest Interface : PortNumber Property

Glossary Item Box

Description

Port number

Property type

Read-write property

Syntax

Visual Basic
Public Property PortNumber As Long

See Also

CQGGWConnectionRequest Interface | CQGGWConnectionRequest Members


%%PageItemTitle%%

CQGGWTrade Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a class responsible for holding single trade's info

Object Model

CQGGWTrade InterfaceCQGFill Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGGWTrade Members


%%PageItemTitle%% $$Members$$

CQGGWTrade Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Aggressive | Returns aggressiveness of the trade
Public Property Currency | Returns currency of the trade
Public Property DisplayPrice | Returns display price of the trade
Public Property ExchangeTradeDate | Returns exchange trade date of the trade
Public Property ExtendedSide | Returns extended side of the trade
Public Property Fill | Returns the owner Fill
Public Property FillEffect | Returns a fill effect of the trade
Public Property Id | Returns the GW ID of the trade
Public Property InstrumentName | Returns name of instrument of the trade
Public Property Leg | Returns the leg number of trade
Public Property Price | Returns price of the trade
Public Property Quantity | Returns quantity of the trade
Public Property QuantityFractional | Returns fractional quantity of the trade
Public Property Side | Returns side of the trade
Public Property StatementDate | Returns statement date of the trade

See Also

CQGGWTrade Interface


%%PageItemTitle%%

Aggressive Property
CQGGWTrade Interface : Aggressive Property

Glossary Item Box

Description

Returns aggressiveness of the trade

Property type

Read-only property

Syntax

Visual Basic
Public Property Aggressive As Boolean

See Also

CQGGWTrade Interface | CQGGWTrade Members


%%PageItemTitle%%

Currency Property
CQGGWTrade Interface : Currency Property

Glossary Item Box

Description

Returns currency of the trade

Property type

Read-only property

Syntax

Visual Basic
Public Property Currency As String

See Also

CQGGWTrade Interface | CQGGWTrade Members


%%PageItemTitle%%

DisplayPrice Property
CQGGWTrade Interface : DisplayPrice Property

Glossary Item Box

Description

Returns display price of the trade

Property type

Read-only property

Syntax

Visual Basic
Public Property DisplayPrice As String

See Also

CQGGWTrade Interface | CQGGWTrade Members


%%PageItemTitle%%

ExchangeTradeDate Property
CQGGWTrade Interface : ExchangeTradeDate Property

Glossary Item Box

Description

Returns exchange trade date of the trade

Property type

Read-only property

Syntax

Visual Basic
Public Property ExchangeTradeDate As Date

See Also

CQGGWTrade Interface | CQGGWTrade Members


%%PageItemTitle%%

ExtendedSide Property
CQGGWTrade Interface : ExtendedSide Property

Glossary Item Box

Description

Returns extended side of the trade

Property type

Read-only property

Syntax

Visual Basic
Public Property ExtendedSide As EExtendedSide

See Also

CQGGWTrade Interface | CQGGWTrade Members


%%PageItemTitle%%

Fill Property
CQGGWTrade Interface : Fill Property

Glossary Item Box

Description

Returns the owner Fill

Property type

Read-only property

Syntax

Visual Basic
Public Property Fill As CQGFill

See Also

CQGGWTrade Interface | CQGGWTrade Members


%%PageItemTitle%%

FillEffect Property
CQGGWTrade Interface : FillEffect Property

Glossary Item Box

Description

Returns a fill effect of the trade

Property type

Read-only property

Syntax

Visual Basic
Public Property FillEffect As eFillEffect

See Also

CQGGWTrade Interface | CQGGWTrade Members


%%PageItemTitle%%

Id Property
CQGGWTrade Interface : Id Property

Glossary Item Box

Description

Returns the GW ID of the trade

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

CQGGWTrade Interface | CQGGWTrade Members


%%PageItemTitle%%

InstrumentName Property
CQGGWTrade Interface : InstrumentName Property

Glossary Item Box

Description

Returns name of instrument of the trade

Property type

Read-only property

Syntax

Visual Basic
Public Property InstrumentName As String

See Also

CQGGWTrade Interface | CQGGWTrade Members


%%PageItemTitle%%

Leg Property
CQGGWTrade Interface : Leg Property

Glossary Item Box

Description

Returns the leg number of trade

Property type

Read-only property

Syntax

Visual Basic
Public Property Leg As Long

See Also

CQGGWTrade Interface | CQGGWTrade Members


%%PageItemTitle%%

Price Property
CQGGWTrade Interface : Price Property

Glossary Item Box

Description

Returns price of the trade

Property type

Read-only property

Syntax

Visual Basic
Public Property Price As Double

See Also

CQGGWTrade Interface | CQGGWTrade Members


%%PageItemTitle%%

Quantity Property
CQGGWTrade Interface : Quantity Property

Glossary Item Box

Description

Returns quantity of the trade

Property type

Read-only property

Syntax

Visual Basic
Public Property Quantity As Long

See Also

CQGGWTrade Interface | CQGGWTrade Members


%%PageItemTitle%%

QuantityFractional Property
CQGGWTrade Interface : QuantityFractional Property

Glossary Item Box

Description

Returns fractional quantity of the trade

Property type

Read-only property

Syntax

Visual Basic
Public Property QuantityFractional As Decimal

See Also

CQGGWTrade Interface | CQGGWTrade Members


%%PageItemTitle%%

Side Property
CQGGWTrade Interface : Side Property

Glossary Item Box

Description

Returns side of the trade

Property type

Read-only property

Syntax

Visual Basic
Public Property Side As eOrderSide

See Also

CQGGWTrade Interface | CQGGWTrade Members


%%PageItemTitle%%

StatementDate Property
CQGGWTrade Interface : StatementDate Property

Glossary Item Box

Description

Returns statement date of the trade

Property type

Read-only property

Syntax

Visual Basic
Public Property StatementDate As Date

See Also

CQGGWTrade Interface | CQGGWTrade Members


%%PageItemTitle%%

CQGHistoricalSessionsRequest Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents parameters for historical sessions request.

Object Model

CQGHistoricalSessionsRequest Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGHistoricalSessionsRequest Members


%%PageItemTitle%% $$Members$$

CQGHistoricalSessionsRequest Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property RangeEnd | Sets/gets the range end, which will be used to formulate the historical sessions request.
Public Property RangeStart | Sets/gets the range start, which will be used to formulate the historical sessions request.
Public Property Symbol | Sets/gets the symbol, which will be used in historical sessions request (required).
Public Property Type | Sets/gets the historical sessions request type (required). Default value for this property is hsrtAll.

See Also

CQGHistoricalSessionsRequest Interface


%%PageItemTitle%%

RangeEnd Property
CQGHistoricalSessionsRequest Interface : RangeEnd Property

Glossary Item Box

Description

Sets/gets the range end, which will be used to formulate the historical sessions request.

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeEnd As Date

Return Type

Range end, represented as Date

Remarks

  • RangeStart/RangeEnd represent date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
  • If Type is hsrtTimeRange, both RangeStart and RangeEnd must be provided, RangeStart must be earlier or equal to RangeEnd.
  • If Type is hsrtSinceTime, RangeStart must be provided.
  • If Type is hsrtAll(default value), all available historical sessions are requested.

See Also

CQGHistoricalSessionsRequest Interface | CQGHistoricalSessionsRequest Members


%%PageItemTitle%%

RangeStart Property
CQGHistoricalSessionsRequest Interface : RangeStart Property

Glossary Item Box

Description

Sets/gets the range start, which will be used to formulate the historical sessions request.

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeStart As Date

Return Type

Range start, represented as Date

Remarks

  • RangeStart/RangeEnd represent date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
  • If Type is hsrtTimeRange, both RangeStart and RangeEnd must be provided, RangeStart must be earlier or equal to RangeEnd.
  • If Type is hsrtSinceTime, RangeStart must be provided.
  • If Type is hsrtAll(default value), all available historical sessions are requested.

See Also

CQGHistoricalSessionsRequest Interface | CQGHistoricalSessionsRequest Members


%%PageItemTitle%%

Symbol Property
CQGHistoricalSessionsRequest Interface : Symbol Property

Glossary Item Box

Description

Sets/gets the symbol, which will be used in historical sessions request (required).

Property type

Read-write property

Syntax

Visual Basic
Public Property Symbol As String

Return Type

Symbol used in the historical sessions request, represented as String

Remarks

Can't be empty string.

e.g. "EP

See Also

CQGHistoricalSessionsRequest Interface | CQGHistoricalSessionsRequest Members


%%PageItemTitle%%

Type Property
CQGHistoricalSessionsRequest Interface : Type Property

Glossary Item Box

Description

Sets/gets the historical sessions request type (required).

Default value for this property is hsrtAll.

Property type

Read-write property

Syntax

Visual Basic
Public Property Type As eHistoricalSessionsRequestType

Return Type

Historical sessions request type, represented as eHistoricalSessionsRequestType

Remarks

If type is hsrtTimeRange, the RangeStart and RangeEnd properties must be provided.

If type is hsrtSinceTime, the RangeStart property must be provided.

See Also

CQGHistoricalSessionsRequest Interface | CQGHistoricalSessionsRequest Members


%%PageItemTitle%%

CQGHoliday Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a single holiday of a session.

Object Model

CQGHoliday Interface

Remarks

For more information, see CQGCEL.HistoricalSessionsResolved's remark section.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGHoliday Members


%%PageItemTitle%% $$Members$$

CQGHoliday Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property HolidayDate | Returns the trading date, which happens to be a holiday.
Public Property IsDaily | Returns flag, which true value means that day is a holiday (for daily charts). It is possible for a day to be on holiday even if none of the sessions are on holiday.
Public Property SessionMask | Returns bit mask for days/sessions that had holiday.

See Also

CQGHoliday Interface


%%PageItemTitle%%

HolidayDate Property
CQGHoliday Interface : HolidayDate Property

Glossary Item Box

Description

Returns the trading date, which happens to be a holiday.

Property type

Read-only property

Syntax

Visual Basic
Public Property HolidayDate As Date

Return Type

Holiday day, represented as Date

Remarks

The holiday day specified through this property may still have tradable sessions. To find out which sessions were tradable, please check the SessionMask and IsDaily properties.

For more information, see CQGCEL.HistoricalSessionsResolved's remark section.

See Also

CQGHoliday Interface | CQGHoliday Members | CQGSessions Collection | CQGHoliday.IsDaily Property | CQGHoliday.SessionMask Property


%%PageItemTitle%%

IsDaily Property
CQGHoliday Interface : IsDaily Property

Glossary Item Box

Description

Returns flag, which true value means that day is a holiday (for daily charts).

It is possible for a day to be on holiday even if none of the sessions are on holiday.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsDaily As Boolean

Return Type

True, if the day is a holiday for daily charts

False, otherwise

Remarks

This flag indicates whether a particular day (the whole day) is marked as holiday or not. If True, that day will not be present on daily charts.

For example,

EP will have a bar for 04/02/2010 (one of the sessions was not on holiday), MWE will not have a bar for the same day as all its sessions were on holiday.

In some rare cases, this flag may be true though some of its sessions still be tradable. To find out which sessions were tradable, please check the SessionMask property.

For more information, see CQGCEL.HistoricalSessionsResolved's remark section.

See Also

CQGHoliday Interface | CQGHoliday Members | CQGSessions Collection | CQGHoliday.HolidayDate Property | CQGHoliday.SessionMask Property


%%PageItemTitle%%

SessionMask Property
CQGHoliday Interface : SessionMask Property

Glossary Item Box

Description

Returns bit mask for days/sessions that had holiday.

Property type

Read-only property

Syntax

Visual Basic
Public Property SessionMask As eSessionWeekDays

Return Type

Session bitmask, represented as eSessionWeekDays

Remarks

Example:

 | bitmask value
Dec | 127
Bin | 1111101

(Dec): 127

(Bin): 1111101

If the instrument has 2 sessions, we need to check for the last 2 binary digits of the bitmask to resolve whether those sessions were holidays or not.

  • 0 means that the session was not a holiday
  • 1 means that the session was a holiday

The session numbers should be resolved as following: 6543210
For our example 1111101, which has two sessions; we need to resolve the last digits 01, where:

  • 1 stands for session number 0 which is a holiday, and
  • 0 stands for session number 1 which is not a holiday.

For more information, see CQGCEL.HistoricalSessionsResolved's remark section.

See Also

CQGHoliday Interface | CQGHoliday Members | CQGSessions Collection | CQGHoliday.HolidayDate Property | CQGHoliday.IsDaily Property


%%PageItemTitle%%

CQGInstrument Interface
See Also Members Send Feedback

Glossary Item Box

Description

The CQGInstrument interface encapsulates all of the information on a trading instrument along with the corresponding functionality.

Object Model

CQGInstrument InterfaceCQGQuote InterfaceCQGQuote InterfaceCQGCEL InterfaceCQGDOMQuotes CollectionCQGQuote InterfaceCQGDOMQuotes CollectionCQGQuote InterfaceCQGInstrumentProperties CollectionCQGInstrumentProperty InterfaceCQGQuotes CollectionCQGQuote InterfaceCQGSessions CollectionCQGSession InterfaceCQGQuote InterfaceCQGInstrument Interface

Example

For the usage, see the example sections of the CQGCEL and InstrumentResolved Event.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGInstrument Members | CreateInstrumentRequest Method | SubscribeNewInstrument Method | InstrumentResolved Event | InstrumentChanged Event | InstrumentDOMChanged Event | CQGInstrumentSubscriptionRequest Interface


%%PageItemTitle%% $$Members$$

CQGInstrument Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method FromDisplayPrice | Converts the display price to the correct price.
Public Method GetNearestTradeablePrice | Rounds a price to a nearest correct tradable price (honoring tick sizes).
Public Method GetTickSizeFor | Gets the price dependent TickSize for specified price
Public Method GetTickValueFor | Gets the price dependent TickValue for specified price
Public Method ToDisplayPrice | Converts the correct price to the display price.

Public Properties

Public Property Ask | Returns the best ask.
Public Property BBAType | Indicates best bid/ask (BBA) type.
Public Property Bid | Returns the best bid.
Public Property CEL | Returns the corresponding CQGCEL object.
Public Property Commodity | Returns commodity abbreviation.
Public Property Country | Returns country abbreviation.
Public Property Currency | Returns instrument currency.
Public Property DataSubscriptionLevel | Indicates data subscription level.
Public Property Description | Returns contract description.
Public Property DetailedDOMLimit | Detailed DOM book limit
Public Property DetailedName | Instrument detailed name. For example, F.US.EP.M20, C.US.CLE.U21.100 (U21 is September 2021; 100 is a strike), C.US.CLE.M20.N100 (M20 is June 2020; N100 is a negative strike: -100).
Public Property DOMAsks | Returns asks of current DOM book.
Public Property DOMBids | Returns bids of the current DOM book.
Public Property DOMBookLimit | Sets/gets the current DOM book limit.
Public Property DOMStatus | Returns the instrument's DOM data is subscribed to or not.
Public Property DTE | Returns days to contract expiration.
Public Property ExchangeAbbreviation | Returns the exchange's abbreviation.
Public Property ExchangeID | Returns the exchange's identification number.
Public Property ExchangeState | The property indicates an exchange state.
Public Property ExpirationDate | Returns contract expiration date.
Public Property FullName | Returns full name of the contract.
Public Property IncludeDetailedDOM | Whether DOM data provided by instrument should include detailed DOM or not
Public Property InitialMargin | Returns initial margin for the contract.
Public Property InstrumentID | Returns instrument ID.
Public Property InstrumentType | Returns type of the contract.
Public Property IsDownTick | Indicates if the market goes down.
Public Property IsFastMarket | Indicates if the contract is traded with red light.
Public Property IsUpTick | Indicates if the market goes up.
Public Property MaintenanceMargin | Returns the maintenance margin for the contract.
Public Property MarketState | Returns market state.
Public Property Month | Returns the month number.
Public Property MonthChar | Returns contract month in symbolic notation.
Public Property NetChange | Returns the option's net change.
Public Property PreferredSessionsName | The preferred custom session name.
Public Property Properties | Returns the current properties of the instrument (both static and dynamic).
Public Property PropertyLevel | Returns the instrument's current dynamic properties subscription level.
Public Property QuoteLevel | Returns the instument's current quotes subscription level.
Public Property Quotes | Returns current quotes.
Public Property Reserved64 | Reserved method
Public Property Reserved65 | Reserved method
Public Property Reserved66 | Reserved method
Public Property Reserved67 | Reserved method
Public Property Scale | Returns the contract scale.
Public Property ServerTimestamp | Returns the server timestamp of the last change.
Public Property SessionMask | Returns bit mask of trading sessions.
Public Property SessionNumber | Returns the currently trading session number.
Public Property Sessions | Returns the current trading sessions collection.
Public Property Strike | Returns the strike price in display price format.
Public Property Tag | This property allows the user to keep his/her own information within the Instrument. Multiple data can be kept in the Tag property under different keys.
Public Property TickSize | Returns the tick size.
Public Property TickSizeFractionDenominator | Returns the denominator of the fractional tick size for synthetic spreads, if set in CQGIC.
Public Property TickSizeFractionNumerator | Returns the numerator of the fractional tick size for synthetic spreads, if set in CQGIC.
Public Property TickValue | Returns the tick value.
Public Property Timestamp | Returns the last response reception timestamp. When a property is updated, CQG API records the information reception time in the Timestamp property (using local time).
Public Property TodayCTotalVolume | Returns the total volume of the contract for today.
Public Property TodayCTotalVolumeFractional | Returns today contract total volume
Public Property Trade | Returns the last trade.
Public Property UnderlyingInstrument | Returns the underlying instrument of an option or Nothing if no underlying instrument is available.
Public Property UnderlyingInstrumentName | Returns the full name of the underlying instrument for options.
Public Property YCOI | Returns the open interest of the contract for yesterday.
Public Property Year | Returns the instrument year.
Public Property YearString | Returns instrument year as string.
Public Property YesterdayCTotalVolume | Returns the total volume of the contract for yesterday.
Public Property YesterdayCTotalVolumeFractional | Returns yesterday contract total volume

See Also

CQGInstrument Interface | CreateInstrumentRequest Method | SubscribeNewInstrument Method | InstrumentResolved Event | InstrumentChanged Event | InstrumentDOMChanged Event | CQGInstrumentSubscriptionRequest Interface


%%PageItemTitle%%

FromDisplayPrice Method
display_price
Display price represented as String
CQGInstrument Interface : FromDisplayPrice Method

Glossary Item Box

Description

Converts the display price to the correct price.

Syntax

Visual Basic
Public Function FromDisplayPrice( _
   ByVal display_price As String _
) As Double

Parameters

display_price
Display price represented as String

Return Type

The correct price represented as Double

Remarks

The conversion is performed based on each instrument's own price conversion rules.

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

GetNearestTradeablePrice Method
price_
The correct price represented as Double
CQGInstrument Interface : GetNearestTradeablePrice Method

Glossary Item Box

Description

Rounds a price to a nearest correct tradable price (honoring tick sizes).

Syntax

Visual Basic
Public Function GetNearestTradeablePrice( _
   ByVal price_ As Double _
) As Double

Parameters

price_
The correct price represented as Double

Return Type

The nearest tradable price represented as Double

Remarks

The rounding is performed based on each instrument's own price conversion rules.

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

GetTickSizeFor Method
Price
The price to get the tick size for
CQGInstrument Interface : GetTickSizeFor Method

Glossary Item Box

Description

Gets the price dependent TickSize for specified price

Syntax

Visual Basic
Public Function GetTickSizeFor( _
   ByVal Price As Double _
) As Double

Parameters

Price
The price to get the tick size for

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

GetTickValueFor Method
Price
The price to get the tick value for
CQGInstrument Interface : GetTickValueFor Method

Glossary Item Box

Description

Gets the price dependent TickValue for specified price

Syntax

Visual Basic
Public Function GetTickValueFor( _
   ByVal Price As Double _
) As Double

Parameters

Price
The price to get the tick value for

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

ToDisplayPrice Method
correct_price
Double value containing the correct price
CQGInstrument Interface : ToDisplayPrice Method

Glossary Item Box

Description

Converts the correct price to the display price.

Syntax

Visual Basic
Public Function ToDisplayPrice( _
   ByVal correct_price As Double _
) As String

Parameters

correct_price
Double value containing the correct price

Return Type

Display price represented as String

Remarks

The conversion is performed based on each instrument's own price conversion rules.

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

Ask Property
CQGInstrument Interface : Ask Property

Glossary Item Box

Description

Returns the best ask.

Property type

Read-only property

Syntax

Visual Basic
Public Property Ask As CQGQuote

Return Type

Best ask represented as CQGQuote

Remarks

Ask is a quote, so it is also the member of the quotes collection.

Example

To access the Instrument properties, see the example section of the InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members | eQuoteType Enumeration


%%PageItemTitle%%

BBAType Property
CQGInstrument Interface : BBAType Property

Glossary Item Box

Description

Indicates best bid/ask (BBA) type.

Property type

Read-write property

Syntax

Visual Basic
Public Property BBAType As eDOMandBBAType

Return Type

Current BBA type represented as a bitmask of eDOMandBBAType

Remarks

BBAType is a way to control the BBA types received by the user as quotes of current instrument. The user can choose to receive any combination of eDOMandBBAType.

If dbtImplied is included, qtImpliedAsk and qtImpliedBid quotes will be present in the instrument's quotes.

If dbtOutright is included, qtOutrightAsk and qtOutrightBid quotes will be present in the instrument's quotes.

If dbtCombined is included, qtAsk and qtBid quotes will be present in the instrument's quotes.

The default value of BBA type can be set from the configuration. By default it is dbtCombined.

See Also

CQGInstrument Interface | CQGInstrument Members | eQuoteType Enumeration | eDOMandBBAType Enumeration | CQGAPIConfig.DefaultInstrumentBBAType Property


%%PageItemTitle%%

Bid Property
CQGInstrument Interface : Bid Property

Glossary Item Box

Description

Returns the best bid.

Property type

Read-only property

Syntax

Visual Basic
Public Property Bid As CQGQuote

Return Type

The best bid represented as CQGQuote

Remarks

Bid is a quote, so it is also a member of the quotes collection.

Example

To access the Instrument properties see the example section of the InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members | eQuoteType Enumeration


%%PageItemTitle%%

CEL Property
CQGInstrument Interface : CEL Property

Glossary Item Box

Description

Returns the corresponding CQGCEL object.

Property type

Read-only property

Syntax

Visual Basic
Public Property CEL As CQGCEL

Return Type

CQGCEL object to which this Instrument belongs

Remarks

This property will be convenient for those who are used to use the VBA specific Parent option.

Example

To access the Instrument properties, see the example section of the InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members | CQGCEL Interface


%%PageItemTitle%%

Commodity Property
CQGInstrument Interface : Commodity Property

Glossary Item Box

Description

Returns commodity abbreviation.

Property type

Read-only property

Syntax

Visual Basic
Public Property Commodity As String

Return Type

The commodity symbol is represented as a String with a limited length of 16 characters.

Remarks

The commodity abbreviation as known in the trading systems is returned. It is a static property of an instrument.

Example

To access the Instrument properties, see the example section of the InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

Country Property
CQGInstrument Interface : Country Property

Glossary Item Box

Description

Returns country abbreviation.

Property type

Read-only property

Syntax

Visual Basic
Public Property Country As String

Return Type

Country abbreviation is represented as a String with a limited length of 3 characters.

Remarks

The country abbreviation as known in trading systems is returned. It is a static property of an instrument.

Example

To access the Instrument properties, see the example section of the InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

Currency Property
CQGInstrument Interface : Currency Property

Glossary Item Box

Description

Returns instrument currency.

Property type

Read-only property

Syntax

Visual Basic
Public Property Currency As String

Return Type

Currency is represented as a String with a limited length of 4 characters.

Remarks

The current instrument currency as set on the exchange is returned. It is a static property of an instrument.

Example

To access the Instrument properties see the example section of the InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

DataSubscriptionLevel Property
CQGInstrument Interface : DataSubscriptionLevel Property

Glossary Item Box

Description

Indicates data subscription level.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataSubscriptionLevel As eDataSubscriptionLevel

Return Type

Current subscription level represented as eDataSubscriptionLevel

Remarks

Data subscription level is a way to control the update events received by the user on current instrument. User can choose between not receiving any events, receiving data on trade changes and receiving trade, ask and bid changes.

When not receiving events option is chosen the actual instrument is not removed from the instruments collection of CQGCEL object and the user can change the update mode any time.

The default value of data subscription level can be set from configuration. By default it is dsQuotesAndBBA.

Example

See the usage of CQGInstrument properties in the InstrumentSubscribed event's example section.

See Also

CQGInstrument Interface | CQGInstrument Members | eDataSubscriptionLevel Enumeration


%%PageItemTitle%%

Description Property
CQGInstrument Interface : Description Property

Glossary Item Box

Description

Returns contract description.

Property type

Read-only property

Syntax

Visual Basic
Public Property Description As String

Return Type

Description is represented as a String with a limited length of 252 characters.

Remarks

Property represents the contract description as settled on the exchange. It is a static property of an instrument.

Example

For access to Instrument properties see example section of InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

DetailedDOMLimit Property
CQGInstrument Interface : DetailedDOMLimit Property

Glossary Item Box

Description

Detailed DOM book limit

Property type

Read-write property

Syntax

Visual Basic
Public Property DetailedDOMLimit As Long

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

DetailedName Property
CQGInstrument Interface : DetailedName Property

Glossary Item Box

Description

Instrument detailed name. For example, F.US.EP.M20, C.US.CLE.U21.100 (U21 is September 2021; 100 is a strike), C.US.CLE.M20.N100 (M20 is June 2020; N100 is a negative strike: -100).

Property type

Read-only property

Syntax

Visual Basic
Public Property DetailedName As String

Remarks

The detailed name is a prefferable way for passing it to CreateOrderByInstrumentName.

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

DOMAsks Property
CQGInstrument Interface : DOMAsks Property

Glossary Item Box

Description

Returns asks of current DOM book.

Property type

Read-only property

Syntax

Visual Basic
Public Property DOMAsks As CQGDOMQuotes

Return Type

Collection of DOM quotes

Remarks

This collection is empty until the instrument data subscription level is set to dsQuotesAndDOM

After that, on each DOM update, new DOM book asks will be stored here.

If later the subscription level is changed again, the collection's last content will be preserved - collection will not be reset.

Note: Not all of the instruments have DOM support. If such instrument's subscription level is set to dsQuotesAndDOM, its DOMAsks collection will remain empty.

Example

To work with DOM collections, see the example section of InstrumentDOMChanged Event.

To work with quotes, see the example section of the InstrumentChanged event.

See Also

CQGInstrument Interface | CQGInstrument Members | CQGQuote Interface | CQGCEL.InstrumentDOMChanged Event


%%PageItemTitle%%

DOMBids Property
CQGInstrument Interface : DOMBids Property

Glossary Item Box

Description

Returns bids of the current DOM book.

Property type

Read-only property

Syntax

Visual Basic
Public Property DOMBids As CQGDOMQuotes

Return Type

Collection of DOM quotes

Remarks

This collection is empty until instrument data subscription level is set to dsQuotesAndDOM.

After that, on each DOM update, new DOM book bids will be stored here.

If later the subscription level is changed again the collection's last content will be preserved - collection will not be reset.

Note: Not all the instruments have DOM support. If such instrument's subscription level is set to dsQuotesAndDOM, its DOMBids collection will remain empty.

Example

To work with DOM collections, see the example section of InstrumentDOMChanged Event.

To work with quotes, see the example section of the InstrumentChanged event.

See Also

CQGInstrument Interface | CQGInstrument Members | CQGQuote Interface | CQGCEL.InstrumentDOMChanged Event


%%PageItemTitle%%

DOMBookLimit Property
CQGInstrument Interface : DOMBookLimit Property

Glossary Item Box

Description

Sets/gets the current DOM book limit.

Property type

Read-write property

Syntax

Visual Basic
Public Property DOMBookLimit As Long

Return Type

DOM book limit, represented as Long

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

DOMStatus Property
CQGInstrument Interface : DOMStatus Property

Glossary Item Box

Description

Returns the instrument's DOM data is subscribed to or not.

Property type

Read-write property

Syntax

Visual Basic
Public Property DOMStatus As Boolean

Return Type

True if DOM data is subscribed to, False otherwise

Remarks

This subscription level should be used if CQGAPIConfig.NewInstrumentMode is set to True, otherwise DataSubscriptionLevel should be used.

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

DTE Property
CQGInstrument Interface : DTE Property

Glossary Item Box

Description

Returns days to contract expiration.

Property type

Read-only property

Syntax

Visual Basic
Public Property DTE As Long

Return Type

Number of days to instrument expiration represented as Long

Remarks

Number of days is settled in the contract on the exchange. It is a dynamic property of an instrument.

Example

For access to Instrument properties see example section of InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

ExchangeAbbreviation Property
CQGInstrument Interface : ExchangeAbbreviation Property

Glossary Item Box

Description

Returns the exchange's abbreviation.

Property type

Read-only property

Syntax

Visual Basic
Public Property ExchangeAbbreviation As String

Return Type

Exchange abbreviation, represented as String

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

ExchangeID Property
CQGInstrument Interface : ExchangeID Property

Glossary Item Box

Description

Returns the exchange's identification number.

Property type

Read-only property

Syntax

Visual Basic
Public Property ExchangeID As Long

Return Type

Exchange ID, represented as Long

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

ExchangeState Property
CQGInstrument Interface : ExchangeState Property

Glossary Item Box

Description

The property indicates an exchange state.

Property type

Read-only property

Syntax

Visual Basic
Public Property ExchangeState As EExchangeState

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

ExpirationDate Property
CQGInstrument Interface : ExpirationDate Property

Glossary Item Box

Description

Returns contract expiration date.

Property type

Read-only property

Syntax

Visual Basic
Public Property ExpirationDate As Date

Return Type

The expiration day represented as Date

Remarks

The day is a part of the contract settled on exchange. It is a static property of an instrument.

Example

For access to Instrument properties see example section of InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

FullName Property
CQGInstrument Interface : FullName Property

Glossary Item Box

Description

Returns full name of the contract.

Property type

Read-only property

Syntax

Visual Basic
Public Property FullName As String

Return Type

Full name is represented as a String with a limited length of 128 characters.

Remarks

Full name includes known abbreviations on contract type, commodity, month and year. It is a static property of an instrument.

Example

See the usage of FullName property in the OrderChanged event's example section.

See Also

CQGInstrument Interface | CQGInstrument Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

IncludeDetailedDOM Property
CQGInstrument Interface : IncludeDetailedDOM Property

Glossary Item Box

Description

Whether DOM data provided by instrument should include detailed DOM or not

Property type

Read-write property

Syntax

Visual Basic
Public Property IncludeDetailedDOM As Boolean

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

InitialMargin Property
CQGInstrument Interface : InitialMargin Property

Glossary Item Box

Description

Returns initial margin for the contract.

Property type

Read-only property

Syntax

Visual Basic
Public Property InitialMargin As Double

Return Type

Initial margin amount represented as Double

Remarks

Initial margin is specific to a contract and is set by FCM. It is a static property of an instrument.

Example

For access to Instrument properties see example section of InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

InstrumentID Property
CQGInstrument Interface : InstrumentID Property

Glossary Item Box

Description

Returns instrument ID.

Property type

Read-only property

Syntax

Visual Basic
Public Property InstrumentID As Long

Return Type

Instrument ID represented as Long

Remarks

It is a static property of an instrument.

Example

For access to Instrument properties see example section of InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

InstrumentType Property
CQGInstrument Interface : InstrumentType Property

Glossary Item Box

Description

Returns type of the contract.

Property type

Read-only property

Syntax

Visual Basic
Public Property InstrumentType As eInstrumentType

Return Type

The instrument type represented as eInstrumentType.

Remarks

It is a static property of an instrument.

Example

To access the Instrument properties see example section of the InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

IsDownTick Property
CQGInstrument Interface : IsDownTick Property

Glossary Item Box

Description

Indicates if the market goes down.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsDownTick As Boolean

Return Type

True if market goes down, False otherwise.

Remarks

This property represents the difference between the current and previous prices on the market. It is a dynamic property of an instrument.

Example

To access the Instrument properties, see the example section of the InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

IsFastMarket Property
CQGInstrument Interface : IsFastMarket Property

Glossary Item Box

Description

Indicates if the contract is traded with red light.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsFastMarket As Boolean

Return Type

True if the market is fast, False - otherwise

Remarks

This property represents the market intensity. It is a dynamic property of an instrument.

Example

To access the Instrument properties, see the example section of InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

IsUpTick Property
CQGInstrument Interface : IsUpTick Property

Glossary Item Box

Description

Indicates if the market goes up.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsUpTick As Boolean

Return Type

True if market goes up, False - otherwise

Remarks

This property represents the difference between current and previous market prices. It is a dynamic property of an instrument.

Example

To access the Instrument properties, see the example section of InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

MaintenanceMargin Property
CQGInstrument Interface : MaintenanceMargin Property

Glossary Item Box

Description

Returns the maintenance margin for the contract.

Property type

Read-only property

Syntax

Visual Basic
Public Property MaintenanceMargin As Double

Return Type

Maintenance margin amount represented as Double

Remarks

Maintenance margin is set by FCM and is based on the trader's current activities. It is a dynamic property of an instrument.

Example

To access the Instrument properties, see the example section of the InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

MarketState Property
CQGInstrument Interface : MarketState Property

Glossary Item Box

Description

Returns market state.

Property type

Read-only property

Syntax

Visual Basic
Public Property MarketState As String

Return Type

Market state represented as String.

Remarks

Market state is exchange specific. It is a dynamic property of an instrument.

Example

To access the Instrument properties, see the example section of the InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

Month Property
CQGInstrument Interface : Month Property

Glossary Item Box

Description

Returns the month number.

Property type

Read-only property

Syntax

Visual Basic
Public Property Month As Long

Return Type

Number of the contract month represented as Long

Remarks

The enumeration of months begins with 1, which corresponds to January. It is a static property of an instrument.

Example

To access the Instrument properties, see the example section of the InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

MonthChar Property
CQGInstrument Interface : MonthChar Property

Glossary Item Box

Description

Returns contract month in symbolic notation.

Property type

Read-only property

Syntax

Visual Basic
Public Property MonthChar As String

Return Type

String containing the month symbol

Remarks

The symbolic notation of contract month is set on the exchange and is a part of the contract's full name. It is a static property of an instrument.

Example

To access the Instrument properties, see the example section of the InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

NetChange Property
CQGInstrument Interface : NetChange Property

Glossary Item Box

Description

Returns the option's net change.

Property type

Read-only property

Syntax

Visual Basic
Public Property NetChange As Double

Return Type

Net change represented as Double

Remarks

An Options specific notion. The property will be 0 if the contract is not an Option. It is a dynamic property of an instrument.

Example

To access the Instrument properties, see the example section of the InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

PreferredSessionsName Property
CQGInstrument Interface : PreferredSessionsName Property

Glossary Item Box

Description

The preferred custom session name.

Property type

Read-only property

Syntax

Visual Basic
Public Property PreferredSessionsName As String

Return Type

Preferred custom session name, represented as String with a limited length of 64 characters.

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

Properties Property
CQGInstrument Interface : Properties Property

Glossary Item Box

Description

Returns the current properties of the instrument (both static and dynamic).

Property type

Read-only property

Syntax

Visual Basic
Public Property Properties As CQGInstrumentProperties

Return Type

Collection of instrument properties

Remarks

For the list of the instrument properties, see eInstrumentProperty Enumeration members.

Example

To work with properties see the example section of the InstrumentChanged event.

See Also

CQGInstrument Interface | CQGInstrument Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

PropertyLevel Property
CQGInstrument Interface : PropertyLevel Property

Glossary Item Box

Description

Returns the instrument's current dynamic properties subscription level.

Property type

Read-only property

Syntax

Visual Basic
Public Property PropertyLevel As ePropertySubscriptionLevel

Return Type

Instrument properties subscription level, represented as ePropertySubscriptionLevel

Remarks

This subscription level should be used if CQGAPIConfig.NewInstrumentMode is set to True, otherwise DataSubscriptionLevel should be used.

Note, the QuoteLevel can't be changed after CQGCEL::SubscribeNewInstrument call. To change it, user has to unsubscribe from the instrument data via CQGCEL::RemoveInstrument and create a new request to subscribe again with new QuoteLevel value.

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

QuoteLevel Property
CQGInstrument Interface : QuoteLevel Property

Glossary Item Box

Description

Returns the instument's current quotes subscription level.

Property type

Read-only property

Syntax

Visual Basic
Public Property QuoteLevel As eQuoteSubscriptionLevel

Return Type

Instrument quotes subscription level, represented as eQuoteSubscriptionLevel

Remarks

This subscription level should be used if CQGAPIConfig.NewInstrumentMode is set to True, otherwise DataSubscriptionLevel should be used.

Note, the QuoteLevel can't be changed after CQGCEL::SubscribeNewInstrument call. To change it, user has to unsubscribe from the instrument data via CQGCEL::RemoveInstrument and create a new request to subscribe again with new QuoteLevel value.

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

Quotes Property
CQGInstrument Interface : Quotes Property

Glossary Item Box

Description

Returns current quotes.

Property type

Read-only property

Syntax

Visual Basic
Public Property Quotes As CQGQuotes

Return Type

Collection of instrument quotes

Remarks

For the list of the instrument quotes, see the eQuoteType Enumeration.

Example

To work with the quotes, see the example section of the InstrumentChanged event.

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

Reserved64 Property
CQGInstrument Interface : Reserved64 Property

Glossary Item Box

Description

Reserved method

Property type

Read-write property

Syntax

Visual Basic
Public Property Reserved64 As Boolean

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

Reserved65 Property
CQGInstrument Interface : Reserved65 Property

Glossary Item Box

Description

Reserved method

Property type

Read-write property

Syntax

Visual Basic
Public Property Reserved65 As Boolean

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

Reserved66 Property
CQGInstrument Interface : Reserved66 Property

Glossary Item Box

Description

Reserved method

Property type

Read-only property

Syntax

Visual Basic
Public Property Reserved66 As Integer

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

Reserved67 Property
CQGInstrument Interface : Reserved67 Property

Glossary Item Box

Description

Reserved method

Property type

Read-only property

Syntax

Visual Basic
Public Property Reserved67 As Long

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

Scale Property
CQGInstrument Interface : Scale Property

Glossary Item Box

Description

Returns the contract scale.

Property type

Read-only property

Syntax

Visual Basic
Public Property Scale As Integer

Return Type

Contract scale, represented as Integer

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

ServerTimestamp Property
CQGInstrument Interface : ServerTimestamp Property

Glossary Item Box

Description

Returns the server timestamp of the last change.

Property type

Read-only property

Syntax

Visual Basic
Public Property ServerTimestamp As Date

Return Type

Date variable containing the server timestamp

Remarks

The timestamp is converted to the timezone, previously configured by the user. If no timezone configuration was made the timestamp is converted to UTC.

Example

To access the Instrument properties, see the example section of the InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members | CQGEnvironment.LineTime Property | CQGCELConfiguration UDT


%%PageItemTitle%%

SessionMask Property
CQGInstrument Interface : SessionMask Property

Glossary Item Box

Description

Returns bit mask of trading sessions.

Property type

Read-only property

Syntax

Visual Basic
Public Property SessionMask As Long

Return Type

The mask represented as Long

Remarks

It is a static property of an instrument.

Example

To access the Instrument properties see example section of the InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

SessionNumber Property
CQGInstrument Interface : SessionNumber Property

Glossary Item Box

Description

Returns the currently trading session number.

Property type

Read-only property

Syntax

Visual Basic
Public Property SessionNumber As Long

Return Type

Session number represented as Long

Remarks

This is a dynamic property of an instrument.

If there is no session today, then the value is "-1".

If the current moment is between sessions, then the value is "-2".

Example

To access the Instrument properties, see the example section of the InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

Sessions Property
CQGInstrument Interface : Sessions Property

Glossary Item Box

Description

Returns the current trading sessions collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Sessions As CQGSessions

Return Type

Collection of trading sessions of the instrument

Example

See the usage of CQGInstrument properties in the InstrumentSubscribed event's example section.
The example demonstrates the Sessions property usage of the CQGInstrument object.

VB
C#
Private Sub cel_InstrumentSubscribed(ByVal Symbl As String, ByVal Instrument As CQG.ICQGInstrument)
    ' You'll get here if instrument is subscribed
    Dim currentColumn As Integer
    ' Let's start from 2nd column
    currentColumn = 2
    Dim currentSession As CQGSession
    For Each currentSession In Instrument.Sessions
        Cells(2, currentColumn) = currentSession.Number
        Cells(3, currentColumn) = currentSession.Name
        Cells(4, currentColumn) = currentSession.PrimaryFlag
        Cells(5, currentColumn) = CStr(currentSession.StartTime)
        Cells(6, currentColumn) = CStr(currentSession.EndTime)
        If currentSession.Number = Instrument.SessionNumber Then
            ' Write above current sesion column that this is the active session
            Cells(1, currentColumn) = "Active"
        End If
        ' Move to the next column
        currentColumn = currentColumn + 1
    Next
End Sub
Private Sub cel_IncorrectSymbol(ByVal Symbl As String)
    ' Incorrect symbol (Symbl) is passed to NewInstrument function
End Sub
private void cel_InstrumentSubscribed(string Symbl, CQGInstrument Instrument)
{
    // You'll get here if instrument is subscribed
    // Let's start from 2nd column
    int currentColumn = 2 ;
    foreach( CQGSession currentSession in Instrument.Sessions )
    {
        // Start new session section and mark it as "Active" if currentSession is the active one
        Console.Write( "Start Session {0} {1}" , currentSession.Number ,
                 ( currentSession.Number == Instrument.SessionNumber ) ? "Active" : "" ) ;

        Console.WriteLine( "Name = {0}" , currentSession.Name ) ;
        Console.WriteLine( "Name = {0}" , currentSession.PrimaryFlag ) ;
        Console.WriteLine( "Name = {0}" , currentSession.StartTime.ToString() ) ;
        Console.WriteLine( "Name = {0}" , currentSession.EndTime.ToString() ) ;

        // Move to the next column
        ++ currentColumn ;
    }
}

private void cel_IncorrectSymbol(string Symbl)
{
     // Incorrect symbol (Symbl) is passed to NewInstrument function
}

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

Strike Property
CQGInstrument Interface : Strike Property

Glossary Item Box

Description

Returns the strike price in display price format.

Property type

Read-only property

Syntax

Visual Basic
Public Property Strike As Long

Return Type

Strike price represented as Long

Remarks

The price at which the futures contract underlying a call or put option can be purchased (if a call) or sold (if a put). It is a dynamic property of an instrument.

Example

To access the Instrument properties, see the example section of the InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

Tag Property
tagName

Key string set by the user. When setting, tagName should keep the key that will be associated with the current data.

When getting the information from the tag, one of the previously set keys should be passed as tagName in order to get the corresponding information.

CQGInstrument Interface : Tag Property

Glossary Item Box

Description

This property allows the user to keep his/her own information within the Instrument. Multiple data can be kept in the Tag property under different keys.

Property type

Read-write property

Syntax

Visual Basic
Public Property Tag( _
   ByVal tagName As String _
) As Variant

Parameters

tagName

Key string set by the user. When setting, tagName should keep the key that will be associated with the current data.

When getting the information from the tag, one of the previously set keys should be passed as tagName in order to get the corresponding information.

Return Type

Information represented as Variant

Remarks

Once set, the tag is kept inside the instrument until modification or deletion. The tag can be modified by any user. Always make sure that the previously set tag has a valid information stored (e.g. some functions in your program has not deleted it).

To delete a tag, the user needs to assign Empty to its value:

Instrument.Tag("tagname") = Empty

Example

See the usage of CQGInstrument properties in the InstrumentSubscribed event's example section.

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

TickSize Property
CQGInstrument Interface : TickSize Property

Glossary Item Box

Description

Returns the tick size.

Property type

Read-only property

Syntax

Visual Basic
Public Property TickSize As Double

Return Type

Tick size represented as Double

Remarks

It is a dynamic property of an instrument.

If instrument has variable TickSize, exception with error message will be thrown.

If instrument has variable TickSize, please use GetTickSizeFor instead.

To check whether instrument has variable TickSize or not, consider using value of ipIsVariableTickSize property.

Example

To access the Instrument properties, see the example section of the InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

TickSizeFractionDenominator Property
CQGInstrument Interface : TickSizeFractionDenominator Property

Glossary Item Box

Description

Returns the denominator of the fractional tick size for synthetic spreads, if set in CQGIC.

Property type

Read-only property

Syntax

Visual Basic
Public Property TickSizeFractionDenominator As Long

Return Type

Value of fractional tick size denominator, represented as Long

Remarks

New price = InitialPrice + (NumberOfTicksChanged*TickSizeFractionNumerator)/TickSizeFractionDenominator)

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

TickSizeFractionNumerator Property
CQGInstrument Interface : TickSizeFractionNumerator Property

Glossary Item Box

Description

Returns the numerator of the fractional tick size for synthetic spreads, if set in CQGIC.

Property type

Read-only property

Syntax

Visual Basic
Public Property TickSizeFractionNumerator As Long

Return Type

Value of fractional tick size numerator, represented as Long

Remarks

New price = InitialPrice + (NumberOfTicksChanged*TickSizeFractionNumerator)/TickSizeFractionDenominator)

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

TickValue Property
CQGInstrument Interface : TickValue Property

Glossary Item Box

Description

Returns the tick value.

Property type

Read-only property

Syntax

Visual Basic
Public Property TickValue As Double

Return Type

Tick value represented as Double

Remarks

It is a dynamic property of an instrument.

If instrument has variable TickValue, exception with error message will be thrown.

If instrument has variable TickValue, please use GetTickValueFor instead.

To check whether instrument has variable TickValue or not, consider using value of ipIsVariableTickSize property.

Example

To access the Instrument properties, see the example section of the InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

Timestamp Property
CQGInstrument Interface : Timestamp Property

Glossary Item Box

Description

Returns the last response reception timestamp.

When a property is updated, CQG API records the information reception time in the Timestamp property (using local time).

Property type

Read-only property

Syntax

Visual Basic
Public Property Timestamp As Date

Return Type

The local timestamp represented as Date

Remarks

The timestamp is converted to the timezone previously configured by the user.

If no timezone configuration was made, the timestamp is converted to UTC.

Example

To access the Instrument properties, see the example section of the InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members | CQGEnvironment.LocalTime Property | CQGCELConfiguration UDT


%%PageItemTitle%%

TodayCTotalVolume Property
CQGInstrument Interface : TodayCTotalVolume Property

Glossary Item Box

Description

Returns the total volume of the contract for today.

Property type

Read-only property

Syntax

Visual Basic
Public Property TodayCTotalVolume As Double

Return Type

Today's total volume of the contract, represented as Double

Example

To access the Instrument properties, see the example section of the CQGCEL.InstrumentSubscribed Event event.

See Also

CQGInstrument Interface | CQGInstrument Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

TodayCTotalVolumeFractional Property
CQGInstrument Interface : TodayCTotalVolumeFractional Property

Glossary Item Box

Description

Returns today contract total volume

Property type

Read-only property

Syntax

Visual Basic
Public Property TodayCTotalVolumeFractional As Decimal

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

Trade Property
CQGInstrument Interface : Trade Property

Glossary Item Box

Description

Returns the last trade.

Property type

Read-only property

Syntax

Visual Basic
Public Property Trade As CQGQuote

Return Type

Last trade represented as CQGQuote

Remarks

Trade is a quote, so it is also a member of the quotes collection.

Example

To access the Instrument properties, see the example section of the InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members | eQuoteType Enumeration


%%PageItemTitle%%

UnderlyingInstrument Property
CQGInstrument Interface : UnderlyingInstrument Property

Glossary Item Box

Description

Returns the underlying instrument of an option or Nothing if no underlying instrument is available.

Property type

Read-only property

Syntax

Visual Basic
Public Property UnderlyingInstrument As CQGInstrument

Return Type

Underlying instrument represented as CQGInstrument Object

Remarks

Mainly this refers to underlying instruments of options. Designed so the CQGInsturment object containing the underlying instrument will be returned only if it was previously and separately resolved. Otherwise, the property will return Nothing.

Nothing is also returned if the instrument is not an option.

Example

To access the Instrument properties see the example section of the InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

UnderlyingInstrumentName Property
CQGInstrument Interface : UnderlyingInstrumentName Property

Glossary Item Box

Description

Returns the full name of the underlying instrument for options.

Property type

Read-only property

Syntax

Visual Basic
Public Property UnderlyingInstrumentName As String

Return Type

Underlying instrument name String

Remarks

If the instrument is not an option, the return value is empty string.

Example

To access the Instrument properties, see the example section of the InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

YCOI Property
CQGInstrument Interface : YCOI Property

Glossary Item Box

Description

Returns the open interest of the contract for yesterday.

Property type

Read-only property

Syntax

Visual Basic
Public Property YCOI As Double

Return Type

Yesterday's open interest of the contract, represented as Double

Example

To access the Instrument properties, see the example section of the CQGCEL.InstrumentSubscribed Event event.

See Also

CQGInstrument Interface | CQGInstrument Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

Year Property
CQGInstrument Interface : Year Property

Glossary Item Box

Description

Returns the instrument year.

Property type

Read-only property

Syntax

Visual Basic
Public Property Year As Long

Return Type

Instrument year represented as Long

Example

To access the Instrument properties, see the example section of the InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

YearString Property
CQGInstrument Interface : YearString Property

Glossary Item Box

Description

Returns instrument year as string.

Property type

Read-only property

Syntax

Visual Basic
Public Property YearString As String

Return Type

Instrument year is represented as a String with a limited length of 5 characters.

Example

To access the Instrument properties, see the example section of the InstrumentSubscribed event.

See Also

CQGInstrument Interface | CQGInstrument Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

YesterdayCTotalVolume Property
CQGInstrument Interface : YesterdayCTotalVolume Property

Glossary Item Box

Description

Returns the total volume of the contract for yesterday.

Property type

Read-only property

Syntax

Visual Basic
Public Property YesterdayCTotalVolume As Double

Return Type

Yesterday's total volume of the contract, represented as Double

Example

To access the Instrument properties, see the example section of the CQGCEL.InstrumentSubscribed Event event.

See Also

CQGInstrument Interface | CQGInstrument Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

YesterdayCTotalVolumeFractional Property
CQGInstrument Interface : YesterdayCTotalVolumeFractional Property

Glossary Item Box

Description

Returns yesterday contract total volume

Property type

Read-only property

Syntax

Visual Basic
Public Property YesterdayCTotalVolumeFractional As Decimal

See Also

CQGInstrument Interface | CQGInstrument Members


%%PageItemTitle%%

CQGInstrumentProperty Interface
See Also Members Send Feedback

Glossary Item Box

Description

Implements an interface to manage the instrument's dynamic and static properties.

Object Model

CQGInstrumentProperty InterfaceCQGInstrument Interface

Example

See the example of InstrumentChanged Event.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGInstrumentProperty Members


%%PageItemTitle%% $$Members$$

CQGInstrumentProperty Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Instrument | Returns the corresponding instrument.
Public Property Name | Returns the name of the instrument property object.
Public Property ServerTimestamp | Returns the server timestamp of the last change.
Public Property Timestamp | Returns the last response reception timestamp. When a property is updated, CQG API records the information reception time in the Timestamp property (using local time).
Public Property Type | Returns the type of the instrument property (dynamic or static).
Public Property Value | Returns the value of instrument property.

See Also

CQGInstrumentProperty Interface


%%PageItemTitle%%

Instrument Property
CQGInstrumentProperty Interface : Instrument Property

Glossary Item Box

Description

Returns the corresponding instrument.

Property type

Read-only property

Syntax

Visual Basic
Public Property Instrument As CQGInstrument

Return Type

CQGInstrument object to which this InstrumentProperty object belongs

Remarks

This property will be convenient for those who are familiar with the VBA specific Parent option.

Example

To access the CQGInstrumentProperty object properties, see the example section of the InstrumentChanged Event.

See Also

CQGInstrumentProperty Interface | CQGInstrumentProperty Members | CQGInstrument Interface


%%PageItemTitle%%

Name Property
CQGInstrumentProperty Interface : Name Property

Glossary Item Box

Description

Returns the name of the instrument property object.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

Return Type

Property name String

Remarks

The Instrument Property name is the display version of eInstrumentProperty Enumeration members, i.e. each name corresponds to one of the enumeration members.

Example

To access the CQGInstrumentProperty object properties, see the example section of the InstrumentChanged Event.

See Also

CQGInstrumentProperty Interface | CQGInstrumentProperty Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

ServerTimestamp Property
CQGInstrumentProperty Interface : ServerTimestamp Property

Glossary Item Box

Description

Returns the server timestamp of the last change.

Property type

Read-only property

Syntax

Visual Basic
Public Property ServerTimestamp As Date

Return Type

The server timestamp of the last property change represented as Date

Remarks

Server timestamp is converted to the timezone previously configured by the user. If the user did not configure the timezone the timestamp is converted to UTC.

Example

To access the CQGInstrumentProperty object properties, see the example section of the InstrumentChanged Event.

See Also

CQGInstrumentProperty Interface | CQGInstrumentProperty Members


%%PageItemTitle%%

Timestamp Property
CQGInstrumentProperty Interface : Timestamp Property

Glossary Item Box

Description

Returns the last response reception timestamp.

When a property is updated, CQG API records the information reception time in the Timestamp property (using local time).

Property type

Read-only property

Syntax

Visual Basic
Public Property Timestamp As Date

Return Type

The local PC timestamp of the last property change represented as Date

Remarks

Local timestamp is converted to the timezone previously configured by the user. If the user did not configure the timezone the timestamp is converted to UTC.

Example

TO access the CQGInstrumentProperty object properties, see the example section of the InstrumentChanged Event.

See Also

CQGInstrumentProperty Interface | CQGInstrumentProperty Members | CQGInstrument.Timestamp Property | CQGCELConfiguration UDT


%%PageItemTitle%%

Type Property
CQGInstrumentProperty Interface : Type Property

Glossary Item Box

Description

Returns the type of the instrument property (dynamic or static).

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As eInstrumentProperty

Return Type

Type of the property represented as the eInstrumentProperty enumeration

Example

To access the CQGInstrumentProperty object properties, see the example section of the InstrumentChanged Event.

See Also

CQGInstrumentProperty Interface | CQGInstrumentProperty Members | eInstrumentProperty Enumeration


%%PageItemTitle%%

Value Property
CQGInstrumentProperty Interface : Value Property

Glossary Item Box

Description

Returns the value of instrument property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Value As Variant

Return Type

The value of the current property. The Variant variable is used because the type of the value depends on the type of the property.

Remarks

If the value changes for the instrument, then the Instrument Property is dynamic (Strike, DTE). If the value doesn't change across Instrument lifetime the Instrument Property is static (Full Name, Instrument Type).

Example

To access the CQGInstrumentProperty object properties, see the example section of the InstrumentChanged Event.

See Also

CQGInstrumentProperty Interface | CQGInstrumentProperty Members


%%PageItemTitle%%

CQGInstrumentsGroup Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a group of instruments resolved using CQGInstrumentsGroupRequest.

Object Model

CQGInstrumentsGroup InterfaceCQGInstruments CollectionCQGInstrument InterfaceCQGInstrumentsGroupRequest Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGInstrumentsGroup Members | CQGInstrumentsGroupRequest Interface | RequestInstrumentsGroup Method | RemoveInstrumentsGroup Method | AllInstrumentsGroups Property


%%PageItemTitle%% $$Members$$

CQGInstrumentsGroup Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Id | Returns the unique identifier of the group.
Public Property Instruments | Returns the collection of instruments in the group.
Public Property Request | Returns the request object of this group.

See Also

CQGInstrumentsGroup Interface | CQGInstrumentsGroupRequest Interface | RequestInstrumentsGroup Method | RemoveInstrumentsGroup Method | AllInstrumentsGroups Property


%%PageItemTitle%%

Id Property
CQGInstrumentsGroup Interface : Id Property

Glossary Item Box

Description

Returns the unique identifier of the group.

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

Return Type

Unique identifier, represented as String

See Also

CQGInstrumentsGroup Interface | CQGInstrumentsGroup Members


%%PageItemTitle%%

Instruments Property
CQGInstrumentsGroup Interface : Instruments Property

Glossary Item Box

Description

Returns the collection of instruments in the group.

Property type

Read-only property

Syntax

Visual Basic
Public Property Instruments As CQGInstruments

Return Type

The corresponding collection, represented as CQGInstruments collection

See Also

CQGInstrumentsGroup Interface | CQGInstrumentsGroup Members | CQGInstrument Interface


%%PageItemTitle%%

Request Property
CQGInstrumentsGroup Interface : Request Property

Glossary Item Box

Description

Returns the request object of this group.

Property type

Read-only property

Syntax

Visual Basic
Public Property Request As CQGInstrumentsGroupRequest

Return Type

The corresponding request object, represented as CQGInstrumentsGroupRequest method

See Also

CQGInstrumentsGroup Interface | CQGInstrumentsGroup Members | CQGInstrumentsGroupRequest Interface


%%PageItemTitle%%

CQGInstrumentsGroupRequest Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents parameters used to formulate a request for a group of instruments.

Object Model

CQGInstrumentsGroupRequest Interface

Remarks

This request can be used to resolve the Options Chain.

Use CQGCEL.CreateInstrumentsGroupRequest Method to create an object of this type.

Use CQGCEL.RequestInstrumentsGroup Method to perform this request.

This request is asynchronous. The execution result is reported via CQGCEL.InstrumentsGroupResolved event.

The request result is represented by the CQGInstrumentsGroup object. It is possible to access all resolved instrument groups via CQGCEL.AllInstrumentsGroups Property.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGInstrumentsGroupRequest Members | CreateInstrumentsGroupRequest Method | RequestInstrumentsGroup Method | InstrumentsGroupResolved Event | CQGInstrumentsGroup Interface | AllInstrumentsGroups Property


%%PageItemTitle%% $$Members$$

CQGInstrumentsGroupRequest Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Commodity | Sets/gets the commodity name to request.
Public Property InstrumentTypes | Sets/gets the types of the instruments to request.
Public Property PropertyLevel | Sets the dynamic property subscription level. Defaults to gpsDefault. Applies both standalone EGroupPropertySubscriptionLevel values and bit-mask combinations of these values.
Public Property RangeEnd | Gets/sets the range end, which will be used to formulate the request for a group of instruments.
Public Property RangeStart | Gets/sets the range start, which will be used to formulate the request for a group of instruments.
Public Property SubscriptionLevel | Sets/gets the subscription level of the request. The default value is gslRealtimeSnapshot.

See Also

CQGInstrumentsGroupRequest Interface | CreateInstrumentsGroupRequest Method | RequestInstrumentsGroup Method | InstrumentsGroupResolved Event | CQGInstrumentsGroup Interface | AllInstrumentsGroups Property


%%PageItemTitle%%

Commodity Property
CQGInstrumentsGroupRequest Interface : Commodity Property

Glossary Item Box

Description

Sets/gets the commodity name to request.

Property type

Read-write property

Syntax

Visual Basic
Public Property Commodity As String

Return Type

Commodity name, represented as String

See Also

CQGInstrumentsGroupRequest Interface | CQGInstrumentsGroupRequest Members


%%PageItemTitle%%

InstrumentTypes Property
CQGInstrumentsGroupRequest Interface : InstrumentTypes Property

Glossary Item Box

Description

Sets/gets the types of the instruments to request.

Property type

Read-write property

Syntax

Visual Basic
Public Property InstrumentTypes As eInstrumentType

Return Type

Instrument types, represented as eInstrumentType enumeration

Remarks

Currently, only option types are supported (i.e., itOptionPut, itOptionCall, and itAllOptions).

If no instrument type is specified, all corresponding options will be returned.

See Also

CQGInstrumentsGroupRequest Interface | CQGInstrumentsGroupRequest Members | eInstrumentType Enumeration


%%PageItemTitle%%

PropertyLevel Property
CQGInstrumentsGroupRequest Interface : PropertyLevel Property

Glossary Item Box

Description

Sets the dynamic property subscription level. Defaults to gpsDefault. Applies both standalone EGroupPropertySubscriptionLevel values and bit-mask combinations of these values.

Property type

Read-write property

Syntax

Visual Basic
Public Property PropertyLevel As EGroupPropertySubscriptionLevel

See Also

CQGInstrumentsGroupRequest Interface | CQGInstrumentsGroupRequest Members | EGroupPropertySubscriptionLevel Enumeration


%%PageItemTitle%%

RangeEnd Property
CQGInstrumentsGroupRequest Interface : RangeEnd Property

Glossary Item Box

Description

Gets/sets the range end, which will be used to formulate the request for a group of instruments.

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeEnd As Variant

Return Type

Range end, represented as Variant

Remarks

RangeStart and RangeEnd specify the underlying instruments month range, for which data is requested.

Only Date and integer are allowed for types of RangeStart/RangeEnd properties:

  • Date values specify the range of contract months starting from the current active instrument month. Values represent date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
    RangeStart must be greater than 0 and RangeEnd must indicate a later date.
  • Integer values specify the range of contract numbers starting from the current active instrument.
    RangeStart must be greater than 0 and RangeEnd must be greater or equal to RangeStart.
  • RangeStart and RangeEnd must be of the same type.
  • If no range is specified, all corresponding instruments will be returned.

See Also

CQGInstrumentsGroupRequest Interface | CQGInstrumentsGroupRequest Members


%%PageItemTitle%%

RangeStart Property
CQGInstrumentsGroupRequest Interface : RangeStart Property

Glossary Item Box

Description

Gets/sets the range start, which will be used to formulate the request for a group of instruments.

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeStart As Variant

Return Type

Range start, represented as Variant

Remarks

RangeStart and RangeEnd specify the underlying instruments month range, for which data is requested.

Only Date and integer are allowed for types of RangeStart/RangeEnd properties:

  • Date values specify the range of contract months starting from the current active instrument month. Values represent date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
    RangeStart must be greater than 0 and RangeEnd must indicate a later date.
  • Integer values specify the range of contract numbers starting from the current active instrument.
    RangeStart must be greater than 0 and RangeEnd must be greater or equal to RangeStart.
  • RangeStart and RangeEnd must be of the same type.
  • If no range (i.e., RangeStart and RangeEnd) is specified, all corresponding instruments will be returned.

See Also

CQGInstrumentsGroupRequest Interface | CQGInstrumentsGroupRequest Members


%%PageItemTitle%%

SubscriptionLevel Property
CQGInstrumentsGroupRequest Interface : SubscriptionLevel Property

Glossary Item Box

Description

Sets/gets the subscription level of the request.

The default value is gslRealtimeSnapshot.

Property type

Read-write property

Syntax

Visual Basic
Public Property SubscriptionLevel As eGroupSubscriptionLevel

Return Type

The request's subscription level, represented as eGroupSubscriptionLevel enumeration

See Also

CQGInstrumentsGroupRequest Interface | CQGInstrumentsGroupRequest Members | eGroupSubscriptionLevel Enumeration


%%PageItemTitle%%

CQGInstrumentSubscriptionRequest Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents parameters used to formulate an instrument subscription request.

Object Model

CQGInstrumentSubscriptionRequest Interface

Remarks

This request should be used if CQGAPIConfig.NewInstrumentMode is set to True, otherwise use the NewInstrument method.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGInstrumentSubscriptionRequest Members


%%PageItemTitle%% $$Members$$

CQGInstrumentSubscriptionRequest Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property DetailedDOMLimit | Detailed DOM book limit
Public Property DOMBBAType | Sets and gets current BBA type.
Public Property DOMBookLimit | DOM book limit
Public Property DOMStatus | Sets and gets the DOM status, which will be used for the subscribed instrument.
Public Property IncludeDetailedDOM | Whether DOM data provided by instrument should include detailed DOM or not
Public Property PropertyLevel | Sets and gets the property subscription level, which should be used for the subscribed instrument.
Public Property QuoteLevel | Sets and gets the quote subscription level, which should be used for the subscribed instrument.
Public Property Symbol | Commodity symbol to resolve.

See Also

CQGInstrumentSubscriptionRequest Interface


%%PageItemTitle%%

DetailedDOMLimit Property
CQGInstrumentSubscriptionRequest Interface : DetailedDOMLimit Property

Glossary Item Box

Description

Detailed DOM book limit

Property type

Read-write property

Syntax

Visual Basic
Public Property DetailedDOMLimit As Long

See Also

CQGInstrumentSubscriptionRequest Interface | CQGInstrumentSubscriptionRequest Members


%%PageItemTitle%%

DOMBBAType Property
CQGInstrumentSubscriptionRequest Interface : DOMBBAType Property

Glossary Item Box

Description

Sets and gets current BBA type.

Property type

Read-write property

Syntax

Visual Basic
Public Property DOMBBAType As eDOMandBBAType

Return Type

BBA type, represented as eDOMandBBAType

See Also

CQGInstrumentSubscriptionRequest Interface | CQGInstrumentSubscriptionRequest Members


%%PageItemTitle%%

DOMBookLimit Property
CQGInstrumentSubscriptionRequest Interface : DOMBookLimit Property

Glossary Item Box

Description

DOM book limit

Property type

Read-write property

Syntax

Visual Basic
Public Property DOMBookLimit As Long

See Also

CQGInstrumentSubscriptionRequest Interface | CQGInstrumentSubscriptionRequest Members


%%PageItemTitle%%

DOMStatus Property
CQGInstrumentSubscriptionRequest Interface : DOMStatus Property

Glossary Item Box

Description

Sets and gets the DOM status, which will be used for the subscribed instrument.

Property type

Read-write property

Syntax

Visual Basic
Public Property DOMStatus As Boolean

Return Type

DOM status, represented as Boolean

Remarks

Set this property value to True if DOM data is needed.

See Also

CQGInstrumentSubscriptionRequest Interface | CQGInstrumentSubscriptionRequest Members


%%PageItemTitle%%

IncludeDetailedDOM Property
CQGInstrumentSubscriptionRequest Interface : IncludeDetailedDOM Property

Glossary Item Box

Description

Whether DOM data provided by instrument should include detailed DOM or not

Property type

Read-write property

Syntax

Visual Basic
Public Property IncludeDetailedDOM As Boolean

See Also

CQGInstrumentSubscriptionRequest Interface | CQGInstrumentSubscriptionRequest Members


%%PageItemTitle%%

PropertyLevel Property
CQGInstrumentSubscriptionRequest Interface : PropertyLevel Property

Glossary Item Box

Description

Sets and gets the property subscription level, which should be used for the subscribed instrument.

Property type

Read-write property

Syntax

Visual Basic
Public Property PropertyLevel As ePropertySubscriptionLevel

Return Type

Property subscription level, represented as ePropertySubscriptionLevel

Remarks

Use this property to specify which instrument dynamic properties are needed.

Note, the QuoteLevel can't be changed after CQGCEL::SubscribeNewInstrument call. To change it, user has to unsubscribe from the instrument data via CQGCEL::RemoveInstrument and create a new request to subscribe again with new QuoteLevel value.

See Also

CQGInstrumentSubscriptionRequest Interface | CQGInstrumentSubscriptionRequest Members


%%PageItemTitle%%

QuoteLevel Property
CQGInstrumentSubscriptionRequest Interface : QuoteLevel Property

Glossary Item Box

Description

Sets and gets the quote subscription level, which should be used for the subscribed instrument.

Property type

Read-write property

Syntax

Visual Basic
Public Property QuoteLevel As eQuoteSubscriptionLevel

Return Type

Quote subscription level, represented as eQuoteSubscriptionLevel

Remarks

Use this property to specify which instrument qutoes are needed.

Note, the QuoteLevel can't be changed after CQGCEL::SubscribeNewInstrument call. To change it, user has to unsubscribe from the instrument data via CQGCEL::RemoveInstrument and create a new request to subscribe again with new QuoteLevel value.

See Also

CQGInstrumentSubscriptionRequest Interface | CQGInstrumentSubscriptionRequest Members


%%PageItemTitle%%

Symbol Property
CQGInstrumentSubscriptionRequest Interface : Symbol Property

Glossary Item Box

Description

Commodity symbol to resolve.

Property type

Read-write property

Syntax

Visual Basic
Public Property Symbol As String

Return Type

Commodity symbol, represented as String

See Also

CQGInstrumentSubscriptionRequest Interface | CQGInstrumentSubscriptionRequest Members


%%PageItemTitle%%

CQGLogger Interface
See Also Members Send Feedback

Glossary Item Box

Description

This class provides logging functionality in CQG API.

Object Model

CQGLogger InterfaceCQGCEL Interface

Example

See an example of CQGLogger usage in CQGCEL example.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGLogger Members


%%PageItemTitle%% $$Members$$

CQGLogger Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method Log

Logs a message if the corresponding log severity is enabled.

Public Properties

Public Property CEL

Returns the corresponding CQGCEL object.

See Also

CQGLogger Interface


%%PageItemTitle%%

Log Method
content_
Specifies the string to be logged the string to be logged.
severity_
The severity of the information to be logged. The parameter is optional. If no parameter is specified lsInfo is used by default.
CQGLogger Interface : Log Method

Glossary Item Box

Description

Logs a message if the corresponding log severity is enabled.

Syntax

Visual Basic
Public Sub Log( _
   ByVal content_ As String, _
   Optional ByVal severity_ As eLogSeverity = lsInfo _
)

Parameters

content_
Specifies the string to be logged the string to be logged.
severity_
Value Description
lsDebug

Debug log message.

lsError

Error log message.

lsFatal

Fatal log message.

(This is the default).

lsInfo

Info log message.

lsWarn

Warning log message.

The severity of the information to be logged. The parameter is optional. If no parameter is specified lsInfo is used by default.

Remarks

Log will be collected if and only if the logger's internal severity enables logs with the given severity.

Example

See an example of CQGLogger usage in CQGCEL example.

See Also

CQGLogger Interface | CQGLogger Members


%%PageItemTitle%%

CEL Property
CQGLogger Interface : CEL Property

Glossary Item Box

Description

Returns the corresponding CQGCEL object.

Property type

Read-only property

Syntax

Visual Basic
Public Property CEL As CQGCEL

Return Type

CQGCEL object to which this Logger belongs

Remarks

This property will be convenient for those who are used to use the VBA specific Parent option.

Example

See an example of CQGLogger properties usage in CQGCEL example.

See Also

CQGLogger Interface | CQGLogger Members


%%PageItemTitle%%

CQGManualFill Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a manual fill.

Object Model

CQGManualFill Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGManualFill Members


%%PageItemTitle%% $$Members$$

CQGManualFill Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Commission | Gets commission charged for a fill
Public Property CommissionCurrency | Gets fill commission currency (ISO code of currency used to express commission)
Public Property DisplayPrice | Gets the display price.
Public Property FillEffect | Gets fill effect
Public Property GWAccountID | Gets the Account Id of the manual fill.
Public Property InstrumentName | The full name of the manual fill's instrument.
Public Property Note | Gets the trade note (for local trades).
Public Property Price | Gets the manual fill price.
Public Property Quantity | Gets the manual fill quantity.
Public Property QuantityFractional | Gets manual fill fractional quantity
Public Property Side | Gets the manual fill side.
Public Property SpeculationType | Gets the speculation type of the manual fill.
Public Property StatementDate | Gets the statement date of the manual fill.
Public Property TradeId | Gets the local trade ID.
Public Property TradeTimestamp | Gets trade's date.

See Also

CQGManualFill Interface


%%PageItemTitle%%

Commission Property
CQGManualFill Interface : Commission Property

Glossary Item Box

Description

Gets commission charged for a fill

Property type

Read-only property

Syntax

Visual Basic
Public Property Commission As Double

See Also

CQGManualFill Interface | CQGManualFill Members


%%PageItemTitle%%

CommissionCurrency Property
CQGManualFill Interface : CommissionCurrency Property

Glossary Item Box

Description

Gets fill commission currency (ISO code of currency used to express commission)

Property type

Read-only property

Syntax

Visual Basic
Public Property CommissionCurrency As String

See Also

CQGManualFill Interface | CQGManualFill Members


%%PageItemTitle%%

DisplayPrice Property
CQGManualFill Interface : DisplayPrice Property

Glossary Item Box

Description

Gets the display price.

Property type

Read-only property

Syntax

Visual Basic
Public Property DisplayPrice As String

Return Type

Display price, represented as String

Remarks

This object can be empty.

See Also

CQGManualFill Interface | CQGManualFill Members


%%PageItemTitle%%

FillEffect Property
CQGManualFill Interface : FillEffect Property

Glossary Item Box

Description

Gets fill effect

Property type

Read-only property

Syntax

Visual Basic
Public Property FillEffect As eFillEffect

See Also

CQGManualFill Interface | CQGManualFill Members


%%PageItemTitle%%

GWAccountID Property
CQGManualFill Interface : GWAccountID Property

Glossary Item Box

Description

Gets the Account Id of the manual fill.

Property type

Read-only property

Syntax

Visual Basic
Public Property GWAccountID As Long

Return Type

Account ID, represented as Long

See Also

CQGManualFill Interface | CQGManualFill Members


%%PageItemTitle%%

InstrumentName Property
CQGManualFill Interface : InstrumentName Property

Glossary Item Box

Description

The full name of the manual fill's instrument.

Property type

Read-only property

Syntax

Visual Basic
Public Property InstrumentName As String

Return Type

Instrument name, represented as String

See Also

CQGManualFill Interface | CQGManualFill Members


%%PageItemTitle%%

Note Property
CQGManualFill Interface : Note Property

Glossary Item Box

Description

Gets the trade note (for local trades).

Property type

Read-only property

Syntax

Visual Basic
Public Property Note As String

Return Type

Trade note, represented as String

See Also

CQGManualFill Interface | CQGManualFill Members


%%PageItemTitle%%

Price Property
CQGManualFill Interface : Price Property

Glossary Item Box

Description

Gets the manual fill price.

Property type

Read-only property

Syntax

Visual Basic
Public Property Price As Double

Return Type

Price, represented as Double

See Also

CQGManualFill Interface | CQGManualFill Members


%%PageItemTitle%%

Quantity Property
CQGManualFill Interface : Quantity Property

Glossary Item Box

Description

Gets the manual fill quantity.

Property type

Read-only property

Syntax

Visual Basic
Public Property Quantity As Long

Return Type

Quantity, represented as Long

See Also

CQGManualFill Interface | CQGManualFill Members


%%PageItemTitle%%

QuantityFractional Property
CQGManualFill Interface : QuantityFractional Property

Glossary Item Box

Description

Gets manual fill fractional quantity

Property type

Read-only property

Syntax

Visual Basic
Public Property QuantityFractional As Decimal

See Also

CQGManualFill Interface | CQGManualFill Members


%%PageItemTitle%%

Side Property
CQGManualFill Interface : Side Property

Glossary Item Box

Description

Gets the manual fill side.

Property type

Read-only property

Syntax

Visual Basic
Public Property Side As eOrderSide

Return Type

Side, represented as eOrderSide

See Also

CQGManualFill Interface | CQGManualFill Members


%%PageItemTitle%%

SpeculationType Property
CQGManualFill Interface : SpeculationType Property

Glossary Item Box

Description

Gets the speculation type of the manual fill.

Property type

Read-only property

Syntax

Visual Basic
Public Property SpeculationType As eSpeculationType

See Also

CQGManualFill Interface | CQGManualFill Members


%%PageItemTitle%%

StatementDate Property
CQGManualFill Interface : StatementDate Property

Glossary Item Box

Description

Gets the statement date of the manual fill.

Property type

Read-only property

Syntax

Visual Basic
Public Property StatementDate As Date

Return Type

Statement date, represented as Date

See Also

CQGManualFill Interface | CQGManualFill Members


%%PageItemTitle%%

TradeId Property
CQGManualFill Interface : TradeId Property

Glossary Item Box

Description

Gets the local trade ID.

Property type

Read-only property

Syntax

Visual Basic
Public Property TradeId As Long

Return Type

Trade ID, represented as Long

See Also

CQGManualFill Interface | CQGManualFill Members


%%PageItemTitle%%

TradeTimestamp Property
CQGManualFill Interface : TradeTimestamp Property

Glossary Item Box

Description

Gets trade's date.

Property type

Read-only property

Syntax

Visual Basic
Public Property TradeTimestamp As Date

Return Type

Trade timestamp, represented as Date

See Also

CQGManualFill Interface | CQGManualFill Members


%%PageItemTitle%%

CQGManualFillRequest Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents parameters used to formulate a manual fill request.

Object Model

CQGManualFillRequest Interface

Remarks

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGManualFillRequest Members


%%PageItemTitle%% $$Members$$

CQGManualFillRequest Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Commission | Commission charged for a fill
Public Property CommissionCurrency | Fill commission currency ((ISO code of currency used to express commission))
Public Property FillEffect | Gets fill effect
Public Property GWAccountID | Gets and sets the Gateway Account ID of the manual fill request.
Public Property InstrumentName | Gets and sets the full instrument name of the manual fill request.
Public Property Note | Gets and sets a trade note for the manual fill request.
Public Property Price | Gets and sets the manual fill request price.
Public Property Quantity | Gets and sets the quantity of the manual fill request.
Public Property QuantityFractional | Gets manual fill fractional quantity
Public Property Side | Gets and sets the side of the manual fill request.
Public Property SpeculationType | Gets and sets the speculation type of the manual fill request.
Public Property StatementDate | Gets and sets the statement date of the manual fill request.
Public Property TradeId | Gets and sets the trade id of the manual fill request.
Public Property TradeTimestamp | Gets and sets trade's timestamp.

See Also

CQGManualFillRequest Interface


%%PageItemTitle%%

Commission Property
CQGManualFillRequest Interface : Commission Property

Glossary Item Box

Description

Commission charged for a fill

Property type

Read-write property

Syntax

Visual Basic
Public Property Commission As Double

See Also

CQGManualFillRequest Interface | CQGManualFillRequest Members


%%PageItemTitle%%

CommissionCurrency Property
CQGManualFillRequest Interface : CommissionCurrency Property

Glossary Item Box

Description

Fill commission currency ((ISO code of currency used to express commission))

Property type

Read-write property

Syntax

Visual Basic
Public Property CommissionCurrency As String

See Also

CQGManualFillRequest Interface | CQGManualFillRequest Members


%%PageItemTitle%%

FillEffect Property
CQGManualFillRequest Interface : FillEffect Property

Glossary Item Box

Description

Gets fill effect

Property type

Read-write property

Syntax

Visual Basic
Public Property FillEffect As eFillEffect

See Also

CQGManualFillRequest Interface | CQGManualFillRequest Members


%%PageItemTitle%%

GWAccountID Property
CQGManualFillRequest Interface : GWAccountID Property

Glossary Item Box

Description

Gets and sets the Gateway Account ID of the manual fill request.

Property type

Read-write property

Syntax

Visual Basic
Public Property GWAccountID As Long

Return Type

Gateway Account ID, represented as Long

See Also

CQGManualFillRequest Interface | CQGManualFillRequest Members


%%PageItemTitle%%

InstrumentName Property
CQGManualFillRequest Interface : InstrumentName Property

Glossary Item Box

Description

Gets and sets the full instrument name of the manual fill request.

Property type

Read-write property

Syntax

Visual Basic
Public Property InstrumentName As String

Return Type

Instrument name, represented as String

See Also

CQGManualFillRequest Interface | CQGManualFillRequest Members


%%PageItemTitle%%

Note Property
CQGManualFillRequest Interface : Note Property

Glossary Item Box

Description

Gets and sets a trade note for the manual fill request.

Property type

Read-write property

Syntax

Visual Basic
Public Property Note As String

Return Type

Note, represented as String

See Also

CQGManualFillRequest Interface | CQGManualFillRequest Members


%%PageItemTitle%%

Price Property
CQGManualFillRequest Interface : Price Property

Glossary Item Box

Description

Gets and sets the manual fill request price.

Property type

Read-write property

Syntax

Visual Basic
Public Property Price As Double

Return Type

Price, represented as Double

See Also

CQGManualFillRequest Interface | CQGManualFillRequest Members


%%PageItemTitle%%

Quantity Property
CQGManualFillRequest Interface : Quantity Property

Glossary Item Box

Description

Gets and sets the quantity of the manual fill request.

Property type

Read-write property

Syntax

Visual Basic
Public Property Quantity As Long

Return Type

Quantity, represented as Long

See Also

CQGManualFillRequest Interface | CQGManualFillRequest Members


%%PageItemTitle%%

QuantityFractional Property
CQGManualFillRequest Interface : QuantityFractional Property

Glossary Item Box

Description

Gets manual fill fractional quantity

Property type

Read-write property

Syntax

Visual Basic
Public Property QuantityFractional As Decimal

See Also

CQGManualFillRequest Interface | CQGManualFillRequest Members


%%PageItemTitle%%

Side Property
CQGManualFillRequest Interface : Side Property

Glossary Item Box

Description

Gets and sets the side of the manual fill request.

Property type

Read-write property

Syntax

Visual Basic
Public Property Side As eOrderSide

Return Type

Side, represented as eOrderSide

See Also

CQGManualFillRequest Interface | CQGManualFillRequest Members


%%PageItemTitle%%

SpeculationType Property
CQGManualFillRequest Interface : SpeculationType Property

Glossary Item Box

Description

Gets and sets the speculation type of the manual fill request.

Property type

Read-write property

Syntax

Visual Basic
Public Property SpeculationType As eSpeculationType

See Also

CQGManualFillRequest Interface | CQGManualFillRequest Members


%%PageItemTitle%%

StatementDate Property
CQGManualFillRequest Interface : StatementDate Property

Glossary Item Box

Description

Gets and sets the statement date of the manual fill request.

Property type

Read-write property

Syntax

Visual Basic
Public Property StatementDate As Date

Return Type

Statement date, represented as Date

See Also

CQGManualFillRequest Interface | CQGManualFillRequest Members


%%PageItemTitle%%

TradeId Property
CQGManualFillRequest Interface : TradeId Property

Glossary Item Box

Description

Gets and sets the trade id of the manual fill request.

Property type

Read-write property

Syntax

Visual Basic
Public Property TradeId As Long

Return Type

Trade ID, represented as Long

See Also

CQGManualFillRequest Interface | CQGManualFillRequest Members


%%PageItemTitle%%

TradeTimestamp Property
CQGManualFillRequest Interface : TradeTimestamp Property

Glossary Item Box

Description

Gets and sets trade's timestamp.

Property type

Read-write property

Syntax

Visual Basic
Public Property TradeTimestamp As Date

Return Type

Trade timestamp, represented as Date

See Also

CQGManualFillRequest Interface | CQGManualFillRequest Members


%%PageItemTitle%%

CQGModifiedProperty Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a single modified order property.

Object Model

CQGModifiedProperty Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGModifiedProperty Members


%%PageItemTitle%% $$Members$$

CQGModifiedProperty Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Description | Returns the description of the modified property.
Public Property Name | Returns the name of the modified property.
Public Property NewValue | Returns the new value of the modified property.
Public Property PreviousValue | Returns the previous value of the modified property.
Public Property Type | Returns the type of the modified property.

See Also

CQGModifiedProperty Interface


%%PageItemTitle%%

Description Property
CQGModifiedProperty Interface : Description Property

Glossary Item Box

Description

Returns the description of the modified property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Description As String

Return Type

Description of the modified property, represented as String

See Also

CQGModifiedProperty Interface | CQGModifiedProperty Members


%%PageItemTitle%%

Name Property
CQGModifiedProperty Interface : Name Property

Glossary Item Box

Description

Returns the name of the modified property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

Return Type

Name of the modified property, represented as String

See Also

CQGModifiedProperty Interface | CQGModifiedProperty Members


%%PageItemTitle%%

NewValue Property
CQGModifiedProperty Interface : NewValue Property

Glossary Item Box

Description

Returns the new value of the modified property.

Property type

Read-only property

Syntax

Visual Basic
Public Property NewValue As Variant

Return Type

The new value of the property, represented as Variant

See Also

CQGModifiedProperty Interface | CQGModifiedProperty Members


%%PageItemTitle%%

PreviousValue Property
CQGModifiedProperty Interface : PreviousValue Property

Glossary Item Box

Description

Returns the previous value of the modified property.

Property type

Read-only property

Syntax

Visual Basic
Public Property PreviousValue As Variant

Return Type

The previous value of the property, represented as Variant

See Also

CQGModifiedProperty Interface | CQGModifiedProperty Members


%%PageItemTitle%%

Type Property
CQGModifiedProperty Interface : Type Property

Glossary Item Box

Description

Returns the type of the modified property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As eOrderProperty

Return Type

Type of the modified property, represented as eOrderProperty

See Also

CQGModifiedProperty Interface | CQGModifiedProperty Members


%%PageItemTitle%%

CQGOrder Interface
See Also Members Send Feedback

Glossary Item Box

Description

This class encapsulates the trading order notion.

Object Model

CQGOrder InterfaceCQGAccount InterfaceCQGFills CollectionCQGFill InterfaceCQGInstrument InterfaceCQGError InterfaceCQGOrderModify InterfaceCQGOrderProperties CollectionCQGOrderProperty InterfaceCQGTransactions CollectionCQGTransaction Interface

Remarks

A CQGOrder object cannot be created manually. The CreateOrder method of CQGCEL should be used instead.

If the user tries to change a property, while its CanBeSet property is False, an exception will be thrown. See eOrderProperty to check which property has read/write access.

Example

See the usage of CQGOrder object in the OrderChanged event's example section.

See examples on retrieving order trader ID, average fill, and other members of the Properties collection in the CQGOrderProperties.Item property's example section.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGOrder Members


%%PageItemTitle%% $$Members$$

CQGOrder Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method Activate | Activates the current order if it is parked.
Public Method Cancel | Requests the current order cancellation.
Public Method Modify | Requests the current order modification.
Public Method Park | Parks the current order if it is active.
Public Method Place | Puts current order in the placement queue.
Public Method PrepareModify | Creates an order modification object which can be filled with desired changes and passed to Modify method.
Public Method SendCareOrderAck | Sends the special care order acknowledgment. Requires APICareOrders enablement

Public Properties

Public Property Account | Gets/sets the corresponding CQGAccount object of the order.
Public Property AlgorithmID | Gets algorithm id of the order
Public Property AlgorithmStringID | Gets algorithm id of the order represented as string
Public Property CanBeCanceled | Returns the order availability for cancellation.
Public Property CanBeModified | Returns the order availability for modification.
Public Property CanBeParked | Returns the order availability for parking.
Public Property CanBeReplaced | Indicates whether the order can be replaced with a market order or not.
Public Property CancelationInstruction | Gets/sets order cancelation instruction type for strategy orders.
Public Property Description | Gets/sets custom description of the order.
Public Property DurationType | Gets/sets the type of order duration.
Public Property FilledQuantity | Returns the order filled quantity.
Public Property FilledQuantityFractional | Order filled fractional quantity
Public Property Fills | Returns the collection of order fills.
Public Property ForceClientExecutionDecision | Execution within the firm
Public Property GUID | Returns Order GUID.
Public Property GWOrderID | Returns order Gateway identifier.
Public Property GWStatus | Returns order Gateway status.
Public Property Instrument | Gets/sets the instrument of the order.
Public Property InstrumentName | Returns the full name of the instrument on which the order is created.
Public Property IsExternal | Identifies if current order is external for this instance of CQG API.
Public Property IsFinal | Identifies if current order status is final.
Public Property LastError | Returns the last error that occurred in this order.
Public Property LastEvent | Returns the last event of the order.
Public Property LimitPrice | Gets/sets the order Limit Price.
Public Property Manual | Whether an order is placed manually or not
Public Property MiFIDAlgorithmID | MiFID algorithm ID
Public Property OrderCheckMark | Gets the order check mark value
Public Property OriginalOrderID | Returns the original order Gateway identifier.
Public Property PlaceTime | Returns the order placing time (local time, converted to the user-configured time zone).
Public Property Properties | Returns a collection of all possible and acceptable (decided depending on the order type) order properties. This is the default property.
Public Property Quantity | Gets/sets the quantity of the order.
Public Property QuantityFractional | Order fractional quantity
Public Property RemainingQuantity | Returns the remaining quantity of the order, i.e. the part of order quantity which is still not filled.
Public Property RemainingQuantityFractional | Order remaining fractional quantity
Public Property Reserved45 | Reserved method
Public Property ServerTimestamp | Timestamp of the last change (server time, converted to the configured time zone). Each order change event forces this property to change its value.
Public Property Side | Gets/sets the side of the order.
Public Property State | Returns the order's local state.
Public Property StopPrice | Gets/sets order Stop Price.
Public Property Tag | This property allows the user to keep his/her own information within the Order object. Multiple pieces of information can be kept in the Tag property under different keys.
Public Property TimeActiveAt | Returns the order activation time (converted to configured time zone).
Public Property Timestamp | Returns the last response reception timestamp. When a property is updated, CQG API records the information reception time in the Timestamp property (using local time). Each order change event forces this property to change its value.
Public Property Transactions | Returns all transactions of the order.
Public Property Type | Returns the type of the order.
Public Property UEName | Returns the order UEName.

See Also

CQGOrder Interface


%%PageItemTitle%%

Activate Method
CQGOrder Interface : Activate Method

Glossary Item Box

Description

Activates the current order if it is parked.

Syntax

Visual Basic
Public Sub Activate()

Remarks

This method works in asynchronous mode, which means that it returns after the request is sent, but without waiting for its results.

If the order is not parked and the user tries to activate it, an exception will be thrown.

This method changes the order status to osInOrderBook. The change will be reported via OrderChanged event.

Example

See the usage of CQGOrder methods in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members | CQGCEL.ActivateAllOrders Method


%%PageItemTitle%%

Cancel Method
CQGOrder Interface : Cancel Method

Glossary Item Box

Description

Requests the current order cancellation.

Syntax

Visual Basic
Public Sub Cancel()

Remarks

This method works in asynchronous mode, which means that it returns after the request is sent, but without waiting for its results.

This method triggers several order status changes. The final status is osCancelled. Each status change will be reported via OrderChanged event.

Example

See the usage of CQGOrder methods in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members | CQGCEL. CancelAllOrders Method | CQGOrder.IsFinal Property | CQGOrder.CanBeCanceled Property


%%PageItemTitle%%

Modify Method
cqg_order_modify
A CQGOrderModify object containing the modification to be made.
CQGOrder Interface : Modify Method

Glossary Item Box

Description

Requests the current order modification.

Syntax

Visual Basic
Public Sub Modify( _
   ByVal cqg_order_modify As CQGOrderModify _
)

Parameters

cqg_order_modify
A CQGOrderModify object containing the modification to be made.

Remarks

Order modification procedure should be started by creating a CQGOrderModify object using the PrepareModify method.

In the returned CQGOrderModify object new property values should be set. For details see its CanBeSet property.

There are several order fields that can be modified while order is not filled. Those are: quantity, price, visible quantity, extended side and locate ID. The price here is a collective name, i.e. the exact property which can be modified depends on the order type. Generally if current order has a price, it can be modified: for example market orders don't have a price, but stops and limits do, etc.

An exception will be thrown if there is no attribute mentioned for modification.

An order can be modified only while it remains in modifiable status, i.e. its status is osInOrderBook.

The order availability for modification can be determined via its CanBeModified property.

The Modify method works in asynchronous mode, which means that it returns after the request is sent, but without waiting for its results.

This method triggers several order status changes. The final status of this transaction is osInOrderBook. Each status change will be reported via OrderChanged event. The modification failure will also be reported that way.

Example

See the usage of Modify method in the PrepareModify method's example section.

See Also

CQGOrder Interface | CQGOrder Members | CQGOrder.CanBeModified Property | CQGOrderModify Interface | CQGOrder.PrepareModify Method | CQGOrderProperty.CanBeSet Property


%%PageItemTitle%%

Park Method
until_
UTC Date/time the parked order should automatically activate.
If value equals to "12/30/1899 12:00:00 AM" UTC (the default value) method will park order without automatic activation.
CQGOrder Interface : Park Method

Glossary Item Box

Description

Parks the current order if it is active.

Syntax

Visual Basic
Public Sub Park( _
   Optional ByVal until_ As Date = "12/30/1899 12:00:00 AM" _
)

Parameters

until_
UTC Date/time the parked order should automatically activate.
If value equals to "12/30/1899 12:00:00 AM" UTC (the default value) method will park order without automatic activation.

Remarks

This method works in asynchronous mode, which means that it returns after the request is sent, but without waiting for its results.

The method fails with an error in the following cases:

  • If the order is inactive;
  • If the order's execution instructions contain the oeiTrailing flag;
  • If the order status is one of osContingent, osRejectGW, osRejectFCM, osCanceled, osFilled, osExpired, osBusted, osParked, osDisconnected, osInTransitTimeout.

This method changes the order status to osParked. The change will be reported through the OrderChanged event.

CanBeParked property determines the order's availability for parking.

The opParked order property determines if the order is parked.

It is possible to remove or change activation time through the CQGOrderModify object. Refer to the opActivationTime order property description.

See Also

CQGOrder Interface | CQGOrder Members | eOrderProperty Enumeration | eOrderStatus Enumeration


%%PageItemTitle%%

Place Method
CQGOrder Interface : Place Method

Glossary Item Box

Description

Puts current order in the placement queue.

Syntax

Visual Basic
Public Sub Place()

Remarks

Order placement procedure should be started with creating an order object using CreateOrder method.

Exception will be thrown if not enough parameters are supplied for order placing. The number of mandatory parameters depends on the order type.

During order placement its status and state are being changed on the fly. Each change is reported via OrderChanged event.

See the eOrderEvent, eOrderStatus and eOrderLocalState descriptions for order's possible conditions.

This method works in asynchronous mode, which means that it returns after the order is sent, but without waiting for its results.

Example

See the usage of Place method in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members | CQGCEL.CreateOrder Method | CQGCEL.OrderChanged Event


%%PageItemTitle%%

PrepareModify Method
CQGOrder Interface : PrepareModify Method

Glossary Item Box

Description

Creates an order modification object which can be filled with desired changes and passed to Modify method.

Syntax

Visual Basic
Public Function PrepareModify() As CQGOrderModify

Return Type

CQGOrderModify object, ready to be configured.

Remarks

See the remarks section of Modify Method for details on order modification.

Example

The following example shows how to modify an internal order via CQG API.

VB
C#
Public Sub ModifyOrder(selectedOrderID As String)
    Dim currentOrderModify As CQGOrderModify
    Dim orderToModify As CQGOrder
    ' Get order with GWOrderID = SelectedOrderID from internal orders collection
    Set orderToModify = CEL.InternalOrders.Item(selectedOrderID)
    If orderToModify Is Nothing Then
        Debug.Print "Order is not found in internal orders collection."
        Exit Sub
    End If
   Debug.Print "Order " & orderToModify.UEName & " was found in internal orders collection."
    'Checking order availability for modification.
    If Not orderToModify.CanBeModified Then
        Debug.Print "Selected order cannot be modified."
        Exit Sub
    End If
    Set currentOrderModify = orderToModify.PrepareModify
    'Change order quantity
    currentOrderModify.Properties(opQuantity) = 11
    orderToModify.Modify currentOrderModify
    Debug.Print "Order modification request was sent."
End Sub
public void ModifyOrder(String selectedOrderID)
{
    // Get order with GWOrderID = SelectedOrderID from internal orders collection
    CQGOrder orderToModify = cel.InternalOrders[selectedOrderID];
    if (orderToModify == null)
    {
        Console.WriteLine("Order is not found in internal orders collection.");
        return;
    }

    Console.WriteLine("Order {0} was found in internal orders collection.", orderToModify.UEName);

    //Checking order availability for modification.
    if (!orderToModify.CanBeModified)
    {
        Console.WriteLine("Selected order cannot be modified.");
        return;
    }

    CQGOrderModify currentOrderModify = orderToModify.PrepareModify();

    // Change order quantity
    currentOrderModify.Properties[eOrderProperty.opQuantity].Value = 11;

    orderToModify.Modify(currentOrderModify);

    Console.WriteLine("Order modification request was sent.");
}

See Also

CQGOrder Interface | CQGOrder Members | CQGOrderModify Interface | CQGOrder. Modify Method | CQGOrder.CanBeModified Property


%%PageItemTitle%%

SendCareOrderAck Method
CQGOrder Interface : SendCareOrderAck Method

Glossary Item Box

Description

Sends the special care order acknowledgment. Requires APICareOrders enablement

Syntax

Visual Basic
Public Sub SendCareOrderAck()

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

Account Property
CQGOrder Interface : Account Property

Glossary Item Box

Description

Gets/sets the corresponding CQGAccount object of the order.

Property type

Read-write property

Syntax

Visual Basic
Public Property Account As CQGAccount

Return Type

CQGAccount object to which this CQGOrder belongs

Remarks

This property becomes read-only after the order is placed.

This property will be convenient for those who are familiar with the VBA specific Parent option.

Example

See the usage of Account property in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

AlgorithmID Property
CQGOrder Interface : AlgorithmID Property

Glossary Item Box

Description

Gets algorithm id of the order

Property type

Read-write property

Syntax

Visual Basic
Public Property AlgorithmID As ULong

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

AlgorithmStringID Property
CQGOrder Interface : AlgorithmStringID Property

Glossary Item Box

Description

Gets algorithm id of the order represented as string

Property type

Read-write property

Syntax

Visual Basic
Public Property AlgorithmStringID As String

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

CanBeCanceled Property
CQGOrder Interface : CanBeCanceled Property

Glossary Item Box

Description

Returns the order availability for cancellation.

Property type

Read-only property

Syntax

Visual Basic
Public Property CanBeCanceled As Boolean

Return Type

True if the order can be cancelled, False otherwise.

Remarks

The order can be cancelled if its status is osInOrderBook, osParked, osContingent, or osBusted.

See Also

CQGOrder Interface | CQGOrder Members | CQGOrder.Cancel Method


%%PageItemTitle%%

CanBeModified Property
CQGOrder Interface : CanBeModified Property

Glossary Item Box

Description

Returns the order availability for modification.

Property type

Read-only property

Syntax

Visual Basic
Public Property CanBeModified As Boolean

Return Type

True if the order can be modified, False otherwise.

Remarks

The order can be modified if its status is osInOrderBook.

See Also

CQGOrder Interface | CQGOrder Members | CQGOrder.PrepareModify Method | CQGOrderModify Interface | CQGOrder.Modify Method


%%PageItemTitle%%

CanBeParked Property
CQGOrder Interface : CanBeParked Property

Glossary Item Box

Description

Returns the order availability for parking.

Property type

Read-only property

Syntax

Visual Basic
Public Property CanBeParked As Boolean

See Also

CQGOrder Interface | CQGOrder Members | Park Method


%%PageItemTitle%%

CanBeReplaced Property
CQGOrder Interface : CanBeReplaced Property

Glossary Item Box

Description

Indicates whether the order can be replaced with a market order or not.

Property type

Read-only property

Syntax

Visual Basic
Public Property CanBeReplaced As Boolean

Return Type

True if the order can be replaced, False otherwise

Remarks

The order can be replaced if its status is osInOrderBook.

You can replace an order by cancelling it then placing a market order with the same parameters (quantity, side, etc.)

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

CancelationInstruction Property
CQGOrder Interface : CancelationInstruction Property

Glossary Item Box

Description

Gets/sets order cancelation instruction type for strategy orders.

Property type

Read-write property

Syntax

Visual Basic
Public Property CancelationInstruction As eOrderCancelationType

Return Type

Order cancelation instruction, represented as eOrderCancelationType

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

Description Property
CQGOrder Interface : Description Property

Glossary Item Box

Description

Gets/sets custom description of the order.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description As String

Return Type

Order description, represented as String

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

DurationType Property
CQGOrder Interface : DurationType Property

Glossary Item Box

Description

Gets/sets the type of order duration.

Property type

Read-write property

Syntax

Visual Basic
Public Property DurationType As eOrderDuration

Return Type

Order duration represented as eOrderDuration

Remarks

See eOrderProperty Enumeration for details.

Example

See the usage of CQGOrder properties in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

FilledQuantity Property
CQGOrder Interface : FilledQuantity Property

Glossary Item Box

Description

Returns the order filled quantity.

Property type

Read-only property

Syntax

Visual Basic
Public Property FilledQuantity As Long

Return Type

Filled quantity represented as Long

Remarks

The quantity may be signed if the UseOrderSide configuration setting is set to False.

Example

See the usage of FilledQuantity property in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members | eOrderProperty Enumeration


%%PageItemTitle%%

FilledQuantityFractional Property
CQGOrder Interface : FilledQuantityFractional Property

Glossary Item Box

Description

Order filled fractional quantity

Property type

Read-only property

Syntax

Visual Basic
Public Property FilledQuantityFractional As Decimal

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

Fills Property
CQGOrder Interface : Fills Property

Glossary Item Box

Description

Returns the collection of order fills.

Property type

Read-only property

Syntax

Visual Basic
Public Property Fills As CQGFills

Return Type

Order fills collection represented as CQGFills

Remarks

Each CQGFill object in this collection, represents a single fill of the order.

Example

See the usage of CQGOrder properties in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members | CQGFills Collection | CQGFill Interface


%%PageItemTitle%%

ForceClientExecutionDecision Property
CQGOrder Interface : ForceClientExecutionDecision Property

Glossary Item Box

Description

Execution within the firm

Property type

Read-write property

Syntax

Visual Basic
Public Property ForceClientExecutionDecision As Boolean

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

GUID Property
CQGOrder Interface : GUID Property

Glossary Item Box

Description

Returns Order GUID.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID As String

Return Type

Order GUID, represented as String

Example

See the usage of CQGOrder properties in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members | eOrderProperty Enumeration


%%PageItemTitle%%

GWOrderID Property
CQGOrder Interface : GWOrderID Property

Glossary Item Box

Description

Returns order Gateway identifier.

Property type

Read-only property

Syntax

Visual Basic
Public Property GWOrderID As String

Return Type

Gateway identifier, represented as String

Remarks

This property can change its value if the order was modified or canceled. See the Remarks section of OriginalOrderID property for details.

Example

See the usage of GWOrderID property in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

GWStatus Property
CQGOrder Interface : GWStatus Property

Glossary Item Box

Description

Returns order Gateway status.

Property type

Read-only property

Syntax

Visual Basic
Public Property GWStatus As eOrderStatus

Return Type

Gateway status, represented as eOrderStatus.

See eOrderProperty Enumeration for details.

Remarks

This property identifies the order's progress in CQG Gateway.

Example

See the usage of GWStatus property in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members | eOrderStatus Enumeration


%%PageItemTitle%%

Instrument Property
CQGOrder Interface : Instrument Property

Glossary Item Box

Description

Gets/sets the instrument of the order.

Property type

Read-write property

Syntax

Visual Basic
Public Property Instrument As CQGInstrument

Return Type

Order instrument represented as CQGInstrument object

Remarks

This property becomes read-only after the order is placed.

An order can be placed only on a subscribed instrument.

The property can be Nothing if the corresponding instrument is not subscribed to. To subscribe to an instrument use CQGCEL.NewInstrument.

Example

See the usage of CQGOrder properties in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

InstrumentName Property
CQGOrder Interface : InstrumentName Property

Glossary Item Box

Description

Returns the full name of the instrument on which the order is created.

Property type

Read-only property

Syntax

Visual Basic
Public Property InstrumentName As String

Return Type

Instrument full name represented as String

Example

See the usage of InstrumentName property in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

IsExternal Property
CQGOrder Interface : IsExternal Property

Glossary Item Box

Description

Identifies if current order is external for this instance of CQG API.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsExternal As Boolean

Return Type

True if the order is external, False otherwise.

Remarks

See the remarks section of Orders Property for description of external orders.

Example

See the usage of CQGOrder properties in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

IsFinal Property
CQGOrder Interface : IsFinal Property

Glossary Item Box

Description

Identifies if current order status is final.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsFinal As Boolean

Return Type

True if the order status is final, False otherwise.

Remarks

The order is final if its GWStatus value is one of the following:

  • osRejectGW
  • osRejectFCM
  • osExpired
  • osCanceled
  • osFilled
  • osBusted
  • osParked
  • osInTransitTimeout

Example

See the usage of IsFinal property in the OnQueryProgress event's example section.

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

LastError Property
CQGOrder Interface : LastError Property

Glossary Item Box

Description

Returns the last error that occurred in this order.

Property type

Read-only property

Syntax

Visual Basic
Public Property LastError As CQGError

Return Type

The last error represented as CQGError object.

Remarks

While there is no error the value of this property remains Nothing.

Example

See the usage of CQGOrder properties in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members | CQGCEL.OrderChanged Event


%%PageItemTitle%%

LastEvent Property
CQGOrder Interface : LastEvent Property

Glossary Item Box

Description

Returns the last event of the order.

Property type

Read-only property

Syntax

Visual Basic
Public Property LastEvent As eOrderEvent

Return Type

The last event of the order represented as eOrderEvent.

Example

See the usage of CQGOrder properties in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members | CQGCEL.OrderChanged Event | eOrderEvent Enumeration


%%PageItemTitle%%

LimitPrice Property
CQGOrder Interface : LimitPrice Property

Glossary Item Box

Description

Gets/sets the order Limit Price.

Property type

Read-write property

Syntax

Visual Basic
Public Property LimitPrice As Double

Return Type

Limit price represented as Double

Invalid value if the order type does not support limit prices.

Remarks

This property becomes read-only after the order is placed.

See eOrderProperty Enumeration for details.

Example

See the usage of CQGOrder properties in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

Manual Property
CQGOrder Interface : Manual Property

Glossary Item Box

Description

Whether an order is placed manually or not

Property type

Read-write property

Syntax

Visual Basic
Public Property Manual As Boolean

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

MiFIDAlgorithmID Property
CQGOrder Interface : MiFIDAlgorithmID Property

Glossary Item Box

Description

MiFID algorithm ID

Property type

Read-write property

Syntax

Visual Basic
Public Property MiFIDAlgorithmID As String

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

OrderCheckMark Property
CQGOrder Interface : OrderCheckMark Property

Glossary Item Box

Description

Gets the order check mark value

Property type

Read-write property

Syntax

Visual Basic
Public Property OrderCheckMark As Boolean

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

OriginalOrderID Property
CQGOrder Interface : OriginalOrderID Property

Glossary Item Box

Description

Returns the original order Gateway identifier.

Property type

Read-only property

Syntax

Visual Basic
Public Property OriginalOrderID As String

Return Type

Original order Gateway identifier, represented as String

Remarks

This property stays equal to GWOrderID until some order transformation (e.g. order modification or cancellation) takes place. In that case the GWOrderID property obtains a new value and OriginalOrderID stays the same, thus identifying the initial order.

Example

See the usage of CQGOrder properties in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

PlaceTime Property
CQGOrder Interface : PlaceTime Property

Glossary Item Box

Description

Returns the order placing time (local time, converted to the user-configured time zone).

Property type

Read-only property

Syntax

Visual Basic
Public Property PlaceTime As Date

Return Type

Date variable containing the place time.

Example

See the usage of PlaceTime property in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

Properties Property
CQGOrder Interface : Properties Property

Glossary Item Box

Description

Returns a collection of all possible and acceptable (decided depending on the order type) order properties.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Properties As CQGOrderProperties

Return Type

Properties collection represented as CQGOrderProperties.

Remarks

Depending on order type, properties contained in this collection will be different.

For example market order will not have price property in this collection, etc.

Example

See the usage of Properties property in the PrepareModify method's example section.

See examples on retrieving order trader ID, average fill, and other members of the Properties collection in the CQGOrderProperties.Item property's example section.

See Also

CQGOrder Interface | CQGOrder Members | eOrderProperty Enumeration


%%PageItemTitle%%

Quantity Property
CQGOrder Interface : Quantity Property

Glossary Item Box

Description

Gets/sets the quantity of the order.

Property type

Read-write property

Syntax

Visual Basic
Public Property Quantity As Long

Return Type

Order quantity represented as Long

Remarks

This property becomes read-only after the order is placed.

The quantity may be signed if the UseOrderSide configuration setting is set to False.

See eOrderProperty Enumeration for details.

Example

See the usage of Quantity property in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

QuantityFractional Property
CQGOrder Interface : QuantityFractional Property

Glossary Item Box

Description

Order fractional quantity

Property type

Read-write property

Syntax

Visual Basic
Public Property QuantityFractional As Decimal

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

RemainingQuantity Property
CQGOrder Interface : RemainingQuantity Property

Glossary Item Box

Description

Returns the remaining quantity of the order, i.e. the part of order quantity which is still not filled.

Property type

Read-only property

Syntax

Visual Basic
Public Property RemainingQuantity As Long

Return Type

Remaining quantity represented as Long

Remarks

The quantity may be signed if the UseOrderSide configuration setting is set to False.

Example

See the usage of CQGOrder properties in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

RemainingQuantityFractional Property
CQGOrder Interface : RemainingQuantityFractional Property

Glossary Item Box

Description

Order remaining fractional quantity

Property type

Read-only property

Syntax

Visual Basic
Public Property RemainingQuantityFractional As Decimal

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

Reserved45 Property
CQGOrder Interface : Reserved45 Property

Glossary Item Box

Description

Reserved method

Property type

Read-write property

Syntax

Visual Basic
Public Property Reserved45 As Long

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

ServerTimestamp Property
CQGOrder Interface : ServerTimestamp Property

Glossary Item Box

Description

Timestamp of the last change (server time, converted to the configured time zone).
Each order change event forces this property to change its value.

Property type

Read-only property

Syntax

Visual Basic
Public Property ServerTimestamp As Date

Return Type

Date variable containing the server timestamp

Remarks

The timestamp is converted to the timezone, previously configured by the user.

If no timezone configuration was made, the timestamp is converted to UTC.

Example

See the usage of CQGOrder properties in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

Side Property
CQGOrder Interface : Side Property

Glossary Item Box

Description

Gets/sets the side of the order.

Property type

Read-write property

Syntax

Visual Basic
Public Property Side As eOrderSide

Return Type

Order side represented as eOrderSide

Remarks

This property becomes read-only after the order is placed.

If the UseOrderSide configuration setting is set to False, this property value will be osdUndefined.

Example

See the usage of Side property in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

State Property
CQGOrder Interface : State Property

Glossary Item Box

Description

Returns the order's local state.

Property type

Read-only property

Syntax

Visual Basic
Public Property State As eOrderLocalState

Return Type

Local state represented as eOrderLocalState

Remarks

This property identifies the order's progress inside CQG API.

See eOrderProperty Enumeration for details.

Example

See the usage of CQGOrder properties in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

StopPrice Property
CQGOrder Interface : StopPrice Property

Glossary Item Box

Description

Gets/sets order Stop Price.

Property type

Read-write property

Syntax

Visual Basic
Public Property StopPrice As Double

Return Type

Stop price represented as Double.

Invalid value if order type does not support stop prices.

Remarks

This property becomes read-only after the order is placed.

See eOrderProperty Enumeration for details.

Example

See the usage of CQGOrder properties in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

Tag Property
tag_name
Key string set by the user. When setting, tagName should contain the key that will be associated with the current data.

When getting the information from the tag, one of the previously set keys should be passed as tagName in order to get the corresponding information.

CQGOrder Interface : Tag Property

Glossary Item Box

Description

This property allows the user to keep his/her own information within the Order object. Multiple pieces of information can be kept in the Tag property under different keys.

Property type

Read-write property

Syntax

Visual Basic
Public Property Tag( _
   ByVal tag_name As String _
) As Variant

Parameters

tag_name
Key string set by the user. When setting, tagName should contain the key that will be associated with the current data.

When getting the information from the tag, one of the previously set keys should be passed as tagName in order to get the corresponding information.

Return Type

Information represented as Variant

Remarks

Once set, the tag is kept inside the instrument until modification or deletion. The tag can be modified by any user. Always make sure that the previously set tag has a valid information stored (e.g. some functions in your program has not deleted it).

To delete a tag, the user needs to assign Empty to its value:

Order.Tag("tagname") = Empty

Example

See the usage of CQGOrder properties in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

TimeActiveAt Property
CQGOrder Interface : TimeActiveAt Property

Glossary Item Box

Description

Returns the order activation time (converted to configured time zone).

Property type

Read-only property

Syntax

Visual Basic
Public Property TimeActiveAt As Date

Return Type

Order activation time, represented as Date

Example

See the usage of CQGOrder properties in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members | eOrderStatus Enumeration


%%PageItemTitle%%

Timestamp Property
CQGOrder Interface : Timestamp Property

Glossary Item Box

Description

Returns the last response reception timestamp.

When a property is updated, CQG API records the information reception time in the Timestamp property (using local time).

Each order change event forces this property to change its value.

Property type

Read-only property

Syntax

Visual Basic
Public Property Timestamp As Date

Return Type

Date variable containing the local timestamp

Remarks

The timestamp is converted to the timezone previously configured by the user.

If no timezone configuration was made, the timestamp is converted to UTC.

Example

See the usage of CQGOrder properties in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

Transactions Property
CQGOrder Interface : Transactions Property

Glossary Item Box

Description

Returns all transactions of the order.

Property type

Read-only property

Syntax

Visual Basic
Public Property Transactions As CQGTransactions

Return Type

Order's transactions, represented as CQGTransactions

Example

See the usage of CQGOrder properties in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

Type Property
CQGOrder Interface : Type Property

Glossary Item Box

Description

Returns the type of the order.

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As eOrderType

Return Type

Order type, represented as eOrderType

Remarks

The order type is set once upon creation and cannot be modified later.

See eOrderProperty Enumeration for details.

Example

See the usage of CQGOrder properties in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members


%%PageItemTitle%%

UEName Property
CQGOrder Interface : UEName Property

Glossary Item Box

Description

Returns the order UEName.

Property type

Read-only property

Syntax

Visual Basic
Public Property UEName As String

Return Type

UEName, represented as String

Remarks

The UEName is set once upon creation and cannot be modified later.

The user-editable part of a UEName has the following restrictions:

  • It may not include the dash character (i.e., "-")
  • Its length is limited to 14 characters

Example

See the usage of UEName property in the OrderChanged event's example section.

See Also

CQGOrder Interface | CQGOrder Members | eOrderProperty Enumeration


%%PageItemTitle%%

CQGOrderActionRequest Interface
See Also Members Send Feedback

Glossary Item Box

Description

Defines the interface of ICQGOrderActionRequest

Object Model

CQGOrderActionRequest InterfaceCQGAccount InterfaceCQGInstrument Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGOrderActionRequest Members


%%PageItemTitle%% $$Members$$

CQGOrderActionRequest Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Account | Gets account for which order action is requested
Public Property AlgorithmID | Gets algorithm id order action request
Public Property AlgorithmStringID | Gets algorithm id of the order action request represented as string
Public Property ForceClientExecutionDecision | Execution within the firm
Public Property FromAllTraders | Gets from all traders flag
Public Property Instrument | Gets instrument for which order action is requested
Public Property Manual | Whether an order is placed manually or not
Public Property MiFIDAlgorithmID | MiFID algorithm ID
Public Property OrderSide | Gets order side
Public Property Parked | Gets parked flag

See Also

CQGOrderActionRequest Interface


%%PageItemTitle%%

Account Property
CQGOrderActionRequest Interface : Account Property

Glossary Item Box

Description

Gets account for which order action is requested

Property type

Read-write property

Syntax

Visual Basic
Public Property Account As CQGAccount

See Also

CQGOrderActionRequest Interface | CQGOrderActionRequest Members


%%PageItemTitle%%

AlgorithmID Property
CQGOrderActionRequest Interface : AlgorithmID Property

Glossary Item Box

Description

Gets algorithm id order action request

Property type

Read-write property

Syntax

Visual Basic
Public Property AlgorithmID As ULong

See Also

CQGOrderActionRequest Interface | CQGOrderActionRequest Members


%%PageItemTitle%%

AlgorithmStringID Property
CQGOrderActionRequest Interface : AlgorithmStringID Property

Glossary Item Box

Description

Gets algorithm id of the order action request represented as string

Property type

Read-write property

Syntax

Visual Basic
Public Property AlgorithmStringID As String

See Also

CQGOrderActionRequest Interface | CQGOrderActionRequest Members


%%PageItemTitle%%

ForceClientExecutionDecision Property
CQGOrderActionRequest Interface : ForceClientExecutionDecision Property

Glossary Item Box

Description

Execution within the firm

Property type

Read-write property

Syntax

Visual Basic
Public Property ForceClientExecutionDecision As Boolean

See Also

CQGOrderActionRequest Interface | CQGOrderActionRequest Members


%%PageItemTitle%%

FromAllTraders Property
CQGOrderActionRequest Interface : FromAllTraders Property

Glossary Item Box

Description

Gets from all traders flag

Property type

Read-write property

Syntax

Visual Basic
Public Property FromAllTraders As Boolean

See Also

CQGOrderActionRequest Interface | CQGOrderActionRequest Members


%%PageItemTitle%%

Instrument Property
CQGOrderActionRequest Interface : Instrument Property

Glossary Item Box

Description

Gets instrument for which order action is requested

Property type

Read-write property

Syntax

Visual Basic
Public Property Instrument As CQGInstrument

See Also

CQGOrderActionRequest Interface | CQGOrderActionRequest Members


%%PageItemTitle%%

Manual Property
CQGOrderActionRequest Interface : Manual Property

Glossary Item Box

Description

Whether an order is placed manually or not

Property type

Read-write property

Syntax

Visual Basic
Public Property Manual As Boolean

See Also

CQGOrderActionRequest Interface | CQGOrderActionRequest Members


%%PageItemTitle%%

MiFIDAlgorithmID Property
CQGOrderActionRequest Interface : MiFIDAlgorithmID Property

Glossary Item Box

Description

MiFID algorithm ID

Property type

Read-write property

Syntax

Visual Basic
Public Property MiFIDAlgorithmID As String

See Also

CQGOrderActionRequest Interface | CQGOrderActionRequest Members


%%PageItemTitle%%

OrderSide Property
CQGOrderActionRequest Interface : OrderSide Property

Glossary Item Box

Description

Gets order side

Property type

Read-write property

Syntax

Visual Basic
Public Property OrderSide As eOrderSide

See Also

CQGOrderActionRequest Interface | CQGOrderActionRequest Members


%%PageItemTitle%%

Parked Property
CQGOrderActionRequest Interface : Parked Property

Glossary Item Box

Description

Gets parked flag

Property type

Read-write property

Syntax

Visual Basic
Public Property Parked As Boolean

See Also

CQGOrderActionRequest Interface | CQGOrderActionRequest Members


%%PageItemTitle%%

CQGOrderChain Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a definition of order chain, which is used to place and modify compound orders of OCO type.

Object Model

CQGOrderChain Interface

Remarks

All orders within the chain shall be either in osNotSent or working state.

All orders within the chain shall belong to the same account.

The state of the first added order (i.e., working or new) defines in what state all the other orders shall be.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGOrderChain Members | PlaceCompoundOrderEx Method | ModifyCompoundOrderEx Method


%%PageItemTitle%% $$Members$$

CQGOrderChain Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method AddOrder Adds order to the chain of orders

Public Properties

Public Property AlgorithmID | Gets algorithm id of compound order
Public Property AlgorithmStringID | Gets algorithm id of the compound order represented as string
Public Property ForceClientExecutionDecision | Execution within the firm
Public Property GUID | Gets chain GUID. Value is generated automatically on object creation.
Public Property GWAccountID | Returns the GW account ID of the orders chain
Public Property Manual | Whether an order is placed manually or not
Public Property MiFIDAlgorithmID | MiFID algorithm ID

See Also

CQGOrderChain Interface | PlaceCompoundOrderEx Method | ModifyCompoundOrderEx Method


%%PageItemTitle%%

AddOrder Method
cqg_order
Order to add
CQGOrderChain Interface : AddOrder Method

Glossary Item Box

Description

Adds order to the chain of orders

Syntax

Visual Basic
Public Sub AddOrder( _
   ByVal cqg_order As CQGOrder _
)

Parameters

cqg_order
Order to add

See Also

CQGOrderChain Interface | CQGOrderChain Members


%%PageItemTitle%%

AlgorithmID Property
CQGOrderChain Interface : AlgorithmID Property

Glossary Item Box

Description

Gets algorithm id of compound order

Property type

Read-write property

Syntax

Visual Basic
Public Property AlgorithmID As ULong

See Also

CQGOrderChain Interface | CQGOrderChain Members


%%PageItemTitle%%

AlgorithmStringID Property
CQGOrderChain Interface : AlgorithmStringID Property

Glossary Item Box

Description

Gets algorithm id of the compound order represented as string

Property type

Read-write property

Syntax

Visual Basic
Public Property AlgorithmStringID As String

See Also

CQGOrderChain Interface | CQGOrderChain Members


%%PageItemTitle%%

ForceClientExecutionDecision Property
CQGOrderChain Interface : ForceClientExecutionDecision Property

Glossary Item Box

Description

Execution within the firm

Property type

Read-write property

Syntax

Visual Basic
Public Property ForceClientExecutionDecision As Boolean

See Also

CQGOrderChain Interface | CQGOrderChain Members


%%PageItemTitle%%

GUID Property
CQGOrderChain Interface : GUID Property

Glossary Item Box

Description

Gets chain GUID. Value is generated automatically on object creation.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID As String

Remarks

Value is used as compound order GUID if object is a parameter in PlaceCompoundOrderEx.

See Also

CQGOrderChain Interface | CQGOrderChain Members


%%PageItemTitle%%

GWAccountID Property
CQGOrderChain Interface : GWAccountID Property

Glossary Item Box

Description

Returns the GW account ID of the orders chain

Property type

Read-only property

Syntax

Visual Basic
Public Property GWAccountID As Long

See Also

CQGOrderChain Interface | CQGOrderChain Members


%%PageItemTitle%%

Manual Property
CQGOrderChain Interface : Manual Property

Glossary Item Box

Description

Whether an order is placed manually or not

Property type

Read-write property

Syntax

Visual Basic
Public Property Manual As Boolean

See Also

CQGOrderChain Interface | CQGOrderChain Members


%%PageItemTitle%%

MiFIDAlgorithmID Property
CQGOrderChain Interface : MiFIDAlgorithmID Property

Glossary Item Box

Description

MiFID algorithm ID

Property type

Read-write property

Syntax

Visual Basic
Public Property MiFIDAlgorithmID As String

See Also

CQGOrderChain Interface | CQGOrderChain Members


%%PageItemTitle%%

CQGOrderConstructor Interface
See Also Members Send Feedback

Glossary Item Box

Description

The class constructs an order by properties set

Object Model

CQGOrderConstructor InterfaceCQGOrder InterfaceCQGOrderProperties CollectionCQGOrderProperty Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGOrderConstructor Members


%%PageItemTitle%% $$Members$$

CQGOrderConstructor Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method CreateOrder Creates the new order using the properties set

Public Properties

Public Property Properties A collection of order properties are required for an order creation.

See Also

CQGOrderConstructor Interface


%%PageItemTitle%%

CreateOrder Method
CQGOrderConstructor Interface : CreateOrder Method

Glossary Item Box

Description

Creates the new order using the properties set

Syntax

Visual Basic
Public Function CreateOrder() As CQGOrder

See Also

CQGOrderConstructor Interface | CQGOrderConstructor Members


%%PageItemTitle%%

Properties Property
CQGOrderConstructor Interface : Properties Property

Glossary Item Box

Description

A collection of order properties are required for an order creation.

Property type

Read-only property

Syntax

Visual Basic
Public Property Properties As CQGOrderProperties

Remarks

The following table shows what properties are stored in the collection for different order types:

Order type Order properties

otMarket
  • opInstrumentNameDetailed
  • opAccountID
  • opQuantityFractional
  • opUEName

otLimit
  • opInstrumentNameDetailed
  • opAccountID
  • opLimitPrice
  • opQuantityFractional
  • opUEName

otStop
  • opInstrumentNameDetailed
  • opAccountID
  • opStopPrice
  • opQuantityFractional
  • opUEName

otStopLimit
  • opInstrumentNameDetailed
  • opAccountID
  • opLimitPrice
  • opStopPrice
  • opQuantityFractional
  • opUEName

See Also

CQGOrderConstructor Interface | CQGOrderConstructor Members


%%PageItemTitle%%

CQGOrderModify Interface
See Also Members Send Feedback

Glossary Item Box

Description

The CQGOrderModify is an object the user needs to create in order to specify order modification parameters.

Object Model

CQGOrderModify InterfaceCQGOrderProperties CollectionCQGOrderProperty Interface

Remarks

To create an object of this type call the PrepareModify method of CQGOrder.

Example

See the usage of CQGOrderModify object in the PrepareModify method's example section.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGOrderModify Members


%%PageItemTitle%% $$Members$$

CQGOrderModify Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Properties

Returns CQGOrderProperties collection containing current order's those properties which are available for modification.

This is the default property.

See Also

CQGOrderModify Interface


%%PageItemTitle%%

Properties Property
CQGOrderModify Interface : Properties Property

Glossary Item Box

Description

Returns CQGOrderProperties collection containing current order's those properties which are available for modification.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Properties As CQGOrderProperties

Return Type

CQGOrderProperties collection object

Remarks

See the CanBeSet property for details on order modification possibilities.

CQGOrderProperty objects in this collection do not have parent orders. Their Order Property value is Nothing.

Example

See the usage of Properties property in the PrepareModify method's example section.

See Also

CQGOrderModify Interface | CQGOrderModify Members


%%PageItemTitle%%

CQGOrderProperty Interface
See Also Members Send Feedback

Glossary Item Box

Description

Encapsulates information on an order property.

Object Model

CQGOrderProperty InterfaceCQGOrder Interface

Remarks

If the user tries to change a property, while its CanBeSet property is False, an exception will be thrown. See eOrderProperty to check which property has read/write access.

Example

See the usage of the CQGOrderProperties collection in OrderChanged event's example section.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGOrderProperty Members


%%PageItemTitle%% $$Members$$

CQGOrderProperty Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property CanBeSet | Indicates whether the property can be set by the user or not.
Public Property Description | Returns the description of the order property.
Public Property Name | Returns the order property name.
Public Property Order | Returns the corresponding CQGOrder object.
Public Property Timestamp | Returns the last response reception timestamp. When a property is updated, CQG API records the information reception time in the Timestamp property (using local time). Each order property change event forces this property to change its value.
Public Property Type | Returns the order property type.
Public Property Value | Gets/sets the value of the order property. This is the default property.

See Also

CQGOrderProperty Interface


%%PageItemTitle%%

CanBeSet Property
CQGOrderProperty Interface : CanBeSet Property

Glossary Item Box

Description

Indicates whether the property can be set by the user or not.

Property type

Read-only property

Syntax

Visual Basic
Public Property CanBeSet As Boolean

Return Type

True if the property can be set, False otherwise.

Remarks

There are two cases when the user may set a property value:

  • upon order creation (after CreateOrder call, but before the actual placing)
  • upon order modification.

The order properties have either read-only or read/write access.

Read-only properties are never set by the user.

All read/write properties available for the order can be set before its placing. All properties available for the current order type are contained in its Properties collection, though not all of them will have read/write access.

Only a few order properties can be modified after order placing. Mainly those are prices and quantity.

See eOrderProperty to check which properties are read-only, which are read/write and which are modifiable.

If the user tries to change a property, while its CanBeSet property is False, an exception will be thrown.

See Also

CQGOrderProperty Interface | CQGOrderProperty Members | CQGOrder.PrepareModify Method | CQGOrder.Modify Method


%%PageItemTitle%%

Description Property
CQGOrderProperty Interface : Description Property

Glossary Item Box

Description

Returns the description of the order property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Description As String

Return Type

Description represented as String

See Also

CQGOrderProperty Interface | CQGOrderProperty Members


%%PageItemTitle%%

Name Property
CQGOrderProperty Interface : Name Property

Glossary Item Box

Description

Returns the order property name.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

Return Type

Property name represented as String

See Also

CQGOrderProperty Interface | CQGOrderProperty Members


%%PageItemTitle%%

Order Property
CQGOrderProperty Interface : Order Property

Glossary Item Box

Description

Returns the corresponding CQGOrder object.

Property type

Read-only property

Syntax

Visual Basic
Public Property Order As CQGOrder

Return Type

If the property belongs to CQGOrder Properties collection this property will return the corresponding CQGOrder object.

If the property belongs to CQGOrderModify Properties collection, this property value will be Nothing.

Remarks

This property will be convenient for those who are familiar with the VBA specific Parent option.

See Also

CQGOrderProperty Interface | CQGOrderProperty Members


%%PageItemTitle%%

Timestamp Property
CQGOrderProperty Interface : Timestamp Property

Glossary Item Box

Description

Returns the last response reception timestamp.

When a property is updated, CQG API records the information reception time in the Timestamp property (using local time).

Each order property change event forces this property to change its value.

Property type

Read-only property

Syntax

Visual Basic
Public Property Timestamp As Date

Return Type

Date variable containing the local timestamp

Remarks

The timestamp is converted to the timezone previously configured by the user.

If no timezone configuration was made, the timestamp is converted to UTC.

See Also

CQGOrderProperty Interface | CQGOrderProperty Members


%%PageItemTitle%%

Type Property
CQGOrderProperty Interface : Type Property

Glossary Item Box

Description

Returns the order property type.

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As eOrderProperty

Return Type

Order property type represented as eOrderProperty

See Also

CQGOrderProperty Interface | CQGOrderProperty Members


%%PageItemTitle%%

Value Property
CQGOrderProperty Interface : Value Property

Glossary Item Box

Description

Gets/sets the value of the order property.

This is the default property.

Property type

Read-write property

Syntax

Visual Basic
Public Property Value As Variant

Return Type

Order property value represented as Variant

See Also

CQGOrderProperty Interface | CQGOrderProperty Members


%%PageItemTitle%%

CQGOrdersQuery Interface
See Also Members Send Feedback

Glossary Item Box

Description

Encapsulates the historical order query functionality.

Object Model

CQGOrdersQuery InterfaceCQGAccount InterfaceCQGCEL InterfaceCQGError InterfaceCQGOrders CollectionCQGOrder InterfaceCQGOrders CollectionCQGOrder Interface

Remarks

Object of this type cannot be created manually. Use QueryOrders of CQGCEL instead.

For details on querying orders see QueryOrders Method and OnQueryProgress Event.

Example

See the usage of CQGOrdersQuery object in the OnQueryProgress event's example section.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGOrdersQuery Members | QueryOrders Method | OnQueryProgress Event


%%PageItemTitle%% $$Members$$

CQGOrdersQuery Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method Cancel

Cancels the current query.

Public Properties

Public Property Account | Returns the CQGAccount object, used to formulate this query.
Public Property CEL | Returns the corresponding CQGCEL object.
Public Property FinalError | Returns the final error of current query.
Public Property LastChunk | Returns the last chunk of orders received as answer to current query.
Public Property Orders | Returns the collection of orders received as a response to the current query.
Public Property QueryID | Returns the unique identifier of current query.
Public Property ServerTimestamp | Timestamp of the last change (server time, converted to the user-configured time zone). Each order query change event forces this property to change its value.
Public Property Status | Returns the current status of the query.
Public Property Timestamp | Returns the last response reception timestamp. When a property is updated, CQG API records the information reception time in the Timestamp property (using local time). Each order query change event forces this property to change its value.

See Also

CQGOrdersQuery Interface | QueryOrders Method | OnQueryProgress Event


%%PageItemTitle%%

Cancel Method
CQGOrdersQuery Interface : Cancel Method

Glossary Item Box

Description

Cancels the current query.

Syntax

Visual Basic
Public Sub Cancel()

Remarks

This method call should lead the query status to become rsCanceled.

The method works in asynchronous mode and the status change will also occur after request is physically cancelled.

See Also

CQGOrdersQuery Interface | CQGOrdersQuery Members


%%PageItemTitle%%

Account Property
CQGOrdersQuery Interface : Account Property

Glossary Item Box

Description

Returns the CQGAccount object, used to formulate this query.

Property type

Read-only property

Syntax

Visual Basic
Public Property Account As CQGAccount

Return Type

The corresponding account, represented as CQGAccount Object

See Also

CQGOrdersQuery Interface | CQGOrdersQuery Members


%%PageItemTitle%%

CEL Property
CQGOrdersQuery Interface : CEL Property

Glossary Item Box

Description

Returns the corresponding CQGCEL object.

Property type

Read-only property

Syntax

Visual Basic
Public Property CEL As CQGCEL

Return Type

CQGCEL object to which this CQGOrdersQuery belongs

Remarks

This property will be convenient for those who are familiar with the VBA specific Parent option.

Example

See the usage of CQGOrdersQuery properties in the OnQueryProgress event's example section.

See Also

CQGOrdersQuery Interface | CQGOrdersQuery Members


%%PageItemTitle%%

FinalError Property
CQGOrdersQuery Interface : FinalError Property

Glossary Item Box

Description

Returns the final error of current query.

Property type

Read-only property

Syntax

Visual Basic
Public Property FinalError As CQGError

Return Type

Final error represented as CQGError object

Remarks

If there is no error the value of this property remains Nothing.

Example

See the usage of CQGOrdersQuery properties in the OnQueryProgress event's example section.

See Also

CQGOrdersQuery Interface | CQGOrdersQuery Members


%%PageItemTitle%%

LastChunk Property
CQGOrdersQuery Interface : LastChunk Property

Glossary Item Box

Description

Returns the last chunk of orders received as answer to current query.

Property type

Read-only property

Syntax

Visual Basic
Public Property LastChunk As CQGOrders

Return Type

Orders chunk represented as CQGOrders collection.

Remarks

See the Remarks section of OnQueryProgress Event for details.

Example

See the usage of CQGOrdersQuery properties in the OnQueryProgress event's example section.

See Also

CQGOrdersQuery Interface | CQGOrdersQuery Members


%%PageItemTitle%%

Orders Property
CQGOrdersQuery Interface : Orders Property

Glossary Item Box

Description

Returns the collection of orders received as a response to the current query.

Property type

Read-only property

Syntax

Visual Basic
Public Property Orders As CQGOrders

Return Type

Resulting orders list represented as CQGOrders

Remarks

See the Remarks section of OnQueryProgress Event for details.

Example

See the usage of CQGOrdersQuery properties in the OnQueryProgress event's example section.

See Also

CQGOrdersQuery Interface | CQGOrdersQuery Members


%%PageItemTitle%%

QueryID Property
CQGOrdersQuery Interface : QueryID Property

Glossary Item Box

Description

Returns the unique identifier of current query.

Property type

Read-only property

Syntax

Visual Basic
Public Property QueryID As Long

Return Type

Query ID represented as Long

Example

See the usage of QueryID property in the OnQueryProgress event's example section.

See Also

CQGOrdersQuery Interface | CQGOrdersQuery Members


%%PageItemTitle%%

ServerTimestamp Property
CQGOrdersQuery Interface : ServerTimestamp Property

Glossary Item Box

Description

Timestamp of the last change (server time, converted to the user-configured time zone).
Each order query change event forces this property to change its value.

Property type

Read-only property

Syntax

Visual Basic
Public Property ServerTimestamp As Date

Return Type

Date variable containing the server timestamp

Remarks

The timestamp is converted to the timezone, previously configured by the user.

If no timezone configuration was made, the timestamp is converted to UTC.

Example

See the usage of CQGOrdersQuery properties in the OnQueryProgress event's example section.

See Also

CQGOrdersQuery Interface | CQGOrdersQuery Members


%%PageItemTitle%%

Status Property
CQGOrdersQuery Interface : Status Property

Glossary Item Box

Description

Returns the current status of the query.

Property type

Read-only property

Syntax

Visual Basic
Public Property Status As eRequestStatus

Return Type

Query status represented as eRequestStatus

Remarks

On each status change an OnQueryProgress event is fired.

Example

See the usage of Status property in the OnQueryProgress event's example section.

See Also

CQGOrdersQuery Interface | CQGOrdersQuery Members


%%PageItemTitle%%

Timestamp Property
CQGOrdersQuery Interface : Timestamp Property

Glossary Item Box

Description

Returns the last response reception timestamp.

When a property is updated, CQG API records the information reception time in the Timestamp property (using local time).

Each order query change event forces this property to change its value.

Property type

Read-only property

Syntax

Visual Basic
Public Property Timestamp As Date

Return Type

Date variable containing the local timestamp

Remarks

The timestamp is converted to the timezone previously configured by the user.

If no timezone configuration was made, the timestamp is converted to UTC.

Example

See the usage of CQGOrdersQuery properties in the OnQueryProgress event's example section.

See Also

CQGOrdersQuery Interface | CQGOrdersQuery Members


%%PageItemTitle%%

CQGParameterDefinition Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a definition of user formula parameter.

Object Model

CQGParameterDefinition InterfaceCQGStringCollection Collection

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGParameterDefinition Members


%%PageItemTitle%% $$Members$$

CQGParameterDefinition Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property AvailableValues | Returns parameter available values
Public Property Comment | Returns the parameter comment.
Public Property DefaultValue | Returns the parameter's default value.
Public Property Name | Returns the parameter name.
Public Property Type | Returns the parameter type.

See Also

CQGParameterDefinition Interface


%%PageItemTitle%%

AvailableValues Property
CQGParameterDefinition Interface : AvailableValues Property

Glossary Item Box

Description

Returns parameter available values

Property type

Read-only property

Syntax

Visual Basic
Public Property AvailableValues As CQGStringCollection

See Also

CQGParameterDefinition Interface | CQGParameterDefinition Members


%%PageItemTitle%%

Comment Property
CQGParameterDefinition Interface : Comment Property

Glossary Item Box

Description

Returns the parameter comment.

Property type

Read-only property

Syntax

Visual Basic
Public Property Comment As String

Return Type

Parameter comment, represented as String

See Also

CQGParameterDefinition Interface | CQGParameterDefinition Members


%%PageItemTitle%%

DefaultValue Property
CQGParameterDefinition Interface : DefaultValue Property

Glossary Item Box

Description

Returns the parameter's default value.

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultValue As Variant

Return Type

Parameter's default value, represented as Variant

Remarks

Possible value types are integer & double compatible.

See Also

CQGParameterDefinition Interface | CQGParameterDefinition Members


%%PageItemTitle%%

Name Property
CQGParameterDefinition Interface : Name Property

Glossary Item Box

Description

Returns the parameter name.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

Return Type

Parameter name, represented as String

See Also

CQGParameterDefinition Interface | CQGParameterDefinition Members


%%PageItemTitle%%

Type Property
CQGParameterDefinition Interface : Type Property

Glossary Item Box

Description

Returns the parameter type.

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As eUserFormulaParameterType

Return Type

Parameter type, represented as eUserFormulaParameterType Enumeration

Remarks

See eUserFormulaParameterType for possible values.

See Also

CQGParameterDefinition Interface | CQGParameterDefinition Members | eUserFormulaParameterType Enumeration


%%PageItemTitle%%

CQGPointAndFigureBar Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a single point and figure bar.

Object Model

CQGPointAndFigureBar Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGPointAndFigureBar Members


%%PageItemTitle%% $$Members$$

CQGPointAndFigureBar Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property High | Returns the high of the point and figure bar.
Public Property Low | Returns the low of the point and figure bar.
Public Property Mid | Returns the mid-point of the point and figure bar.
Public Property PFHigh | Returns the high
Public Property PFLow | Returns the low
Public Property Timestamp | Returns the timestamp, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
Public Property TimestampOffset | Returns the timestamp offset, which is used to identify various CQGPointAndFigureBar objects that have the same timestamp.
Public Property Up | Indicates whether this point and figure bar is up or not.

See Also

CQGPointAndFigureBar Interface


%%PageItemTitle%%

High Property
CQGPointAndFigureBar Interface : High Property

Glossary Item Box

Description

Returns the high of the point and figure bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property High As Double

Return Type

High, represented as Double

See Also

CQGPointAndFigureBar Interface | CQGPointAndFigureBar Members


%%PageItemTitle%%

Low Property
CQGPointAndFigureBar Interface : Low Property

Glossary Item Box

Description

Returns the low of the point and figure bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property Low As Double

Return Type

Low, represented as Double

See Also

CQGPointAndFigureBar Interface | CQGPointAndFigureBar Members


%%PageItemTitle%%

Mid Property
CQGPointAndFigureBar Interface : Mid Property

Glossary Item Box

Description

Returns the mid-point of the point and figure bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property Mid As Double

Return Type

Mid-point, represented as Double

See Also

CQGPointAndFigureBar Interface | CQGPointAndFigureBar Members


%%PageItemTitle%%

PFHigh Property
CQGPointAndFigureBar Interface : PFHigh Property

Glossary Item Box

Description

Returns the high

Property type

Read-only property

Syntax

Visual Basic
Public Property PFHigh As Double

See Also

CQGPointAndFigureBar Interface | CQGPointAndFigureBar Members


%%PageItemTitle%%

PFLow Property
CQGPointAndFigureBar Interface : PFLow Property

Glossary Item Box

Description

Returns the low

Property type

Read-only property

Syntax

Visual Basic
Public Property PFLow As Double

See Also

CQGPointAndFigureBar Interface | CQGPointAndFigureBar Members


%%PageItemTitle%%

Timestamp Property
CQGPointAndFigureBar Interface : Timestamp Property

Glossary Item Box

Description

Returns the timestamp, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

Property type

Read-only property

Syntax

Visual Basic
Public Property Timestamp As Date

Return Type

Timestamp, represented as Date

See Also

CQGPointAndFigureBar Interface | CQGPointAndFigureBar Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

TimestampOffset Property
CQGPointAndFigureBar Interface : TimestampOffset Property

Glossary Item Box

Description

Returns the timestamp offset, which is used to identify various CQGPointAndFigureBar objects that have the same timestamp.

Property type

Read-only property

Syntax

Visual Basic
Public Property TimestampOffset As Long

Return Type

Timestamp offset, represented as Long

Remarks

The TimestampOffset value grows for subsequent objects. It resets when the timestamp is changed.

See Also

CQGPointAndFigureBar Interface | CQGPointAndFigureBar Members


%%PageItemTitle%%

Up Property
CQGPointAndFigureBar Interface : Up Property

Glossary Item Box

Description

Indicates whether this point and figure bar is up or not.

Property type

Read-only property

Syntax

Visual Basic
Public Property Up As Boolean

Return Type

True, if this is an up point and figure bar; False, otherwise

See Also

CQGPointAndFigureBar Interface | CQGPointAndFigureBar Members


%%PageItemTitle%%

CQGPointAndFigureBarsRequest Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents parameters used to formulate a point and figure bars request.

Object Model

CQGPointAndFigureBarsRequest Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGPointAndFigureBarsRequest Members


%%PageItemTitle%% $$Members$$

CQGPointAndFigureBarsRequest Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property BoxSize | Sets/gets the box size, which will be used to formulate the point and figure bars request. The default value for this parameter is 3.
Public Property BoxUnits | Sets/gets the box units, which will be used to formulate the point and figure bars request.
Public Property Continuation | Sets/gets the continuation type, which will be used to formulate the point and figure bars request. The default value is tsctNoContinuation.
Public Property DataSource | Sets/gets the data source, which will be used to formulate the point and figure bars request.
Public Property DaysBeforeExpiration | Sets/gets the number of days prior to expiration, when the rollover will occur, to be used to formulate the point and figure bars request. The default value for this property is 0.
Public Property EqualizeCloses | Gets/sets the equalize closes flag, which will be used to formulate the point and figure bars request. The default value for this property is True.
Public Property IncludeEnd | Gets/sets the include end flag, which will be used to formulate the point and figure bars request. The default value for this property is False.
Public Property RangeEnd | Gets/sets the range end, which will be used to formulate the point and figure bars request (required).
Public Property RangeStart | Gets/sets the range start, which will be used to formulate the point and figure bars request (required).
Public Property RecalcPeriod | Sets/gets the recalculation period (in seconds), which will be used to formulate the point and figure bars request. The default value for this property is 60.
Public Property Reversal | Sets/gets the reversal, which will be used to formulate the point and figure bars request. The default value for this parameter is 3.
Public Property SessionFlags | Sets/gets the session flags, which will be used to formulate the point and figure bars request. The default value for this property is sfUndefined.
Public Property SessionsFilter | Sets/gets the sessions filter, which will be used to formulate the point and figure bars request. The default value for this property is 0.
Public Property SubscriptionLevel | Sets/gets the subscription level, which will be used to formulate the point and figure bars request. The default value for this property is tslEachBar.
Public Property Symbol | Sets/gets the symbol, which will be used to formulate the point and figure bars request (required).
Public Property UpdatesEnabled | Gets/sets the updates enabled flag, which will be used to formulate the point and figure bars request. The default value for this property is False.

See Also

CQGPointAndFigureBarsRequest Interface


%%PageItemTitle%%

BoxSize Property
CQGPointAndFigureBarsRequest Interface : BoxSize Property

Glossary Item Box

Description

Sets/gets the box size, which will be used to formulate the point and figure bars request.

The default value for this parameter is 3.

Property type

Read-write property

Syntax

Visual Basic
Public Property BoxSize As Long

Return Type

Box size, represented as Long

See Also

CQGPointAndFigureBarsRequest Interface | CQGPointAndFigureBarsRequest Members


%%PageItemTitle%%

BoxUnits Property
CQGPointAndFigureBarsRequest Interface : BoxUnits Property

Glossary Item Box

Description

Sets/gets the box units, which will be used to formulate the point and figure bars request.

Property type

Read-write property

Syntax

Visual Basic
Public Property BoxUnits As ePfBoxUnits

Return Type

Box units, represented as ePfBoxUnits

Remarks

See the ePfBoxUnits enumeration for possible values.

See Also

CQGPointAndFigureBarsRequest Interface | CQGPointAndFigureBarsRequest Members | ePfBoxUnits Enumeration


%%PageItemTitle%%

Continuation Property
CQGPointAndFigureBarsRequest Interface : Continuation Property

Glossary Item Box

Description

Sets/gets the continuation type, which will be used to formulate the point and figure bars request.

The default value is tsctNoContinuation.

Property type

Read-write property

Syntax

Visual Basic
Public Property Continuation As eTimeSeriesContinuationType

Return Type

Continuation type, represented as eTimeSeriesContinuationType

Remarks

See eTimeSeriesContinuationType enumeration for possible values.

See Also

CQGPointAndFigureBarsRequest Interface | CQGPointAndFigureBarsRequest Members | eTimeSeriesContinuationType Enumeration


%%PageItemTitle%%

DataSource Property
CQGPointAndFigureBarsRequest Interface : DataSource Property

Glossary Item Box

Description

Sets/gets the data source, which will be used to formulate the point and figure bars request.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataSource As ePfDataSource

Return Type

Data source, represented as ePfDataSource

Remarks

See the ePfDataSource enumeration for possible values.

See Also

CQGPointAndFigureBarsRequest Interface | CQGPointAndFigureBarsRequest Members | ePfDataSource Enumeration


%%PageItemTitle%%

DaysBeforeExpiration Property
CQGPointAndFigureBarsRequest Interface : DaysBeforeExpiration Property

Glossary Item Box

Description

Sets/gets the number of days prior to expiration, when the rollover will occur, to be used to formulate the point and figure bars request.

The default value for this property is 0.

Property type

Read-write property

Syntax

Visual Basic
Public Property DaysBeforeExpiration As Long

Return Type

Number of days prior to expiration, represented as Long

Remarks

This property is required and must have a positive value, when the Continuation property indicates an adjusted continuation.

If the continuation is not adjusted, this property has no effect.

See Also

CQGPointAndFigureBarsRequest Interface | CQGPointAndFigureBarsRequest Members | CQGPointAndFigureBarsRequest.Continuation Property


%%PageItemTitle%%

EqualizeCloses Property
CQGPointAndFigureBarsRequest Interface : EqualizeCloses Property

Glossary Item Box

Description

Gets/sets the equalize closes flag, which will be used to formulate the point and figure bars request.

The default value for this property is True.

Property type

Read-write property

Syntax

Visual Basic
Public Property EqualizeCloses As Boolean

Return Type

True (default), if closes should be equalized; False, otherwise

Remarks

This property has effect only when the Continuation property indicates an active or adjusted continuation.

See Also

CQGPointAndFigureBarsRequest Interface | CQGPointAndFigureBarsRequest Members | CQGPointAndFigureBarsRequest.Continuation Property


%%PageItemTitle%%

IncludeEnd Property
CQGPointAndFigureBarsRequest Interface : IncludeEnd Property

Glossary Item Box

Description

Gets/sets the include end flag, which will be used to formulate the point and figure bars request.

The default value for this property is False.

Property type

Read-write property

Syntax

Visual Basic
Public Property IncludeEnd As Boolean

Return Type

True, if end should be included; False (default), otherwise

Remarks

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGPointAndFigureBarsRequest Interface | CQGPointAndFigureBarsRequest Members


%%PageItemTitle%%

RangeEnd Property
CQGPointAndFigureBarsRequest Interface : RangeEnd Property

Glossary Item Box

Description

Gets/sets the range end, which will be used to formulate the point and figure bars request (required).

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeEnd As Variant

Remarks

Only Date and integer are allowed for types of RangeStart/RangeEnd properties.

  • If the type is Date, RangeStart/RangeEnd represent date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode). Non-timed bar requests process date/time range values with a precision of up to minutes.
  • All combinations of Date and integer can apply for these properties, except integer/Date.
  • If RangeEnd type is integer, then it represents the count of records prior to RangeStart to be requested, so it must be a negative value.
  • If RangeEnd is date, it must be further in time than RangeStart.

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGPointAndFigureBarsRequest Interface | CQGPointAndFigureBarsRequest Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

RangeStart Property
CQGPointAndFigureBarsRequest Interface : RangeStart Property

Glossary Item Box

Description

Gets/sets the range start, which will be used to formulate the point and figure bars request (required).

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeStart As Variant

Remarks

Only Date and integer are allowed for types of RangeStart/RangeEnd properties:

  • All combinations of Date and Integer can apply for these properties, except Integer/Date.
  • If type is Date, RangeStart represents date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode). Non-timed bar requests process date/time range values with a precision of up to minutes.
  • If type is Integer, RangeStart represents the current condition's result number (0 is the current condition result number, negative numbers represent condition results in the past, positive numbers - in the future).
  • If the type of RangeStart is integer, it shall be 0 (denoting "current").

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGPointAndFigureBarsRequest Interface | CQGPointAndFigureBarsRequest Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

RecalcPeriod Property
CQGPointAndFigureBarsRequest Interface : RecalcPeriod Property

Glossary Item Box

Description

Sets/gets the recalculation period (in seconds), which will be used to formulate the point and figure bars request.

The default value for this property is 60.

Property type

Read-write property

Syntax

Visual Basic
Public Property RecalcPeriod As Long

Return Type

Recalculation period in seconds, represented as Long

Remarks

Only positive values are allowed for this property.

See Also

CQGPointAndFigureBarsRequest Interface | CQGPointAndFigureBarsRequest Members


%%PageItemTitle%%

Reversal Property
CQGPointAndFigureBarsRequest Interface : Reversal Property

Glossary Item Box

Description

Sets/gets the reversal, which will be used to formulate the point and figure bars request.

The default value for this parameter is 3.

Property type

Read-write property

Syntax

Visual Basic
Public Property Reversal As Long

Return Type

Reversal, represented as Long

See Also

CQGPointAndFigureBarsRequest Interface | CQGPointAndFigureBarsRequest Members


%%PageItemTitle%%

SessionFlags Property
CQGPointAndFigureBarsRequest Interface : SessionFlags Property

Glossary Item Box

Description

Sets/gets the session flags, which will be used to formulate the point and figure bars request.

The default value for this property is sfUndefined.

Property type

Read-write property

Syntax

Visual Basic
Public Property SessionFlags As eSessionFlag

Return Type

Session flags, represented as eSessionFlag

Remarks

See the eSessionFlag enumeration for possible values.

See Also

CQGPointAndFigureBarsRequest Interface | CQGPointAndFigureBarsRequest Members | eSessionFlag Enumeration


%%PageItemTitle%%

SessionsFilter Property
CQGPointAndFigureBarsRequest Interface : SessionsFilter Property

Glossary Item Box

Description

Sets/gets the sessions filter, which will be used to formulate the point and figure bars request.

The default value for this property is 0.

Property type

Read-write property

Syntax

Visual Basic
Public Property SessionsFilter As Variant

Return Type

Sessions filter, represented as Variant

Remarks

Only String and integer are considered for SessionsFilter type.

  • If type is integer, SessionsFilter represents session number.
    Special values: 0 represents primary sessions only, 31 represents all sessions.
  • If type is String, SessionsFilter represents custom session name.
    Special values: "all" and "primaryOnly" are equivalent to 31 and 0, respectively.
  • If other types are used for SessionsFilter, SessionsFilter is ignored.

See Also

CQGPointAndFigureBarsRequest Interface | CQGPointAndFigureBarsRequest Members


%%PageItemTitle%%

SubscriptionLevel Property
CQGPointAndFigureBarsRequest Interface : SubscriptionLevel Property

Glossary Item Box

Description

Sets/gets the subscription level, which will be used to formulate the point and figure bars request.

The default value for this property is tslEachBar.

Property type

Read-write property

Syntax

Visual Basic
Public Property SubscriptionLevel As eTimeSeriesSubscriptionLevel

Return Type

Subscription level, represented as eTimeSeriesSubscriptionLevel

See Also

CQGPointAndFigureBarsRequest Interface | CQGPointAndFigureBarsRequest Members | eTimeSeriesSubscriptionLevel Enumeration


%%PageItemTitle%%

Symbol Property
CQGPointAndFigureBarsRequest Interface : Symbol Property

Glossary Item Box

Description

Sets/gets the symbol, which will be used to formulate the point and figure bars request (required).

Property type

Read-write property

Syntax

Visual Basic
Public Property Symbol As String

Return Type

Symbol, represented as String

Remarks

This property value cannot be an empty string.

e.g. "EP"

See Also

CQGPointAndFigureBarsRequest Interface | CQGPointAndFigureBarsRequest Members


%%PageItemTitle%%

UpdatesEnabled Property
CQGPointAndFigureBarsRequest Interface : UpdatesEnabled Property

Glossary Item Box

Description

Gets/sets the updates enabled flag, which will be used to formulate the point and figure bars request.

The default value for this property is False.

Property type

Read-write property

Syntax

Visual Basic
Public Property UpdatesEnabled As Boolean

Return Type

True, if the updates are enabled; False (default), otherwise

See Also

CQGPointAndFigureBarsRequest Interface | CQGPointAndFigureBarsRequest Members


%%PageItemTitle%%

CQGPosition Interface
See Also Members Send Feedback

Glossary Item Box

Description

The CQGPosition interface encapsulates all the information on a position.

Object Model

CQGPosition InterfaceCQGAccount InterfaceCQGInstrument InterfaceCQGTrades CollectionCQGTrade InterfaceCQGTrades CollectionCQGTrade Interface

Remarks

The properties of CQGPosition interface which are calculated on the fly are available only when position's instrument is subscribed.

Example

See the usage of CQGPosition properties in the AccountChanged event's example section.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGPosition Members


%%PageItemTitle%% $$Members$$

CQGPosition Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Account | Returns the corresponding CQGAccount object.
Public Property AveragePrice | Returns the average price of position's open trades.
Public Property Instrument | Returns a CQGInstrument object representing the instrument on which the current position is created.
Public Property InstrumentName | Returns the full name of the instrument on which the current position is created.
Public Property ManualFillsInvolved | Returns the flag that indicates whether the manual fills are involved in position calculation or not.
Public Property MatchedTrades | Returns the collection of currently matched trades. The availability of position matched trades information is controlled by PositionDetailing setting of CQG API Configuration.
Public Property MVO | Returns the Market Value Option, calculated for the current position if its instrument is an option.
Public Property OpenTrades | Returns the collection of currently open trades. The availability of position open trades information is controlled by PositionDetailing setting of CQG API Configuration.
Public Property OTE | Returns the Open Trade Equity, calculated for the current position if its instrument is a future.
Public Property PositionDay | Current/Previous day position for instruments with explicit position tracking type
Public Property ProfitLoss | Returns the position's profit/loss since the start of the business day.
Public Property Quantity | Returns the position's quantity, i.e. the sum of position's open trades' quantities.
Public Property QuantityFractional | Gets position open fractional quantity, signed(positive for long position, negative for short position)
Public Property ServerTimestamp | Returns the server timestamp of the last position update (converted to the user-configured time zone).
Public Property Side | Returns the position's side, basing on its open trades.
Public Property Timestamp | Returns the last response reception timestamp. When a property is updated, CQG API records the information reception time in the Timestamp property (using local time).
Public Property TrackingType | Postion tracking type
Public Property UPL | Unrealized Profit Loss (options only, zero for futures)

See Also

CQGPosition Interface


%%PageItemTitle%%

Account Property
CQGPosition Interface : Account Property

Glossary Item Box

Description

Returns the corresponding CQGAccount object.

Property type

Read-only property

Syntax

Visual Basic
Public Property Account As CQGAccount

Return Type

CQGAccount object to which this CQGPosition belongs

Remarks

This property will be convenient for those who are familiar with the VBA specific Parent option.

Example

See the usage of CQGPosition properties in the AccountChanged event's example section.

See Also

CQGPosition Interface | CQGPosition Members


%%PageItemTitle%%

AveragePrice Property
CQGPosition Interface : AveragePrice Property

Glossary Item Box

Description

Returns the average price of position's open trades.

Property type

Read-only property

Syntax

Visual Basic
Public Property AveragePrice As Double

Return Type

The average price represented as Double

Example

See the usage of CQGPosition properties in the AccountChanged event's example section.

See Also

CQGPosition Interface | CQGPosition Members


%%PageItemTitle%%

Instrument Property
CQGPosition Interface : Instrument Property

Glossary Item Box

Description

Returns a CQGInstrument object representing the instrument on which the current position is created.

Property type

Read-only property

Syntax

Visual Basic
Public Property Instrument As CQGInstrument

Return Type

The instrument represented as CQGInstrument.

Nothing if the instrument is not subscribed.

Remarks

After instrument subscription a CQGInstrument object will be available both from this property and from CQGCEL.Instruments collection. Note that if you remove it from the collection it won't be available from this property any more. It will affect the calculations of the position's dynamic properties and the summary of corresponding account.

Example

See the usage of Instrument property in the AccountChanged event's example section.

See Also

CQGPosition Interface | CQGPosition Members


%%PageItemTitle%%

InstrumentName Property
CQGPosition Interface : InstrumentName Property

Glossary Item Box

Description

Returns the full name of the instrument on which the current position is created.

Property type

Read-only property

Syntax

Visual Basic
Public Property InstrumentName As String

Return Type

Instrument's full name represented as String

Example

See the usage of CQGPosition properties in the AccountChanged event's example section.

See Also

CQGPosition Interface | CQGPosition Members


%%PageItemTitle%%

ManualFillsInvolved Property
CQGPosition Interface : ManualFillsInvolved Property

Glossary Item Box

Description

Returns the flag that indicates whether the manual fills are involved in position calculation or not.

Property type

Read-only property

Syntax

Visual Basic
Public Property ManualFillsInvolved As Boolean

Return Type

True, if manual fills are involved; False otherwise

See Also

CQGPosition Interface | CQGPosition Members


%%PageItemTitle%%

MatchedTrades Property
CQGPosition Interface : MatchedTrades Property

Glossary Item Box

Description

Returns the collection of currently matched trades.

The availability of position matched trades information is controlled by PositionDetailing setting of CQG API Configuration.

Property type

Read-only property

Syntax

Visual Basic
Public Property MatchedTrades As CQGTrades

Return Type

CQGTrades collection containing position's matched trades.

Nothing, if this information is not available.

Remarks

Position's trades are considered matched if the sum of their signed quantities is 0.

The trades which are matched together have equal GroupID property.

Note: Matched trades are kept in this collection until the end of the trading day. Upon the start of new trading day position does not have any matched trade.

Example

See the usage of CQGPosition properties in the AccountChanged event's example section.

See Also

CQGPosition Interface | CQGPosition Members


%%PageItemTitle%%

MVO Property
CQGPosition Interface : MVO Property

Glossary Item Box

Description

Returns the Market Value Option, calculated for the current position if its instrument is an option.

Property type

Read-only property

Syntax

Visual Basic
Public Property MVO As Double

Return Type

MVO represented as Double if the instrument is an option, 0 otherwise

Remarks

The value is calculated on the fly, basing on the values of current quotes of the position's instrument and prices/quantities of position's open trades.

Note: If the instrument is not subscribed, this property returns invalid value.

Example

See the usage of MVO property in the AccountChanged event's example section.

See Also

CQGPosition Interface | CQGPosition Members


%%PageItemTitle%%

OpenTrades Property
CQGPosition Interface : OpenTrades Property

Glossary Item Box

Description

Returns the collection of currently open trades.

The availability of position open trades information is controlled by PositionDetailing setting of CQG API Configuration.

Property type

Read-only property

Syntax

Visual Basic
Public Property OpenTrades As CQGTrades

Return Type

CQGTrades collection containing position's open trades.

Nothing, if this information is not available.

Remarks

The sum of position's open trades' quantities gives the position's quantity.

The GroupID property of an open trade is 0.

Example

See the usage of CQGPosition properties in the AccountChanged event's example section.

See Also

CQGPosition Interface | CQGPosition Members


%%PageItemTitle%%

OTE Property
CQGPosition Interface : OTE Property

Glossary Item Box

Description

Returns the Open Trade Equity, calculated for the current position if its instrument is a future.

Property type

Read-only property

Syntax

Visual Basic
Public Property OTE As Double

Return Type

OTE represented as Double if the instrument is a future, 0 otherwise.

Remarks

The value is calculated on the fly, basing on the values of current quotes of the position's instrument and prices/quantities of position's open trades.

Note: If the instrument is not subscribed, this property returns invalid value.

Example

See the usage of OTE property in the AccountChanged event's example section.

See Also

CQGPosition Interface | CQGPosition Members


%%PageItemTitle%%

PositionDay Property
CQGPosition Interface : PositionDay Property

Glossary Item Box

Description

Current/Previous day position for instruments with explicit position tracking type

Property type

Read-only property

Syntax

Visual Basic
Public Property PositionDay As EPositionDay

See Also

CQGPosition Interface | CQGPosition Members


%%PageItemTitle%%

ProfitLoss Property
CQGPosition Interface : ProfitLoss Property

Glossary Item Box

Description

Returns the position's profit/loss since the start of the business day.

Property type

Read-only property

Syntax

Visual Basic
Public Property ProfitLoss As Double

Return Type

Profit/Loss represented as Double

Example

See the usage of CQGPosition properties in the AccountChanged event's example section.

See Also

CQGPosition Interface | CQGPosition Members


%%PageItemTitle%%

Quantity Property
CQGPosition Interface : Quantity Property

Glossary Item Box

Description

Returns the position's quantity, i.e. the sum of position's open trades' quantities.

Property type

Read-only property

Syntax

Visual Basic
Public Property Quantity As Long

Return Type

The quantity represented as Long.

Depending on UseOrderSide setting of CQG API Configuration the quantity can be signed or unsigned.

Remarks

If UseOrderSide is set to True, the quantity is always positive and the position's side is shown by position's Side property.

If UseOrderSide is set to False, the quantity is positive in case of long position and negative in case of short one.

Note: If the position is liquidated, its Quantity becomes = 0. The actual CQGPosition object is not removed from the collection until the end of the trading day, when all re-calculations are taking place.

Example

See the usage of CQGPosition properties in the AccountChanged event's example section.

See Also

CQGPosition Interface | CQGPosition Members


%%PageItemTitle%%

QuantityFractional Property
CQGPosition Interface : QuantityFractional Property

Glossary Item Box

Description

Gets position open fractional quantity, signed(positive for long position, negative for short position)

Property type

Read-only property

Syntax

Visual Basic
Public Property QuantityFractional As Decimal

See Also

CQGPosition Interface | CQGPosition Members


%%PageItemTitle%%

ServerTimestamp Property
CQGPosition Interface : ServerTimestamp Property

Glossary Item Box

Description

Returns the server timestamp of the last position update (converted to the user-configured time zone).

Property type

Read-only property

Syntax

Visual Basic
Public Property ServerTimestamp As Date

Return Type

Date variable containing the server timestamp

Remarks

The timestamp is converted to the timezone, previously configured by the user.

If no timezone configuration was made the timestamp is converted to UTC.

Example

See the usage of CQGPosition properties in the AccountChanged event's example section.

See Also

CQGPosition Interface | CQGPosition Members


%%PageItemTitle%%

Side Property
CQGPosition Interface : Side Property

Glossary Item Box

Description

Returns the position's side, basing on its open trades.

Property type

Read-only property

Syntax

Visual Basic
Public Property Side As eOrderSide

Return Type

The position's side represented as eOrderSide.

Depending on UseOrderSide setting of CQG API Configuration the side can be undefined.

Remarks

If UseOrderSide is set to True, the property value is osdBuy in case of long position and osdSell in case of short one.

If UseOrderSide is set to False, the property value is osdUndefined and the side is reflected by position's quantity sign.

Example

See the usage of CQGPosition properties in the AccountChanged event's example section.

See Also

CQGPosition Interface | CQGPosition Members


%%PageItemTitle%%

Timestamp Property
CQGPosition Interface : Timestamp Property

Glossary Item Box

Description

Returns the last response reception timestamp.

When a property is updated, CQG API records the information reception time in the Timestamp property (using local time).

Property type

Read-only property

Syntax

Visual Basic
Public Property Timestamp As Date

Return Type

Date variable containing the local timestamp

Remarks

The timestamp is converted to the timezone previously configured by user.

If no timezone configuration was made, the timestamp is converted to UTC.

Example

See the usage of CQGPosition properties in the AccountChanged event's example section.

See Also

CQGPosition Interface | CQGPosition Members


%%PageItemTitle%%

TrackingType Property
CQGPosition Interface : TrackingType Property

Glossary Item Box

Description

Postion tracking type

Property type

Read-only property

Syntax

Visual Basic
Public Property TrackingType As EPositionTrackingType

See Also

CQGPosition Interface | CQGPosition Members


%%PageItemTitle%%

UPL Property
CQGPosition Interface : UPL Property

Glossary Item Box

Description

Unrealized Profit Loss (options only, zero for futures)

Property type

Read-only property

Syntax

Visual Basic
Public Property UPL As Double

See Also

CQGPosition Interface | CQGPosition Members


%%PageItemTitle%%

CQGPositionsStatement Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a class for managing positions statement.

Object Model

CQGPositionsStatement InterfaceCQGPositions CollectionCQGPosition Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGPositionsStatement Members


%%PageItemTitle%% $$Members$$

CQGPositionsStatement Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property GWAccountID | Returns the account's gateway ID, for which the positions statement is requested.
Public Property Positions | Returns the collection of account's positions.
Public Property StatementDate | Returns the date, for which the positions statement is requested.

See Also

CQGPositionsStatement Interface


%%PageItemTitle%%

GWAccountID Property
CQGPositionsStatement Interface : GWAccountID Property

Glossary Item Box

Description

Returns the account's gateway ID, for which the positions statement is requested.

Property type

Read-only property

Syntax

Visual Basic
Public Property GWAccountID As Long

Return Type

Gateway ID, represented as Long

See Also

CQGPositionsStatement Interface | CQGPositionsStatement Members


%%PageItemTitle%%

Positions Property
CQGPositionsStatement Interface : Positions Property

Glossary Item Box

Description

Returns the collection of account's positions.

Property type

Read-only property

Syntax

Visual Basic
Public Property Positions As CQGPositions

Return Type

Colleciton of positions, represented as CQGPositions

See Also

CQGPositionsStatement Interface | CQGPositionsStatement Members | CQGPositions Collection


%%PageItemTitle%%

StatementDate Property
CQGPositionsStatement Interface : StatementDate Property

Glossary Item Box

Description

Returns the date, for which the positions statement is requested.

Property type

Read-only property

Syntax

Visual Basic
Public Property StatementDate As Date

Return Type

Statement date, represented as Date

See Also

CQGPositionsStatement Interface | CQGPositionsStatement Members


%%PageItemTitle%%

CQGQFormulaDefinition Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a definition of QFormula.

Object Model

CQGQFormulaDefinition Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGQFormulaDefinition Members


%%PageItemTitle%% $$Members$$

CQGQFormulaDefinition Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property ExecutionPattern | Returns the QFormula execution pattern.
Public Property Expression | Returns the QFormula expression.
Public Property Name | Returns the QFormula name.
Public Property Number | Returns the QFormula number.

See Also

CQGQFormulaDefinition Interface


%%PageItemTitle%%

ExecutionPattern Property
CQGQFormulaDefinition Interface : ExecutionPattern Property

Glossary Item Box

Description

Returns the QFormula execution pattern.

Property type

Read-only property

Syntax

Visual Basic
Public Property ExecutionPattern As String

Return Type

QFormula execution pattern, represented as String

See Also

CQGQFormulaDefinition Interface | CQGQFormulaDefinition Members


%%PageItemTitle%%

Expression Property
CQGQFormulaDefinition Interface : Expression Property

Glossary Item Box

Description

Returns the QFormula expression.

Property type

Read-only property

Syntax

Visual Basic
Public Property Expression As String

Return Type

QFormula expression, represented as String

See Also

CQGQFormulaDefinition Interface | CQGQFormulaDefinition Members


%%PageItemTitle%%

Name Property
CQGQFormulaDefinition Interface : Name Property

Glossary Item Box

Description

Returns the QFormula name.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

Return Type

QFormula name, represented as String

See Also

CQGQFormulaDefinition Interface | CQGQFormulaDefinition Members


%%PageItemTitle%%

Number Property
CQGQFormulaDefinition Interface : Number Property

Glossary Item Box

Description

Returns the QFormula number.

Property type

Read-only property

Syntax

Visual Basic
Public Property Number As Long

Return Type

QFormula number, represented as Long

See Also

CQGQFormulaDefinition Interface | CQGQFormulaDefinition Members


%%PageItemTitle%%

CQGQuote Interface
See Also Members Send Feedback

Glossary Item Box

Description

This class allows the user to manage instrument quotes.

Object Model

CQGQuote InterfaceCQGInstrument InterfaceCQGDOMOrders CollectionCQGDOMOrder Object

Example

See an example of InstrumentChanged Event.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGQuote Members


%%PageItemTitle%% $$Members$$

CQGQuote Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property HasVolume | Indicates whether the quote has volume information or not.
Public Property Instrument | Returns the corresponding instrument.
Public Property IsValid | Indicates if the quote value is valid and/or available.
Public Property Name | Returns the name of the instrument quote object.
Public Property OrdersQueue | Orders that make the quote volume. Unavailable in case of eDetailedDOMMode.eddmNone
Public Property Price | Returns quote price.
Public Property Reserved9 | Reserved method
Public Property ServerTimestamp | Returns the server timestamp of the last change.
Public Property Timestamp | Returns the last response reception timestamp. When a property is updated, CQG API records the information reception time in the Timestamp property (using local time).
Public Property Type | Returns the type of instrument quote.
Public Property Volume | Returns the corresponding volume of the instrument quote.
Public Property VolumeFractional | Returns quote fractional volume (can be 0 for some quotes)

See Also

CQGQuote Interface


%%PageItemTitle%%

HasVolume Property
CQGQuote Interface : HasVolume Property

Glossary Item Box

Description

Indicates whether the quote has volume information or not.

Property type

Read-only property

Syntax

Visual Basic
Public Property HasVolume As Boolean

Return Type

True if the quote has volume, False otherwise

See Also

CQGQuote Interface | CQGQuote Members


%%PageItemTitle%%

Instrument Property
CQGQuote Interface : Instrument Property

Glossary Item Box

Description

Returns the corresponding instrument.

Property type

Read-only property

Syntax

Visual Basic
Public Property Instrument As CQGInstrument

Return Type

CQGInstrument object to which this Instrument quote belongs

Remarks

This property will be convenient for those who are familiar with the VBA specific Parent option.

Example

To access the CQGInstrumentQuote object properties, see the example section of the InstrumentChanged Event.

See Also

CQGQuote Interface | CQGQuote Members


%%PageItemTitle%%

IsValid Property
CQGQuote Interface : IsValid Property

Glossary Item Box

Description

Indicates if the quote value is valid and/or available.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsValid As Boolean

Return Type

True if the quote is valid, False - otherwise.

Remarks

If the subscription level of the instrument is set to dsQuotes, then the IsValid property of Ask and Bid quotes will be False in the InstrumentChanged Event parameters.

Example

For access to CQGInstrumentQuote object properties see example section of InstrumentChanged Event.

See Also

CQGQuote Interface | CQGQuote Members


%%PageItemTitle%%

Name Property
CQGQuote Interface : Name Property

Glossary Item Box

Description

Returns the name of the instrument quote object.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

Return Type

Quote name string.

Remarks

Instrument Quote name is the display version of eQuoteType Enumeration members, i.e. each name corresponds to one of the enumeration members.

Example

To access the CQGInstrumentQuote object properties, see the example section of the InstrumentChanged Event.

See Also

CQGQuote Interface | CQGQuote Members


%%PageItemTitle%%

OrdersQueue Property
CQGQuote Interface : OrdersQueue Property

Glossary Item Box

Description

Orders that make the quote volume. Unavailable in case of eDetailedDOMMode.eddmNone

Property type

Read-only property

Syntax

Visual Basic
Public Property OrdersQueue As CQGDOMOrders

See Also

CQGQuote Interface | CQGQuote Members


%%PageItemTitle%%

Price Property
CQGQuote Interface : Price Property

Glossary Item Box

Description

Returns quote price.

Property type

Read-only property

Syntax

Visual Basic
Public Property Price As Double

Return Type

Quote price represented as Double.

Remarks

If the quote is not valid (see IsValid Property), then this property has no value assigned.

Example

To access the CQGInstrumentQuote object properties, see the example section of the InstrumentChanged Event.

See Also

CQGQuote Interface | CQGQuote Members


%%PageItemTitle%%

Reserved9 Property
CQGQuote Interface : Reserved9 Property

Glossary Item Box

Description

Reserved method

Property type

Read-only property

Syntax

Visual Basic
Public Property Reserved9 As Boolean

See Also

CQGQuote Interface | CQGQuote Members


%%PageItemTitle%%

ServerTimestamp Property
CQGQuote Interface : ServerTimestamp Property

Glossary Item Box

Description

Returns the server timestamp of the last change.

Property type

Read-only property

Syntax

Visual Basic
Public Property ServerTimestamp As Date

Return Type

Date variable containing the server timestamp of the last quote change.

Remarks

Server timestamp is converted to the timezone previously configured by user. If user did not configure the timezone the timestamp is converted to UTC.

Example

To access the CQGInstrumentQuote object properties, see the example section of the InstrumentChanged Event.

See Also

CQGQuote Interface | CQGQuote Members | CQGCEL.ServerTimestamp Property | CQGCELConfiguration UDT


%%PageItemTitle%%

Timestamp Property
CQGQuote Interface : Timestamp Property

Glossary Item Box

Description

Returns the last response reception timestamp.

When a property is updated, CQG API records the information reception time in the Timestamp property (using local time).

Property type

Read-only property

Syntax

Visual Basic
Public Property Timestamp As Date

Return Type

Date variable containing the local PC timestamp of the last quote change.

Remarks

Local timestamp is converted to the timezone previously configured by the user. If the user did not configure any timezone the timestamp is converted to UTC.

Example

To access the CQGInstrumentQuote object properties, see the example section of the InstrumentChanged Event.

See Also

CQGQuote Interface | CQGQuote Members | CQGCELConfiguration UDT | CQGInstrument.Timestamp Property


%%PageItemTitle%%

Type Property
CQGQuote Interface : Type Property

Glossary Item Box

Description

Returns the type of instrument quote.

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As eQuoteType

Return Type

Type of the quote represented as eQuoteType Enumeration.

Example

To access the CQGInstrumentQuote object properties, see the example section of the InstrumentChanged Event.

See Also

CQGQuote Interface | CQGQuote Members


%%PageItemTitle%%

Volume Property
CQGQuote Interface : Volume Property

Glossary Item Box

Description

Returns the corresponding volume of the instrument quote.

Property type

Read-only property

Syntax

Visual Basic
Public Property Volume As Long

Return Type

Volume represented as Long.

Example

To access the CQGInstrumentQuote object properties, see the example section of the InstrumentChanged Event.

See Also

CQGQuote Interface | CQGQuote Members


%%PageItemTitle%%

VolumeFractional Property
CQGQuote Interface : VolumeFractional Property

Glossary Item Box

Description

Returns quote fractional volume (can be 0 for some quotes)

Property type

Read-only property

Syntax

Visual Basic
Public Property VolumeFractional As Decimal

See Also

CQGQuote Interface | CQGQuote Members


%%PageItemTitle%%

CQGRangeBar Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents class for a range bar

Object Model

CQGRangeBar Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGRangeBar Members


%%PageItemTitle%% $$Members$$

CQGRangeBar Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property ActualVolume | Returns the actual volume
Public Property ActualVolumeFractional | Returns the actual fractional volume
Public Property Avg | Returns the average
Public Property Close | Returns real close
Public Property High | Returns real high
Public Property HLC3 | Returns the (High+Low+Close)/3
Public Property Low | Returns real low
Public Property Mid | Returns the mid-point
Public Property Open | Returns real open
Public Property Range | Returns the range
Public Property TickVolume | Returns the tick volume
Public Property Timestamp | Returns the timestamp
Public Property TimestampOffset | Returns the offset in the timestamp
Public Property TrueHigh | Returns the true high
Public Property TrueLow | Returns the true low
Public Property TrueRange | Returns the true range

See Also

CQGRangeBar Interface


%%PageItemTitle%%

ActualVolume Property
CQGRangeBar Interface : ActualVolume Property

Glossary Item Box

Description

Returns the actual volume

Property type

Read-only property

Syntax

Visual Basic
Public Property ActualVolume As Long

See Also

CQGRangeBar Interface | CQGRangeBar Members


%%PageItemTitle%%

ActualVolumeFractional Property
CQGRangeBar Interface : ActualVolumeFractional Property

Glossary Item Box

Description

Returns the actual fractional volume

Property type

Read-only property

Syntax

Visual Basic
Public Property ActualVolumeFractional As Double

See Also

CQGRangeBar Interface | CQGRangeBar Members


%%PageItemTitle%%

Avg Property
CQGRangeBar Interface : Avg Property

Glossary Item Box

Description

Returns the average

Property type

Read-only property

Syntax

Visual Basic
Public Property Avg As Double

See Also

CQGRangeBar Interface | CQGRangeBar Members


%%PageItemTitle%%

Close Property
CQGRangeBar Interface : Close Property

Glossary Item Box

Description

Returns real close

Property type

Read-only property

Syntax

Visual Basic
Public Property Close As Double

See Also

CQGRangeBar Interface | CQGRangeBar Members


%%PageItemTitle%%

High Property
CQGRangeBar Interface : High Property

Glossary Item Box

Description

Returns real high

Property type

Read-only property

Syntax

Visual Basic
Public Property High As Double

See Also

CQGRangeBar Interface | CQGRangeBar Members


%%PageItemTitle%%

HLC3 Property
CQGRangeBar Interface : HLC3 Property

Glossary Item Box

Description

Returns the (High+Low+Close)/3

Property type

Read-only property

Syntax

Visual Basic
Public Property HLC3 As Double

See Also

CQGRangeBar Interface | CQGRangeBar Members


%%PageItemTitle%%

Low Property
CQGRangeBar Interface : Low Property

Glossary Item Box

Description

Returns real low

Property type

Read-only property

Syntax

Visual Basic
Public Property Low As Double

See Also

CQGRangeBar Interface | CQGRangeBar Members


%%PageItemTitle%%

Mid Property
CQGRangeBar Interface : Mid Property

Glossary Item Box

Description

Returns the mid-point

Property type

Read-only property

Syntax

Visual Basic
Public Property Mid As Double

See Also

CQGRangeBar Interface | CQGRangeBar Members


%%PageItemTitle%%

Open Property
CQGRangeBar Interface : Open Property

Glossary Item Box

Description

Returns real open

Property type

Read-only property

Syntax

Visual Basic
Public Property Open As Double

See Also

CQGRangeBar Interface | CQGRangeBar Members


%%PageItemTitle%%

Range Property
CQGRangeBar Interface : Range Property

Glossary Item Box

Description

Returns the range

Property type

Read-only property

Syntax

Visual Basic
Public Property Range As Double

See Also

CQGRangeBar Interface | CQGRangeBar Members


%%PageItemTitle%%

TickVolume Property
CQGRangeBar Interface : TickVolume Property

Glossary Item Box

Description

Returns the tick volume

Property type

Read-only property

Syntax

Visual Basic
Public Property TickVolume As Long

See Also

CQGRangeBar Interface | CQGRangeBar Members


%%PageItemTitle%%

Timestamp Property
CQGRangeBar Interface : Timestamp Property

Glossary Item Box

Description

Returns the timestamp

Property type

Read-only property

Syntax

Visual Basic
Public Property Timestamp As Date

See Also

CQGRangeBar Interface | CQGRangeBar Members


%%PageItemTitle%%

TimestampOffset Property
CQGRangeBar Interface : TimestampOffset Property

Glossary Item Box

Description

Returns the offset in the timestamp

Property type

Read-only property

Syntax

Visual Basic
Public Property TimestampOffset As Long

See Also

CQGRangeBar Interface | CQGRangeBar Members


%%PageItemTitle%%

TrueHigh Property
CQGRangeBar Interface : TrueHigh Property

Glossary Item Box

Description

Returns the true high

Property type

Read-only property

Syntax

Visual Basic
Public Property TrueHigh As Double

See Also

CQGRangeBar Interface | CQGRangeBar Members


%%PageItemTitle%%

TrueLow Property
CQGRangeBar Interface : TrueLow Property

Glossary Item Box

Description

Returns the true low

Property type

Read-only property

Syntax

Visual Basic
Public Property TrueLow As Double

See Also

CQGRangeBar Interface | CQGRangeBar Members


%%PageItemTitle%%

TrueRange Property
CQGRangeBar Interface : TrueRange Property

Glossary Item Box

Description

Returns the true range

Property type

Read-only property

Syntax

Visual Basic
Public Property TrueRange As Double

See Also

CQGRangeBar Interface | CQGRangeBar Members


%%PageItemTitle%%

CQGRangeBarsRequest Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents parameters for range bars request

Object Model

CQGRangeBarsRequest Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGRangeBarsRequest Members


%%PageItemTitle%% $$Members$$

CQGRangeBarsRequest Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Continuation | Sets the continuation type which will be used in range bar request
Public Property DaysBeforeExpiration | Sets the number of days prior to expiration the rollover will occur to be used in range bar request
Public Property EqualizeCloses | Sets the equalize closes flag which will be used in range bar request
Public Property IncludeEnd | Sets the include end flag which will be used in range bar request
Public Property MaxNullBars | The property is obsolete.
Public Property Range | Sets range which will be used in range bar request
Public Property RangeEnd | Sets the range end which will be used in range bar request (required)
Public Property RangeStart | Sets the range start which will be used in range bar request (required)
Public Property RangeUnit | Sets range unit (required)
Public Property RecalcPeriod | Sets the recalculation period which will be used in range bar request
Public Property SessionFlags | Sets the session flags which will be used in range bar request
Public Property SessionsFilter | Sets the sessions filter which will be used in range bar request
Public Property StartPoint | The start point for the calculation of the bars. Defaults to EStartPoint.spSession.
Public Property SubscriptionLevel | Sets the subscription level which will be used in range bar request
Public Property Symbol | Sets the symbol which will be used in range bar request (required)
Public Property TickFilter | Sets the tick filter which will be used in range bar request
Public Property UpdatesEnabled | Sets the updates enabled flag which will be used in range bar request

See Also

CQGRangeBarsRequest Interface


%%PageItemTitle%%

Continuation Property
CQGRangeBarsRequest Interface : Continuation Property

Glossary Item Box

Description

Sets the continuation type which will be used in range bar request

Property type

Read-write property

Syntax

Visual Basic
Public Property Continuation As eTimeSeriesContinuationType

See Also

CQGRangeBarsRequest Interface | CQGRangeBarsRequest Members


%%PageItemTitle%%

DaysBeforeExpiration Property
CQGRangeBarsRequest Interface : DaysBeforeExpiration Property

Glossary Item Box

Description

Sets the number of days prior to expiration the rollover will occur to be used in range bar request

Property type

Read-write property

Syntax

Visual Basic
Public Property DaysBeforeExpiration As Long

See Also

CQGRangeBarsRequest Interface | CQGRangeBarsRequest Members


%%PageItemTitle%%

EqualizeCloses Property
CQGRangeBarsRequest Interface : EqualizeCloses Property

Glossary Item Box

Description

Sets the equalize closes flag which will be used in range bar request

Property type

Read-write property

Syntax

Visual Basic
Public Property EqualizeCloses As Boolean

See Also

CQGRangeBarsRequest Interface | CQGRangeBarsRequest Members


%%PageItemTitle%%

IncludeEnd Property
CQGRangeBarsRequest Interface : IncludeEnd Property

Glossary Item Box

Description

Sets the include end flag which will be used in range bar request

Property type

Read-write property

Syntax

Visual Basic
Public Property IncludeEnd As Boolean

Remarks

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGRangeBarsRequest Interface | CQGRangeBarsRequest Members


%%PageItemTitle%%

MaxNullBars Property
CQGRangeBarsRequest Interface : MaxNullBars Property

Glossary Item Box

Description

The property is obsolete.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxNullBars As Long

See Also

CQGRangeBarsRequest Interface | CQGRangeBarsRequest Members


%%PageItemTitle%%

Range Property
CQGRangeBarsRequest Interface : Range Property

Glossary Item Box

Description

Sets range which will be used in range bar request

Property type

Read-write property

Syntax

Visual Basic
Public Property Range As Long

See Also

CQGRangeBarsRequest Interface | CQGRangeBarsRequest Members


%%PageItemTitle%%

RangeEnd Property
CQGRangeBarsRequest Interface : RangeEnd Property

Glossary Item Box

Description

Sets the range end which will be used in range bar request (required)

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeEnd As Variant

Remarks

Only Date and integer are allowed for types of RangeStart/RangeEnd properties.

  • If the type is Date, RangeStart/RangeEnd represent date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode). Non-timed bar requests process date/time range values with a precision of up to minutes.
  • All combinations of Date and integer can apply for these properties, except integer/Date.
  • If RangeEnd type is integer, then it represents the count of records prior to RangeStart to be requested, so it must be a negative value.
  • If RangeEnd is date, it must be further in time than RangeStart.

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGRangeBarsRequest Interface | CQGRangeBarsRequest Members


%%PageItemTitle%%

RangeStart Property
CQGRangeBarsRequest Interface : RangeStart Property

Glossary Item Box

Description

Sets the range start which will be used in range bar request (required)

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeStart As Variant

Remarks

Only Date and integer are allowed for types of RangeStart/RangeEnd properties:

  • All combinations of Date and Integer can apply for these properties, except Integer/Date.
  • If type is Date, RangeStart represents date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode). Non-timed bar requests process date/time range values with a precision of up to minutes.
  • If type is Integer, RangeStart represents the current condition's result number (0 is the current condition result number, negative numbers represent condition results in the past, positive numbers - in the future).
  • If the type of RangeStart is integer, it shall be 0 (denoting "current").

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGRangeBarsRequest Interface | CQGRangeBarsRequest Members


%%PageItemTitle%%

RangeUnit Property
CQGRangeBarsRequest Interface : RangeUnit Property

Glossary Item Box

Description

Sets range unit (required)

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeUnit As eRangeUnit

See Also

CQGRangeBarsRequest Interface | CQGRangeBarsRequest Members


%%PageItemTitle%%

RecalcPeriod Property
CQGRangeBarsRequest Interface : RecalcPeriod Property

Glossary Item Box

Description

Sets the recalculation period which will be used in range bar request

Property type

Read-write property

Syntax

Visual Basic
Public Property RecalcPeriod As Long

See Also

CQGRangeBarsRequest Interface | CQGRangeBarsRequest Members


%%PageItemTitle%%

SessionFlags Property
CQGRangeBarsRequest Interface : SessionFlags Property

Glossary Item Box

Description

Sets the session flags which will be used in range bar request

Property type

Read-write property

Syntax

Visual Basic
Public Property SessionFlags As eSessionFlag

See Also

CQGRangeBarsRequest Interface | CQGRangeBarsRequest Members


%%PageItemTitle%%

SessionsFilter Property
CQGRangeBarsRequest Interface : SessionsFilter Property

Glossary Item Box

Description

Sets the sessions filter which will be used in range bar request

Property type

Read-write property

Syntax

Visual Basic
Public Property SessionsFilter As Variant

See Also

CQGRangeBarsRequest Interface | CQGRangeBarsRequest Members


%%PageItemTitle%%

StartPoint Property
CQGRangeBarsRequest Interface : StartPoint Property

Glossary Item Box

Description

The start point for the calculation of the bars. Defaults to EStartPoint.spSession.

Property type

Read-write property

Syntax

Visual Basic
Public Property StartPoint As EStartPoint

Remarks

Corresponds to the "Start Point" parameter for the Range Bars chart in CQG IC.

See Also

CQGRangeBarsRequest Interface | CQGRangeBarsRequest Members


%%PageItemTitle%%

SubscriptionLevel Property
CQGRangeBarsRequest Interface : SubscriptionLevel Property

Glossary Item Box

Description

Sets the subscription level which will be used in range bar request

Property type

Read-write property

Syntax

Visual Basic
Public Property SubscriptionLevel As eTimeSeriesSubscriptionLevel

See Also

CQGRangeBarsRequest Interface | CQGRangeBarsRequest Members


%%PageItemTitle%%

Symbol Property
CQGRangeBarsRequest Interface : Symbol Property

Glossary Item Box

Description

Sets the symbol which will be used in range bar request (required)

Property type

Read-write property

Syntax

Visual Basic
Public Property Symbol As String

See Also

CQGRangeBarsRequest Interface | CQGRangeBarsRequest Members


%%PageItemTitle%%

TickFilter Property
CQGRangeBarsRequest Interface : TickFilter Property

Glossary Item Box

Description

Sets the tick filter which will be used in range bar request

Property type

Read-write property

Syntax

Visual Basic
Public Property TickFilter As eTickFilter

See Also

CQGRangeBarsRequest Interface | CQGRangeBarsRequest Members


%%PageItemTitle%%

UpdatesEnabled Property
CQGRangeBarsRequest Interface : UpdatesEnabled Property

Glossary Item Box

Description

Sets the updates enabled flag which will be used in range bar request

Property type

Read-write property

Syntax

Visual Basic
Public Property UpdatesEnabled As Boolean

See Also

CQGRangeBarsRequest Interface | CQGRangeBarsRequest Members


%%PageItemTitle%%

CQGRemoteOpenAPISession Interface
See Also Members Send Feedback

Glossary Item Box

Description

CQGRemoteOpenAPISession keeps properties connected with the remote Open API session

Object Model

CQGRemoteOpenAPISession Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGRemoteOpenAPISession Members


%%PageItemTitle%% $$Members$$

CQGRemoteOpenAPISession Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property LogonName | Returns authentication log on name
Public Property ROMNumber | Returns client's ROM number
Public Property ServerAddress | Returns remote Open API server address to which CEL is currently connected

See Also

CQGRemoteOpenAPISession Interface


%%PageItemTitle%%

LogonName Property
CQGRemoteOpenAPISession Interface : LogonName Property

Glossary Item Box

Description

Returns authentication log on name

Property type

Read-only property

Syntax

Visual Basic
Public Property LogonName As String

See Also

CQGRemoteOpenAPISession Interface | CQGRemoteOpenAPISession Members


%%PageItemTitle%%

ROMNumber Property
CQGRemoteOpenAPISession Interface : ROMNumber Property

Glossary Item Box

Description

Returns client's ROM number

Property type

Read-only property

Syntax

Visual Basic
Public Property ROMNumber As Long

See Also

CQGRemoteOpenAPISession Interface | CQGRemoteOpenAPISession Members


%%PageItemTitle%%

ServerAddress Property
CQGRemoteOpenAPISession Interface : ServerAddress Property

Glossary Item Box

Description

Returns remote Open API server address to which CEL is currently connected

Property type

Read-only property

Syntax

Visual Basic
Public Property ServerAddress As String

See Also

CQGRemoteOpenAPISession Interface | CQGRemoteOpenAPISession Members


%%PageItemTitle%%

CQGRenkoBar Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents class for a renko bar

Object Model

CQGRenkoBar Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGRenkoBar Members


%%PageItemTitle%% $$Members$$

CQGRenkoBar Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property ActualVolume | Returns the actual volume
Public Property ActualVolumeFractional | Returns the actual fractional volume
Public Property Close | Returns real close
Public Property High | Returns real high
Public Property Low | Returns real low
Public Property Open | Returns real open
Public Property RenkoHigh | Returns Renko bar high
Public Property RenkoLow | Returns Renko bar low
Public Property RenkoUp | Returns Renko bar up
Public Property TickVolume | Returns the tick volume
Public Property Timestamp | Returns the timestamp
Public Property TimestampOffset | Returns the offset in the timestamp

See Also

CQGRenkoBar Interface


%%PageItemTitle%%

ActualVolume Property
CQGRenkoBar Interface : ActualVolume Property

Glossary Item Box

Description

Returns the actual volume

Property type

Read-only property

Syntax

Visual Basic
Public Property ActualVolume As Long

See Also

CQGRenkoBar Interface | CQGRenkoBar Members


%%PageItemTitle%%

ActualVolumeFractional Property
CQGRenkoBar Interface : ActualVolumeFractional Property

Glossary Item Box

Description

Returns the actual fractional volume

Property type

Read-only property

Syntax

Visual Basic
Public Property ActualVolumeFractional As Double

See Also

CQGRenkoBar Interface | CQGRenkoBar Members


%%PageItemTitle%%

Close Property
CQGRenkoBar Interface : Close Property

Glossary Item Box

Description

Returns real close

Property type

Read-only property

Syntax

Visual Basic
Public Property Close As Double

See Also

CQGRenkoBar Interface | CQGRenkoBar Members


%%PageItemTitle%%

High Property
CQGRenkoBar Interface : High Property

Glossary Item Box

Description

Returns real high

Property type

Read-only property

Syntax

Visual Basic
Public Property High As Double

See Also

CQGRenkoBar Interface | CQGRenkoBar Members


%%PageItemTitle%%

Low Property
CQGRenkoBar Interface : Low Property

Glossary Item Box

Description

Returns real low

Property type

Read-only property

Syntax

Visual Basic
Public Property Low As Double

See Also

CQGRenkoBar Interface | CQGRenkoBar Members


%%PageItemTitle%%

Open Property
CQGRenkoBar Interface : Open Property

Glossary Item Box

Description

Returns real open

Property type

Read-only property

Syntax

Visual Basic
Public Property Open As Double

See Also

CQGRenkoBar Interface | CQGRenkoBar Members


%%PageItemTitle%%

RenkoHigh Property
CQGRenkoBar Interface : RenkoHigh Property

Glossary Item Box

Description

Returns Renko bar high

Property type

Read-only property

Syntax

Visual Basic
Public Property RenkoHigh As Double

See Also

CQGRenkoBar Interface | CQGRenkoBar Members


%%PageItemTitle%%

RenkoLow Property
CQGRenkoBar Interface : RenkoLow Property

Glossary Item Box

Description

Returns Renko bar low

Property type

Read-only property

Syntax

Visual Basic
Public Property RenkoLow As Double

See Also

CQGRenkoBar Interface | CQGRenkoBar Members


%%PageItemTitle%%

RenkoUp Property
CQGRenkoBar Interface : RenkoUp Property

Glossary Item Box

Description

Returns Renko bar up

Property type

Read-only property

Syntax

Visual Basic
Public Property RenkoUp As Boolean

See Also

CQGRenkoBar Interface | CQGRenkoBar Members


%%PageItemTitle%%

TickVolume Property
CQGRenkoBar Interface : TickVolume Property

Glossary Item Box

Description

Returns the tick volume

Property type

Read-only property

Syntax

Visual Basic
Public Property TickVolume As Long

See Also

CQGRenkoBar Interface | CQGRenkoBar Members


%%PageItemTitle%%

Timestamp Property
CQGRenkoBar Interface : Timestamp Property

Glossary Item Box

Description

Returns the timestamp

Property type

Read-only property

Syntax

Visual Basic
Public Property Timestamp As Date

See Also

CQGRenkoBar Interface | CQGRenkoBar Members


%%PageItemTitle%%

TimestampOffset Property
CQGRenkoBar Interface : TimestampOffset Property

Glossary Item Box

Description

Returns the offset in the timestamp

Property type

Read-only property

Syntax

Visual Basic
Public Property TimestampOffset As Long

See Also

CQGRenkoBar Interface | CQGRenkoBar Members


%%PageItemTitle%%

CQGRenkoBarsRequest Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents parameters for renko bars request

Object Model

CQGRenkoBarsRequest Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGRenkoBarsRequest Members


%%PageItemTitle%% $$Members$$

CQGRenkoBarsRequest Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property BrickSize | Sets brick size which will be used in renko bar request
Public Property BrickUnit | Sets brick unit (required)
Public Property Continuation | Sets the continuation type which will be used in renko bar request
Public Property DaysBeforeExpiration | Sets the number of days prior to expiration the rollover will occur to be used in renko bar request
Public Property EqualizeCloses | Sets the equalize closes flag which will be used in renko bar request
Public Property IncludeEnd | Sets the include end flag which will be used in renko bar request
Public Property MaxNullBricks | Sets max null bricks which will be used in renko bar request
Public Property RangeEnd | Sets the range end which will be used in renko bar request (required)
Public Property RangeStart | Sets the range start which will be used in renko bar request (required)
Public Property RecalcPeriod | Sets the recalculation period which will be used in renko bar request
Public Property SessionFlags | Sets the session flags which will be used in renko bar request
Public Property SessionsFilter | Sets the sessions filter which will be used in renko bar request
Public Property SubscriptionLevel | Sets the subscription level which will be used in renko bar request
Public Property Symbol | Sets the symbol which will be used in renko bar request (required)
Public Property TickFilter | Sets the tick filter which will be used in renko bar request
Public Property UpdatesEnabled | Sets the updates enabled flag which will be used in renko bar request

See Also

CQGRenkoBarsRequest Interface


%%PageItemTitle%%

BrickSize Property
CQGRenkoBarsRequest Interface : BrickSize Property

Glossary Item Box

Description

Sets brick size which will be used in renko bar request

Property type

Read-write property

Syntax

Visual Basic
Public Property BrickSize As Long

See Also

CQGRenkoBarsRequest Interface | CQGRenkoBarsRequest Members


%%PageItemTitle%%

BrickUnit Property
CQGRenkoBarsRequest Interface : BrickUnit Property

Glossary Item Box

Description

Sets brick unit (required)

Property type

Read-write property

Syntax

Visual Basic
Public Property BrickUnit As eBrickUnit

See Also

CQGRenkoBarsRequest Interface | CQGRenkoBarsRequest Members


%%PageItemTitle%%

Continuation Property
CQGRenkoBarsRequest Interface : Continuation Property

Glossary Item Box

Description

Sets the continuation type which will be used in renko bar request

Property type

Read-write property

Syntax

Visual Basic
Public Property Continuation As eTimeSeriesContinuationType

See Also

CQGRenkoBarsRequest Interface | CQGRenkoBarsRequest Members


%%PageItemTitle%%

DaysBeforeExpiration Property
CQGRenkoBarsRequest Interface : DaysBeforeExpiration Property

Glossary Item Box

Description

Sets the number of days prior to expiration the rollover will occur to be used in renko bar request

Property type

Read-write property

Syntax

Visual Basic
Public Property DaysBeforeExpiration As Long

See Also

CQGRenkoBarsRequest Interface | CQGRenkoBarsRequest Members


%%PageItemTitle%%

EqualizeCloses Property
CQGRenkoBarsRequest Interface : EqualizeCloses Property

Glossary Item Box

Description

Sets the equalize closes flag which will be used in renko bar request

Property type

Read-write property

Syntax

Visual Basic
Public Property EqualizeCloses As Boolean

See Also

CQGRenkoBarsRequest Interface | CQGRenkoBarsRequest Members


%%PageItemTitle%%

IncludeEnd Property
CQGRenkoBarsRequest Interface : IncludeEnd Property

Glossary Item Box

Description

Sets the include end flag which will be used in renko bar request

Property type

Read-write property

Syntax

Visual Basic
Public Property IncludeEnd As Boolean

Remarks

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGRenkoBarsRequest Interface | CQGRenkoBarsRequest Members


%%PageItemTitle%%

MaxNullBricks Property
CQGRenkoBarsRequest Interface : MaxNullBricks Property

Glossary Item Box

Description

Sets max null bricks which will be used in renko bar request

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxNullBricks As Long

See Also

CQGRenkoBarsRequest Interface | CQGRenkoBarsRequest Members


%%PageItemTitle%%

RangeEnd Property
CQGRenkoBarsRequest Interface : RangeEnd Property

Glossary Item Box

Description

Sets the range end which will be used in renko bar request (required)

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeEnd As Variant

Remarks

Only Date and integer are allowed for types of RangeStart/RangeEnd properties.

  • If the type is Date, RangeStart/RangeEnd represent date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode). Non-timed bar requests process date/time range values with a precision of up to minutes.
  • All combinations of Date and integer can apply for these properties, except integer/Date.
  • If RangeEnd type is integer, then it represents the count of records prior to RangeStart to be requested, so it must be a negative value.
  • If RangeEnd is date, it must be further in time than RangeStart.

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGRenkoBarsRequest Interface | CQGRenkoBarsRequest Members


%%PageItemTitle%%

RangeStart Property
CQGRenkoBarsRequest Interface : RangeStart Property

Glossary Item Box

Description

Sets the range start which will be used in renko bar request (required)

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeStart As Variant

Remarks

Only Date and integer are allowed for types of RangeStart/RangeEnd properties:

  • All combinations of Date and Integer can apply for these properties, except Integer/Date.
  • If type is Date, RangeStart represents date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode). Non-timed bar requests process date/time range values with a precision of up to minutes.
  • If type is Integer, RangeStart represents the current condition's result number (0 is the current condition result number, negative numbers represent condition results in the past, positive numbers - in the future).
  • If the type of RangeStart is integer, it shall be 0 (denoting "current").

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGRenkoBarsRequest Interface | CQGRenkoBarsRequest Members


%%PageItemTitle%%

RecalcPeriod Property
CQGRenkoBarsRequest Interface : RecalcPeriod Property

Glossary Item Box

Description

Sets the recalculation period which will be used in renko bar request

Property type

Read-write property

Syntax

Visual Basic
Public Property RecalcPeriod As Long

See Also

CQGRenkoBarsRequest Interface | CQGRenkoBarsRequest Members


%%PageItemTitle%%

SessionFlags Property
CQGRenkoBarsRequest Interface : SessionFlags Property

Glossary Item Box

Description

Sets the session flags which will be used in renko bar request

Property type

Read-write property

Syntax

Visual Basic
Public Property SessionFlags As eSessionFlag

See Also

CQGRenkoBarsRequest Interface | CQGRenkoBarsRequest Members


%%PageItemTitle%%

SessionsFilter Property
CQGRenkoBarsRequest Interface : SessionsFilter Property

Glossary Item Box

Description

Sets the sessions filter which will be used in renko bar request

Property type

Read-write property

Syntax

Visual Basic
Public Property SessionsFilter As Variant

See Also

CQGRenkoBarsRequest Interface | CQGRenkoBarsRequest Members


%%PageItemTitle%%

SubscriptionLevel Property
CQGRenkoBarsRequest Interface : SubscriptionLevel Property

Glossary Item Box

Description

Sets the subscription level which will be used in renko bar request

Property type

Read-write property

Syntax

Visual Basic
Public Property SubscriptionLevel As eTimeSeriesSubscriptionLevel

See Also

CQGRenkoBarsRequest Interface | CQGRenkoBarsRequest Members


%%PageItemTitle%%

Symbol Property
CQGRenkoBarsRequest Interface : Symbol Property

Glossary Item Box

Description

Sets the symbol which will be used in renko bar request (required)

Property type

Read-write property

Syntax

Visual Basic
Public Property Symbol As String

See Also

CQGRenkoBarsRequest Interface | CQGRenkoBarsRequest Members


%%PageItemTitle%%

TickFilter Property
CQGRenkoBarsRequest Interface : TickFilter Property

Glossary Item Box

Description

Sets the tick filter which will be used in renko bar request

Property type

Read-write property

Syntax

Visual Basic
Public Property TickFilter As eTickFilter

See Also

CQGRenkoBarsRequest Interface | CQGRenkoBarsRequest Members


%%PageItemTitle%%

UpdatesEnabled Property
CQGRenkoBarsRequest Interface : UpdatesEnabled Property

Glossary Item Box

Description

Sets the updates enabled flag which will be used in renko bar request

Property type

Read-write property

Syntax

Visual Basic
Public Property UpdatesEnabled As Boolean

See Also

CQGRenkoBarsRequest Interface | CQGRenkoBarsRequest Members


%%PageItemTitle%%

CQGSession Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents information about an instrument's sessions or a custom session.

Object Model

CQGSession InterfaceCQGInstrument Interface

Remarks

All Date properties in CQGSession are plain times, without day/month/year part, and always are in Central time zone (i.e., GMT-6:00).

Starting from CQG API v.4.0, all Date properties in CQGSession are plain times in the user-configured time zone instead of the Central time zone. The current date is used to perform the conversion. Please note that daylight saving issues will apply (e.g., you may get different times for summer and winter).

Example

See the usage of CQGSession object in the CQGInstrument.Sessions' example section.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGSession Members


%%PageItemTitle%% $$Members$$

CQGSession Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method IsTimeInSession

Specifies whether the given date is within the session time period.

Public Properties

Public Property ActivationDate | Returns the session activation date.
Public Property DayCloseOffset | Returns session close day offset related to the current applied day in central time
Public Property DayStartOffset | Returns session start day offset related to the current applied day in central time
Public Property DayStartsYesterday | Returns the DayStartsYesterday flag
Public Property EndTime | Returns the trading session end time.
Public Property Instrument | Returns the corresponding instrument of the trading session.
Public Property Name | Returns the trading session's name.
Public Property Number | Returns the trading session number.
Public Property PrimaryFlag | Indicates if the trading session is primary.
Public Property StartTime | Returns the trading session start time.
Public Property Type | Returns the session type.
Public Property ValidEndTime | Returns the trading session's valid end time.
Public Property ValidStartTime | Returns the trading session's valid start time.
Public Property WorkingWeekDays | Returns the session working week days.

See Also

CQGSession Interface


%%PageItemTitle%%

IsTimeInSession Method
date_time
The date to be checked, in user-configured time zone, represented as Date
use_session_valid_times

This is an optional flag identifying whether the official or valid session times should be used.

- if True, the valid start and end times will be used.

- if False, the official start and end times will be used.

CQGSession Interface : IsTimeInSession Method

Glossary Item Box

Description

Specifies whether the given date is within the session time period.

Syntax

Visual Basic
Public Function IsTimeInSession( _
   ByVal date_time As Date, _
   Optional ByVal use_session_valid_times As Boolean = False _
) As Boolean

Parameters

date_time
The date to be checked, in user-configured time zone, represented as Date
use_session_valid_times

This is an optional flag identifying whether the official or valid session times should be used.

- if True, the valid start and end times will be used.

- if False, the official start and end times will be used.

Return Type

True if the given date is within the session, False otherwise

See Also

CQGSession Interface | CQGSession Members | TimeZoneCode Property


%%PageItemTitle%%

ActivationDate Property
CQGSession Interface : ActivationDate Property

Glossary Item Box

Description

Returns the session activation date.

Property type

Read-only property

Syntax

Visual Basic
Public Property ActivationDate As Date

Return Type

Session activation date, represented as Date

Remarks

Activation date is converted to the timezone previously configured by the user. If the user did not configure the timezone, the activation date time is converted to UTC.

Example

See the usage of CQGSession properties in the CQGInstrument.Sessions' example section.

See Also

CQGSession Interface | CQGSession Members


%%PageItemTitle%%

DayCloseOffset Property
CQGSession Interface : DayCloseOffset Property

Glossary Item Box

Description

Returns session close day offset related to the current applied day in central time

Property type

Read-only property

Syntax

Visual Basic
Public Property DayCloseOffset As Byte

See Also

CQGSession Interface | CQGSession Members


%%PageItemTitle%%

DayStartOffset Property
CQGSession Interface : DayStartOffset Property

Glossary Item Box

Description

Returns session start day offset related to the current applied day in central time

Property type

Read-only property

Syntax

Visual Basic
Public Property DayStartOffset As Byte

See Also

CQGSession Interface | CQGSession Members


%%PageItemTitle%%

DayStartsYesterday Property
CQGSession Interface : DayStartsYesterday Property

Glossary Item Box

Description

Returns the DayStartsYesterday flag

Property type

Read-only property

Syntax

Visual Basic
Public Property DayStartsYesterday As Boolean

See Also

CQGSession Interface | CQGSession Members


%%PageItemTitle%%

EndTime Property
CQGSession Interface : EndTime Property

Glossary Item Box

Description

Returns the trading session end time.

Property type

Read-only property

Syntax

Visual Basic
Public Property EndTime As Date

Return Type

Date variable containing the end time of the current session.

Remarks

Session end time is converted to the timezone previously configured by the user. If the user did not configure the timezone, the end time is converted to UTC.

Example

See the usage of CQGSession properties in the CQGInstrument.Sessions' example section.

See Also

CQGSession Interface | CQGSession Members


%%PageItemTitle%%

Instrument Property
CQGSession Interface : Instrument Property

Glossary Item Box

Description

Returns the corresponding instrument of the trading session.

Property type

Read-only property

Syntax

Visual Basic
Public Property Instrument As CQGInstrument

Return Type

CQGInstrument object to which this session belongs.

Will be Nothing if this is a custom session.

Remarks

This property will be convenient for those who are used to use the VBA specific Parent option.

Example

See the usage of CQGSession properties in the CQGInstrument.Sessions' example section.

See Also

CQGSession Interface | CQGSession Members | CQGInstrument Interface | CQGSession.Type Property


%%PageItemTitle%%

Name Property
CQGSession Interface : Name Property

Glossary Item Box

Description

Returns the trading session's name.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

Return Type

Session name string

Example

See the usage of CQGSession properties in the CQGInstrument.Sessions' example section.

See Also

CQGSession Interface | CQGSession Members


%%PageItemTitle%%

Number Property
CQGSession Interface : Number Property

Glossary Item Box

Description

Returns the trading session number.

Property type

Read-only property

Syntax

Visual Basic
Public Property Number As Integer

Return Type

Session number represented as integer.

Example

See the usage of CQGSession properties in the CQGInstrument.Sessions' example section.

See Also

CQGSession Interface | CQGSession Members


%%PageItemTitle%%

PrimaryFlag Property
CQGSession Interface : PrimaryFlag Property

Glossary Item Box

Description

Indicates if the trading session is primary.

Property type

Read-only property

Syntax

Visual Basic
Public Property PrimaryFlag As Boolean

Return Type

True if the session is primary, False - otherwise.

Example

See the usage of CQGSession properties in the CQGInstrument.Sessions' example section.

See Also

CQGSession Interface | CQGSession Members


%%PageItemTitle%%

StartTime Property
CQGSession Interface : StartTime Property

Glossary Item Box

Description

Returns the trading session start time.

Property type

Read-only property

Syntax

Visual Basic
Public Property StartTime As Date

Return Type

Date variable containing the session start time.

Remarks

Session start time is converted to the timezone previously configured by the user. If the user did not configure the timezone the start time is converted to UTC.

Example

See the usage of CQGSession properties in the CQGInstrument.Sessions' example section.

See Also

CQGSession Interface | CQGSession Members


%%PageItemTitle%%

Type Property
CQGSession Interface : Type Property

Glossary Item Box

Description

Returns the session type.

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As eSymbolSessionType

Return Type

Session type represented as eSymbolSessionType

Example

See the usage of CQGSession properties in the CQGInstrument.Sessions' property's example section.

See Also

CQGSession Interface | CQGSession Members | eSymbolSessionType Enumeration


%%PageItemTitle%%

ValidEndTime Property
CQGSession Interface : ValidEndTime Property

Glossary Item Box

Description

Returns the trading session's valid end time.

Property type

Read-only property

Syntax

Visual Basic
Public Property ValidEndTime As Date

Return Type

Session valid end time, represented as Date

See Also

CQGSession Interface | CQGSession Members


%%PageItemTitle%%

ValidStartTime Property
CQGSession Interface : ValidStartTime Property

Glossary Item Box

Description

Returns the trading session's valid start time.

Property type

Read-only property

Syntax

Visual Basic
Public Property ValidStartTime As Date

Return Type

Session valid start time, represented as Date

See Also

CQGSession Interface | CQGSession Members


%%PageItemTitle%%

WorkingWeekDays Property
CQGSession Interface : WorkingWeekDays Property

Glossary Item Box

Description

Returns the session working week days.

Property type

Read-only property

Syntax

Visual Basic
Public Property WorkingWeekDays As eSessionWeekDays

Return Type

Session working week days represented as a bitmask of eSessionWeekDays

Example

See the usage of CQGSession properties in the CQGInstrument.Sessions' property's example section.

See Also

CQGSession Interface | CQGSession Members | eSessionWeekDays Enumeration


%%PageItemTitle%%

CQGStrategyDefinition Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a strategy definition.

Object Model

CQGStrategyDefinition InterfaceCQGError Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGStrategyDefinition Members


%%PageItemTitle%% $$Members$$

CQGStrategyDefinition Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property ClientId | Returns the CQGIC generated GUID for the strategy definition.
Public Property Id | Returns the unique identifier of the strategy definition.
Public Property LastError | Returns the CQGError object describing the last error occurred to this object.
Public Property RequestString | Returns the string used to formulate the strategy definition request.
Public Property Status | Returns the status of the strategy definition. See eStrategyRequestStatus for possible values.
Public Property Symbol | Returns the Gateway alias for the strategy.

See Also

CQGStrategyDefinition Interface


%%PageItemTitle%%

ClientId Property
CQGStrategyDefinition Interface : ClientId Property

Glossary Item Box

Description

Returns the CQGIC generated GUID for the strategy definition.

Property type

Read-only property

Syntax

Visual Basic
Public Property ClientId As String

Return Type

CQGIC generated GUID, represented as String

Remarks

This property could be empty string.

See Also

CQGStrategyDefinition Interface | CQGStrategyDefinition Members


%%PageItemTitle%%

Id Property
CQGStrategyDefinition Interface : Id Property

Glossary Item Box

Description

Returns the unique identifier of the strategy definition.

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

Return Type

Unique identifier, represented as String

See Also

CQGStrategyDefinition Interface | CQGStrategyDefinition Members


%%PageItemTitle%%

LastError Property
CQGStrategyDefinition Interface : LastError Property

Glossary Item Box

Description

Returns the CQGError object describing the last error occurred to this object.

Property type

Read-only property

Syntax

Visual Basic
Public Property LastError As CQGError

Return Type

The last error, represented as CQGError object

See Also

CQGStrategyDefinition Interface | CQGStrategyDefinition Members | CQGError Interface


%%PageItemTitle%%

RequestString Property
CQGStrategyDefinition Interface : RequestString Property

Glossary Item Box

Description

Returns the string used to formulate the strategy definition request.

Property type

Read-only property

Syntax

Visual Basic
Public Property RequestString As String

Return Type

Strategy definition request string, represented as String

See Also

CQGStrategyDefinition Interface | CQGStrategyDefinition Members


%%PageItemTitle%%

Status Property
CQGStrategyDefinition Interface : Status Property

Glossary Item Box

Description

Returns the status of the strategy definition.

See eStrategyRequestStatus for possible values.

Property type

Read-only property

Syntax

Visual Basic
Public Property Status As eStrategyRequestStatus

Return Type

Status of the strategy definition, represented as eStrategyRequestStatus

See Also

CQGStrategyDefinition Interface | CQGStrategyDefinition Members | eStrategyRequestStatus Enumeration


%%PageItemTitle%%

Symbol Property
CQGStrategyDefinition Interface : Symbol Property

Glossary Item Box

Description

Returns the Gateway alias for the strategy.

Property type

Read-only property

Syntax

Visual Basic
Public Property Symbol As String

Return Type

Gateway alias, represented as String

See Also

CQGStrategyDefinition Interface | CQGStrategyDefinition Members


%%PageItemTitle%%

CQGStrategyLegFill Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a leg fill for a strategy order.

Object Model

CQGStrategyLegFill InterfaceCQGOrder Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGStrategyLegFill Members


%%PageItemTitle%% $$Members$$

CQGStrategyLegFill Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property ExecutionId | Returns the leg order's fill transaction execution identifier.
Public Property Order | Returns the corresponding leg order.
Public Property OriginalOrderID | Returns the leg order's original Gateway identifier.
Public Property Quantity | Returns the quantity of the leg order's fill.

See Also

CQGStrategyLegFill Interface


%%PageItemTitle%%

ExecutionId Property
CQGStrategyLegFill Interface : ExecutionId Property

Glossary Item Box

Description

Returns the leg order's fill transaction execution identifier.

Property type

Read-only property

Syntax

Visual Basic
Public Property ExecutionId As String

Return Type

Leg order's fill transaction execution identifier, represented as String

See Also

CQGStrategyLegFill Interface | CQGStrategyLegFill Members


%%PageItemTitle%%

Order Property
CQGStrategyLegFill Interface : Order Property

Glossary Item Box

Description

Returns the corresponding leg order.

Property type

Read-only property

Syntax

Visual Basic
Public Property Order As CQGOrder

Return Type

Corresponding leg order, represented as CQGOrder

Remarks

If the leg order is not available in CEL, this property returns Nothing.

See Also

CQGStrategyLegFill Interface | CQGStrategyLegFill Members | CQGOrder Interface


%%PageItemTitle%%

OriginalOrderID Property
CQGStrategyLegFill Interface : OriginalOrderID Property

Glossary Item Box

Description

Returns the leg order's original Gateway identifier.

Property type

Read-only property

Syntax

Visual Basic
Public Property OriginalOrderID As String

Return Type

Leg order's original Gateway identifier, represented as String

See Also

CQGStrategyLegFill Interface | CQGStrategyLegFill Members


%%PageItemTitle%%

Quantity Property
CQGStrategyLegFill Interface : Quantity Property

Glossary Item Box

Description

Returns the quantity of the leg order's fill.

Property type

Read-only property

Syntax

Visual Basic
Public Property Quantity As Long

Return Type

Quantity of the leg order's fill, represented as Long

Remarks

This property is always positive regardless to the CQGAPIConfig.UseOrderSide setting.

See Also

CQGStrategyLegFill Interface | CQGStrategyLegFill Members


%%PageItemTitle%%

CQGSubMinuteBar Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a single sub minute bar

Object Model

CQGSubMinuteBar Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGSubMinuteBar Members


%%PageItemTitle%% $$Members$$

CQGSubMinuteBar Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property AskVolume | Returns the ask volume
Public Property AskVolumeFractional | Returns the fractional ask volume
Public Property Avg | Returns the average
Public Property BidVolume | Returns the bid volume
Public Property BidVolumeFractional | Returns the fractional bid volume
Public Property Close | Returns the close
Public Property High | Returns the high
Public Property HLC3 | Returns (High+Low+Close)/3
Public Property Low | Returns the low
Public Property Mid | Returns the midian
Public Property Open | Returns the open
Public Property Range | Returns the range
Public Property TickVolume | Returns the tick volume
Public Property Timestamp | Returns the timestamp
Public Property TimestampOffset | Returns bar index in minute
Public Property TrueHigh | Returns the true high
Public Property TrueLow | Returns the true low
Public Property TrueRange | Returns the true range
Public Property Volume | Returns the actual volume
Public Property VolumeFractional | Returns the fractional volume

See Also

CQGSubMinuteBar Interface


%%PageItemTitle%%

AskVolume Property
CQGSubMinuteBar Interface : AskVolume Property

Glossary Item Box

Description

Returns the ask volume

Property type

Read-only property

Syntax

Visual Basic
Public Property AskVolume As Long

See Also

CQGSubMinuteBar Interface | CQGSubMinuteBar Members


%%PageItemTitle%%

AskVolumeFractional Property
CQGSubMinuteBar Interface : AskVolumeFractional Property

Glossary Item Box

Description

Returns the fractional ask volume

Property type

Read-only property

Syntax

Visual Basic
Public Property AskVolumeFractional As Double

See Also

CQGSubMinuteBar Interface | CQGSubMinuteBar Members


%%PageItemTitle%%

Avg Property
CQGSubMinuteBar Interface : Avg Property

Glossary Item Box

Description

Returns the average

Property type

Read-only property

Syntax

Visual Basic
Public Property Avg As Double

See Also

CQGSubMinuteBar Interface | CQGSubMinuteBar Members


%%PageItemTitle%%

BidVolume Property
CQGSubMinuteBar Interface : BidVolume Property

Glossary Item Box

Description

Returns the bid volume

Property type

Read-only property

Syntax

Visual Basic
Public Property BidVolume As Long

See Also

CQGSubMinuteBar Interface | CQGSubMinuteBar Members


%%PageItemTitle%%

BidVolumeFractional Property
CQGSubMinuteBar Interface : BidVolumeFractional Property

Glossary Item Box

Description

Returns the fractional bid volume

Property type

Read-only property

Syntax

Visual Basic
Public Property BidVolumeFractional As Double

See Also

CQGSubMinuteBar Interface | CQGSubMinuteBar Members


%%PageItemTitle%%

Close Property
CQGSubMinuteBar Interface : Close Property

Glossary Item Box

Description

Returns the close

Property type

Read-only property

Syntax

Visual Basic
Public Property Close As Double

See Also

CQGSubMinuteBar Interface | CQGSubMinuteBar Members


%%PageItemTitle%%

High Property
CQGSubMinuteBar Interface : High Property

Glossary Item Box

Description

Returns the high

Property type

Read-only property

Syntax

Visual Basic
Public Property High As Double

See Also

CQGSubMinuteBar Interface | CQGSubMinuteBar Members


%%PageItemTitle%%

HLC3 Property
CQGSubMinuteBar Interface : HLC3 Property

Glossary Item Box

Description

Returns (High+Low+Close)/3

Property type

Read-only property

Syntax

Visual Basic
Public Property HLC3 As Double

See Also

CQGSubMinuteBar Interface | CQGSubMinuteBar Members


%%PageItemTitle%%

Low Property
CQGSubMinuteBar Interface : Low Property

Glossary Item Box

Description

Returns the low

Property type

Read-only property

Syntax

Visual Basic
Public Property Low As Double

See Also

CQGSubMinuteBar Interface | CQGSubMinuteBar Members


%%PageItemTitle%%

Mid Property
CQGSubMinuteBar Interface : Mid Property

Glossary Item Box

Description

Returns the midian

Property type

Read-only property

Syntax

Visual Basic
Public Property Mid As Double

See Also

CQGSubMinuteBar Interface | CQGSubMinuteBar Members


%%PageItemTitle%%

Open Property
CQGSubMinuteBar Interface : Open Property

Glossary Item Box

Description

Returns the open

Property type

Read-only property

Syntax

Visual Basic
Public Property Open As Double

See Also

CQGSubMinuteBar Interface | CQGSubMinuteBar Members


%%PageItemTitle%%

Range Property
CQGSubMinuteBar Interface : Range Property

Glossary Item Box

Description

Returns the range

Property type

Read-only property

Syntax

Visual Basic
Public Property Range As Double

See Also

CQGSubMinuteBar Interface | CQGSubMinuteBar Members


%%PageItemTitle%%

TickVolume Property
CQGSubMinuteBar Interface : TickVolume Property

Glossary Item Box

Description

Returns the tick volume

Property type

Read-only property

Syntax

Visual Basic
Public Property TickVolume As Long

See Also

CQGSubMinuteBar Interface | CQGSubMinuteBar Members


%%PageItemTitle%%

Timestamp Property
CQGSubMinuteBar Interface : Timestamp Property

Glossary Item Box

Description

Returns the timestamp

Property type

Read-only property

Syntax

Visual Basic
Public Property Timestamp As Date

See Also

CQGSubMinuteBar Interface | CQGSubMinuteBar Members


%%PageItemTitle%%

TimestampOffset Property
CQGSubMinuteBar Interface : TimestampOffset Property

Glossary Item Box

Description

Returns bar index in minute

Property type

Read-only property

Syntax

Visual Basic
Public Property TimestampOffset As Long

See Also

CQGSubMinuteBar Interface | CQGSubMinuteBar Members


%%PageItemTitle%%

TrueHigh Property
CQGSubMinuteBar Interface : TrueHigh Property

Glossary Item Box

Description

Returns the true high

Property type

Read-only property

Syntax

Visual Basic
Public Property TrueHigh As Double

See Also

CQGSubMinuteBar Interface | CQGSubMinuteBar Members


%%PageItemTitle%%

TrueLow Property
CQGSubMinuteBar Interface : TrueLow Property

Glossary Item Box

Description

Returns the true low

Property type

Read-only property

Syntax

Visual Basic
Public Property TrueLow As Double

See Also

CQGSubMinuteBar Interface | CQGSubMinuteBar Members


%%PageItemTitle%%

TrueRange Property
CQGSubMinuteBar Interface : TrueRange Property

Glossary Item Box

Description

Returns the true range

Property type

Read-only property

Syntax

Visual Basic
Public Property TrueRange As Double

See Also

CQGSubMinuteBar Interface | CQGSubMinuteBar Members


%%PageItemTitle%%

Volume Property
CQGSubMinuteBar Interface : Volume Property

Glossary Item Box

Description

Returns the actual volume

Property type

Read-only property

Syntax

Visual Basic
Public Property Volume As Long

See Also

CQGSubMinuteBar Interface | CQGSubMinuteBar Members


%%PageItemTitle%%

VolumeFractional Property
CQGSubMinuteBar Interface : VolumeFractional Property

Glossary Item Box

Description

Returns the fractional volume

Property type

Read-only property

Syntax

Visual Basic
Public Property VolumeFractional As Double

See Also

CQGSubMinuteBar Interface | CQGSubMinuteBar Members


%%PageItemTitle%%

CQGSubMinuteBarsRequest Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents parameters for sub minute bars request

Object Model

CQGSubMinuteBarsRequest Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGSubMinuteBarsRequest Members


%%PageItemTitle%% $$Members$$

CQGSubMinuteBarsRequest Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Continuation | Sets the continuation type which will be used in sub minute bars request
Public Property DaysBeforeExpiration | Sets the number of days prior to expiration the rollover will occur to be used in sub minute bars request
Public Property EqualizeCloses | Sets the equalize closes flag which will be used in sub minute bars request
Public Property GapFilter | Sets gap filter which will be used in sub minute bars request
Public Property IncludeEnd | Sets the include end flag which will be used in sub minute bars request
Public Property Interval | Sets bar interval in seconds (required)
Public Property RangeEnd | Sets the range end which will be used in sub minute bars request (required)
Public Property RangeStart | Sets the range start which will be used in sub minute bars request (required)
Public Property RecalcPeriod | Sets the recalculation period which will be used in sub minute bars request
Public Property SessionFlags | Sets the session flags which will be used in sub minute bars request
Public Property SessionsFilter | Sets the sessions filter which will be used in sub minute bars request
Public Property SubscriptionLevel | Sets the subscription level which will be used in sub minute bars request
Public Property Symbol | Sets the symbol which will be used in sub minute bars request (required)
Public Property TickFilter | Sets the tick filter which will be used in sub minute bars request
Public Property UpdatesEnabled | Sets the updates enabled flag which will be used in sub minute bars request

See Also

CQGSubMinuteBarsRequest Interface


%%PageItemTitle%%

Continuation Property
CQGSubMinuteBarsRequest Interface : Continuation Property

Glossary Item Box

Description

Sets the continuation type which will be used in sub minute bars request

Property type

Read-write property

Syntax

Visual Basic
Public Property Continuation As eTimeSeriesContinuationType

See Also

CQGSubMinuteBarsRequest Interface | CQGSubMinuteBarsRequest Members


%%PageItemTitle%%

DaysBeforeExpiration Property
CQGSubMinuteBarsRequest Interface : DaysBeforeExpiration Property

Glossary Item Box

Description

Sets the number of days prior to expiration the rollover will occur to be used in sub minute bars request

Property type

Read-write property

Syntax

Visual Basic
Public Property DaysBeforeExpiration As Long

See Also

CQGSubMinuteBarsRequest Interface | CQGSubMinuteBarsRequest Members


%%PageItemTitle%%

EqualizeCloses Property
CQGSubMinuteBarsRequest Interface : EqualizeCloses Property

Glossary Item Box

Description

Sets the equalize closes flag which will be used in sub minute bars request

Property type

Read-write property

Syntax

Visual Basic
Public Property EqualizeCloses As Boolean

See Also

CQGSubMinuteBarsRequest Interface | CQGSubMinuteBarsRequest Members


%%PageItemTitle%%

GapFilter Property
CQGSubMinuteBarsRequest Interface : GapFilter Property

Glossary Item Box

Description

Sets gap filter which will be used in sub minute bars request

Property type

Read-write property

Syntax

Visual Basic
Public Property GapFilter As eGapFilter

See Also

CQGSubMinuteBarsRequest Interface | CQGSubMinuteBarsRequest Members


%%PageItemTitle%%

IncludeEnd Property
CQGSubMinuteBarsRequest Interface : IncludeEnd Property

Glossary Item Box

Description

Sets the include end flag which will be used in sub minute bars request

Property type

Read-write property

Syntax

Visual Basic
Public Property IncludeEnd As Boolean

Remarks

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGSubMinuteBarsRequest Interface | CQGSubMinuteBarsRequest Members


%%PageItemTitle%%

Interval Property
CQGSubMinuteBarsRequest Interface : Interval Property

Glossary Item Box

Description

Sets bar interval in seconds (required)

Property type

Read-write property

Syntax

Visual Basic
Public Property Interval As Long

See Also

CQGSubMinuteBarsRequest Interface | CQGSubMinuteBarsRequest Members


%%PageItemTitle%%

RangeEnd Property
CQGSubMinuteBarsRequest Interface : RangeEnd Property

Glossary Item Box

Description

Sets the range end which will be used in sub minute bars request (required)

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeEnd As Variant

Remarks

Only Date and integer are allowed for types of RangeStart/RangeEnd properties.

  • If the type is Date, RangeStart/RangeEnd represent date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode). Non-timed bar requests process date/time range values with a precision of up to minutes.
  • All combinations of Date and integer can apply for these properties, except integer/Date.
  • If RangeEnd type is integer, then it represents the count of records prior to RangeStart to be requested, so it must be a negative value.
  • If RangeEnd is date, it must be further in time than RangeStart.

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGSubMinuteBarsRequest Interface | CQGSubMinuteBarsRequest Members


%%PageItemTitle%%

RangeStart Property
CQGSubMinuteBarsRequest Interface : RangeStart Property

Glossary Item Box

Description

Sets the range start which will be used in sub minute bars request (required)

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeStart As Variant

Remarks

Only Date and integer are allowed for types of RangeStart/RangeEnd properties:

  • All combinations of Date and Integer can apply for these properties, except Integer/Date.
  • If type is Date, RangeStart represents date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode). Non-timed bar requests process date/time range values with a precision of up to minutes.
  • If type is Integer, RangeStart represents the current condition's result number (0 is the current condition result number, negative numbers represent condition results in the past, positive numbers - in the future).
  • If the type of RangeStart is integer, it shall be 0 (denoting "current").

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGSubMinuteBarsRequest Interface | CQGSubMinuteBarsRequest Members


%%PageItemTitle%%

RecalcPeriod Property
CQGSubMinuteBarsRequest Interface : RecalcPeriod Property

Glossary Item Box

Description

Sets the recalculation period which will be used in sub minute bars request

Property type

Read-write property

Syntax

Visual Basic
Public Property RecalcPeriod As Long

See Also

CQGSubMinuteBarsRequest Interface | CQGSubMinuteBarsRequest Members


%%PageItemTitle%%

SessionFlags Property
CQGSubMinuteBarsRequest Interface : SessionFlags Property

Glossary Item Box

Description

Sets the session flags which will be used in sub minute bars request

Property type

Read-write property

Syntax

Visual Basic
Public Property SessionFlags As eSessionFlag

See Also

CQGSubMinuteBarsRequest Interface | CQGSubMinuteBarsRequest Members


%%PageItemTitle%%

SessionsFilter Property
CQGSubMinuteBarsRequest Interface : SessionsFilter Property

Glossary Item Box

Description

Sets the sessions filter which will be used in sub minute bars request

Property type

Read-write property

Syntax

Visual Basic
Public Property SessionsFilter As Variant

See Also

CQGSubMinuteBarsRequest Interface | CQGSubMinuteBarsRequest Members


%%PageItemTitle%%

SubscriptionLevel Property
CQGSubMinuteBarsRequest Interface : SubscriptionLevel Property

Glossary Item Box

Description

Sets the subscription level which will be used in sub minute bars request

Property type

Read-write property

Syntax

Visual Basic
Public Property SubscriptionLevel As eTimeSeriesSubscriptionLevel

See Also

CQGSubMinuteBarsRequest Interface | CQGSubMinuteBarsRequest Members


%%PageItemTitle%%

Symbol Property
CQGSubMinuteBarsRequest Interface : Symbol Property

Glossary Item Box

Description

Sets the symbol which will be used in sub minute bars request (required)

Property type

Read-write property

Syntax

Visual Basic
Public Property Symbol As String

See Also

CQGSubMinuteBarsRequest Interface | CQGSubMinuteBarsRequest Members


%%PageItemTitle%%

TickFilter Property
CQGSubMinuteBarsRequest Interface : TickFilter Property

Glossary Item Box

Description

Sets the tick filter which will be used in sub minute bars request

Property type

Read-write property

Syntax

Visual Basic
Public Property TickFilter As eTickFilter

See Also

CQGSubMinuteBarsRequest Interface | CQGSubMinuteBarsRequest Members


%%PageItemTitle%%

UpdatesEnabled Property
CQGSubMinuteBarsRequest Interface : UpdatesEnabled Property

Glossary Item Box

Description

Sets the updates enabled flag which will be used in sub minute bars request

Property type

Read-write property

Syntax

Visual Basic
Public Property UpdatesEnabled As Boolean

See Also

CQGSubMinuteBarsRequest Interface | CQGSubMinuteBarsRequest Members


%%PageItemTitle%%

CQGSummariesStatement Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a class for managing summaries statement.

Object Model

CQGSummariesStatement InterfaceCQGAccountSummaries CollectionCQGAccountSummary InterfaceCQGAccountSummary Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGSummariesStatement Members


%%PageItemTitle%% $$Members$$

CQGSummariesStatement Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property CurrencySummaries | Returns a collection of account summaries, which includes one CQGAccountSummary for each account currency.
Public Property GWAccountID | Returns the account's gateway ID, for which the summaries statement is requested.
Public Property StatementDate | Returns the date, for which the summaries statement is requested.
Public Property Summary | Returns an account statistics summary, converted to the reporting currency.

See Also

CQGSummariesStatement Interface


%%PageItemTitle%%

CurrencySummaries Property
CQGSummariesStatement Interface : CurrencySummaries Property

Glossary Item Box

Description

Returns a collection of account summaries, which includes one CQGAccountSummary for each account currency.

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrencySummaries As CQGAccountSummaries

Return Type

Collection of account summaries, represented as CQGAccountSummaries

See Also

CQGSummariesStatement Interface | CQGSummariesStatement Members


%%PageItemTitle%%

GWAccountID Property
CQGSummariesStatement Interface : GWAccountID Property

Glossary Item Box

Description

Returns the account's gateway ID, for which the summaries statement is requested.

Property type

Read-only property

Syntax

Visual Basic
Public Property GWAccountID As Long

Return Type

Gateway ID, represented as Long

See Also

CQGSummariesStatement Interface | CQGSummariesStatement Members


%%PageItemTitle%%

StatementDate Property
CQGSummariesStatement Interface : StatementDate Property

Glossary Item Box

Description

Returns the date, for which the summaries statement is requested.

Property type

Read-only property

Syntax

Visual Basic
Public Property StatementDate As Date

Return Type

Statement date, represented as Date

See Also

CQGSummariesStatement Interface | CQGSummariesStatement Members


%%PageItemTitle%%

Summary Property
CQGSummariesStatement Interface : Summary Property

Glossary Item Box

Description

Returns an account statistics summary, converted to the reporting currency.

Property type

Read-only property

Syntax

Visual Basic
Public Property Summary As CQGAccountSummary

Return Type

Account summary, represented as CQGAccountSummary

See Also

CQGSummariesStatement Interface | CQGSummariesStatement Members


%%PageItemTitle%%

CQGTFlowBar Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a single TFlow bar.

Object Model

CQGTFlowBar Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTFlowBar Members | RequestTFlowBars Method | RemoveAllTFlowBars Method | RemoveTFlowBars Method | CQGTFlowBarsRequest Interface | CQGTFlowBars Collection


%%PageItemTitle%% $$Members$$

CQGTFlowBar Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property AskVolume | Returns the ask volume for the TFlow bar.
Public Property AskVolumeFractional | Returns the ask fractional volume
Public Property BestAskPrice | Returns the best ask price value for the TFlow bar.
Public Property BestBidPrice | Returns the best bid price value for the TFlow bar.
Public Property BidVolume | Returns the bid volume value for the TFlow bar.
Public Property BidVolumeFractional | Returns the bid fractional volume
Public Property Close | Returns the close value for the TFlow bar.
Public Property DomAskCount | Returns the number of DOM asks in the TFlow bar.
Public Property DomAskVolume | Returns the DOM ask volume by its index.
Public Property DomAskVolumeFractional | Returns the DOM ask fractional volume by index
Public Property DomBidCount | Returns the number of all DOM bids in the TFlow bar.
Public Property DomBidVolume | Returns the DOM bid volume by its index for the TFlow bar.
Public Property DomBidVolumeFractional | Returns the DOM bid fractional volume by index
Public Property High | Returns the high value of the TFlow bar.
Public Property Low | Returns the low value of the TFlow bar.
Public Property Mid | Returns the mid-point value of the TFlow bar.
Public Property Open | Returns the open.
Public Property Timestamp | Returns the timestamp, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
Public Property TimestampOffset | Returns the timestamp offset, which is used to identify various CQGTFlowBar objects that have the same timestamp.
Public Property TrueHigh | Returns the true high.
Public Property TrueLow | Returns the true low.
Public Property TrueMid | Returns the true midian.

See Also

CQGTFlowBar Interface | RequestTFlowBars Method | RemoveAllTFlowBars Method | RemoveTFlowBars Method | CQGTFlowBarsRequest Interface | CQGTFlowBars Collection


%%PageItemTitle%%

AskVolume Property
CQGTFlowBar Interface : AskVolume Property

Glossary Item Box

Description

Returns the ask volume for the TFlow bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property AskVolume As Long

Return Type

Ask volume, represented as Long

See Also

CQGTFlowBar Interface | CQGTFlowBar Members


%%PageItemTitle%%

AskVolumeFractional Property
CQGTFlowBar Interface : AskVolumeFractional Property

Glossary Item Box

Description

Returns the ask fractional volume

Property type

Read-only property

Syntax

Visual Basic
Public Property AskVolumeFractional As Double

See Also

CQGTFlowBar Interface | CQGTFlowBar Members


%%PageItemTitle%%

BestAskPrice Property
CQGTFlowBar Interface : BestAskPrice Property

Glossary Item Box

Description

Returns the best ask price value for the TFlow bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property BestAskPrice As Double

Return Type

Best ask price, represented as Double

See Also

CQGTFlowBar Interface | CQGTFlowBar Members


%%PageItemTitle%%

BestBidPrice Property
CQGTFlowBar Interface : BestBidPrice Property

Glossary Item Box

Description

Returns the best bid price value for the TFlow bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property BestBidPrice As Double

Return Type

Best bid price, represented as Double

See Also

CQGTFlowBar Interface | CQGTFlowBar Members


%%PageItemTitle%%

BidVolume Property
CQGTFlowBar Interface : BidVolume Property

Glossary Item Box

Description

Returns the bid volume value for the TFlow bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property BidVolume As Long

Return Type

Bid volume, represented as Long

See Also

CQGTFlowBar Interface | CQGTFlowBar Members


%%PageItemTitle%%

BidVolumeFractional Property
CQGTFlowBar Interface : BidVolumeFractional Property

Glossary Item Box

Description

Returns the bid fractional volume

Property type

Read-only property

Syntax

Visual Basic
Public Property BidVolumeFractional As Double

See Also

CQGTFlowBar Interface | CQGTFlowBar Members


%%PageItemTitle%%

Close Property
CQGTFlowBar Interface : Close Property

Glossary Item Box

Description

Returns the close value for the TFlow bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property Close As Double

Return Type

Close, represented as Double

See Also

CQGTFlowBar Interface | CQGTFlowBar Members


%%PageItemTitle%%

DomAskCount Property
CQGTFlowBar Interface : DomAskCount Property

Glossary Item Box

Description

Returns the number of DOM asks in the TFlow bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property DomAskCount As Long

Return Type

Number of DOM asks, represented as Long

See Also

CQGTFlowBar Interface | CQGTFlowBar Members


%%PageItemTitle%%

DomAskVolume Property
index_
Sequential index of DOM ask volume
CQGTFlowBar Interface : DomAskVolume Property

Glossary Item Box

Description

Returns the DOM ask volume by its index.

Property type

Read-only property

Syntax

Visual Basic
Public Property DomAskVolume( _
   ByVal index_ As Long _
) As Long

Parameters

index_
Sequential index of DOM ask volume

Return Type

DOM ask volume, represented as Long

See Also

CQGTFlowBar Interface | CQGTFlowBar Members


%%PageItemTitle%%

DomAskVolumeFractional Property
index_
Zero-based index of item in the collection
CQGTFlowBar Interface : DomAskVolumeFractional Property

Glossary Item Box

Description

Returns the DOM ask fractional volume by index

Property type

Read-only property

Syntax

Visual Basic
Public Property DomAskVolumeFractional( _
   ByVal index_ As Long _
) As Double

Parameters

index_
Zero-based index of item in the collection

See Also

CQGTFlowBar Interface | CQGTFlowBar Members


%%PageItemTitle%%

DomBidCount Property
CQGTFlowBar Interface : DomBidCount Property

Glossary Item Box

Description

Returns the number of all DOM bids in the TFlow bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property DomBidCount As Long

Return Type

Number of DOM bids, represented as Long

See Also

CQGTFlowBar Interface | CQGTFlowBar Members


%%PageItemTitle%%

DomBidVolume Property
index_
Sequential index of DOM bid volume
CQGTFlowBar Interface : DomBidVolume Property

Glossary Item Box

Description

Returns the DOM bid volume by its index for the TFlow bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property DomBidVolume( _
   ByVal index_ As Long _
) As Long

Parameters

index_
Sequential index of DOM bid volume

Return Type

DOM bid volume, represented as Long

See Also

CQGTFlowBar Interface | CQGTFlowBar Members


%%PageItemTitle%%

DomBidVolumeFractional Property
index_
Zero-based index of item in the collection
CQGTFlowBar Interface : DomBidVolumeFractional Property

Glossary Item Box

Description

Returns the DOM bid fractional volume by index

Property type

Read-only property

Syntax

Visual Basic
Public Property DomBidVolumeFractional( _
   ByVal index_ As Long _
) As Double

Parameters

index_
Zero-based index of item in the collection

See Also

CQGTFlowBar Interface | CQGTFlowBar Members


%%PageItemTitle%%

High Property
CQGTFlowBar Interface : High Property

Glossary Item Box

Description

Returns the high value of the TFlow bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property High As Double

Return Type

High, represented as Double

See Also

CQGTFlowBar Interface | CQGTFlowBar Members


%%PageItemTitle%%

Low Property
CQGTFlowBar Interface : Low Property

Glossary Item Box

Description

Returns the low value of the TFlow bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property Low As Double

Return Type

Low, represented as Double

See Also

CQGTFlowBar Interface | CQGTFlowBar Members


%%PageItemTitle%%

Mid Property
CQGTFlowBar Interface : Mid Property

Glossary Item Box

Description

Returns the mid-point value of the TFlow bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property Mid As Double

Return Type

Mid-point, represented as Double

See Also

CQGTFlowBar Interface | CQGTFlowBar Members


%%PageItemTitle%%

Open Property
CQGTFlowBar Interface : Open Property

Glossary Item Box

Description

Returns the open.

Property type

Read-only property

Syntax

Visual Basic
Public Property Open As Double

Return Type

Open, represented as Double

See Also

CQGTFlowBar Interface | CQGTFlowBar Members


%%PageItemTitle%%

Timestamp Property
CQGTFlowBar Interface : Timestamp Property

Glossary Item Box

Description

Returns the timestamp, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

Property type

Read-only property

Syntax

Visual Basic
Public Property Timestamp As Date

Return Type

Timestamp, represented as Date

See Also

CQGTFlowBar Interface | CQGTFlowBar Members


%%PageItemTitle%%

TimestampOffset Property
CQGTFlowBar Interface : TimestampOffset Property

Glossary Item Box

Description

Returns the timestamp offset, which is used to identify various CQGTFlowBar objects that have the same timestamp.

Property type

Read-only property

Syntax

Visual Basic
Public Property TimestampOffset As Long

Return Type

Timestamp offset, represented as Long

Remarks

The TimestampOffset value grows for subsequent objects. It resets when the timestamp is changed.

See Also

CQGTFlowBar Interface | CQGTFlowBar Members


%%PageItemTitle%%

TrueHigh Property
CQGTFlowBar Interface : TrueHigh Property

Glossary Item Box

Description

Returns the true high.

Property type

Read-only property

Syntax

Visual Basic
Public Property TrueHigh As Double

Return Type

True high, represented as Double

See Also

CQGTFlowBar Interface | CQGTFlowBar Members


%%PageItemTitle%%

TrueLow Property
CQGTFlowBar Interface : TrueLow Property

Glossary Item Box

Description

Returns the true low.

Property type

Read-only property

Syntax

Visual Basic
Public Property TrueLow As Double

Return Type

True low, represented as Double

See Also

CQGTFlowBar Interface | CQGTFlowBar Members


%%PageItemTitle%%

TrueMid Property
CQGTFlowBar Interface : TrueMid Property

Glossary Item Box

Description

Returns the true midian.

Property type

Read-only property

Syntax

Visual Basic
Public Property TrueMid As Double

Return Type

True midian, represented as Double

See Also

CQGTFlowBar Interface | CQGTFlowBar Members


%%PageItemTitle%%

CQGTFlowBarsRequest Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents parameters used to formulate a TFlow bars request.

Object Model

CQGTFlowBarsRequest Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTFlowBarsRequest Members | RequestTFlowBars Method | CQGTFlowBars Collection


%%PageItemTitle%% $$Members$$

CQGTFlowBarsRequest Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Aggregation | Sets/gets the aggregation, which will be used to formulate this TFlow bars request. The default value for this property is tfaBars.
Public Property AggregationLevel | Sets/gets the aggregation level, which will be used to formulate this TFlow bars request. The default value for this property is 1.
Public Property Continuation | Sets/gets the continuation type, which will be used to formulate this TFlow bars request. The default value is tsctNoContinuation.
Public Property DaysBeforeExpiration | Sets/gets the number of days prior to expiration, when the rollover will occur, to be used to formulate this TFlow bars request. The default value for this property is 0.
Public Property DomAskVolumeLevel | Sets/gets the DOM ask volumes level, which will be used in the trade flow bars request.
Public Property DomBidVolumeLevel | Sets/gets the DOM bid volumes level, which will be used in the trade flow bars request.
Public Property EqualizeCloses | Gets/sets the equalize closes flag, which will be used to formulate this TFlow bars request. The default value for this property is True.
Public Property IncludeEnd | Gets/sets the include end flag, which will be used to formulate this TFlow bars request. The default value for this property is False.
Public Property RangeEnd | Gets/sets the range end, which will be used to formulate this TFlow bars request (required).
Public Property RangeStart | Gets/sets the range start, which will be used to formulate this TFlow bars request (required).
Public Property RecalcPeriod | Sets/gets the recalculation period (in seconds), which will be used to formulate the TFlow bars request. The default value for this property is 60.
Public Property SessionFlags | Sets/gets the session flags, which will be used to formulate this TFlow bars request. The default value for this property is sfUndefined.
Public Property SessionsFilter | Sets/gets the sessions filter, which will be used to formulate this TFlow bars request. The default value for this property is 0.
Public Property SubscriptionLevel | Sets/gets the subscription level, which will be used to formulate the TFlow bars request. The default value for this property is tslEachBar.
Public Property Symbol | Sets/gets the symbol, which will be used to formulate the TFlow bars request (required).
Public Property UpdatesEnabled | Gets/sets the updates enabled flag, which will be used in the TFlow bars request. The default value for this property is False.
Public Property UseAggressorFlag | Sets/gets the "Use Aggressor Flag" option, which will be used to formulate this TFlow bars request. Corresponds to "Use Aggressor Flag" TFlow study option. The default value for this property is False. Property affects CQGTFlowBar.AskVolume and CQGTFlowBar.BidVolume outputs.

See Also

CQGTFlowBarsRequest Interface | RequestTFlowBars Method | CQGTFlowBars Collection


%%PageItemTitle%%

Aggregation Property
CQGTFlowBarsRequest Interface : Aggregation Property

Glossary Item Box

Description

Sets/gets the aggregation, which will be used to formulate this TFlow bars request.

The default value for this property is tfaBars.

Property type

Read-write property

Syntax

Visual Basic
Public Property Aggregation As eTfAggregation

Return Type

Aggregation, represented as eTfAggregation

Remarks

See eTfAggregation enumeration for possible values.

See Also

CQGTFlowBarsRequest Interface | CQGTFlowBarsRequest Members | eTfAggregation Enumeration


%%PageItemTitle%%

AggregationLevel Property
CQGTFlowBarsRequest Interface : AggregationLevel Property

Glossary Item Box

Description

Sets/gets the aggregation level, which will be used to formulate this TFlow bars request.

The default value for this property is 1.

Property type

Read-write property

Syntax

Visual Basic
Public Property AggregationLevel As Long

Return Type

Aggregation level, represented as Long

See Also

CQGTFlowBarsRequest Interface | CQGTFlowBarsRequest Members


%%PageItemTitle%%

Continuation Property
CQGTFlowBarsRequest Interface : Continuation Property

Glossary Item Box

Description

Sets/gets the continuation type, which will be used to formulate this TFlow bars request.

The default value is tsctNoContinuation.

Property type

Read-write property

Syntax

Visual Basic
Public Property Continuation As eTimeSeriesContinuationType

Return Type

Continuation type, represented as eTimeSeriesContinuationType

Remarks

See eTimeSeriesContinuationType enumeration for possible values.

See Also

CQGTFlowBarsRequest Interface | CQGTFlowBarsRequest Members | eTimeSeriesContinuationType Enumeration


%%PageItemTitle%%

DaysBeforeExpiration Property
CQGTFlowBarsRequest Interface : DaysBeforeExpiration Property

Glossary Item Box

Description

Sets/gets the number of days prior to expiration, when the rollover will occur, to be used to formulate this TFlow bars request.

The default value for this property is 0.

Property type

Read-write property

Syntax

Visual Basic
Public Property DaysBeforeExpiration As Long

Return Type

Number of days prior to expiration, represented as Long

Remarks

This property is required and must have a positive value, when the Continuation property indicates an adjusted continuation.

If the continuation is not adjusted, this property has no effect.

See Also

CQGTFlowBarsRequest Interface | CQGTFlowBarsRequest Members | CQGTFlowBarsReques.Continuation Property


%%PageItemTitle%%

DomAskVolumeLevel Property
CQGTFlowBarsRequest Interface : DomAskVolumeLevel Property

Glossary Item Box

Description

Sets/gets the DOM ask volumes level, which will be used in the trade flow bars request.

Property type

Read-write property

Syntax

Visual Basic
Public Property DomAskVolumeLevel As eTFlowRequestDomVolumeLevel

Return Type

DOM ask volume level, represented as eTFlowRequestDomVolumeLevel

See Also

CQGTFlowBarsRequest Interface | CQGTFlowBarsRequest Members


%%PageItemTitle%%

DomBidVolumeLevel Property
CQGTFlowBarsRequest Interface : DomBidVolumeLevel Property

Glossary Item Box

Description

Sets/gets the DOM bid volumes level, which will be used in the trade flow bars request.

Property type

Read-write property

Syntax

Visual Basic
Public Property DomBidVolumeLevel As eTFlowRequestDomVolumeLevel

Return Type

DOM bid volume level, represented as eTFlowRequestDomVolumeLevel

See Also

CQGTFlowBarsRequest Interface | CQGTFlowBarsRequest Members


%%PageItemTitle%%

EqualizeCloses Property
CQGTFlowBarsRequest Interface : EqualizeCloses Property

Glossary Item Box

Description

Gets/sets the equalize closes flag, which will be used to formulate this TFlow bars request.

The default value for this property is True.

Property type

Read-write property

Syntax

Visual Basic
Public Property EqualizeCloses As Boolean

Return Type

True (default), if closes should be equalized; False, otherwise

See Also

CQGTFlowBarsRequest Interface | CQGTFlowBarsRequest Members | CQGTFlowBarsReques.Continuation Property


%%PageItemTitle%%

IncludeEnd Property
CQGTFlowBarsRequest Interface : IncludeEnd Property

Glossary Item Box

Description

Gets/sets the include end flag, which will be used to formulate this TFlow bars request.

The default value for this property is False.

Property type

Read-write property

Syntax

Visual Basic
Public Property IncludeEnd As Boolean

Return Type

True, if end should be included; False (default), otherwise

Remarks

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGTFlowBarsRequest Interface | CQGTFlowBarsRequest Members


%%PageItemTitle%%

RangeEnd Property
CQGTFlowBarsRequest Interface : RangeEnd Property

Glossary Item Box

Description

Gets/sets the range end, which will be used to formulate this TFlow bars request (required).

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeEnd As Variant

Return Type

Range end, represented as Variant

Remarks

Only Date and integer are allowed for types of RangeStart/RangeEnd properties.

  • If the type is Date, RangeStart/RangeEnd represent date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode). Non-timed bar requests process date/time range values with a precision of up to minutes.
  • All combinations of Date and integer can apply for these properties, except integer/Date.
  • If RangeEnd type is integer, then it represents the count of records prior to RangeStart to be requested, so it must be a negative value.
  • If RangeEnd is date, it must be further in time than RangeStart.

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGTFlowBarsRequest Interface | CQGTFlowBarsRequest Members


%%PageItemTitle%%

RangeStart Property
CQGTFlowBarsRequest Interface : RangeStart Property

Glossary Item Box

Description

Gets/sets the range start, which will be used to formulate this TFlow bars request (required).

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeStart As Variant

Return Type

Range start, represented as Variant

Remarks

Only Date and integer are allowed for types of RangeStart/RangeEnd properties:

  • All combinations of Date and Integer can apply for these properties, except Integer/Date.
  • If type is Date, RangeStart represents date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode). Non-timed bar requests process date/time range values with a precision of up to minutes.
  • If type is Integer, RangeStart represents the current condition's result number (0 is the current condition result number, negative numbers represent condition results in the past, positive numbers - in the future).
  • If the type of RangeStart is integer, it shall be 0 (denoting "current").

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGTFlowBarsRequest Interface | CQGTFlowBarsRequest Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

RecalcPeriod Property
CQGTFlowBarsRequest Interface : RecalcPeriod Property

Glossary Item Box

Description

Sets/gets the recalculation period (in seconds), which will be used to formulate the TFlow bars request.

The default value for this property is 60.

Property type

Read-write property

Syntax

Visual Basic
Public Property RecalcPeriod As Long

Return Type

Recalculation period in seconds, represented as Long

Remarks

Only positive values are allowed for this property.

See Also

CQGTFlowBarsRequest Interface | CQGTFlowBarsRequest Members


%%PageItemTitle%%

SessionFlags Property
CQGTFlowBarsRequest Interface : SessionFlags Property

Glossary Item Box

Description

Sets/gets the session flags, which will be used to formulate this TFlow bars request.

The default value for this property is sfUndefined.

Property type

Read-write property

Syntax

Visual Basic
Public Property SessionFlags As eSessionFlag

Return Type

Session flags, represented as eSessionFlag

Remarks

See eSessionFlag enumeration for possible values.

See Also

CQGTFlowBarsRequest Interface | CQGTFlowBarsRequest Members | eSessionFlag Enumeration


%%PageItemTitle%%

SessionsFilter Property
CQGTFlowBarsRequest Interface : SessionsFilter Property

Glossary Item Box

Description

Sets/gets the sessions filter, which will be used to formulate this TFlow bars request.

The default value for this property is 0.

Property type

Read-write property

Syntax

Visual Basic
Public Property SessionsFilter As Variant

Return Type

Sessions filter, represented as Variant

Remarks

Only String and integer are considered for SessionsFilter type.

  • If type is integer, SessionsFilter represents the session number.
    Special values: 0 represents primary sessions only, 31 represents all sessions.
  • If type is String, SessionsFilter represents custom session name.
    Special values: "primaryOnly" and "all" are equivalent to 0 and 31, respectively.
  • If other types are used for SessionsFilter, SessionsFilter is ignored.

See Also

CQGTFlowBarsRequest Interface | CQGTFlowBarsRequest Members


%%PageItemTitle%%

SubscriptionLevel Property
CQGTFlowBarsRequest Interface : SubscriptionLevel Property

Glossary Item Box

Description

Sets/gets the subscription level, which will be used to formulate the TFlow bars request.

The default value for this property is tslEachBar.

Property type

Read-write property

Syntax

Visual Basic
Public Property SubscriptionLevel As eTimeSeriesSubscriptionLevel

Return Type

Subscription level, represented as eTimeSeriesSubscriptionLevel

See Also

CQGTFlowBarsRequest Interface | CQGTFlowBarsRequest Members | eTimeSeriesSubscriptionLevel Enumeration


%%PageItemTitle%%

Symbol Property
CQGTFlowBarsRequest Interface : Symbol Property

Glossary Item Box

Description

Sets/gets the symbol, which will be used to formulate the TFlow bars request (required).

Property type

Read-write property

Syntax

Visual Basic
Public Property Symbol As String

Return Type

Symbol, represented as String

Remarks

The symbol cannot be empty string.

e.g. "EP"

See Also

CQGTFlowBarsRequest Interface | CQGTFlowBarsRequest Members


%%PageItemTitle%%

UpdatesEnabled Property
CQGTFlowBarsRequest Interface : UpdatesEnabled Property

Glossary Item Box

Description

Gets/sets the updates enabled flag, which will be used in the TFlow bars request.

The default value for this property is False.

Property type

Read-write property

Syntax

Visual Basic
Public Property UpdatesEnabled As Boolean

Return Type

True, if the updates are enabled; False (default), otherwise

See Also

CQGTFlowBarsRequest Interface | CQGTFlowBarsRequest Members


%%PageItemTitle%%

UseAggressorFlag Property
CQGTFlowBarsRequest Interface : UseAggressorFlag Property

Glossary Item Box

Description

Sets/gets the "Use Aggressor Flag" option, which will be used to formulate this TFlow bars request. Corresponds to "Use Aggressor Flag" TFlow study option.

The default value for this property is False.

Property affects CQGTFlowBar.AskVolume and CQGTFlowBar.BidVolume outputs.

Property type

Read-write property

Syntax

Visual Basic
Public Property UseAggressorFlag As Boolean

See Also

CQGTFlowBarsRequest Interface | CQGTFlowBarsRequest Members


%%PageItemTitle%%

CQGTick Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a single tick.

Object Model

CQGTick Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTick Members


%%PageItemTitle%% $$Members$$

CQGTick Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property ContributorId | Returns the unique identifier of the contributor.
Public Property ContributorIdCode | Returns the code of the contributor's unique identifier.
Public Property CorrectionType | Returns the correction type.
Public Property MarketState | Reserved for future use. Designated to return the market state. Currently this property will always return msNormal.
Public Property Price | Returns the price.
Public Property PriceType | Returns the price type.
Public Property SalesConditionCode | Returns the sales condition code.
Public Property SalesConditionLabel | Returns the sales condition text.
Public Property Timestamp | Returns the timestamp, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
Public Property Volume | Returns the volume.
Public Property VolumeFractional | Returns the fractional volume

See Also

CQGTick Interface


%%PageItemTitle%%

ContributorId Property
CQGTick Interface : ContributorId Property

Glossary Item Box

Description

Returns the unique identifier of the contributor.

Property type

Read-only property

Syntax

Visual Basic
Public Property ContributorId As String

Return Type

Contributor's unique identifier, represented as String

See Also

CQGTick Interface | CQGTick Members


%%PageItemTitle%%

ContributorIdCode Property
CQGTick Interface : ContributorIdCode Property

Glossary Item Box

Description

Returns the code of the contributor's unique identifier.

Property type

Read-only property

Syntax

Visual Basic
Public Property ContributorIdCode As Long

Return Type

Contributor's unique identifier code, represented as Long

See Also

CQGTick Interface | CQGTick Members


%%PageItemTitle%%

CorrectionType Property
CQGTick Interface : CorrectionType Property

Glossary Item Box

Description

Returns the correction type.

Property type

Read-only property

Syntax

Visual Basic
Public Property CorrectionType As eTickCorrectionType

Return Type

Correction type, represented as eTickCorrectionType

Remarks

See eTickCorrectionType for possible return values.

See Also

CQGTick Interface | CQGTick Members | eTickCorrectionType Enumeration


%%PageItemTitle%%

MarketState Property
CQGTick Interface : MarketState Property

Glossary Item Box

Description

Reserved for future use.

Designated to return the market state.

Currently this property will always return msNormal.

Property type

Read-only property

Syntax

Visual Basic
Public Property MarketState As eMarketState

Return Type

Market state, represented as eMarketState

Remarks

See eMarketState for possible return values.

See Also

CQGTick Interface | CQGTick Members


%%PageItemTitle%%

Price Property
CQGTick Interface : Price Property

Glossary Item Box

Description

Returns the price.

Property type

Read-only property

Syntax

Visual Basic
Public Property Price As Double

Return Type

Price, represented as Double

See Also

CQGTick Interface | CQGTick Members


%%PageItemTitle%%

PriceType Property
CQGTick Interface : PriceType Property

Glossary Item Box

Description

Returns the price type.

Property type

Read-only property

Syntax

Visual Basic
Public Property PriceType As eTickPriceType

Return Type

Price type, represented as eTickPriceType

Remarks

See eTickPriceType for possible return values.

See Also

CQGTick Interface | CQGTick Members | eTickPriceType Enumeration


%%PageItemTitle%%

SalesConditionCode Property
CQGTick Interface : SalesConditionCode Property

Glossary Item Box

Description

Returns the sales condition code.

Property type

Read-only property

Syntax

Visual Basic
Public Property SalesConditionCode As Long

Return Type

Sales condition code, represented as Long

See Also

CQGTick Interface | CQGTick Members


%%PageItemTitle%%

SalesConditionLabel Property
CQGTick Interface : SalesConditionLabel Property

Glossary Item Box

Description

Returns the sales condition text.

Property type

Read-only property

Syntax

Visual Basic
Public Property SalesConditionLabel As String

Return Type

Sales condition text, represented as String

See Also

CQGTick Interface | CQGTick Members


%%PageItemTitle%%

Timestamp Property
CQGTick Interface : Timestamp Property

Glossary Item Box

Description

Returns the timestamp, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

Property type

Read-only property

Syntax

Visual Basic
Public Property Timestamp As Date

Return Type

Timestamp, represented as Date

See Also

CQGTick Interface | CQGTick Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

Volume Property
CQGTick Interface : Volume Property

Glossary Item Box

Description

Returns the volume.

Property type

Read-only property

Syntax

Visual Basic
Public Property Volume As Long

Return Type

Volume, represented as Double

See Also

CQGTick Interface | CQGTick Members


%%PageItemTitle%%

VolumeFractional Property
CQGTick Interface : VolumeFractional Property

Glossary Item Box

Description

Returns the fractional volume

Property type

Read-only property

Syntax

Visual Basic
Public Property VolumeFractional As Decimal

See Also

CQGTick Interface | CQGTick Members


%%PageItemTitle%%

CQGTicksRequest Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents parameters used to formulate a ticks request.

Object Model

CQGTicksRequest Interface

Remarks

The ticks are available for "native" user defined strategies (UDS) only. If ticks are requested for "synthetic" UDS, then new ticks notifications come as soon as UDS become "native" one.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTicksRequest Members


%%PageItemTitle%% $$Members$$

CQGTicksRequest Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Limit | Controls the ticks count limit in resulted ticks collection. There is no limit by default.
Public Property RangeEnd | Gets/sets the range end, which will be used to formulate the ticks request (required).
Public Property RangeStart | Gets/sets the range start, which will be used to formulate the ticks request (required).
Public Property SessionsFilter | Sets/gets the sessions filter, which will be used to formulate the ticks request. The default value for this property is 0.
Public Property Symbol | Sets/gets the symbol, which will be used to formulate the ticks request (required).
Public Property TickFilter | Returns the tick filter, which will be used to formulate the ticks request. The default value is tfDefault.
Public Property Type | Returns the ticks request type.

See Also

CQGTicksRequest Interface


%%PageItemTitle%%

Limit Property
CQGTicksRequest Interface : Limit Property

Glossary Item Box

Description

Controls the ticks count limit in resulted ticks collection.

There is no limit by default.

Property type

Read-write property

Syntax

Visual Basic
Public Property Limit As Long

Remarks

If the ticks count in resulted CQGTicks collection is greater than the property value, then the first tick in the collection is removed and TicksRemoved event is fired.

If the property is not set (by default), then the collection size is not limited.

Available since 19x3 CQG IC version.

See Also

CQGTicksRequest Interface | CQGTicksRequest Members


%%PageItemTitle%%

RangeEnd Property
CQGTicksRequest Interface : RangeEnd Property

Glossary Item Box

Description

Gets/sets the range end, which will be used to formulate the ticks request (required).

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeEnd As Date

Return Type

Range end, represented as Date

Remarks

RangeStart and RangeEnd specify the time range, for which data is requested, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

  • If Type is trtTimeRange, both RangeStart and RangeEnd must be provided, RangeEnd must be earlier than the current time and RangeStart must be earlier or equal RangeEnd.
  • If Type is trtSinceTime or trtSinceTimeNotify, RangeStart must be provided and it must be earlier than the current time.
  • If Type is trtCurrentNotify, neither RangeStart nor Range end needs to be provided.

See Also

CQGTicksRequest Interface | CQGTicksRequest Members | CQGAPIConfig.TimeZoneCode Property | eTicksRequestType Enumeration


%%PageItemTitle%%

RangeStart Property
CQGTicksRequest Interface : RangeStart Property

Glossary Item Box

Description

Gets/sets the range start, which will be used to formulate the ticks request (required).

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeStart As Date

Return Type

Range start, represented as Date

Remarks

RangeStart and RangeEnd specify the time range, for which data is requested, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

  • If Type is trtTimeRange, both RangeStart and RangeEnd must be provided, RangeEnd must be earlier than the current time and RangeStart must be earlier or equal RangeEnd.
  • If Type is trtSinceTime or trtSinceTimeNotify, RangeStart must be provided and it must be earlier than the current time.
  • If Type is trtCurrentNotify, neither RangeStart nor Range end needs to be provided.

See Also

CQGTicksRequest Interface | CQGTicksRequest Members | CQGAPIConfig.TimeZoneCode Property | eTicksRequestType Enumeration


%%PageItemTitle%%

SessionsFilter Property
CQGTicksRequest Interface : SessionsFilter Property

Glossary Item Box

Description

Sets/gets the sessions filter, which will be used to formulate the ticks request.

The default value for this property is 0.

Property type

Read-write property

Syntax

Visual Basic
Public Property SessionsFilter As Long

Return Type

Sessions filter—in the form of a bitmask of session numbers, represented as Long

Remarks

Special values:

  • 0 represents primary session only
  • 31 represents all sessions

See Also

CQGTicksRequest Interface | CQGTicksRequest Members


%%PageItemTitle%%

Symbol Property
CQGTicksRequest Interface : Symbol Property

Glossary Item Box

Description

Sets/gets the symbol, which will be used to formulate the ticks request (required).

Property type

Read-write property

Syntax

Visual Basic
Public Property Symbol As String

Return Type

Symbol, represented as String

Remarks

This property cannot be an empty string.

e.g. "EP"

See Also

CQGTicksRequest Interface | CQGTicksRequest Members


%%PageItemTitle%%

TickFilter Property
CQGTicksRequest Interface : TickFilter Property

Glossary Item Box

Description

Returns the tick filter, which will be used to formulate the ticks request.

The default value is tfDefault.

Property type

Read-write property

Syntax

Visual Basic
Public Property TickFilter As eTickFilter

Return Type

Tick filter, represented as eTickFilter

See Also

CQGTicksRequest Interface | CQGTicksRequest Members | eTickFilter Enumeration


%%PageItemTitle%%

Type Property
CQGTicksRequest Interface : Type Property

Glossary Item Box

Description

Returns the ticks request type.

Property type

Read-write property

Syntax

Visual Basic
Public Property Type As eTicksRequestType

Return Type

The ticks request type, represented as eTicksRequestType

See Also

CQGTicksRequest Interface | CQGTicksRequest Members


%%PageItemTitle%%

CQGTimedBar Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a single timed bar.

Object Model

CQGTimedBar Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTimedBar Members | CQGTimedBars Collection | CQGTimedBarsRequest Interface | RequestTimedBars Method


%%PageItemTitle%% $$Members$$

CQGTimedBar Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property ActualVolume | Returns the actual volume of the timed bar.
Public Property ActualVolumeFractional | Returns the fractional actual volume
Public Property AskFlagVolume | Trades volume with 'buy' aggressor flag
Public Property AskVolume | Returns the ask volume of the timed bar.
Public Property AskVolumeFractional | Returns the fractional ask volume
Public Property Avg | Returns the average value of the timed bar.
Public Property BidFlagVolume | Trades volume with 'sell' aggressor flag
Public Property BidVolume | Returns the bid volume of the timed bar.
Public Property BidVolumeFractional | Returns the fractional bid volume
Public Property Close | Returns the close value of the timed bar.
Public Property CommodityOpenInterest | Returns the commodity open interest
Public Property CommodityTickVolume | Returns the commodity tick volume
Public Property CommodityVolume | Returns the commodity volume
Public Property CommodityVolumeFractional | Returns the fractional commodity volume
Public Property ContractOpenInterest | Returns the contract open interest
Public Property ContractTickVolume | Returns the contract tick volume
Public Property ContractVolume | Returns the contract volume
Public Property ContractVolumeFractional | Returns the fractional contract volume
Public Property High | Returns the high value of the timed bar.
Public Property HLC3 | Returns the ((High+Low+Close)/3) value of the timed bar.
Public Property Low | Returns the low value of the timed bar.
Public Property Mid | Returns the mid-point value of the timed bar.
Public Property Open | Returns the open value of the timed bar.
Public Property OpenInterest | Returns the open intererst of the timed bar.
Public Property Range | Returns the range value of the timed bar.
Public Property TickVolume | Returns the tick volume of the timed bar.
Public Property Timestamp | Returns the timestamp, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
Public Property TrueHigh | Returns the true high value of the timed bar.
Public Property TrueLow | Returns the true low value of the timed bar.
Public Property TrueRange | Returns the true range value of the timed bar.

See Also

CQGTimedBar Interface | CQGTimedBars Collection | CQGTimedBarsRequest Interface | RequestTimedBars Method


%%PageItemTitle%%

ActualVolume Property
CQGTimedBar Interface : ActualVolume Property

Glossary Item Box

Description

Returns the actual volume of the timed bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property ActualVolume As Long

Return Type

Actual volume, represented as Long

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

ActualVolumeFractional Property
CQGTimedBar Interface : ActualVolumeFractional Property

Glossary Item Box

Description

Returns the fractional actual volume

Property type

Read-only property

Syntax

Visual Basic
Public Property ActualVolumeFractional As Double

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

AskFlagVolume Property
CQGTimedBar Interface : AskFlagVolume Property

Glossary Item Box

Description

Trades volume with 'buy' aggressor flag

Property type

Read-only property

Syntax

Visual Basic
Public Property AskFlagVolume As Double

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

AskVolume Property
CQGTimedBar Interface : AskVolume Property

Glossary Item Box

Description

Returns the ask volume of the timed bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property AskVolume As Long

Return Type

Ask volume, represented as Long

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

AskVolumeFractional Property
CQGTimedBar Interface : AskVolumeFractional Property

Glossary Item Box

Description

Returns the fractional ask volume

Property type

Read-only property

Syntax

Visual Basic
Public Property AskVolumeFractional As Double

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

Avg Property
CQGTimedBar Interface : Avg Property

Glossary Item Box

Description

Returns the average value of the timed bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property Avg As Double

Return Type

Average, represented as Double

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

BidFlagVolume Property
CQGTimedBar Interface : BidFlagVolume Property

Glossary Item Box

Description

Trades volume with 'sell' aggressor flag

Property type

Read-only property

Syntax

Visual Basic
Public Property BidFlagVolume As Double

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

BidVolume Property
CQGTimedBar Interface : BidVolume Property

Glossary Item Box

Description

Returns the bid volume of the timed bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property BidVolume As Long

Return Type

Bid volume, represented as Long

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

BidVolumeFractional Property
CQGTimedBar Interface : BidVolumeFractional Property

Glossary Item Box

Description

Returns the fractional bid volume

Property type

Read-only property

Syntax

Visual Basic
Public Property BidVolumeFractional As Double

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

Close Property
CQGTimedBar Interface : Close Property

Glossary Item Box

Description

Returns the close value of the timed bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property Close As Double

Return Type

Close, represented as Double

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

CommodityOpenInterest Property
CQGTimedBar Interface : CommodityOpenInterest Property

Glossary Item Box

Description

Returns the commodity open interest

Property type

Read-only property

Syntax

Visual Basic
Public Property CommodityOpenInterest As Long

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

CommodityTickVolume Property
CQGTimedBar Interface : CommodityTickVolume Property

Glossary Item Box

Description

Returns the commodity tick volume

Property type

Read-only property

Syntax

Visual Basic
Public Property CommodityTickVolume As Long

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

CommodityVolume Property
CQGTimedBar Interface : CommodityVolume Property

Glossary Item Box

Description

Returns the commodity volume

Property type

Read-only property

Syntax

Visual Basic
Public Property CommodityVolume As Long

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

CommodityVolumeFractional Property
CQGTimedBar Interface : CommodityVolumeFractional Property

Glossary Item Box

Description

Returns the fractional commodity volume

Property type

Read-only property

Syntax

Visual Basic
Public Property CommodityVolumeFractional As Double

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

ContractOpenInterest Property
CQGTimedBar Interface : ContractOpenInterest Property

Glossary Item Box

Description

Returns the contract open interest

Property type

Read-only property

Syntax

Visual Basic
Public Property ContractOpenInterest As Long

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

ContractTickVolume Property
CQGTimedBar Interface : ContractTickVolume Property

Glossary Item Box

Description

Returns the contract tick volume

Property type

Read-only property

Syntax

Visual Basic
Public Property ContractTickVolume As Long

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

ContractVolume Property
CQGTimedBar Interface : ContractVolume Property

Glossary Item Box

Description

Returns the contract volume

Property type

Read-only property

Syntax

Visual Basic
Public Property ContractVolume As Long

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

ContractVolumeFractional Property
CQGTimedBar Interface : ContractVolumeFractional Property

Glossary Item Box

Description

Returns the fractional contract volume

Property type

Read-only property

Syntax

Visual Basic
Public Property ContractVolumeFractional As Double

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

High Property
CQGTimedBar Interface : High Property

Glossary Item Box

Description

Returns the high value of the timed bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property High As Double

Return Type

High, represented as Double

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

HLC3 Property
CQGTimedBar Interface : HLC3 Property

Glossary Item Box

Description

Returns the ((High+Low+Close)/3) value of the timed bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property HLC3 As Double

Return Type

Result of ((High+Low+Close)/3), represented as Double

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

Low Property
CQGTimedBar Interface : Low Property

Glossary Item Box

Description

Returns the low value of the timed bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property Low As Double

Return Type

Low, represented as Double

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

Mid Property
CQGTimedBar Interface : Mid Property

Glossary Item Box

Description

Returns the mid-point value of the timed bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property Mid As Double

Return Type

Mid-point, represented as Double

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

Open Property
CQGTimedBar Interface : Open Property

Glossary Item Box

Description

Returns the open value of the timed bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property Open As Double

Return Type

Open, represented as Double

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

OpenInterest Property
CQGTimedBar Interface : OpenInterest Property

Glossary Item Box

Description

Returns the open intererst of the timed bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property OpenInterest As Long

Return Type

Open interest, represented as Long

Remarks

The open interest value is updated daily—typically overnight—when exchanges report this number. Therefore, no real-time data is available for this property.

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

Range Property
CQGTimedBar Interface : Range Property

Glossary Item Box

Description

Returns the range value of the timed bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property Range As Double

Return Type

Range, represented as Double

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

TickVolume Property
CQGTimedBar Interface : TickVolume Property

Glossary Item Box

Description

Returns the tick volume of the timed bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property TickVolume As Long

Return Type

Tick volume, represented as Long

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

Timestamp Property
CQGTimedBar Interface : Timestamp Property

Glossary Item Box

Description

Returns the timestamp, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

Property type

Read-only property

Syntax

Visual Basic
Public Property Timestamp As Date

Return Type

Timestamp, represented as Date

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

TrueHigh Property
CQGTimedBar Interface : TrueHigh Property

Glossary Item Box

Description

Returns the true high value of the timed bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property TrueHigh As Double

Return Type

True High, represented as Double

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

TrueLow Property
CQGTimedBar Interface : TrueLow Property

Glossary Item Box

Description

Returns the true low value of the timed bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property TrueLow As Double

Return Type

True Low, represented as Double

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

TrueRange Property
CQGTimedBar Interface : TrueRange Property

Glossary Item Box

Description

Returns the true range value of the timed bar.

Property type

Read-only property

Syntax

Visual Basic
Public Property TrueRange As Double

Return Type

True Range, represented as Double

See Also

CQGTimedBar Interface | CQGTimedBar Members


%%PageItemTitle%%

CQGTimedBarsRequest Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents parameters used to formulate a timed bars request.

Object Model

CQGTimedBarsRequest Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTimedBarsRequest Members | RequestTimedBars Method | CQGTimedBars Collection


%%PageItemTitle%% $$Members$$

CQGTimedBarsRequest Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method ExcludeAllOutputs | Excludes all outputs from timed bars request.
Public Method IncludeOutput | Includes or excludes the specified output in the requested timed bars.
Public Method IsOutputIncluded | Returns whether the specified output is currently included or not.

Public Properties

Public Property Continuation | Sets/gets the continuation type, which will be used to formulate the timed bars request. The default value is tsctNoContinuation.
Public Property DailyBarClose | Returns the daily bar's close setting which will be used in timed bars request
Public Property DaysBeforeExpiration | Sets/gets the number of days prior to expiration, when the rollover will occur, to be used to formulate the timed bars request. The default value for this property is 0.
Public Property EqualizeCloses | Returns the equalize closes flag which will be used in timed bars request
Public Property HistoricalPeriod | Gets/sets the historical period, which will be used to formulate the timed bars request. The default value for this property is hpUndefined.
Public Property IgnoreEventsOnHistoricalBars | Returns the flag indicating whether events on historical bars should be ignored or not
Public Property IncludeEnd | Sets/gets the include end flag, which will be used to formulate the timed bars request. The default value for this property is False.
Public Property IntradayPeriod | Sets/gets the intraday period, which will be used to formulate the timed bars request.
Public Property RangeEnd | Gets/sets the range end, which will be used to formulate the timed bars request (required).
Public Property RangeStart | Gets/sets the range start, which will be used to formulate the timed bars request (required).
Public Property SessionFlags | Sets/gets the session flags, which will be used to formulate the timed bars request. The default value for this property is sfUndefined.
Public Property SessionsFilter | Sets/gets the sessions filter, which will be used to formulate the timed bars request. The default value for this property is 0.
Public Property Symbol | Sets/gets the symbol, which will be used to formulate the timed bars request (required).
Public Property TickFilter | Returns the tick filter, which will be used to formulate the timed bars request. The default value is tfDefault.
Public Property UpdatesEnabled | Gets/sets the updates enabled flag, which will be used to formulate the timed bars request. The default value for this property is False.

See Also

CQGTimedBarsRequest Interface | RequestTimedBars Method | CQGTimedBars Collection


%%PageItemTitle%%

ExcludeAllOutputs Method
CQGTimedBarsRequest Interface : ExcludeAllOutputs Method

Glossary Item Box

Description

Excludes all outputs from timed bars request.

Syntax

Visual Basic
Public Sub ExcludeAllOutputs()

Remarks

All output types are included by default.

See Also

CQGTimedBarsRequest Interface | CQGTimedBarsRequest Members


%%PageItemTitle%%

IncludeOutput Method
timed_bar_output

Timed bar output to include or exclude

include_output

If True, the output specified in timed_bar_output will be included

If False, the output specified in timed_bar_output will be excluded

CQGTimedBarsRequest Interface : IncludeOutput Method

Glossary Item Box

Description

Includes or excludes the specified output in the requested timed bars.

Syntax

Visual Basic
Public Sub IncludeOutput( _
   ByVal timed_bar_output As eTimedBarsRequestOutputs, _
   ByVal include_output As Boolean _
)

Parameters

timed_bar_output
Value Description
tbrActualVolume

Actual volume

tbrAskFlagVolume

Volume of trade with 'buy' aggressor flag

tbrAskVolume

Ask volume

tbrBidFlagVolume

Volume of trade with 'sell' aggressor flag

tbrBidVolume

Bid volume

tbrCommodityOpenInterest

Commodity open interest

tbrCommodityTickVolume

Commodity tick volume

tbrCommodityVolume

Commodity volume

tbrContractOpenInterest

Contract open interest

tbrContractTickVolume

Contract tick volume

tbrContractVolume

Contract volume

tbrOpenInterest

Open interest

tbrTickVolume

Tick volume

Timed bar output to include or exclude

include_output

If True, the output specified in timed_bar_output will be included

If False, the output specified in timed_bar_output will be excluded

Remarks

All output types are included by default.

See Also

CQGTimedBarsRequest Interface | CQGTimedBarsRequest Members


%%PageItemTitle%%

IsOutputIncluded Method
timed_bar_output

Timed bar request output to be checked

CQGTimedBarsRequest Interface : IsOutputIncluded Method

Glossary Item Box

Description

Returns whether the specified output is currently included or not.

Syntax

Visual Basic
Public Function IsOutputIncluded( _
   ByVal timed_bar_output As eTimedBarsRequestOutputs _
) As Boolean

Parameters

timed_bar_output
Value Description
tbrActualVolume

Actual volume

tbrAskFlagVolume

Volume of trade with 'buy' aggressor flag

tbrAskVolume

Ask volume

tbrBidFlagVolume

Volume of trade with 'sell' aggressor flag

tbrBidVolume

Bid volume

tbrCommodityOpenInterest

Commodity open interest

tbrCommodityTickVolume

Commodity tick volume

tbrCommodityVolume

Commodity volume

tbrContractOpenInterest

Contract open interest

tbrContractTickVolume

Contract tick volume

tbrContractVolume

Contract volume

tbrOpenInterest

Open interest

tbrTickVolume

Tick volume

Timed bar request output to be checked

Return Type

True, if the specified output is included

False, if excluded

Remarks

All output types are included by default.

See Also

CQGTimedBarsRequest Interface | CQGTimedBarsRequest Members


%%PageItemTitle%%

Continuation Property
CQGTimedBarsRequest Interface : Continuation Property

Glossary Item Box

Description

Sets/gets the continuation type, which will be used to formulate the timed bars request.

The default value is tsctNoContinuation.

Property type

Read-write property

Syntax

Visual Basic
Public Property Continuation As eTimeSeriesContinuationType

Return Type

Continuation type, represented as eTimeSeriesContinuationType

Remarks

See eTimeSeriesContinuationType enumeration for possible values.

See Also

CQGTimedBarsRequest Interface | CQGTimedBarsRequest Members | eTimeSeriesContinuationType Enumeration


%%PageItemTitle%%

DailyBarClose Property
CQGTimedBarsRequest Interface : DailyBarClose Property

Glossary Item Box

Description

Returns the daily bar's close setting which will be used in timed bars request

Property type

Read-write property

Syntax

Visual Basic
Public Property DailyBarClose As eDailyBarClose

See Also

CQGTimedBarsRequest Interface | CQGTimedBarsRequest Members


%%PageItemTitle%%

DaysBeforeExpiration Property
CQGTimedBarsRequest Interface : DaysBeforeExpiration Property

Glossary Item Box

Description

Sets/gets the number of days prior to expiration, when the rollover will occur, to be used to formulate the timed bars request.

The default value for this property is 0.

Property type

Read-write property

Syntax

Visual Basic
Public Property DaysBeforeExpiration As Long

Return Type

Number of days prior to expiration, represented as Long

Remarks

This property is required and must have a positive value, when the Continuation property indicates an adjusted continuation.

If the continuation is not adjusted, this property has no effect.

See Also

CQGTimedBarsRequest Interface | CQGTimedBarsRequest Members


%%PageItemTitle%%

EqualizeCloses Property
CQGTimedBarsRequest Interface : EqualizeCloses Property

Glossary Item Box

Description

Returns the equalize closes flag which will be used in timed bars request

Property type

Read-write property

Syntax

Visual Basic
Public Property EqualizeCloses As Boolean

Return Type

True (default), if closes should be equalized; False, otherwise

Remarks

This property has effect only when the Continuation property indicates an active or adjusted continuation.

See Also

CQGTimedBarsRequest Interface | CQGTimedBarsRequest Members | CQGTimedBarsRequest.Continuation Property


%%PageItemTitle%%

HistoricalPeriod Property
CQGTimedBarsRequest Interface : HistoricalPeriod Property

Glossary Item Box

Description

Gets/sets the historical period, which will be used to formulate the timed bars request.

The default value for this property is hpUndefined.

Property type

Read-write property

Syntax

Visual Basic
Public Property HistoricalPeriod As eHistoricalPeriod

Return Type

Historical period, represented as eHistoricalPeriod

See Also

CQGTimedBarsRequest Interface | CQGTimedBarsRequest Members | eHistoricalPeriod Enumeration


%%PageItemTitle%%

IgnoreEventsOnHistoricalBars Property
CQGTimedBarsRequest Interface : IgnoreEventsOnHistoricalBars Property

Glossary Item Box

Description

Returns the flag indicating whether events on historical bars should be ignored or not

Property type

Read-write property

Syntax

Visual Basic
Public Property IgnoreEventsOnHistoricalBars As Boolean

See Also

CQGTimedBarsRequest Interface | CQGTimedBarsRequest Members


%%PageItemTitle%%

IncludeEnd Property
CQGTimedBarsRequest Interface : IncludeEnd Property

Glossary Item Box

Description

Sets/gets the include end flag, which will be used to formulate the timed bars request.

The default value for this property is False.

Property type

Read-write property

Syntax

Visual Basic
Public Property IncludeEnd As Boolean

Return Type

True, if end should be included; False (default), otherwise

Remarks

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGTimedBarsRequest Interface | CQGTimedBarsRequest Members


%%PageItemTitle%%

IntradayPeriod Property
CQGTimedBarsRequest Interface : IntradayPeriod Property

Glossary Item Box

Description

Sets/gets the intraday period, which will be used to formulate the timed bars request.

Property type

Read-write property

Syntax

Visual Basic
Public Property IntradayPeriod As Long

Remarks

Intraday period, represented as Long

See Also

CQGTimedBarsRequest Interface | CQGTimedBarsRequest Members


%%PageItemTitle%%

RangeEnd Property
CQGTimedBarsRequest Interface : RangeEnd Property

Glossary Item Box

Description

Gets/sets the range end, which will be used to formulate the timed bars request (required).

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeEnd As Variant

Remarks

Only Date and integer are allowed for types of RangeStart/RangeEnd properties.

  • If the type is Date, RangeStart/RangeEnd represent date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode). Non-timed bar requests process date/time range values with a precision of up to minutes.
  • All combinations of Date and integer can apply for these properties, except integer/Date.
  • If RangeEnd type is integer, then it represents the count of records prior to RangeStart to be requested, so it must be a negative value.
  • If RangeEnd is date, it must be further in time than RangeStart.

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGTimedBarsRequest Interface | CQGTimedBarsRequest Members


%%PageItemTitle%%

RangeStart Property
CQGTimedBarsRequest Interface : RangeStart Property

Glossary Item Box

Description

Gets/sets the range start, which will be used to formulate the timed bars request (required).

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeStart As Variant

Remarks

Only Date and integer are allowed for types of RangeStart/RangeEnd properties:

  • All combinations of Date and Integer can apply for these properties, except Integer/Date.
  • If type is Date, RangeStart represents date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode). Non-timed bar requests process date/time range values with a precision of up to minutes.
  • If type is Integer, RangeStart represents the current condition's result number (0 is the current condition result number, negative numbers represent condition results in the past, positive numbers - in the future).
  • If the type of RangeStart is integer, it shall be 0 (denoting "current").

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGTimedBarsRequest Interface | CQGTimedBarsRequest Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

SessionFlags Property
CQGTimedBarsRequest Interface : SessionFlags Property

Glossary Item Box

Description

Sets/gets the session flags, which will be used to formulate the timed bars request.

The default value for this property is sfUndefined.

Property type

Read-write property

Syntax

Visual Basic
Public Property SessionFlags As eSessionFlag

Return Type

Session flags, represented as eSessionFlag

Remarks

See the eSessionFlag enumeration for possible values.

See Also

CQGTimedBarsRequest Interface | CQGTimedBarsRequest Members | eSessionFlag Enumeration


%%PageItemTitle%%

SessionsFilter Property
CQGTimedBarsRequest Interface : SessionsFilter Property

Glossary Item Box

Description

Sets/gets the sessions filter, which will be used to formulate the timed bars request.

The default value for this property is 0.

Property type

Read-write property

Syntax

Visual Basic
Public Property SessionsFilter As Variant

Return Type

Sessions filter, represented as Variant

Remarks

Only String and integer are considered for SessionsFilter type.

  • If type is integer, SessionsFilter represents session number.
    Special values: 0 represents primary sessions only, 31 represents all sessions.
  • If type is String, SessionsFilter represents custom session name.
    Special values: "all" and "primaryOnly" are equivalent to 31 and 0, respectively.
  • If other types are used for SessionsFilter, SessionsFilter is ignored.

See Also

CQGTimedBarsRequest Interface | CQGTimedBarsRequest Members


%%PageItemTitle%%

Symbol Property
CQGTimedBarsRequest Interface : Symbol Property

Glossary Item Box

Description

Sets/gets the symbol, which will be used to formulate the timed bars request (required).

Property type

Read-write property

Syntax

Visual Basic
Public Property Symbol As String

Return Type

The request symbol, represented as String

Remarks

The symbol cannot be empty string.

e.g. "EP"

See Also

CQGTimedBarsRequest Interface | CQGTimedBarsRequest Members


%%PageItemTitle%%

TickFilter Property
CQGTimedBarsRequest Interface : TickFilter Property

Glossary Item Box

Description

Returns the tick filter, which will be used to formulate the timed bars request.

The default value is tfDefault.

Property type

Read-write property

Syntax

Visual Basic
Public Property TickFilter As eTickFilter

Return Type

Tick filter, represented as eTickFilter

Remarks

The tick filter is applicable only for the intraday bars and it will be ignored when used with historical bars.

See Also

CQGTimedBarsRequest Interface | CQGTimedBarsRequest Members


%%PageItemTitle%%

UpdatesEnabled Property
CQGTimedBarsRequest Interface : UpdatesEnabled Property

Glossary Item Box

Description

Gets/sets the updates enabled flag, which will be used to formulate the timed bars request.

The default value for this property is False.

Property type

Read-write property

Syntax

Visual Basic
Public Property UpdatesEnabled As Boolean

Return Type

True, if the updates are enabled; False (default), otherwise

See Also

CQGTimedBarsRequest Interface | CQGTimedBarsRequest Members


%%PageItemTitle%%

CQGTrade Interface
See Also Members Send Feedback

Glossary Item Box

Description

The CQGTrade interface encapsulates all the information on a trade.

Object Model

CQGTrade Interface

Remarks

The availability of information on trades is controlled by PositionDetailing setting of CQG API Configuration.

Example

See the usage of CQGTrade object in the AccountChanged event's example section.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTrade Members


%%PageItemTitle%% $$Members$$

CQGTrade Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property GroupID | Returns the group identifier of the current trade, if any.
Public Property IsMatched | Returns the trade's matched/not matched status.
Public Property Price | Returns the trade price.
Public Property Quantity | Returns the trade's quantity.
Public Property QuantityFractional | Gets trade fractional quantity, positive for long, negative for short
Public Property ServerTimestamp | Returns the server timestamp of last trade update (server time, converted to configured time zone).
Public Property Side | Returns the trade's side.
Public Property Timestamp | Returns the last response reception timestamp. When a property is updated, CQG API records the information reception time in the Timestamp property (using local time).

See Also

CQGTrade Interface


%%PageItemTitle%%

GroupID Property
CQGTrade Interface : GroupID Property

Glossary Item Box

Description

Returns the group identifier of the current trade, if any.

Property type

Read-only property

Syntax

Visual Basic
Public Property GroupID As Long

Return Type

Group identifier represented as Long

Remarks

Trades are divided in groups by matching, i.e. all trades matched with each other have the same GroupID.

If the trade is open (i.e. not matched) its GroupID is 0.

Example

See the usage of CQGTrade properties in the AccountChanged event's example section.

See Also

CQGTrade Interface | CQGTrade Members


%%PageItemTitle%%

IsMatched Property
CQGTrade Interface : IsMatched Property

Glossary Item Box

Description

Returns the trade's matched/not matched status.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsMatched As Boolean

Return Type

True if the trade is matched, False otherwise

Remarks

If this property value is True the trade is present in position's MatchedTrades collection and its GroupID is not 0.

If it is False, the trade is present in positions OpenTrades collection and its GroupID property is 0.

Example

See the usage of CQGTrade properties in the AccountChanged event's example section.

See Also

CQGTrade Interface | CQGTrade Members


%%PageItemTitle%%

Price Property
CQGTrade Interface : Price Property

Glossary Item Box

Description

Returns the trade price.

Property type

Read-only property

Syntax

Visual Basic
Public Property Price As Double

Return Type

Trade price represented as Double

Example

See the usage of CQGTrade properties in the AccountChanged event's example section.

See Also

CQGTrade Interface | CQGTrade Members


%%PageItemTitle%%

Quantity Property
CQGTrade Interface : Quantity Property

Glossary Item Box

Description

Returns the trade's quantity.

Property type

Read-only property

Syntax

Visual Basic
Public Property Quantity As Long

Return Type

The quantity represented as Long.

Depending on UseOrderSide setting of CQG API Configuration the quantity can be signed or unsigned.

Remarks

If UseOrderSide is set to True, the quantity is always positive and the side is shown by the trade's Side property.

If UseOrderSide is set to False, the quantity is:

  • positive in case of a buy trade
  • negative in case of a sell trade.

Example

See the usage of CQGTrade properties in the AccountChanged event's example section.

See Also

CQGTrade Interface | CQGTrade Members


%%PageItemTitle%%

QuantityFractional Property
CQGTrade Interface : QuantityFractional Property

Glossary Item Box

Description

Gets trade fractional quantity, positive for long, negative for short

Property type

Read-only property

Syntax

Visual Basic
Public Property QuantityFractional As Decimal

See Also

CQGTrade Interface | CQGTrade Members


%%PageItemTitle%%

ServerTimestamp Property
CQGTrade Interface : ServerTimestamp Property

Glossary Item Box

Description

Returns the server timestamp of last trade update (server time, converted to configured time zone).

Property type

Read-only property

Syntax

Visual Basic
Public Property ServerTimestamp As Date

Return Type

Date variable containing the server timestamp

Remarks

The timestamp is converted to the timezone, previously configured by the user.

If no timezone configuration was made the timestamp is converted to UTC.

Example

See the usage of CQGTrade properties in the AccountChanged event's example section.

See Also

CQGTrade Interface | CQGTrade Members


%%PageItemTitle%%

Side Property
CQGTrade Interface : Side Property

Glossary Item Box

Description

Returns the trade's side.

Property type

Read-only property

Syntax

Visual Basic
Public Property Side As eOrderSide

Return Type

The trade's side represented as eOrderSide.

Depending on UseOrderSide setting of CQG API Configuration the side can be undefined.

Remarks

If UseOrderSide is set to True, the property value is osdBuy in case of buy trade and osdSell in case of a sell.

If UseOrderSide is set to False, the property value is osdUndefined and the side is reflected by trade's quantity.

Example

See the usage of CQGTrade properties in the AccountChanged event's example section.

See Also

CQGTrade Interface | CQGTrade Members


%%PageItemTitle%%

Timestamp Property
CQGTrade Interface : Timestamp Property

Glossary Item Box

Description

Returns the last response reception timestamp.

When a property is updated, CQG API records the information reception time in the Timestamp property (using local time).

Property type

Read-only property

Syntax

Visual Basic
Public Property Timestamp As Date

Return Type

Date variable containing the local timestamp

Remarks

The timestamp is converted to the timezone previously configured by the user.

If no timezone configuration was made, the timestamp is converted to UTC.

Example

See the usage of CQGTrade properties in the AccountChanged event's example section.

See Also

CQGTrade Interface | CQGTrade Members


%%PageItemTitle%%

CQGTradeEntry Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a trade entry.

Object Model

CQGTradeEntry InterfaceCQGTradeEntryDefinition InterfaceCQGTradeExits CollectionCQGTradeExit InterfaceCQGTradingSystemTrade Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTradeEntry Members


%%PageItemTitle%% $$Members$$

CQGTradeEntry Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property CanPlaceOrderSignal | Returns signal which indicates whether trade entry can place order
Public Property Definition | Returns the trade entry definition.
Public Property Price | Returns the trade entry price.
Public Property Quantity | Returns the trade entry quantity.
Public Property QuantityFractional | Returns the trade entry fractional quantity
Public Property RelatedExits | Represents a collection of related trade exits.
Public Property Signal | Returns the trade entry signal.
Public Property StopLimitPrice | Returns the trade entry stop limit price.
Public Property Trade | Returns the parent trade.

See Also

CQGTradeEntry Interface


%%PageItemTitle%%

CanPlaceOrderSignal Property
CQGTradeEntry Interface : CanPlaceOrderSignal Property

Glossary Item Box

Description

Returns signal which indicates whether trade entry can place order

Property type

Read-only property

Syntax

Visual Basic
Public Property CanPlaceOrderSignal As Boolean

See Also

CQGTradeEntry Interface | CQGTradeEntry Members


%%PageItemTitle%%

Definition Property
CQGTradeEntry Interface : Definition Property

Glossary Item Box

Description

Returns the trade entry definition.

Property type

Read-only property

Syntax

Visual Basic
Public Property Definition As CQGTradeEntryDefinition

Return Type

Trade entry definition, represented as CQGTradeEntryDefinition object

See Also

CQGTradeEntry Interface | CQGTradeEntry Members | CQGTradeEntryDefinition Interface


%%PageItemTitle%%

Price Property
CQGTradeEntry Interface : Price Property

Glossary Item Box

Description

Returns the trade entry price.

Property type

Read-only property

Syntax

Visual Basic
Public Property Price As Double

Return Type

Trade entry price, represented as Double

See Also

CQGTradeEntry Interface | CQGTradeEntry Members


%%PageItemTitle%%

Quantity Property
CQGTradeEntry Interface : Quantity Property

Glossary Item Box

Description

Returns the trade entry quantity.

Property type

Read-only property

Syntax

Visual Basic
Public Property Quantity As Long

Return Type

Trade entry quantity, represented as Long

See Also

CQGTradeEntry Interface | CQGTradeEntry Members


%%PageItemTitle%%

QuantityFractional Property
CQGTradeEntry Interface : QuantityFractional Property

Glossary Item Box

Description

Returns the trade entry fractional quantity

Property type

Read-only property

Syntax

Visual Basic
Public Property QuantityFractional As Decimal

See Also

CQGTradeEntry Interface | CQGTradeEntry Members


%%PageItemTitle%%

RelatedExits Property
CQGTradeEntry Interface : RelatedExits Property

Glossary Item Box

Description

Represents a collection of related trade exits.

Property type

Read-only property

Syntax

Visual Basic
Public Property RelatedExits As CQGTradeExits

Return Type

A collection of related trade exits, represented as CQGTradeExits

See Also

CQGTradeEntry Interface | CQGTradeEntry Members


%%PageItemTitle%%

Signal Property
CQGTradeEntry Interface : Signal Property

Glossary Item Box

Description

Returns the trade entry signal.

Property type

Read-only property

Syntax

Visual Basic
Public Property Signal As Boolean

Return Type

True, if trade entry is signalled; False, otherwise

See Also

CQGTradeEntry Interface | CQGTradeEntry Members


%%PageItemTitle%%

StopLimitPrice Property
CQGTradeEntry Interface : StopLimitPrice Property

Glossary Item Box

Description

Returns the trade entry stop limit price.

Property type

Read-only property

Syntax

Visual Basic
Public Property StopLimitPrice As Double

Return Type

Trade entry stop limit price, represented as Double

See Also

CQGTradeEntry Interface | CQGTradeEntry Members


%%PageItemTitle%%

Trade Property
CQGTradeEntry Interface : Trade Property

Glossary Item Box

Description

Returns the parent trade.

Property type

Read-only property

Syntax

Visual Basic
Public Property Trade As CQGTradingSystemTrade

Return Type

Parent trade, represented as CQGTradingSystemTrade Object

See Also

CQGTradeEntry Interface | CQGTradeEntry Members | CQGTradingSystemTrade Interface


%%PageItemTitle%%

CQGTradeEntryDefinition Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a definition of the trade entry.

Object Model

CQGTradeEntryDefinition Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTradeEntryDefinition Members


%%PageItemTitle%% $$Members$$

CQGTradeEntryDefinition Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property AllowEntryOnExit | Returns the flag indicating whether the entry is allowed on exit or not.
Public Property AllowPyramids | Returns the flag indicating whether the pyramids are allowed or not.
Public Property OrderType | Returns the entry order type.

See Also

CQGTradeEntryDefinition Interface


%%PageItemTitle%%

AllowEntryOnExit Property
CQGTradeEntryDefinition Interface : AllowEntryOnExit Property

Glossary Item Box

Description

Returns the flag indicating whether the entry is allowed on exit or not.

Property type

Read-only property

Syntax

Visual Basic
Public Property AllowEntryOnExit As Boolean

Return Type

True, if entry on exis is allowed; False, otherwise

See Also

CQGTradeEntryDefinition Interface | CQGTradeEntryDefinition Members


%%PageItemTitle%%

AllowPyramids Property
CQGTradeEntryDefinition Interface : AllowPyramids Property

Glossary Item Box

Description

Returns the flag indicating whether the pyramids are allowed or not.

Property type

Read-only property

Syntax

Visual Basic
Public Property AllowPyramids As Boolean

Return Type

True, if pyramids are allowed; False, otherwise

See Also

CQGTradeEntryDefinition Interface | CQGTradeEntryDefinition Members


%%PageItemTitle%%

OrderType Property
CQGTradeEntryDefinition Interface : OrderType Property

Glossary Item Box

Description

Returns the entry order type.

Property type

Read-only property

Syntax

Visual Basic
Public Property OrderType As eOrderType

Return Type

Entry order type, represented as eOrderType

Remarks

See eOrderType for possible values.

See Also

CQGTradeEntryDefinition Interface | CQGTradeEntryDefinition Members


%%PageItemTitle%%

CQGTradeExit Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a trade exit.

Object Model

CQGTradeExit InterfaceCQGTradeExitDefinition InterfaceCQGTradeEntries CollectionCQGTradeEntry InterfaceCQGTradingSystemTrade Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTradeExit Members


%%PageItemTitle%% $$Members$$

CQGTradeExit Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property CanPlaceOrderSignal | Returns signal which indicates whether trade exit can place order
Public Property Definition | Returns the trade exit definition.
Public Property Price | Returns the trade exit price.
Public Property Quantity | Returns the trade exit quantity.
Public Property RelatedEntries | Represents a collection of related trade entries.
Public Property Signal | Returns the trade exit signal.
Public Property StopLimitPrice | Returns the exit stop limit price.
Public Property Trade | Returns the parent trade.

See Also

CQGTradeExit Interface


%%PageItemTitle%%

CanPlaceOrderSignal Property
CQGTradeExit Interface : CanPlaceOrderSignal Property

Glossary Item Box

Description

Returns signal which indicates whether trade exit can place order

Property type

Read-only property

Syntax

Visual Basic
Public Property CanPlaceOrderSignal As Boolean

See Also

CQGTradeExit Interface | CQGTradeExit Members


%%PageItemTitle%%

Definition Property
CQGTradeExit Interface : Definition Property

Glossary Item Box

Description

Returns the trade exit definition.

Property type

Read-only property

Syntax

Visual Basic
Public Property Definition As CQGTradeExitDefinition

Return Type

Trade exit definition, represented as CQGTradeExitDefinition

See Also

CQGTradeExit Interface | CQGTradeExit Members | CQGTradeExitDefinition Interface


%%PageItemTitle%%

Price Property
CQGTradeExit Interface : Price Property

Glossary Item Box

Description

Returns the trade exit price.

Property type

Read-only property

Syntax

Visual Basic
Public Property Price As Double

Return Type

Trade exit price, represented as Double

See Also

CQGTradeExit Interface | CQGTradeExit Members


%%PageItemTitle%%

Quantity Property
CQGTradeExit Interface : Quantity Property

Glossary Item Box

Description

Returns the trade exit quantity.

Property type

Read-only property

Syntax

Visual Basic
Public Property Quantity As Long

Return Type

Trade exit quantity, represented as Long

See Also

CQGTradeExit Interface | CQGTradeExit Members


%%PageItemTitle%%

RelatedEntries Property
CQGTradeExit Interface : RelatedEntries Property

Glossary Item Box

Description

Represents a collection of related trade entries.

Property type

Read-only property

Syntax

Visual Basic
Public Property RelatedEntries As CQGTradeEntries

Return Type

A collection of related trade entries, represented as CQGTradeEntries

See Also

CQGTradeExit Interface | CQGTradeExit Members


%%PageItemTitle%%

Signal Property
CQGTradeExit Interface : Signal Property

Glossary Item Box

Description

Returns the trade exit signal.

Property type

Read-only property

Syntax

Visual Basic
Public Property Signal As Boolean

Return Type

True, if the trade exit is signalled; False, otherwise

See Also

CQGTradeExit Interface | CQGTradeExit Members


%%PageItemTitle%%

StopLimitPrice Property
CQGTradeExit Interface : StopLimitPrice Property

Glossary Item Box

Description

Returns the exit stop limit price.

Property type

Read-only property

Syntax

Visual Basic
Public Property StopLimitPrice As Double

Return Type

Exit stop limit price, represented as Double

See Also

CQGTradeExit Interface | CQGTradeExit Members


%%PageItemTitle%%

Trade Property
CQGTradeExit Interface : Trade Property

Glossary Item Box

Description

Returns the parent trade.

Property type

Read-only property

Syntax

Visual Basic
Public Property Trade As CQGTradingSystemTrade

Return Type

Parent trade, represented as CQGTradingSystemTrade object

See Also

CQGTradeExit Interface | CQGTradeExit Members | CQGTradingSystemTrade Interface


%%PageItemTitle%%

CQGTradeExitDefinition Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a definition of the trade exit.

Object Model

CQGTradeExitDefinition Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTradeExitDefinition Members


%%PageItemTitle%% $$Members$$

CQGTradeExitDefinition Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property AllowExitOnEntry | Returns the flag indicating whether the exit is allowed on entry or not.
Public Property AllowMoreThanOnce | Returns the flag indicating whether the exit is allowed more than once or not.
Public Property Name | Returns the exit name.
Public Property OrderType | Returns the exit order type.

See Also

CQGTradeExitDefinition Interface


%%PageItemTitle%%

AllowExitOnEntry Property
CQGTradeExitDefinition Interface : AllowExitOnEntry Property

Glossary Item Box

Description

Returns the flag indicating whether the exit is allowed on entry or not.

Property type

Read-only property

Syntax

Visual Basic
Public Property AllowExitOnEntry As Boolean

Return Type

True, if exit on entry is allowed; False, otherwise

See Also

CQGTradeExitDefinition Interface | CQGTradeExitDefinition Members


%%PageItemTitle%%

AllowMoreThanOnce Property
CQGTradeExitDefinition Interface : AllowMoreThanOnce Property

Glossary Item Box

Description

Returns the flag indicating whether the exit is allowed more than once or not.

Property type

Read-only property

Syntax

Visual Basic
Public Property AllowMoreThanOnce As Boolean

Return Type

True, if more than one exit is allowed; False, otherwise

See Also

CQGTradeExitDefinition Interface | CQGTradeExitDefinition Members


%%PageItemTitle%%

Name Property
CQGTradeExitDefinition Interface : Name Property

Glossary Item Box

Description

Returns the exit name.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

Return Type

Exit name, represented as String

See Also

CQGTradeExitDefinition Interface | CQGTradeExitDefinition Members


%%PageItemTitle%%

OrderType Property
CQGTradeExitDefinition Interface : OrderType Property

Glossary Item Box

Description

Returns the exit order type.

Property type

Read-only property

Syntax

Visual Basic
Public Property OrderType As eOrderType

Return Type

Exit order type, represented as eOrderType

Remarks

See eOrderType for possible values.

See Also

CQGTradeExitDefinition Interface | CQGTradeExitDefinition Members | eOrderType Enumeration


%%PageItemTitle%%

CQGTradingSystem Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a trading system.

Is returned by the CQGCEL.RequestTradingSystem method call.

Object Model

CQGTradingSystem InterfaceCQGTradingSystemDefinition InterfaceCQGError InterfaceCQGTradingSystemRequest InterfaceCQGTradingSystemStatisticsCollection CollectionCQGTradingSystemStatistics InterfaceCQGTradingSystemTradesRows CollectionCQGTradingSystemTradesRow Collection

Remarks

The CQGCEL.TradingSystemResolved and CQGCEL.TradingSystemSignaled can be fired for the CQGTradingSystem.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTradingSystem Members | RequestTradingSystem Method


%%PageItemTitle%% $$Members$$

CQGTradingSystem Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Definition | Returns the trading system definition.
Public Property Id | Returns the unique identifier of the trading system.
Public Property LastError | Returns the CQGError object describing the last error occurred to this object, or Nothing/Invalid_Error in case of no error.
Public Property Request | Returns the read-only copy of CQGTradingSystemRequest object, that was passed to the corresponding CQGCEL.RequestTradingSystem method call.
Public Property Statistics | Returns the CQGTradingSystemStatisticsCollection.
Public Property Status | Returns the trading system request's status.
Public Property Tag | This property allows the user to keep his/her own information within the trading system.
Public Property TradesRows | Returns the collection of trades rows.

See Also

CQGTradingSystem Interface | RequestTradingSystem Method


%%PageItemTitle%%

Definition Property
CQGTradingSystem Interface : Definition Property

Glossary Item Box

Description

Returns the trading system definition.

Property type

Read-only property

Syntax

Visual Basic
Public Property Definition As CQGTradingSystemDefinition

Return Type

Definition, represented as CQGTradingSystemDefinition

See Also

CQGTradingSystem Interface | CQGTradingSystem Members | CQGTradingSystemTradeDefinition Interface


%%PageItemTitle%%

Id Property
CQGTradingSystem Interface : Id Property

Glossary Item Box

Description

Returns the unique identifier of the trading system.

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

Return Type

Unique identifier, represented as String

See Also

CQGTradingSystem Interface | CQGTradingSystem Members


%%PageItemTitle%%

LastError Property
CQGTradingSystem Interface : LastError Property

Glossary Item Box

Description

Returns the CQGError object describing the last error occurred to this object, or Nothing/Invalid_Error in case of no error.

Property type

Read-only property

Syntax

Visual Basic
Public Property LastError As CQGError

Return Type

The last error, represented as CQGError

See Also

CQGTradingSystem Interface | CQGTradingSystem Members | CQGError Interface


%%PageItemTitle%%

Request Property
CQGTradingSystem Interface : Request Property

Glossary Item Box

Description

Returns the read-only copy of CQGTradingSystemRequest object, that was passed to the corresponding CQGCEL.RequestTradingSystem method call.

Property type

Read-only property

Syntax

Visual Basic
Public Property Request As CQGTradingSystemRequest

Return Type

A read-only copy of the corresponding CQGTradingSystemRequest object

See Also

CQGTradingSystem Interface | CQGTradingSystem Members | CQGTradingSystemRequest Interface | RequestTradingSystem Method


%%PageItemTitle%%

Statistics Property
CQGTradingSystem Interface : Statistics Property

Glossary Item Box

Description

Returns the CQGTradingSystemStatisticsCollection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Statistics As CQGTradingSystemStatisticsCollection

Return Type

Statistics collection, represented as CQGTradingSystemStatisticsCollection

See Also

CQGTradingSystem Interface | CQGTradingSystem Members | CQGTradingSystemStatisticsCollection Collection


%%PageItemTitle%%

Status Property
CQGTradingSystem Interface : Status Property

Glossary Item Box

Description

Returns the trading system request's status.

Property type

Read-only property

Syntax

Visual Basic
Public Property Status As eRequestStatus

Return Type

Request status, represented as eRequestStatus

See Also

CQGTradingSystem Interface | CQGTradingSystem Members | eRequestStatus Enumeration


%%PageItemTitle%%

Tag Property
tag_name

The user-defined value's name.

When setting, the tag_name parameter should keep the key that will be associated with the passed information.

When getting the information from the Tag, one of the previously set keys should be passed as tag_name in order to get the corresponding information.

CQGTradingSystem Interface : Tag Property

Glossary Item Box

Description

This property allows the user to keep his/her own information within the trading system.

Property type

Read-write property

Syntax

Visual Basic
Public Property Tag( _
   ByVal tag_name As String _
) As Variant

Parameters

tag_name

The user-defined value's name.

When setting, the tag_name parameter should keep the key that will be associated with the passed information.

When getting the information from the Tag, one of the previously set keys should be passed as tag_name in order to get the corresponding information.

Return Type

The user-defined value, represented as Variant

Remarks

Multiple data can be kept in the Tag property under different keys.

  • If no user-defined value with this tag_name exists, Empty is returned.
  • If empty is set to an existing tag_name, it is deleted/unregistered.
  • If a new value is set to an existing tag_name, the old value is overwritten.

See Also

CQGTradingSystem Interface | CQGTradingSystem Members


%%PageItemTitle%%

TradesRows Property
CQGTradingSystem Interface : TradesRows Property

Glossary Item Box

Description

Returns the collection of trades rows.

Property type

Read-only property

Syntax

Visual Basic
Public Property TradesRows As CQGTradingSystemTradesRows

Return Type

Trades rows collection, represented as CQGTradingSystemTradesRows

See Also

CQGTradingSystem Interface | CQGTradingSystem Members | CQGTradingSystemTradesRows Collection


%%PageItemTitle%%

CQGTradingSystemAddInfo Interface
See Also Members Send Feedback

Glossary Item Box

Description

This interface is reserved for future use.

Object Model

CQGTradingSystemAddInfo Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTradingSystemAddInfo Members


%%PageItemTitle%% $$Members$$

CQGTradingSystemAddInfo Interface Members
See Also Overview Send Feedback

Glossary Item Box

See Also

CQGTradingSystemAddInfo Interface


%%PageItemTitle%%

CQGTradingSystemBaseBarParameter Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a trading system base bar parameter.

Object Model

CQGTradingSystemBaseBarParameter Interface

Remarks

See CQGTradingSystemRequest.BaseBarType for more information.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTradingSystemBaseBarParameter Members


%%PageItemTitle%% $$Members$$

CQGTradingSystemBaseBarParameter Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Name | Gets the name of trading system base bar parameter.
Public Property Type | Gets the type of trading system base bar parameter.
Public Property Value | Sets/gets the trading system base bar parameter value.

See Also

CQGTradingSystemBaseBarParameter Interface


%%PageItemTitle%%

Name Property
CQGTradingSystemBaseBarParameter Interface : Name Property

Glossary Item Box

Description

Gets the name of trading system base bar parameter.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

Return Type

Trading system base bar parameter name, represented as String

See Also

CQGTradingSystemBaseBarParameter Interface | CQGTradingSystemBaseBarParameter Members


%%PageItemTitle%%

Type Property
CQGTradingSystemBaseBarParameter Interface : Type Property

Glossary Item Box

Description

Gets the type of trading system base bar parameter.

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As eTradingSystemBaseBarParameter

Return Type

Trading system base bar parameter type, represented as eTradingSystemBaseBarParameter

See Also

CQGTradingSystemBaseBarParameter Interface | CQGTradingSystemBaseBarParameter Members


%%PageItemTitle%%

Value Property
CQGTradingSystemBaseBarParameter Interface : Value Property

Glossary Item Box

Description

Sets/gets the trading system base bar parameter value.

Property type

Read-write property

Syntax

Visual Basic
Public Property Value As Variant

Return Type

Value of trading system base bar parameter, represented as Variant

Remarks

To find out the type of the returned Variant for each trading system base bar type, see the descriptions of the eTradingSystemBaseBarParameter values.

See Also

CQGTradingSystemBaseBarParameter Interface | CQGTradingSystemBaseBarParameter Members


%%PageItemTitle%%

CQGTradingSystemDefinition Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a definition of trading system.

Object Model

CQGTradingSystemDefinition InterfaceCQGParameterDefinitions CollectionCQGParameterDefinition InterfaceCQGTradingSystemTradeDefinitions CollectionCQGTradingSystemTradeDefinition Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTradingSystemDefinition Members


%%PageItemTitle%% $$Members$$

CQGTradingSystemDefinition Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Abbreviation | Returns the trading system abbreviation.
Public Property Commission | Returns the trading system commission.
Public Property CommissionType | Returns the trading system commission type.
Public Property Name | Returns the trading system name.
Public Property ParameterDefinitions | Returns all parameter definitions.
Public Property TradeDefinitions | Returns all trade definitions.

See Also

CQGTradingSystemDefinition Interface


%%PageItemTitle%%

Abbreviation Property
CQGTradingSystemDefinition Interface : Abbreviation Property

Glossary Item Box

Description

Returns the trading system abbreviation.

Property type

Read-only property

Syntax

Visual Basic
Public Property Abbreviation As String

Return Type

Trading system abbreviation, represented as String

See Also

CQGTradingSystemDefinition Interface | CQGTradingSystemDefinition Members


%%PageItemTitle%%

Commission Property
CQGTradingSystemDefinition Interface : Commission Property

Glossary Item Box

Description

Returns the trading system commission.

Property type

Read-only property

Syntax

Visual Basic
Public Property Commission As Double

Return Type

Trading system commission, represented as Double

See Also

CQGTradingSystemDefinition Interface | CQGTradingSystemDefinition Members


%%PageItemTitle%%

CommissionType Property
CQGTradingSystemDefinition Interface : CommissionType Property

Glossary Item Box

Description

Returns the trading system commission type.

Property type

Read-only property

Syntax

Visual Basic
Public Property CommissionType As eTradingSystemCommissionType

Return Type

Trading system commission type, represented as eTradingSystemCommissionType

Remarks

See eTradingSystemCommissionType for possible values.

See Also

CQGTradingSystemDefinition Interface | CQGTradingSystemDefinition Members | eTradingSystemCommissionType Enumeration


%%PageItemTitle%%

Name Property
CQGTradingSystemDefinition Interface : Name Property

Glossary Item Box

Description

Returns the trading system name.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

Return Type

Trading system name, represented as String

See Also

CQGTradingSystemDefinition Interface | CQGTradingSystemDefinition Members


%%PageItemTitle%%

ParameterDefinitions Property
CQGTradingSystemDefinition Interface : ParameterDefinitions Property

Glossary Item Box

Description

Returns all parameter definitions.

Property type

Read-only property

Syntax

Visual Basic
Public Property ParameterDefinitions As CQGParameterDefinitions

Return Type

Parameter definitions, represented as CQGParameterDefinitions collection

See Also

CQGTradingSystemDefinition Interface | CQGTradingSystemDefinition Members


%%PageItemTitle%%

TradeDefinitions Property
CQGTradingSystemDefinition Interface : TradeDefinitions Property

Glossary Item Box

Description

Returns all trade definitions.

Property type

Read-only property

Syntax

Visual Basic
Public Property TradeDefinitions As CQGTradingSystemTradeDefinitions

Return Type

Trade definitions, represented as CQGTradingSystemTradeDefinitions collection

See Also

CQGTradingSystemDefinition Interface | CQGTradingSystemDefinition Members | CQGTradingSystemTradeDefinitions Collection


%%PageItemTitle%%

CQGTradingSystemInsertInfo Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a definition of trading system.

Object Model

CQGTradingSystemInsertInfo Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTradingSystemInsertInfo Members


%%PageItemTitle%% $$Members$$

CQGTradingSystemInsertInfo Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Index

Index of inserted trade row and/or statistics.

See Also

CQGTradingSystemInsertInfo Interface


%%PageItemTitle%%

Index Property
CQGTradingSystemInsertInfo Interface : Index Property

Glossary Item Box

Description

Index of inserted trade row and/or statistics.

Property type

Read-only property

Syntax

Visual Basic
Public Property Index As Long

Return Type

Trade row and/or statistics index, represented as Long

See Also

CQGTradingSystemInsertInfo Interface | CQGTradingSystemInsertInfo Members


%%PageItemTitle%%

CQGTradingSystemRelationAddInfo Interface
See Also Members Send Feedback

Glossary Item Box

Description

This class contains information about the added relation between an entry and exit within the trading system.

Object Model

CQGTradingSystemRelationAddInfo InterfaceCQGTradeEntry InterfaceCQGTradeExit Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTradingSystemRelationAddInfo Members


%%PageItemTitle%% $$Members$$

CQGTradingSystemRelationAddInfo Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Entry | Trade entry, which participates in the relation.
Public Property EntryRowIndex | Returns the index of the row, which contains the trade entry.
Public Property Exit | Trade exit, which participates in the relation.
Public Property ExitRowIndex | Returns the index of the row, which contains the trade exit.

See Also

CQGTradingSystemRelationAddInfo Interface


%%PageItemTitle%%

Entry Property
CQGTradingSystemRelationAddInfo Interface : Entry Property

Glossary Item Box

Description

Trade entry, which participates in the relation.

Property type

Read-only property

Syntax

Visual Basic
Public Property Entry As CQGTradeEntry

Return Type

Trade entry, represented as CQGTradeEntry

See Also

CQGTradingSystemRelationAddInfo Interface | CQGTradingSystemRelationAddInfo Members


%%PageItemTitle%%

EntryRowIndex Property
CQGTradingSystemRelationAddInfo Interface : EntryRowIndex Property

Glossary Item Box

Description

Returns the index of the row, which contains the trade entry.

Property type

Read-only property

Syntax

Visual Basic
Public Property EntryRowIndex As Long

Return Type

Entry row index, represented as Long

See Also

CQGTradingSystemRelationAddInfo Interface | CQGTradingSystemRelationAddInfo Members


%%PageItemTitle%%

Exit Property
CQGTradingSystemRelationAddInfo Interface : Exit Property

Glossary Item Box

Description

Trade exit, which participates in the relation.

Property type

Read-only property

Syntax

Visual Basic
Public Property Exit As CQGTradeExit

Return Type

Trade exit, represented as CQGTradeExit

See Also

CQGTradingSystemRelationAddInfo Interface | CQGTradingSystemRelationAddInfo Members


%%PageItemTitle%%

ExitRowIndex Property
CQGTradingSystemRelationAddInfo Interface : ExitRowIndex Property

Glossary Item Box

Description

Returns the index of the row, which contains the trade exit.

Property type

Read-only property

Syntax

Visual Basic
Public Property ExitRowIndex As Long

Return Type

Exit row index, represented as Long

See Also

CQGTradingSystemRelationAddInfo Interface | CQGTradingSystemRelationAddInfo Members


%%PageItemTitle%%

CQGTradingSystemRemoveInfo Interface
See Also Members Send Feedback

Glossary Item Box

Description

This class contains information about the updates made to the trading system.

It is used by the CQGCEL.TradingSystemUpdateNotification event.

Object Model

CQGTradingSystemRemoveInfo Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTradingSystemRemoveInfo Members


%%PageItemTitle%% $$Members$$

CQGTradingSystemRemoveInfo Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Index

Index of removed trade row and/or statistics.

See Also

CQGTradingSystemRemoveInfo Interface


%%PageItemTitle%%

Index Property
CQGTradingSystemRemoveInfo Interface : Index Property

Glossary Item Box

Description

Index of removed trade row and/or statistics.

Property type

Read-only property

Syntax

Visual Basic
Public Property Index As Long

Return Type

Trade row and/or statistics index, represented as Long

See Also

CQGTradingSystemRemoveInfo Interface | CQGTradingSystemRemoveInfo Members


%%PageItemTitle%%

CQGTradingSystemRequest Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents parameters used to formulate a trading system request.

Object Model

CQGTradingSystemRequest InterfaceCQGTradingSystemBaseBarParameters CollectionCQGTradingSystemBaseBarParameter InterfaceCQGTradingSystemDefinition Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTradingSystemRequest Members


%%PageItemTitle%% $$Members$$

CQGTradingSystemRequest Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method ExcludeAllStatistics | Excludes all statistics from the trading system request.
Public Method IncludeStatistic | Includes the specified statistic to be present in the requested trading system.
Public Method IsStatisticIncluded | Returns whether the specified statistics item is currently included.

Public Properties

Public Property BaseBarParameters | Returns the trading system's base bar parameters collection, based on the base bar type.
Public Property BaseBarType | Sets/gets the type of the trading system base bar.
Public Property BaseExpression | Sets/gets the base expression, which will be used to formulate this trading system request.
Public Property Continuation | Sets/gets the continuation type, which will be used to formulate this trading system request. The default value is tsctNoContinuation.
Public Property DaysBeforeExpiration | Sets/gets the number of days prior to expiration, when the rollover will occur, to be used to formulate this trading system request. The default value for this property is 0.
Public Property Definition | Returns the trading system definition.
Public Property EqualizeCloses | Gets/sets the equalize closes flag, which will be used to formulate this trading system request. The default value for this property is True.
Public Property HistoricalPeriod | Gets/sets the historical period, which will be used to formulate the trading system request. The default value for this property is hpUndefined.
Public Property IncludeEnd | Gets/sets the include end flag, which will be used to formulate this trading system request. The default value for this property is False.
Public Property IntradayPeriod | Gets/sets the intraday period, which will be used to formulate the trading system request.
Public Property Parameter | Sets/gets the parameter value, which will be used to formulate this trading system request.
Public Property RangeEnd | Gets/sets the range end, which will be used to formulate this trading system request (required).
Public Property RangeStart | Gets/sets the range start, which will be used to formulate this trading system request (required).
Public Property RecalcPeriod | Sets/gets the recalculation period (in seconds), which will be used to formulate the trading system request. The default value for this property is 60.
Public Property SessionFlags | Sets/gets the session flags, which will be used to formulate this trading system request. The default value for this property is sfUndefined.
Public Property SessionsFilter | Sets/gets the sessions filter, which will be used to formulate this trading system request. The default value for this property is 0.
Public Property SubscriptionLevel | Sets/gets the subscription level, which will be used to formulate the trading system request. The default value for this property is tslEachBar.

See Also

CQGTradingSystemRequest Interface


%%PageItemTitle%%

ExcludeAllStatistics Method
CQGTradingSystemRequest Interface : ExcludeAllStatistics Method

Glossary Item Box

Description

Excludes all statistics from the trading system request.

Syntax

Visual Basic
Public Sub ExcludeAllStatistics()

See Also

CQGTradingSystemRequest Interface | CQGTradingSystemRequest Members


%%PageItemTitle%%

IncludeStatistic Method
trading_system_statistic

Trading system statistics to include.

CQGTradingSystemRequest Interface : IncludeStatistic Method

Glossary Item Box

Description

Includes the specified statistic to be present in the requested trading system.

Syntax

Visual Basic
Public Sub IncludeStatistic( _
   ByVal trading_system_statistic As eTradingSystemStatistic _
)

Parameters

trading_system_statistic
Value Description
tssAverageDuration

Average duration

tssAverageLoss

Average loss

tssAverageProfit

Average profit

tssAverageWin

Average win

tssClosedNetProfit

Closed net profit

tssCurConsecLosses

Current consecutive losses

tssCurConsecWins

Current consecutive wins

tssCurDrawDown

Current draw down

tssLinearRegression

Linear regression

tssMaxClosedDraw

Maximum closed draw

tssMaxConsecLosses

Maximum consecutive losses

tssMaxConsecWins

Maximum consecutive wins

tssMaxDrawAmount

Maximum draw amount

tssMaxDrawDuration

Maximum draw duration

tssMaximumLoss

Maximum loss

tssMaximumWin

Maximum win

tssOpenPosition

Open position

tssPercentLong

Percent long

tssPercentWinners

Percent winners

tssProfitLossRatio

Profit/loss ration

tssProfitToMaxDraw

Profit to maximum draw

tssRemoveToNeutral

Remove to neutral

tssReturnRetracement

Return retracement

tssTimePercentage

Time percentage

tssTotalNetProfit

Total net profit

tssTotalTradeCount

Total trade count

Trading system statistics to include.

Remarks

Upon the creation of the CQGTradingSystemRequest instance, all statistics are included by default.

If the IncludeStatistic method is called on an instance, where all statistics are already included, all statistics become excluded except the one specified by the trading_system_statistic parameter.

Otherwise, trading_system_statistic is included in addition to the already included other statistics.

See Also

CQGTradingSystemRequest Interface | CQGTradingSystemRequest Members | eTradingSystemStatistic Enumeration


%%PageItemTitle%%

IsStatisticIncluded Method
trading_system_statistic

The trading system statistic of interest.

CQGTradingSystemRequest Interface : IsStatisticIncluded Method

Glossary Item Box

Description

Returns whether the specified statistics item is currently included.

Syntax

Visual Basic
Public Function IsStatisticIncluded( _
   ByVal trading_system_statistic As eTradingSystemStatistic _
) As Boolean

Parameters

trading_system_statistic
Value Description
tssAverageDuration

Average duration

tssAverageLoss

Average loss

tssAverageProfit

Average profit

tssAverageWin

Average win

tssClosedNetProfit

Closed net profit

tssCurConsecLosses

Current consecutive losses

tssCurConsecWins

Current consecutive wins

tssCurDrawDown

Current draw down

tssLinearRegression

Linear regression

tssMaxClosedDraw

Maximum closed draw

tssMaxConsecLosses

Maximum consecutive losses

tssMaxConsecWins

Maximum consecutive wins

tssMaxDrawAmount

Maximum draw amount

tssMaxDrawDuration

Maximum draw duration

tssMaximumLoss

Maximum loss

tssMaximumWin

Maximum win

tssOpenPosition

Open position

tssPercentLong

Percent long

tssPercentWinners

Percent winners

tssProfitLossRatio

Profit/loss ration

tssProfitToMaxDraw

Profit to maximum draw

tssRemoveToNeutral

Remove to neutral

tssReturnRetracement

Return retracement

tssTimePercentage

Time percentage

tssTotalNetProfit

Total net profit

tssTotalTradeCount

Total trade count

The trading system statistic of interest.

Return Type

True if included, False otherwise

See Also

CQGTradingSystemRequest Interface | CQGTradingSystemRequest Members | eTradingSystemStatistic Enumeration


%%PageItemTitle%%

BaseBarParameters Property
CQGTradingSystemRequest Interface : BaseBarParameters Property

Glossary Item Box

Description

Returns the trading system's base bar parameters collection, based on the base bar type.

Property type

Read-only property

Syntax

Visual Basic
Public Property BaseBarParameters As CQGTradingSystemBaseBarParameters

Return Type

Collection of base bar parameters, represented as CQGTradingSystemBaseBarParameters

Remarks

The CQGTradingSystemRequest.BaseBarType property has a definitive role for the contents of this property, therefore it should be set first.

See Also

CQGTradingSystemRequest Interface | CQGTradingSystemRequest Members


%%PageItemTitle%%

BaseBarType Property
CQGTradingSystemRequest Interface : BaseBarType Property

Glossary Item Box

Description

Sets/gets the type of the trading system base bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BaseBarType As eTradingSystemBaseBar

Return Type

Base bar, represented as eTradingSystemBaseBar

Remarks

The content of CQGTradingSystemRequest.BaseBarParameters will be based on this property value.

To find out the available parameters for each base bar type, see eTradingSystemBaseBar.

See Also

CQGTradingSystemRequest Interface | CQGTradingSystemRequest Members


%%PageItemTitle%%

BaseExpression Property
CQGTradingSystemRequest Interface : BaseExpression Property

Glossary Item Box

Description

Sets/gets the base expression, which will be used to formulate this trading system request.

Property type

Read-write property

Syntax

Visual Basic
Public Property BaseExpression As String

Return Type

Base expression, represented as String

See Also

CQGTradingSystemRequest Interface | CQGTradingSystemRequest Members


%%PageItemTitle%%

Continuation Property
CQGTradingSystemRequest Interface : Continuation Property

Glossary Item Box

Description

Sets/gets the continuation type, which will be used to formulate this trading system request.

The default value is tsctNoContinuation.

Property type

Read-write property

Syntax

Visual Basic
Public Property Continuation As eTimeSeriesContinuationType

Return Type

Continuation type, represented as eTimeSeriesContinuationType

Remarks

See eTimeSeriesContinuationType enumeration for possible values.

See Also

CQGTradingSystemRequest Interface | CQGTradingSystemRequest Members | eTimeSeriesContinuationType Enumeration


%%PageItemTitle%%

DaysBeforeExpiration Property
CQGTradingSystemRequest Interface : DaysBeforeExpiration Property

Glossary Item Box

Description

Sets/gets the number of days prior to expiration, when the rollover will occur, to be used to formulate this trading system request.

The default value for this property is 0.

Property type

Read-write property

Syntax

Visual Basic
Public Property DaysBeforeExpiration As Long

Return Type

Number of days prior to expiration, represented as Long

Remarks

This property is required and must have a positive value, when the Continuation property indicates an adjusted continuation.

If the continuation is not adjusted, this property has no effect.

See Also

CQGTradingSystemRequest Interface | CQGTradingSystemRequest Members | CQGTradingSystemRequest.Continuation Property


%%PageItemTitle%%

Definition Property
CQGTradingSystemRequest Interface : Definition Property

Glossary Item Box

Description

Returns the trading system definition.

Property type

Read-only property

Syntax

Visual Basic
Public Property Definition As CQGTradingSystemDefinition

Return Type

Trading system definition, represented as CQGTradingSystemDefinition

See Also

CQGTradingSystemRequest Interface | CQGTradingSystemRequest Members | CQGTradingSystemDefinition Interface


%%PageItemTitle%%

EqualizeCloses Property
CQGTradingSystemRequest Interface : EqualizeCloses Property

Glossary Item Box

Description

Gets/sets the equalize closes flag, which will be used to formulate this trading system request.

The default value for this property is True.

Property type

Read-write property

Syntax

Visual Basic
Public Property EqualizeCloses As Boolean

Return Type

True (default), if closes should be equalized; False, otherwise

See Also

CQGTradingSystemRequest Interface | CQGTradingSystemRequest Members


%%PageItemTitle%%

HistoricalPeriod Property
CQGTradingSystemRequest Interface : HistoricalPeriod Property

Glossary Item Box

Description

Gets/sets the historical period, which will be used to formulate the trading system request.

The default value for this property is hpUndefined.

Property type

Read-write property

Syntax

Visual Basic
Public Property HistoricalPeriod As eHistoricalPeriod

Return Type

Historical period, represented as eHistoricalPeriod

See Also

CQGTradingSystemRequest Interface | CQGTradingSystemRequest Members | eHistoricalPeriod Enumeration


%%PageItemTitle%%

IncludeEnd Property
CQGTradingSystemRequest Interface : IncludeEnd Property

Glossary Item Box

Description

Gets/sets the include end flag, which will be used to formulate this trading system request.

The default value for this property is False.

Property type

Read-write property

Syntax

Visual Basic
Public Property IncludeEnd As Boolean

Return Type

True, if end should be included; False (default), otherwise

Remarks

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGTradingSystemRequest Interface | CQGTradingSystemRequest Members


%%PageItemTitle%%

IntradayPeriod Property
CQGTradingSystemRequest Interface : IntradayPeriod Property

Glossary Item Box

Description

Gets/sets the intraday period, which will be used to formulate the trading system request.

Property type

Read-write property

Syntax

Visual Basic
Public Property IntradayPeriod As Long

Return Type

Intraday period, represented as Long

See Also

CQGTradingSystemRequest Interface | CQGTradingSystemRequest Members


%%PageItemTitle%%

Parameter Property
key_
CQGTradingSystemRequest Interface : Parameter Property

Glossary Item Box

Description

Sets/gets the parameter value, which will be used to formulate this trading system request.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parameter( _
   ByVal key_ As Variant _
) As Variant

Parameters

key_

Return Type

Parameter value, represented as Variant

See Also

CQGTradingSystemRequest Interface | CQGTradingSystemRequest Members


%%PageItemTitle%%

RangeEnd Property
CQGTradingSystemRequest Interface : RangeEnd Property

Glossary Item Box

Description

Gets/sets the range end, which will be used to formulate this trading system request (required).

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeEnd As Variant

Return Type

Range end, represented as Date

Remarks

Only Date and integer are allowed for types of RangeStart/RangeEnd properties.

  • If the type is Date, RangeStart/RangeEnd represent date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode). Non-timed bar requests process date/time range values with a precision of up to minutes.
  • All combinations of Date and integer can apply for these properties, except integer/Date.
  • If RangeEnd type is integer, then it represents the count of records prior to RangeStart to be requested, so it must be a negative value.
  • If RangeEnd is date, it must be further in time than RangeStart.

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGTradingSystemRequest Interface | CQGTradingSystemRequest Members


%%PageItemTitle%%

RangeStart Property
CQGTradingSystemRequest Interface : RangeStart Property

Glossary Item Box

Description

Gets/sets the range start, which will be used to formulate this trading system request (required).

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeStart As Variant

Return Type

Range start, represented as Date

Remarks

Only Date and integer are allowed for types of RangeStart/RangeEnd properties:

  • All combinations of Date and Integer can apply for these properties, except Integer/Date.
  • If type is Date, RangeStart represents date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode). Non-timed bar requests process date/time range values with a precision of up to minutes.
  • If type is Integer, RangeStart represents the current condition's result number (0 is the current condition result number, negative numbers represent condition results in the past, positive numbers - in the future).
  • If the type of RangeStart is integer, it shall be 0 (denoting "current").

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGTradingSystemRequest Interface | CQGTradingSystemRequest Members


%%PageItemTitle%%

RecalcPeriod Property
CQGTradingSystemRequest Interface : RecalcPeriod Property

Glossary Item Box

Description

Sets/gets the recalculation period (in seconds), which will be used to formulate the trading system request.

The default value for this property is 60.

Property type

Read-write property

Syntax

Visual Basic
Public Property RecalcPeriod As Long

Return Type

Recalculation period in seconds, represented as Long

Remarks

Only positive values are allowed for this property.

See Also

CQGTradingSystemRequest Interface | CQGTradingSystemRequest Members


%%PageItemTitle%%

SessionFlags Property
CQGTradingSystemRequest Interface : SessionFlags Property

Glossary Item Box

Description

Sets/gets the session flags, which will be used to formulate this trading system request.

The default value for this property is sfUndefined.

Property type

Read-write property

Syntax

Visual Basic
Public Property SessionFlags As eSessionFlag

Return Type

Session flags, represented as eSessionFlag

Remarks

See eSessionFlag enumeration for possible values.

See Also

CQGTradingSystemRequest Interface | CQGTradingSystemRequest Members


%%PageItemTitle%%

SessionsFilter Property
CQGTradingSystemRequest Interface : SessionsFilter Property

Glossary Item Box

Description

Sets/gets the sessions filter, which will be used to formulate this trading system request.

The default value for this property is 0.

Property type

Read-write property

Syntax

Visual Basic
Public Property SessionsFilter As Variant

Return Type

Sessions filter, represented as Variant

Remarks

Only String and integer are considered for SessionsFilter type.

  • If type is integer, SessionsFilter represents session number.
    Special values: 0 represents primary sessions only, 31 represents all sessions.
  • If type is String, SessionsFilter represents custom session name.
    Special values: "primaryOnly" and "all" are equivalent to 0 and 31, respectively.
  • If other types are used for SessionsFilter, SessionsFilter is ignored.

See Also

CQGTradingSystemRequest Interface | CQGTradingSystemRequest Members


%%PageItemTitle%%

SubscriptionLevel Property
CQGTradingSystemRequest Interface : SubscriptionLevel Property

Glossary Item Box

Description

Sets/gets the subscription level, which will be used to formulate the trading system request.

The default value for this property is tslEachBar.

Property type

Read-write property

Syntax

Visual Basic
Public Property SubscriptionLevel As eTimeSeriesSubscriptionLevel

Return Type

Subscription level, represented as eTimeSeriesSubscriptionLevel

See Also

CQGTradingSystemRequest Interface | CQGTradingSystemRequest Members | eTimeSeriesSubscriptionLevel Enumeration


%%PageItemTitle%%

CQGTradingSystemStatistics Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents trading system statistics.

Object Model

CQGTradingSystemStatistics Interface

Remarks

The value of a statistic will be invalid if that statistic was not included in the corresponding request.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTradingSystemStatistics Members


%%PageItemTitle%% $$Members$$

CQGTradingSystemStatistics Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property AverageDuration | Returns the average duration.
Public Property AverageLoss | Returns the average loss.
Public Property AverageProfit | Returns the average profit.
Public Property AverageWin | Returns the average win.
Public Property ClosedNetProfit | Returns the closed net profit.
Public Property CurConsecLosses | Returns the current consecutive losses.
Public Property CurConsecWins | Returns the current consecutive wins.
Public Property CurDrawDown | Returns the current draw down.
Public Property LinearRegression | Returns the linear regression.
Public Property MaxClosedDraw | Returns the maximum closed draw.
Public Property MaxConsecLosses | Returns the maximum consecutive losses.
Public Property MaxConsecWins | Returns the maximum consecutive wins.
Public Property MaxDrawAmount | Returns the maximum draw amount.
Public Property MaxDrawDuration | Returns the maximum draw duration.
Public Property MaximumLoss | Returns the maximum loss.
Public Property MaximumWin | Returns the maximum win.
Public Property OpenPosition | Returns the open position.
Public Property PercentLong | Returns the percent long.
Public Property PercentWinners | Returns the percent of winners.
Public Property ProfitLossRatio | Returns the profit/loss ratio.
Public Property ProfitToMaxDraw | Returns the profit to maximum draw.
Public Property RemoveToNeutral | Returns the remove to neutral.
Public Property ReturnRetracement | Returns the return retracement.
Public Property TimePercentage | Returns the time percentage.
Public Property Timestamp | Returns the timestamp, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
Public Property TimestampOffset | Returns the timestamp offset, which is used to identify various CQGTradingSystemStatistics objects that have the same timestamp.
Public Property TotalNetProfit | Returns the total net profit.
Public Property TotalTradeCount | Returns the total trade count.
Public Property Value | Returns the value of a specified statistic. This is the default property.

See Also

CQGTradingSystemStatistics Interface


%%PageItemTitle%%

AverageDuration Property
CQGTradingSystemStatistics Interface : AverageDuration Property

Glossary Item Box

Description

Returns the average duration.

Property type

Read-only property

Syntax

Visual Basic
Public Property AverageDuration As Double

Return Type

Average duration, represented as Double

See Also

CQGTradingSystemStatistics Interface | CQGTradingSystemStatistics Members


%%PageItemTitle%%

AverageLoss Property
CQGTradingSystemStatistics Interface : AverageLoss Property

Glossary Item Box

Description

Returns the average loss.

Property type

Read-only property

Syntax

Visual Basic
Public Property AverageLoss As Double

Return Type

Average loss, represented as Double

See Also

CQGTradingSystemStatistics Interface | CQGTradingSystemStatistics Members


%%PageItemTitle%%

AverageProfit Property
CQGTradingSystemStatistics Interface : AverageProfit Property

Glossary Item Box

Description

Returns the average profit.

Property type

Read-only property

Syntax

Visual Basic
Public Property AverageProfit As Double

Return Type

Average profit, represented as Double

See Also

CQGTradingSystemStatistics Interface | CQGTradingSystemStatistics Members


%%PageItemTitle%%

AverageWin Property
CQGTradingSystemStatistics Interface : AverageWin Property

Glossary Item Box

Description

Returns the average win.

Property type

Read-only property

Syntax

Visual Basic
Public Property AverageWin As Double

Return Type

Average win, represented as Double

See Also

CQGTradingSystemStatistics Interface | CQGTradingSystemStatistics Members


%%PageItemTitle%%

ClosedNetProfit Property
CQGTradingSystemStatistics Interface : ClosedNetProfit Property

Glossary Item Box

Description

Returns the closed net profit.

Property type

Read-only property

Syntax

Visual Basic
Public Property ClosedNetProfit As Double

Return Type

Closed net profit, represented as Double

See Also

CQGTradingSystemStatistics Interface | CQGTradingSystemStatistics Members


%%PageItemTitle%%

CurConsecLosses Property
CQGTradingSystemStatistics Interface : CurConsecLosses Property

Glossary Item Box

Description

Returns the current consecutive losses.

Property type

Read-only property

Syntax

Visual Basic
Public Property CurConsecLosses As Double

Return Type

Current consecutive losses, represented as Double

See Also

CQGTradingSystemStatistics Interface | CQGTradingSystemStatistics Members


%%PageItemTitle%%

CurConsecWins Property
CQGTradingSystemStatistics Interface : CurConsecWins Property

Glossary Item Box

Description

Returns the current consecutive wins.

Property type

Read-only property

Syntax

Visual Basic
Public Property CurConsecWins As Double

Return Type

Current consecutive wins, represented as Double

See Also

CQGTradingSystemStatistics Interface | CQGTradingSystemStatistics Members


%%PageItemTitle%%

CurDrawDown Property
CQGTradingSystemStatistics Interface : CurDrawDown Property

Glossary Item Box

Description

Returns the current draw down.

Property type

Read-only property

Syntax

Visual Basic
Public Property CurDrawDown As Double

Return Type

Current draw down, represented as Double

See Also

CQGTradingSystemStatistics Interface | CQGTradingSystemStatistics Members


%%PageItemTitle%%

LinearRegression Property
CQGTradingSystemStatistics Interface : LinearRegression Property

Glossary Item Box

Description

Returns the linear regression.

Property type

Read-only property

Syntax

Visual Basic
Public Property LinearRegression As Double

Return Type

Linear regression, represented as Double

See Also

CQGTradingSystemStatistics Interface | CQGTradingSystemStatistics Members


%%PageItemTitle%%

MaxClosedDraw Property
CQGTradingSystemStatistics Interface : MaxClosedDraw Property

Glossary Item Box

Description

Returns the maximum closed draw.

Property type

Read-only property

Syntax

Visual Basic
Public Property MaxClosedDraw As Double

Return Type

Maximum closed draw, represented as Double

See Also

CQGTradingSystemStatistics Interface | CQGTradingSystemStatistics Members


%%PageItemTitle%%

MaxConsecLosses Property
CQGTradingSystemStatistics Interface : MaxConsecLosses Property

Glossary Item Box

Description

Returns the maximum consecutive losses.

Property type

Read-only property

Syntax

Visual Basic
Public Property MaxConsecLosses As Double

Return Type

Maximum consecutive losses, represented as Double

See Also

CQGTradingSystemStatistics Interface | CQGTradingSystemStatistics Members


%%PageItemTitle%%

MaxConsecWins Property
CQGTradingSystemStatistics Interface : MaxConsecWins Property

Glossary Item Box

Description

Returns the maximum consecutive wins.

Property type

Read-only property

Syntax

Visual Basic
Public Property MaxConsecWins As Double

Return Type

Maximum consecntive wins, represented as Double

See Also

CQGTradingSystemStatistics Interface | CQGTradingSystemStatistics Members


%%PageItemTitle%%

MaxDrawAmount Property
CQGTradingSystemStatistics Interface : MaxDrawAmount Property

Glossary Item Box

Description

Returns the maximum draw amount.

Property type

Read-only property

Syntax

Visual Basic
Public Property MaxDrawAmount As Double

Return Type

Maximum draw amount, represented as Double

See Also

CQGTradingSystemStatistics Interface | CQGTradingSystemStatistics Members


%%PageItemTitle%%

MaxDrawDuration Property
CQGTradingSystemStatistics Interface : MaxDrawDuration Property

Glossary Item Box

Description

Returns the maximum draw duration.

Property type

Read-only property

Syntax

Visual Basic
Public Property MaxDrawDuration As Double

Return Type

Maximum draw duration, represented as Double

See Also

CQGTradingSystemStatistics Interface | CQGTradingSystemStatistics Members


%%PageItemTitle%%

MaximumLoss Property
CQGTradingSystemStatistics Interface : MaximumLoss Property

Glossary Item Box

Description

Returns the maximum loss.

Property type

Read-only property

Syntax

Visual Basic
Public Property MaximumLoss As Double

Return Type

Maximum loss, represented as Double

See Also

CQGTradingSystemStatistics Interface | CQGTradingSystemStatistics Members


%%PageItemTitle%%

MaximumWin Property
CQGTradingSystemStatistics Interface : MaximumWin Property

Glossary Item Box

Description

Returns the maximum win.

Property type

Read-only property

Syntax

Visual Basic
Public Property MaximumWin As Double

Return Type

Maximum win, represented as Double

See Also

CQGTradingSystemStatistics Interface | CQGTradingSystemStatistics Members


%%PageItemTitle%%

OpenPosition Property
CQGTradingSystemStatistics Interface : OpenPosition Property

Glossary Item Box

Description

Returns the open position.

Property type

Read-only property

Syntax

Visual Basic
Public Property OpenPosition As Double

Return Type

Open position, represented as Double

See Also

CQGTradingSystemStatistics Interface | CQGTradingSystemStatistics Members


%%PageItemTitle%%

PercentLong Property
CQGTradingSystemStatistics Interface : PercentLong Property

Glossary Item Box

Description

Returns the percent long.

Property type

Read-only property

Syntax

Visual Basic
Public Property PercentLong As Double

Return Type

Percent long, represented as Double

See Also

CQGTradingSystemStatistics Interface | CQGTradingSystemStatistics Members


%%PageItemTitle%%

PercentWinners Property
CQGTradingSystemStatistics Interface : PercentWinners Property

Glossary Item Box

Description

Returns the percent of winners.

Property type

Read-only property

Syntax

Visual Basic
Public Property PercentWinners As Double

Return Type

Percent of winners, represented as Double

See Also

CQGTradingSystemStatistics Interface | CQGTradingSystemStatistics Members


%%PageItemTitle%%

ProfitLossRatio Property
CQGTradingSystemStatistics Interface : ProfitLossRatio Property

Glossary Item Box

Description

Returns the profit/loss ratio.

Property type

Read-only property

Syntax

Visual Basic
Public Property ProfitLossRatio As Double

Return Type

Profit/loss ratio, represented as Double

See Also

CQGTradingSystemStatistics Interface | CQGTradingSystemStatistics Members


%%PageItemTitle%%

ProfitToMaxDraw Property
CQGTradingSystemStatistics Interface : ProfitToMaxDraw Property

Glossary Item Box

Description

Returns the profit to maximum draw.

Property type

Read-only property

Syntax

Visual Basic
Public Property ProfitToMaxDraw As Double

Return Type

Profit to maximum draw, represented as Double

See Also

CQGTradingSystemStatistics Interface | CQGTradingSystemStatistics Members


%%PageItemTitle%%

RemoveToNeutral Property
CQGTradingSystemStatistics Interface : RemoveToNeutral Property

Glossary Item Box

Description

Returns the remove to neutral.

Property type

Read-only property

Syntax

Visual Basic
Public Property RemoveToNeutral As Double

Return Type

Remove to neutral, represented as Double

See Also

CQGTradingSystemStatistics Interface | CQGTradingSystemStatistics Members


%%PageItemTitle%%

ReturnRetracement Property
CQGTradingSystemStatistics Interface : ReturnRetracement Property

Glossary Item Box

Description

Returns the return retracement.

Property type

Read-only property

Syntax

Visual Basic
Public Property ReturnRetracement As Double

Return Type

Return retracement, represented as Double

See Also

CQGTradingSystemStatistics Interface | CQGTradingSystemStatistics Members


%%PageItemTitle%%

TimePercentage Property
CQGTradingSystemStatistics Interface : TimePercentage Property

Glossary Item Box

Description

Returns the time percentage.

Property type

Read-only property

Syntax

Visual Basic
Public Property TimePercentage As Double

Return Type

Time percentage, represented as Double

See Also

CQGTradingSystemStatistics Interface | CQGTradingSystemStatistics Members


%%PageItemTitle%%

Timestamp Property
CQGTradingSystemStatistics Interface : Timestamp Property

Glossary Item Box

Description

Returns the timestamp, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

Property type

Read-only property

Syntax

Visual Basic
Public Property Timestamp As Date

Return Type

Timestamp, represented as Date

See Also

CQGTradingSystemStatistics Interface | CQGTradingSystemStatistics Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

TimestampOffset Property
CQGTradingSystemStatistics Interface : TimestampOffset Property

Glossary Item Box

Description

Returns the timestamp offset, which is used to identify various CQGTradingSystemStatistics objects that have the same timestamp.

Property type

Read-only property

Syntax

Visual Basic
Public Property TimestampOffset As Long

Return Type

Timestamp offset, represented as Long

Remarks

The TimestampOffset value grows for subsequent objects. It resets when the timestamp is changed.

See Also

CQGTradingSystemStatistics Interface | CQGTradingSystemStatistics Members


%%PageItemTitle%%

TotalNetProfit Property
CQGTradingSystemStatistics Interface : TotalNetProfit Property

Glossary Item Box

Description

Returns the total net profit.

Property type

Read-only property

Syntax

Visual Basic
Public Property TotalNetProfit As Double

Return Type

Total net profit, represented as Double

See Also

CQGTradingSystemStatistics Interface | CQGTradingSystemStatistics Members


%%PageItemTitle%%

TotalTradeCount Property
CQGTradingSystemStatistics Interface : TotalTradeCount Property

Glossary Item Box

Description

Returns the total trade count.

Property type

Read-only property

Syntax

Visual Basic
Public Property TotalTradeCount As Double

Return Type

Total trade count, represented as Double

See Also

CQGTradingSystemStatistics Interface | CQGTradingSystemStatistics Members


%%PageItemTitle%%

Value Property
ts_statistic
The statistic of interest
CQGTradingSystemStatistics Interface : Value Property

Glossary Item Box

Description

Returns the value of a specified statistic.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Value( _
   ByVal ts_statistic As eTradingSystemStatistic _
) As Double

Parameters

ts_statistic
Value Description
tssAverageDuration

Average duration

tssAverageLoss

Average loss

tssAverageProfit

Average profit

tssAverageWin

Average win

tssClosedNetProfit

Closed net profit

tssCurConsecLosses

Current consecutive losses

tssCurConsecWins

Current consecutive wins

tssCurDrawDown

Current draw down

tssLinearRegression

Linear regression

tssMaxClosedDraw

Maximum closed draw

tssMaxConsecLosses

Maximum consecutive losses

tssMaxConsecWins

Maximum consecutive wins

tssMaxDrawAmount

Maximum draw amount

tssMaxDrawDuration

Maximum draw duration

tssMaximumLoss

Maximum loss

tssMaximumWin

Maximum win

tssOpenPosition

Open position

tssPercentLong

Percent long

tssPercentWinners

Percent winners

tssProfitLossRatio

Profit/loss ration

tssProfitToMaxDraw

Profit to maximum draw

tssRemoveToNeutral

Remove to neutral

tssReturnRetracement

Return retracement

tssTimePercentage

Time percentage

tssTotalNetProfit

Total net profit

tssTotalTradeCount

Total trade count

The statistic of interest

Return Type

Value of specified statistic, represented as Double

See Also

CQGTradingSystemStatistics Interface | CQGTradingSystemStatistics Members | eTradingSystemStatistic Enumeration


%%PageItemTitle%%

CQGTradingSystemStatisticsChangeInfo Interface
See Also Members Send Feedback

Glossary Item Box

Description

This class contains information about the statistics change for a trading system.

Object Model

CQGTradingSystemStatisticsChangeInfo InterfaceCQGTradingSystemStatistics Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTradingSystemStatisticsChangeInfo Members


%%PageItemTitle%% $$Members$$

CQGTradingSystemStatisticsChangeInfo Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method IsStatisticChanged

Returns whether the value of the specified statistic is changed since the last notification or not.

Public Properties

Public Property Statistics

Returns the trading system statistics (with the most recent values).

See Also

CQGTradingSystemStatisticsChangeInfo Interface


%%PageItemTitle%%

IsStatisticChanged Method
trading_system_statistic

The specified statistic

CQGTradingSystemStatisticsChangeInfo Interface : IsStatisticChanged Method

Glossary Item Box

Description

Returns whether the value of the specified statistic is changed since the last notification or not.

Syntax

Visual Basic
Public Function IsStatisticChanged( _
   ByVal trading_system_statistic As eTradingSystemStatistic _
) As Boolean

Parameters

trading_system_statistic
Value Description
tssAverageDuration

Average duration

tssAverageLoss

Average loss

tssAverageProfit

Average profit

tssAverageWin

Average win

tssClosedNetProfit

Closed net profit

tssCurConsecLosses

Current consecutive losses

tssCurConsecWins

Current consecutive wins

tssCurDrawDown

Current draw down

tssLinearRegression

Linear regression

tssMaxClosedDraw

Maximum closed draw

tssMaxConsecLosses

Maximum consecutive losses

tssMaxConsecWins

Maximum consecutive wins

tssMaxDrawAmount

Maximum draw amount

tssMaxDrawDuration

Maximum draw duration

tssMaximumLoss

Maximum loss

tssMaximumWin

Maximum win

tssOpenPosition

Open position

tssPercentLong

Percent long

tssPercentWinners

Percent winners

tssProfitLossRatio

Profit/loss ration

tssProfitToMaxDraw

Profit to maximum draw

tssRemoveToNeutral

Remove to neutral

tssReturnRetracement

Return retracement

tssTimePercentage

Time percentage

tssTotalNetProfit

Total net profit

tssTotalTradeCount

Total trade count

The specified statistic

Return Type

True, if the statistic is changed; False, otherwise

See Also

CQGTradingSystemStatisticsChangeInfo Interface | CQGTradingSystemStatisticsChangeInfo Members | eTradingSystemStatistic Enumeration


%%PageItemTitle%%

Statistics Property
CQGTradingSystemStatisticsChangeInfo Interface : Statistics Property

Glossary Item Box

Description

Returns the trading system statistics (with the most recent values).

Property type

Read-only property

Syntax

Visual Basic
Public Property Statistics As CQGTradingSystemStatistics

Return Type

The updated CQGTradingSystemStatistics object

See Also

CQGTradingSystemStatisticsChangeInfo Interface | CQGTradingSystemStatisticsChangeInfo Members | CQGTradingSystemStatistics Interface


%%PageItemTitle%%

CQGTradingSystemTrade Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a single trade of the trading system.

Object Model

CQGTradingSystemTrade InterfaceCQGTradingSystemTradeDefinition InterfaceCQGTradeEntry InterfaceCQGTradeExits CollectionCQGTradeExit InterfaceCQGTradingSystemTradesRow CollectionCQGTradingSystemTrade Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTradingSystemTrade Members


%%PageItemTitle%% $$Members$$

CQGTradingSystemTrade Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Definition | Returns the trade definition.
Public Property IsActive | Specifies whether the trade is active or not.
Public Property Timestamp | Returns the timestamp, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
Public Property TimestampOffset | Returns the timestamp offset, which is used to identify various CQGTradingSystemTrade objects that have the same timestamp.
Public Property TradeEntry | Returns the entry.
Public Property TradeExits | Returns the exits.
Public Property TradesRow | Represents the owner trade row of CQGTradingSystemTrade.

See Also

CQGTradingSystemTrade Interface


%%PageItemTitle%%

Definition Property
CQGTradingSystemTrade Interface : Definition Property

Glossary Item Box

Description

Returns the trade definition.

Property type

Read-only property

Syntax

Visual Basic
Public Property Definition As CQGTradingSystemTradeDefinition

Return Type

Trade definition, represented as CQGTradingSystemTradeDefinition

See Also

CQGTradingSystemTrade Interface | CQGTradingSystemTrade Members | CQGTradingSystemTradeDefinition Interface


%%PageItemTitle%%

IsActive Property
CQGTradingSystemTrade Interface : IsActive Property

Glossary Item Box

Description

Specifies whether the trade is active or not.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsActive As Boolean

Return Type

True if trade is active, false otherwise

See Also

CQGTradingSystemTrade Interface | CQGTradingSystemTrade Members


%%PageItemTitle%%

Timestamp Property
CQGTradingSystemTrade Interface : Timestamp Property

Glossary Item Box

Description

Returns the timestamp, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

Property type

Read-only property

Syntax

Visual Basic
Public Property Timestamp As Date

Return Type

Timestamp, represented as Date

See Also

CQGTradingSystemTrade Interface | CQGTradingSystemTrade Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

TimestampOffset Property
CQGTradingSystemTrade Interface : TimestampOffset Property

Glossary Item Box

Description

Returns the timestamp offset, which is used to identify various CQGTradingSystemTrade objects that have the same timestamp.

Property type

Read-only property

Syntax

Visual Basic
Public Property TimestampOffset As Long

Return Type

Timestamp offset, represented as Long

Remarks

The TimestampOffset value grows for subsequent objects. It resets when the timestamp is changed.

See Also

CQGTradingSystemTrade Interface | CQGTradingSystemTrade Members


%%PageItemTitle%%

TradeEntry Property
CQGTradingSystemTrade Interface : TradeEntry Property

Glossary Item Box

Description

Returns the entry.

Property type

Read-only property

Syntax

Visual Basic
Public Property TradeEntry As CQGTradeEntry

Return Type

Trade entry, represented as CQGTradeEntry

See Also

CQGTradingSystemTrade Interface | CQGTradingSystemTrade Members | CQGTradeEntry Interface


%%PageItemTitle%%

TradeExits Property
CQGTradingSystemTrade Interface : TradeExits Property

Glossary Item Box

Description

Returns the exits.

Property type

Read-only property

Syntax

Visual Basic
Public Property TradeExits As CQGTradeExits

Return Type

Trade exits, represented as CQGTradeExits

See Also

CQGTradingSystemTrade Interface | CQGTradingSystemTrade Members | CQGTradeExit Interface


%%PageItemTitle%%

TradesRow Property
CQGTradingSystemTrade Interface : TradesRow Property

Glossary Item Box

Description

Represents the owner trade row of CQGTradingSystemTrade.

Property type

Read-only property

Syntax

Visual Basic
Public Property TradesRow As CQGTradingSystemTradesRow

Return Type

Owner trade row, represented as CQGTradingSystemTradesRow

See Also

CQGTradingSystemTrade Interface | CQGTradingSystemTrade Members


%%PageItemTitle%%

CQGTradingSystemTradeDefinition Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a definition of the trading system single trade.

Object Model

CQGTradingSystemTradeDefinition InterfaceCQGTradeEntryDefinition InterfaceCQGTradeExitDefinitions CollectionCQGTradeExitDefinition Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTradingSystemTradeDefinition Members


%%PageItemTitle%% $$Members$$

CQGTradingSystemTradeDefinition Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Entry | Returns the trade entry definition.
Public Property Exits | Returns the trade exits definitions.
Public Property Name | Returns the trade name.
Public Property Side | Returns the trade side.

See Also

CQGTradingSystemTradeDefinition Interface


%%PageItemTitle%%

Entry Property
CQGTradingSystemTradeDefinition Interface : Entry Property

Glossary Item Box

Description

Returns the trade entry definition.

Property type

Read-only property

Syntax

Visual Basic
Public Property Entry As CQGTradeEntryDefinition

Return Type

Trade entry definition, represented as CQGTradeEntryDefinition

See Also

CQGTradingSystemTradeDefinition Interface | CQGTradingSystemTradeDefinition Members | CQGTradeEntryDefinition Interface


%%PageItemTitle%%

Exits Property
CQGTradingSystemTradeDefinition Interface : Exits Property

Glossary Item Box

Description

Returns the trade exits definitions.

Property type

Read-only property

Syntax

Visual Basic
Public Property Exits As CQGTradeExitDefinitions

Return Type

Trade exit definitions, represented as CQGTradeExitDefinitions Object

See Also

CQGTradingSystemTradeDefinition Interface | CQGTradingSystemTradeDefinition Members | CQGTradeExitDefinitions Collection


%%PageItemTitle%%

Name Property
CQGTradingSystemTradeDefinition Interface : Name Property

Glossary Item Box

Description

Returns the trade name.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

Return Type

Trade name, represented as String

See Also

CQGTradingSystemTradeDefinition Interface | CQGTradingSystemTradeDefinition Members


%%PageItemTitle%%

Side Property
CQGTradingSystemTradeDefinition Interface : Side Property

Glossary Item Box

Description

Returns the trade side.

Property type

Read-only property

Syntax

Visual Basic
Public Property Side As eTradeSide

Return Type

Trade side, represented as eTradeSide

Remarks

See eTradeSide for possible values.

See Also

CQGTradingSystemTradeDefinition Interface | CQGTradingSystemTradeDefinition Members | eTradeSide Enumeration


%%PageItemTitle%%

CQGTradingSystemUpdateInfo Interface
See Also Members Send Feedback

Glossary Item Box

Description

This class contains information about the updates made to the trading system.

It is used by the CQGCEL.TradingSystemUpdateNotification event.

Object Model

CQGTradingSystemUpdateInfo InterfaceCQGChangedTradeEntries CollectionCQGChangedTradeEntry InterfaceCQGChangedTradeExits CollectionCQGChangedTradeExit InterfaceCQGTradingSystemStatisticsChangeInfo Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTradingSystemUpdateInfo Members


%%PageItemTitle%% $$Members$$

CQGTradingSystemUpdateInfo Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property ChangedEntries | Returns the collection of changed entries, with optional filtering.
Public Property ChangedExits | Returns the collection of changed exits, with optional filtering.
Public Property Index | Index of updated trade row and/or statistics.
Public Property StatisticsChangeInfo | Returns an object containing information about changed statistics.

See Also

CQGTradingSystemUpdateInfo Interface


%%PageItemTitle%%

ChangedEntries Property
change_filter
Filter specifying which categories of changes are required
CQGTradingSystemUpdateInfo Interface : ChangedEntries Property

Glossary Item Box

Description

Returns the collection of changed entries, with optional filtering.

Property type

Read-only property

Syntax

Visual Basic
Public Property ChangedEntries( _
   Optional ByVal change_filter As eTradeChangeCategory = tccAll _
) As CQGChangedTradeEntries

Parameters

change_filter
Value Description
tccAll All kinds of changes.

The value of this enumerator is tccSignalSet Or tccSignalReset Or tccQuantity Or tccPrice Or tccStopLimitPrice.

tccPrice

Entry/exit price change.

tccQuantity

Entry/exit quantity change.

tccSignalReset

Entry/exit signaled flag reset.

tccSignalSet

Entry/exit signaled flag set.

tccStopLimitPrice

Entry/exit stop-limit price change

Filter specifying which categories of changes are required

Return Type

Collection of changed trade entries, represented as CQGChangedTradeEntries

See Also

CQGTradingSystemUpdateInfo Interface | CQGTradingSystemUpdateInfo Members | CQGChangedTradeEntries Collection


%%PageItemTitle%%

ChangedExits Property
change_filter
Filter specifying which categories of changes are required
CQGTradingSystemUpdateInfo Interface : ChangedExits Property

Glossary Item Box

Description

Returns the collection of changed exits, with optional filtering.

Property type

Read-only property

Syntax

Visual Basic
Public Property ChangedExits( _
   Optional ByVal change_filter As eTradeChangeCategory = tccAll _
) As CQGChangedTradeExits

Parameters

change_filter
Value Description
tccAll All kinds of changes.

The value of this enumerator is tccSignalSet Or tccSignalReset Or tccQuantity Or tccPrice Or tccStopLimitPrice.

tccPrice

Entry/exit price change.

tccQuantity

Entry/exit quantity change.

tccSignalReset

Entry/exit signaled flag reset.

tccSignalSet

Entry/exit signaled flag set.

tccStopLimitPrice

Entry/exit stop-limit price change

Filter specifying which categories of changes are required

Return Type

Collection of changed trade exits, represented as CQGChangedTradeExits

See Also

CQGTradingSystemUpdateInfo Interface | CQGTradingSystemUpdateInfo Members | CQGChangedTradeExits Collection


%%PageItemTitle%%

Index Property
CQGTradingSystemUpdateInfo Interface : Index Property

Glossary Item Box

Description

Index of updated trade row and/or statistics.

Property type

Read-only property

Syntax

Visual Basic
Public Property Index As Long

Return Type

Trade row and/or statistics index, represented as Long

See Also

CQGTradingSystemUpdateInfo Interface | CQGTradingSystemUpdateInfo Members


%%PageItemTitle%%

StatisticsChangeInfo Property
CQGTradingSystemUpdateInfo Interface : StatisticsChangeInfo Property

Glossary Item Box

Description

Returns an object containing information about changed statistics.

Property type

Read-only property

Syntax

Visual Basic
Public Property StatisticsChangeInfo As CQGTradingSystemStatisticsChangeInfo

Return Type

Information about changed statistics, represented as CQGTradingSystemStatisticsChangeInfo object

See Also

CQGTradingSystemUpdateInfo Interface | CQGTradingSystemUpdateInfo Members | CQGTradingSystemStatisticsChangeInfo Interface


%%PageItemTitle%%

CQGTransaction Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents a single order transaction

Object Model

CQGTransaction InterfaceCQGFill InterfaceCQGStringCollection CollectionCQGOrder InterfaceCQGModifiedProperties CollectionCQGModifiedProperty InterfaceCQGStrategyLegFills Collection

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTransaction Members


%%PageItemTitle%% $$Members$$

CQGTransaction Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property ExecutionId | Returns the Gateway execution unique identifier for the transaction.
Public Property Fill | Returns the corresponding fill object.
Public Property FillEffect | Returns a fill effect of the transaction
Public Property HangOrderIds | Returns the collection of Gateway IDs for the leg orders, which participate in a synthetic strategy order hang. This property is used, when the transaction's status is eOrderEvent.oeSyntheticHang.
Public Property HangQuantity | Returns the hang size for the transaction. This property is used, when the transaction's status is eOrderEvent.oeSyntheticHang.
Public Property Id | Returns the Gateway transaction identifier.
Public Property Order | Returns the corresponding order object.
Public Property Properties | Returns the collection of modified order properties.
Public Property RejectReason | Returns the reason of an order request rejection. Order requests include order placement, modification, and cancellation.
Public Property ServerTimestamp | Returns the timestamp of the transaction arrival to the Gateway.
Public Property Status | Returns the order transaction status.
Public Property StrategyLegFills | Returns the collection of strategy leg fills.
Public Property Timestamp | Returns the timestamp of the transaction arrival to API.

See Also

CQGTransaction Interface


%%PageItemTitle%%

ExecutionId Property
CQGTransaction Interface : ExecutionId Property

Glossary Item Box

Description

Returns the Gateway execution unique identifier for the transaction.

Property type

Read-only property

Syntax

Visual Basic
Public Property ExecutionId As String

Return Type

Transaction's execution ID, represented as String

See Also

CQGTransaction Interface | CQGTransaction Members


%%PageItemTitle%%

Fill Property
CQGTransaction Interface : Fill Property

Glossary Item Box

Description

Returns the corresponding fill object.

Property type

Read-only property

Syntax

Visual Basic
Public Property Fill As CQGFill

Return Type

Fill object, represented as CQGFill

Remarks

This property is valid if CQGTransaction.Status = oeFill, oeFillBust, oeFillMod, or oeFillCan.

See Also

CQGTransaction Interface | CQGTransaction Members | CQGFill Interface


%%PageItemTitle%%

FillEffect Property
CQGTransaction Interface : FillEffect Property

Glossary Item Box

Description

Returns a fill effect of the transaction

Property type

Read-only property

Syntax

Visual Basic
Public Property FillEffect As eFillEffect

See Also

CQGTransaction Interface | CQGTransaction Members


%%PageItemTitle%%

HangOrderIds Property
CQGTransaction Interface : HangOrderIds Property

Glossary Item Box

Description

Returns the collection of Gateway IDs for the leg orders, which participate in a synthetic strategy order hang.

This property is used, when the transaction's status is eOrderEvent.oeSyntheticHang.

Property type

Read-only property

Syntax

Visual Basic
Public Property HangOrderIds As CQGStringCollection

Return Type

The corresponding collection of Gateway IDs, represented as CQGStringCollection

See Also

CQGTransaction Interface | CQGTransaction Members


%%PageItemTitle%%

HangQuantity Property
CQGTransaction Interface : HangQuantity Property

Glossary Item Box

Description

Returns the hang size for the transaction.

This property is used, when the transaction's status is eOrderEvent.oeSyntheticHang.

Property type

Read-only property

Syntax

Visual Basic
Public Property HangQuantity As Long

See Also

CQGTransaction Interface | CQGTransaction Members


%%PageItemTitle%%

Id Property
CQGTransaction Interface : Id Property

Glossary Item Box

Description

Returns the Gateway transaction identifier.

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

Return Type

Gateway transaction identifier, represented as String

Remarks

This property holds the same value of CQGFill.Id.

See Also

CQGTransaction Interface | CQGTransaction Members | CQGFill.Id Property


%%PageItemTitle%%

Order Property
CQGTransaction Interface : Order Property

Glossary Item Box

Description

Returns the corresponding order object.

Property type

Read-only property

Syntax

Visual Basic
Public Property Order As CQGOrder

Return Type

Order object, represented as CQGOrder

See Also

CQGTransaction Interface | CQGTransaction Members | CQGOrder Interface


%%PageItemTitle%%

Properties Property
CQGTransaction Interface : Properties Property

Glossary Item Box

Description

Returns the collection of modified order properties.

Property type

Read-only property

Syntax

Visual Basic
Public Property Properties As CQGModifiedProperties

Return Type

Collection of modified properties, represented as CQGModifiedProperties

Remarks

This property is valid if CQGTransaction.Status = oeAckMod.

See Also

CQGTransaction Interface | CQGTransaction Members | CQGModifiedProperties Collection | CQGTransaction.Status Property | eOrderEvent Enumeration


%%PageItemTitle%%

RejectReason Property
CQGTransaction Interface : RejectReason Property

Glossary Item Box

Description

Returns the reason of an order request rejection.

Order requests include order placement, modification, and cancellation.

Property type

Read-only property

Syntax

Visual Basic
Public Property RejectReason As String

Return Type

Reason of order request rejection, represented as String

See Also

CQGTransaction Interface | CQGTransaction Members


%%PageItemTitle%%

ServerTimestamp Property
CQGTransaction Interface : ServerTimestamp Property

Glossary Item Box

Description

Returns the timestamp of the transaction arrival to the Gateway.

Property type

Read-only property

Syntax

Visual Basic
Public Property ServerTimestamp As Date

Return Type

Server timestamp, represented as Date

Remarks

The timestamp is converted to the timezone previously configured by the user.

If no timezone configuration was made, the timestamp is converted to UTC.

See Also

CQGTransaction Interface | CQGTransaction Members


%%PageItemTitle%%

Status Property
CQGTransaction Interface : Status Property

Glossary Item Box

Description

Returns the order transaction status.

Property type

Read-only property

Syntax

Visual Basic
Public Property Status As eOrderEvent

Return Type

Order transaction status, represented as eOrderEvent

See Also

CQGTransaction Interface | CQGTransaction Members | eOrderEvent Enumeration


%%PageItemTitle%%

StrategyLegFills Property
CQGTransaction Interface : StrategyLegFills Property

Glossary Item Box

Description

Returns the collection of strategy leg fills.

Property type

Read-only property

Syntax

Visual Basic
Public Property StrategyLegFills As CQGStrategyLegFills

Return Type

The corresponding collection of strategy leg fills, represented as CQGStrategyLegFills

See Also

CQGTransaction Interface | CQGTransaction Members


%%PageItemTitle%%

Timestamp Property
CQGTransaction Interface : Timestamp Property

Glossary Item Box

Description

Returns the timestamp of the transaction arrival to API.

Property type

Read-only property

Syntax

Visual Basic
Public Property Timestamp As Date

Return Type

Local PC timestamp, represented as Date

Remarks

The timestamp is converted to the timezone previously configured by the user.

If no timezone configuration was made, the timestamp is converted to UTC.

See Also

CQGTransaction Interface | CQGTransaction Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

CQGYield Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents class for a yield

Object Model

CQGYield Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGYield Members


%%PageItemTitle%% $$Members$$

CQGYield Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Avg | Returns the average
Public Property Close | Returns the close
Public Property High | Returns the high
Public Property HLC3 | Returns the (High+Low+Close)/3
Public Property Low | Returns the low
Public Property Mid | Returns the mid-point
Public Property Open | Returns the open
Public Property Range | Returns the range
Public Property Timestamp | Returns the timestamp, in user configured time zone
Public Property TrueHigh | Returns the true high
Public Property TrueLow | Returns the true low
Public Property TrueRange | Returns the true range

See Also

CQGYield Interface


%%PageItemTitle%%

Avg Property
CQGYield Interface : Avg Property

Glossary Item Box

Description

Returns the average

Property type

Read-only property

Syntax

Visual Basic
Public Property Avg As Double

See Also

CQGYield Interface | CQGYield Members


%%PageItemTitle%%

Close Property
CQGYield Interface : Close Property

Glossary Item Box

Description

Returns the close

Property type

Read-only property

Syntax

Visual Basic
Public Property Close As Double

See Also

CQGYield Interface | CQGYield Members


%%PageItemTitle%%

High Property
CQGYield Interface : High Property

Glossary Item Box

Description

Returns the high

Property type

Read-only property

Syntax

Visual Basic
Public Property High As Double

See Also

CQGYield Interface | CQGYield Members


%%PageItemTitle%%

HLC3 Property
CQGYield Interface : HLC3 Property

Glossary Item Box

Description

Returns the (High+Low+Close)/3

Property type

Read-only property

Syntax

Visual Basic
Public Property HLC3 As Double

See Also

CQGYield Interface | CQGYield Members


%%PageItemTitle%%

Low Property
CQGYield Interface : Low Property

Glossary Item Box

Description

Returns the low

Property type

Read-only property

Syntax

Visual Basic
Public Property Low As Double

See Also

CQGYield Interface | CQGYield Members


%%PageItemTitle%%

Mid Property
CQGYield Interface : Mid Property

Glossary Item Box

Description

Returns the mid-point

Property type

Read-only property

Syntax

Visual Basic
Public Property Mid As Double

See Also

CQGYield Interface | CQGYield Members


%%PageItemTitle%%

Open Property
CQGYield Interface : Open Property

Glossary Item Box

Description

Returns the open

Property type

Read-only property

Syntax

Visual Basic
Public Property Open As Double

See Also

CQGYield Interface | CQGYield Members


%%PageItemTitle%%

Range Property
CQGYield Interface : Range Property

Glossary Item Box

Description

Returns the range

Property type

Read-only property

Syntax

Visual Basic
Public Property Range As Double

See Also

CQGYield Interface | CQGYield Members


%%PageItemTitle%%

Timestamp Property
CQGYield Interface : Timestamp Property

Glossary Item Box

Description

Returns the timestamp, in user configured time zone

Property type

Read-only property

Syntax

Visual Basic
Public Property Timestamp As Date

See Also

CQGYield Interface | CQGYield Members


%%PageItemTitle%%

TrueHigh Property
CQGYield Interface : TrueHigh Property

Glossary Item Box

Description

Returns the true high

Property type

Read-only property

Syntax

Visual Basic
Public Property TrueHigh As Double

See Also

CQGYield Interface | CQGYield Members


%%PageItemTitle%%

TrueLow Property
CQGYield Interface : TrueLow Property

Glossary Item Box

Description

Returns the true low

Property type

Read-only property

Syntax

Visual Basic
Public Property TrueLow As Double

See Also

CQGYield Interface | CQGYield Members


%%PageItemTitle%%

TrueRange Property
CQGYield Interface : TrueRange Property

Glossary Item Box

Description

Returns the true range

Property type

Read-only property

Syntax

Visual Basic
Public Property TrueRange As Double

See Also

CQGYield Interface | CQGYield Members


%%PageItemTitle%%

CQGYieldsRequest Interface
See Also Members Send Feedback

Glossary Item Box

Description

Represents parameters for yields request

Object Model

CQGYieldsRequest Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGYieldsRequest Members


%%PageItemTitle%% $$Members$$

CQGYieldsRequest Interface Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Compound | Returns the compound which will be used in yields request
Public Property Continuation | Returns the continuation type which will be used in yields request
Public Property DaysBeforeExpiration | Returns the days before expiration which will be used in yields request
Public Property EqualizeCloses | Returns the equalize closes flag which will be used in yields request
Public Property IncludeEnd | Returns the include end flag which will be used in yields request
Public Property Model | Returns the model which will be used in yields request
Public Property RangeEnd | Returns the range end which will be used in yields request
Public Property RangeStart | Returns the range start which will be used in yields request
Public Property RecalcPeriod | Sets the ticks recalculation period which will be used in yields bars request
Public Property SessionFlags | Returns the session flags which will be used in yields request
Public Property SessionsFilter | Returns the sessions filter which will be used in yields request
Public Property SubscriptionLevel | Sets the subscription level which will be used in yields request
Public Property Symbol | Returns the symbol which will be used in yields request
Public Property UpdatesEnabled | Returns the updates enabled flag which will be used in yields request

See Also

CQGYieldsRequest Interface


%%PageItemTitle%%

Compound Property
CQGYieldsRequest Interface : Compound Property

Glossary Item Box

Description

Returns the compound which will be used in yields request

Property type

Read-write property

Syntax

Visual Basic
Public Property Compound As eYieldCompound

See Also

CQGYieldsRequest Interface | CQGYieldsRequest Members


%%PageItemTitle%%

Continuation Property
CQGYieldsRequest Interface : Continuation Property

Glossary Item Box

Description

Returns the continuation type which will be used in yields request

Property type

Read-write property

Syntax

Visual Basic
Public Property Continuation As eTimeSeriesContinuationType

See Also

CQGYieldsRequest Interface | CQGYieldsRequest Members


%%PageItemTitle%%

DaysBeforeExpiration Property
CQGYieldsRequest Interface : DaysBeforeExpiration Property

Glossary Item Box

Description

Returns the days before expiration which will be used in yields request

Property type

Read-write property

Syntax

Visual Basic
Public Property DaysBeforeExpiration As Long

See Also

CQGYieldsRequest Interface | CQGYieldsRequest Members


%%PageItemTitle%%

EqualizeCloses Property
CQGYieldsRequest Interface : EqualizeCloses Property

Glossary Item Box

Description

Returns the equalize closes flag which will be used in yields request

Property type

Read-write property

Syntax

Visual Basic
Public Property EqualizeCloses As Boolean

See Also

CQGYieldsRequest Interface | CQGYieldsRequest Members


%%PageItemTitle%%

IncludeEnd Property
CQGYieldsRequest Interface : IncludeEnd Property

Glossary Item Box

Description

Returns the include end flag which will be used in yields request

Property type

Read-write property

Syntax

Visual Basic
Public Property IncludeEnd As Boolean

Remarks

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGYieldsRequest Interface | CQGYieldsRequest Members


%%PageItemTitle%%

Model Property
CQGYieldsRequest Interface : Model Property

Glossary Item Box

Description

Returns the model which will be used in yields request

Property type

Read-write property

Syntax

Visual Basic
Public Property Model As eYieldModel

See Also

CQGYieldsRequest Interface | CQGYieldsRequest Members


%%PageItemTitle%%

RangeEnd Property
CQGYieldsRequest Interface : RangeEnd Property

Glossary Item Box

Description

Returns the range end which will be used in yields request

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeEnd As Variant

Remarks

Only Date and integer are allowed for types of RangeStart/RangeEnd properties.

  • If the type is Date, RangeStart/RangeEnd represent date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode). Non-timed bar requests process date/time range values with a precision of up to minutes.
  • All combinations of Date and integer can apply for these properties, except integer/Date.
  • If RangeEnd type is integer, then it represents the count of records prior to RangeStart to be requested, so it must be a negative value.
  • If RangeEnd is date, it must be further in time than RangeStart.

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGYieldsRequest Interface | CQGYieldsRequest Members


%%PageItemTitle%%

RangeStart Property
CQGYieldsRequest Interface : RangeStart Property

Glossary Item Box

Description

Returns the range start which will be used in yields request

Property type

Read-write property

Syntax

Visual Basic
Public Property RangeStart As Variant

Remarks

Only Date and integer are allowed for types of RangeStart/RangeEnd properties:

  • All combinations of Date and Integer can apply for these properties, except Integer/Date.
  • If type is Date, RangeStart represents date/time in the user-configured time zone (CQGAPIConfig.TimeZoneCode). Non-timed bar requests process date/time range values with a precision of up to minutes.
  • If type is Integer, RangeStart represents the current condition's result number (0 is the current condition result number, negative numbers represent condition results in the past, positive numbers - in the future).
  • If the type of RangeStart is integer, it shall be 0 (denoting "current").

If you would like to request data from specific time in the past to current time with updates, then check out the following link.

See Also

CQGYieldsRequest Interface | CQGYieldsRequest Members


%%PageItemTitle%%

RecalcPeriod Property
CQGYieldsRequest Interface : RecalcPeriod Property

Glossary Item Box

Description

Sets the ticks recalculation period which will be used in yields bars request

Property type

Read-write property

Syntax

Visual Basic
Public Property RecalcPeriod As Long

See Also

CQGYieldsRequest Interface | CQGYieldsRequest Members


%%PageItemTitle%%

SessionFlags Property
CQGYieldsRequest Interface : SessionFlags Property

Glossary Item Box

Description

Returns the session flags which will be used in yields request

Property type

Read-write property

Syntax

Visual Basic
Public Property SessionFlags As eSessionFlag

See Also

CQGYieldsRequest Interface | CQGYieldsRequest Members


%%PageItemTitle%%

SessionsFilter Property
CQGYieldsRequest Interface : SessionsFilter Property

Glossary Item Box

Description

Returns the sessions filter which will be used in yields request

Property type

Read-write property

Syntax

Visual Basic
Public Property SessionsFilter As Variant

See Also

CQGYieldsRequest Interface | CQGYieldsRequest Members


%%PageItemTitle%%

SubscriptionLevel Property
CQGYieldsRequest Interface : SubscriptionLevel Property

Glossary Item Box

Description

Sets the subscription level which will be used in yields request

Property type

Read-write property

Syntax

Visual Basic
Public Property SubscriptionLevel As eTimeSeriesSubscriptionLevel

See Also

CQGYieldsRequest Interface | CQGYieldsRequest Members


%%PageItemTitle%%

Symbol Property
CQGYieldsRequest Interface : Symbol Property

Glossary Item Box

Description

Returns the symbol which will be used in yields request

Property type

Read-write property

Syntax

Visual Basic
Public Property Symbol As String

See Also

CQGYieldsRequest Interface | CQGYieldsRequest Members


%%PageItemTitle%%

UpdatesEnabled Property
CQGYieldsRequest Interface : UpdatesEnabled Property

Glossary Item Box

Description

Returns the updates enabled flag which will be used in yields request

Property type

Read-write property

Syntax

Visual Basic
Public Property UpdatesEnabled As Boolean

See Also

CQGYieldsRequest Interface | CQGYieldsRequest Members


%%PageItemTitle%%

CQGAccounts Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGAccount objects.

Object Model

CQGAccounts CollectionCQGAccount Interface

Remarks

The collection is filled only on CQG Gateway logon. New accounts will not be added to this collection at run time.

Access to an item in this collection can be made based on either the account Gateway ID or the Account FCM ID / FCM ID pair.

See Accessing non-existent collection items for details on accessing items that do not exist in the collection.

Example

See the usage of CQGAccounts collection in the AccountChanged event's example section.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGAccounts Members


%%PageItemTitle%% $$Members$$

CQGAccounts Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method Add Adds an account to collection

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of accounts in the collection.
Public Property Item | Returns the selected account from the collection. This is the default property.
Public Property ItemByFCM | Returns a CQGAccount object based on its FCM account ID and fcmID.
Public Property ItemByIndex | Returns the corresponding account by its sequential index.

See Also

CQGAccounts Collection


%%PageItemTitle%%

Add Method
cqg_account
Account to be added to the collection.
CQGAccounts Collection : Add Method

Glossary Item Box

Description

Adds an account to collection

Syntax

Visual Basic
Public Sub Add( _
   ByVal cqg_account As CQGAccount _
)

Parameters

cqg_account
Account to be added to the collection.

See Also

CQGAccounts Collection | CQGAccounts Members


%%PageItemTitle%%

_NewEnum Property
CQGAccounts Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGAccounts Collection | CQGAccounts Members


%%PageItemTitle%%

Count Property
CQGAccounts Collection : Count Property

Glossary Item Box

Description

Returns the number of accounts in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of accounts represented as Long

Example

See the usage of CQGAccounts' properties in the AccountChanged event's example section.

See Also

CQGAccounts Collection | CQGAccounts Members


%%PageItemTitle%%

Item Property
gw_account_id
CQG Gateway account identifier
CQGAccounts Collection : Item Property

Glossary Item Box

Description

Returns the selected account from the collection.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal gw_account_id As Long _
) As CQGAccount

Parameters

gw_account_id
CQG Gateway account identifier

Return Type

If the account exists in the collection, this property returns the selected account represented as CQGAccount object.

If the accessed item does not exist, see Accessing non-existent collection items to learn more about the return type.

Example

See the usage of CQGAccounts' properties in the AccountChanged event's example section.

See Also

CQGAccounts Collection | CQGAccounts Members


%%PageItemTitle%%

ItemByFCM Property
fcm_account_id
FCM account identifier
fcm_id
FCM identifier
CQGAccounts Collection : ItemByFCM Property

Glossary Item Box

Description

Returns a CQGAccount object based on its FCM account ID and fcmID.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemByFCM( _
   ByVal fcm_account_id As String, _
   ByVal fcm_id As Long _
) As CQGAccount

Parameters

fcm_account_id
FCM account identifier
fcm_id
FCM identifier

Return Type

Returns the selected account if found.

If the accessed item does not exist, see Accessing non-existent collection items to learn more about the return type.

Example

See the usage of CQGAccounts' properties in the AccountChanged event's example section.

See Also

CQGAccounts Collection | CQGAccounts Members


%%PageItemTitle%%

ItemByIndex Property
index_
Zero-based index of item in the collection
CQGAccounts Collection : ItemByIndex Property

Glossary Item Box

Description

Returns the corresponding account by its sequential index.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemByIndex( _
   ByVal index_ As Long _
) As CQGAccount

Parameters

index_
Zero-based index of item in the collection

Return Type

Account object, represented as CQGAccount

Remarks

If no CQGAccount object exists with the specified identifier, depending on the CQGAPIConfig settings; it either returns "Nothing" if no such item is present in the collection, or throws an exception.

Example

See the usage of CQGAccounts' properties in the AccountChanged event's example section.

See Also

CQGAccounts Collection | CQGAccounts Members


%%PageItemTitle%%

CQGAccountSummaries Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGAccountSummary objects calculated for each currency in an account.

Object Model

CQGAccountSummaries CollectionCQGAccountSummary Interface

Remarks

In this collection, there are account summaries calculated for each currency on which the account has a position.

Access to an item in this collection can be made based on the currency ISO code or the currency 0-based index.

See Accessing non-existent collection items for details on accessing items that do not exist in the collection.

Example

See the usage of CQGAccountSummeries collection in the AccountChanged event's example section.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGAccountSummaries Members


%%PageItemTitle%% $$Members$$

CQGAccountSummaries Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of account summaries in the collection.
Public Property Item | Returns the selected summary from the collection. This is the default property.

See Also

CQGAccountSummaries Collection


%%PageItemTitle%%

_NewEnum Property
CQGAccountSummaries Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGAccountSummaries Collection | CQGAccountSummaries Members


%%PageItemTitle%%

Count Property
CQGAccountSummaries Collection : Count Property

Glossary Item Box

Description

Returns the number of account summaries in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of summaries represented as Long

Example

See the usage of CQGAccountSummeries' properties in the AccountChanged event's example section.

See Also

CQGAccountSummaries Collection | CQGAccountSummaries Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGAccountSummaries Collection : Item Property

Glossary Item Box

Description

Returns the selected summary from the collection.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Variant _
) As CQGAccountSummary

Parameters

index_
Zero-based index of item in the collection

Return Type

If the summary exists in the collection, returns the selected summary represented as CQGAccountSummary object.

If the accessed item does not exist, see Accessing non-existent collection items to learn more about the return type.

Example

See the usage of CQGAccountSummeries' properties in the AccountChanged event's example section.

See Also

CQGAccountSummaries Collection | CQGAccountSummaries Members


%%PageItemTitle%%

CQGAdvancedStudies Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGAdvancedStudy objects.

Object Model

CQGAdvancedStudies CollectionCQGAdvancedStudy Collection

Remarks

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGAdvancedStudies Members


%%PageItemTitle%% $$Members$$

CQGAdvancedStudies Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGAdvancedStudy in the collection
Public Property Item | Returns the CQGAdvancedStudy by index
Public Property ItemById | Returns the CQGAdvancedStudy by id

See Also

CQGAdvancedStudies Collection


%%PageItemTitle%%

_NewEnum Property
CQGAdvancedStudies Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGAdvancedStudies Collection | CQGAdvancedStudies Members


%%PageItemTitle%%

Count Property
CQGAdvancedStudies Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGAdvancedStudy in the collection

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

CQGAdvancedStudies Collection | CQGAdvancedStudies Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGAdvancedStudies Collection : Item Property

Glossary Item Box

Description

Returns the CQGAdvancedStudy by index

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGAdvancedStudy

Parameters

index_
Zero-based index of item in the collection

See Also

CQGAdvancedStudies Collection | CQGAdvancedStudies Members


%%PageItemTitle%%

ItemById Property
id_
Unique identifier of advanced study
CQGAdvancedStudies Collection : ItemById Property

Glossary Item Box

Description

Returns the CQGAdvancedStudy by id

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemById( _
   ByVal id_ As String _
) As CQGAdvancedStudy

Parameters

id_
Unique identifier of advanced study

See Also

CQGAdvancedStudies Collection | CQGAdvancedStudies Members


%%PageItemTitle%%

CQGAdvancedStudy Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGCurves objects.

Object Model

CQGAdvancedStudy CollectionCQGCurves Collection

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGAdvancedStudy Members


%%PageItemTitle%% $$Members$$

CQGAdvancedStudy Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method IndexForDate Returns start index for specified date

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGCurves in the collection
Public Property CurveHeaders | Returns the headers of included curves
Public Property Definition | Returns the advanced study definition
Public Property EndTimestamp | Returns the ending (maximum) timestamp of all arrived curves so far
Public Property Id | Returns the unique identifier of advanced study
Public Property Item | Returns the CQGCurves by index
Public Property LastError | Returns CQGError object describing the last error occurred to this object
Public Property Request | Returns the read-only copy of CQGAdvancedStudyRequest object
Public Property StartTimestamp | Returns the starting (minimum) timestamp of all arrived curves
Public Property Status | Returns the status
Public Property Tag | Returns a user defined value

See Also

CQGAdvancedStudy Collection


%%PageItemTitle%%

IndexForDate Method
date_

Date for which index is needed

CQGAdvancedStudy Collection : IndexForDate Method

Glossary Item Box

Description

Returns start index for specified date

Syntax

Visual Basic
Public Function IndexForDate( _
   ByVal date_ As Date _
) As Long

Parameters

date_

Date for which index is needed

Return Type

Index of the first record which date is equal to the specified date.

See Also

CQGAdvancedStudy Collection | CQGAdvancedStudy Members


%%PageItemTitle%%

_NewEnum Property
CQGAdvancedStudy Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGAdvancedStudy Collection | CQGAdvancedStudy Members


%%PageItemTitle%%

Count Property
CQGAdvancedStudy Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGCurves in the collection

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

CQGAdvancedStudy Collection | CQGAdvancedStudy Members


%%PageItemTitle%%

CurveHeaders Property
CQGAdvancedStudy Collection : CurveHeaders Property

Glossary Item Box

Description

Returns the headers of included curves

Property type

Read-only property

Syntax

Visual Basic
Public Property CurveHeaders As CQGCurveHeaders

See Also

CQGAdvancedStudy Collection | CQGAdvancedStudy Members


%%PageItemTitle%%

Definition Property
CQGAdvancedStudy Collection : Definition Property

Glossary Item Box

Description

Returns the advanced study definition

Property type

Read-only property

Syntax

Visual Basic
Public Property Definition As CQGAdvancedStudyDefinition

See Also

CQGAdvancedStudy Collection | CQGAdvancedStudy Members


%%PageItemTitle%%

EndTimestamp Property
CQGAdvancedStudy Collection : EndTimestamp Property

Glossary Item Box

Description

Returns the ending (maximum) timestamp of all arrived curves so far

Property type

Read-only property

Syntax

Visual Basic
Public Property EndTimestamp As Date

See Also

CQGAdvancedStudy Collection | CQGAdvancedStudy Members


%%PageItemTitle%%

Id Property
CQGAdvancedStudy Collection : Id Property

Glossary Item Box

Description

Returns the unique identifier of advanced study

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

CQGAdvancedStudy Collection | CQGAdvancedStudy Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGAdvancedStudy Collection : Item Property

Glossary Item Box

Description

Returns the CQGCurves by index

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGCurves

Parameters

index_
Zero-based index of item in the collection

See Also

CQGAdvancedStudy Collection | CQGAdvancedStudy Members


%%PageItemTitle%%

LastError Property
CQGAdvancedStudy Collection : LastError Property

Glossary Item Box

Description

Returns CQGError object describing the last error occurred to this object

Property type

Read-only property

Syntax

Visual Basic
Public Property LastError As CQGError

See Also

CQGAdvancedStudy Collection | CQGAdvancedStudy Members


%%PageItemTitle%%

Request Property
CQGAdvancedStudy Collection : Request Property

Glossary Item Box

Description

Returns the read-only copy of CQGAdvancedStudyRequest object

Property type

Read-only property

Syntax

Visual Basic
Public Property Request As CQGAdvancedStudyRequest

See Also

CQGAdvancedStudy Collection | CQGAdvancedStudy Members


%%PageItemTitle%%

StartTimestamp Property
CQGAdvancedStudy Collection : StartTimestamp Property

Glossary Item Box

Description

Returns the starting (minimum) timestamp of all arrived curves

Property type

Read-only property

Syntax

Visual Basic
Public Property StartTimestamp As Date

See Also

CQGAdvancedStudy Collection | CQGAdvancedStudy Members


%%PageItemTitle%%

Status Property
CQGAdvancedStudy Collection : Status Property

Glossary Item Box

Description

Returns the status

Property type

Read-only property

Syntax

Visual Basic
Public Property Status As eRequestStatus

See Also

CQGAdvancedStudy Collection | CQGAdvancedStudy Members


%%PageItemTitle%%

Tag Property
tag_name
User tag name
CQGAdvancedStudy Collection : Tag Property

Glossary Item Box

Description

Returns a user defined value

Property type

Read-write property

Syntax

Visual Basic
Public Property Tag( _
   ByVal tag_name As String _
) As Variant

Parameters

tag_name
User tag name

See Also

CQGAdvancedStudy Collection | CQGAdvancedStudy Members


%%PageItemTitle%%

CQGAdvancedStudyDefinitions Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGAdvancedStudyDefinition objects.

Object Model

CQGAdvancedStudyDefinitions CollectionCQGAdvancedStudyDefinition Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGAdvancedStudyDefinitions Members


%%PageItemTitle%% $$Members$$

CQGAdvancedStudyDefinitions Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGAlgorithmicOrderDefinition objects in the collection.
Public Property Item | Returns the CQGAlgorithmicOrderDefinition by index. This is the default property
Public Property ItemByAbbreviation | Returns the CQGAdvancedStudyDefinition by abbreviation
Public Property ItemByName | Returns the CQGAdvancedStudyDefinition by name

See Also

CQGAdvancedStudyDefinitions Collection


%%PageItemTitle%%

_NewEnum Property
CQGAdvancedStudyDefinitions Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGAdvancedStudyDefinitions Collection | CQGAdvancedStudyDefinitions Members


%%PageItemTitle%%

Count Property
CQGAdvancedStudyDefinitions Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGAlgorithmicOrderDefinition objects in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of property definitions, represented as Long

See Also

CQGAdvancedStudyDefinitions Collection | CQGAdvancedStudyDefinitions Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGAdvancedStudyDefinitions Collection : Item Property

Glossary Item Box

Description

Returns the CQGAlgorithmicOrderDefinition by index.

This is the default property

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGAdvancedStudyDefinition

Parameters

index_
Zero-based index of item in the collection

See Also

CQGAdvancedStudyDefinitions Collection | CQGAdvancedStudyDefinitions Members


%%PageItemTitle%%

ItemByAbbreviation Property
advanced_study_abbreviation

Abbreviation of the study definition in the collection

CQGAdvancedStudyDefinitions Collection : ItemByAbbreviation Property

Glossary Item Box

Description

Returns the CQGAdvancedStudyDefinition by abbreviation

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemByAbbreviation( _
   ByVal advanced_study_abbreviation As String _
) As CQGAdvancedStudyDefinition

Parameters

advanced_study_abbreviation

Abbreviation of the study definition in the collection

See Also

CQGAdvancedStudyDefinitions Collection | CQGAdvancedStudyDefinitions Members


%%PageItemTitle%%

ItemByName Property
advanced_study_name

Name of the study definition in the collection

CQGAdvancedStudyDefinitions Collection : ItemByName Property

Glossary Item Box

Description

Returns the CQGAdvancedStudyDefinition by name

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemByName( _
   ByVal advanced_study_name As String _
) As CQGAdvancedStudyDefinition

Parameters

advanced_study_name

Name of the study definition in the collection

See Also

CQGAdvancedStudyDefinitions Collection | CQGAdvancedStudyDefinitions Members


%%PageItemTitle%%

CQGAlgorithmicOrderDefinitions Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGAlgorithmicOrderDefinition objects.

Object Model

CQGAlgorithmicOrderDefinitions CollectionCQGAlgorithmicOrderDefinition Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGAlgorithmicOrderDefinitions Members


%%PageItemTitle%% $$Members$$

CQGAlgorithmicOrderDefinitions Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method Add | Adds a algorithmic order property definition to the collection.
Public Method CreateDefinition | Creates a new algorithmic order property definition.

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGAlgorithmicOrderDefinition objects in the collection.
Public Property Item | Returns the CQGAlgorithmicOrderDefinition by index. This is the default property.

See Also

CQGAlgorithmicOrderDefinitions Collection


%%PageItemTitle%%

Add Method
definition_

Definition to be added to the collection.

CQGAlgorithmicOrderDefinitions Collection : Add Method

Glossary Item Box

Description

Adds a algorithmic order property definition to the collection.

Syntax

Visual Basic
Public Sub Add( _
   ByVal definition_ As CQGAlgorithmicOrderDefinition _
)

Parameters

definition_

Definition to be added to the collection.

Remarks

An exception will be thrown if there's existing definition with the same name as the definition_ (case-insensitive)

See Also

CQGAlgorithmicOrderDefinitions Collection | CQGAlgorithmicOrderDefinitions Members | CQGAlgorithmicOrderDefinition Interface


%%PageItemTitle%%

CreateDefinition Method
CQGAlgorithmicOrderDefinitions Collection : CreateDefinition Method

Glossary Item Box

Description

Creates a new algorithmic order property definition.

Syntax

Visual Basic
Public Function CreateDefinition() As CQGAlgorithmicOrderDefinition

Return Type

Property definition, represented as CQGCustomOrderDefinition

See Also

CQGAlgorithmicOrderDefinitions Collection | CQGAlgorithmicOrderDefinitions Members | CQGAlgorithmicOrderDefinition Interface


%%PageItemTitle%%

_NewEnum Property
CQGAlgorithmicOrderDefinitions Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGAlgorithmicOrderDefinitions Collection | CQGAlgorithmicOrderDefinitions Members


%%PageItemTitle%%

Count Property
CQGAlgorithmicOrderDefinitions Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGAlgorithmicOrderDefinition objects in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of property definitions, represented as Long

See Also

CQGAlgorithmicOrderDefinitions Collection | CQGAlgorithmicOrderDefinitions Members | CQGAlgorithmicOrderDefinition Interface


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGAlgorithmicOrderDefinitions Collection : Item Property

Glossary Item Box

Description

Returns the CQGAlgorithmicOrderDefinition by index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGAlgorithmicOrderDefinition

Parameters

index_
Zero-based index of item in the collection

See Also

CQGAlgorithmicOrderDefinitions Collection | CQGAlgorithmicOrderDefinitions Members | CQGAlgorithmicOrderDefinition Interface


%%PageItemTitle%%

CQGAlgorithmicOrderProperties Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGAlgorithmicOrderProperty objects.

Object Model

CQGAlgorithmicOrderProperties CollectionCQGAlgorithmicOrderProperty Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGAlgorithmicOrderProperties Members


%%PageItemTitle%% $$Members$$

CQGAlgorithmicOrderProperties Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGAlgorithmicOrderProperty objects in the collection.
Public Property Item | Returns the CQGAlgorithmicOrderProperty object by its index. This is the default property.

See Also

CQGAlgorithmicOrderProperties Collection


%%PageItemTitle%%

_NewEnum Property
CQGAlgorithmicOrderProperties Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGAlgorithmicOrderProperties Collection | CQGAlgorithmicOrderProperties Members


%%PageItemTitle%%

Count Property
CQGAlgorithmicOrderProperties Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGAlgorithmicOrderProperty objects in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of collection items, represented as Long

See Also

CQGAlgorithmicOrderProperties Collection | CQGAlgorithmicOrderProperties Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGAlgorithmicOrderProperties Collection : Item Property

Glossary Item Box

Description

Returns the CQGAlgorithmicOrderProperty object by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGAlgorithmicOrderProperty

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item, represented as CQGAlgorithmicOrderProperty

See Also

CQGAlgorithmicOrderProperties Collection | CQGAlgorithmicOrderProperties Members


%%PageItemTitle%%

CQGBarsTimestamps Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of DateTimes

Object Model

CQGBarsTimestamps Collection

Remarks

The CQGCEL.BarsTimestampsResolved event is fired for CQGBarsTimestamps.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGBarsTimestamps Members


%%PageItemTitle%% $$Members$$

CQGBarsTimestamps Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of timestamp records in the collection.
Public Property Id | Returns the unique identifier of timed bars timestamps.
Public Property Item | Returns the timestamp by its index. This is the default property.
Public Property LastError | Returns the CQGError object describing the last error occurred to this object or Nothing/Invalid_Error in case of no error.
Public Property Status | Returns the request status.

See Also

CQGBarsTimestamps Collection


%%PageItemTitle%%

_NewEnum Property
CQGBarsTimestamps Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGBarsTimestamps Collection | CQGBarsTimestamps Members


%%PageItemTitle%%

Count Property
CQGBarsTimestamps Collection : Count Property

Glossary Item Box

Description

Returns the number of timestamp records in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of timestamps in the collection, represented as Long

See Also

CQGBarsTimestamps Collection | CQGBarsTimestamps Members


%%PageItemTitle%%

Id Property
CQGBarsTimestamps Collection : Id Property

Glossary Item Box

Description

Returns the unique identifier of timed bars timestamps.

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

Return Type

Unique identifier, represented as String

See Also

CQGBarsTimestamps Collection | CQGBarsTimestamps Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGBarsTimestamps Collection : Item Property

Glossary Item Box

Description

Returns the timestamp by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As Date

Parameters

index_
Zero-based index of item in the collection

Return Type

Timestamp, represented as Date

See Also

CQGBarsTimestamps Collection | CQGBarsTimestamps Members


%%PageItemTitle%%

LastError Property
CQGBarsTimestamps Collection : LastError Property

Glossary Item Box

Description

Returns the CQGError object describing the last error occurred to this object or Nothing/Invalid_Error in case of no error.

Property type

Read-only property

Syntax

Visual Basic
Public Property LastError As CQGError

Return Type

Object's last error, represented as CQGError object

See Also

CQGBarsTimestamps Collection | CQGBarsTimestamps Members


%%PageItemTitle%%

Status Property
CQGBarsTimestamps Collection : Status Property

Glossary Item Box

Description

Returns the request status.

Property type

Read-only property

Syntax

Visual Basic
Public Property Status As eRequestStatus

Return Type

Request status, represented as eRequestStatus

See Also

CQGBarsTimestamps Collection | CQGBarsTimestamps Members


%%PageItemTitle%%

CQGChangedTradeEntries Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGChangedTradeEntry objects.

Object Model

CQGChangedTradeEntries CollectionCQGChangedTradeEntry Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGChangedTradeEntries Members


%%PageItemTitle%% $$Members$$

CQGChangedTradeEntries Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property ChangeFilter | Returns the filter of change categories used to obtain the current collection. This is the change_filter passed to the corresponding CQGTradingSystemNotificationInfo.ChangedEntries property call, or the combination of all eTradeChangeCategory values if change_filter was omitted.
Public Property Count | Returns the number of CQGChangedTradeEntry objects in the collection.
Public Property Item | Returns the CQGChangedTradeEntry object by its index. This is the default property.

See Also

CQGChangedTradeEntries Collection


%%PageItemTitle%%

_NewEnum Property
CQGChangedTradeEntries Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGChangedTradeEntries Collection | CQGChangedTradeEntries Members


%%PageItemTitle%%

ChangeFilter Property
CQGChangedTradeEntries Collection : ChangeFilter Property

Glossary Item Box

Description

Returns the filter of change categories used to obtain the current collection.

This is the change_filter passed to the corresponding CQGTradingSystemNotificationInfo.ChangedEntries property call, or the combination of all eTradeChangeCategory values if change_filter was omitted.

Property type

Read-only property

Syntax

Visual Basic
Public Property ChangeFilter As eTradeChangeCategory

See Also

CQGChangedTradeEntries Collection | CQGChangedTradeEntries Members | eTradeChangeCategory Enumeration


%%PageItemTitle%%

Count Property
CQGChangedTradeEntries Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGChangedTradeEntry objects in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of collection items, reprsented as Long

See Also

CQGChangedTradeEntries Collection | CQGChangedTradeEntries Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGChangedTradeEntries Collection : Item Property

Glossary Item Box

Description

Returns the CQGChangedTradeEntry object by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGChangedTradeEntry

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item, represented as CQGChangedTradeEntry

See Also

CQGChangedTradeEntries Collection | CQGChangedTradeEntries Members | CQGChangedTradeEntry Interface


%%PageItemTitle%%

CQGChangedTradeExits Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGChangedTradeExit objects.

Object Model

CQGChangedTradeExits CollectionCQGChangedTradeExit Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGChangedTradeExits Members | CQGChangedTradeExit Interface


%%PageItemTitle%% $$Members$$

CQGChangedTradeExits Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property ChangeFilter | Returns the filter of change categories used to obtain the current collection. This is the change_filter passed to the corresponding CQGTradingSystemNotificationInfo.ChangedEntries property call, or the combination of all eTradeChangeCategory values if change_filter was omitted.
Public Property Count | Returns the number of CQGChangedTradeExits objects in the collection.
Public Property Item | Returns the CQGChangedTradeExit object by its index. This is the default property.

See Also

CQGChangedTradeExits Collection | CQGChangedTradeExit Interface


%%PageItemTitle%%

_NewEnum Property
CQGChangedTradeExits Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGChangedTradeExits Collection | CQGChangedTradeExits Members


%%PageItemTitle%%

ChangeFilter Property
CQGChangedTradeExits Collection : ChangeFilter Property

Glossary Item Box

Description

Returns the filter of change categories used to obtain the current collection.

This is the change_filter passed to the corresponding CQGTradingSystemNotificationInfo.ChangedEntries property call, or the combination of all eTradeChangeCategory values if change_filter was omitted.

Property type

Read-only property

Syntax

Visual Basic
Public Property ChangeFilter As eTradeChangeCategory

See Also

CQGChangedTradeExits Collection | CQGChangedTradeExits Members | eTradeChangeCategory Enumeration


%%PageItemTitle%%

Count Property
CQGChangedTradeExits Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGChangedTradeExits objects in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of collection items, reprsented as Long

See Also

CQGChangedTradeExits Collection | CQGChangedTradeExits Members | CQGChangedTradeExit Interface


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGChangedTradeExits Collection : Item Property

Glossary Item Box

Description

Returns the CQGChangedTradeExit object by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGChangedTradeExit

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item, represented as CQGChangedTradeExit

See Also

CQGChangedTradeExits Collection | CQGChangedTradeExits Members | CQGChangedTradeExit Interface


%%PageItemTitle%%

CQGCommodities Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of commodity names.

Object Model

CQGCommodities Collection

Remarks

Used in CQGCEL.TradableCommoditiesResolved.
Enumeration through this collection is possible.

See Accessing non-existent collection items for details on accessing items that do not exist in the collection.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGCommodities Members | RequestTradableCommodities Method | TradableCommoditiesResolved Event


%%PageItemTitle%% $$Members$$

CQGCommodities Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of commodities in the collection.
Public Property GWAccountID | Returns the gateway account ID, with which the tradable commodities were requested.
Public Property Item | Returns the commodity name by its index. This is the default property.

See Also

CQGCommodities Collection | RequestTradableCommodities Method | TradableCommoditiesResolved Event


%%PageItemTitle%%

_NewEnum Property
CQGCommodities Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGCommodities Collection | CQGCommodities Members


%%PageItemTitle%%

Count Property
CQGCommodities Collection : Count Property

Glossary Item Box

Description

Returns the number of commodities in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of commodities in the collection represented as Long

See Also

CQGCommodities Collection | CQGCommodities Members | CQGCommodities.Item Property


%%PageItemTitle%%

GWAccountID Property
CQGCommodities Collection : GWAccountID Property

Glossary Item Box

Description

Returns the gateway account ID, with which the tradable commodities were requested.

Property type

Read-only property

Syntax

Visual Basic
Public Property GWAccountID As Long

Return Type

The Gateway account ID represented as Long.

The value that was passed to CQGCEL.RequestTradableCommodities, or 0 if not passed.

See Also

CQGCommodities Collection | CQGCommodities Members | CQGCEL.RequestTradableCommodities Method | CQGCEL.TradableCommoditiesResolved Event


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGCommodities Collection : Item Property

Glossary Item Box

Description

Returns the commodity name by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As String

Parameters

index_
Zero-based index of item in the collection

Return Type

Commodity name represented as String

See Also

CQGCommodities Collection | CQGCommodities Members | CQGCommodities.Count Property | CQGAPIConfig.CollectionsThrowException Property


%%PageItemTitle%%

CQGCommodityInstruments Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of resolved instrument names.

Object Model

CQGCommodityInstruments Collection

Remarks

In this collection names of instruments corresponding to some commodity symbols are present.

Access to an item in this collection can be made based on its index. The index is 0 based, i.e. the first item in the collection has index 0.

See Accessing non-existent collection items for details on accessing items that do not exist in the collection.

Example

See the usage of CQGCommodityInstruments collection in CommodityInstrumentsResolved Example.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGCommodityInstruments Members


%%PageItemTitle%% $$Members$$

CQGCommodityInstruments Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of instrument names in the collection.
Public Property IsTradableOnly | Indicates whether only tradable commodities were requested.
Public Property Item | Returns the selected instrument name from the collection. This is the default property.

See Also

CQGCommodityInstruments Collection


%%PageItemTitle%%

_NewEnum Property
CQGCommodityInstruments Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGCommodityInstruments Collection | CQGCommodityInstruments Members


%%PageItemTitle%%

Count Property
CQGCommodityInstruments Collection : Count Property

Glossary Item Box

Description

Returns the number of instrument names in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of instruments names represented as Long.

Example

See the usage of CQGCommodityInstruments Collection in CommodityInstrumentsResolved Example.

See Also

CQGCommodityInstruments Collection | CQGCommodityInstruments Members


%%PageItemTitle%%

IsTradableOnly Property
CQGCommodityInstruments Collection : IsTradableOnly Property

Glossary Item Box

Description

Indicates whether only tradable commodities were requested.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsTradableOnly As Boolean

See Also

CQGCommodityInstruments Collection | CQGCommodityInstruments Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGCommodityInstruments Collection : Item Property

Glossary Item Box

Description

Returns the selected instrument name from the collection.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As String

Parameters

index_
Zero-based index of item in the collection

Return Type

Corresponding collection item represented as String.

If the accessed item does not exist, see Accessing non-existent collection items to learn more about the return type.

Example

See the usage of CQGCommodityInstruments Collection in CommodityInstrumentsResolved Example.

See Also

CQGCommodityInstruments Collection | CQGCommodityInstruments Members


%%PageItemTitle%%

CQGCondition Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGConditionResult objects.

It is returned by the CQGCEL.RequestCondition method.

Object Model

CQGCondition CollectionCQGConditionResult Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGCondition Members


%%PageItemTitle%% $$Members$$

CQGCondition Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method IndexForDate

Returns the start index for the specified date.

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of all records in the collection.
Public Property Definition | Returns the condition's definition.
Public Property EndTimestamp | Returns the ending (maximum) timestamp of all arrived condition results so far, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
Public Property Id | Returns the unique identifier of the condition.
Public Property Item | Returns the CQGConditionResult by its index. This is the default property.
Public Property LastError | Returns CQGError object describing the last error occurred to this object.
Public Property Request | Returns the read-only copy of the CQGConditionRequest object, that was passed to the corresponding CQGCEL.RequestCondition call.
Public Property StartTimestamp | Returns the starting (minimum) timestamp of all arrived condition results, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
Public Property Status | Returns the status of the condition.
Public Property Tag | This property allows the user to keep his/her own information within the condition.

See Also

CQGCondition Collection


%%PageItemTitle%%

IndexForDate Method
date_

Specifies the date, in the user-configured time zone (CQGAPIConfig.TimeZoneCode)

CQGCondition Collection : IndexForDate Method

Glossary Item Box

Description

Returns the start index for the specified date.

Syntax

Visual Basic
Public Function IndexForDate( _
   ByVal date_ As Date _
) As Long

Parameters

date_

Specifies the date, in the user-configured time zone (CQGAPIConfig.TimeZoneCode)

Return Type

If in this CQGCondition there are CQGConditionResult objects having their Timestamp parameters equal to date_, the first such record's index is returned.

Otherwise, the returned value will be invalid.

See Also

CQGCondition Collection | CQGCondition Members | TimeZoneCode Property


%%PageItemTitle%%

_NewEnum Property
CQGCondition Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGCondition Collection | CQGCondition Members


%%PageItemTitle%%

Count Property
CQGCondition Collection : Count Property

Glossary Item Box

Description

Returns the number of all records in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of records, represented as Long

See Also

CQGCondition Collection | CQGCondition Members


%%PageItemTitle%%

Definition Property
CQGCondition Collection : Definition Property

Glossary Item Box

Description

Returns the condition's definition.

Property type

Read-only property

Syntax

Visual Basic
Public Property Definition As CQGConditionDefinition

Return Type

Condition's definition, represented as CQGConditionDefinition object

See Also

CQGCondition Collection | CQGCondition Members | CQGConditionDefinition Interface


%%PageItemTitle%%

EndTimestamp Property
CQGCondition Collection : EndTimestamp Property

Glossary Item Box

Description

Returns the ending (maximum) timestamp of all arrived condition results so far, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

Property type

Read-only property

Syntax

Visual Basic
Public Property EndTimestamp As Date

Return Type

The timestamp of the last arrived condition result, represented as Date

See Also

CQGCondition Collection | CQGCondition Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

Id Property
CQGCondition Collection : Id Property

Glossary Item Box

Description

Returns the unique identifier of the condition.

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

Return Type

Unique identifier, represented as String

See Also

CQGCondition Collection | CQGCondition Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGCondition Collection : Item Property

Glossary Item Box

Description

Returns the CQGConditionResult by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGConditionResult

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item, represented as CQGConditionResult object

Remarks

CQGConditionResult will be created upon request and passed to the user without storing it.

Two sequential requests for the same record may return different objects.

See Also

CQGCondition Collection | CQGCondition Members | CQGConditionResult Interface


%%PageItemTitle%%

LastError Property
CQGCondition Collection : LastError Property

Glossary Item Box

Description

Returns CQGError object describing the last error occurred to this object.

Property type

Read-only property

Syntax

Visual Basic
Public Property LastError As CQGError

Return Type

Object's last error, represented as CQGError

See Also

CQGCondition Collection | CQGCondition Members | CQGError Interface


%%PageItemTitle%%

Request Property
CQGCondition Collection : Request Property

Glossary Item Box

Description

Returns the read-only copy of the CQGConditionRequest object, that was passed to the corresponding CQGCEL.RequestCondition call.

Property type

Read-only property

Syntax

Visual Basic
Public Property Request As CQGConditionRequest

Return Type

A read-only copy of the CQGConditionRequest object

See Also

CQGCondition Collection | CQGCondition Members | CQGConditionRequest Interface | CQGCEL.RequestCondition Method


%%PageItemTitle%%

StartTimestamp Property
CQGCondition Collection : StartTimestamp Property

Glossary Item Box

Description

Returns the starting (minimum) timestamp of all arrived condition results, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

Property type

Read-only property

Syntax

Visual Basic
Public Property StartTimestamp As Date

Return Type

The timestamp of the first arrived condition result, represented as Date

See Also

CQGCondition Collection | CQGCondition Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

Status Property
CQGCondition Collection : Status Property

Glossary Item Box

Description

Returns the status of the condition.

Property type

Read-only property

Syntax

Visual Basic
Public Property Status As eRequestStatus

Return Type

Status of the condition, represented as eRequestStatus

See Also

CQGCondition Collection | CQGCondition Members | eRequestStatus Enumeration


%%PageItemTitle%%

Tag Property
tag_name

The user-defined value's name.

When setting, the tag_name parameter should keep the key that will be associated with the passed information.

When getting the information from the Tag, one of the previously set keys should be passed as tag_name in order to get the corresponding information.

CQGCondition Collection : Tag Property

Glossary Item Box

Description

This property allows the user to keep his/her own information within the condition.

Property type

Read-write property

Syntax

Visual Basic
Public Property Tag( _
   ByVal tag_name As String _
) As Variant

Parameters

tag_name

The user-defined value's name.

When setting, the tag_name parameter should keep the key that will be associated with the passed information.

When getting the information from the Tag, one of the previously set keys should be passed as tag_name in order to get the corresponding information.

Return Type

The user-defined value, represented as Variant

Remarks

Multiple data can be kept in the Tag property under different keys.

If no user-defined value with this tag_name exists, Empty is returned.

If empty is set to an existing tag_name, it is deleted/unregistered.

If a new value is set to an existing tag_name, the old value is overwritten.

See Also

CQGCondition Collection | CQGCondition Members


%%PageItemTitle%%

CQGConditionDefinitions Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGConditionDefinition objects.

Object Model

CQGConditionDefinitions CollectionCQGConditionDefinition Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGConditionDefinitions Members | CQGConditionDefinition Interface


%%PageItemTitle%% $$Members$$

CQGConditionDefinitions Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGConditionDefinition objects in the collection.
Public Property Item | Returns the CQGConditionDefinition by its index. This is the default property.
Public Property ItemByName | Returns the CQGConditionDefinition by its name.

See Also

CQGConditionDefinitions Collection | CQGConditionDefinition Interface


%%PageItemTitle%%

_NewEnum Property
CQGConditionDefinitions Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGConditionDefinitions Collection | CQGConditionDefinitions Members


%%PageItemTitle%%

Count Property
CQGConditionDefinitions Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGConditionDefinition objects in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of CQGConditionDefinition objects, represented as Long

See Also

CQGConditionDefinitions Collection | CQGConditionDefinitions Members | CQGConditionDefinition Interface


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGConditionDefinitions Collection : Item Property

Glossary Item Box

Description

Returns the CQGConditionDefinition by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGConditionDefinition

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item represented as CQGConditionDefinition object

See Also

CQGConditionDefinitions Collection | CQGConditionDefinitions Members | CQGConditionDefinition Interface


%%PageItemTitle%%

ItemByName Property
condition_name
Name of the condition definition in the collection
CQGConditionDefinitions Collection : ItemByName Property

Glossary Item Box

Description

Returns the CQGConditionDefinition by its name.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemByName( _
   ByVal condition_name As String _
) As CQGConditionDefinition

Parameters

condition_name
Name of the condition definition in the collection

Return Type

The corresponding CQGConditionDefinition object

Remarks

A collection exception will be thrown in case of non-existent condition name.

See Also

CQGConditionDefinitions Collection | CQGConditionDefinitions Members | CQGConditionDefinition Interface


%%PageItemTitle%%

CQGConditions Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGCondition objects

Object Model

CQGConditions CollectionCQGCondition Collection

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGConditions Members


%%PageItemTitle%% $$Members$$

CQGConditions Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGCondition objects in the collection.
Public Property Item | Returns the CQGCondition by its index. This is the default property.
Public Property ItemById | Returns the CQGCondition by its identifier.

See Also

CQGConditions Collection


%%PageItemTitle%%

_NewEnum Property
CQGConditions Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGConditions Collection | CQGConditions Members


%%PageItemTitle%%

Count Property
CQGConditions Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGCondition objects in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of CQGCondition objects in the collection, represented as Long

See Also

CQGConditions Collection | CQGConditions Members | CQGCondition Collection


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGConditions Collection : Item Property

Glossary Item Box

Description

Returns the CQGCondition by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGCondition

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item represented as CQGCondition object

See Also

CQGConditions Collection | CQGConditions Members | CQGCondition Collection


%%PageItemTitle%%

ItemById Property
id_
Identifier of CQGCondition
CQGConditions Collection : ItemById Property

Glossary Item Box

Description

Returns the CQGCondition by its identifier.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemById( _
   ByVal id_ As String _
) As CQGCondition

Parameters

id_
Identifier of CQGCondition

Return Type

The corresponding CQGCondition object

See Also

CQGConditions Collection | CQGConditions Members | CQGCondition Collection


%%PageItemTitle%%

CQGConstantVolumeBars Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGConstantVolumeBar objects.

It is returned by the CQGCEL.RequestConstantVolumeBars method.

The CQGCEL.ConstantVolumeBarsResolved, CQGCEL.ConstantVolumeBarsAdded, and CQGCEL.ConstantVolumeBarsUpdated events can be fired for the CQGConstantVolumeBars.

Object Model

CQGConstantVolumeBars CollectionCQGConstantVolumeBar Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGConstantVolumeBars Members | CQGConstantVolumeBar Interface | ConstantVolumeBarsResolved Event | ConstantVolumeBarsAdded Event | ConstantVolumeBarsInserted Event | ConstantVolumeBarsRemoved Event | ConstantVolumeBarsUpdated Event


%%PageItemTitle%% $$Members$$

CQGConstantVolumeBars Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of all records in the collection.
Public Property EndTimestamp | Returns the ending (maximum) timestamp of all arrived constant volume bars, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
Public Property Id | Returns the unique identifier of this constant volume bars.
Public Property Item | Returns the CQGConstantVolumeBar by its index. This is the default property.
Public Property LastError | Returns the CQGError object describing the last error occurred to this object.
Public Property Request | Returns the read-only copy of the CQGConstantVolumeBarsRequest object, that was passed to the corresponding RequestConstantVolumeBars call.
Public Property StartTimestamp | Returns the starting (minimum) timestamp of all arrived constant volume bars, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
Public Property Status | Returns the status of the constant volume bars request.
Public Property Tag | This property allows the user to keep his/her own information within the constant volume bars.

See Also

CQGConstantVolumeBars Collection | CQGConstantVolumeBar Interface | ConstantVolumeBarsResolved Event | ConstantVolumeBarsAdded Event | ConstantVolumeBarsInserted Event | ConstantVolumeBarsRemoved Event | ConstantVolumeBarsUpdated Event


%%PageItemTitle%%

_NewEnum Property
CQGConstantVolumeBars Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGConstantVolumeBars Collection | CQGConstantVolumeBars Members


%%PageItemTitle%%

Count Property
CQGConstantVolumeBars Collection : Count Property

Glossary Item Box

Description

Returns the number of all records in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of records, represented as Long

See Also

CQGConstantVolumeBars Collection | CQGConstantVolumeBars Members


%%PageItemTitle%%

EndTimestamp Property
CQGConstantVolumeBars Collection : EndTimestamp Property

Glossary Item Box

Description

Returns the ending (maximum) timestamp of all arrived constant volume bars, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

Property type

Read-only property

Syntax

Visual Basic
Public Property EndTimestamp As Date

Return Type

Ending timestamp, represented as Date

See Also

CQGConstantVolumeBars Collection | CQGConstantVolumeBars Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

Id Property
CQGConstantVolumeBars Collection : Id Property

Glossary Item Box

Description

Returns the unique identifier of this constant volume bars.

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

Return Type

Unique identifier, represented as String

See Also

CQGConstantVolumeBars Collection | CQGConstantVolumeBars Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGConstantVolumeBars Collection : Item Property

Glossary Item Box

Description

Returns the CQGConstantVolumeBar by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGConstantVolumeBar

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item represented as CQGConstantVolumeBar object

Remarks

A CQGConstantVolumeBar object will be created upon request and passed to the user without storing it.

Two sequential requests for the same record may return different objects.

See Also

CQGConstantVolumeBars Collection | CQGConstantVolumeBars Members | CQGConstantVolumeBar Interface


%%PageItemTitle%%

LastError Property
CQGConstantVolumeBars Collection : LastError Property

Glossary Item Box

Description

Returns the CQGError object describing the last error occurred to this object.

Property type

Read-only property

Syntax

Visual Basic
Public Property LastError As CQGError

Return Type

Last error, represented as CQGError object

See Also

CQGConstantVolumeBars Collection | CQGConstantVolumeBars Members | CQGError Interface


%%PageItemTitle%%

Request Property
CQGConstantVolumeBars Collection : Request Property

Glossary Item Box

Description

Returns the read-only copy of the CQGConstantVolumeBarsRequest object, that was passed to the corresponding RequestConstantVolumeBars call.

Property type

Read-only property

Syntax

Visual Basic
Public Property Request As CQGConstantVolumeBarsRequest

Return Type

The corresponding CQGConstantVolumeBarsRequest object

See Also

CQGConstantVolumeBars Collection | CQGConstantVolumeBars Members | CQGConstantVolumeBarsRequest Interface


%%PageItemTitle%%

StartTimestamp Property
CQGConstantVolumeBars Collection : StartTimestamp Property

Glossary Item Box

Description

Returns the starting (minimum) timestamp of all arrived constant volume bars, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

Property type

Read-only property

Syntax

Visual Basic
Public Property StartTimestamp As Date

Return Type

Starting timestamp, represented as Date

See Also

CQGConstantVolumeBars Collection | CQGConstantVolumeBars Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

Status Property
CQGConstantVolumeBars Collection : Status Property

Glossary Item Box

Description

Returns the status of the constant volume bars request.

Property type

Read-only property

Syntax

Visual Basic
Public Property Status As eRequestStatus

Return Type

Request status, represented as eRequestStatus

Remarks

See eRequestStatus for possible values.

See Also

CQGConstantVolumeBars Collection | CQGConstantVolumeBars Members | eRequestStatus Enumeration


%%PageItemTitle%%

Tag Property
tag_name

The user-defined value's name.

When setting, the tag_name parameter should keep the key that will be associated with the passed information.

When getting the information from the Tag, one of the previously set keys should be passed as tag_name in order to get the corresponding information.

CQGConstantVolumeBars Collection : Tag Property

Glossary Item Box

Description

This property allows the user to keep his/her own information within the constant volume bars.

Property type

Read-write property

Syntax

Visual Basic
Public Property Tag( _
   ByVal tag_name As String _
) As Variant

Parameters

tag_name

The user-defined value's name.

When setting, the tag_name parameter should keep the key that will be associated with the passed information.

When getting the information from the Tag, one of the previously set keys should be passed as tag_name in order to get the corresponding information.

Return Type

The user-defined value, represented as Variant

Remarks

Multiple data can be kept in the Tag property under different keys.

If no user-defined value with this tag_name exists, Empty is returned.

If empty is set to an existing tag_name, it is deleted/unregistered.

If a new value is set to an existing tag_name, the old value is overwritten.

See Also

CQGConstantVolumeBars Collection | CQGConstantVolumeBars Members


%%PageItemTitle%%

CQGConstantVolumeBarsCollection Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGConstantVolumeBars objects.

Object Model

CQGConstantVolumeBarsCollection CollectionCQGConstantVolumeBars Collection

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGConstantVolumeBarsCollection Members | CQGConstantVolumeBars Collection


%%PageItemTitle%% $$Members$$

CQGConstantVolumeBarsCollection Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGConstantVolumeBars in the collection.
Public Property Item | Returns the CQGConstantVolumeBars by its index. This is the default property.
Public Property ItemById | Returns the CQGConstantVolumeBars by the identifier.

See Also

CQGConstantVolumeBarsCollection Collection | CQGConstantVolumeBars Collection


%%PageItemTitle%%

_NewEnum Property
CQGConstantVolumeBarsCollection Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGConstantVolumeBarsCollection Collection | CQGConstantVolumeBarsCollection Members


%%PageItemTitle%%

Count Property
CQGConstantVolumeBarsCollection Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGConstantVolumeBars in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

The number of CQGConstantVolumeBars objects in the collection

See Also

CQGConstantVolumeBarsCollection Collection | CQGConstantVolumeBarsCollection Members | CQGConstantVolumeBars Collection


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGConstantVolumeBarsCollection Collection : Item Property

Glossary Item Box

Description

Returns the CQGConstantVolumeBars by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGConstantVolumeBars

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item represented as CQGConstantVolumeBars object

See Also

CQGConstantVolumeBarsCollection Collection | CQGConstantVolumeBarsCollection Members | CQGConstantVolumeBars Collection


%%PageItemTitle%%

ItemById Property
id_
Identifier of bars
CQGConstantVolumeBarsCollection Collection : ItemById Property

Glossary Item Box

Description

Returns the CQGConstantVolumeBars by the identifier.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemById( _
   ByVal id_ As String _
) As CQGConstantVolumeBars

Parameters

id_
Identifier of bars

Return Type

The corresponding collection item represented as CQGConstantVolumeBars object

See Also

CQGConstantVolumeBarsCollection Collection | CQGConstantVolumeBarsCollection Members | CQGConstantVolumeBars Collection


%%PageItemTitle%%

CQGCurrencyRates Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGCurrencyRate objects.

Object Model

CQGCurrencyRates CollectionCQGCurrencyRate Interface

Remarks

Access to an item in this collection can be made based on the FCM identifier, the currency code, and optionally the base currency code.

See Accessing non-existent collection items for details on accessing items that do not exist in the collection.

Example

See the usage of CQGCurrencyRates collection in the CurrencyRatesChanged event's example section.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGCurrencyRates Members


%%PageItemTitle%% $$Members$$

CQGCurrencyRates Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of currency rates in the collection.
Public Property Item | Returns the selected currency rate from the collection. This is the default property.

See Also

CQGCurrencyRates Collection


%%PageItemTitle%%

_NewEnum Property
CQGCurrencyRates Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGCurrencyRates Collection | CQGCurrencyRates Members


%%PageItemTitle%%

Count Property
CQGCurrencyRates Collection : Count Property

Glossary Item Box

Description

Returns the number of currency rates in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of currency rates represented as Long

Example

See the usage of CQGCurrencyRates collection properties in the CurrencyRatesChanged event's example section.

See Also

CQGCurrencyRates Collection | CQGCurrencyRates Members


%%PageItemTitle%%

Item Property
fcm_id
FCM identifier
currency_
Currency
base_currency
Base currency
CQGCurrencyRates Collection : Item Property

Glossary Item Box

Description

Returns the selected currency rate from the collection.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal fcm_id As Long, _
   ByVal currency_ As String, _
   Optional ByVal base_currency As String = "" _
) As CQGCurrencyRate

Parameters

fcm_id
FCM identifier
currency_
Currency
base_currency
Base currency

Return Type

The corresponding collection item represented as CQGCurrencyRate.

If the accessed item does not exist, see Accessing non-existent collection items to learn more about the return type.

Remarks

Currency ISO codes are case-insensitive.

Example

See the usage of CQGCurrencyRates collection properties in the CurrencyRatesChanged event's example section.

See Also

CQGCurrencyRates Collection | CQGCurrencyRates Members


%%PageItemTitle%%

CQGCurveDefinitions Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGCurveDefinition objects.

Object Model

CQGCurveDefinitions CollectionCQGCurveDefinition Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGCurveDefinitions Members | CQGCurveDefinition Interface


%%PageItemTitle%% $$Members$$

CQGCurveDefinitions Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGCurveDefinition objects in the collection.
Public Property Item | Returns the CQGCurveDefinition by its index. This is the default property.
Public Property ItemByName | Returns the CQGCurveDefinition object by its name.

See Also

CQGCurveDefinitions Collection | CQGCurveDefinition Interface


%%PageItemTitle%%

_NewEnum Property
CQGCurveDefinitions Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGCurveDefinitions Collection | CQGCurveDefinitions Members


%%PageItemTitle%%

Count Property
CQGCurveDefinitions Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGCurveDefinition objects in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of collection items, represented as Long

See Also

CQGCurveDefinitions Collection | CQGCurveDefinitions Members | CQGCurveDefinition Interface


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGCurveDefinitions Collection : Item Property

Glossary Item Box

Description

Returns the CQGCurveDefinition by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGCurveDefinition

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item, represented as CQGCurveDefinition object

See Also

CQGCurveDefinitions Collection | CQGCurveDefinitions Members | CQGCurveDefinition Interface


%%PageItemTitle%%

ItemByName Property
curve_name
Name of the curve definition in the collection
CQGCurveDefinitions Collection : ItemByName Property

Glossary Item Box

Description

Returns the CQGCurveDefinition object by its name.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemByName( _
   ByVal curve_name As String _
) As CQGCurveDefinition

Parameters

curve_name
Name of the curve definition in the collection

Return Type

The corresponding collection item, represented as CQGCurveDefinition Object object

See Also

CQGCurveDefinitions Collection | CQGCurveDefinitions Members | CQGCurveDefinition Interface


%%PageItemTitle%%

CQGCurveHeaders Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of String - curve headers.

Object Model

CQGCurveHeaders Collection

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGCurveHeaders Members


%%PageItemTitle%% $$Members$$

CQGCurveHeaders Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of headers in the collection.
Public Property Item | Returns the curve header by its index. This is the default property.

See Also

CQGCurveHeaders Collection


%%PageItemTitle%%

_NewEnum Property
CQGCurveHeaders Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGCurveHeaders Collection | CQGCurveHeaders Members


%%PageItemTitle%%

Count Property
CQGCurveHeaders Collection : Count Property

Glossary Item Box

Description

Returns the number of headers in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of headers, represented as Long

See Also

CQGCurveHeaders Collection | CQGCurveHeaders Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGCurveHeaders Collection : Item Property

Glossary Item Box

Description

Returns the curve header by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As String

Parameters

index_
Zero-based index of item in the collection

Return Type

Curve header, represented as String

See Also

CQGCurveHeaders Collection | CQGCurveHeaders Members


%%PageItemTitle%%

CQGCurves Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of curves (Double).

Object Model

CQGCurves Collection

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGCurves Members


%%PageItemTitle%% $$Members$$

CQGCurves Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of all records in the collection.
Public Property Item | Returns the value by its index. This is the default property.
Public Property Timestamp | Returns the timestamp, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
Public Property TimestampOffset | Returns the timestamp offset, which is used to identify various CQGCurves objects that have the same timestamp.

See Also

CQGCurves Collection


%%PageItemTitle%%

_NewEnum Property
CQGCurves Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGCurves Collection | CQGCurves Members


%%PageItemTitle%%

Count Property
CQGCurves Collection : Count Property

Glossary Item Box

Description

Returns the number of all records in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of records, represented as Long

See Also

CQGCurves Collection | CQGCurves Members


%%PageItemTitle%%

Item Property
key_
CQGCurves Collection : Item Property

Glossary Item Box

Description

Returns the value by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal key_ As Variant _
) As Double

Parameters

key_

Return Type

Curve value, represented as Double

Remarks

The returned value will be invalid if the specified curve was not included in the corresponding request.

See Also

CQGCurves Collection | CQGCurves Members


%%PageItemTitle%%

Timestamp Property
CQGCurves Collection : Timestamp Property

Glossary Item Box

Description

Returns the timestamp, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

Property type

Read-only property

Syntax

Visual Basic
Public Property Timestamp As Date

Return Type

Timestamp, represented as Date

See Also

CQGCurves Collection | CQGCurves Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

TimestampOffset Property
CQGCurves Collection : TimestampOffset Property

Glossary Item Box

Description

Returns the timestamp offset, which is used to identify various CQGCurves objects that have the same timestamp.

Property type

Read-only property

Syntax

Visual Basic
Public Property TimestampOffset As Long

Return Type

Timestamp offset, represented as Long

Remarks

The TimestampOffset value grows for subsequent objects. It resets when the timestamp is changed.

See Also

CQGCurves Collection | CQGCurves Members


%%PageItemTitle%%

CQGCustomStudies Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGCustomStudy objects.

Object Model

CQGCustomStudies CollectionCQGCustomStudy Collection

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGCustomStudies Members


%%PageItemTitle%% $$Members$$

CQGCustomStudies Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGCustomStudy objects in the collection.
Public Property Item | Returns the CQGCustomStudy by its index. This is the default property.
Public Property ItemById | Returns the CQGCustomStudy by its identifier.

See Also

CQGCustomStudies Collection


%%PageItemTitle%%

_NewEnum Property
CQGCustomStudies Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGCustomStudies Collection | CQGCustomStudies Members


%%PageItemTitle%%

Count Property
CQGCustomStudies Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGCustomStudy objects in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of items in the collection, represented as Long

See Also

CQGCustomStudies Collection | CQGCustomStudies Members | CQGCustomStudy Collection


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGCustomStudies Collection : Item Property

Glossary Item Box

Description

Returns the CQGCustomStudy by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGCustomStudy

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item, represented as CQGCustomStudy object

See Also

CQGCustomStudies Collection | CQGCustomStudies Members | CQGCustomStudy Collection


%%PageItemTitle%%

ItemById Property
id_
Identifier of CQGCustomStudy
CQGCustomStudies Collection : ItemById Property

Glossary Item Box

Description

Returns the CQGCustomStudy by its identifier.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemById( _
   ByVal id_ As String _
) As CQGCustomStudy

Parameters

id_
Identifier of CQGCustomStudy

Return Type

The corresponding collection item, represented as CQGCustomStudy Object

See Also

CQGCustomStudies Collection | CQGCustomStudies Members


%%PageItemTitle%%

CQGCustomStudy Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGCurves objects.

It is returned by the CQGCEL.RequestCustomStudy method call.

The CQGCEL.CustomStudyResolved, CQGCEL.CustomStudyAdded, and CQGCEL.CustomStudyUpdated events can be fired for the CQGCustomStudy.

Object Model

CQGCustomStudy CollectionCQGCurves Collection

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGCustomStudy Members | CQGCurves Collection


%%PageItemTitle%% $$Members$$

CQGCustomStudy Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method IndexForDate

Returns the start index for the specified date.

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of all records in the collection.
Public Property CurveHeaders | Returns the headers of included curves.
Public Property Definition | Returns the custom study definition.
Public Property EndTimestamp | Returns the ending (maximum) timestamp of all arrived curves, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
Public Property Id | Returns the unique identifier of the custom study.
Public Property Item | Returns the CQGCurves by index. This is the default property.
Public Property LastError | Returns CQGError object describing the last error occurred to this object.
Public Property Request | Returns the read-only copy of the CQGCustomStudyRequest object, that was passed to the corresponding CQGCEL.RequestCustomStudy method call.
Public Property StartTimestamp | Returns the starting (minimum) timestamp of all arrived curves, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
Public Property Status | Returns the status of the request.
Public Property Tag | This property allows the user to keep his/her own information within the custom study.

See Also

CQGCustomStudy Collection | CQGCurves Collection


%%PageItemTitle%%

IndexForDate Method
date_

Specifies the date, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

CQGCustomStudy Collection : IndexForDate Method

Glossary Item Box

Description

Returns the start index for the specified date.

Syntax

Visual Basic
Public Function IndexForDate( _
   ByVal date_ As Date _
) As Long

Parameters

date_

Specifies the date, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

Return Type

Start index, represented as Long

Remarks

If in this CQGCustomStudy, there are CQGCurves objects having their Timestamp equal to date_, the first such record's index is returned.

Otherwise, the returned value will be invalid.

See Also

CQGCustomStudy Collection | CQGCustomStudy Members | CQGCurves Collection | TimeZoneCode Property


%%PageItemTitle%%

_NewEnum Property
CQGCustomStudy Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGCustomStudy Collection | CQGCustomStudy Members


%%PageItemTitle%%

Count Property
CQGCustomStudy Collection : Count Property

Glossary Item Box

Description

Returns the number of all records in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of records, represented as Long

See Also

CQGCustomStudy Collection | CQGCustomStudy Members


%%PageItemTitle%%

CurveHeaders Property
CQGCustomStudy Collection : CurveHeaders Property

Glossary Item Box

Description

Returns the headers of included curves.

Property type

Read-only property

Syntax

Visual Basic
Public Property CurveHeaders As CQGCurveHeaders

Return Type

Included curve headers, represented as CQGCurveHeaders

See Also

CQGCustomStudy Collection | CQGCustomStudy Members | CQGCurveHeaders Collection


%%PageItemTitle%%

Definition Property
CQGCustomStudy Collection : Definition Property

Glossary Item Box

Description

Returns the custom study definition.

Property type

Read-only property

Syntax

Visual Basic
Public Property Definition As CQGCustomStudyDefinition

Return Type

Custom study definition, represented as CQGCustomStudyDefinition object

See Also

CQGCustomStudy Collection | CQGCustomStudy Members | CQGCustomStudyDefinition Interface


%%PageItemTitle%%

EndTimestamp Property
CQGCustomStudy Collection : EndTimestamp Property

Glossary Item Box

Description

Returns the ending (maximum) timestamp of all arrived curves, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

Property type

Read-only property

Syntax

Visual Basic
Public Property EndTimestamp As Date

Return Type

Ending timestamp, represented as Date

See Also

CQGCustomStudy Collection | CQGCustomStudy Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

Id Property
CQGCustomStudy Collection : Id Property

Glossary Item Box

Description

Returns the unique identifier of the custom study.

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

Return Type

Unique identifier, represented as String

See Also

CQGCustomStudy Collection | CQGCustomStudy Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGCustomStudy Collection : Item Property

Glossary Item Box

Description

Returns the CQGCurves by index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGCurves

Parameters

index_
Zero-based index of item in the collection

Remarks

A CQGCurves object will be created upon request and passed to the user without storing it.

Two sequential requests for the same record may return different objects.

See Also

CQGCustomStudy Collection | CQGCustomStudy Members | CQGCurves Collection


%%PageItemTitle%%

LastError Property
CQGCustomStudy Collection : LastError Property

Glossary Item Box

Description

Returns CQGError object describing the last error occurred to this object.

Property type

Read-only property

Syntax

Visual Basic
Public Property LastError As CQGError

Return Type

Last error, represented as CQGError object

See Also

CQGCustomStudy Collection | CQGCustomStudy Members | CQGError Interface


%%PageItemTitle%%

Request Property
CQGCustomStudy Collection : Request Property

Glossary Item Box

Description

Returns the read-only copy of the CQGCustomStudyRequest object, that was passed to the corresponding CQGCEL.RequestCustomStudy method call.

Property type

Read-only property

Syntax

Visual Basic
Public Property Request As CQGCustomStudyRequest

Return Type

The read-only copy of the corresponding CQGCustomStudyRequest object

See Also

CQGCustomStudy Collection | CQGCustomStudy Members | CQGCustomStudyRequest Interface | CQGCEL.RequestCustomStudy Method


%%PageItemTitle%%

StartTimestamp Property
CQGCustomStudy Collection : StartTimestamp Property

Glossary Item Box

Description

Returns the starting (minimum) timestamp of all arrived curves, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

Property type

Read-only property

Syntax

Visual Basic
Public Property StartTimestamp As Date

Return Type

Starting timestamp, represented as Date

See Also

CQGCustomStudy Collection | CQGCustomStudy Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

Status Property
CQGCustomStudy Collection : Status Property

Glossary Item Box

Description

Returns the status of the request.

Property type

Read-only property

Syntax

Visual Basic
Public Property Status As eRequestStatus

Return Type

Request status, represented as eRequestStatus Enumeration

See Also

CQGCustomStudy Collection | CQGCustomStudy Members | eRequestStatus Enumeration


%%PageItemTitle%%

Tag Property
tag_name

The user-defined value's name.

When setting, the tag_name parameter should keep the key that will be associated with the passed information.

When getting the information from the Tag, one of the previously set keys should be passed as tag_name in order to get the corresponding information.

CQGCustomStudy Collection : Tag Property

Glossary Item Box

Description

This property allows the user to keep his/her own information within the custom study.

Property type

Read-write property

Syntax

Visual Basic
Public Property Tag( _
   ByVal tag_name As String _
) As Variant

Parameters

tag_name

The user-defined value's name.

When setting, the tag_name parameter should keep the key that will be associated with the passed information.

When getting the information from the Tag, one of the previously set keys should be passed as tag_name in order to get the corresponding information.

Return Type

The user-defined value, represented as Variant

Remarks

Multiple data can be kept in the Tag property under different keys.

If no user-defined value with this tag_name exists, Empty is returned.

If empty is set to an existing tag_name, it is deleted/unregistered.

If a new value is set to an existing tag_name, the old value is overwritten.

See Also

CQGCustomStudy Collection | CQGCustomStudy Members


%%PageItemTitle%%

CQGCustomStudyDefinitions Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGCustomStudy objects.

Object Model

CQGCustomStudyDefinitions CollectionCQGCustomStudyDefinition Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGCustomStudyDefinitions Members


%%PageItemTitle%% $$Members$$

CQGCustomStudyDefinitions Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGCustomStudyDefinition objects in the collection.
Public Property Item | Returns the CQGCustomStudyDefinition by its index. This is the default property.
Public Property ItemByAbbreviation | Returns the CQGCustomStudyDefinition by its abbreviation.
Public Property ItemByName | Returns the CQGCustomStudyDefinition by its name.

See Also

CQGCustomStudyDefinitions Collection


%%PageItemTitle%%

_NewEnum Property
CQGCustomStudyDefinitions Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGCustomStudyDefinitions Collection | CQGCustomStudyDefinitions Members


%%PageItemTitle%%

Count Property
CQGCustomStudyDefinitions Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGCustomStudyDefinition objects in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of CQGCustomStudyDefinition objects, represented as Long

See Also

CQGCustomStudyDefinitions Collection | CQGCustomStudyDefinitions Members | CQGCustomStudyDefinition Interface


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGCustomStudyDefinitions Collection : Item Property

Glossary Item Box

Description

Returns the CQGCustomStudyDefinition by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGCustomStudyDefinition

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item, represented as CQGCustomStudyDefinition object

See Also

CQGCustomStudyDefinitions Collection | CQGCustomStudyDefinitions Members | CQGCustomStudyDefinition Interface


%%PageItemTitle%%

ItemByAbbreviation Property
custom_study_abbreviation
Abbreviation of the study definition in the collection
CQGCustomStudyDefinitions Collection : ItemByAbbreviation Property

Glossary Item Box

Description

Returns the CQGCustomStudyDefinition by its abbreviation.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemByAbbreviation( _
   ByVal custom_study_abbreviation As String _
) As CQGCustomStudyDefinition

Parameters

custom_study_abbreviation
Abbreviation of the study definition in the collection

Return Type

The corresponding collection item, represented as CQGCustomStudyDefinition

Remarks

A collection exception will be thrown in case of non-existent custom study abbreviation.

See Also

CQGCustomStudyDefinitions Collection | CQGCustomStudyDefinitions Members | CQGCustomStudyDefinition Interface


%%PageItemTitle%%

ItemByName Property
custom_study_name
Name of the study definition in the collection
CQGCustomStudyDefinitions Collection : ItemByName Property

Glossary Item Box

Description

Returns the CQGCustomStudyDefinition by its name.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemByName( _
   ByVal custom_study_name As String _
) As CQGCustomStudyDefinition

Parameters

custom_study_name
Name of the study definition in the collection

Return Type

The corresponding collection item, represented as CQGCustomStudyDefinition Object

Remarks

A collection exception will be thrown in case of non-existent custom study name.

See Also

CQGCustomStudyDefinitions Collection | CQGCustomStudyDefinitions Members


%%PageItemTitle%%

CQGDataSources Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGDataSource objects.

Object Model

CQGDataSources CollectionCQGDataSource Interface

Example

See the usage of CQGDataSources collection in the DataSourcesResolved event's example section.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGDataSources Members | RequestDataSources Method | DataSourcesResolved Event | CQGDataSource Interface


%%PageItemTitle%% $$Members$$

CQGDataSources Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGDataSource objects in the collection.
Public Property Item | Returns the CQGDataSource object by its index. This is the default property.
Public Property ItemByAbbreviation | Returns the CQGDataSource by its abbreviation.

See Also

CQGDataSources Collection | RequestDataSources Method | DataSourcesResolved Event | CQGDataSource Interface


%%PageItemTitle%%

_NewEnum Property
CQGDataSources Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGDataSources Collection | CQGDataSources Members


%%PageItemTitle%%

Count Property
CQGDataSources Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGDataSource objects in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of data sources, represented as Long

Example

See the usage of CQGDataSources properties in the DataSourcesResolved event's example section.

See Also

CQGDataSources Collection | CQGDataSources Members | DataSourcesResolved Event


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGDataSources Collection : Item Property

Glossary Item Box

Description

Returns the CQGDataSource object by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGDataSource

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item, represented as CQGDataSource object

See Also

CQGDataSources Collection | CQGDataSources Members | CQGDataSource Interface


%%PageItemTitle%%

ItemByAbbreviation Property
data_source_abbreviation
Data source abbreviation
CQGDataSources Collection : ItemByAbbreviation Property

Glossary Item Box

Description

Returns the CQGDataSource by its abbreviation.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemByAbbreviation( _
   ByVal data_source_abbreviation As String _
) As CQGDataSource

Parameters

data_source_abbreviation
Data source abbreviation

Return Type

The corresponding collection item, represented as CQGDataSource object

Remarks

A collection exception will be thrown in case of non-existent data source abbreviation.

See Also

CQGDataSources Collection | CQGDataSources Members | CQGDataSource Interface


%%PageItemTitle%%

CQGDataSourceSymbols Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGDataSourceSymbol objects.

Object Model

CQGDataSourceSymbols CollectionCQGDataSourceSymbol Interface

Example

See the usage of CQGDataSourceSymbols collection in the DataSourcesResolved event's example section.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGDataSourceSymbols Members | requestdatasource | DataSourceSymbolsResolved Event | CQGDataSourceSymbol Interface


%%PageItemTitle%% $$Members$$

CQGDataSourceSymbols Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of data source symbols in the interface.
Public Property DataSourceAbbreviation | Returns the data source abbreviation, to which symbols in the collection belong.
Public Property Item | Returns the CQGDataSourceSymbol by its index. This is the default property.

See Also

CQGDataSourceSymbols Collection | requestdatasource | DataSourceSymbolsResolved Event | CQGDataSourceSymbol Interface


%%PageItemTitle%%

_NewEnum Property
CQGDataSourceSymbols Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGDataSourceSymbols Collection | CQGDataSourceSymbols Members


%%PageItemTitle%%

Count Property
CQGDataSourceSymbols Collection : Count Property

Glossary Item Box

Description

Returns the number of data source symbols in the interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of data source symbols represented as Long

Example

See the usage of CQGDataSourceSymbols properties in the DataSourcesResolved event's example section.

See Also

CQGDataSourceSymbols Collection | CQGDataSourceSymbols Members | CQGCEL.DataSourcesResolved Event


%%PageItemTitle%%

DataSourceAbbreviation Property
CQGDataSourceSymbols Collection : DataSourceAbbreviation Property

Glossary Item Box

Description

Returns the data source abbreviation, to which symbols in the collection belong.

Property type

Read-only property

Syntax

Visual Basic
Public Property DataSourceAbbreviation As String

Return Type

Data source abbreviation, represented as String

Example

See the usage of CQGDataSourceSymbols properties in the DataSourcesResolved event's example section.

See Also

CQGDataSourceSymbols Collection | CQGDataSourceSymbols Members | CQGCEL.DataSourcesResolved Event


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGDataSourceSymbols Collection : Item Property

Glossary Item Box

Description

Returns the CQGDataSourceSymbol by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGDataSourceSymbol

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item, represented as CQGDataSourceSymbol object

See Also

CQGDataSourceSymbols Collection | CQGDataSourceSymbols Members | CQGDataSourceSymbol Interface


%%PageItemTitle%%

CQGDOMOrder Object
See Also Members Send Feedback

Glossary Item Box

Description

Represents class for managing a DOM order (the one that makes a DOM price volume)

Object Model

CQGDOMOrder Object

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGDOMOrder Members


%%PageItemTitle%% $$Members$$

CQGDOMOrder Object Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property ContributorId | An order contributor ID. Applied only to detailed DOM actual mode
Public Property Id | An order ID. Applied only to detailed DOM actual mode
Public Property Type | DOM order type
Public Property Volume | An order volume
Public Property VolumeFractional | An order fractional volume

See Also

CQGDOMOrder Object


%%PageItemTitle%%

ContributorId Property
CQGDOMOrder Object : ContributorId Property

Glossary Item Box

Description

An order contributor ID. Applied only to detailed DOM actual mode

Property type

Read-only property

Syntax

Visual Basic
Public Property ContributorId As Long

See Also

CQGDOMOrder Object | CQGDOMOrder Members


%%PageItemTitle%%

Id Property
CQGDOMOrder Object : Id Property

Glossary Item Box

Description

An order ID. Applied only to detailed DOM actual mode

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

CQGDOMOrder Object | CQGDOMOrder Members


%%PageItemTitle%%

Type Property
CQGDOMOrder Object : Type Property

Glossary Item Box

Description

DOM order type

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As eDOMandBBAType

See Also

CQGDOMOrder Object | CQGDOMOrder Members


%%PageItemTitle%%

Volume Property
CQGDOMOrder Object : Volume Property

Glossary Item Box

Description

An order volume

Property type

Read-only property

Syntax

Visual Basic
Public Property Volume As {Unrecognised type 21}

See Also

CQGDOMOrder Object | CQGDOMOrder Members


%%PageItemTitle%%

VolumeFractional Property
CQGDOMOrder Object : VolumeFractional Property

Glossary Item Box

Description

An order fractional volume

Property type

Read-only property

Syntax

Visual Basic
Public Property VolumeFractional As Decimal

See Also

CQGDOMOrder Object | CQGDOMOrder Members


%%PageItemTitle%%

CQGDOMOrders Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents the collection of CQGDOMOrder

Object Model

CQGDOMOrders CollectionCQGDOMOrder Object

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGDOMOrders Members


%%PageItemTitle%% $$Members$$

CQGDOMOrders Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns a number of all items in the collection
Public Property Item | Returns a collection item by index

See Also

CQGDOMOrders Collection


%%PageItemTitle%%

_NewEnum Property
CQGDOMOrders Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGDOMOrders Collection | CQGDOMOrders Members


%%PageItemTitle%%

Count Property
CQGDOMOrders Collection : Count Property

Glossary Item Box

Description

Returns a number of all items in the collection

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

CQGDOMOrders Collection | CQGDOMOrders Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGDOMOrders Collection : Item Property

Glossary Item Box

Description

Returns a collection item by index

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGDOMOrder

Parameters

index_
Zero-based index of item in the collection

See Also

CQGDOMOrders Collection | CQGDOMOrders Members


%%PageItemTitle%%

CQGDOMQuotes Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGQuote. Each CQGQuote in the collection represents one item of the DOM book.

This is the default property.

Object Model

CQGDOMQuotes CollectionCQGQuote Interface

Remarks

To show the whole depth of the market, CQG API uses two instances of these collections. One for DOM Asks, one for DOM Bids.

There are two instances of this collection in CQGInstrument Object for access to instrument DOM asks and DOM bids.

While the instrument's subscription level is set to anything but dsQuotesAndDOM, its DOM collections are empty. But if after change to dsQuotesAndDOM the subscription level is changed again the contents of DOM collections will be preserved - they will not be reset.

This collection is also used as parameter in the InstrumentDOMChanged event.

Note: Not all the instruments have DOM support. If such an instrument's subscription level is set to dsQuotesAndDOM, its DOM collections will be empty.

See Accessing non-existent collection items for details on accessing items that do not exist in the collection.

Example

See the example of InstrumentDOMChanged Event.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGDOMQuotes Members


%%PageItemTitle%% $$Members$$

CQGDOMQuotes Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of quotes in the DOM collection.
Public Property Item | Returns the selected DOM quote from the collection. This is the default property.
Public Property ItemByPrice | Returns a DOM quote by its price.

See Also

CQGDOMQuotes Collection


%%PageItemTitle%%

_NewEnum Property
CQGDOMQuotes Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGDOMQuotes Collection | CQGDOMQuotes Members


%%PageItemTitle%%

Count Property
CQGDOMQuotes Collection : Count Property

Glossary Item Box

Description

Returns the number of quotes in the DOM collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of quotes represented as Long

Example

For the usage of the DOM collection, see the example section of the InstrumentDOMChanged Event.

See Also

CQGDOMQuotes Collection | CQGDOMQuotes Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGDOMQuotes Collection : Item Property

Glossary Item Box

Description

Returns the selected DOM quote from the collection.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGQuote

Parameters

index_
Zero-based index of item in the collection

Return Type

Corresponding collection item represented as CQGQuote.

If the accessed item does not exist, see Accessing non-existent collection items to learn more about the return type.

Remarks

This property is default.

Example

For the usage of the DOM collection, see the example section of the InstrumentDOMChanged Event.

See Also

CQGDOMQuotes Collection | CQGDOMQuotes Members


%%PageItemTitle%%

ItemByPrice Property
price_
round_to_better
CQGDOMQuotes Collection : ItemByPrice Property

Glossary Item Box

Description

Returns a DOM quote by its price.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemByPrice( _
   ByVal price_ As Double, _
   Optional ByVal round_to_better As Boolean = True _
) As CQGQuote

Parameters

price_
round_to_better

Return Type

Corresponding collection item represented as CQGQuote.

If the accessed item does not exist, see Accessing non-existent collection items to learn more about the return type.

Remarks

The impact of roundToBetter parameter depends on the collection. If the collection is a collection of asks, the better price is the lowest. Hence a quote will be returned with lower price than the one given in Price parameter.

And vice-versa for bids - if roundToBetter is True a quote with a higher price will be returned.

Example

For the usage of the DOM collection, see the example section of the InstrumentDOMChanged Event.

See Also

CQGDOMQuotes Collection | CQGDOMQuotes Members


%%PageItemTitle%%

CQGExchanges Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of exchange names.

Object Model

CQGExchanges Collection

Remarks

Used in CQGCEL.TradableExchangesResolved.

Enumeration through this collection is possible.

See Accessing non-existent collection items for details on accessing items that do not exist in the collection.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGExchanges Members


%%PageItemTitle%% $$Members$$

CQGExchanges Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of exchanges in the collection.
Public Property GWAccountID | Returns the gateway account ID, with which the tradable exchanges were requested.
Public Property Item | Returns the exchange name by its index. This is the default property.

See Also

CQGExchanges Collection


%%PageItemTitle%%

_NewEnum Property
CQGExchanges Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGExchanges Collection | CQGExchanges Members


%%PageItemTitle%%

Count Property
CQGExchanges Collection : Count Property

Glossary Item Box

Description

Returns the number of exchanges in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of exchanges in the collection, represented as Long

See Also

CQGExchanges Collection | CQGExchanges Members | CQGExchanges.Item Property


%%PageItemTitle%%

GWAccountID Property
CQGExchanges Collection : GWAccountID Property

Glossary Item Box

Description

Returns the gateway account ID, with which the tradable exchanges were requested.

Property type

Read-only property

Syntax

Visual Basic
Public Property GWAccountID As Long

Return Type

The Gateway account ID represented as Long.

The value that was passed to CQGCEL.RequestTradableExchanges, or 0 if not passed.

See Also

CQGExchanges Collection | CQGExchanges Members | CQGCEL.RequestTradableExchanges Method | CQGCEL.TradableExchangesResolved Event


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGExchanges Collection : Item Property

Glossary Item Box

Description

Returns the exchange name by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As String

Parameters

index_
Zero-based index of item in the collection

Return Type

Exchange name, represented as String

See Also

CQGExchanges Collection | CQGExchanges Members | CQGAPIConfig.CollectionsThrowException Property


%%PageItemTitle%%

CQGExecutionPatternParameters Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents collection of CQGExecutionPatternParameter objects.

Object Model

CQGExecutionPatternParameters CollectionCQGExecutionPatternParameter Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGExecutionPatternParameters Members


%%PageItemTitle%% $$Members$$

CQGExecutionPatternParameters Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method Add | Adds a new parameter to the collection.
Public Method Remove | Removes a parameter from the collection by its sequential index or name.

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of parameters in the collection.
Public Property Item | Returns a parameter from the collection by its sequential index or name.

See Also

CQGExecutionPatternParameters Collection


%%PageItemTitle%%

Add Method
name_

Parameter's name, represented as String

type_

Parameter's type represented as eExecutionPatternParameterType

value_

Parameter's value, represented as String.

If the parameter's type is epptObject, epptCollection, or epptCollectionItem; its value should be empty string.

CQGExecutionPatternParameters Collection : Add Method

Glossary Item Box

Description

Adds a new parameter to the collection.

Syntax

Visual Basic
Public Function Add( _
   ByVal name_ As String, _
   ByVal type_ As eExecutionPatternParameterType, _
   Optional ByVal value_ As String = "" _
) As CQGExecutionPatternParameter

Parameters

name_

Parameter's name, represented as String

type_
Value Description
epptBool

Boolean type

epptCollection

Collection type

epptCollectionItem

Collection item type

epptDouble

Double type

epptInt32

Integer type

epptObject

Object type

epptString

String type

Parameter's type represented as eExecutionPatternParameterType

value_

Parameter's value, represented as String.

If the parameter's type is epptObject, epptCollection, or epptCollectionItem; its value should be empty string.

Return Type

Returns the added parameter, represented as CQGExecutionPatternParameter

See Also

CQGExecutionPatternParameters Collection | CQGExecutionPatternParameters Members | eExecutionPatternParameterType Enumeration | CQGExecutionPatternParameter Interface


%%PageItemTitle%%

Remove Method
index_

Specifies the 0-based sequential index or the Name of the parameter in the collection.

If the index type is integer, valid values for index are from 0 to Count-1.

An exception is thrown when the accessed item does not exist (i.e., out-of-range index, inexistent name, or invalid index type).

CQGExecutionPatternParameters Collection : Remove Method

Glossary Item Box

Description

Removes a parameter from the collection by its sequential index or name.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal index_ As Variant _
)

Parameters

index_

Specifies the 0-based sequential index or the Name of the parameter in the collection.

If the index type is integer, valid values for index are from 0 to Count-1.

An exception is thrown when the accessed item does not exist (i.e., out-of-range index, inexistent name, or invalid index type).

See Also

CQGExecutionPatternParameters Collection | CQGExecutionPatternParameters Members


%%PageItemTitle%%

_NewEnum Property
CQGExecutionPatternParameters Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGExecutionPatternParameters Collection | CQGExecutionPatternParameters Members


%%PageItemTitle%%

Count Property
CQGExecutionPatternParameters Collection : Count Property

Glossary Item Box

Description

Returns the number of parameters in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of parameters, represented as Long

See Also

CQGExecutionPatternParameters Collection | CQGExecutionPatternParameters Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGExecutionPatternParameters Collection : Item Property

Glossary Item Box

Description

Returns a parameter from the collection by its sequential index or name.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Variant _
) As CQGExecutionPatternParameter

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item, represented as CQGExecutionPatternParameter

See Also

CQGExecutionPatternParameters Collection | CQGExecutionPatternParameters Members | CQGExecutionPatternParameter Interface


%%PageItemTitle%%

CQGExpression Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGExpressionOutputs.

Is returned by the CQGCEL.RequestExpression method call.

The CQGCEL.ExpressionResolved, CQGCEL.ExpressionAdded, and CQGCEL.ExpressionUpdated events can be fired for the CQGExpression.

Object Model

CQGExpression CollectionCQGExpressionOutputs Collection

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGExpression Members | CQGExpressionOutputs Collection | RemoveExpression Method | ExpressionResolved Event | ExpressionAdded Event | ExpressionRemoved Event | ExpressionUpdated Event


%%PageItemTitle%% $$Members$$

CQGExpression Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method IndexForDate

Returns the start index for the specified date.

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of all records in the collection.
Public Property EndTimestamp | Returns the ending (maximum) timestamp of arrived expression outputs, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
Public Property Id | Returns the unique identifier of the expression.
Public Property Item | Returns the CQGExpressionOutputs by its index. This is the default property.
Public Property LastError | Returns CQGError object describing the last error occurred to this object.
Public Property OutputHeaders | Returns the expression outputs headers.
Public Property Request | Returns the read-only copy of CQGExpressionRequest object, that was passed to the corresponding CQGCEL.RequestExpression method call.
Public Property StartTimestamp | Returns the starting (minimum) timestamp of arrived expression outputs, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
Public Property Status | Returns the status of the request.
Public Property Tag | This property allows the user to keep his/her own information within the expression.

See Also

CQGExpression Collection | CQGExpressionOutputs Collection | RemoveExpression Method | ExpressionResolved Event | ExpressionAdded Event | ExpressionRemoved Event | ExpressionUpdated Event


%%PageItemTitle%%

IndexForDate Method
date_

Specifies date, in the user-configured time zone (CQGAPIConfig.TimeZoneCode)

CQGExpression Collection : IndexForDate Method

Glossary Item Box

Description

Returns the start index for the specified date.

Syntax

Visual Basic
Public Function IndexForDate( _
   ByVal date_ As Date _
) As Long

Parameters

date_

Specifies date, in the user-configured time zone (CQGAPIConfig.TimeZoneCode)

Return Type

Start index, represented as Long

Remarks

If in this CQGExpression there are CQGExpressionOutputs objects having their Timestamp values equal to date_, the first such record's index is returned.

Otherwise, the returned value will be invalid.

See Also

CQGExpression Collection | CQGExpression Members | CQGAPIConfig.TimeZoneCode Property | CQGExpressionOutputs Collection


%%PageItemTitle%%

_NewEnum Property
CQGExpression Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGExpression Collection | CQGExpression Members


%%PageItemTitle%%

Count Property
CQGExpression Collection : Count Property

Glossary Item Box

Description

Returns the number of all records in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of records, represented as Long

See Also

CQGExpression Collection | CQGExpression Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

EndTimestamp Property
CQGExpression Collection : EndTimestamp Property

Glossary Item Box

Description

Returns the ending (maximum) timestamp of arrived expression outputs, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

Property type

Read-only property

Syntax

Visual Basic
Public Property EndTimestamp As Date

Return Type

Ending timestamp, represented as Date

See Also

CQGExpression Collection | CQGExpression Members


%%PageItemTitle%%

Id Property
CQGExpression Collection : Id Property

Glossary Item Box

Description

Returns the unique identifier of the expression.

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

Return Type

Unique identifier, represented as String

See Also

CQGExpression Collection | CQGExpression Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGExpression Collection : Item Property

Glossary Item Box

Description

Returns the CQGExpressionOutputs by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGExpressionOutputs

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item, represented as CQGExpressionOutputs object

Remarks

A CQGExpressionOutputs object will be created upon request and passed to the user without storing it.

Two sequential requests for the same record may return different objects.

See Also

CQGExpression Collection | CQGExpression Members | CQGExpressionOutputs Collection


%%PageItemTitle%%

LastError Property
CQGExpression Collection : LastError Property

Glossary Item Box

Description

Returns CQGError object describing the last error occurred to this object.

Property type

Read-only property

Syntax

Visual Basic
Public Property LastError As CQGError

Return Type

The last error, represented as CQGError object

See Also

CQGExpression Collection | CQGExpression Members | CQGError Interface


%%PageItemTitle%%

OutputHeaders Property
CQGExpression Collection : OutputHeaders Property

Glossary Item Box

Description

Returns the expression outputs headers.

Property type

Read-only property

Syntax

Visual Basic
Public Property OutputHeaders As CQGExpressionOutputHeaders

Return Type

Expression outputs headers, represented as the CQGExpressionOutputHeaders collection

See Also

CQGExpression Collection | CQGExpression Members | CQGExpressionOutputHeaders Collection


%%PageItemTitle%%

Request Property
CQGExpression Collection : Request Property

Glossary Item Box

Description

Returns the read-only copy of CQGExpressionRequest object, that was passed to the corresponding CQGCEL.RequestExpression method call.

Property type

Read-only property

Syntax

Visual Basic
Public Property Request As CQGExpressionRequest

Return Type

Read-only copy of the corresponding CQGExpressionRequest object

See Also

CQGExpression Collection | CQGExpression Members | CQGExpressionRequest Interface | CQGCEL.RequestExpression Method


%%PageItemTitle%%

StartTimestamp Property
CQGExpression Collection : StartTimestamp Property

Glossary Item Box

Description

Returns the starting (minimum) timestamp of arrived expression outputs, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

Property type

Read-only property

Syntax

Visual Basic
Public Property StartTimestamp As Date

Return Type

Starting timestamp, represented as Date

See Also

CQGExpression Collection | CQGExpression Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

Status Property
CQGExpression Collection : Status Property

Glossary Item Box

Description

Returns the status of the request.

Property type

Read-only property

Syntax

Visual Basic
Public Property Status As eRequestStatus

Return Type

Request status, represented as eRequestStatus

Remarks

See eRequestStatus for possible values.

See Also

CQGExpression Collection | CQGExpression Members | eRequestStatus Enumeration


%%PageItemTitle%%

Tag Property
tag_name

The user-defined value's name.

When setting, the tag_name parameter should keep the key that will be associated with the passed information.

When getting the information from the Tag, one of the previously set keys should be passed as tag_name in order to get the corresponding information.

CQGExpression Collection : Tag Property

Glossary Item Box

Description

This property allows the user to keep his/her own information within the expression.

Property type

Read-write property

Syntax

Visual Basic
Public Property Tag( _
   ByVal tag_name As String _
) As Variant

Parameters

tag_name

The user-defined value's name.

When setting, the tag_name parameter should keep the key that will be associated with the passed information.

When getting the information from the Tag, one of the previously set keys should be passed as tag_name in order to get the corresponding information.

Return Type

The user-defined value, represented as Variant

Remarks

Multiple data can be kept in the Tag property under different keys.

If no user-defined value with this tag_name exists, Empty is returned.

If empty is set to an existing tag_name, it is deleted/unregistered.

If a new value is set to an existing tag_name, the old value is overwritten.

See Also

CQGExpression Collection | CQGExpression Members


%%PageItemTitle%%

CQGExpressionOutputHeaders Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of String - expression output headers.

Object Model

CQGExpressionOutputHeaders Collection

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGExpressionOutputHeaders Members


%%PageItemTitle%% $$Members$$

CQGExpressionOutputHeaders Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of String in the collection.
Public Property Item | Returns the String by its index. This is the default property.

See Also

CQGExpressionOutputHeaders Collection


%%PageItemTitle%%

_NewEnum Property
CQGExpressionOutputHeaders Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGExpressionOutputHeaders Collection | CQGExpressionOutputHeaders Members


%%PageItemTitle%%

Count Property
CQGExpressionOutputHeaders Collection : Count Property

Glossary Item Box

Description

Returns the number of String in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of String, represented as Long

See Also

CQGExpressionOutputHeaders Collection | CQGExpressionOutputHeaders Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGExpressionOutputHeaders Collection : Item Property

Glossary Item Box

Description

Returns the String by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As String

Parameters

index_
Zero-based index of item in the collection

See Also

CQGExpressionOutputHeaders Collection | CQGExpressionOutputHeaders Members


%%PageItemTitle%%

CQGExpressionOutputs Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of expression outputs.

Object Model

CQGExpressionOutputs Collection

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGExpressionOutputs Members


%%PageItemTitle%% $$Members$$

CQGExpressionOutputs Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of expression outputs in the collection.
Public Property Item | Returns the expression output by ist key. this is the default property.
Public Property Timestamp | Returns the timestamp, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
Public Property TimestampOffset | Returns the timestamp offset, which is used to identify various CQGExpressionOutputs objects that have the same timestamp.

See Also

CQGExpressionOutputs Collection


%%PageItemTitle%%

_NewEnum Property
CQGExpressionOutputs Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGExpressionOutputs Collection | CQGExpressionOutputs Members


%%PageItemTitle%%

Count Property
CQGExpressionOutputs Collection : Count Property

Glossary Item Box

Description

Returns the number of expression outputs in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of expression outputs, represented as Long

See Also

CQGExpressionOutputs Collection | CQGExpressionOutputs Members


%%PageItemTitle%%

Item Property
key_
CQGExpressionOutputs Collection : Item Property

Glossary Item Box

Description

Returns the expression output by ist key.

this is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal key_ As Variant _
) As Double

Parameters

key_

Remarks

The call will throw a collection exception in case of incorrect type, out-of-range index, or inexistent name.

See Also

CQGExpressionOutputs Collection | CQGExpressionOutputs Members


%%PageItemTitle%%

Timestamp Property
CQGExpressionOutputs Collection : Timestamp Property

Glossary Item Box

Description

Returns the timestamp, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

Property type

Read-only property

Syntax

Visual Basic
Public Property Timestamp As Date

Return Type

Timestamp, represented as Date

See Also

CQGExpressionOutputs Collection | CQGExpressionOutputs Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

TimestampOffset Property
CQGExpressionOutputs Collection : TimestampOffset Property

Glossary Item Box

Description

Returns the timestamp offset, which is used to identify various CQGExpressionOutputs objects that have the same timestamp.

Property type

Read-only property

Syntax

Visual Basic
Public Property TimestampOffset As Long

Return Type

Timestamp offset, represented as Long

Remarks

The TimestampOffset value grows for subsequent objects. It resets when the timestamp is changed.

See Also

CQGExpressionOutputs Collection | CQGExpressionOutputs Members


%%PageItemTitle%%

CQGExpressions Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGExpression objects.

Object Model

CQGExpressions CollectionCQGExpression Collection

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGExpressions Members | CQGExpression Collection


%%PageItemTitle%% $$Members$$

CQGExpressions Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGExpression in the collection.
Public Property Item | Returns the CQGExpression by its index. This is the default property.
Public Property ItemById | Returns the CQGExpression by its unique identifier.

See Also

CQGExpressions Collection | CQGExpression Collection


%%PageItemTitle%%

_NewEnum Property
CQGExpressions Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGExpressions Collection | CQGExpressions Members


%%PageItemTitle%%

Count Property
CQGExpressions Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGExpression in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of collection items, represented as Long

See Also

CQGExpressions Collection | CQGExpressions Members | CQGExpression Collection


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGExpressions Collection : Item Property

Glossary Item Box

Description

Returns the CQGExpression by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGExpression

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item, represented as CQGExpression object

See Also

CQGExpressions Collection | CQGExpressions Members | CQGExpression Collection


%%PageItemTitle%%

ItemById Property
id_
CQGExpressions Collection : ItemById Property

Glossary Item Box

Description

Returns the CQGExpression by its unique identifier.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemById( _
   ByVal id_ As String _
) As CQGExpression

Parameters

id_

Remarks

A collection exception will be thrown if no CQGExpression exists with the specified id.

See Also

CQGExpressions Collection | CQGExpressions Members | CQGExpression Collection


%%PageItemTitle%%

CQGFills Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGFill objects.

Object Model

CQGFills CollectionCQGFill Interface

Remarks

All fills of an order are stored in this collection, each one represented as a CQGFill object. If one fill is overridden by another, both will be stored in the collection.

Access to an item in this collection can be made based on either CQGFill.Id or its sequential index.

See Accessing non-existent collection items for details on accessing items that do not exist in the collection.

Example

See the usage of CQG API collections in the InstrumentChanged event's example section.

See the usage of CQGFill properties in the OrderChanged event's example section.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGFills Members


%%PageItemTitle%% $$Members$$

CQGFills Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of fills in the collection.
Public Property Item | Returns the fill by its CQGFill.Id. This is the default property.
Public Property ItemByIndex | Returns the fill by its sequential index.

See Also

CQGFills Collection


%%PageItemTitle%%

_NewEnum Property
CQGFills Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGFills Collection | CQGFills Members


%%PageItemTitle%%

Count Property
CQGFills Collection : Count Property

Glossary Item Box

Description

Returns the number of fills in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of fills represented as Long

Example

See the usage of CQGFill properties in the OrderChanged event's example section.

See Also

CQGFills Collection | CQGFills Members


%%PageItemTitle%%

Item Property
fill_id
CQGFills Collection : Item Property

Glossary Item Box

Description

Returns the fill by its CQGFill.Id.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal fill_id As String _
) As CQGFill

Parameters

fill_id

Return Type

If the fill exists in the collection, this property returns the selected fill represented as CQGFill object.

If the accessed item does not exist, see Accessing non-existent collection items to learn more about the return type.

Example

See the usage of CQGFill properties in the OrderChanged event's example section.

See Also

CQGFills Collection | CQGFills Members | CQGFill Interface | CQGFill.Id parameter


%%PageItemTitle%%

ItemByIndex Property
index_
Index of the fill inside the collection
CQGFills Collection : ItemByIndex Property

Glossary Item Box

Description

Returns the fill by its sequential index.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemByIndex( _
   ByVal index_ As Long _
) As CQGFill

Parameters

index_
Index of the fill inside the collection

Return Type

If the fill exists in the collection, this property returns the selected fill represented as CQGFill object.

If the accessed item does not exist, see Accessing non-existent collection items to learn more about the return type.

Example

See the usage of CQGFill properties in the OrderChanged event's example section.

See Also

CQGFills Collection | CQGFills Members | CQGFill Interface


%%PageItemTitle%%

CQGGWTrades Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGGWTrade objects.

Object Model

CQGGWTrades CollectionCQGGWTrade Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGGWTrades Members


%%PageItemTitle%% $$Members$$

CQGGWTrades Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Get the number of all atomic fills in the collection
Public Property Item | Get the trade by its GW ID
Public Property ItemByIndex | Get the gateway trade by sequential index

See Also

CQGGWTrades Collection


%%PageItemTitle%%

_NewEnum Property
CQGGWTrades Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGGWTrades Collection | CQGGWTrades Members


%%PageItemTitle%%

Count Property
CQGGWTrades Collection : Count Property

Glossary Item Box

Description

Get the number of all atomic fills in the collection

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

CQGGWTrades Collection | CQGGWTrades Members


%%PageItemTitle%%

Item Property
trade_gw_id
CQGGWTrades Collection : Item Property

Glossary Item Box

Description

Get the trade by its GW ID

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal trade_gw_id As String _
) As CQGGWTrade

Parameters

trade_gw_id

See Also

CQGGWTrades Collection | CQGGWTrades Members


%%PageItemTitle%%

ItemByIndex Property
index_
Index of the trade inside the collection
CQGGWTrades Collection : ItemByIndex Property

Glossary Item Box

Description

Get the gateway trade by sequential index

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemByIndex( _
   ByVal index_ As Long _
) As CQGGWTrade

Parameters

index_
Index of the trade inside the collection

See Also

CQGGWTrades Collection | CQGGWTrades Members


%%PageItemTitle%%

CQGHolidays Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGHoliday objects.

Object Model

CQGHolidays CollectionCQGHoliday Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGHolidays Members | CQGHoliday Interface


%%PageItemTitle%% $$Members$$

CQGHolidays Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGHoliday objects in the collection.
Public Property Item | Returns the CQGHoliday by its index. This is the default property.
Public Property Sessions | Returns the CQGSessions that this collection belongs to.

See Also

CQGHolidays Collection | CQGHoliday Interface


%%PageItemTitle%%

_NewEnum Property
CQGHolidays Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGHolidays Collection | CQGHolidays Members


%%PageItemTitle%%

Count Property
CQGHolidays Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGHoliday objects in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of collection items, represented as Long

See Also

CQGHolidays Collection | CQGHolidays Members | CQGHoliday Interface


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGHolidays Collection : Item Property

Glossary Item Box

Description

Returns the CQGHoliday by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGHoliday

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item represented as CQGHoliday

Remarks

For more information, see CQGCEL.HistoricalSessionsResolved's remark section.

See Also

CQGHolidays Collection | CQGHolidays Members | CQGHoliday Interface


%%PageItemTitle%%

Sessions Property
CQGHolidays Collection : Sessions Property

Glossary Item Box

Description

Returns the CQGSessions that this collection belongs to.

Property type

Read-only property

Syntax

Visual Basic
Public Property Sessions As CQGSessions

Return Type

The corresponding sessions collection, represented as CQGSessions

Remarks

For more information, see CQGCEL.HistoricalSessionsResolved's remark section.

See Also

CQGHolidays Collection | CQGHolidays Members | CQGSessions Collection


%%PageItemTitle%%

CQGInstrumentProperties Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of instrument (dynamic and static) properties.

Object Model

CQGInstrumentProperties CollectionCQGInstrumentProperty Interface

Remarks

This collection is used in CQGInstrument Object to access the instrument properties (dynamic and static), and in InstrumentChanged Event as a parameter passing the changed properties.

Access to an item in this collection is made by property type.

See Accessing non-existent collection items for details on accessing items that do not exist in the collection.

Example

See the example of InstrumentChanged Event.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGInstrumentProperties Members | CQGInstrumentProperty Interface | eInstrumentProperty Enumeration


%%PageItemTitle%% $$Members$$

CQGInstrumentProperties Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Gets the number of properties in this collection.
Public Property Item | Returns the instrument property of the specified type. This is the default property.

See Also

CQGInstrumentProperties Collection | CQGInstrumentProperty Interface | eInstrumentProperty Enumeration


%%PageItemTitle%%

_NewEnum Property
CQGInstrumentProperties Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGInstrumentProperties Collection | CQGInstrumentProperties Members


%%PageItemTitle%%

Count Property
CQGInstrumentProperties Collection : Count Property

Glossary Item Box

Description

Gets the number of properties in this collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

the number of properties represented as Long

Example

See the example of InstrumentChanged Event.

See Also

CQGInstrumentProperties Collection | CQGInstrumentProperties Members


%%PageItemTitle%%

Item Property
instrument_property
CQGInstrumentProperties Collection : Item Property

Glossary Item Box

Description

Returns the instrument property of the specified type.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal instrument_property As eInstrumentProperty _
) As CQGInstrumentProperty

Parameters

instrument_property
Value | Description
ipAverageVolatility

Average volatility based on Options Preferences in CQG IC UI.

This is a floating-point-type property (dynamic property).

See CQG IC Help for the calculation formula.

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psVolatility flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipCommodity

Instrument commodity.

See the Commodity property of the CQGInstrument class.

This is a string-type property with a limited length of 16 characters.

ipCountry

Instrument country.

See the Country property of the CQGInstrument class.

This is a string-type property with a limited length of 3 characters.

ipCurrency

Instrument currency.

See the Currency property of the CQGInstrument class.

This is a string-type property with a limited length of 4 characters.

ipDecimalStrike

Decimal strike representation.

ipDelayMode

Instrument delay mode.

See eDelayMode for details.

ipDelayPeriod

Instrument delay period value in minutes.

The property value depends on ipDelayMode property and can have the following values:

ipDelayMode value

 ipDelayPeriod values
dmUndefined | -1
dmNoDelay | 0
dmDelay | >0
dmEndOfDeyDelay | >=0
ipDelayTime

Time of delay for contract in minutes.

ipDelta

Current Delta of option based on Options Preferences in CQG IC UI.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psGreeks flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipDeltaNetChange

Change in Delta value from the prior day.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psGreeks flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipDescription

Instrument description.

See the Description property of the CQGInstrument class.

This is a string-type property with a limited length of 252 characters.

ipDetailedName | Instrument detailed name. For example, F.US.EP.M20, C.US.CLE.N20.N100
ipDTE

Days to expiration (dynamic property).

See the DTE property of the CQGInstrument class.

ipExchangeAbbreviation

Exchange abbreviation.

See the ExchangeAbbreviation property of the CQGInstrument class.

ipExchangeID

Exchange's identification number.

See the ExchangeID property of the CQGInstrument class.

ipExchangeState

Exchange state.

See the ExchangeState property of the CQGInstrument class.

ipExpirationDate

Instrument expiration date.

See the ExpirationDate property of the CQGInstrument class.

ipFirstNoticeDate

Instrument first notice date.

ipFullName

Instrument full name.

See the FullName property of the CQGInstrument class.

This is a string-type property with a limited length of 128 characters.

ipGamma

Current Gamma of option based on Options Preferences in CQG IC UI.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psGreeks flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipGammaNetChange

Change in Gamma value from the prior day.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psGreeks flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipImpliedVolatility

Implied volatility of an options contract using selected options model in Options Preferences in CQG IC UI.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psVolatility flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipImpliedVolatilityNetChange

Change in Implied Volatility from prior day's close.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psVolatility flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipImpliedVolatilityOnAsk

Implied volatility for the option ask price using selected options model in Options Preferences in CQG IC UI.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psVolatility flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipImpliedVolatilityOnBid

Implied volatility for the option bid price using selected options model in Options Preferences in CQG IC UI.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psVolatility flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipInitialMargin

Instrument initial margin.

See the InitialMargin property of the CQGInstrument class.

ipInstrumentID

Instrument unique and invariant identifier.

See the InstrumentID property of the CQGInstrument class.

ipInstrumentType

Instrument type.

See the InstrumentType property of the CQGInstrument class.

ipIsDetailedDOMAvailable | Indicates whether detailed DOM is available for instrument.
ipIsDownTick

Indicated if market goes down (dynamic property).

See the IsDownTick property of the CQGInstrument class.

ipIsFastMarket

Indicated whether contract is traded with red light (dynamic property).

See the IsFastMarket property of the CQGInstrument class.

ipIsFutureStyleOption | Futures style option
ipIsUpTick

Indicated if market goes up (dynamic property).

See the IsUpTick property of the CQGInstrument class.

ipIsVariableTickSize | Indicates whether instrument tick size data is variable.
ipLeadingContractName

The leading contract name for the commodity.

This is a string-type property with a limited length of 128 characters.

ipMaintenanceMargin

Instrument maintenance margin.

See the MaintenanceMargin property of the CQGInstrument class.

ipMarketState

Instrument market state.

See the MarketState property of the CQGInstrument class.

ipMonth

Instrument month.

See the Month property of the CQGInstrument class.

ipMonthChar

Instrument month character.

See MonthChar property of the CQGInstrument class.

ipNetChange

Option net change (dynamic property).

See the NetChange property of the CQGInstrument class.

ipPreferredSessionName

The preferred custom session name (dynamic property).

See the PreferredSessionsName property of the CQGInstrument Object class.

This is a string-type property with a limited length of 64 characters.

ipRho

Current Rho of option based on Options Preferences in CQG IC UI.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psGreeks flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipRhoNetChange

Change in Rho value from the prior day.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psGreeks flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipScale

Instrument scale.

See the Scale property of the CQGInstrument class.

ipSessionMask

Instrument session mask.

See the SessionMask property of the CQGInstrument class.

ipSessionNumber

Current session number (dynamic property).

See the SessionNumber property of the CQGInstrument class.

ipStrike

Instrument strike.

See the Strike property of the CQGInstrument class.

ipStrikeScale

Strike scale.

ipTheoreticalValue

Theoretical Value of option based on Options Preferences in CQG IC UI.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psTheoreticalValue flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipTheoValueNetChange

Change in Theoretical Value from the prior day.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psTheoreticalValue flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipTheta

Current Theta of option based on Options Preferences in CQG IC UI.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psGreeks flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipThetaNetChange

Change in Theta value from the prior day.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psGreeks flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipTickSize

Instrument tick size.

See the TickSize property of the CQGInstrument class.

ipTickSizeFractionDenominator

The instrument fractional tick size denominator.

See the TickSizeFractionDenominator property of the CQGInstrument class.

ipTickSizeFractionNumerator

The instrument fractional tick size numerator.

See the TickSizeFractionNumerator property of the CQGInstrument class.

ipTickValue

Instrument tick value.

See the TickValue property of the CQGInstrument class.

ipTodayCTotalVolume

The total trade volume of the contract for today (dynamic property).

See the TodayCTotalVolume property of the CQGInstrument class.

ipTodayCTotalVolumeFractional | The same as ipTodayCTotalVolume, but values have a decimal type
ipVega

Current Vega of option based on Options Preferences in CQG IC UI.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psGreeks flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipVegaNetChange

Change in Vega value from the prior day.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psGreeks flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipVolatilityCurve

Volatility designated in Volatility Workshop based on Volatility Workshop Preferences in CQG IC UI.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psVolatility flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipWorkup

Workup mode.

ipYCOI

The open interest of the contract for yesterday (dynamic property).

See the YCOI property of the CQGInstrument class.

ipYear

Instrument year.

See the Year property of the CQGInstrument class.

ipYearString

Instrument year string.

See the YearString property of the CQGInstrument class.

This is a string-type property with a limited length of 5 characters.

ipYesterdayCTotalVolume

The total trade volume of the contract for yesterday (dynamic property).

See the YesterdayCTotalVolume property of the CQGInstrument class.

ipYesterdayCTotalVolumeFractional | The same as ipYesterdayCTotalVolume, but values have a decimal type

Return Type

The selected instrument property represented as CQGInstrumentProperty Object.

If the accessed item does not exist, see Accessing non-existent collection items to learn more about the return type.

Example

See the example of InstrumentChanged Event.

See Also

CQGInstrumentProperties Collection | CQGInstrumentProperties Members | CQGInstrumentProperty Interface | eInstrumentProperty Enumeration


%%PageItemTitle%%

CQGInstruments Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGInstrument objects.

Object Model

CQGInstruments CollectionCQGInstrument Interface

Remarks

In this collection, there are instruments that are subscribed, or which subscription level was set to dsNone, but they were not removed.

Access to an item in this collection can be made based on Instrument Full Name or Instrument ID.

See Accessing non-existent collection items for details on accessing items that do not exist in the collection.

Example

See the usage of CQGInstruments collection in CQGCEL Instruments property's example section.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGInstruments Members


%%PageItemTitle%% $$Members$$

CQGInstruments Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of instruments in the instruments collection.
Public Property Item | Returns the selected instrument from the collection. This is the default property.

See Also

CQGInstruments Collection


%%PageItemTitle%%

_NewEnum Property
CQGInstruments Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGInstruments Collection | CQGInstruments Members


%%PageItemTitle%%

Count Property
CQGInstruments Collection : Count Property

Glossary Item Box

Description

Returns the number of instruments in the instruments collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of instruments represented as Long.

Example

For the usage of the Instruments collection, see the example section of CQGCEL Instruments Property.

See Also

CQGInstruments Collection | CQGInstruments Members | CQGCEL.Instruments Property


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGInstruments Collection : Item Property

Glossary Item Box

Description

Returns the selected instrument from the collection.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Variant _
) As CQGInstrument

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item represented as CQGInstrument Object.

If the accessed item does not exist, see Accessing non-existent collection items to learn more about the return type.

Example

For the usage of the Instruments collection, see the example section of the CQGCEL Instruments Property.

See Also

CQGInstruments Collection | CQGInstruments Members | CQGInstrument Interface | CQGCEL.Instruments Property


%%PageItemTitle%%

CQGInstrumentsGroups Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGInstrumentsGroup objects.

Object Model

CQGInstrumentsGroups CollectionCQGInstrumentsGroup Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGInstrumentsGroups Members


%%PageItemTitle%% $$Members$$

CQGInstrumentsGroups Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of all instruments groups in the collection.
Public Property Item | Returns an instrument group by its index or group id.

See Also

CQGInstrumentsGroups Collection


%%PageItemTitle%%

_NewEnum Property
CQGInstrumentsGroups Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGInstrumentsGroups Collection | CQGInstrumentsGroups Members


%%PageItemTitle%%

Count Property
CQGInstrumentsGroups Collection : Count Property

Glossary Item Box

Description

Returns the number of all instruments groups in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of instruments groups, represented as Long

See Also

CQGInstrumentsGroups Collection | CQGInstrumentsGroups Members


%%PageItemTitle%%

Item Property
index_

The value is used as an index if it is an integer.

The value is used as a group id if it is a string.

CQGInstrumentsGroups Collection : Item Property

Glossary Item Box

Description

Returns an instrument group by its index or group id.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Variant _
) As CQGInstrumentsGroup

Parameters

index_

The value is used as an index if it is an integer.

The value is used as a group id if it is a string.

Return Type

The corresponding collection member, represented as CQGInstrumentsGroup object

See Also

CQGInstrumentsGroups Collection | CQGInstrumentsGroups Members | CQGInstrumentsGroup Interface | CQGInstrumentsGroups.Count Property


%%PageItemTitle%%

CQGIntegerCollection Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of Integers.

Object Model

CQGIntegerCollection Collection

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGIntegerCollection Members


%%PageItemTitle%% $$Members$$

CQGIntegerCollection Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of integer values in the collection.
Public Property Item | Returns the integer value by its identifier.

See Also

CQGIntegerCollection Collection


%%PageItemTitle%%

_NewEnum Property
CQGIntegerCollection Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGIntegerCollection Collection | CQGIntegerCollection Members


%%PageItemTitle%%

Count Property
CQGIntegerCollection Collection : Count Property

Glossary Item Box

Description

Returns the number of integer values in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of integers, represented as Long

See Also

CQGIntegerCollection Collection | CQGIntegerCollection Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGIntegerCollection Collection : Item Property

Glossary Item Box

Description

Returns the integer value by its identifier.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As Long

Parameters

index_
Zero-based index of item in the collection

Return Type

Value of the integer, represented as Long

See Also

CQGIntegerCollection Collection | CQGIntegerCollection Members


%%PageItemTitle%%

CQGManualFills Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGManualFill objects

Object Model

CQGManualFills CollectionCQGManualFill Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGManualFills Members


%%PageItemTitle%% $$Members$$

CQGManualFills Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGManualFill in the collection.
Public Property DataLevel | Returns CQGManualFills data level
Public Property GWAccountID | Gets the Gateway Account ID for the contained manual fill objects.
Public Property Item | Returns the manual fill member by its trade_id. This is the default property.
Public Property ItemByIndex | Returns the manual fill by its sequential index.

See Also

CQGManualFills Collection


%%PageItemTitle%%

_NewEnum Property
CQGManualFills Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGManualFills Collection | CQGManualFills Members


%%PageItemTitle%%

Count Property
CQGManualFills Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGManualFill in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of collection members, represented as Long

See Also

CQGManualFills Collection | CQGManualFills Members


%%PageItemTitle%%

DataLevel Property
CQGManualFills Collection : DataLevel Property

Glossary Item Box

Description

Returns CQGManualFills data level

Property type

Read-only property

Syntax

Visual Basic
Public Property DataLevel As eManualFillsDataLevel

Return Type

Manual fills data level, represented as eManualFillsDataLevel

See Also

CQGManualFills Collection | CQGManualFills Members | CQGManualFill Interface | eManualFillsDataLevel Enumeration


%%PageItemTitle%%

GWAccountID Property
CQGManualFills Collection : GWAccountID Property

Glossary Item Box

Description

Gets the Gateway Account ID for the contained manual fill objects.

Property type

Read-only property

Syntax

Visual Basic
Public Property GWAccountID As Long

Return Type

Gateway Account ID, represented as Long

See Also

CQGManualFills Collection | CQGManualFills Members


%%PageItemTitle%%

Item Property
trade_id
CQGManualFills Collection : Item Property

Glossary Item Box

Description

Returns the manual fill member by its trade_id.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal trade_id As Long _
) As CQGManualFill

Parameters

trade_id

Return Type

If the fill exists in the collection, this property returns the selected fill; represented as CQGManualFill object.

If the accessed item does not exist, see Accessing non-existent collection items to learn more about the return type.

See Also

CQGManualFills Collection | CQGManualFills Members


%%PageItemTitle%%

ItemByIndex Property
index_
Zero-based index of item in the collection
CQGManualFills Collection : ItemByIndex Property

Glossary Item Box

Description

Returns the manual fill by its sequential index.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemByIndex( _
   ByVal index_ As Long _
) As CQGManualFill

Parameters

index_
Zero-based index of item in the collection

Return Type

If the fill exists in the collection, this property returns the selected fill; represented as CQGManualFill object.

If the accessed item does not exist, see Accessing non-existent collection items to learn more about the return type.

See Also

CQGManualFills Collection | CQGManualFills Members


%%PageItemTitle%%

CQGManualFillsCollection Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGManualFills objects.

Object Model

CQGManualFillsCollection CollectionCQGManualFills Collection

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGManualFillsCollection Members


%%PageItemTitle%% $$Members$$

CQGManualFillsCollection Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of manual fills collections in the collection.
Public Property Item | Returns the selected manual fills collection by its Gateway account ID. This is the default property.
Public Property ItemByIndex | Returns the corresponding CQGManualFills collection by its sequential index.

See Also

CQGManualFillsCollection Collection


%%PageItemTitle%%

_NewEnum Property
CQGManualFillsCollection Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGManualFillsCollection Collection | CQGManualFillsCollection Members


%%PageItemTitle%%

Count Property
CQGManualFillsCollection Collection : Count Property

Glossary Item Box

Description

Returns the number of manual fills collections in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of collection members, represented as Long

See Also

CQGManualFillsCollection Collection | CQGManualFillsCollection Members


%%PageItemTitle%%

Item Property
account_id
CQGManualFillsCollection Collection : Item Property

Glossary Item Box

Description

Returns the selected manual fills collection by its Gateway account ID.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal account_id As Long _
) As CQGManualFills

Parameters

account_id

See Also

CQGManualFillsCollection Collection | CQGManualFillsCollection Members


%%PageItemTitle%%

ItemByIndex Property
index_
Zero-based index of item in the collection
CQGManualFillsCollection Collection : ItemByIndex Property

Glossary Item Box

Description

Returns the corresponding CQGManualFills collection by its sequential index.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemByIndex( _
   ByVal index_ As Long _
) As CQGManualFills

Parameters

index_
Zero-based index of item in the collection

Return Type

Manual fills collection, represented as CQGManualFills

See Also

CQGManualFillsCollection Collection | CQGManualFillsCollection Members | CQGManualFills Collection


%%PageItemTitle%%

CQGModifiedProperties Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGModifiedProperty objects.

Object Model

CQGModifiedProperties CollectionCQGModifiedProperty Interface

Remarks

Access to an item in this collection can be made based on either order property type or sequential index.

See Accessing non-existent collection items for details on accessing items that do not exist in the collection.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGModifiedProperties Members | CQGModifiedProperty Interface


%%PageItemTitle%% $$Members$$

CQGModifiedProperties Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of the CQGModifiedProperty objects in the collection.
Public Property Item | Returns the modified property object by its type.
Public Property ItemByIndex | Returns the modified property object by its sequential index.

See Also

CQGModifiedProperties Collection | CQGModifiedProperty Interface


%%PageItemTitle%%

_NewEnum Property
CQGModifiedProperties Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGModifiedProperties Collection | CQGModifiedProperties Members


%%PageItemTitle%%

Count Property
CQGModifiedProperties Collection : Count Property

Glossary Item Box

Description

Returns the number of the CQGModifiedProperty objects in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of modified properties, represented as Long

See Also

CQGModifiedProperties Collection | CQGModifiedProperties Members


%%PageItemTitle%%

Item Property
property_type
CQGModifiedProperties Collection : Item Property

Glossary Item Box

Description

Returns the modified property object by its type.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal property_type As eOrderProperty _
) As CQGModifiedProperty

Parameters

property_type
Value | Description
opAccountID

CQG Gateway identifier of the account to which this order belongs.

This is a read-only property of Long type.

opActivationTime
UTC Date/time the parked order should automatically activate.
This is read-write property of Date type.
When a property is set during order creation, it is necessary to set the opParked property to True.
The property is writable only when the opParked property value is True.
The property corresponds to until_ parameter from CQGOrder.Park method.
The property is modifiable through the CQGOrderModify object.
Set the property value to "12/30/1899 12:00:00 AM" UTC to remove the activation time through the CQGOrderModify object.
opAggressive

The property specifying the aggressiveness of the order (Fixed Income only).

This is a read/write property of Boolean type.

This property becomes read-only after the order is placed.

opAlgorithmID

Algorithm identifier of the order

This is a read-only property of Long type.

opAverageFillPrice

The average price of the order's fills.

This is a read-only property of Double type.

opCancelationInstruction

The strategy order cancelation flag that determines the cancelation type.

This is a read-write property of eOrderCancelationType type.

opCanceledTime

Time of the cancelation transaction for this order.

This is a read-only property of Date type.

opCareOrderIDs | Property which defines the comma separated set of care order identifiers based on which the execution is done
opCompoundOrderGUID

Compound order GUID. Value equals to GUID property of CQGOrderChain that was used as parameter in PlaceCompoundOrderEx.

Property is present only if order is a part (leg) of some compound order.

This is a read-only property of String type.

opCompoundOrderID

Compound order ID, unique value assigned by server.

Property is present only if order is a part (leg) of some compound order.

This is a read-only property of String type.

opCompoundOrderType

Compound order type.

Property is present only if order is a part (leg) of some compound order.

This is read-only property of ECompoundOrderType type.

opCQGID

The CQG system identifier (serial number).

This is a read-only property of String type.

opDescription

User-created custom description for the order.

Note that this description is stored on the gateway and is not lost between the sessions.

This is a read-write property of String type.

opDurationType

The duration of the order.

This is a read/write property of eOrderDuration type.

This property becomes read-only after the order is placed.

This property is available if order type is not otMarket.

opErrorFlag

The flag that indicates that the order had errors.

This is a read-only property of Boolean type.

opEventServerTimestamp

The server timestamp of the last event of the order.

This is a read-only property of Date type.

opEventTimestamp

The local timestamp of the last event of the order.

This is a read-only property of Date type.

opExchangeConf

The confirmation supplied for the order by the Exchange (Exchange order ID).

This is a read-only property of String type.

opExecSystemOrderID

The system specific order ID.

This is a read-only property of String type.

opExecutionInstructions

The property specifying the combination of execution instructions.

This is a read/write bitmask of eOrderExecutionInstruction type.

This property becomes read-only after the order is placed.

opExecutionPattern

Execution pattern of the spread order represented as string.

This is a read/write property of String type.

opExtendedSide

Specifies special order side value.

This is a read/write property of EExtendedSide type.

This property is modifiable through the CQGOrderModify object.

See EExtendedSide description for more information.

opFilledCount

The number of order fills.

This is a read-only property of Long type.

opFilledQuantity

The filled quantity of the order.

This is a read-only property of Long type.

opFilledQuantityFractional

The same as opFilledQuantity but data type. The data type is Decimal.

opGTDTime

The good-till-date value of the order.

This is a read/write property of Date type.

This property is available if order duration type is odGoodTillDate.

opGTTTime

The good-till-time value of the order.

This is a read/write property of Date type.

This property is available if order duration type is odDayGoodTillTime or odGoodTillTime.

opGUID

The GUID of the order.

This is a read-only property of String type.

opGWStatus

The CQG Gateway status of the order.

This is a read-only property of eOrderStatus type.

opInstrumentName

The full name of the Instrument on which this order is placed.

This is a read-only property of String type.

opInstrumentNameDetailed

The detailed name of the Instrument on which this order is placed.

This is a read-only property of String type.

opIsCareOrder

Property which defines if the order is Care order or not.

This is a read-write property of boolean type.

opLastEvent

The last event of the order.

This is a read-only property of eOrderEvent type.

opLastEventID

The identifier of the last event of the order.

This is a read-only property of Long type.

opLastFillTime

Time of the last fill's transaction for this order.

This is a read-only property of Date type.

opLastTrailingTime

Time of the most recent move of trailing order.

This is a read-only property of Double type.

This property is valid only for trailing order.

This property is available only if order type is otLimit, otStop, or otStopLimit and oeiTrailing is set.

See CQG IC Help to read more about trailing orders.

opLimitPrice

The limit price of the order.

This is a read/write property of Double type.

This property becomes read-only after the order is placed.

This property is available if order type is one of the following: otLimit, otStopLimit.

This property is modifiable through the CQGOrderModify object.

opLocateID

Locate ID for Sell Short order. In some cases, the short sell order itself requires to identify where (from which broker/participant) the shares will be borrowed.

This is an optional read/write property of String type.

This property can be specified only if opExtendedSide is set to esSellShort.

This property is modifiable through the CQGOrderModify object.

opManual

Whether the order is placed manually.

This is a read-write property of boolean type.

This property becomes read-only after the order is placed.

This property is modifiable through the CQGOrderModify object.

opMiFIDAlgorithmID

MiFID algorithm ID of the order

This is a read-write property of String type.

This property becomes read-only after the order is placed.

This property is modifiable through the CQGOrderModify object.

opOpenCloseInstruction

The order open/close instruction.

This is a read-write property of eOpenCloseInstruction type.

opOrderCheckMark

Custom flag for user-defined purposes.

This is a read-write property of Boolean type and can be set regardless of the order's state.

opOrderID

The CQG Gateway identifier of the order.

This is a read-only property of Long type.

opOrderType

Order type.

This is a read-only property represented by eOrderType enumeration.

Depending on this property the availability of others is decided.

opOriginalOrderID

The CQG Gateway identifier of the original order.

This is a read-only property of Long type.

opParentOrderGUID

The GUID of parent order.

This is a read-only property of String type.

opParked

The property specifying the order's being parked.

This is a read/write property of Boolean type.

This property becomes read-only after the order is placed.

opPlaceTime

The time of order placing.

This is a read-only property of Date type.

opPreferredTrailingPeg

Preferred trailing peg (preferred price value for order to trail).

Mandatory property for trailing order.

This is a read/write property of eOrderTrailingPeg type.

This property becomes read-only after the order is placed.

See CQG IC Help to read more about trailing orders.

opQuantity

The quantity of the order.

This is a read/write property of Long type.

This property becomes read-only after the order is placed.

This property is modifiable through the CQGOrderModify object.

Note that if the UseOrderSide setting of CQG API Configuration is set to False, the side of the order should also be taken into account when setting this property.

opQuantityFractional

The same as opQuantity but data type. The data type is Decimal.

opRemainingQuantity

The remaining quantity of the order.

This is a read-only property of Long type.

opRemainingQuantityFractional

The same as opRemainingQuantity but data type. The data type is Decimal.

opReserved57
opSide

The side of the order.

This is a read/write property of eOrderSide type.

This property becomes read-only after the order is placed.

Note that if the UseOrderSide setting of CQG API Configuration is set to False, the side of the order should be given via opQuantity property sign.

opSpeculationType

The speculation type of the order.

This is a read/write property of eSpeculationType type.

This property becomes read-only after the order is placed.

opState

The local CQG API state of the order.

This is a read-only property of eOrderLocalState type.

opStopPrice

The stop price of the order.

This is a read/write property of Double type.

This property becomes read-only after the order is placed.

This property is available if order type is one of the following: otStop, otStopLimit.

This property is modifiable through the CQGOrderModify object.

opStrategyOrderGUID

Strategy order GUID if the order is a leg of some strategy order.

This is a read-only property of String type.

opSynthetic

The property specifying the order's being synthetic.

This is a read/write property of Boolean type.

This property becomes read-only after the order is placed.

opTimeActiveAt

The time when the order will be automatically activated.

This is a read-only property of Date type.

opTraderID The identifier of the trader who last modified the order.

This property value will change if the order was modified (for example, canceled or activated) by a trader other than the one who placed it.

This is a read-only property of Long type.

opTradingExpression | Specifies the trading expression.
opTrailingLimitPrice

Initial limit price of the trailing order.

This is a read-only property of Double type.

This property is valid only for trailing order.

This property is available only if order type is otLimit or otStopLimit and oeiTrailing is set.

See CQG IC Help to read more about trailing orders.

opTrailingOffset

The offset of the trailing order.

Mandatory property for trailing order.

This is a read/write property of Double type.

This property becomes read-only after the order is placed.

This property is available only if order type is otLimit, otStop, or otStopLimit and oeiTrailing is set.

This property is currently not modifiable.

See CQG IC Help to read more about trailing orders.

opTrailingStopPrice

Initial stop price of the trailing order.

This is a read-only property of Double type.

This property is valid only for trailing order.

This property is available only if order type is otStop or otStopLimit and oeiTrailing is set.

See CQG IC Help to read more about trailing orders.

opTriggerQuantity

Trigger quantity of QTS order.

This is a read/write property of Long type.

This property becomes read-only after the order is placed.

opTriggerQuantityFractional | The same as opTriggerQuantity but data type. The data type is Decimal.
opUEName

The user-friendly name of the order.

This is a read-only property of String type.

opUserName

The name of the CQG Gateway trader who placed the order.

This is a read-only property of String type.

opVisibleQuantity

The visible quantity of Fixed Income/Iceberg.

This is a read/write property of Long type.

This property becomes read-only after the order is placed.

This property is modifiable through the CQGOrderModify object.

opVisibleQuantityFractional | The same as opVisibleQuantity but data type. The data type is Decimal.

Return Type

The corresponding modified property, represented as CQGModifiedProperty object.

If the accessed item does not exist, see Accessing non-existent collection items to learn more about the return type.

Remarks

A collection exception will be thrown if no ModifiedProperty exists with the specified type.

See Also

CQGModifiedProperties Collection | CQGModifiedProperties Members | eOrderProperty Enumeration | CQGModifiedProperty Interface


%%PageItemTitle%%

ItemByIndex Property
index_
Zero-based index of item in the collection
CQGModifiedProperties Collection : ItemByIndex Property

Glossary Item Box

Description

Returns the modified property object by its sequential index.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemByIndex( _
   ByVal index_ As Long _
) As CQGModifiedProperty

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding modified property, represented as CQGModifiedProperty object.

If the accessed item does not exist, see Accessing non-existent collection items to learn more about the return type.

Remarks

A collection exception will be thrown if index is out of range.

See Also

CQGModifiedProperties Collection | CQGModifiedProperties Members


%%PageItemTitle%%

CQGOrderProperties Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of order (dynamic and static) properties represented as CQGOrderProperty objects.

Object Model

CQGOrderProperties CollectionCQGOrderProperty Interface

Remarks

This collection is used in CQGOrder to access the order dynamic and static properties, and in OrderChanged event as a parameter passing the changed properties.

Access to an item in this collection is made by property type.

See Accessing non-existent collection items for details on accessing items that do not exist in the collection.

Example

See the usage of CQGOrderProperties collection in OrderChanged event's example section. See examples on retrieving order trader ID, average fill, and other members of the Properties collection in the CQGOrderProperties.Item property's example section.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGOrderProperties Members


%%PageItemTitle%% $$Members$$

CQGOrderProperties Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of properties in the collection.
Public Property Item | Returns the order property by type. This is the default property.

See Also

CQGOrderProperties Collection


%%PageItemTitle%%

_NewEnum Property
CQGOrderProperties Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGOrderProperties Collection | CQGOrderProperties Members


%%PageItemTitle%%

Count Property
CQGOrderProperties Collection : Count Property

Glossary Item Box

Description

Returns the number of properties in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of properties represented as Long

Example

See the usage of CQGOrderProperties properties in OrderChanged event's example section.

See Also

CQGOrderProperties Collection | CQGOrderProperties Members


%%PageItemTitle%%

Item Property
order_property
CQGOrderProperties Collection : Item Property

Glossary Item Box

Description

Returns the order property by type.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal order_property As eOrderProperty _
) As CQGOrderProperty

Parameters

order_property
Value | Description
opAccountID

CQG Gateway identifier of the account to which this order belongs.

This is a read-only property of Long type.

opActivationTime
UTC Date/time the parked order should automatically activate.
This is read-write property of Date type.
When a property is set during order creation, it is necessary to set the opParked property to True.
The property is writable only when the opParked property value is True.
The property corresponds to until_ parameter from CQGOrder.Park method.
The property is modifiable through the CQGOrderModify object.
Set the property value to "12/30/1899 12:00:00 AM" UTC to remove the activation time through the CQGOrderModify object.
opAggressive

The property specifying the aggressiveness of the order (Fixed Income only).

This is a read/write property of Boolean type.

This property becomes read-only after the order is placed.

opAlgorithmID

Algorithm identifier of the order

This is a read-only property of Long type.

opAverageFillPrice

The average price of the order's fills.

This is a read-only property of Double type.

opCancelationInstruction

The strategy order cancelation flag that determines the cancelation type.

This is a read-write property of eOrderCancelationType type.

opCanceledTime

Time of the cancelation transaction for this order.

This is a read-only property of Date type.

opCareOrderIDs | Property which defines the comma separated set of care order identifiers based on which the execution is done
opCompoundOrderGUID

Compound order GUID. Value equals to GUID property of CQGOrderChain that was used as parameter in PlaceCompoundOrderEx.

Property is present only if order is a part (leg) of some compound order.

This is a read-only property of String type.

opCompoundOrderID

Compound order ID, unique value assigned by server.

Property is present only if order is a part (leg) of some compound order.

This is a read-only property of String type.

opCompoundOrderType

Compound order type.

Property is present only if order is a part (leg) of some compound order.

This is read-only property of ECompoundOrderType type.

opCQGID

The CQG system identifier (serial number).

This is a read-only property of String type.

opDescription

User-created custom description for the order.

Note that this description is stored on the gateway and is not lost between the sessions.

This is a read-write property of String type.

opDurationType

The duration of the order.

This is a read/write property of eOrderDuration type.

This property becomes read-only after the order is placed.

This property is available if order type is not otMarket.

opErrorFlag

The flag that indicates that the order had errors.

This is a read-only property of Boolean type.

opEventServerTimestamp

The server timestamp of the last event of the order.

This is a read-only property of Date type.

opEventTimestamp

The local timestamp of the last event of the order.

This is a read-only property of Date type.

opExchangeConf

The confirmation supplied for the order by the Exchange (Exchange order ID).

This is a read-only property of String type.

opExecSystemOrderID

The system specific order ID.

This is a read-only property of String type.

opExecutionInstructions

The property specifying the combination of execution instructions.

This is a read/write bitmask of eOrderExecutionInstruction type.

This property becomes read-only after the order is placed.

opExecutionPattern

Execution pattern of the spread order represented as string.

This is a read/write property of String type.

opExtendedSide

Specifies special order side value.

This is a read/write property of EExtendedSide type.

This property is modifiable through the CQGOrderModify object.

See EExtendedSide description for more information.

opFilledCount

The number of order fills.

This is a read-only property of Long type.

opFilledQuantity

The filled quantity of the order.

This is a read-only property of Long type.

opFilledQuantityFractional

The same as opFilledQuantity but data type. The data type is Decimal.

opGTDTime

The good-till-date value of the order.

This is a read/write property of Date type.

This property is available if order duration type is odGoodTillDate.

opGTTTime

The good-till-time value of the order.

This is a read/write property of Date type.

This property is available if order duration type is odDayGoodTillTime or odGoodTillTime.

opGUID

The GUID of the order.

This is a read-only property of String type.

opGWStatus

The CQG Gateway status of the order.

This is a read-only property of eOrderStatus type.

opInstrumentName

The full name of the Instrument on which this order is placed.

This is a read-only property of String type.

opInstrumentNameDetailed

The detailed name of the Instrument on which this order is placed.

This is a read-only property of String type.

opIsCareOrder

Property which defines if the order is Care order or not.

This is a read-write property of boolean type.

opLastEvent

The last event of the order.

This is a read-only property of eOrderEvent type.

opLastEventID

The identifier of the last event of the order.

This is a read-only property of Long type.

opLastFillTime

Time of the last fill's transaction for this order.

This is a read-only property of Date type.

opLastTrailingTime

Time of the most recent move of trailing order.

This is a read-only property of Double type.

This property is valid only for trailing order.

This property is available only if order type is otLimit, otStop, or otStopLimit and oeiTrailing is set.

See CQG IC Help to read more about trailing orders.

opLimitPrice

The limit price of the order.

This is a read/write property of Double type.

This property becomes read-only after the order is placed.

This property is available if order type is one of the following: otLimit, otStopLimit.

This property is modifiable through the CQGOrderModify object.

opLocateID

Locate ID for Sell Short order. In some cases, the short sell order itself requires to identify where (from which broker/participant) the shares will be borrowed.

This is an optional read/write property of String type.

This property can be specified only if opExtendedSide is set to esSellShort.

This property is modifiable through the CQGOrderModify object.

opManual

Whether the order is placed manually.

This is a read-write property of boolean type.

This property becomes read-only after the order is placed.

This property is modifiable through the CQGOrderModify object.

opMiFIDAlgorithmID

MiFID algorithm ID of the order

This is a read-write property of String type.

This property becomes read-only after the order is placed.

This property is modifiable through the CQGOrderModify object.

opOpenCloseInstruction

The order open/close instruction.

This is a read-write property of eOpenCloseInstruction type.

opOrderCheckMark

Custom flag for user-defined purposes.

This is a read-write property of Boolean type and can be set regardless of the order's state.

opOrderID

The CQG Gateway identifier of the order.

This is a read-only property of Long type.

opOrderType

Order type.

This is a read-only property represented by eOrderType enumeration.

Depending on this property the availability of others is decided.

opOriginalOrderID

The CQG Gateway identifier of the original order.

This is a read-only property of Long type.

opParentOrderGUID

The GUID of parent order.

This is a read-only property of String type.

opParked

The property specifying the order's being parked.

This is a read/write property of Boolean type.

This property becomes read-only after the order is placed.

opPlaceTime

The time of order placing.

This is a read-only property of Date type.

opPreferredTrailingPeg

Preferred trailing peg (preferred price value for order to trail).

Mandatory property for trailing order.

This is a read/write property of eOrderTrailingPeg type.

This property becomes read-only after the order is placed.

See CQG IC Help to read more about trailing orders.

opQuantity

The quantity of the order.

This is a read/write property of Long type.

This property becomes read-only after the order is placed.

This property is modifiable through the CQGOrderModify object.

Note that if the UseOrderSide setting of CQG API Configuration is set to False, the side of the order should also be taken into account when setting this property.

opQuantityFractional

The same as opQuantity but data type. The data type is Decimal.

opRemainingQuantity

The remaining quantity of the order.

This is a read-only property of Long type.

opRemainingQuantityFractional

The same as opRemainingQuantity but data type. The data type is Decimal.

opReserved57
opSide

The side of the order.

This is a read/write property of eOrderSide type.

This property becomes read-only after the order is placed.

Note that if the UseOrderSide setting of CQG API Configuration is set to False, the side of the order should be given via opQuantity property sign.

opSpeculationType

The speculation type of the order.

This is a read/write property of eSpeculationType type.

This property becomes read-only after the order is placed.

opState

The local CQG API state of the order.

This is a read-only property of eOrderLocalState type.

opStopPrice

The stop price of the order.

This is a read/write property of Double type.

This property becomes read-only after the order is placed.

This property is available if order type is one of the following: otStop, otStopLimit.

This property is modifiable through the CQGOrderModify object.

opStrategyOrderGUID

Strategy order GUID if the order is a leg of some strategy order.

This is a read-only property of String type.

opSynthetic

The property specifying the order's being synthetic.

This is a read/write property of Boolean type.

This property becomes read-only after the order is placed.

opTimeActiveAt

The time when the order will be automatically activated.

This is a read-only property of Date type.

opTraderID The identifier of the trader who last modified the order.

This property value will change if the order was modified (for example, canceled or activated) by a trader other than the one who placed it.

This is a read-only property of Long type.

opTradingExpression | Specifies the trading expression.
opTrailingLimitPrice

Initial limit price of the trailing order.

This is a read-only property of Double type.

This property is valid only for trailing order.

This property is available only if order type is otLimit or otStopLimit and oeiTrailing is set.

See CQG IC Help to read more about trailing orders.

opTrailingOffset

The offset of the trailing order.

Mandatory property for trailing order.

This is a read/write property of Double type.

This property becomes read-only after the order is placed.

This property is available only if order type is otLimit, otStop, or otStopLimit and oeiTrailing is set.

This property is currently not modifiable.

See CQG IC Help to read more about trailing orders.

opTrailingStopPrice

Initial stop price of the trailing order.

This is a read-only property of Double type.

This property is valid only for trailing order.

This property is available only if order type is otStop or otStopLimit and oeiTrailing is set.

See CQG IC Help to read more about trailing orders.

opTriggerQuantity

Trigger quantity of QTS order.

This is a read/write property of Long type.

This property becomes read-only after the order is placed.

opTriggerQuantityFractional | The same as opTriggerQuantity but data type. The data type is Decimal.
opUEName

The user-friendly name of the order.

This is a read-only property of String type.

opUserName

The name of the CQG Gateway trader who placed the order.

This is a read-only property of String type.

opVisibleQuantity

The visible quantity of Fixed Income/Iceberg.

This is a read/write property of Long type.

This property becomes read-only after the order is placed.

This property is modifiable through the CQGOrderModify object.

opVisibleQuantityFractional | The same as opVisibleQuantity but data type. The data type is Decimal.

Return Type

If the property exists in the collection, this property returns the selected property represented as CQGOrderProperty object.

If the accessed item does not exist, see Accessing non-existent collection items to learn more about the return type.

Example

This is an example of how to get properties from CQGOrders.Properties collection.

VB
C#
Private Sub PrintSomeOrderProperties(Order As CQGOrder)
    'The identifier of the trader who last modified the order.
    Debug.Print "TraderID : " & Order.Properties(eOrderProperty.opTraderID)
    'CQG Gateway identifier of the account to which this order belongs.
    Debug.Print "AccountID : " & Order.Properties(eOrderProperty.opAccountID)
    'The full name of the Instrument on which this order is placed.
    Debug.Print "InstrumentName : " & Order.Properties(eOrderProperty.opInstrumentName)
    'The quantity of the order.
    Debug.Print "Quantity : " & Order.Properties(eOrderProperty.opQuantity)
    'The average price of the order's fills.
    Debug.Print "AverageFillPrice : " & Order.Properties(eOrderProperty.opAverageFillPrice)
End Sub
private void PrintSomeOrderProperties(CQGOrder Order)
{
    //The identifier of the trader who last modified the order.
    Console.WriteLine("TraderID : {0}", Order.Properties[eOrderProperty.opTraderID]);

    //CQG Gateway identifier of the account to which this order belongs.
    Console.WriteLine("AccountID : ", Order.Properties[eOrderProperty.opAccountID]);

    //The full name of the Instrument on which this order is placed.
    Console.WriteLine("InstrumentName : {0}", Order.Properties[eOrderProperty.opInstrumentName]);

    //The quantity of the order.
    Console.WriteLine("Quantity : {0}", Order.Properties[eOrderProperty.opQuantity]);

    //The average price of the order's fills.
    Console.WriteLine("AverageFillPrice : {0}", Order.Properties[eOrderProperty.opAverageFillPrice]);

}

See Also

CQGOrderProperties Collection | CQGOrderProperties Members | eOrderProperty Enumeration


%%PageItemTitle%%

CQGOrders Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGOrder objects.

Object Model

CQGOrders CollectionCQGOrder Interface

Remarks

This collection is used for both orders storing and passing order queries results.

Access to an item in this collection can be made based on either Gateway order ID or order GUID.

See Accessing non-existent collection items for details on accessing items that do not exist in the collection.

Example

See the usage of CQGOrders collections in the PrepareModify method's example section.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGOrders Members


%%PageItemTitle%% $$Members$$

CQGOrders Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method AddToLiveOrders | Appends the orders in current collection (usually obtained via query) to Orders and InternalOrders collections of CQGCEL and CQGAccount objects.
Public Method SelectByInstrumentName | Returns a sub-collection of current orders collection, filtered by order instrument full name.
Public Method SelectByOrderStatus | Returns a sub-collection of current orders collection, filtered by order status.
Public Method SelectByOrderType | Returns a sub-collection of current orders collection, filtered by order type.
Public Method SelectByProperty | Returns a sub-collection of current orders collection, filtered by order property.
Public Method SelectBySide | Returns a sub-collection of current orders collection, filtered by order side.
Public Method SelectByTag | Returns a sub-collection of current orders collection, filtered by order tag (and its value if given).

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of orders in the collection.
Public Property Item | Returns the selected order from the collection by its Gateway identifier. This is the default property.
Public Property ItemByGuid | Returns the selected order from the collection by its GUID.
Public Property ItemByIndex | Gets the order by index

See Also

CQGOrders Collection


%%PageItemTitle%%

AddToLiveOrders Method
CQGOrders Collection : AddToLiveOrders Method

Glossary Item Box

Description

Appends the orders in current collection (usually obtained via query) to Orders and InternalOrders collections of CQGCEL and CQGAccount objects.

Syntax

Visual Basic
Public Sub AddToLiveOrders()

Remarks

If the order being added already exists in the destination collection its duplicate will not be created.

Example

See the usage of CQGOrders methods in the PrepareModify method's example section.

See Also

CQGOrders Collection | CQGOrders Members | CQGAccount.Orders Property | CQGAccount.InternalOrders Property | CQGCEL.Orders Property | CQGCEL.InternalOrders Property


%%PageItemTitle%%

SelectByInstrumentName Method
instrument_name

Instrument name that will be used as the selection criteria, represented as String

CQGOrders Collection : SelectByInstrumentName Method

Glossary Item Box

Description

Returns a sub-collection of current orders collection, filtered by order instrument full name.

Syntax

Visual Basic
Public Function SelectByInstrumentName( _
   ByVal instrument_name As String _
) As CQGOrders

Parameters

instrument_name

Instrument name that will be used as the selection criteria, represented as String

Return Type

A CQGOrders collection consisting of orders with the same InstrumentName that are picked from the current orders collection.

Example

See the usage of CQGOrders methods in the PrepareModify method's example section.

See Also

CQGOrders Collection | CQGOrders Members | CQGOrder.InstrumentName Property


%%PageItemTitle%%

SelectByOrderStatus Method
order_status

Order status that will be used as the selection criteria, represented as eOrderStatus

CQGOrders Collection : SelectByOrderStatus Method

Glossary Item Box

Description

Returns a sub-collection of current orders collection, filtered by order status.

Syntax

Visual Basic
Public Function SelectByOrderStatus( _
   ByVal order_status As eOrderStatus _
) As CQGOrders

Parameters

order_status
Value | Description
osActiveAt

The order will be active at the nearest session.

osBusted | Order was completely filled and then all fills were busted
osCanceled | The order is cancelled.
osContingent | The order is contingent on another order, awaiting activation.
osDisconnected | The order might be cancelled because a disconnect occurred.
osExpired

The order is expired.

It means that the order was not filled during its duration period.

osFilled | The order is filled.
osInCancel | The order is in cancellation stage.
osInClient | The order either is in CQGIC or is flying to the CQG Gateway.
osInModify | The order is in modification stage.
osInOrderBook | The order is working.
osInTransit

Order is in transit.

It means that the order has already reached the CQG Gateway, and now it is on its way to the exchange.

osInTransitTimeout | The order was timed out, while waiting for notification from the CQG Gateway.
osNotSent | The order did not leave the CQG API side, yet.
osParked | The order is parked.
osRejectFCM | The order is rejected by FCM.
osRejectGW | The order is rejected by CQG Gateway.

Order status that will be used as the selection criteria, represented as eOrderStatus

Return Type

A CQGOrders collection consisting of orders with the same GWStatus, which are picked from the current orders collection.

Example

See the usage of CQGOrders methods in the PrepareModify method's example section.

See Also

CQGOrders Collection | CQGOrders Members | eOrderStatus Enumeration


%%PageItemTitle%%

SelectByOrderType Method
order_type

Order type that will be used as the selection criteria, represented as eOrderType

CQGOrders Collection : SelectByOrderType Method

Glossary Item Box

Description

Returns a sub-collection of current orders collection, filtered by order type.

Syntax

Visual Basic
Public Function SelectByOrderType( _
   ByVal order_type As eOrderType _
) As CQGOrders

Parameters

order_type
Value Description
otLimit

Limit order.

otMarket

Market order.

otStop

Stop order.

otStopLimit

Stop Limit order.

otUndefined

Undefined order type.

Order type that will be used as the selection criteria, represented as eOrderType

Return Type

A CQGOrders collection consisting of orders with the same Type which are picked from the current orders collection.

Example

See the usage of CQGOrders methods in the PrepareModify method's example section.

See Also

CQGOrders Collection | CQGOrders Members | eOrderType Enumeration


%%PageItemTitle%%

SelectByProperty Method
property_type

Order property that will be used as the selection criteria, represented as eOrderProperty

property_value

Value of the property type that will be used as the selection criteria, represented as Variant

CQGOrders Collection : SelectByProperty Method

Glossary Item Box

Description

Returns a sub-collection of current orders collection, filtered by order property.

Syntax

Visual Basic
Public Function SelectByProperty( _
   ByVal property_type As eOrderProperty, _
   ByVal property_value As Variant _
) As CQGOrders

Parameters

property_type
Value | Description
opAccountID

CQG Gateway identifier of the account to which this order belongs.

This is a read-only property of Long type.

opActivationTime
UTC Date/time the parked order should automatically activate.
This is read-write property of Date type.
When a property is set during order creation, it is necessary to set the opParked property to True.
The property is writable only when the opParked property value is True.
The property corresponds to until_ parameter from CQGOrder.Park method.
The property is modifiable through the CQGOrderModify object.
Set the property value to "12/30/1899 12:00:00 AM" UTC to remove the activation time through the CQGOrderModify object.
opAggressive

The property specifying the aggressiveness of the order (Fixed Income only).

This is a read/write property of Boolean type.

This property becomes read-only after the order is placed.

opAlgorithmID

Algorithm identifier of the order

This is a read-only property of Long type.

opAverageFillPrice

The average price of the order's fills.

This is a read-only property of Double type.

opCancelationInstruction

The strategy order cancelation flag that determines the cancelation type.

This is a read-write property of eOrderCancelationType type.

opCanceledTime

Time of the cancelation transaction for this order.

This is a read-only property of Date type.

opCareOrderIDs | Property which defines the comma separated set of care order identifiers based on which the execution is done
opCompoundOrderGUID

Compound order GUID. Value equals to GUID property of CQGOrderChain that was used as parameter in PlaceCompoundOrderEx.

Property is present only if order is a part (leg) of some compound order.

This is a read-only property of String type.

opCompoundOrderID

Compound order ID, unique value assigned by server.

Property is present only if order is a part (leg) of some compound order.

This is a read-only property of String type.

opCompoundOrderType

Compound order type.

Property is present only if order is a part (leg) of some compound order.

This is read-only property of ECompoundOrderType type.

opCQGID

The CQG system identifier (serial number).

This is a read-only property of String type.

opDescription

User-created custom description for the order.

Note that this description is stored on the gateway and is not lost between the sessions.

This is a read-write property of String type.

opDurationType

The duration of the order.

This is a read/write property of eOrderDuration type.

This property becomes read-only after the order is placed.

This property is available if order type is not otMarket.

opErrorFlag

The flag that indicates that the order had errors.

This is a read-only property of Boolean type.

opEventServerTimestamp

The server timestamp of the last event of the order.

This is a read-only property of Date type.

opEventTimestamp

The local timestamp of the last event of the order.

This is a read-only property of Date type.

opExchangeConf

The confirmation supplied for the order by the Exchange (Exchange order ID).

This is a read-only property of String type.

opExecSystemOrderID

The system specific order ID.

This is a read-only property of String type.

opExecutionInstructions

The property specifying the combination of execution instructions.

This is a read/write bitmask of eOrderExecutionInstruction type.

This property becomes read-only after the order is placed.

opExecutionPattern

Execution pattern of the spread order represented as string.

This is a read/write property of String type.

opExtendedSide

Specifies special order side value.

This is a read/write property of EExtendedSide type.

This property is modifiable through the CQGOrderModify object.

See EExtendedSide description for more information.

opFilledCount

The number of order fills.

This is a read-only property of Long type.

opFilledQuantity

The filled quantity of the order.

This is a read-only property of Long type.

opFilledQuantityFractional

The same as opFilledQuantity but data type. The data type is Decimal.

opGTDTime

The good-till-date value of the order.

This is a read/write property of Date type.

This property is available if order duration type is odGoodTillDate.

opGTTTime

The good-till-time value of the order.

This is a read/write property of Date type.

This property is available if order duration type is odDayGoodTillTime or odGoodTillTime.

opGUID

The GUID of the order.

This is a read-only property of String type.

opGWStatus

The CQG Gateway status of the order.

This is a read-only property of eOrderStatus type.

opInstrumentName

The full name of the Instrument on which this order is placed.

This is a read-only property of String type.

opInstrumentNameDetailed

The detailed name of the Instrument on which this order is placed.

This is a read-only property of String type.

opIsCareOrder

Property which defines if the order is Care order or not.

This is a read-write property of boolean type.

opLastEvent

The last event of the order.

This is a read-only property of eOrderEvent type.

opLastEventID

The identifier of the last event of the order.

This is a read-only property of Long type.

opLastFillTime

Time of the last fill's transaction for this order.

This is a read-only property of Date type.

opLastTrailingTime

Time of the most recent move of trailing order.

This is a read-only property of Double type.

This property is valid only for trailing order.

This property is available only if order type is otLimit, otStop, or otStopLimit and oeiTrailing is set.

See CQG IC Help to read more about trailing orders.

opLimitPrice

The limit price of the order.

This is a read/write property of Double type.

This property becomes read-only after the order is placed.

This property is available if order type is one of the following: otLimit, otStopLimit.

This property is modifiable through the CQGOrderModify object.

opLocateID

Locate ID for Sell Short order. In some cases, the short sell order itself requires to identify where (from which broker/participant) the shares will be borrowed.

This is an optional read/write property of String type.

This property can be specified only if opExtendedSide is set to esSellShort.

This property is modifiable through the CQGOrderModify object.

opManual

Whether the order is placed manually.

This is a read-write property of boolean type.

This property becomes read-only after the order is placed.

This property is modifiable through the CQGOrderModify object.

opMiFIDAlgorithmID

MiFID algorithm ID of the order

This is a read-write property of String type.

This property becomes read-only after the order is placed.

This property is modifiable through the CQGOrderModify object.

opOpenCloseInstruction

The order open/close instruction.

This is a read-write property of eOpenCloseInstruction type.

opOrderCheckMark

Custom flag for user-defined purposes.

This is a read-write property of Boolean type and can be set regardless of the order's state.

opOrderID

The CQG Gateway identifier of the order.

This is a read-only property of Long type.

opOrderType

Order type.

This is a read-only property represented by eOrderType enumeration.

Depending on this property the availability of others is decided.

opOriginalOrderID

The CQG Gateway identifier of the original order.

This is a read-only property of Long type.

opParentOrderGUID

The GUID of parent order.

This is a read-only property of String type.

opParked

The property specifying the order's being parked.

This is a read/write property of Boolean type.

This property becomes read-only after the order is placed.

opPlaceTime

The time of order placing.

This is a read-only property of Date type.

opPreferredTrailingPeg

Preferred trailing peg (preferred price value for order to trail).

Mandatory property for trailing order.

This is a read/write property of eOrderTrailingPeg type.

This property becomes read-only after the order is placed.

See CQG IC Help to read more about trailing orders.

opQuantity

The quantity of the order.

This is a read/write property of Long type.

This property becomes read-only after the order is placed.

This property is modifiable through the CQGOrderModify object.

Note that if the UseOrderSide setting of CQG API Configuration is set to False, the side of the order should also be taken into account when setting this property.

opQuantityFractional

The same as opQuantity but data type. The data type is Decimal.

opRemainingQuantity

The remaining quantity of the order.

This is a read-only property of Long type.

opRemainingQuantityFractional

The same as opRemainingQuantity but data type. The data type is Decimal.

opReserved57
opSide

The side of the order.

This is a read/write property of eOrderSide type.

This property becomes read-only after the order is placed.

Note that if the UseOrderSide setting of CQG API Configuration is set to False, the side of the order should be given via opQuantity property sign.

opSpeculationType

The speculation type of the order.

This is a read/write property of eSpeculationType type.

This property becomes read-only after the order is placed.

opState

The local CQG API state of the order.

This is a read-only property of eOrderLocalState type.

opStopPrice

The stop price of the order.

This is a read/write property of Double type.

This property becomes read-only after the order is placed.

This property is available if order type is one of the following: otStop, otStopLimit.

This property is modifiable through the CQGOrderModify object.

opStrategyOrderGUID

Strategy order GUID if the order is a leg of some strategy order.

This is a read-only property of String type.

opSynthetic

The property specifying the order's being synthetic.

This is a read/write property of Boolean type.

This property becomes read-only after the order is placed.

opTimeActiveAt

The time when the order will be automatically activated.

This is a read-only property of Date type.

opTraderID The identifier of the trader who last modified the order.

This property value will change if the order was modified (for example, canceled or activated) by a trader other than the one who placed it.

This is a read-only property of Long type.

opTradingExpression | Specifies the trading expression.
opTrailingLimitPrice

Initial limit price of the trailing order.

This is a read-only property of Double type.

This property is valid only for trailing order.

This property is available only if order type is otLimit or otStopLimit and oeiTrailing is set.

See CQG IC Help to read more about trailing orders.

opTrailingOffset

The offset of the trailing order.

Mandatory property for trailing order.

This is a read/write property of Double type.

This property becomes read-only after the order is placed.

This property is available only if order type is otLimit, otStop, or otStopLimit and oeiTrailing is set.

This property is currently not modifiable.

See CQG IC Help to read more about trailing orders.

opTrailingStopPrice

Initial stop price of the trailing order.

This is a read-only property of Double type.

This property is valid only for trailing order.

This property is available only if order type is otStop or otStopLimit and oeiTrailing is set.

See CQG IC Help to read more about trailing orders.

opTriggerQuantity

Trigger quantity of QTS order.

This is a read/write property of Long type.

This property becomes read-only after the order is placed.

opTriggerQuantityFractional | The same as opTriggerQuantity but data type. The data type is Decimal.
opUEName

The user-friendly name of the order.

This is a read-only property of String type.

opUserName

The name of the CQG Gateway trader who placed the order.

This is a read-only property of String type.

opVisibleQuantity

The visible quantity of Fixed Income/Iceberg.

This is a read/write property of Long type.

This property becomes read-only after the order is placed.

This property is modifiable through the CQGOrderModify object.

opVisibleQuantityFractional | The same as opVisibleQuantity but data type. The data type is Decimal.

Order property that will be used as the selection criteria, represented as eOrderProperty

property_value

Value of the property type that will be used as the selection criteria, represented as Variant

Return Type

A CQGOrders collection consisting of orders with the same eOrderProperty value that are picked from the current orders collection.

Example

See the usage of CQGOrders methods in the PrepareModify method's example section.

See Also

CQGOrders Collection | CQGOrders Members | eOrderProperty Enumeration


%%PageItemTitle%%

SelectBySide Method
order_side

Order side that will be used as the selection criteria, represented as eOrderSide

CQGOrders Collection : SelectBySide Method

Glossary Item Box

Description

Returns a sub-collection of current orders collection, filtered by order side.

Syntax

Visual Basic
Public Function SelectBySide( _
   ByVal order_side As eOrderSide _
) As CQGOrders

Parameters

order_side
Value | Description
osdBuy Side properties return this value if CQGAPIConfig.UseOrderSide is set to True.

Depending on the owner, osdBuy value is returned in case of:

  • the object is a CQGTrade referring to a buy trade
  • the object is a CQGPosition referring to a long position.

  • the object is a CQGOrder referring to an order of buy type.
  • the object is a CQGFill referring to a fill of buy type.
osdSell Side properties return this value if CQGAPIConfig.UseOrderSide is set to True.

Depending on the owner, osdSell value is returned in case of:

  • the object is a CQGTrade referring to a sell trade
  • the object is a CQGPosition referring to a short position.

  • the object is a CQGOrder referring to an order of sell type.
  • the object is a CQGFill referring to a fill of sell type.
osdUndefined | Side properties return this value if CQGAPIConfig.UseOrderSide is set to False.

Order side that will be used as the selection criteria, represented as eOrderSide

Return Type

A CQGOrders collection consisting of orders with the same Side that are picked from the current orders collection.

Example

See the usage of CQGOrders methods in the PrepareModify method's example section.

See Also

CQGOrders Collection | CQGOrders Members | eOrderSide Enumeration


%%PageItemTitle%%

SelectByTag Method
tag_name

Order's tag name that will be used as the selection criteria, represented as String

tag_value

Value of the tag that will be used as the selection criteria, represented as Variant.

This parameter is optional.

CQGOrders Collection : SelectByTag Method

Glossary Item Box

Description

Returns a sub-collection of current orders collection, filtered by order tag (and its value if given).

Syntax

Visual Basic
Public Function SelectByTag( _
   ByVal tag_name As String, _
   Optional ByVal tag_value As Variant = "" _
) As CQGOrders

Parameters

tag_name

Order's tag name that will be used as the selection criteria, represented as String

tag_value

Value of the tag that will be used as the selection criteria, represented as Variant.

This parameter is optional.

Return Type

A CQGOrders collection consisting of orders with the same Tag that are picked from the current orders collection.

Example

See the usage of CQGOrders methods in the PrepareModify method's example section.

See Also

CQGOrders Collection | CQGOrders Members | CQGOrder.Tag Property


%%PageItemTitle%%

_NewEnum Property
CQGOrders Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGOrders Collection | CQGOrders Members


%%PageItemTitle%%

Count Property
CQGOrders Collection : Count Property

Glossary Item Box

Description

Returns the number of orders in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of orders, represented as Long

Example

See the usage of CQGOrders properties in the PrepareModify method's example section.

See Also

CQGOrders Collection | CQGOrders Members


%%PageItemTitle%%

Item Property
order_id
CQGOrders Collection : Item Property

Glossary Item Box

Description

Returns the selected order from the collection by its Gateway identifier.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal order_id As String _
) As CQGOrder

Parameters

order_id

Return Type

If the order exists in the collection, this property returns the selected order represented as CQGOrder object.

If the accessed item does not exist, see Accessing non-existent collection items to learn more about the return type.

Example

See the usage of CQGOrders properties in the PrepareModify method's example section.

See Also

CQGOrders Collection | CQGOrders Members | CQGOrder.GWOrderID Property


%%PageItemTitle%%

ItemByGuid Property
order_guid
CQGOrders Collection : ItemByGuid Property

Glossary Item Box

Description

Returns the selected order from the collection by its GUID.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemByGuid( _
   ByVal order_guid As String _
) As CQGOrder

Parameters

order_guid

Return Type

If the order exists in the collection, this property returns the selected order represented as CQGOrder object.

If the accessed item does not exist, see Accessing non-existent collection items to learn more about the return type.

Example

See the usage of CQGOrders properties in the PrepareModify method's example section.

See Also

CQGOrders Collection | CQGOrders Members | CQGOrder.GUID Property


%%PageItemTitle%%

ItemByIndex Property
index_
Zero-based index of item in the collection
CQGOrders Collection : ItemByIndex Property

Glossary Item Box

Description

Gets the order by index

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemByIndex( _
   ByVal index_ As Long _
) As CQGOrder

Parameters

index_
Zero-based index of item in the collection

See Also

CQGOrders Collection | CQGOrders Members


%%PageItemTitle%%

CQGOrdersRequest Object
See Also Members Send Feedback

Glossary Item Box

Description

Represents parameters for orders request

Object Model

CQGOrdersRequest ObjectCQGAccount InterfaceCQGInstrument Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGOrdersRequest Members


%%PageItemTitle%% $$Members$$

CQGOrdersRequest Object Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Account | CQGAccount object representing the account historical orders of which should be retrieved.
Public Property Date | Specifying the day of the requested orders. This parameter is optional.
Public Property Instrument | CQGInstrument object representing the instrument historical orders of which should be retrieved. This parameter is optional.
Public Property Side | Identifies the side of the historical orders to be retrieved. The parameter is optional.
Public Property StatusFilter | Order status filter allowing to select the historical orders by their statuses. This parameter is optional.

See Also

CQGOrdersRequest Object


%%PageItemTitle%%

Account Property
CQGOrdersRequest Object : Account Property

Glossary Item Box

Description

CQGAccount object representing the account historical orders of which should be retrieved.

Property type

Read-write property

Syntax

Visual Basic
Public Property Account As CQGAccount

See Also

CQGOrdersRequest Object | CQGOrdersRequest Members


%%PageItemTitle%%

Date Property
CQGOrdersRequest Object : Date Property

Glossary Item Box

Description

Specifying the day of the requested orders. This parameter is optional.

Property type

Read-write property

Syntax

Visual Basic
Public Property Date As Date

See Also

CQGOrdersRequest Object | CQGOrdersRequest Members


%%PageItemTitle%%

Instrument Property
CQGOrdersRequest Object : Instrument Property

Glossary Item Box

Description

CQGInstrument object representing the instrument historical orders of which should be retrieved. This parameter is optional.

Property type

Read-write property

Syntax

Visual Basic
Public Property Instrument As CQGInstrument

See Also

CQGOrdersRequest Object | CQGOrdersRequest Members


%%PageItemTitle%%

Side Property
CQGOrdersRequest Object : Side Property

Glossary Item Box

Description

Identifies the side of the historical orders to be retrieved. The parameter is optional.

Property type

Read-write property

Syntax

Visual Basic
Public Property Side As eOrderSide

See Also

CQGOrdersRequest Object | CQGOrdersRequest Members


%%PageItemTitle%%

StatusFilter Property
CQGOrdersRequest Object : StatusFilter Property

Glossary Item Box

Description

Order status filter allowing to select the historical orders by their statuses. This parameter is optional.

Property type

Read-write property

Syntax

Visual Basic
Public Property StatusFilter As eOrderStatusFilter

See Also

CQGOrdersRequest Object | CQGOrdersRequest Members


%%PageItemTitle%%

CQGParameterDefinitions Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGParameterDefinition objects.

Object Model

CQGParameterDefinitions CollectionCQGParameterDefinition Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGParameterDefinitions Members | CQGParameterDefinition


%%PageItemTitle%% $$Members$$

CQGParameterDefinitions Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGParameterDefinition objects in the collection.
Public Property Item | Returns the CQGParameterDefinition by its index. This is the default property.
Public Property ItemByName | Returns the CQGParameterDefinition object by its name.

See Also

CQGParameterDefinitions Collection | CQGParameterDefinition


%%PageItemTitle%%

_NewEnum Property
CQGParameterDefinitions Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGParameterDefinitions Collection | CQGParameterDefinitions Members


%%PageItemTitle%%

Count Property
CQGParameterDefinitions Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGParameterDefinition objects in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of collection items, represented as Long

See Also

CQGParameterDefinitions Collection | CQGParameterDefinitions Members | CQGParameterDefinition Interface


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGParameterDefinitions Collection : Item Property

Glossary Item Box

Description

Returns the CQGParameterDefinition by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGParameterDefinition

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item represented as CQGParameterDefinition object

See Also

CQGParameterDefinitions Collection | CQGParameterDefinitions Members | CQGParameterDefinition Interface


%%PageItemTitle%%

ItemByName Property
parameter_name
CQGParameterDefinitions Collection : ItemByName Property

Glossary Item Box

Description

Returns the CQGParameterDefinition object by its name.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemByName( _
   ByVal parameter_name As String _
) As CQGParameterDefinition

Parameters

parameter_name

Return Type

The corresponding collection item, represented as CQGParameterDefinition object

Remarks

A collection exception will be thrown in case of non-existent parameter name.

See Also

CQGParameterDefinitions Collection | CQGParameterDefinitions Members


%%PageItemTitle%%

CQGPointAndFigureBars Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGPointAndFigureBar objects.

Object Model

CQGPointAndFigureBars CollectionCQGPointAndFigureBar Interface

Remarks

Is returned by the CQGCEL.RequestPointAndFigureBars method call.

The CQGCEL.PointAndFigureBarsResolved, CQGCEL.PointAndFigureBarsAdded and CQGCEL.PointAndFigureBarsUpdated events can be fired for CQGPointAndFigureBars.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGPointAndFigureBars Members | CQGPointAndFigureBar


%%PageItemTitle%% $$Members$$

CQGPointAndFigureBars Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of all records in the collection.
Public Property EndTimestamp | Returns the ending (maximum) timestamp of all arrived point and figure bar results so far, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
Public Property Id | Returns the unique identifier of the point and figure bars.
Public Property Item | Returns the CQGPointAndFigureBar by its index. This is the default property.
Public Property LastError | Returns CQGError object describing the last error occurred to this object.
Public Property Request | Returns a read-only copy of the CQGPointAndFigureBarsRequest object that was passed to the corresponding CQGCEL.RequestPointAndFigures method call.
Public Property StartTimestamp | Returns the starting (minimum) timestamp of all arrived point and figure bar results, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
Public Property Status | Returns the status of the point and figure bar request.
Public Property Tag | This property allows the user to keep his/her own information within the point and figure bars.

See Also

CQGPointAndFigureBars Collection | CQGPointAndFigureBar


%%PageItemTitle%%

_NewEnum Property
CQGPointAndFigureBars Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGPointAndFigureBars Collection | CQGPointAndFigureBars Members


%%PageItemTitle%%

Count Property
CQGPointAndFigureBars Collection : Count Property

Glossary Item Box

Description

Returns the number of all records in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of point and figure bars, represented as Long

See Also

CQGPointAndFigureBars Collection | CQGPointAndFigureBars Members


%%PageItemTitle%%

EndTimestamp Property
CQGPointAndFigureBars Collection : EndTimestamp Property

Glossary Item Box

Description

Returns the ending (maximum) timestamp of all arrived point and figure bar results so far, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

Property type

Read-only property

Syntax

Visual Basic
Public Property EndTimestamp As Date

Return Type

The timestamp of the last-arrived point and figure bar result, represented as Date

See Also

CQGPointAndFigureBars Collection | CQGPointAndFigureBars Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

Id Property
CQGPointAndFigureBars Collection : Id Property

Glossary Item Box

Description

Returns the unique identifier of the point and figure bars.

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

Return Type

Unique identifier, represented as String

See Also

CQGPointAndFigureBars Collection | CQGPointAndFigureBars Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGPointAndFigureBars Collection : Item Property

Glossary Item Box

Description

Returns the CQGPointAndFigureBar by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGPointAndFigureBar

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item, represented as CQGPointAndFigureBar object

Remarks

A CQGPointAndFigureBar object will be created upon request and passed to the user without storing it.

Two sequential requests for the same record may return different objects.

See Also

CQGPointAndFigureBars Collection | CQGPointAndFigureBars Members | CQGPointAndFigureBar Interface


%%PageItemTitle%%

LastError Property
CQGPointAndFigureBars Collection : LastError Property

Glossary Item Box

Description

Returns CQGError object describing the last error occurred to this object.

Property type

Read-only property

Syntax

Visual Basic
Public Property LastError As CQGError

Return Type

The last error, represented as CQGError object

See Also

CQGPointAndFigureBars Collection | CQGPointAndFigureBars Members | CQGError Interface


%%PageItemTitle%%

Request Property
CQGPointAndFigureBars Collection : Request Property

Glossary Item Box

Description

Returns a read-only copy of the CQGPointAndFigureBarsRequest object that was passed to the corresponding CQGCEL.RequestPointAndFigures method call.

Property type

Read-only property

Syntax

Visual Basic
Public Property Request As CQGPointAndFigureBarsRequest

Return Type

The corresponding read-only copy of CQGPointAndFigureBarsRequest

See Also

CQGPointAndFigureBars Collection | CQGPointAndFigureBars Members | CQGPointAndFigureBarsRequest Interface | CQGCEL.RequestPointAndFigures Method


%%PageItemTitle%%

StartTimestamp Property
CQGPointAndFigureBars Collection : StartTimestamp Property

Glossary Item Box

Description

Returns the starting (minimum) timestamp of all arrived point and figure bar results, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

Property type

Read-only property

Syntax

Visual Basic
Public Property StartTimestamp As Date

Return Type

The timestamp of the first-arrived point and figure bar result, represented as Date

See Also

CQGPointAndFigureBars Collection | CQGPointAndFigureBars Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

Status Property
CQGPointAndFigureBars Collection : Status Property

Glossary Item Box

Description

Returns the status of the point and figure bar request.

Property type

Read-only property

Syntax

Visual Basic
Public Property Status As eRequestStatus

Return Type

Request status, represented as eRequestStatus

Remarks

See eRequestStatus for possible values.

See Also

CQGPointAndFigureBars Collection | CQGPointAndFigureBars Members | eRequestStatus Enumeration


%%PageItemTitle%%

Tag Property
tag_name

The user-defined value's name.

When setting, the tag_name parameter should keep the key that will be associated with the passed information.

When getting the information from the Tag, one of the previously set keys should be passed as tag_name in order to get the corresponding information.

CQGPointAndFigureBars Collection : Tag Property

Glossary Item Box

Description

This property allows the user to keep his/her own information within the point and figure bars.

Property type

Read-write property

Syntax

Visual Basic
Public Property Tag( _
   ByVal tag_name As String _
) As Variant

Parameters

tag_name

The user-defined value's name.

When setting, the tag_name parameter should keep the key that will be associated with the passed information.

When getting the information from the Tag, one of the previously set keys should be passed as tag_name in order to get the corresponding information.

Return Type

The user-defined value, represented as Variant

Remarks

Multiple data can be kept in the Tag property under different keys.

If no user-defined value with this tag_name exists, Empty is returned.

If empty is set to an existing tag_name, it is deleted/unregistered.

If a new value is set to an existing tag_name, the old value is overwritten.

See Also

CQGPointAndFigureBars Collection | CQGPointAndFigureBars Members


%%PageItemTitle%%

CQGPointAndFigureBarsCollection Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGPointAndFigureBars objects.

Object Model

CQGPointAndFigureBarsCollection CollectionCQGPointAndFigureBars Collection

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGPointAndFigureBarsCollection Members | CQGPointAndFigureBars Collection


%%PageItemTitle%% $$Members$$

CQGPointAndFigureBarsCollection Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGPointAndFigureBars objects in the collection.
Public Property Item | Returns the CQGPointAndFigureBars by its index. This is the default property.
Public Property ItemById | Returns the CQGPointAndFigureBars by its unique identifier.

See Also

CQGPointAndFigureBarsCollection Collection | CQGPointAndFigureBars Collection


%%PageItemTitle%%

_NewEnum Property
CQGPointAndFigureBarsCollection Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGPointAndFigureBarsCollection Collection | CQGPointAndFigureBarsCollection Members


%%PageItemTitle%%

Count Property
CQGPointAndFigureBarsCollection Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGPointAndFigureBars objects in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of collection items, represented as Long

See Also

CQGPointAndFigureBarsCollection Collection | CQGPointAndFigureBarsCollection Members | CQGPointAndFigureBars Collection


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGPointAndFigureBarsCollection Collection : Item Property

Glossary Item Box

Description

Returns the CQGPointAndFigureBars by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGPointAndFigureBars

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item represented as CQGPointAndFigureBars object

See Also

CQGPointAndFigureBarsCollection Collection | CQGPointAndFigureBarsCollection Members | CQGPointAndFigureBars Collection


%%PageItemTitle%%

ItemById Property
id_
CQGPointAndFigureBarsCollection Collection : ItemById Property

Glossary Item Box

Description

Returns the CQGPointAndFigureBars by its unique identifier.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemById( _
   ByVal id_ As String _
) As CQGPointAndFigureBars

Parameters

id_

Return Type

The corresponding CQGPointAndFigureBars object

Remarks

A collection exception will be thrown if no CQGPointAndFigureBars exists with the specified unique identifier.

See Also

CQGPointAndFigureBarsCollection Collection | CQGPointAndFigureBarsCollection Members | CQGPointAndFigureBars Collection


%%PageItemTitle%%

CQGPositions Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGPosition objects.

Object Model

CQGPositions CollectionCQGPosition Interface

Remarks

In this collection CQGPosition objects are gathered, each representing the account's position that was open during the current trading session. Even if a position is currently liquidated, its object remains in the collection until the end of current trading day.

Access to an item in this collection can be made based on the instrument full name.

See Accessing non-existent collection items for details on accessing items that do not exist in the collection.

Example

See the usage of CQGPositions collections in the AccountChanged event's example section.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGPositions Members


%%PageItemTitle%% $$Members$$

CQGPositions Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method FiterByInstrumentName Returns the CQGPositions by intrument name

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of positions in the collection.
Public Property Item | Returns the selected position by its instrument full name. This is the default property.
Public Property ItemByIndex | Returns the position by its index.

See Also

CQGPositions Collection


%%PageItemTitle%%

FiterByInstrumentName Method
instrument_name
CQGPositions Collection : FiterByInstrumentName Method

Glossary Item Box

Description

Returns the CQGPositions by intrument name

Syntax

Visual Basic
Public Function FiterByInstrumentName( _
   ByVal instrument_name As String _
) As CQGPositions

Parameters

instrument_name

See Also

CQGPositions Collection | CQGPositions Members


%%PageItemTitle%%

_NewEnum Property
CQGPositions Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGPositions Collection | CQGPositions Members


%%PageItemTitle%%

Count Property
CQGPositions Collection : Count Property

Glossary Item Box

Description

Returns the number of positions in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of positions represented as Long

Example

See the usage of CQGPositions properties in the AccountChanged event's example section.

See Also

CQGPositions Collection | CQGPositions Members


%%PageItemTitle%%

Item Property
instrument_name
CQGPositions Collection : Item Property

Glossary Item Box

Description

Returns the selected position by its instrument full name.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal instrument_name As String _
) As CQGPosition

Parameters

instrument_name

Return Type

If the position exists in the collection, this property returns the selected position represented as CQGPosition object.

If the accessed item does not exist, see Accessing non-existent collection items to learn more about the return type.

Example

See the usage of CQGPositions properties in the AccountChanged event's example section.

See Also

CQGPositions Collection | CQGPositions Members


%%PageItemTitle%%

ItemByIndex Property
index_
Zero-based index of item in the collection
CQGPositions Collection : ItemByIndex Property

Glossary Item Box

Description

Returns the position by its index.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemByIndex( _
   ByVal index_ As Long _
) As CQGPosition

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding position in the collection, represented as CQGPosition object.

If the accessed item does not exist, see Accessing non-existent collection items to learn more about the return type.

See Also

CQGPositions Collection | CQGPositions Members


%%PageItemTitle%%

CQGQFormulaDefinitions Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGQFormulaDefinition objects.

Object Model

CQGQFormulaDefinitions CollectionCQGQFormulaDefinition Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGQFormulaDefinitions Members | CQGQFormulaDefinition Interface


%%PageItemTitle%% $$Members$$

CQGQFormulaDefinitions Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGQFormulaDefinition objects in the collection.
Public Property Item | Returns the CQGQFormulaDefinition object by its index. This is the default property.
Public Property ItemByName | Returns the CQGQFormulaDefinition by its name.

See Also

CQGQFormulaDefinitions Collection | CQGQFormulaDefinition Interface


%%PageItemTitle%%

_NewEnum Property
CQGQFormulaDefinitions Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGQFormulaDefinitions Collection | CQGQFormulaDefinitions Members


%%PageItemTitle%%

Count Property
CQGQFormulaDefinitions Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGQFormulaDefinition objects in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of collection items, represented as Long

See Also

CQGQFormulaDefinitions Collection | CQGQFormulaDefinitions Members | CQGQFormulaDefinition Interface


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGQFormulaDefinitions Collection : Item Property

Glossary Item Box

Description

Returns the CQGQFormulaDefinition object by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGQFormulaDefinition

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item, represented as CQGFormulaDefinition object

See Also

CQGQFormulaDefinitions Collection | CQGQFormulaDefinitions Members | CQGQFormulaDefinition Interface


%%PageItemTitle%%

ItemByName Property
qformula_name
CQGQFormulaDefinitions Collection : ItemByName Property

Glossary Item Box

Description

Returns the CQGQFormulaDefinition by its name.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemByName( _
   ByVal qformula_name As String _
) As CQGQFormulaDefinition

Parameters

qformula_name

Return Type

The corresponding collection item, represented as CQGQFormulaDefinition object

Remarks

A collection exception will be thrown in case of non-existent QFormula name.

See Also

CQGQFormulaDefinitions Collection | CQGQFormulaDefinitions Members | CQGQFormulaDefinition Interface


%%PageItemTitle%%

CQGQuotes Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGQuote objects.

Object Model

CQGQuotes CollectionCQGQuote Interface

Remarks

This collection is used in CQGInstrument Object to access the instrument quotes and in InstrumentChanged Event as a parameter to pass the changed quotes.

Access to an item in this collection is made by quote type.

See Accessing non-existent collection items for details on accessing items that do not exist in the collection.

Example

See an example of InstrumentChanged Event.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGQuotes Members


%%PageItemTitle%% $$Members$$

CQGQuotes Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Gets the number of quotes in this collection.
Public Property Item | Returns the instrument quote of the specified type.

See Also

CQGQuotes Collection


%%PageItemTitle%%

_NewEnum Property
CQGQuotes Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGQuotes Collection | CQGQuotes Members


%%PageItemTitle%%

Count Property
CQGQuotes Collection : Count Property

Glossary Item Box

Description

Gets the number of quotes in this collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of quotes represented as Long.

Example

See the example of InstrumentChanged Event.

See Also

CQGQuotes Collection | CQGQuotes Members


%%PageItemTitle%%

Item Property
quote_type
CQGQuotes Collection : Item Property

Glossary Item Box

Description

Returns the instrument quote of the specified type.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal quote_type As eQuoteType _
) As CQGQuote

Parameters

quote_type
Value Description
qtAsk

Best ask.

(Combined)

qtBid

Best bid.

(Combined)

qtCohUndAsk

Coherent underlying price for the best ask.

qtCohUndBid

Coherent underlying price for the best bid.

qtDayHigh

Current day high price.

qtDayLow

Current day low price.

qtDayOpen

Day open price.

qtImpliedAsk

Implied best ask.

qtImpliedBid

Implied best bid.

qtIndicativeOpen

Indicative open.

qtMarker

Marker price, date time.

qtOutrightAsk

Outright best ask.

qtOutrightBid

Outright best bid.

qtSettlement

Settlement price.

qtTodayMarker

Marker price, date time.

qtTrade

Last trade price.

qtYesterdaySettlement

Yesterday's settlement price.

Return Type

Selected instrument quote, represented as CQGQuote Object.

If the accessed item does not exist, see Accessing non-existent collection items to learn more about the return type.

Example

See the example of InstrumentChanged Event.

See Also

CQGQuotes Collection | CQGQuotes Members | CQGQuote Interface | eQuoteType Enumeration


%%PageItemTitle%%

CQGRangeBars Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGRangeBar

Object Model

CQGRangeBars CollectionCQGRangeBar Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGRangeBars Members


%%PageItemTitle%% $$Members$$

CQGRangeBars Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the quantity of CQGRangeBar in the collection
Public Property EndTimestamp | Returns the ending (maximum) timestamp of all arrived renko bars so far
Public Property Id | Returns the unique identifier of renko bars
Public Property Item | Returns CQGRangeBar by index
Public Property LastError | Returns CQGError object describing the last error occurred to this object
Public Property Request | Returns the read-only copy of CQGRangeBarsRequest object
Public Property StartTimestamp | Returns the starting (minimum) timestamp of all arrived renko bars
Public Property Status | Returns the status
Public Property Tag | Returns a user defined value

See Also

CQGRangeBars Collection


%%PageItemTitle%%

_NewEnum Property
CQGRangeBars Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGRangeBars Collection | CQGRangeBars Members


%%PageItemTitle%%

Count Property
CQGRangeBars Collection : Count Property

Glossary Item Box

Description

Returns the quantity of CQGRangeBar in the collection

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

CQGRangeBars Collection | CQGRangeBars Members


%%PageItemTitle%%

EndTimestamp Property
CQGRangeBars Collection : EndTimestamp Property

Glossary Item Box

Description

Returns the ending (maximum) timestamp of all arrived renko bars so far

Property type

Read-only property

Syntax

Visual Basic
Public Property EndTimestamp As Date

See Also

CQGRangeBars Collection | CQGRangeBars Members


%%PageItemTitle%%

Id Property
CQGRangeBars Collection : Id Property

Glossary Item Box

Description

Returns the unique identifier of renko bars

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

CQGRangeBars Collection | CQGRangeBars Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGRangeBars Collection : Item Property

Glossary Item Box

Description

Returns CQGRangeBar by index

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGRangeBar

Parameters

index_
Zero-based index of item in the collection

See Also

CQGRangeBars Collection | CQGRangeBars Members


%%PageItemTitle%%

LastError Property
CQGRangeBars Collection : LastError Property

Glossary Item Box

Description

Returns CQGError object describing the last error occurred to this object

Property type

Read-only property

Syntax

Visual Basic
Public Property LastError As CQGError

See Also

CQGRangeBars Collection | CQGRangeBars Members


%%PageItemTitle%%

Request Property
CQGRangeBars Collection : Request Property

Glossary Item Box

Description

Returns the read-only copy of CQGRangeBarsRequest object

Property type

Read-only property

Syntax

Visual Basic
Public Property Request As CQGRangeBarsRequest

See Also

CQGRangeBars Collection | CQGRangeBars Members


%%PageItemTitle%%

StartTimestamp Property
CQGRangeBars Collection : StartTimestamp Property

Glossary Item Box

Description

Returns the starting (minimum) timestamp of all arrived renko bars

Property type

Read-only property

Syntax

Visual Basic
Public Property StartTimestamp As Date

See Also

CQGRangeBars Collection | CQGRangeBars Members


%%PageItemTitle%%

Status Property
CQGRangeBars Collection : Status Property

Glossary Item Box

Description

Returns the status

Property type

Read-only property

Syntax

Visual Basic
Public Property Status As eRequestStatus

See Also

CQGRangeBars Collection | CQGRangeBars Members


%%PageItemTitle%%

Tag Property
tag_name
CQGRangeBars Collection : Tag Property

Glossary Item Box

Description

Returns a user defined value

Property type

Read-write property

Syntax

Visual Basic
Public Property Tag( _
   ByVal tag_name As String _
) As Variant

Parameters

tag_name

See Also

CQGRangeBars Collection | CQGRangeBars Members


%%PageItemTitle%%

CQGRangeBarsCollection Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGRangeBars

Object Model

CQGRangeBarsCollection CollectionCQGRangeBars Collection

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGRangeBarsCollection Members


%%PageItemTitle%% $$Members$$

CQGRangeBarsCollection Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGRangeBars in the collection
Public Property Item | Returns the CQGRangeBars by index
Public Property ItemById | Returns the CQGRangeBars by id

See Also

CQGRangeBarsCollection Collection


%%PageItemTitle%%

_NewEnum Property
CQGRangeBarsCollection Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGRangeBarsCollection Collection | CQGRangeBarsCollection Members


%%PageItemTitle%%

Count Property
CQGRangeBarsCollection Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGRangeBars in the collection

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

CQGRangeBarsCollection Collection | CQGRangeBarsCollection Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGRangeBarsCollection Collection : Item Property

Glossary Item Box

Description

Returns the CQGRangeBars by index

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGRangeBars

Parameters

index_
Zero-based index of item in the collection

See Also

CQGRangeBarsCollection Collection | CQGRangeBarsCollection Members


%%PageItemTitle%%

ItemById Property
id_
CQGRangeBarsCollection Collection : ItemById Property

Glossary Item Box

Description

Returns the CQGRangeBars by id

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemById( _
   ByVal id_ As String _
) As CQGRangeBars

Parameters

id_

See Also

CQGRangeBarsCollection Collection | CQGRangeBarsCollection Members


%%PageItemTitle%%

CQGRenkoBars Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGRenkoBar

Object Model

CQGRenkoBars CollectionCQGRenkoBar Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGRenkoBars Members


%%PageItemTitle%% $$Members$$

CQGRenkoBars Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the quantity of CQGRenkoBar in the collection
Public Property EndTimestamp | Returns the ending (maximum) timestamp of all arrived renko bars so far
Public Property Id | Returns the unique identifier of renko bars
Public Property Item | Returns CQGRenkoBar by index
Public Property LastError | Returns CQGError object describing the last error occurred to this object
Public Property Request | Returns the read-only copy of CQGRenkoBarsRequest object
Public Property StartTimestamp | Returns the starting (minimum) timestamp of all arrived renko bars
Public Property Status | Returns the status
Public Property Tag | Returns a user defined value

See Also

CQGRenkoBars Collection


%%PageItemTitle%%

_NewEnum Property
CQGRenkoBars Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGRenkoBars Collection | CQGRenkoBars Members


%%PageItemTitle%%

Count Property
CQGRenkoBars Collection : Count Property

Glossary Item Box

Description

Returns the quantity of CQGRenkoBar in the collection

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

CQGRenkoBars Collection | CQGRenkoBars Members


%%PageItemTitle%%

EndTimestamp Property
CQGRenkoBars Collection : EndTimestamp Property

Glossary Item Box

Description

Returns the ending (maximum) timestamp of all arrived renko bars so far

Property type

Read-only property

Syntax

Visual Basic
Public Property EndTimestamp As Date

See Also

CQGRenkoBars Collection | CQGRenkoBars Members


%%PageItemTitle%%

Id Property
CQGRenkoBars Collection : Id Property

Glossary Item Box

Description

Returns the unique identifier of renko bars

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

CQGRenkoBars Collection | CQGRenkoBars Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGRenkoBars Collection : Item Property

Glossary Item Box

Description

Returns CQGRenkoBar by index

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGRenkoBar

Parameters

index_
Zero-based index of item in the collection

See Also

CQGRenkoBars Collection | CQGRenkoBars Members


%%PageItemTitle%%

LastError Property
CQGRenkoBars Collection : LastError Property

Glossary Item Box

Description

Returns CQGError object describing the last error occurred to this object

Property type

Read-only property

Syntax

Visual Basic
Public Property LastError As CQGError

See Also

CQGRenkoBars Collection | CQGRenkoBars Members


%%PageItemTitle%%

Request Property
CQGRenkoBars Collection : Request Property

Glossary Item Box

Description

Returns the read-only copy of CQGRenkoBarsRequest object

Property type

Read-only property

Syntax

Visual Basic
Public Property Request As CQGRenkoBarsRequest

See Also

CQGRenkoBars Collection | CQGRenkoBars Members


%%PageItemTitle%%

StartTimestamp Property
CQGRenkoBars Collection : StartTimestamp Property

Glossary Item Box

Description

Returns the starting (minimum) timestamp of all arrived renko bars

Property type

Read-only property

Syntax

Visual Basic
Public Property StartTimestamp As Date

See Also

CQGRenkoBars Collection | CQGRenkoBars Members


%%PageItemTitle%%

Status Property
CQGRenkoBars Collection : Status Property

Glossary Item Box

Description

Returns the status

Property type

Read-only property

Syntax

Visual Basic
Public Property Status As eRequestStatus

See Also

CQGRenkoBars Collection | CQGRenkoBars Members


%%PageItemTitle%%

Tag Property
tag_name
CQGRenkoBars Collection : Tag Property

Glossary Item Box

Description

Returns a user defined value

Property type

Read-write property

Syntax

Visual Basic
Public Property Tag( _
   ByVal tag_name As String _
) As Variant

Parameters

tag_name

See Also

CQGRenkoBars Collection | CQGRenkoBars Members


%%PageItemTitle%%

CQGRenkoBarsCollection Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGRenkoBars

Object Model

CQGRenkoBarsCollection CollectionCQGRenkoBars Collection

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGRenkoBarsCollection Members


%%PageItemTitle%% $$Members$$

CQGRenkoBarsCollection Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGRenkoBars in the collection
Public Property Item | Returns the CQGRenkoBars by index
Public Property ItemById | Returns the CQGRenkoBars by id

See Also

CQGRenkoBarsCollection Collection


%%PageItemTitle%%

_NewEnum Property
CQGRenkoBarsCollection Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGRenkoBarsCollection Collection | CQGRenkoBarsCollection Members


%%PageItemTitle%%

Count Property
CQGRenkoBarsCollection Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGRenkoBars in the collection

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

CQGRenkoBarsCollection Collection | CQGRenkoBarsCollection Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGRenkoBarsCollection Collection : Item Property

Glossary Item Box

Description

Returns the CQGRenkoBars by index

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGRenkoBars

Parameters

index_
Zero-based index of item in the collection

See Also

CQGRenkoBarsCollection Collection | CQGRenkoBarsCollection Members


%%PageItemTitle%%

ItemById Property
id_
CQGRenkoBarsCollection Collection : ItemById Property

Glossary Item Box

Description

Returns the CQGRenkoBars by id

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemById( _
   ByVal id_ As String _
) As CQGRenkoBars

Parameters

id_

See Also

CQGRenkoBarsCollection Collection | CQGRenkoBarsCollection Members


%%PageItemTitle%%

CQGSessions Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGSession objects.

Object Model

CQGSessions CollectionCQGSession Interface

Remarks

Access to an item in this collection is made by CQGSession Number Property.

See Accessing non-existent collection items for details on accessing items that do not exist in the collection.

Example

See the usage of CQGSessions collection in the CQGInstrument.Sessions' example section.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGSessions Members | CQGSession Interface | CQGSessionsCollection Collection


%%PageItemTitle%% $$Members$$

CQGSessions Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method IsTimeInSession

Specifies whether the given date is within one of the sessions in the sessions collection.

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of sessions in the trading sessions collection.
Public Property DescriptionEnd | Returns session description end date/time (converted to the user-configured time zone).
Public Property DescriptionNumber | Returns session description number.
Public Property DescriptionStart | Returns the session description's start date/time (converted to the user-configured time zone).
Public Property Holidays | Returns the corresponding CQGHolidays, which is a collection of CQGHoliday objects.
Public Property Item | Returns a session by its index or name. This is the default property.
Public Property Name | Returns the custom session name of each session in the collection.
Public Property Type | Returns the sessions type.

See Also

CQGSessions Collection | CQGSession Interface | CQGSessionsCollection Collection


%%PageItemTitle%%

IsTimeInSession Method
date_time
The date to be checked, in user-configured time zone, represented as Date
use_session_valid_times

This is an optional flag identifying whether the official or valid session times should be used.

- if True, the valid start and end times will be used.

-if False, the official start and end times will be used.

CQGSessions Collection : IsTimeInSession Method

Glossary Item Box

Description

Specifies whether the given date is within one of the sessions in the sessions collection.

Syntax

Visual Basic
Public Function IsTimeInSession( _
   ByVal date_time As Date, _
   Optional ByVal use_session_valid_times As Boolean = False _
) As Boolean

Parameters

date_time
The date to be checked, in user-configured time zone, represented as Date
use_session_valid_times

This is an optional flag identifying whether the official or valid session times should be used.

- if True, the valid start and end times will be used.

-if False, the official start and end times will be used.

Return Type

True if the given date is within one of the sessions in the sessions collection, False otherwise

See Also

CQGSessions Collection | CQGSessions Members | CQGSession.IsTimeInSession Method | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

_NewEnum Property
CQGSessions Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGSessions Collection | CQGSessions Members


%%PageItemTitle%%

Count Property
CQGSessions Collection : Count Property

Glossary Item Box

Description

Returns the number of sessions in the trading sessions collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of sessions represented as Long.

Example

See the usage of CQGSessions properties in the CQGInstrument.Sessions' example section.

See Also

CQGSessions Collection | CQGSessions Members | CQGInstrument.Sessions Property


%%PageItemTitle%%

DescriptionEnd Property
CQGSessions Collection : DescriptionEnd Property

Glossary Item Box

Description

Returns session description end date/time (converted to the user-configured time zone).

Property type

Read-only property

Syntax

Visual Basic
Public Property DescriptionEnd As Date

Return Type

Description's range end, represented as Date

Remarks

For more information, see CQGCEL.HistoricalSessionsResolved's remark section.

See Also

CQGSessions Collection | CQGSessions Members | CQGCEL.HistoricalSessionsResolved Event


%%PageItemTitle%%

DescriptionNumber Property
CQGSessions Collection : DescriptionNumber Property

Glossary Item Box

Description

Returns session description number.

Property type

Read-only property

Syntax

Visual Basic
Public Property DescriptionNumber As Long

Return Type

Session description number, represented as Long

Remarks

For more information, see CQGCEL.HistoricalSessionsResolved's remark section.

See Also

CQGSessions Collection | CQGSessions Members


%%PageItemTitle%%

DescriptionStart Property
CQGSessions Collection : DescriptionStart Property

Glossary Item Box

Description

Returns the session description's start date/time (converted to the user-configured time zone).

Property type

Read-only property

Syntax

Visual Basic
Public Property DescriptionStart As Date

Return Type

Description's range start, represented as Date

Remarks

For more information, see CQGCEL.HistoricalSessionsResolved's remark section.

See Also

CQGSessions Collection | CQGSessions Members | CQGSessions.DescriptionEnd Property | CQGSessions. DescriptionNumber Property | CQGSessions.Holidays Property | CQGHoliday.SessionMask Property | CQGHoliday.HolidayDate Property | CQGHoliday.IsDaily Property


%%PageItemTitle%%

Holidays Property
CQGSessions Collection : Holidays Property

Glossary Item Box

Description

Returns the corresponding CQGHolidays, which is a collection of CQGHoliday objects.

Property type

Read-only property

Syntax

Visual Basic
Public Property Holidays As CQGHolidays

Remarks

The CQGHolidays collection for custom sessions and instrument sessions will be empty, as it is not not supported for these types of sessions.

To resolve an instrument's sessions' holidays RequestHistoricalSessions method should be used.

For more information, see CQGCEL.HistoricalSessionsResolved's remark section.

See Also

CQGSessions Collection | CQGSessions Members | CQGHoliday Interface | CQGHolidays Collection


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGSessions Collection : Item Property

Glossary Item Box

Description

Returns a session by its index or name.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Variant _
) As CQGSession

Parameters

index_
Zero-based index of item in the collection

Return Type

Selected trading session represented as CQGSession Object.

Remarks

If there are several sessions with the same name as the passed one, the first session with such a name is returned.

Example

See the usage of CQGSessions properties in the CQGInstrument.Sessions' example section.

See Also

CQGSessions Collection | CQGSessions Members | CQGSession Interface


%%PageItemTitle%%

Name Property
CQGSessions Collection : Name Property

Glossary Item Box

Description

Returns the custom session name of each session in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

Return Type

Custom session name represented as String

Remarks

If Type doesn't include sstCustom, the returned string is empty.

Example

See the usage of CQGSessions properties in the CQGInstrument.Sessions' example section.

See Also

CQGSessions Collection | CQGSessions Members | CQGSessions.Type Property | eSymbolSessionType Enumeration | CQGInstrument.Sessions Property


%%PageItemTitle%%

Type Property
CQGSessions Collection : Type Property

Glossary Item Box

Description

Returns the sessions type.

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As eSymbolSessionType

Return Type

Session type represented as eSymbolSessionType

Remarks

All contained sessions have the same type.

Example

See the usage of CQGSessions properties in the CQGInstrument.Sessions' example section.

See Also

CQGSessions Collection | CQGSessions Members | eSymbolSessionType Enumeration | CQGSession.Type Property


%%PageItemTitle%%

CQGSessionsCollection Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGSessions objects.

Object Model

CQGSessionsCollection CollectionCQGSessions Collection

Remarks

This collection is used in the CustomSessionsResolved event.

See Accessing non-existent collection items for details on accessing items that do not exist in the collection.

Example

See the usage of CQGSessionsCollection object in the CustomSessionsResolved event's example section.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGSessionsCollection Members | CQGSession Interface | CQGSessions Collection | CustomSessionsResolved Event


%%PageItemTitle%% $$Members$$

CQGSessionsCollection Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of all CQGSessions objects in the collection.
Public Property Item | Returns the CQGSessions object by its index. This is the default property.

See Also

CQGSessionsCollection Collection | CQGSession Interface | CQGSessions Collection | CustomSessionsResolved Event


%%PageItemTitle%%

_NewEnum Property
CQGSessionsCollection Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGSessionsCollection Collection | CQGSessionsCollection Members


%%PageItemTitle%%

Count Property
CQGSessionsCollection Collection : Count Property

Glossary Item Box

Description

Returns the number of all CQGSessions objects in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of CQGSessions objects in the collection, represented as Long

Example

See the usage of CQGSessionsCollection properties in the CustomSessionsResolved event's example section.

See Also

CQGSessionsCollection Collection | CQGSessionsCollection Members | CQGSessions Collection | CQGSessionsCollection.Item Property


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGSessionsCollection Collection : Item Property

Glossary Item Box

Description

Returns the CQGSessions object by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Variant _
) As CQGSessions

Parameters

index_
Zero-based index of item in the collection

Return Type

Sessions represented as CQGSessions object

Remarks

Calling with an incorrect index type, number, an empty or custom session's non-existent name will throw a collection exception.

Example

See the usage of CQGSessionsCollection properties in the CustomSessionsResolved event's example section.

See Also

CQGSessionsCollection Collection | CQGSessionsCollection Members | CQGSessionsCollection.Count Property | CQGSession Interface | CQGSessions Collection | CQGAPIConfig.CollectionsThrowException Property


%%PageItemTitle%%

CQGStrategyDefinitions Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGStrategyDefinition objects.

Object Model

CQGStrategyDefinitions CollectionCQGStrategyDefinition Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGStrategyDefinitions Members


%%PageItemTitle%% $$Members$$

CQGStrategyDefinitions Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of strategy definitions in the collection.
Public Property Item | Returns the selected strategy definition by its unique identifier. This is the default property.
Public Property ItemByIndex | Returns the definition by the sequential index.

See Also

CQGStrategyDefinitions Collection


%%PageItemTitle%%

_NewEnum Property
CQGStrategyDefinitions Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGStrategyDefinitions Collection | CQGStrategyDefinitions Members


%%PageItemTitle%%

Count Property
CQGStrategyDefinitions Collection : Count Property

Glossary Item Box

Description

Returns the number of strategy definitions in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of strategy definitions, represented as Long

See Also

CQGStrategyDefinitions Collection | CQGStrategyDefinitions Members


%%PageItemTitle%%

Item Property
id_
CQGStrategyDefinitions Collection : Item Property

Glossary Item Box

Description

Returns the selected strategy definition by its unique identifier.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal id_ As String _
) As CQGStrategyDefinition

Parameters

id_

Return Type

The corresponding CQGStrategyDefinition object.

If the accessed object does not exist, see Accessing non-existent collection items to learn more about the return type.

See Also

CQGStrategyDefinitions Collection | CQGStrategyDefinitions Members | CQGStrategyDefinition Interface


%%PageItemTitle%%

ItemByIndex Property
index_
Zero-based index of item in the collection
CQGStrategyDefinitions Collection : ItemByIndex Property

Glossary Item Box

Description

Returns the definition by the sequential index.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemByIndex( _
   ByVal index_ As Long _
) As CQGStrategyDefinition

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding strategy definition object, represented as CQGStrategyDefinition

See Also

CQGStrategyDefinitions Collection | CQGStrategyDefinitions Members | CQGStrategyDefinition Interface


%%PageItemTitle%%

CQGStrategyLegFills Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGStrategyLegFill for a strategy order.

Object Model

CQGStrategyLegFills Collection

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGStrategyLegFills Members


%%PageItemTitle%% $$Members$$

CQGStrategyLegFills Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Count | Returns the number of leg fills in the collection.
Public Property ItemByIndex | Returns the leg fill by its sequental index.

See Also

CQGStrategyLegFills Collection


%%PageItemTitle%%

Count Property
CQGStrategyLegFills Collection : Count Property

Glossary Item Box

Description

Returns the number of leg fills in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of leg fills in the collection, represented as Long

See Also

CQGStrategyLegFills Collection | CQGStrategyLegFills Members


%%PageItemTitle%%

ItemByIndex Property
index_
Zero-based index of item in the collection
CQGStrategyLegFills Collection : ItemByIndex Property

Glossary Item Box

Description

Returns the leg fill by its sequental index.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemByIndex( _
   ByVal index_ As Long _
) As CQGStrategyLegFill

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding colleciton item, represented as CQGStrategyLegFill

See Also

CQGStrategyLegFills Collection | CQGStrategyLegFills Members | CQGStrategyLegFill Interface


%%PageItemTitle%%

CQGStrategyQuoteRequest Object
See Also Members Send Feedback

Glossary Item Box

Description

Represents a request for quotes (RFQ)

Object Model

CQGStrategyQuoteRequest ObjectCQGAccount Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGStrategyQuoteRequest Members


%%PageItemTitle%% $$Members$$

CQGStrategyQuoteRequest Object Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property Account | Account
Public Property AlgorithmDescription | Algorithm description
Public Property AlgorithmID | Algorithm ID
Public Property Side | The side of the requested quote. Default value is eOrderSide.osdUndefined.
Public Property Size | The size of the requested quote.
Public Property SizeFractional | Fractional size
Public Property Symbol | Symbol for which quotes are requested

See Also

CQGStrategyQuoteRequest Object


%%PageItemTitle%%

Account Property
CQGStrategyQuoteRequest Object : Account Property

Glossary Item Box

Description

Account

Property type

Read-only property

Syntax

Visual Basic
Public Property Account As CQGAccount

See Also

CQGStrategyQuoteRequest Object | CQGStrategyQuoteRequest Members


%%PageItemTitle%%

AlgorithmDescription Property
CQGStrategyQuoteRequest Object : AlgorithmDescription Property

Glossary Item Box

Description

Algorithm description

Property type

Read-write property

Syntax

Visual Basic
Public Property AlgorithmDescription As String

See Also

CQGStrategyQuoteRequest Object | CQGStrategyQuoteRequest Members


%%PageItemTitle%%

AlgorithmID Property
CQGStrategyQuoteRequest Object : AlgorithmID Property

Glossary Item Box

Description

Algorithm ID

Property type

Read-write property

Syntax

Visual Basic
Public Property AlgorithmID As Long

See Also

CQGStrategyQuoteRequest Object | CQGStrategyQuoteRequest Members


%%PageItemTitle%%

Side Property
CQGStrategyQuoteRequest Object : Side Property

Glossary Item Box

Description

The side of the requested quote. Default value is eOrderSide.osdUndefined.

Property type

Read-write property

Syntax

Visual Basic
Public Property Side As eOrderSide

Remarks

If the setting of CQGAPIConfig.UseOrderSide is set to False, the side of the requested quote should be given via CQGStrategyQuoteRequest.Size property sign.

See Also

CQGStrategyQuoteRequest Object | CQGStrategyQuoteRequest Members


%%PageItemTitle%%

Size Property
CQGStrategyQuoteRequest Object : Size Property

Glossary Item Box

Description

The size of the requested quote.

Property type

Read-write property

Syntax

Visual Basic
Public Property Size As Long

Remarks

If the setting of CQGAPIConfig.UseOrderSide is set to False, the side of the request should also be taken into account when setting this property.

See Also

CQGStrategyQuoteRequest Object | CQGStrategyQuoteRequest Members


%%PageItemTitle%%

SizeFractional Property
CQGStrategyQuoteRequest Object : SizeFractional Property

Glossary Item Box

Description

Fractional size

Property type

Read-write property

Syntax

Visual Basic
Public Property SizeFractional As Decimal

See Also

CQGStrategyQuoteRequest Object | CQGStrategyQuoteRequest Members


%%PageItemTitle%%

Symbol Property
CQGStrategyQuoteRequest Object : Symbol Property

Glossary Item Box

Description

Symbol for which quotes are requested

Property type

Read-only property

Syntax

Visual Basic
Public Property Symbol As String

See Also

CQGStrategyQuoteRequest Object | CQGStrategyQuoteRequest Members


%%PageItemTitle%%

CQGStringCollection Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of strings.

Object Model

CQGStringCollection Collection

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGStringCollection Members


%%PageItemTitle%% $$Members$$

CQGStringCollection Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of all strings in the collection.
Public Property Item | Returns the string value by its index.

See Also

CQGStringCollection Collection


%%PageItemTitle%%

_NewEnum Property
CQGStringCollection Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGStringCollection Collection | CQGStringCollection Members


%%PageItemTitle%%

Count Property
CQGStringCollection Collection : Count Property

Glossary Item Box

Description

Returns the number of all strings in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of strings, represented as Long

See Also

CQGStringCollection Collection | CQGStringCollection Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGStringCollection Collection : Item Property

Glossary Item Box

Description

Returns the string value by its index.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As String

Parameters

index_
Zero-based index of item in the collection

Return Type

String object, represented as String

See Also

CQGStringCollection Collection | CQGStringCollection Members


%%PageItemTitle%%

CQGSubMinuteBars Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGSubMinuteBar objects.

Object Model

CQGSubMinuteBars CollectionCQGSubMinuteBar Interface

Remarks

This collection is returned by the CQGCEL.RequestSubMinuteBars method calls.

The CQGCEL.SubMinuteBarsResolved, CQGCEL.SubMinuteBarsAdded, and CQGCEL.SubMinuteBarsUpdated events can be fired for CQGSubMinuteBars.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGSubMinuteBars Members


%%PageItemTitle%% $$Members$$

CQGSubMinuteBars Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGSubMinuteBar in the collection
Public Property EndTimestamp | Returns the ending (maximum) timestamp of all arrived sub minute bars so far
Public Property Id | Returns the unique identifier of sub minute bars
Public Property Item | Returns the CQGSubMinuteBar by index
Public Property LastError | Returns CQGError object describing the last error occurred to this object
Public Property Request | Returns the read-only copy of CQGTimedBarsRequest object
Public Property StartTimestamp | Returns the starting (minimum) timestamp of all arrived sub minute bars
Public Property Status | Returns the status
Public Property Tag | Returns a user defined value

See Also

CQGSubMinuteBars Collection


%%PageItemTitle%%

_NewEnum Property
CQGSubMinuteBars Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGSubMinuteBars Collection | CQGSubMinuteBars Members


%%PageItemTitle%%

Count Property
CQGSubMinuteBars Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGSubMinuteBar in the collection

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

CQGSubMinuteBars Collection | CQGSubMinuteBars Members


%%PageItemTitle%%

EndTimestamp Property
CQGSubMinuteBars Collection : EndTimestamp Property

Glossary Item Box

Description

Returns the ending (maximum) timestamp of all arrived sub minute bars so far

Property type

Read-only property

Syntax

Visual Basic
Public Property EndTimestamp As Date

See Also

CQGSubMinuteBars Collection | CQGSubMinuteBars Members


%%PageItemTitle%%

Id Property
CQGSubMinuteBars Collection : Id Property

Glossary Item Box

Description

Returns the unique identifier of sub minute bars

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

CQGSubMinuteBars Collection | CQGSubMinuteBars Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGSubMinuteBars Collection : Item Property

Glossary Item Box

Description

Returns the CQGSubMinuteBar by index

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGSubMinuteBar

Parameters

index_
Zero-based index of item in the collection

See Also

CQGSubMinuteBars Collection | CQGSubMinuteBars Members


%%PageItemTitle%%

LastError Property
CQGSubMinuteBars Collection : LastError Property

Glossary Item Box

Description

Returns CQGError object describing the last error occurred to this object

Property type

Read-only property

Syntax

Visual Basic
Public Property LastError As CQGError

See Also

CQGSubMinuteBars Collection | CQGSubMinuteBars Members


%%PageItemTitle%%

Request Property
CQGSubMinuteBars Collection : Request Property

Glossary Item Box

Description

Returns the read-only copy of CQGTimedBarsRequest object

Property type

Read-only property

Syntax

Visual Basic
Public Property Request As CQGSubMinuteBarsRequest

See Also

CQGSubMinuteBars Collection | CQGSubMinuteBars Members


%%PageItemTitle%%

StartTimestamp Property
CQGSubMinuteBars Collection : StartTimestamp Property

Glossary Item Box

Description

Returns the starting (minimum) timestamp of all arrived sub minute bars

Property type

Read-only property

Syntax

Visual Basic
Public Property StartTimestamp As Date

See Also

CQGSubMinuteBars Collection | CQGSubMinuteBars Members


%%PageItemTitle%%

Status Property
CQGSubMinuteBars Collection : Status Property

Glossary Item Box

Description

Returns the status

Property type

Read-only property

Syntax

Visual Basic
Public Property Status As eRequestStatus

See Also

CQGSubMinuteBars Collection | CQGSubMinuteBars Members


%%PageItemTitle%%

Tag Property
tag_name
A user defined value's name
CQGSubMinuteBars Collection : Tag Property

Glossary Item Box

Description

Returns a user defined value

Property type

Read-write property

Syntax

Visual Basic
Public Property Tag( _
   ByVal tag_name As String _
) As Variant

Parameters

tag_name
A user defined value's name

See Also

CQGSubMinuteBars Collection | CQGSubMinuteBars Members


%%PageItemTitle%%

CQGSubMinuteBarsCollection Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGSubMinuteBars objects.

Object Model

CQGSubMinuteBarsCollection CollectionCQGSubMinuteBars Collection

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGSubMinuteBarsCollection Members


%%PageItemTitle%% $$Members$$

CQGSubMinuteBarsCollection Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGSubMinuteBars in the collection
Public Property Item | Returns the CQGSubMinuteBars by index
Public Property ItemById | Returns the CQGSubMinuteBars by id

See Also

CQGSubMinuteBarsCollection Collection


%%PageItemTitle%%

_NewEnum Property
CQGSubMinuteBarsCollection Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGSubMinuteBarsCollection Collection | CQGSubMinuteBarsCollection Members


%%PageItemTitle%%

Count Property
CQGSubMinuteBarsCollection Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGSubMinuteBars in the collection

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

CQGSubMinuteBarsCollection Collection | CQGSubMinuteBarsCollection Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGSubMinuteBarsCollection Collection : Item Property

Glossary Item Box

Description

Returns the CQGSubMinuteBars by index

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGSubMinuteBars

Parameters

index_
Zero-based index of item in the collection

See Also

CQGSubMinuteBarsCollection Collection | CQGSubMinuteBarsCollection Members


%%PageItemTitle%%

ItemById Property
id_
CQGSubMinuteBarsCollection Collection : ItemById Property

Glossary Item Box

Description

Returns the CQGSubMinuteBars by id

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemById( _
   ByVal id_ As String _
) As CQGSubMinuteBars

Parameters

id_

See Also

CQGSubMinuteBarsCollection Collection | CQGSubMinuteBarsCollection Members


%%PageItemTitle%%

CQGTFlowBars Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGTFlowBar objects.

Is returned by the CQGCEL.RequestTFlows method call.

Object Model

CQGTFlowBars CollectionCQGTFlowBar Interface

Remarks

The CQGCEL.TFlowBarsResolved, CQGCEL.TFlowBarsAdded, and CQGCEL.TFlowBarsUpdated events can be fired for CQGTFlowBars.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTFlowBars Members | CQGTFlowBar Interface | RequestTFlowBars Method | TFlowBarsResolved Event | TFlowBarsAdded Event | TFlowBarsInserted Event | TFlowBarsRemoved Event | TFlowBarsUpdated Event


%%PageItemTitle%% $$Members$$

CQGTFlowBars Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of all records in the collection.
Public Property EndTimestamp | Returns the ending (maximum) timestamp of all arrived TFlow bars, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
Public Property Id | Returns the unique identifier of the TFlow bars.
Public Property Item | Returns the corresponding CQGTFlowBar object by its index. This is the default property.
Public Property LastError | Returns CQGError object describing the last error occurred to this object.
Public Property Request | Returns the read-only copy of CQGTFlowBarsRequest object, that was passed to the corresponding CQGCEL.RequestTFlowBars method call.
Public Property StartTimestamp | Returns the starting (minimum) timestamp of all arrived TFlow bars, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
Public Property Status | Returns the TFlow bar request's status.
Public Property Tag | This property allows the user to keep his/her own information within the TFlow bars.

See Also

CQGTFlowBars Collection | CQGTFlowBar Interface | RequestTFlowBars Method | TFlowBarsResolved Event | TFlowBarsAdded Event | TFlowBarsInserted Event | TFlowBarsRemoved Event | TFlowBarsUpdated Event


%%PageItemTitle%%

_NewEnum Property
CQGTFlowBars Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGTFlowBars Collection | CQGTFlowBars Members


%%PageItemTitle%%

Count Property
CQGTFlowBars Collection : Count Property

Glossary Item Box

Description

Returns the number of all records in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of CQGTFlowBar object, represented as Long

See Also

CQGTFlowBars Collection | CQGTFlowBars Members | CQGTFlowBar Interface


%%PageItemTitle%%

EndTimestamp Property
CQGTFlowBars Collection : EndTimestamp Property

Glossary Item Box

Description

Returns the ending (maximum) timestamp of all arrived TFlow bars, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

Property type

Read-only property

Syntax

Visual Basic
Public Property EndTimestamp As Date

Return Type

The ending timestamp, represented as Date

See Also

CQGTFlowBars Collection | CQGTFlowBars Members | CQGAPIConfig.TimeZoneCode Property | CQGTFlowBar Interface


%%PageItemTitle%%

Id Property
CQGTFlowBars Collection : Id Property

Glossary Item Box

Description

Returns the unique identifier of the TFlow bars.

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

Return Type

Unique identifier, represented as String

See Also

CQGTFlowBars Collection | CQGTFlowBars Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGTFlowBars Collection : Item Property

Glossary Item Box

Description

Returns the corresponding CQGTFlowBar object by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGTFlowBar

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item, represented as CQGTFlowBar object

Remarks

A CQGTFlowBar object will be created upon request and passed to the user without storing it.

Two sequential requests for the same record may return different objects.

See Also

CQGTFlowBars Collection | CQGTFlowBars Members | CQGTFlowBar Interface


%%PageItemTitle%%

LastError Property
CQGTFlowBars Collection : LastError Property

Glossary Item Box

Description

Returns CQGError object describing the last error occurred to this object.

Property type

Read-only property

Syntax

Visual Basic
Public Property LastError As CQGError

Return Type

The last error, represented as CQGError object

See Also

CQGTFlowBars Collection | CQGTFlowBars Members | CQGError Interface


%%PageItemTitle%%

Request Property
CQGTFlowBars Collection : Request Property

Glossary Item Box

Description

Returns the read-only copy of CQGTFlowBarsRequest object, that was passed to the corresponding CQGCEL.RequestTFlowBars method call.

Property type

Read-only property

Syntax

Visual Basic
Public Property Request As CQGTFlowBarsRequest

Return Type

A read-only copy of the corresponding CQGTFlowBarsRequest object

See Also

CQGTFlowBars Collection | CQGTFlowBars Members | CQGTFlowBarsRequest Interface | CQGCEL.RequestTFlows Method


%%PageItemTitle%%

StartTimestamp Property
CQGTFlowBars Collection : StartTimestamp Property

Glossary Item Box

Description

Returns the starting (minimum) timestamp of all arrived TFlow bars, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

Property type

Read-only property

Syntax

Visual Basic
Public Property StartTimestamp As Date

Return Type

The starting timestamp, represented as Date

See Also

CQGTFlowBars Collection | CQGTFlowBars Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

Status Property
CQGTFlowBars Collection : Status Property

Glossary Item Box

Description

Returns the TFlow bar request's status.

Property type

Read-only property

Syntax

Visual Basic
Public Property Status As eRequestStatus

Return Type

The status of the TFlow bar request, represented as eRequestStatus

Remarks

See eRequestStatus for possible values.

See Also

CQGTFlowBars Collection | CQGTFlowBars Members | eRequestStatus Enumeration


%%PageItemTitle%%

Tag Property
tag_name

The user-defined value's name.

When setting, the tag_name parameter should keep the key that will be associated with the passed information.

When getting the information from the Tag, one of the previously set keys should be passed as tag_name in order to get the corresponding information.

CQGTFlowBars Collection : Tag Property

Glossary Item Box

Description

This property allows the user to keep his/her own information within the TFlow bars.

Property type

Read-write property

Syntax

Visual Basic
Public Property Tag( _
   ByVal tag_name As String _
) As Variant

Parameters

tag_name

The user-defined value's name.

When setting, the tag_name parameter should keep the key that will be associated with the passed information.

When getting the information from the Tag, one of the previously set keys should be passed as tag_name in order to get the corresponding information.

Return Type

The user-defined value, represented as Variant

Remarks

Multiple data can be kept in the Tag property under different keys.

  • If no user-defined value with this tag_name exists, Empty is returned.
  • If empty is set to an existing tag_name, it is deleted/unregistered.
  • If a new value is set to an existing tag_name, the old value is overwritten.

See Also

CQGTFlowBars Collection | CQGTFlowBars Members


%%PageItemTitle%%

CQGTFlowBarsCollection Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGTFlowBars objects.

Object Model

CQGTFlowBarsCollection CollectionCQGTFlowBars Collection

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTFlowBarsCollection Members | CQGTFlowBars Collection


%%PageItemTitle%% $$Members$$

CQGTFlowBarsCollection Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGTFlowBars in the collection.
Public Property Item | Returns the corresponding CQGTFlowBars object by its index. This is the default property.
Public Property ItemById | Returns the corresponding CQGTFlowBars object by its unique identifier.

See Also

CQGTFlowBarsCollection Collection | CQGTFlowBars Collection


%%PageItemTitle%%

_NewEnum Property
CQGTFlowBarsCollection Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGTFlowBarsCollection Collection | CQGTFlowBarsCollection Members


%%PageItemTitle%%

Count Property
CQGTFlowBarsCollection Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGTFlowBars in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of collection items, represented as Long

See Also

CQGTFlowBarsCollection Collection | CQGTFlowBarsCollection Members | CQGTFlowBars Collection


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGTFlowBarsCollection Collection : Item Property

Glossary Item Box

Description

Returns the corresponding CQGTFlowBars object by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGTFlowBars

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item, represented as CQGTFlowBars object

See Also

CQGTFlowBarsCollection Collection | CQGTFlowBarsCollection Members | CQGTFlowBars Collection


%%PageItemTitle%%

ItemById Property
id_
CQGTFlowBarsCollection Collection : ItemById Property

Glossary Item Box

Description

Returns the corresponding CQGTFlowBars object by its unique identifier.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemById( _
   ByVal id_ As String _
) As CQGTFlowBars

Parameters

id_

Return Type

The corresponding collection item, represented as CQGTFlowBars

Remarks

A collection exception will be thrown if no CQGTFlowBars exists with the specified unique identifier.

See Also

CQGTFlowBarsCollection Collection | CQGTFlowBarsCollection Members | CQGTFlowBars Collection


%%PageItemTitle%%

CQGTicks Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGTick objects.

Object Model

CQGTicks CollectionCQGTick Interface

Remarks

Is returned by the CQGCEL.RequestTicks method call.

The CQGCEL.TicksResolved and CQGCEL.TicksAdded events can be fired for CQGTicks.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTicks Members | CQGTick Interface


%%PageItemTitle%% $$Members$$

CQGTicks Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method IndexForDate | Returns the start index for the specified date.
Public Method IndicesForDates | Returns start and end indices for specified dates.

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of all records in the collection.
Public Property EndTimestamp | Returns the ending (maximum) timestamp of all arrived ticks, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
Public Property HasUpdates | Returns the updates flag.
Public Property Id | Returns the unique identifier of ticks.
Public Property Item | Returns the CQGTick by its index. This is the default property.
Public Property LastError | Returns CQGError object describing the last error occurred to this object.
Public Property Request | Returns the read-only copy of the CQGTicksRequest object, that was passed to the corresponding CQGCEL.RequestTicks method call.
Public Property StartTimestamp | Returns the starting (minimum) timestamp of all arrived ticks, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
Public Property Status | Returns the status.
Public Property Tag | This property allows the user to keep his/her own information within the ticks.

See Also

CQGTicks Collection | CQGTick Interface


%%PageItemTitle%%

IndexForDate Method
date_

Specifies date, in the user-configured time zone (CQGAPIConfig.TimeZoneCode)

CQGTicks Collection : IndexForDate Method

Glossary Item Box

Description

Returns the start index for the specified date.

Syntax

Visual Basic
Public Function IndexForDate( _
   ByVal date_ As Date _
) As Long

Parameters

date_

Specifies date, in the user-configured time zone (CQGAPIConfig.TimeZoneCode)

Remarks

If in this CQGTicks there are CQGTick objects having their Timestamp equal to date_, the first such record's index is returned.

Otherwise, the returned value will be invalid.

See Also

CQGTicks Collection | CQGTicks Members | CQGTick Interface | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

IndicesForDates Method
date_1

Specifies the first date, in the user-configured time zone (CQGAPIConfig.TimeZoneCode)

date_2

Specifies the second date, in the user-configured time zone (CQGAPIConfig.TimeZoneCode)

start_index

Specifies the start indices to be set

end_index

Specifies the end indices to be set

CQGTicks Collection : IndicesForDates Method

Glossary Item Box

Description

Returns start and end indices for specified dates.

Syntax

Visual Basic
Public Sub IndicesForDates( _
   ByVal date_1 As Date, _
   ByVal date_2 As Date, _
   ByRef start_index As Long, _
   ByRef end_index As Long _
)

Parameters

date_1

Specifies the first date, in the user-configured time zone (CQGAPIConfig.TimeZoneCode)

date_2

Specifies the second date, in the user-configured time zone (CQGAPIConfig.TimeZoneCode)

start_index

Specifies the start indices to be set

end_index

Specifies the end indices to be set

Remarks

If in this CQGTicks, there are CQGTick objects having their Timestamp in the range [date_1, date_2), then after the call the range [start_index, end_index] will specify the indices of all such CQGTick objects.

An exception is thrown if date_1 is not earlier than date_2.

Otherwise if no such record exists, both start_index and end_index will be invalid.

See Also

CQGTicks Collection | CQGTicks Members | CQGAPIConfig.TimeZoneCode Property | CQGTick Interface


%%PageItemTitle%%

_NewEnum Property
CQGTicks Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGTicks Collection | CQGTicks Members


%%PageItemTitle%%

Count Property
CQGTicks Collection : Count Property

Glossary Item Box

Description

Returns the number of all records in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of records, represented as Long

See Also

CQGTicks Collection | CQGTicks Members


%%PageItemTitle%%

EndTimestamp Property
CQGTicks Collection : EndTimestamp Property

Glossary Item Box

Description

Returns the ending (maximum) timestamp of all arrived ticks, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

Property type

Read-only property

Syntax

Visual Basic
Public Property EndTimestamp As Date

Return Type

Ending timestamp, represented as Date

See Also

CQGTicks Collection | CQGTicks Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

HasUpdates Property
CQGTicks Collection : HasUpdates Property

Glossary Item Box

Description

Returns the updates flag.

Property type

Read-only property

Syntax

Visual Basic
Public Property HasUpdates As Boolean

Return Type

True, if updates are available; False, otherwise

See Also

CQGTicks Collection | CQGTicks Members


%%PageItemTitle%%

Id Property
CQGTicks Collection : Id Property

Glossary Item Box

Description

Returns the unique identifier of ticks.

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

Return Type

Unique identifier, represented as String

See Also

CQGTicks Collection | CQGTicks Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGTicks Collection : Item Property

Glossary Item Box

Description

Returns the CQGTick by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGTick

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item, represented as CQGTick object

Remarks

A CQGTick object will be created upon request and passed to the user without storing it.

Two sequential requests for the same record may return different objects.

See Also

CQGTicks Collection | CQGTicks Members | CQGTick Interface


%%PageItemTitle%%

LastError Property
CQGTicks Collection : LastError Property

Glossary Item Box

Description

Returns CQGError object describing the last error occurred to this object.

Property type

Read-only property

Syntax

Visual Basic
Public Property LastError As CQGError

Return Type

The last error, represented as CQGError object

See Also

CQGTicks Collection | CQGTicks Members | CQGError Interface


%%PageItemTitle%%

Request Property
CQGTicks Collection : Request Property

Glossary Item Box

Description

Returns the read-only copy of the CQGTicksRequest object, that was passed to the corresponding CQGCEL.RequestTicks method call.

Property type

Read-only property

Syntax

Visual Basic
Public Property Request As CQGTicksRequest

Return Type

A read-only copy of the CQGTicksRequest object

See Also

CQGTicks Collection | CQGTicks Members | CQGTicksRequest Interface | CQGCEL.RequestTicks Method


%%PageItemTitle%%

StartTimestamp Property
CQGTicks Collection : StartTimestamp Property

Glossary Item Box

Description

Returns the starting (minimum) timestamp of all arrived ticks, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

Property type

Read-only property

Syntax

Visual Basic
Public Property StartTimestamp As Date

Return Type

Starting timestamp, represented as Date

See Also

CQGTicks Collection | CQGTicks Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

Status Property
CQGTicks Collection : Status Property

Glossary Item Box

Description

Returns the status.

Property type

Read-only property

Syntax

Visual Basic
Public Property Status As eRequestStatus

Return Type

Request status, represented as eRequestStatus

Remarks

See eRequestStatus for possible values.

See Also

CQGTicks Collection | CQGTicks Members | eRequestStatus Enumeration


%%PageItemTitle%%

Tag Property
tag_name

The user-defined value's name.

When setting, the tag_name parameter should keep the key that will be associated with the passed information.

When getting the information from the Tag, one of the previously set keys should be passed as tag_name in order to get the corresponding information.

CQGTicks Collection : Tag Property

Glossary Item Box

Description

This property allows the user to keep his/her own information within the ticks.

Property type

Read-write property

Syntax

Visual Basic
Public Property Tag( _
   ByVal tag_name As String _
) As Variant

Parameters

tag_name

The user-defined value's name.

When setting, the tag_name parameter should keep the key that will be associated with the passed information.

When getting the information from the Tag, one of the previously set keys should be passed as tag_name in order to get the corresponding information.

Return Type

The user-defined value, represented as Variant

Remarks

Multiple data can be kept in the Tag property under different keys.

If no user-defined value with this tag_name exists, Empty is returned.

If empty is set to an existing tag_name, it is deleted/unregistered.

If a new value is set to an existing tag_name, the old value is overwritten.

See Also

CQGTicks Collection | CQGTicks Members


%%PageItemTitle%%

CQGTicksCollection Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGTicks objects.

Object Model

CQGTicksCollection CollectionCQGTicks Collection

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTicksCollection Members | CQGTicks Collection


%%PageItemTitle%% $$Members$$

CQGTicksCollection Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGTicks in the collection.
Public Property Item | Returns the CQGTicks object by its index. This is the default property.
Public Property ItemById | Returns the CQGTicks by its unique identifier.

See Also

CQGTicksCollection Collection | CQGTicks Collection


%%PageItemTitle%%

_NewEnum Property
CQGTicksCollection Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGTicksCollection Collection | CQGTicksCollection Members


%%PageItemTitle%%

Count Property
CQGTicksCollection Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGTicks in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of collection items, represented as Long

See Also

CQGTicksCollection Collection | CQGTicksCollection Members | CQGTicks Collection


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGTicksCollection Collection : Item Property

Glossary Item Box

Description

Returns the CQGTicks object by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGTicks

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item, represented as CQGTicks object

See Also

CQGTicksCollection Collection | CQGTicksCollection Members | CQGTicks Collection


%%PageItemTitle%%

ItemById Property
id_
CQGTicksCollection Collection : ItemById Property

Glossary Item Box

Description

Returns the CQGTicks by its unique identifier.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemById( _
   ByVal id_ As String _
) As CQGTicks

Parameters

id_

Remarks

A collection exception will be thrown if no CQGTicks exists with the specified id.

See Also

CQGTicksCollection Collection | CQGTicksCollection Members | CQGTicks Collection


%%PageItemTitle%%

CQGTimedBars Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGTimedBar objects.

Object Model

CQGTimedBars CollectionCQGTimedBar Interface

Remarks

This collection is returned by the CQGCEL.RequestTimedBars method calls.

The CQGCEL.TimedBarsResolved, CQGCEL.TimedBarsAdded, and CQGCEL.TimedBarsUpdated events can be fired for CQGTimedBars.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTimedBars Members | CQGTimedBar Interface


%%PageItemTitle%% $$Members$$

CQGTimedBars Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method IndexForDate

Returns the start index for the specified date.

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of all records in the collection.
Public Property EndTimestamp | Returns the ending (maximum) timestamp of all arrived timed bars, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
Public Property Id | Returns the unique identifier of the timed bars.
Public Property Item | Returns the CQGTimedBar by its index. This is the default property.
Public Property LastError | Returns CQGError object describing the last error occurred to this object.
Public Property Request | Returns a read-only copy of the CQGTimedBarsRequest object, that was passed to the corresponding CQGCEL.RequestTimedBars method call.
Public Property StartTimestamp | Returns the starting (minimum) timestamp of all arrived timed bars, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
Public Property Status | Returns the status of the timed bars request.
Public Property Tag | This property allows the user to keep his/her own information within the timed bars.

See Also

CQGTimedBars Collection | CQGTimedBar Interface


%%PageItemTitle%%

IndexForDate Method
date_

Specifies the date, in the user-configured time zone (CQGAPIConfig.TimeZoneCode)

CQGTimedBars Collection : IndexForDate Method

Glossary Item Box

Description

Returns the start index for the specified date.

Syntax

Visual Basic
Public Function IndexForDate( _
   ByVal date_ As Date _
) As Long

Parameters

date_

Specifies the date, in the user-configured time zone (CQGAPIConfig.TimeZoneCode)

Return Type

Remarks

If in this CQGTimedBars, there are CQGTimedBar objects having their Timestamps equal to date_, the first such record's index is returned.

Otherwise, the returned value will be invalid.

See Also

CQGTimedBars Collection | CQGTimedBars Members | CQGTimedBar Interface | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

_NewEnum Property
CQGTimedBars Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGTimedBars Collection | CQGTimedBars Members


%%PageItemTitle%%

Count Property
CQGTimedBars Collection : Count Property

Glossary Item Box

Description

Returns the number of all records in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of records, represented as Long

See Also

CQGTimedBars Collection | CQGTimedBars Members


%%PageItemTitle%%

EndTimestamp Property
CQGTimedBars Collection : EndTimestamp Property

Glossary Item Box

Description

Returns the ending (maximum) timestamp of all arrived timed bars, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

Property type

Read-only property

Syntax

Visual Basic
Public Property EndTimestamp As Date

Return Type

Ending timestamp, represented as Date

See Also

CQGTimedBars Collection | CQGTimedBars Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

Id Property
CQGTimedBars Collection : Id Property

Glossary Item Box

Description

Returns the unique identifier of the timed bars.

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

Return Type

Unique identifier, represented as String

See Also

CQGTimedBars Collection | CQGTimedBars Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGTimedBars Collection : Item Property

Glossary Item Box

Description

Returns the CQGTimedBar by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGTimedBar

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item represented as CQGTimedBar object

Remarks

A CQGTimedBar will be created upon request and passed to the user without storing it.

Two sequential requests for the same record may return different objects.

See Also

CQGTimedBars Collection | CQGTimedBars Members | CQGTimedBar Interface


%%PageItemTitle%%

LastError Property
CQGTimedBars Collection : LastError Property

Glossary Item Box

Description

Returns CQGError object describing the last error occurred to this object.

Property type

Read-only property

Syntax

Visual Basic
Public Property LastError As CQGError

Return Type

The last error, represented as CQGError object

See Also

CQGTimedBars Collection | CQGTimedBars Members | CQGError Interface


%%PageItemTitle%%

Request Property
CQGTimedBars Collection : Request Property

Glossary Item Box

Description

Returns a read-only copy of the CQGTimedBarsRequest object, that was passed to the corresponding CQGCEL.RequestTimedBars method call.

Property type

Read-only property

Syntax

Visual Basic
Public Property Request As CQGTimedBarsRequest

Return Type

A read-only copy of the corresponding CQGTimedBarsRequest object

See Also

CQGTimedBars Collection | CQGTimedBars Members | CQGTimedBarsRequest Interface | CQGCEL.RequestTimedBars Method


%%PageItemTitle%%

StartTimestamp Property
CQGTimedBars Collection : StartTimestamp Property

Glossary Item Box

Description

Returns the starting (minimum) timestamp of all arrived timed bars, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

Property type

Read-only property

Syntax

Visual Basic
Public Property StartTimestamp As Date

Return Type

Starting timestamp, represented as Date

See Also

CQGTimedBars Collection | CQGTimedBars Members | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

Status Property
CQGTimedBars Collection : Status Property

Glossary Item Box

Description

Returns the status of the timed bars request.

Property type

Read-only property

Syntax

Visual Basic
Public Property Status As eRequestStatus

Return Type

The request status, represented as eRequestStatus Enumeration

Remarks

See eRequestStatus for possible values.

See Also

CQGTimedBars Collection | CQGTimedBars Members | eRequestStatus Enumeration


%%PageItemTitle%%

Tag Property
tag_name

The user-defined value's name.

When setting, the tag_name parameter should keep the key that will be associated with the passed information.

When getting the information from the Tag, one of the previously set keys should be passed as tag_name in order to get the corresponding information.

CQGTimedBars Collection : Tag Property

Glossary Item Box

Description

This property allows the user to keep his/her own information within the timed bars.

Property type

Read-write property

Syntax

Visual Basic
Public Property Tag( _
   ByVal tag_name As String _
) As Variant

Parameters

tag_name

The user-defined value's name.

When setting, the tag_name parameter should keep the key that will be associated with the passed information.

When getting the information from the Tag, one of the previously set keys should be passed as tag_name in order to get the corresponding information.

Return Type

The user-defined value, represented as Variant

Remarks

Multiple data can be kept in the Tag property under different keys.

If no user-defined value with this tag_name exists, Empty is returned.

If empty is set to an existing tag_name, it is deleted/unregistered.

If a new value is set to an existing tag_name, the old value is overwritten.

See Also

CQGTimedBars Collection | CQGTimedBars Members


%%PageItemTitle%%

CQGTimedBarsCollection Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGTimedBars objects.

Object Model

CQGTimedBarsCollection CollectionCQGTimedBars Collection

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTimedBarsCollection Members | CQGTimedBars Collection


%%PageItemTitle%% $$Members$$

CQGTimedBarsCollection Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGTimedBars objects in the collection.
Public Property Item | Returns the CQGTimedBars by its index. This is the default property.
Public Property ItemById | Returns the CQGTimedBars by its unique identifier.

See Also

CQGTimedBarsCollection Collection | CQGTimedBars Collection


%%PageItemTitle%%

_NewEnum Property
CQGTimedBarsCollection Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGTimedBarsCollection Collection | CQGTimedBarsCollection Members


%%PageItemTitle%%

Count Property
CQGTimedBarsCollection Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGTimedBars objects in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of collection items, represented as Long

See Also

CQGTimedBarsCollection Collection | CQGTimedBarsCollection Members | CQGTimedBars Collection


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGTimedBarsCollection Collection : Item Property

Glossary Item Box

Description

Returns the CQGTimedBars by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGTimedBars

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item, represented as CQGTimedBars object

See Also

CQGTimedBarsCollection Collection | CQGTimedBarsCollection Members | CQGTimedBars Collection


%%PageItemTitle%%

ItemById Property
id_
CQGTimedBarsCollection Collection : ItemById Property

Glossary Item Box

Description

Returns the CQGTimedBars by its unique identifier.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemById( _
   ByVal id_ As String _
) As CQGTimedBars

Parameters

id_

Return Type

The corresponding CQGTimedBars object

Remarks

A collection exception will be thrown if no CQGTimedBars exists with the specified unique identifier.

See Also

CQGTimedBarsCollection Collection | CQGTimedBarsCollection Members | CQGTimedBars Collection


%%PageItemTitle%%

CQGTradeEntries Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGTradeEntry objects.

Object Model

CQGTradeEntries CollectionCQGTradeEntry Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTradeEntries Members


%%PageItemTitle%% $$Members$$

CQGTradeEntries Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGTradeEntry objects in the collection.
Public Property Item | Returns the CQGTradeEntry object by its index. This is the default property.

See Also

CQGTradeEntries Collection


%%PageItemTitle%%

_NewEnum Property
CQGTradeEntries Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGTradeEntries Collection | CQGTradeEntries Members


%%PageItemTitle%%

Count Property
CQGTradeEntries Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGTradeEntry objects in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of collection items, represented as Long

See Also

CQGTradeEntries Collection | CQGTradeEntries Members | CQGTradeEntry Interface


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGTradeEntries Collection : Item Property

Glossary Item Box

Description

Returns the CQGTradeEntry object by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGTradeEntry

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item, represented as CQGTradeEntry object

See Also

CQGTradeEntries Collection | CQGTradeEntries Members | CQGTradeEntry Interface


%%PageItemTitle%%

CQGTradeExitDefinitions Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGTradeExitDefinition objects.

Object Model

CQGTradeExitDefinitions CollectionCQGTradeExitDefinition Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTradeExitDefinitions Members | CQGTradeExitDefinition Interface


%%PageItemTitle%% $$Members$$

CQGTradeExitDefinitions Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGTradeExitDefinition in the collection.
Public Property Item | Returns the CQGTradeExitDefinition by its index. This is the default property.
Public Property ItemByName | Returns the corresponding CQGTradeExitDefinition object by its name.

See Also

CQGTradeExitDefinitions Collection | CQGTradeExitDefinition Interface


%%PageItemTitle%%

_NewEnum Property
CQGTradeExitDefinitions Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGTradeExitDefinitions Collection | CQGTradeExitDefinitions Members


%%PageItemTitle%%

Count Property
CQGTradeExitDefinitions Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGTradeExitDefinition in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of CQGTradeExitDefinition objects, represented as Long

See Also

CQGTradeExitDefinitions Collection | CQGTradeExitDefinitions Members | CQGTradeExitDefinition Interface


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGTradeExitDefinitions Collection : Item Property

Glossary Item Box

Description

Returns the CQGTradeExitDefinition by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGTradeExitDefinition

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item represented as CQGTradeExitDefinition object

See Also

CQGTradeExitDefinitions Collection | CQGTradeExitDefinitions Members | CQGTradeExitDefinition Interface


%%PageItemTitle%%

ItemByName Property
exit_name
CQGTradeExitDefinitions Collection : ItemByName Property

Glossary Item Box

Description

Returns the corresponding CQGTradeExitDefinition object by its name.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemByName( _
   ByVal exit_name As String _
) As CQGTradeExitDefinition

Parameters

exit_name

Return Type

The corresponding collection item, represented as CQGTradeExitDefinition

Remarks

A collection exception will be thrown in case of non-existent trade exit name.

See Also

CQGTradeExitDefinitions Collection | CQGTradeExitDefinitions Members | CQGTradeExitDefinition Interface


%%PageItemTitle%%

CQGTradeExits Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGTradeExit objects.

Object Model

CQGTradeExits CollectionCQGTradeExit Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTradeExits Members | CQGTradeExit Interface


%%PageItemTitle%% $$Members$$

CQGTradeExits Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGTradeExit objects in the collection.
Public Property Item | Returns the CQGTradeExit object by its index. This is the default property.
Public Property ItemByName | Returns the corresponding trade exit by its Name.

See Also

CQGTradeExits Collection | CQGTradeExit Interface


%%PageItemTitle%%

_NewEnum Property
CQGTradeExits Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGTradeExits Collection | CQGTradeExits Members


%%PageItemTitle%%

Count Property
CQGTradeExits Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGTradeExit objects in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of collection items, represented as Long

See Also

CQGTradeExits Collection | CQGTradeExits Members | CQGTradeExit Interface


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGTradeExits Collection : Item Property

Glossary Item Box

Description

Returns the CQGTradeExit object by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGTradeExit

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item, represented as CQGTradeExit object

See Also

CQGTradeExits Collection | CQGTradeExits Members | CQGTradeExit Interface


%%PageItemTitle%%

ItemByName Property
exit_name
CQGTradeExits Collection : ItemByName Property

Glossary Item Box

Description

Returns the corresponding trade exit by its Name.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemByName( _
   ByVal exit_name As String _
) As CQGTradeExit

Parameters

exit_name

Return Type

The corresponding collection item, represented as CQGTradeExit

See Also

CQGTradeExits Collection | CQGTradeExits Members | CQGTradeExit Interface


%%PageItemTitle%%

CQGTrades Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGTrade objects.

Object Model

CQGTrades CollectionCQGTrade Interface

Remarks

There are two instances of CQGTrades collection used in CQG API CQGPosition objects: one for open trades, one for matched trades.

Access to an item in this collection can be made by its index. The index is 0 based, i.e. the index of the first item in the collection is 0.

See Accessing non-existent collection items for details on accessing items that do not exist in the collection.

Example

See the usage of CQGTrades collections in the AccountChanged event's example section.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTrades Members


%%PageItemTitle%% $$Members$$

CQGTrades Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of trades in the collection.
Public Property Item | Returns the selected trade by its sequential index. This is the default property.

See Also

CQGTrades Collection


%%PageItemTitle%%

_NewEnum Property
CQGTrades Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGTrades Collection | CQGTrades Members


%%PageItemTitle%%

Count Property
CQGTrades Collection : Count Property

Glossary Item Box

Description

Returns the number of trades in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of trades represented as Long

Example

See the usage of CQGTrades properties in the AccountChanged event's example section.

See Also

CQGTrades Collection | CQGTrades Members | CQGTrade Interface


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGTrades Collection : Item Property

Glossary Item Box

Description

Returns the selected trade by its sequential index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGTrade

Parameters

index_
Zero-based index of item in the collection

Return Type

If the trade exists in the collection, this property returns the selected trade represented as CQGTrade object.

If the accessed item does not exist, see Accessing non-existent collection items to learn more about the return type.

Example

See the usage of CQGTrades properties in the AccountChanged event's example section.

See Also

CQGTrades Collection | CQGTrades Members | CQGTrade Interface


%%PageItemTitle%%

CQGTradingSystemBaseBarParameters Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGTradingSystemBaseBarParameter objects.

Object Model

CQGTradingSystemBaseBarParameters CollectionCQGTradingSystemBaseBarParameter Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTradingSystemBaseBarParameters Members


%%PageItemTitle%% $$Members$$

CQGTradingSystemBaseBarParameters Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGTradingSystemBaseBarParameter objects in the collection.
Public Property Item | Returns the trading system base bar parameter by its type. This is the default property.

See Also

CQGTradingSystemBaseBarParameters Collection


%%PageItemTitle%%

_NewEnum Property
CQGTradingSystemBaseBarParameters Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGTradingSystemBaseBarParameters Collection | CQGTradingSystemBaseBarParameters Members


%%PageItemTitle%%

Count Property
CQGTradingSystemBaseBarParameters Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGTradingSystemBaseBarParameter objects in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of collection items, represented as Long

See Also

CQGTradingSystemBaseBarParameters Collection | CQGTradingSystemBaseBarParameters Members | CQGTradingSystemBaseBarParameter Interface


%%PageItemTitle%%

Item Property
parameter_type
CQGTradingSystemBaseBarParameters Collection : Item Property

Glossary Item Box

Description

Returns the trading system base bar parameter by its type.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal parameter_type As eTradingSystemBaseBarParameter _
) As CQGTradingSystemBaseBarParameter

Parameters

parameter_type
Value Description
bbpAggregation Specifies the aggregation parameter for the PF base bar.

This is a read/write property of eTfAggregation type.

bbpAggregationLevel Specifies the aggregation level parameter for the PF base bar.

This is a read/write property of Long type.

bbpBoxSize Specifies the volume type parameter for the PF base bar.

This is a read/write property of Long type.

bbpBoxUnits Specifies the box units parameter for the PF base bar.

This is a read/write property of ePfBoxUnits type.

bbpDataSource Specifies the data source parameter for the PF base bar.

This is a read/write property of ePfDataSource type.

bbpIncludeFlatTicks Specifies whether flat ticks are included or not in the CVB base bar.

This is a read/write property of Boolean type.

bbpReversal Specifies the reversal parameter for the PF base bar.

This is a read/write property of Long type.

bbpVolumeLevel Specifies the volume level parameter for the CVB base bar.

This is a read/write property of Long type.

bbpVolumeType Specifies the volume type parameter for the CVB base bar.

This is a read/write property of eCvbVolumeType type.

Return Type

The corresponding collection item, represented as CQGTradingSystemBaseBarParameter object

See Also

CQGTradingSystemBaseBarParameters Collection | CQGTradingSystemBaseBarParameters Members | CQGTradingSystemBaseBarParameter Interface


%%PageItemTitle%%

CQGTradingSystemDefinitions Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGTradingSystemDefinition objects.

Object Model

CQGTradingSystemDefinitions CollectionCQGTradingSystemDefinition Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTradingSystemDefinitions Members | CQGTradingSystemDefinition Interface


%%PageItemTitle%% $$Members$$

CQGTradingSystemDefinitions Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGTradingSystemDefinition objects in the collection.
Public Property Item | Returns the corresponding CQGTradingSystemDefinition object by its index. This is the default property.
Public Property ItemByAbbreviation | Returns the CQGTradingSystemDefinition by its abbreviation.
Public Property ItemByName | Returns the corresponding CQGTradingSystemDefinition object by its name.

See Also

CQGTradingSystemDefinitions Collection | CQGTradingSystemDefinition Interface


%%PageItemTitle%%

_NewEnum Property
CQGTradingSystemDefinitions Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGTradingSystemDefinitions Collection | CQGTradingSystemDefinitions Members


%%PageItemTitle%%

Count Property
CQGTradingSystemDefinitions Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGTradingSystemDefinition objects in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of collection items, represented as Long

See Also

CQGTradingSystemDefinitions Collection | CQGTradingSystemDefinitions Members | CQGTradingSystemDefinition Interface


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGTradingSystemDefinitions Collection : Item Property

Glossary Item Box

Description

Returns the corresponding CQGTradingSystemDefinition object by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGTradingSystemDefinition

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item represented as CQGTradingSystemDefinition object

See Also

CQGTradingSystemDefinitions Collection | CQGTradingSystemDefinitions Members | CQGTradingSystemDefinition Interface


%%PageItemTitle%%

ItemByAbbreviation Property
trading_system_abbreviation
CQGTradingSystemDefinitions Collection : ItemByAbbreviation Property

Glossary Item Box

Description

Returns the CQGTradingSystemDefinition by its abbreviation.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemByAbbreviation( _
   ByVal trading_system_abbreviation As String _
) As CQGTradingSystemDefinition

Parameters

trading_system_abbreviation

Return Type

The corresponding collection item, represented as CQGTradingSystemDefinition object

Remarks

A collection exception will be thrown in case of non-existent trading system abbreviation.

See Also

CQGTradingSystemDefinitions Collection | CQGTradingSystemDefinitions Members | CQGTradingSystemDefinition Interface


%%PageItemTitle%%

ItemByName Property
trading_system_name
CQGTradingSystemDefinitions Collection : ItemByName Property

Glossary Item Box

Description

Returns the corresponding CQGTradingSystemDefinition object by its name.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemByName( _
   ByVal trading_system_name As String _
) As CQGTradingSystemDefinition

Parameters

trading_system_name

Return Type

The corresponding collection item, represented as CQGTradingSystemDefinition

Remarks

A collection exception will be thrown in case of non-existent trading system name.

See Also

CQGTradingSystemDefinitions Collection | CQGTradingSystemDefinitions Members | CQGTradingSystemDefinition Interface


%%PageItemTitle%%

CQGTradingSystems Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGTradingSystem objects.

Object Model

CQGTradingSystems CollectionCQGTradingSystem Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTradingSystems Members | CQGTradingSystem Interface


%%PageItemTitle%% $$Members$$

CQGTradingSystems Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Number of CQGTradingSystem objects in the collection.
Public Property Item | Returns the CQGTradingSystem by its index. This is the default property.
Public Property ItemById | Returns the corresponding CQGTradingSystem object by its unique identifier.

See Also

CQGTradingSystems Collection | CQGTradingSystem Interface


%%PageItemTitle%%

_NewEnum Property
CQGTradingSystems Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGTradingSystems Collection | CQGTradingSystems Members


%%PageItemTitle%%

Count Property
CQGTradingSystems Collection : Count Property

Glossary Item Box

Description

Number of CQGTradingSystem objects in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of collection items, represented as Long

See Also

CQGTradingSystems Collection | CQGTradingSystems Members | CQGTradingSystem Interface


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGTradingSystems Collection : Item Property

Glossary Item Box

Description

Returns the CQGTradingSystem by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGTradingSystem

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item represented as CQGTradingSystem object

See Also

CQGTradingSystems Collection | CQGTradingSystems Members | CQGTradingSystem Interface


%%PageItemTitle%%

ItemById Property
id_
CQGTradingSystems Collection : ItemById Property

Glossary Item Box

Description

Returns the corresponding CQGTradingSystem object by its unique identifier.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemById( _
   ByVal id_ As String _
) As CQGTradingSystem

Parameters

id_

Return Type

The corresponding collection item, represented as CQGTradingSystem

Remarks

A collection exception will be thrown if no CQGTradingSystem exists with the specified unique identifier.

See Also

CQGTradingSystems Collection | CQGTradingSystems Members | CQGTradingSystem Interface


%%PageItemTitle%%

CQGTradingSystemStatisticsCollection Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGTradingSystemStatistics.

Object Model

CQGTradingSystemStatisticsCollection CollectionCQGTradingSystemStatistics Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTradingSystemStatisticsCollection Members | CQGTradingSystemStatistics Interface


%%PageItemTitle%% $$Members$$

CQGTradingSystemStatisticsCollection Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method IndexForDate | Returns the start index for the specified date.
Public Method IndicesForDates | Returns the start and end indices for the specified dates.

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of all records in the collection.
Public Property Item | Returns the CQGTradingSystemStatistics object by its index. This is the default property.

See Also

CQGTradingSystemStatisticsCollection Collection | CQGTradingSystemStatistics Interface


%%PageItemTitle%%

IndexForDate Method
date_

Specifies date, in the user-configured time zone (see CQGAPIConfig.TimeZoneCode)

CQGTradingSystemStatisticsCollection Collection : IndexForDate Method

Glossary Item Box

Description

Returns the start index for the specified date.

Syntax

Visual Basic
Public Function IndexForDate( _
   ByVal date_ As Date _
) As Long

Parameters

date_

Specifies date, in the user-configured time zone (see CQGAPIConfig.TimeZoneCode)

Return Type

Start index, represented as Long

Remarks

If in this CQGTradingSystemStatisticsCollection there are CQGTradingSystemStatistics objects having their Timestamps equal to date_, the first such record's index is returned.

Otherwise, the returned value will be invalid.

See Also

CQGTradingSystemStatisticsCollection Collection | CQGTradingSystemStatisticsCollection Members | CQGTradingSystemStatistics Interface | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

IndicesForDates Method
date_1

Specifies the first date, in the user-configured time zone (CQGAPIConfig.TimeZoneCode)

date_2

Specifies the second date, in the user-configured time zone (CQGAPIConfig.TimeZoneCode)

start_index

Specifies the start index to be set

end_index

Specifies the end index to be set

CQGTradingSystemStatisticsCollection Collection : IndicesForDates Method

Glossary Item Box

Description

Returns the start and end indices for the specified dates.

Syntax

Visual Basic
Public Sub IndicesForDates( _
   ByVal date_1 As Date, _
   ByVal date_2 As Date, _
   ByRef start_index As Long, _
   ByRef end_index As Long _
)

Parameters

date_1

Specifies the first date, in the user-configured time zone (CQGAPIConfig.TimeZoneCode)

date_2

Specifies the second date, in the user-configured time zone (CQGAPIConfig.TimeZoneCode)

start_index

Specifies the start index to be set

end_index

Specifies the end index to be set

Remarks

If in this CQGTradingSystemStatisticsCollection there are CQGTradingSystemStatistics objects having their Timestamps in the range [date_1, date_2), then after the call the range [start_index, end_index] will specify the indices of all such CQGTradingSystemStatistics objects.

An exception is thrown if date_1 is not earlier than date_2.

Otherwise if no such record exists, both start_index and end_index will be invalid.

See Also

CQGTradingSystemStatisticsCollection Collection | CQGTradingSystemStatisticsCollection Members | CQGAPIConfig.TimeZoneCode Property | CQGTradingSystemStatistics Interface


%%PageItemTitle%%

_NewEnum Property
CQGTradingSystemStatisticsCollection Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGTradingSystemStatisticsCollection Collection | CQGTradingSystemStatisticsCollection Members


%%PageItemTitle%%

Count Property
CQGTradingSystemStatisticsCollection Collection : Count Property

Glossary Item Box

Description

Returns the number of all records in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of collection items, represented as Long

See Also

CQGTradingSystemStatisticsCollection Collection | CQGTradingSystemStatisticsCollection Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGTradingSystemStatisticsCollection Collection : Item Property

Glossary Item Box

Description

Returns the CQGTradingSystemStatistics object by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGTradingSystemStatistics

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item, represented as CQGTradingSystemStatistics object

Remarks

A CQGTradingSystemStatistics object will be created upon request and passed to the user without storing it.

Two sequential requests for the same record may return different objects.

See Also

CQGTradingSystemStatisticsCollection Collection | CQGTradingSystemStatisticsCollection Members | CQGTradingSystemStatistics Interface


%%PageItemTitle%%

CQGTradingSystemTradeDefinitions Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGTradingSystemTradeDefinition objects.

Object Model

CQGTradingSystemTradeDefinitions CollectionCQGTradingSystemTradeDefinition Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTradingSystemTradeDefinitions Members | CQGTradingSystemDefinition Interface


%%PageItemTitle%% $$Members$$

CQGTradingSystemTradeDefinitions Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of CQGTradingSystemTradeDefinition objects in the collection.
Public Property Item | Returns the corresponding CQGTradingSystemTradeDefinition object by its index. This is the default property.
Public Property ItemByName | Returns the CQGTradingSystemTradeDefinition by name.

See Also

CQGTradingSystemTradeDefinitions Collection | CQGTradingSystemDefinition Interface


%%PageItemTitle%%

_NewEnum Property
CQGTradingSystemTradeDefinitions Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGTradingSystemTradeDefinitions Collection | CQGTradingSystemTradeDefinitions Members


%%PageItemTitle%%

Count Property
CQGTradingSystemTradeDefinitions Collection : Count Property

Glossary Item Box

Description

Returns the number of CQGTradingSystemTradeDefinition objects in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of collection items, represented as Long

See Also

CQGTradingSystemTradeDefinitions Collection | CQGTradingSystemTradeDefinitions Members | CQGTradingSystemTradeDefinition Interface


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGTradingSystemTradeDefinitions Collection : Item Property

Glossary Item Box

Description

Returns the corresponding CQGTradingSystemTradeDefinition object by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGTradingSystemTradeDefinition

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item, represented as CQGTradingSystemTradeDefinition object

See Also

CQGTradingSystemTradeDefinitions Collection | CQGTradingSystemTradeDefinitions Members | CQGTradingSystemTradeDefinition Interface


%%PageItemTitle%%

ItemByName Property
trade_name
CQGTradingSystemTradeDefinitions Collection : ItemByName Property

Glossary Item Box

Description

Returns the CQGTradingSystemTradeDefinition by name.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemByName( _
   ByVal trade_name As String _
) As CQGTradingSystemTradeDefinition

Parameters

trade_name

Return Type

The corresponding collection item, represented as CQGTradingSystemTradeDefinition

Remarks

A collection exception will be thrown in case of non-existent trade name.

See Also

CQGTradingSystemTradeDefinitions Collection | CQGTradingSystemTradeDefinitions Members | CQGTradingSystemTradeDefinition Interface


%%PageItemTitle%%

CQGTradingSystemTradesRow Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGTradingSystemTrade objects.

Object Model

CQGTradingSystemTradesRow CollectionCQGTradingSystemTrade Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTradingSystemTradesRow Members | CQGTradingSystemTrade Interface


%%PageItemTitle%% $$Members$$

CQGTradingSystemTradesRow Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of all records in the collection.
Public Property Item | Returns the CQGTradingSystemTrade by its index. This is the default property.
Public Property ItemByName | Returns the CQGTradingSystemTrade by its name.
Public Property Timestamp | Returns the timestamp, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).
Public Property TimestampOffset | Returns the timestamp offset, which is used to identify various CQGTradingSystemTradesRow objects that have the same timestamp.

See Also

CQGTradingSystemTradesRow Collection | CQGTradingSystemTrade Interface


%%PageItemTitle%%

_NewEnum Property
CQGTradingSystemTradesRow Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGTradingSystemTradesRow Collection | CQGTradingSystemTradesRow Members


%%PageItemTitle%%

Count Property
CQGTradingSystemTradesRow Collection : Count Property

Glossary Item Box

Description

Returns the number of all records in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of collection items, represented as Long

See Also

CQGTradingSystemTradesRow Collection | CQGTradingSystemTradesRow Members | CQGTradingSystemTrade Interface


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGTradingSystemTradesRow Collection : Item Property

Glossary Item Box

Description

Returns the CQGTradingSystemTrade by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGTradingSystemTrade

Parameters

index_
Zero-based index of item in the collection

Remarks

A CQGTradingSystemTrade object will be created upon request and passed to the user without storing it.

2 sequential requests for the same record may return different objects.

See Also

CQGTradingSystemTradesRow Collection | CQGTradingSystemTradesRow Members | CQGTradingSystemTrade Interface


%%PageItemTitle%%

ItemByName Property
trade_name
CQGTradingSystemTradesRow Collection : ItemByName Property

Glossary Item Box

Description

Returns the CQGTradingSystemTrade by its name.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemByName( _
   ByVal trade_name As String _
) As CQGTradingSystemTrade

Parameters

trade_name

Return Type

THe corresponding collection item, represented as CQGTradingSystemTrade object

See Also

CQGTradingSystemTradesRow Collection | CQGTradingSystemTradesRow Members | CQGTradingSystemTrade Interface


%%PageItemTitle%%

Timestamp Property
CQGTradingSystemTradesRow Collection : Timestamp Property

Glossary Item Box

Description

Returns the timestamp, in the user-configured time zone (CQGAPIConfig.TimeZoneCode).

Property type

Read-only property

Syntax

Visual Basic
Public Property Timestamp As Date

Return Type

Timestamp, represented as Date

See Also

CQGTradingSystemTradesRow Collection | CQGTradingSystemTradesRow Members | CQGTradingSystemTrade Interface | CQGAPIConfig.TimeZoneCode Property


%%PageItemTitle%%

TimestampOffset Property
CQGTradingSystemTradesRow Collection : TimestampOffset Property

Glossary Item Box

Description

Returns the timestamp offset, which is used to identify various CQGTradingSystemTradesRow objects that have the same timestamp.

Property type

Read-only property

Syntax

Visual Basic
Public Property TimestampOffset As Long

Return Type

Timestamp offset, represented as Long

Remarks

The TimestampOffset value grows for subsequent objects. It resets when the timestamp is changed.

See Also

CQGTradingSystemTradesRow Collection | CQGTradingSystemTradesRow Members


%%PageItemTitle%%

CQGTradingSystemTradesRows Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGTradingSystemTrade objects.

Object Model

CQGTradingSystemTradesRows CollectionCQGTradingSystemTradesRow Collection

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTradingSystemTradesRows Members | CQGTradingSystemTradesRow Collection


%%PageItemTitle%% $$Members$$

CQGTradingSystemTradesRows Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of all records in the collection.
Public Property Item | Returns the CQGTradingSystemTradesRow by its index. This is the default property.

See Also

CQGTradingSystemTradesRows Collection | CQGTradingSystemTradesRow Collection


%%PageItemTitle%%

_NewEnum Property
CQGTradingSystemTradesRows Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGTradingSystemTradesRows Collection | CQGTradingSystemTradesRows Members


%%PageItemTitle%%

Count Property
CQGTradingSystemTradesRows Collection : Count Property

Glossary Item Box

Description

Returns the number of all records in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of collection items, represented as Long

See Also

CQGTradingSystemTradesRows Collection | CQGTradingSystemTradesRows Members | CQGTradingSystemTradesRow Collection


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGTradingSystemTradesRows Collection : Item Property

Glossary Item Box

Description

Returns the CQGTradingSystemTradesRow by its index.

This is the default property.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGTradingSystemTradesRow

Parameters

index_
Zero-based index of item in the collection

Return Type

The corresponding collection item, represented as CQGTradingSystemTradesRow object

See Also

CQGTradingSystemTradesRows Collection | CQGTradingSystemTradesRows Members | CQGTradingSystemTradesRow Collection


%%PageItemTitle%%

CQGTransactions Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGTransaction objects.

Object Model

CQGTransactions CollectionCQGTransaction Interface

Remarks

Access to an item in this collection can be made based on either Transaction ID or sequential index.

See Accessing non-existent collection items for details on accessing items that do not exist in the collection.

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGTransactions Members | CQGTransaction Interface


%%PageItemTitle%% $$Members$$

CQGTransactions Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of the transactions in the collection.
Public Property Item | Returns a transaction by its CQGTransaction.Id.
Public Property ItemByIndex | Returns the transaction by its sequential index.

See Also

CQGTransactions Collection | CQGTransaction Interface


%%PageItemTitle%%

_NewEnum Property
CQGTransactions Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGTransactions Collection | CQGTransactions Members


%%PageItemTitle%%

Count Property
CQGTransactions Collection : Count Property

Glossary Item Box

Description

Returns the number of the transactions in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

Return Type

Number of transactions, represented as Long

See Also

CQGTransactions Collection | CQGTransactions Members | CQGTransaction Interface


%%PageItemTitle%%

Item Property
id_
CQGTransactions Collection : Item Property

Glossary Item Box

Description

Returns a transaction by its CQGTransaction.Id.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal id_ As String _
) As CQGTransaction

Parameters

id_

Return Type

Transaction object, represented as CQGTransaction.

If the accessed item does not exist, see Accessing non-existent collection items to learn more about the return type.

Remarks

A collection exception will be thrown if no transaction exists with the specified identifier.

See Also

CQGTransactions Collection | CQGTransactions Members | CQGTransaction Interface


%%PageItemTitle%%

ItemByIndex Property
index_
Zero-based index of item in the collection
CQGTransactions Collection : ItemByIndex Property

Glossary Item Box

Description

Returns the transaction by its sequential index.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemByIndex( _
   ByVal index_ As Long _
) As CQGTransaction

Parameters

index_
Zero-based index of item in the collection

Return Type

Transaction object, represented as CQGTransaction.

If the accessed item does not exist, see Accessing non-existent collection items to learn more about the return type.

Remarks

A collection exception will be thrown if index is out of range.

See Also

CQGTransactions Collection | CQGTransactions Members | CQGTransaction Interface


%%PageItemTitle%%

CQGYields Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGYield objects.

Object Model

CQGYields CollectionCQGYield Interface

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGYields Members


%%PageItemTitle%% $$Members$$

CQGYields Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Methods

Public Method IndexForDate Returns start index for specified date

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of all yields in the collection
Public Property EndTimestamp | Returns the ending (maximum) timestamp of all arrived yields so far, in user configured time zone (CQGAPIConfig.TimeZoneCode)
Public Property Id | Returns the unique identifier of yields
Public Property Item | Returns the CQGYield by its index
Public Property LastError | Returns CQGError object describing the last error occurred to this object
Public Property Request | Returns the read-only copy of CQGYieldsRequest object
Public Property StartTimestamp | Returns the starting (minimum) timestamp of all arrived yields, in user configured time zone (CQGAPIConfig.TimeZoneCode)
Public Property Status | Returns the status
Public Property Tag | Returns a user defined value

See Also

CQGYields Collection


%%PageItemTitle%%

IndexForDate Method
date_
Date for which index is needed
CQGYields Collection : IndexForDate Method

Glossary Item Box

Description

Returns start index for specified date

Syntax

Visual Basic
Public Function IndexForDate( _
   ByVal date_ As Date _
) As Long

Parameters

date_
Date for which index is needed

See Also

CQGYields Collection | CQGYields Members


%%PageItemTitle%%

_NewEnum Property
CQGYields Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGYields Collection | CQGYields Members


%%PageItemTitle%%

Count Property
CQGYields Collection : Count Property

Glossary Item Box

Description

Returns the number of all yields in the collection

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

CQGYields Collection | CQGYields Members


%%PageItemTitle%%

EndTimestamp Property
CQGYields Collection : EndTimestamp Property

Glossary Item Box

Description

Returns the ending (maximum) timestamp of all arrived yields so far, in user configured time zone (CQGAPIConfig.TimeZoneCode)

Property type

Read-only property

Syntax

Visual Basic
Public Property EndTimestamp As Date

See Also

CQGYields Collection | CQGYields Members


%%PageItemTitle%%

Id Property
CQGYields Collection : Id Property

Glossary Item Box

Description

Returns the unique identifier of yields

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

CQGYields Collection | CQGYields Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGYields Collection : Item Property

Glossary Item Box

Description

Returns the CQGYield by its index

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGYield

Parameters

index_
Zero-based index of item in the collection

See Also

CQGYields Collection | CQGYields Members


%%PageItemTitle%%

LastError Property
CQGYields Collection : LastError Property

Glossary Item Box

Description

Returns CQGError object describing the last error occurred to this object

Property type

Read-only property

Syntax

Visual Basic
Public Property LastError As CQGError

See Also

CQGYields Collection | CQGYields Members


%%PageItemTitle%%

Request Property
CQGYields Collection : Request Property

Glossary Item Box

Description

Returns the read-only copy of CQGYieldsRequest object

Property type

Read-only property

Syntax

Visual Basic
Public Property Request As CQGYieldsRequest

See Also

CQGYields Collection | CQGYields Members


%%PageItemTitle%%

StartTimestamp Property
CQGYields Collection : StartTimestamp Property

Glossary Item Box

Description

Returns the starting (minimum) timestamp of all arrived yields, in user configured time zone (CQGAPIConfig.TimeZoneCode)

Property type

Read-only property

Syntax

Visual Basic
Public Property StartTimestamp As Date

See Also

CQGYields Collection | CQGYields Members


%%PageItemTitle%%

Status Property
CQGYields Collection : Status Property

Glossary Item Box

Description

Returns the status

Property type

Read-only property

Syntax

Visual Basic
Public Property Status As eRequestStatus

See Also

CQGYields Collection | CQGYields Members


%%PageItemTitle%%

Tag Property
tag_name
CQGYields Collection : Tag Property

Glossary Item Box

Description

Returns a user defined value

Property type

Read-write property

Syntax

Visual Basic
Public Property Tag( _
   ByVal tag_name As String _
) As Variant

Parameters

tag_name

See Also

CQGYields Collection | CQGYields Members


%%PageItemTitle%%

CQGYieldsCollection Collection
See Also Members Send Feedback

Glossary Item Box

Description

Represents a collection of CQGYields objects.

Object Model

CQGYieldsCollection CollectionCQGYields Collection

Example

For additional examples and samples of the usage of this functionality, please go to the API web page.

See Also

CQGYieldsCollection Members


%%PageItemTitle%% $$Members$$

CQGYieldsCollection Collection Members
See Also Overview Send Feedback

Glossary Item Box

Public Properties

Public Property _NewEnum | Returns the new enumerator
Public Property Count | Returns the number of all yields in the collection
Public Property Item | Returns the yields by its index
Public Property ItemById | Returns the yields by its id

See Also

CQGYieldsCollection Collection


%%PageItemTitle%%

_NewEnum Property
CQGYieldsCollection Collection : _NewEnum Property

Glossary Item Box

Description

Returns the new enumerator

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum As IEnumVARIANT

See Also

CQGYieldsCollection Collection | CQGYieldsCollection Members


%%PageItemTitle%%

Count Property
CQGYieldsCollection Collection : Count Property

Glossary Item Box

Description

Returns the number of all yields in the collection

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

CQGYieldsCollection Collection | CQGYieldsCollection Members


%%PageItemTitle%%

Item Property
index_
Zero-based index of item in the collection
CQGYieldsCollection Collection : Item Property

Glossary Item Box

Description

Returns the yields by its index

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal index_ As Long _
) As CQGYields

Parameters

index_
Zero-based index of item in the collection

See Also

CQGYieldsCollection Collection | CQGYieldsCollection Members


%%PageItemTitle%%

ItemById Property
id_
CQGYieldsCollection Collection : ItemById Property

Glossary Item Box

Description

Returns the yields by its id

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemById( _
   ByVal id_ As String _
) As CQGYields

Parameters

id_

See Also

CQGYieldsCollection Collection | CQGYieldsCollection Members


%%PageItemTitle%%

CQGCELConfiguration UDT
See Also Members Send Feedback

Glossary Item Box

Description

Defines various CQGCEL configuration options and parameters.
Deprecated!

UDT Members

Member | Type | Description
DefaultInstrumentSubscriptionLevel | eDataSubscriptionLevel | The default data subscription level setting. Allows to configure the initial data subscription level of subscribed instruments. The default value is dsQuotesAndBBA.
DOMUpdatesMode | eDOMUpdatesMode | Mode of DOM updates sending.
DOMUpdatesPeriod | Long | Time period indicating the time interval for DOM updates sending.
LogSeverity | eLogSeverity | Logging severity
MaxLogFileCount | Long | Maximum number of log files.
MaxLogFileDuration | Date | The log file duration time period represented as Date.
MaxLogFileSize | Long | Maximum size of a log file in KB.
MetaDataEnabled | Boolean | Reserved for future use.
ReadyStatusCheck | eReadyStatusCheck | State of application ready status checking
TimeZoneCode | eTimeZone | The timezone code to adjust all reported dates to. The default value is UTC time.

Remarks

Important note: Starting from version 3.0 of CQG API, CQGCELConfiguration is deprecated and the configuration is managed through the CQGAPIConfig interface.

This structure persists only for backward compatibility.


%%PageItemTitle%%

eAccountChangeType Enumeration

Glossary Item Box

Description

Specifies the type of account/position change passed to the AccountChanged event.

Members

Member Value Description
actAccountChanged 1

An account-specific change occurred, e.g. date of last statement is changed.

After an event of this type, another AccountChange event of actPositionsReloaded type will be fired.

An event of this type is also fired for each account if the account subscription level is set from aslAccountsOnly to aslAccountsAndUpdates.

actAccountsReloaded 0

All accounts are reloaded.

This change type is passed in two cases:

  • when the user logs on to CQG Gateway from CQGIC
  • when the user programmatically switches initial account subscription level to aslNone and then back.
actPositionAdded 3 A new position is created.

For example, due to trading new instruments.

actPositionChanged 4 A position-specific change occurred, e.g. position quantity or price is changed.

The number of fired events of this type depends on the FireEventOnChangedPrices configuration setting.

See the FireEventsOnChangedPrices configuration setting for possible options of controlling the flow of position changed events.

actPositionsReloaded 2
  • All positions of an account are reloaded.

    There are many cases when this change type is passed. For example:

    • when we change position subscription level from pslNoPositions to any other value
    • when an account-specific change occurs for the current account
    • when CQG Gateway environment change occurs, etc.
actTradersReloaded 5

Authorized traders of accounts are reloaded.


%%PageItemTitle%%

eAccountMarginDetailing Enumeration

Glossary Item Box

Description

Defines level of account margin info detailing

Members

Member | Value | Description
amdMarginSnapshot | 1 | Margin information is obtained for the account, but not updated
amdMarginSnapshotAndUpdate | 2 | Margin information with updates
amdNoMargin | 0 | No margin information should be provided in account


%%PageItemTitle%%

eAccountSubscriptionLevel Enumeration

Glossary Item Box

Description

Specifies event subscription levels for accounts.

Members

Member Value Description
aslAccountsAndUpdates 2 Accounts are obtained, fully refreshed and all account updates are fired as well, e.g. balance changes, currency changes etc.

Position updates are controlled by ePositionSubscriptionLevel property of each account.

If subscription level was set to aslAccountsOnly and then set to aslAccountsAndUpdates, an AccountChanged event will be fired with actAccountsReloaded type. Further account updates will be received via AccountChanged event of actAccountChanged type. For details of this event type see description of eAccountChangeType.actAccountChanged.

aslAccountsOnly 1 Accounts are obtained and fully refreshed once, but no account updates are received after that.

To update the collection in this case the user must set the subscription level to aslNone and back to aslAccountsOnly.

aslAccountUpdatesAndChildOrders 4

The same as aslAccountUpdatesAndOrders subscription level with addition of child orders related fuctionality and events.

This works as a switch: if the level is less than aslAccountsUpdatesAndOrders then no orders related functionality is available via CQG API.

aslAccountUpdatesAndOrders 3

The same as aslAccountsAndUpdates subscription level with addition of orders related functionality and events.

This works as a switch: if the level is less than aslAccountsUpdatesAndOrders then no orders related functionality is available via CQG API.

aslNone 0 No account information is provided.

This also works as a switch for CQG API 3.0 (and higher) functionality, i.e. if aslNone is set then only functionality of CQG API v.1.1 will be available.

This is the default value.

When initially set the CQGCEL.Accounts collection remains empty.

When this value is set after some other value then CQGCEL.Accounts collection will not be emptied, i.e. will remain in the same state as it was when setting to aslNone.

If the CQG Gateway connection is lost, after it is up again the CQGCEL.AccountSubscriptionLevel is reset to aslNone.

When the subscription level is changed from aslNone an AccountChanged event will be fired with actAccountsReloaded type.

Remarks

This is a general setting that covers all accounts.


%%PageItemTitle%%

eAlgorithmicOrderPropertyType Enumeration

Glossary Item Box

Description

Indicates the algorithmic order property type.

Members

Member | Value | Description
aoptBoolean | 5 | Boolean type
aoptDateTime | 4 | DateTime type
aoptDouble | 2 | Double type
aoptInt | 0 | Integer type
aoptList | 6 | List type
aoptString | 3 | String type
aoptUInt | 1 | Unsigned Integer type


%%PageItemTitle%%

eBrickUnit Enumeration

Glossary Item Box

Description

Specifies Renko 'Brick Unit' property value

Members

Member | Value | Description
buPrice | 1 | Units bricks are measured in price
buTick | 0 | Units bricks are measured in ticks


%%PageItemTitle%%

eChangeType Enumeration

Glossary Item Box

Description

Specifies the possible type of order change, passed as an argument to OrderChanged event.

Members

Member | Value | Description
ctAdded | 0 | New order is added and is already in the collection.
ctChanged | 1 | The order is changed.
ctRemoved | 2 | The order is removed from the collection.


%%PageItemTitle%%

ECompoundOrderType Enumeration

Glossary Item Box

Description

Represends compound order type.

Members

Member | Value | Description
coOCO | 1 | Order-Cancels-Orders type. The order consists of several parts (legs, orders from CQGOrderChain). If one part (leg) of the order is executed, then all other parts (legs) are canceled.
coOPO | 0 | Order-Places-Order type. The order consists of several parts (legs, orders from CQGOrderChain). Initially, only the first part (leg) is active (in a working state) and all others are in a waiting state (corresponds to osContingent order status). When the active part (leg) is executed, all other parts (legs) become active.

See Also

PlaceCompoundOrderEx Method | ModifyCompoundOrderEx Method | CQGOrderChain Interface


%%PageItemTitle%%

eConnectionStatus Enumeration

Glossary Item Box

Description

Indicates the connection status of CQG data server or CQG gateway.

Members

Member | Value | Description
csConnectionDelayed | 1 | Connection is delayed.
csConnectionDown | 2 | Connection is down.
csConnectionNotLoggedOn | 4 | Connected but not logged on Gateway.
csConnectionTrouble | 3 | Trouble with Gateway connection.
csConnectionUp | 0 | Connection is up.

Remarks

Whenever the data or GW connection goes down, all corresponding CEL objects should be considered obsolete. Therefore, when the connection is reestablished, fresh queries should be conducted.

See Also

DataConnectionStatusChanged Event | DataConnectionStatus Property


%%PageItemTitle%%

eCvbVolumeType Enumeration

Glossary Item Box

Description

Indicates the constant volume bars' volume type.

Members

Member | Value | Description
cvbvtActual | 1 | Actual
cvbvtTicks | 0 | Ticks


%%PageItemTitle%%

eDailyBarClose Enumeration

Glossary Item Box

Description

Specifies a daily bar close setting value that the system should use to calculate close

Members

Member | Value | Description
dbcDefault | 0 | Default
dbcLastQuote | 1 | Last Quote
dbcLastQuoteOrSettlement | 2 | Last Quote or Settlement
dbcSettlementOrLastQuote | 3 | Settlement or Last Quote


%%PageItemTitle%%

eDataSourceStatus Enumeration

Glossary Item Box

Description

Indicates the data source status.

Members

Member | Value | Description
dssAvailable | 1 | Data source is available.
dssDelay | 2 | Data source is available with delay.
dssDisabled | 0 | Data source is disabled.
dssExtraDelay | 3 | Data source is available with extra delay.
dssSnapshot | 4 | Data source is available as snapshot.

See Also

CQGDataSource.Status Property


%%PageItemTitle%%

eDataSubscriptionLevel Enumeration

Glossary Item Box

Description

Specifies the data subscription level for a CQGInstrument.

Members

Member | Value | Description
dsDisable | 5 | This level means that instrument is working with the new mode CQGAPIConfig.NewInstrumentMode.
dsGroup | 4 | The instrument is a part of a group and the level is accessible via eGroupSubscriptionLevel.
dsNone | 0 | No subscription. Nothing is updated.
dsQuotes | 1 | Subscription to receive trade and dynamic properties updates.
dsQuotesAndBBA | 2 | Subscription to receive trade, dynamic properties as well as bid and ask updates.
dsQuotesAndDOM | 3 | Subscription to all possible data: quotes, dynamic properties and full DOM.

Example

See the examples section in CQGCEL InstrumentSubscribed Event.

See Also

CQGQuote Interface | CQGInstrumentProperty Interface


%%PageItemTitle%%

eDelayMode Enumeration

Glossary Item Box

Description

Specifies an instrument's delay mode

Members

Member | Value | Description
dmDelay | 2 | Instrument data is provided with regular delay (according to enablements)
dmEndOfDayDelay | 3 | Instrument data is provided with end of day delay
dmNoDelay | 1 | Instrument data is provided without delay
dmUndefined | 0 | Undefined delay mode (Instrument delay mode detection is in progress)

Remarks

The exact delay value can be found in ipDelayPeriod proprerty of Instrument's Properties.


%%PageItemTitle%%

eDOMandBBAType Enumeration

Glossary Item Box

Description

Indicates DOM and BBA type.

Members

Member | Value | Description
dbtCombined | 4 | Combined DOM and BBA type. (Summary of outright and implied types).
dbtImplied | 1 | Implied DOM and BBA type.
dbtOutright | 2 | Outright DOM and BBA type.

Remarks

This is used in the CQGInstrument.BBAType and CQGAPIConfig.DefaultInstrumentBBAType properties.

See Also

CQGInstrument.BBAType Property | CQGAPIConfig.DefaultInstrumentBBAType


%%PageItemTitle%%

eDOMUpdatesMode Enumeration

Glossary Item Box

Description

Represents possible modes of DOM data updates.

All modes depend on the value of the update period, which is set from configuration.

Members

Member | Value | Description
domUMDynamic | 0 | Dynamic update mode. In this mode a DOM update is sent only if DOM changes after time period expiration.
domUMSnapshot | 1 | Snapshot update mode. In this mode when the time period expires the current (last before time expiration) DOM book is sent as an update.

Remarks

In case the dynamic mode is set, DOM updates will be sent not earlier than the time period given in the CQGAPIConfig.DOMUpdatesPeriod property.

In case of the snapshot mode, DOM updates will be sent with period equal to the time period given in the CQGAPIConfig.DOMUpdatesPeriod property.

If there are no DOM updates during the time period, no DOM updates will be sent in either mode.

If the time period is set to 0 both modes behave the same way - updates will be sent on each DOM change.

See Also

CQGAPIConfig.DOMUpdatesPeriod


%%PageItemTitle%%

EExchangeState Enumeration

Glossary Item Box

Description

Enumerates possible exchange states.

Members

Member | Value | Description
xsClosed | 4 | Order placement is not allowed; there are no quotes besides the end-of-day summary (Settlement, Open Interest, end-of-day total volume) that can follow; the DOM book is empty.
xsHalted | 1 | The trading is "halted" unexpectedly, order matching is not allowed, and order placement and cancellation depend on the particular exchange.
xsOpen | 3 | Order placement is allowed, bid/ask quotes can follow, matching and filling are functioning, trade messages are expected, and the DOM book cannot be crossed in the trading state.
xsPreOpening | 2 | Trading is not started, order placement is allowed, bid/ask quotes can follow, and the DOM book can be crossed because there is no matching in the out-of-trading state.
xsSuspended | 5 | "Suspended" is externally (regulation authorities) initiated interruption in trading that could last several days; this state should be considered as an extended "Halt" state - there are no bid/ask quotes, and the DOM book is in an unknown state due to order cancelation allowed.
xsUnknown | 0 | No info on Exchange State.


%%PageItemTitle%%

eExecutionPatternParameterType Enumeration

Glossary Item Box

Description

Indicates execution pattern parameter types.

Members

Member | Value | Description
epptBool | 0 | Boolean type
epptCollection | 5 | Collection type
epptCollectionItem | 6 | Collection item type
epptDouble | 2 | Double type
epptInt32 | 1 | Integer type
epptObject | 4 | Object type
epptString | 3 | String type


%%PageItemTitle%%

EExtendedSide Enumeration

Glossary Item Box

Description

Specifies special/extended order side.

Members

Member | Value | Description
esSellShort 1

In context of equity markets, this means a sell order for shares you do not own. Unlike futures markets, most equity markets require that a short seller makes arrangements to borrow the shares (and pays a fee to the owner to do so) before selling.

In some cases, the short sell order itself requires to identify where (from which broker/participant) the shares will be borrowed, see opLocateID order property.

esUndefined | 0 | No extended side.


%%PageItemTitle%%

eFcmClass Enumeration

Glossary Item Box

Description

Specifies the FCM class.

Members

Member | Value | Description
fcDerivative | 0 | Futures and options.
fcFixedIncome | 1 | Fixed Income.
fcForex | 2 | Forex.


%%PageItemTitle%%

eFillEffect Enumeration

Glossary Item Box

Description

Specifies whether the fill is opening/increasing or closing/reducing a position

Members

Member | Value | Description
feClose | 2 | Close position
feClosePrevious | 3 | Close previous day position
feOpen | 1 | Opens position
feUndefined | 0 | Undefined


%%PageItemTitle%%

eFillStatus Enumeration

Glossary Item Box

Description

Represents possible statuses of the order.

Members

Member | Value | Description
fsBusted | 3 | Fill is busted.
fsCanceled | 1 | Fill is canceled.
fsModified | 2 | Fill is modified. When a fill is modified, the collection of fills contains the new fill, which replaced this one.
fsNormal | 0 | Normal fill. A fill with this status changes the position.


%%PageItemTitle%%

eGapFilter Enumeration

Glossary Item Box

Description

Defines gap filter of sub minute bars request

Members

Member | Value | Description
gfAllowGaps | 0 | Allow gaps
gfFillGap | 2 | Fill gap
gfNoGap | 1 | No gap


%%PageItemTitle%%

EGroupPropertySubscriptionLevel Enumeration

Glossary Item Box

Description

Specifies the CQGInstrumentsGroupRequest.PropertyLevel value.

Members

Member | Value | Description
gpsDefault | 0 | The default value that does not include any additional dynamic properties.
gpsGreeks | 1 | Subscribes to ipDelta, ipDeltaNetChange, ipTheta, ipThetaNetChange, ipGamma, ipGammaNetChange, ipVega, ipVegaNetChange, ipRho, and ipRhoNetChange.
gpsTheoreticalValue | 4 | Subscribes to ipTheoreticalValue and ipTheoValueNetChange.
gpsVolatility | 2 | Subscribes to ipAverageVolatility, ipImpliedVolatility, ipImpliedVolatilityOnAsk, ipImpliedVolatilityOnBid, ipImpliedVolatilityNetChange, and ipVolatilityCurve.

Remarks

Values can be combined into single bit-mask value.

See Also

CQGInstrumentsGroupRequest Interface | PropertyLevel Property | CQGInstrumentProperties Collection | eInstrumentProperty Enumeration


%%PageItemTitle%%

eGroupSubscriptionLevel Enumeration

Glossary Item Box

Description

Indicates the subscription levels for instruments group.

Members

Member | Value | Description
gslFullSnapshot | 2 | Full data without Implied/Outright quotes.
gslFullUpdates | 3 | Only common properties and quotes with timestamps. Updates will be received.
gslRealtimeSnapshot | 0 | Only common properties and quotes without timestamps
gslRealtimeUpdates | 1 | Full data without Implied/Outright quotes. Updates will be received.

Remarks

Depending on the subscription level, the following instrument properties will be available:

Data | Level of subscription: API streaming data |  | Level of subscription: Full data
 | gslRealtimeSnapshot | gslRealtimeUpdates | gslFullSnapshot | gslFullUpdates
ipFullName | X | X | X | X
ipDescription | X | X | X | X
ipInstrumentID | X | X | X | X
ipExpirationDate | X | X | X | X
ipDTE |  |  | X | X
ipInitialMargin |  |  |  |
ipMaintenanceMargin |  |  |  |
ipSessionMask | X | X | X | X
ipCommodity | X | X | X | X
ipCountry | X | X | X | X
ipMonthChar | X | X | X | X
ipMonth | X | X | X | X
ipStrike | X | X | X | X
ipScale | X | X | X | X
ipStrikeScale | X | X | X | X
ipDecimalStrike | X | X | X | X
ipInstrumentType | X | X | X | X
ipYear | X | X | X | X
ipYearString | X | X | X | X
ipCurrency | X | X | X | X
ipTickSize | X | X | X | X
ipTickValue | X | X | X | X
ipExchangeID | X | X | X | X
ipExchangeAbbreviation | X | X | X | X
ipNetChange | X | X | X | X
ipIsFastMarket | X | X | X | X
ipIsUpTick | X | X | X | X
ipIsDownTick | X | X | X | X
ipYOI |  |  | X | X
ipYCOI |  |  | X | X
ipSessionNumber |  |  | X | X
ipTodayTotalVolume |  |  | X | X
ipTodayCTotalVolume |  |  | X | X
ipYesterdayTotalVolume |  |  | X | X
ipYesterdayCTotalVolume |  |  | X | X
ipPreferredSessionName |  |  | X | X
ipDelayTime |  |  |  |

Similarly, depending on the subscription level, the following quote properties will be updated:

Data | Level of subscription: Real-Time data |  | Level of subscription: Full data
 | gslRealtimeSnapshot | gslRealtimeUpdates | gslFullSnapshot | gslFullUpdates
qtAsk Price | X | X | X | X
qtAsk Volume |  | X | X | X
qtAsk Timestamp |  | X | X | X
qtBid Price | X | X | X | X
qtBid Volume |  | X | X | X
qtBid Timestamp |  | X | X | X
qtTrade Price | X | X | X | X
qtTrade Volume |  | X | X | X
qtTrade Timestamp |  | X | X | X
qtSettlement Price |  |  | X | X
qtSettlement Volume |  |  | X | X
qtSettlement Timestamp |  |  | X | X
qtCohUndAsk Price | X | X | X | X
qtCohUndBid Price | X | X | X | X
qtDayOpen Price |  |  | X | X
qtDayHigh Price |  |  | X | X
qtDayLow Price |  |  | X | X
qtYesterdaySettlement Price |  |  | X | X


%%PageItemTitle%%

eGWEnvChangeCode Enumeration

Glossary Item Box

Description

Defines the CQG Gateway environment change types.

Members

Member | Value | Description
eccBalanceChanged | 1 | Previous close balance is changed.
eccManualStatementChanged | 3 | Manual statement change.
eccNewStatement | 2 | New statement.
eccPositionChanged | 0 | Previous close position is changed.


%%PageItemTitle%%

eHistoricalPeriod Enumeration

Glossary Item Box

Description

Indicates historical periods.

Members

Member | Value | Description
hpDaily | 1440 | Daily period.
hpMonthly | 43200 | Monthly period.
hpQuarterly | 131040 | Quarterly period.
hpSemiannual | 262080 | Semiannual period.
hpUndefined | 0 | Undefined historical period.
hpWeekly | 10080 | Weekly period.
hpYearly | 525600 | Yearly period.

Remarks

This is used in CQGConditionRequest.HistoricalPeriod, CQGCustomStudyRequest.HistoricalPeriod, CQGExpressionRequest.HistoricalPeriod, CQGTimedBarsRequest.HistoricalPeriod, and CQGTradingSystemRequest.HistoricalPeriod

See Also

CQGConditionRequest.HistoricalPeriod Property | CQGCustomStudyRequest.HistoricalPeriod Property | CQGExpressionRequest.HistoricalPeriod Property | CQGTimedBarsRequest.HistoricalPeriod Property | CQGTradingSystemRequest.HistoricalPeriod Property


%%PageItemTitle%%

eHistoricalSessionsRequestType Enumeration

Glossary Item Box

Description

Indicates the request type of historical sessions.

Members

Member | Value | Description
hsrtAll | 0 | Requests all available sessions.
hsrtSinceTime | 2 | Requests sessions from the specified start time till current (request) time.
hsrtTimeRange | 1 | Requests sessions in the range specified by start and end time.


%%PageItemTitle%%

eICConnectionStatus Enumeration

Glossary Item Box

Description

Indicates the status of the CQGIC connection.

Members

Member | Value | Description
iccsExited | 0 | Indicates that the CQGIC has been shut down.


%%PageItemTitle%%

eInstrumentProperty Enumeration

Glossary Item Box

Description

Defines all possible instrument properties.

Members

Member | Value | Description
ipAverageVolatility 58

Average volatility based on Options Preferences in CQG IC UI.

This is a floating-point-type property (dynamic property).

See CQG IC Help for the calculation formula.

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psVolatility flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipCommodity 8

Instrument commodity.

See the Commodity property of the CQGInstrument class.

This is a string-type property with a limited length of 16 characters.

ipCountry 9

Instrument country.

See the Country property of the CQGInstrument class.

This is a string-type property with a limited length of 3 characters.

ipCurrency 3

Instrument currency.

See the Currency property of the CQGInstrument class.

This is a string-type property with a limited length of 4 characters.

ipDecimalStrike 32

Decimal strike representation.

ipDelayMode 41

Instrument delay mode.

See eDelayMode for details.

ipDelayPeriod 42

Instrument delay period value in minutes.

The property value depends on ipDelayMode property and can have the following values:

ipDelayMode value | ipDelayPeriod values
dmUndefined | -1
dmNoDelay | 0
dmDelay | >0
dmEndOfDeyDelay | >=0
ipDelayTime 33

Time of delay for contract in minutes.

ipDelta 48

Current Delta of option based on Options Preferences in CQG IC UI.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psGreeks flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipDeltaNetChange 49

Change in Delta value from the prior day.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psGreeks flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipDescription 1

Instrument description.

See the Description property of the CQGInstrument class.

This is a string-type property with a limited length of 252 characters.

ipDetailedName | 46 | Instrument detailed name. For example, F.US.EP.M20, C.US.CLE.N20.N100
ipDTE 20

Days to expiration (dynamic property).

See the DTE property of the CQGInstrument class.

ipExchangeAbbreviation 29

Exchange abbreviation.

See the ExchangeAbbreviation property of the CQGInstrument class.

ipExchangeID 28

Exchange's identification number.

See the ExchangeID property of the CQGInstrument class.

ipExchangeState 66

Exchange state.

See the ExchangeState property of the CQGInstrument class.

ipExpirationDate 4

Instrument expiration date.

See the ExpirationDate property of the CQGInstrument class.

ipFirstNoticeDate 37

Instrument first notice date.

ipFullName 0

Instrument full name.

See the FullName property of the CQGInstrument class.

This is a string-type property with a limited length of 128 characters.

ipGamma 52

Current Gamma of option based on Options Preferences in CQG IC UI.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psGreeks flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipGammaNetChange 53

Change in Gamma value from the prior day.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psGreeks flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipImpliedVolatility 59

Implied volatility of an options contract using selected options model in Options Preferences in CQG IC UI.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psVolatility flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipImpliedVolatilityNetChange 62

Change in Implied Volatility from prior day's close.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psVolatility flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipImpliedVolatilityOnAsk 60

Implied volatility for the option ask price using selected options model in Options Preferences in CQG IC UI.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psVolatility flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipImpliedVolatilityOnBid 61

Implied volatility for the option bid price using selected options model in Options Preferences in CQG IC UI.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psVolatility flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipInitialMargin 5

Instrument initial margin.

See the InitialMargin property of the CQGInstrument class.

ipInstrumentID 2

Instrument unique and invariant identifier.

See the InstrumentID property of the CQGInstrument class.

ipInstrumentType 13

Instrument type.

See the InstrumentType property of the CQGInstrument class.

ipIsDetailedDOMAvailable | 43 | Indicates whether detailed DOM is available for instrument.
ipIsDownTick 21

Indicated if market goes down (dynamic property).

See the IsDownTick property of the CQGInstrument class.

ipIsFastMarket 23

Indicated whether contract is traded with red light (dynamic property).

See the IsFastMarket property of the CQGInstrument class.

ipIsFutureStyleOption | 39 | Futures style option
ipIsUpTick 22

Indicated if market goes up (dynamic property).

See the IsUpTick property of the CQGInstrument class.

ipIsVariableTickSize | 40 | Indicates whether instrument tick size data is variable.
ipLeadingContractName 34

The leading contract name for the commodity.

This is a string-type property with a limited length of 128 characters.

ipMaintenanceMargin 6

Instrument maintenance margin.

See the MaintenanceMargin property of the CQGInstrument class.

ipMarketState 47

Instrument market state.

See the MarketState property of the CQGInstrument class.

ipMonth 11

Instrument month.

See the Month property of the CQGInstrument class.

ipMonthChar 10

Instrument month character.

See MonthChar property of the CQGInstrument class.

ipNetChange 19

Option net change (dynamic property).

See the NetChange property of the CQGInstrument class.

ipPreferredSessionName 24

The preferred custom session name (dynamic property).

See the PreferredSessionsName property of the CQGInstrument Object class.

This is a string-type property with a limited length of 64 characters.

ipRho 56

Current Rho of option based on Options Preferences in CQG IC UI.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psGreeks flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipRhoNetChange 57

Change in Rho value from the prior day.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psGreeks flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipScale 30

Instrument scale.

See the Scale property of the CQGInstrument class.

ipSessionMask 7

Instrument session mask.

See the SessionMask property of the CQGInstrument class.

ipSessionNumber 18

Current session number (dynamic property).

See the SessionNumber property of the CQGInstrument class.

ipStrike 12

Instrument strike.

See the Strike property of the CQGInstrument class.

ipStrikeScale 31

Strike scale.

ipTheoreticalValue 64

Theoretical Value of option based on Options Preferences in CQG IC UI.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psTheoreticalValue flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipTheoValueNetChange 65

Change in Theoretical Value from the prior day.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psTheoreticalValue flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipTheta 50

Current Theta of option based on Options Preferences in CQG IC UI.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psGreeks flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipThetaNetChange 51

Change in Theta value from the prior day.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psGreeks flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipTickSize 16

Instrument tick size.

See the TickSize property of the CQGInstrument class.

ipTickSizeFractionDenominator 36

The instrument fractional tick size denominator.

See the TickSizeFractionDenominator property of the CQGInstrument class.

ipTickSizeFractionNumerator 35

The instrument fractional tick size numerator.

See the TickSizeFractionNumerator property of the CQGInstrument class.

ipTickValue 17

Instrument tick value.

See the TickValue property of the CQGInstrument class.

ipTodayCTotalVolume 25

The total trade volume of the contract for today (dynamic property).

See the TodayCTotalVolume property of the CQGInstrument class.

ipTodayCTotalVolumeFractional | 44 | The same as ipTodayCTotalVolume, but values have a decimal type
ipVega 54

Current Vega of option based on Options Preferences in CQG IC UI.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psGreeks flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipVegaNetChange 55

Change in Vega value from the prior day.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psGreeks flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipVolatilityCurve 63

Volatility designated in Volatility Workshop based on Volatility Workshop Preferences in CQG IC UI.

This is a floating-point-type property (dynamic property).

In case NewInstrumentMode is enabled add ePropertySubscriptionLevel.psVolatility flag to CQGInstrumentSubscriptionRequest.PropertyLevel value to get this property.

ipWorkup 38

Workup mode.

ipYCOI 27

The open interest of the contract for yesterday (dynamic property).

See the YCOI property of the CQGInstrument class.

ipYear 14

Instrument year.

See the Year property of the CQGInstrument class.

ipYearString 15

Instrument year string.

See the YearString property of the CQGInstrument class.

This is a string-type property with a limited length of 5 characters.

ipYesterdayCTotalVolume 26

The total trade volume of the contract for yesterday (dynamic property).

See the YesterdayCTotalVolume property of the CQGInstrument class.

ipYesterdayCTotalVolumeFractional | 45 | The same as ipYesterdayCTotalVolume, but values have a decimal type

Remarks

Properties marked as "dynamic property" have variable values during CQGInstrument object lifetime. All the other properties are invariant.

See Also

CQGInstrumentProperty Interface | CQGInstrument Interface


%%PageItemTitle%%

eInstrumentType Enumeration

Glossary Item Box

Description

Defines instrument type representations as bitmasks.

Used in CQGCEL.RequestCommodityInstruments and CQGDataSourceSymbols.Type.

Members

Member | Value | Description
itAllInstruments | 127 | Represents all instrument types.
itAllOptions | 6 | Represents Option Call and Option Put instrument types.
itFuture | 1 | Represents Futures instrument type.
itOptionCall | 4 | Represents Option Call instrument type.
itOptionPut | 2 | Represents Option Put instrument type.
itOther | 32 | Represents other (not explicitly listed in the enumeration) instrument types, such as cash, indices, currencies, reports etc.
itStock | 8 | Represents Stock instrument type.
itSyntheticStrategy | 64 | Represents synthetic strategy instrument type.
itTreasure | 16 | Represents Treasury instrument type.
itUndefined | 0 | Undefined type.

Remarks

If any bitmask is set in RequestCommodityInstruments method call, instruments of corresponding type will be included in the resolved commodities collection.

Example

See the usage of the eInstrumentType enumeration in CommodityInstrumentsResolved Example.

See Also

RequestCommodityInstruments Method | CommodityInstrumentsResolved Event | CQGCommodityInstruments Collection


%%PageItemTitle%%

eLogSeverity Enumeration

Glossary Item Box

Description

Specifies logging severity.

Members

Member | Value | Description
lsDebug | 10000 | Debug log message.
lsError | 40000 | Error log message.
lsFatal | 50000 | Fatal log message. (This is the default).
lsInfo | 20000 | Info log message.
lsWarn | 30000 | Warning log message.

Example

For usage of this enumeration, see event implementations in examples section of CQGCEL Object.

See Also

CQGLogger Interface


%%PageItemTitle%%

eManualFillsDataLevel Enumeration

Glossary Item Box

Description

Specifies data subscription levels for manual fills.

Members

Member | Value | Description
mfdlSnapshot | 0 | Only current values of manual fills will be received.
mfdlSnapshotAndUpdates | 1 | All current values of manual fills as well as notifications about their changes will be received.

See Also

RequestManualFills Method


%%PageItemTitle%%

eManualFillUpdateType Enumeration

Glossary Item Box

Description

Specifies the manual fill's update type.

Members

Member | Value | Description
mfutAdd | 0 | Add manual fill.
mfutDelete | 2 | Remove manual fill.
mfutModify | 1 | Change manual fill.

See Also

ManualFillChanged Event


%%PageItemTitle%%

eMarketState Enumeration

Glossary Item Box

Description

Indicates the market state (fast or not).

Members

Member | Value | Description
msFast | 0 | Fast market.
msNormal | 1 | Normal market.


%%PageItemTitle%%

eNoGapRemoveFrom Enumeration

Glossary Item Box

Description

Specifies No Gap 'Remove From' property value

Members

Member | Value | Description
ngrfAll | 0 | All gaps
ngrfEndOfSession | 2 | Remove gaps occurring at the end of session
ngrfStartAndEndOfSession | 3 | Remove gaps occurring at the start and end of session
ngrfStartOfSession | 1 | Remove gaps occurring at the start of session


%%PageItemTitle%%

eOpenCloseInstruction Enumeration

Glossary Item Box

Description

Specifies whether the order is opening/increasing or closing/reducing a position

Members

Member | Value | Description
ociClose | 2 | Close a position
ociClosePrevious | 3 | Close a previous day postion
ociOpen | 1 | Open a position
ociUndefined | 0 | Undefined


%%PageItemTitle%%

eOrderCancelationType Enumeration

Glossary Item Box

Description

Specifies the order cancellation instruction type.

Members

Member | Value | Description
octCancelAllLegOrders | 1 | Cancel strategy orders along with all incomplete legs.
octCancelPrimaryLegOrders | 2 | Cancel the strategy order and let the incomplete legs as working.
octUndefined | 0 | Undefined instruction type, used for non strategy type orders.


%%PageItemTitle%%

eOrderDuration Enumeration

Glossary Item Box

Description

Specifies the possible durations of an order.

Members

Member | Value | Description
odATC | 7 | The order duration is "At The Close".
odATO | 6 | The order duration is "At The Open".
odDay | 1 | The order lasts until the end of the trading day.
odDayGoodTillTime | 9 | The order duration is "Day Good Till Time". The order lasts until specified time portion, after which order is set to suspended state. Time portion should be specified via opGTTTime property.
odFAK | 5 | The order duration is "Fill And Kill". It means: "Immediately fill as many as possible and cancel the rest".
odFOK | 4 | The order duration is "Fill Or Kill". It means: "Immediately fill this order completely or cancel".
odGoodTillCanceled | 3 | The order lasts till it is cancelled or till the instrument is expired.
odGoodTillDate | 2 | The order duration is "Good Till Date". Date portion should be specified via opGTDTime property.
odGoodTillTime | 8 | The order duration is "Good Till Time". Time portion should be specified via opGTTTime property.
odUndefined | 0 | Undefined.


%%PageItemTitle%%

eOrderEvent Enumeration

Glossary Item Box

Description

Specifies the possible order event (transaction) types received via OrderChanged event.

Members

Member | Value | Description
oeAckCan | 19 | The cancellation request for the order is acknowledged by the FCM/Exchange.
oeAckMod | 18 | The modification request for the order is acknowledged by the FCM/Exchange.
oeAckPlace | 10 | The order is acknowledged by the FCM/Exchange.
oeActiveAt | 29 | Notification that the order will be activated at the specified time. This event type is sent for orders that were sent while the trading session was not open.
oeCancelQueueTimeout | 5 | Important: This order event type is obsolete and will not be fired. The cancel request for the order timed out in the "Rate Protection" queue.
oeCancelSent | 2 | A cancellation request for the order is sent.
oeDisconnected | 26 | The order might be cancelled because a disconnect occurred.
oeExpired | 13 | The order is expired.
oeFill | 20 | A fill for the order is received from the FCM/Exchange.
oeFillBust | 28 | Order's fill is busted.
oeFillCan | 27 | Order's fill is cancelled.
oeFillMod | 25 | A modification occurred to the previous fill of the order.
oeInCan | 14 | A cancel request for the order is sent to the FCM/Exchange.
oeInCanTmout | 17 | Important: This order event type is obsolete and will not be fired. The cancellation request for the order timed out, while waiting for a response from the FCM/Exchange.
oeInClient | 7 | The order did not get a response from CQG Gateway yet.
oeInfoChanged | 36 | The eOrderCancellationType for the secondary orders of a synthetic strategy is changed to octCancelPrimaryLegOrders.
oeInMod | 15 | A modification request for the order is sent to the FCM/Exchange.
oeInModTmout | 16 | Important: This order event type is obsolete and will not be fired. The modification request for the order timed out, while waiting for a response from the FCM/Exchange.
oeInQueue | 1 | The order is in the "Rate Protection"* queue.
oeInTransit | 8 | The order request is sent to the FCM/Exchange.
oeInTransTmout | 11 | Important: This order event type is obsolete and will not be fired. The order was timed out, while waiting for notification from the CQG Gateway.
oeLinkChg | 24 | A change to a linked order affected this order.
oeModifyQueueTimeout | 6 | Important: This order event type is obsolete and will not be fired. The modification request for the order timed out in the "Rate Protection" queue.
oeModifySent | 3 | A modification request for the order is sent.
oePark | 23 | The order is parked, i.e. the order is being held by the CQG Gateway until the explicit activation.
oeQueueTimeout | 4 | Important: This order event type is obsolete and will not be fired. The order timed out in the "Rate Protection" queue.
oeRejCan | 22 | The cancellation request for the order is rejected by the FCM/Exchange.
oeRejectFCM | 12 | Important: This order event type is obsolete and will not be fired. The order timed out in the "Rate Protection" queue.
oeRejectGW | 9 | The order is rejected by the CQG Gateway.
oeRejLinkChg | 32 | Linked order change is rejected.
oeRejMod | 21 | The modification request for the order is rejected by FCM/Exchange.
oeRemoved | 31 | The order is removed from the orders collection.
oeSyntheticActivated | 30 | The synthetic order is sent to the actual exchange.
oeSyntheticFailed | 33 | The synthetic strategy execution is failed. Synthetic strategy execution failed.
oeSyntheticHang | 35 | Synthetic order execution is hung.
oeSyntheticOverFill | 34 | The synthetic order is overfilled.
oeUndefined | 0 | Undefined.

Remarks

* "Rate protection" is especially designed to protect the CQG Gateway from excessive number of orders. Its queue is placed in the CQGIC and allows to control the number of orders sent to the CQG Gateway so that it does not exceed the number, which the later can process.

See Also

eOrderStatus Enumeration | eOrderLocalState Enumeration


%%PageItemTitle%%

eOrderExecutionInstruction Enumeration

Glossary Item Box

Description

Defines order execution instructions

Members

Member | Value | Description
oeiAllOrNothing | 1 | All or nothing execution instruction.
oeiFunari | 16 | Funari execution instruction.
oeiIceberg | 4 | Iceberg execution instruction.
oeiMIT | 32 | "Market If Touched" execution instruction.
oeiPostOnly | 128 | Post-only execution instruction.
oeiQTS | 8 | Quantity Triggered Stop execution instruction.
oeiReserved64 | 64 |
oeiTrailing | 2 | Trailing execution instruction.
oeiUndefined | 0 | Undefined (no execution instruction).


%%PageItemTitle%%

eOrderLocalState Enumeration

Glossary Item Box

Description

Defines local states of the order. 'Local' here means from CQG API point of view.

Members

Member | Value | Description
olsActivateSent | 5 | An activation request for the order is sent. An order can be in this state only if it is Parked.
olsAtGW | 7 | The order is at CQG Gateway.
olsCancelSent | 4 | A cancellation request for the order is sent.
olsInClient | 6 | The order is in CQGIC.
olsInQueue | 1 | The order is in "Rate Protection" queue. For description of "Rate Protection" see the Remarks section of eOrderEvent Enumeration.
olsModifySent | 3 | A modification request for the order is sent.
olsNotSent | 0 | The order is not sent yet.
olsParkSent | 10 | A park request for the order is sent.
olsQueueTimeout | 2 | The order timed out in "Rate Protection" queue.
olsRemoved | 8 | The order is removed from all collections.
olsStrategyPending | 9 | Strategy Order is waiting for strategy to get defined.

See Also

eOrderEvent Enumeration | eOrderStatus Enumeration


%%PageItemTitle%%

eOrderProperty Enumeration

Glossary Item Box

Description

Specifies all possible and acceptable properties of an order.

Members

Member | Value | Description
opAccountID | 1 | CQG Gateway identifier of the account to which this order belongs. This is a read-only property of Long type.
opActivationTime | 71 | UTC Date/time the parked order should automatically activate. This is read-write property of Date type. When a property is set during order creation, it is necessary to set the opParked property to True. The property is writable only when the opParked property value is True. The property corresponds to until_ parameter from CQGOrder.Park method. The property is modifiable through the CQGOrderModify object. Set the property value to "12/30/1899 12:00:00 AM" UTC to remove the activation time through the CQGOrderModify object.
opAggressive | 10 | The property specifying the aggressiveness of the order (Fixed Income only). This is a read/write property of Boolean type. This property becomes read-only after the order is placed.
opAlgorithmID | 53 | Algorithm identifier of the order This is a read-only property of Long type.
opAverageFillPrice | 24 | The average price of the order's fills. This is a read-only property of Double type.
opCancelationInstruction | 46 | The strategy order cancelation flag that determines the cancelation type. This is a read-write property of eOrderCancelationType type.
opCanceledTime | 45 | Time of the cancelation transaction for this order. This is a read-only property of Date type.
opCareOrderIDs | 51 | Property which defines the comma separated set of care order identifiers based on which the execution is done
opCompoundOrderGUID | 49 | Compound order GUID. Value equals to GUID property of CQGOrderChain that was used as parameter in PlaceCompoundOrderEx. Property is present only if order is a part (leg) of some compound order. This is a read-only property of String type.
opCompoundOrderID | 48 | Compound order ID, unique value assigned by server. Property is present only if order is a part (leg) of some compound order. This is a read-only property of String type.
opCompoundOrderType | 70 | Compound order type. Property is present only if order is a part (leg) of some compound order. This is read-only property of ECompoundOrderType type.
opCQGID | 36 | The CQG system identifier (serial number). This is a read-only property of String type.
opDescription | 41 | User-created custom description for the order. Note that this description is stored on the gateway and is not lost between the sessions. This is a read-write property of String type.
opDurationType | 5 | The duration of the order. This is a read/write property of eOrderDuration type. This property becomes read-only after the order is placed. This property is available if order type is not otMarket.
opErrorFlag | 25 | The flag that indicates that the order had errors. This is a read-only property of Boolean type.
opEventServerTimestamp | 30 | The server timestamp of the last event of the order. This is a read-only property of Date type.
opEventTimestamp | 29 | The local timestamp of the last event of the order. This is a read-only property of Date type.
opExchangeConf | 18 | The confirmation supplied for the order by the Exchange (Exchange order ID). This is a read-only property of String type.
opExecSystemOrderID | 60 | The system specific order ID. This is a read-only property of String type.
opExecutionInstructions | 11 | The property specifying the combination of execution instructions. This is a read/write bitmask of eOrderExecutionInstruction type. This property becomes read-only after the order is placed.
opExecutionPattern | 43 | Execution pattern of the spread order represented as string. This is a read/write property of String type.
opExtendedSide | 68 | Specifies special order side value. This is a read/write property of EExtendedSide type. This property is modifiable through the CQGOrderModify object. See EExtendedSide description for more information.
opFilledCount | 23 | The number of order fills. This is a read-only property of Long type.
opFilledQuantity | 22 | The filled quantity of the order. This is a read-only property of Long type.
opFilledQuantityFractional | 63 | The same as opFilledQuantity but data type. The data type is Decimal.
opGTDTime | 6 | The good-till-date value of the order. This is a read/write property of Date type. This property is available if order duration type is odGoodTillDate.
opGTTTime | 67 | The good-till-time value of the order. This is a read/write property of Date type. This property is available if order duration type is odDayGoodTillTime or odGoodTillTime.
opGUID | 14 | The GUID of the order. This is a read-only property of String type.
opGWStatus | 19 | The CQG Gateway status of the order. This is a read-only property of eOrderStatus type.
opInstrumentName | 2 | The full name of the Instrument on which this order is placed. This is a read-only property of String type.
opInstrumentNameDetailed | 66 | The detailed name of the Instrument on which this order is placed. This is a read-only property of String type.
opIsCareOrder | 50 | Property which defines if the order is Care order or not. This is a read-write property of boolean type.
opLastEvent | 27 | The last event of the order. This is a read-only property of eOrderEvent type.
opLastEventID | 28 | The identifier of the last event of the order. This is a read-only property of Long type.
opLastFillTime | 44 | Time of the last fill's transaction for this order. This is a read-only property of Date type.
opLastTrailingTime | 33 | Time of the most recent move of trailing order. This is a read-only property of Double type. This property is valid only for trailing order. This property is available only if order type is otLimit, otStop, or otStopLimit and oeiTrailing is set. See CQG IC Help to read more about trailing orders.
opLimitPrice | 3 | The limit price of the order. This is a read/write property of Double type. This property becomes read-only after the order is placed. This property is available if order type is one of the following: otLimit, otStopLimit. This property is modifiable through the CQGOrderModify object.
opLocateID | 69 | Locate ID for Sell Short order. In some cases, the short sell order itself requires to identify where (from which broker/participant) the shares will be borrowed. This is an optional read/write property of String type. This property can be specified only if opExtendedSide is set to esSellShort. This property is modifiable through the CQGOrderModify object.
opManual | 58 | Whether the order is placed manually. This is a read-write property of boolean type. This property becomes read-only after the order is placed. This property is modifiable through the CQGOrderModify object.
opMiFIDAlgorithmID | 55 | MiFID algorithm ID of the order This is a read-write property of String type. This property becomes read-only after the order is placed. This property is modifiable through the CQGOrderModify object.
opOpenCloseInstruction | 56 | The order open/close instruction. This is a read-write property of eOpenCloseInstruction type.
opOrderCheckMark | 52 | Custom flag for user-defined purposes. This is a read-write property of Boolean type and can be set regardless of the order's state.
opOrderID | 16 | The CQG Gateway identifier of the order. This is a read-only property of Long type.
opOrderType | 0 | Order type. This is a read-only property represented by eOrderType enumeration. Depending on this property the availability of others is decided.
opOriginalOrderID | 17 | The CQG Gateway identifier of the original order. This is a read-only property of Long type.
opParentOrderGUID | 59 | The GUID of parent order. This is a read-only property of String type.
opParked | 12 | The property specifying the order's being parked. This is a read/write property of Boolean type. This property becomes read-only after the order is placed.
opPlaceTime | 21 | The time of order placing. This is a read-only property of Date type.
opPreferredTrailingPeg | 40 | Preferred trailing peg (preferred price value for order to trail). Mandatory property for trailing order. This is a read/write property of eOrderTrailingPeg type. This property becomes read-only after the order is placed. See CQG IC Help to read more about trailing orders.
opQuantity | 8 | The quantity of the order. This is a read/write property of Long type. This property becomes read-only after the order is placed. This property is modifiable through the CQGOrderModify object. Note that if the UseOrderSide setting of CQG API Configuration is set to False, the side of the order should also be taken into account when setting this property.
opQuantityFractional | 61 | The same as opQuantity but data type. The data type is Decimal.
opRemainingQuantity | 31 | The remaining quantity of the order. This is a read-only property of Long type.
opRemainingQuantityFractional | 64 | The same as opRemainingQuantity but data type. The data type is Decimal.
opReserved57 | 57 |
opSide | 7 | The side of the order. This is a read/write property of eOrderSide type. This property becomes read-only after the order is placed. Note that if the UseOrderSide setting of CQG API Configuration is set to False, the side of the order should be given via opQuantity property sign.
opSpeculationType | 54 | The speculation type of the order. This is a read/write property of eSpeculationType type. This property becomes read-only after the order is placed.
opState | 20 | The local CQG API state of the order. This is a read-only property of eOrderLocalState type.
opStopPrice | 4 | The stop price of the order. This is a read/write property of Double type. This property becomes read-only after the order is placed. This property is available if order type is one of the following: otStop, otStopLimit. This property is modifiable through the CQGOrderModify object.
opStrategyOrderGUID | 42 | Strategy order GUID if the order is a leg of some strategy order. This is a read-only property of String type.
opSynthetic | 13 | The property specifying the order's being synthetic. This is a read/write property of Boolean type. This property becomes read-only after the order is placed.
opTimeActiveAt | 26 | The time when the order will be automatically activated. This is a read-only property of Date type.
opTraderID | 38 | The identifier of the trader who last modified the order. This property value will change if the order was modified (for example, canceled or activated) by a trader other than the one who placed it. This is a read-only property of Long type.
opTradingExpression | 47 | Specifies the trading expression.
opTrailingLimitPrice | 34 | Initial limit price of the trailing order. This is a read-only property of Double type. This property is valid only for trailing order. This property is available only if order type is otLimit or otStopLimit and oeiTrailing is set. See CQG IC Help to read more about trailing orders.
opTrailingOffset | 32 | The offset of the trailing order. Mandatory property for trailing order. This is a read/write property of Double type. This property becomes read-only after the order is placed. This property is available only if order type is otLimit, otStop, or otStopLimit and oeiTrailing is set. This property is currently not modifiable. See CQG IC Help to read more about trailing orders.
opTrailingStopPrice | 35 | Initial stop price of the trailing order. This is a read-only property of Double type. This property is valid only for trailing order. This property is available only if order type is otStop or otStopLimit and oeiTrailing is set. See CQG IC Help to read more about trailing orders.
opTriggerQuantity | 39 | Trigger quantity of QTS order. This is a read/write property of Long type. This property becomes read-only after the order is placed.
opTriggerQuantityFractional | 65 | The same as opTriggerQuantity but data type. The data type is Decimal.
opUEName | 15 | The user-friendly name of the order. This is a read-only property of String type.
opUserName | 37 | The name of the CQG Gateway trader who placed the order. This is a read-only property of String type.
opVisibleQuantity | 9 | The visible quantity of Fixed Income/Iceberg. This is a read/write property of Long type. This property becomes read-only after the order is placed. This property is modifiable through the CQGOrderModify object.
opVisibleQuantityFractional | 62 | The same as opVisibleQuantity but data type. The data type is Decimal.

Remarks

The properties that can be set for an order depend on the order type.

If the property is read/write it means that it can be set from CQGOrder.Properties.

If the property is read-only it means that it was either previously set during CQGCEL.CreateOrder call or is set by CQG Gateway.


%%PageItemTitle%%

eOrderSide Enumeration

Glossary Item Box

Description

Identifies the order side notion in terms of buy and sell.

Members

Member | Value | Description
osdBuy 1 Side properties return this value if CQGAPIConfig.UseOrderSide is set to True.

Depending on the owner, osdBuy value is returned in case of:

  • the object is a CQGTrade referring to a buy trade
  • the object is a CQGPosition referring to a long position.

  • the object is a CQGOrder referring to an order of buy type.
  • the object is a CQGFill referring to a fill of buy type.
osdSell 2 Side properties return this value if CQGAPIConfig.UseOrderSide is set to True.

Depending on the owner, osdSell value is returned in case of:

  • the object is a CQGTrade referring to a sell trade
  • the object is a CQGPosition referring to a short position.

  • the object is a CQGOrder referring to an order of sell type.
  • the object is a CQGFill referring to a fill of sell type.
osdUndefined | 0 | Side properties return this value if CQGAPIConfig.UseOrderSide is set to False.

Remarks

The preferred method can be set through the CQGAPIConfig.UseOrderSide property.

See Also

CQGAPIConfig.UseOrderSide Property


%%PageItemTitle%%

eOrderSideFilter Enumeration

Glossary Item Box

Description

Specifies the orders side filter.

Members

Member | Value | Description
osftAll | 3 | Both buy and sell orders
osftBuy | 1 | Buy orders
osftSell | 2 | Sell orders


%%PageItemTitle%%

eOrderStatus Enumeration

Glossary Item Box

Description

Defines the CQG Gateway statuses of the order.

Members

Member | Value | Description
osActiveAt | 16 | The order will be active at the nearest session.
osBusted | 15 | Order was completely filled and then all fills were busted
osCanceled | 10 | The order is cancelled.
osContingent | 14 | The order is contingent on another order, awaiting activation.
osDisconnected | 13 | The order might be cancelled because a disconnect occurred.
osExpired | 7 | The order is expired. It means that the order was not filled during its duration period.
osFilled | 11 | The order is filled.
osInCancel | 8 | The order is in cancellation stage.
osInClient | 1 | The order either is in CQGIC or is flying to the CQG Gateway.
osInModify | 9 | The order is in modification stage.
osInOrderBook | 4 | The order is working.
osInTransit | 2 | Order is in transit. It means that the order has already reached the CQG Gateway, and now it is on its way to the exchange.
osInTransitTimeout | 5 | The order was timed out, while waiting for notification from the CQG Gateway.
osNotSent | 0 | The order did not leave the CQG API side, yet.
osParked | 12 | The order is parked.
osRejectFCM | 6 | The order is rejected by FCM.
osRejectGW | 3 | The order is rejected by CQG Gateway.


%%PageItemTitle%%

eOrderStatusFilter Enumeration

Glossary Item Box

Description

Specifies the order's CQGOrder.GWStatus filter's possible values, available for CQGCEL.QueryOrders method calls.

Members

Member | Value | Description
osfAll | 0 | Orders with any Gateway status.
osfCanceled | 6 | Cancelled orders.
osfException | 4 | Orders with errors or rejected orders.
osfFilled | 3 | Orders that have at least 1 fill.
osfFinal | 2 | Final orders, i.e. orders, Gateway statuses of which are one of the following: osRejectGW, osRejectFCM, osExpired, osCanceled, osFilled, osBusted, osParked, osInTransitTimeout.
osfNotFinal | 1 | Not final orders, i.e. orders, Gateway statuses of which are one of the following: osInOrderBook, osInTransit, osActiveAt, osContingent, osDisconnected, osInCancel, osInModify.
osfParked | 5 | Parked and contingent orders.


%%PageItemTitle%%

eOrderTrailingPeg Enumeration

Glossary Item Box

Description

Order trailing peg, which defines user's preference for trailing after the market.

Members

Member | Value | Description
otpBestAsk | 1 | Best ask.
otpBestBid | 0 | Causes trailing limit price to trail the Best bid.
otpLastTrade | 2 | Last trade.
otpUndefined | 3 | Undefined.


%%PageItemTitle%%

eOrderType Enumeration

Glossary Item Box

Description

Specifies the available order types.

Members

Member | Value | Description
otLimit | 2 | Limit order.
otMarket | 1 | Market order.
otStop | 3 | Stop order.
otStopLimit | 4 | Stop Limit order.
otUndefined | 0 | Undefined order type.


%%PageItemTitle%%

ePfBoxUnits Enumeration

Glossary Item Box

Description

Indicates the point and figure box units.

Members

Member | Value | Description
pfbuPrice | 0 | Price.
pfbuTicks | 1 | Ticks.


%%PageItemTitle%%

ePfDataSource Enumeration

Glossary Item Box

Description

Indicates the point and figure bar data source.

Members

Member | Value | Description
pfds15Min | 3 | 15 minute.
pfds1Min | 1 | 1 minute.
pfds30Min | 4 | 30 minute.
pfds5Min | 2 | 5 minute.
pfds60Min | 5 | 60 minute.
pfdsDaily | 6 | Daily.
pfdsTicks | 0 | Ticks.


%%PageItemTitle%%

EPositionDay Enumeration

Glossary Item Box

Description

Current/Previous day position for instruments with explicit position tracking type

Members

Member | Value | Description
dayCurrent | 1 | Current day postion
dayPrevious | 2 | Previous day postion
dayUndefined | 0 | Undefined value


%%PageItemTitle%%

ePositionDetailing Enumeration

Glossary Item Box

Description

Defines the level of position information detailing.

Members

Member | Value | Description
pdAllTrades | 2 | Information on both open and matched trades will be provided. The information will be stored in the OpenTrades and MatchedTrades collections of each position.
pdNoTrades | 0 | No trade information will be provided. This is the default value.
pdOpenTrades | 1 | Open trades information will be provided. The information will be stored in the OpenTrades collection of each position.

Remarks

This value can be set from the configuration PositionDetailing property and is one for all positions of all accounts.

See Also

CQGAPIConfig.PositionDetailing Property


%%PageItemTitle%%

ePositionSubscriptionLevel Enumeration

Glossary Item Box

Description

Specifies the update subscription levels for an account's positions.

Members

Member Value Description
pslNoPositions 0 No position information is provided.

This is the default value.

When initially set the CQGAccount.Positions collection remains empty.

If this value is set after some other value, then the CQGAccount.Positions collection will not be emptied, i.e. it will remain in the same state as it was when setting to pslNoPositions.

If the subscription level is changed from lower to higher an AccountChanged event will be fired with actPositionsReloaded type.

pslSnapshot 1 Positions for the account are obtained and fully refreshed once, but no updates on new trades/new positions are received after that.

To update the collection in this case, the user must set the subscription level to pslNoPositions and back to pslSnapshot.

pslSnapshotAndUpdates 2 Positions for the account are obtained, fully refreshed and all updates are fired as well, e.g. new trades, new positions, position changes etc.

Note: If you want to get an event on each price change, you also need to set CQGAPIConfig.FireEventOnChangedPrices to True.

Remarks

This is an account specific setting, i.e. each account may have its own position subscription level.


%%PageItemTitle%%

EPositionTrackingType Enumeration

Glossary Item Box

Description

Position tracking type

Members

Member Value Description
pttExplicit 2

Explicit postion tracking type.

It includes the following positions:

  • Previous day long postion
  • Previous day short postion
  • Current day long postion
  • Current day short postion
pttImplied 1

Implied postion tracking type.

It includes the following postions:

  • Long position
  • Short position
pttNet 0

Net position tracking type


%%PageItemTitle%%

ePriceMode Enumeration

Glossary Item Box

Description

Specifies the available price modes for accounts and positions.

Members

Member | Value | Description
pmBidsAsks | 0 | Calculate using Best Asks/Best Bids.
pmTradesOnly | 1 | Calculate using Last Trades. This is the default value.

Remarks

Account summaries and position's trade-specific properties can be calculated in two ways:

  1. basing on Best Ask / Best Bid values
  2. basing on Last Trade values.

The User can configure it via PriceMode configuration setting.

This is a general setting that covers all accounts and positions.

See Also

CQGAPIConfig.PriceMode Property


%%PageItemTitle%%

ePropertySubscriptionLevel Enumeration

Glossary Item Box

Description

Specifies the property subscription level for CQGInstrument.

Members

Member | Value | Description
psGreeks | 8 | ipDelta, ipDeltaNetChange, ipTheta, ipThetaNetChange, ipGamma, ipGammaNetChange, ipVega, ipVegaNetChange, ipRho, ipRhoNetChange
psMarketState | 1 | IsDownTick, IsUpTick, IsFastMarket
psNetChange | 2 | ipNetChange
psNone | 0 | No dynamic property is available.
psTheoreticalValue | 32 | ipTheoreticalValue, ipTheoValueNetChange
psTotalVolumes | 4 | ipTodayCTotalVolume, ipYesterdayCTotalVolume
psVolatility | 16 | ipAverageVolatility, ipImpliedVolatility, ipImpliedVolatilityOnAsk, ipImpliedVolatilityOnBid, ipImpliedVolatilityNetChange, ipVolatilityCurve

Remarks

Effective if CQGAPIConfig.NewInstrumentMode is set to True, otherwise eDataSubscriptionLevel should be used.

Values can be combined using bitwise OR operation.

See Also

CQGAPIConfig.NewInstrumentMode | eDataSubscriptionLevel Enumeration | CQGInstrumentSubscriptionRequest Interface | PropertyLevel Property


%%PageItemTitle%%

eQuoteSubscriptionLevel Enumeration

Glossary Item Box

Description

Specifies the quote subscription level for CQGInstrument.

Members

Member | Value | Description
qsBBA | 2 | qtAsk, qtBid, qtImpliedAsk, qtImpliedBid, qtOutrightAsk, qtOutrightBid based on the eDOMandBBAType value; and qtCohUndAsk, qtCohUndBid if options.
qsNone | 0 | No subscription. Nothing is updated.
qsQuotes | 1 | qtTrade, qtSettlement, qtDayOpen, qtDayHigh, qtDayLow, qtYesterdaySettlement, qtIndicativeOpen, qtSettlement; and qtTodayMarker and qtMarker for futures.

Remarks

Effective if CQGAPIConfig.NewInstrumentMode is set to True, otherwise eDataSubscriptionLevel should be used.

See Also

eDataSubscriptionLevel Enumeration | CQGAPIConfig.NewInstrumentMode | CQGQuotes Collection | CQGInstrument Interface | CQGInstrument.Quotes | eQuoteType Enumeration | InstrumentChanged Event | QuoteLevel Property


%%PageItemTitle%%

eQuoteType Enumeration

Glossary Item Box

Description

Specifies all possible quote types.

Members

Member | Value | Description
qtAsk | 0 | Best ask. (Combined)
qtBid | 1 | Best bid. (Combined)
qtCohUndAsk | 4 | Coherent underlying price for the best ask.
qtCohUndBid | 5 | Coherent underlying price for the best bid.
qtDayHigh | 7 | Current day high price.
qtDayLow | 8 | Current day low price.
qtDayOpen | 6 | Day open price.
qtImpliedAsk | 9 | Implied best ask.
qtImpliedBid | 10 | Implied best bid.
qtIndicativeOpen | 14 | Indicative open.
qtMarker | 16 | Marker price, date time.
qtOutrightAsk | 11 | Outright best ask.
qtOutrightBid | 12 | Outright best bid.
qtSettlement | 3 | Settlement price.
qtTodayMarker | 15 | Marker price, date time.
qtTrade | 2 | Last trade price.
qtYesterdaySettlement | 13 | Yesterday's settlement price.

See Also

CQGQuotes Collection


%%PageItemTitle%%

eRangeUnit Enumeration

Glossary Item Box

Description

Specifies Range 'Range Unit' property value

Members

Member | Value | Description
ruPrice | 1 | Display price scale units are used for range
ruTick | 0 | Tick price scale units are used for range


%%PageItemTitle%%

eReadyStatus Enumeration

Glossary Item Box

Description

Indicates if the host application (MS Excel) is ready to handle events.

Members

Member | Value | Description
rsBusy | 0 | The host application (MS Excel) is in edit mode.
rsNotReady | 2 | The host application (MS Excel) isn't ready (when Application.Ready = False).
rsReady | 1 | The host application (MS Excel) is ready (when Application.Ready = True).

Remarks

The rsBusy value is actually never used by the user. It is just a way for the CQG API to know that Excel will not let any event pass, because it did not let the IsReady event pass as well (just set its return value to default).

Example

For the usage of this enumeration, see the IsReady event implementation in the examples section of CQGCEL Object

See Also

CQGCEL.IsReady Event


%%PageItemTitle%%

eReadyStatusCheck Enumeration

Glossary Item Box

Description

Turns on/off the application's ready status checking.

Members

Member | Value | Description
rscOff | 0 | Ready status check is off.
rscOn | 1 | Ready status check is on.

Remarks

Ready status checking was added taking into account Excel's Application.Ready flag, which reflects Excel readiness to receive user events. The reason to add this, was that Excel - other than the Busy state - can sometimes (if the user is in the edit mode) not receive user events at all and the user does not even have a way to know that.

ReadyStatusCheck member of CQGCELConfiguration structure should be set to rscOn if used from MSExcel 2003. In all other cases it can be set to rscOff. In that case IsReady event won't be fired to check application readiness.

See Also

IsReady Event | CQGAPIConfig.ReadyStatusCheck Property


%%PageItemTitle%%

eRequestStatus Enumeration

Glossary Item Box

Description

Request status, used in orders query and historical requests.

Members

Member | Value | Description
rsCanceled | 3 | The request is canceled.
rsFailed | 2 | The request failed.
rsInProgress | 0 | The request is in progress.
rsSuccess | 1 | The request is completed successfully.

Remarks

This is used in the CQGOrdersQuery.Status property.

See Also

CQGOrdersQuery.Status Property


%%PageItemTitle%%

eSessionFlag Enumeration

Glossary Item Box

Description

Indicates session flag.

Members

Member | Value | Description
sfDailyFromIntraday | 2 | Daily from intraday flag.
sfUndefined | 0 | Undefined.


%%PageItemTitle%%

eSessionStatus Enumeration

Glossary Item Box

Description

Used to specify remote Open API session status

Members

Member | Value | Description
ssAlreadyLoggedIn | 5 | User is already logged in
ssAuthorizationFailed | 4 | User authorization failed
ssInternalSystemError | 2 | Internal error
ssNoAvailableDataServers | 7 | There were no available data servers for the client request
ssNoAvailableLoginService | 0 | Login service is not available
ssNoAvailableMetadataServers | 8 | There were no available metadata servers for the client request
ssNoAvailableROMNumbers | 9 | No ROM numbers are available in CQGT client pool for CQGT authentication request to succeed
ssNoRemoteAPIPermission | 10 | Client doesn't have enablement to access Remote API
ssNotAuthenticated | 6 | User is not authenticated
ssNotEnabled | 3 | Client is not enabled
ssSuccess | 1 | Successful result


%%PageItemTitle%%

eSessionWeekDays Enumeration

Glossary Item Box

Description

Indicates the session working days.

Members

Member | Value | Description
swdFriday | 2 | Friday is a working day.
swdMonday | 32 | Monday is a working day.
swdSaturday | 1 | Saturday is a working day.
swdSunday | 64 | Sunday is a working day.
swdThursday | 4 | Thursday is a working day.
swdTuesday | 16 | Tuesday is a working day.
swdUndefined | 0 | Undefined.
swdWednesday | 8 | Wednesday is a working day.

Remarks

This is used in the CQGSession.WorkingWeekDays property.

Example

See the usage of eSessionWeekDays enumeration in the CustomSessionsResolved event's example section.

See Also

CQGSession.WorkingWeekDays Property


%%PageItemTitle%%

eSpeculationType Enumeration

Glossary Item Box

Description

Specifies order speculation type

Members

Member | Value | Description
sptArbitrage | 2 | Arbitrage
sptHedge | 3 | Hedge
sptSpeculation | 1 | Speculation
sptUndefined | 0 | Undefined


%%PageItemTitle%%

EStartPoint Enumeration

Glossary Item Box

Description

Start Point study parameter values for Range Bars.

Members

Member | Value | Description
spMonth | 2 | Start calculation from the current month.
spSession | 0 | Start calculation from the current session.
spWeek | 1 | Start calculation from the current week.

Remarks

Corresponds to possible values for the "Start Point" parameter for the Range Bars chart in CQG IC.

See Also

CQGRangeBarsRequest Interface | StartPoint Property


%%PageItemTitle%%

eStrategyRequestStatus Enumeration

Glossary Item Box

Description

Indicated the status of the Gateway strategy definition request.

Members

Member | Value | Description
srsFailed | 3 | The request is failed.
srsNotActive | 0 | The request is not active.
srsPending | 1 | The request is pending.
srsSuccess | 2 | The request is completed successfully.


%%PageItemTitle%%

eSymbolSessionType Enumeration

Glossary Item Box

Description

Indicates the instrument session type.

Members

Member | Value | Description
sstAll | 3 | All sessions (value = sstDefault | sstCustom). Reserved for future use.
sstCustom | 2 | Custom session.
sstDefault | 1 | Default session.

Remarks

This is used in the CQGSession.Type and CQGSessions.Type properties.

See Also

CQGSession.Type Property | CQGSessions.Type Property


%%PageItemTitle%%

eSymbolType Enumeration

Glossary Item Box

Description

Indicates the symbol type.

Members

Member | Value | Description
stCash | 32 | Cash data source.
stCurrency | 64 | Currencies data source.
stFuture | 1 | Futures and spreads data source.
stIndex | 128 | Indices data source.
stOption | 6 | Options data source (of values 2 or 4).
stReport | 256 | Reports data source.
stStock | 8 | Stock data source.
stTreasury | 16 | Treasures data source.
stUndefined | 0 | Undefined.

Remarks

This is used in the CQGDataSource.SymbolTypes and CQGDataSourceSymbol.Type properties.

Example

See the usage of eDataSourceType enumeration in the DataSourcesResolved event's example section.

See Also

CQGDataSource.SymbolTypes Property | CQGDataSourceSymbol.Type Property


%%PageItemTitle%%

eTfAggregation Enumeration

Glossary Item Box

Description

Indicates the TFlow bar aggregation.

Members

Member | Value | Description
tfaBars | 0 | Bars
tfaRange | 1 | Range
tfaSmoothing | 2 | Smoothing


%%PageItemTitle%%

eTFlowRequestDomVolumeLevel Enumeration

Glossary Item Box

Description

Specifies the level of DOM volume in TFlowBarsRequest.

Members

Member | Value | Description
dvLevel0 | 0 | DOM ask or DOM bid volume of level 0 is requested.
dvLevel1 | 1 | DOM ask or DOM bid volume of level 1 is requested.
dvLevel2 | 2 | DOM ask or DOM bid volume of level 2 is requested.
dvLevel3 | 3 | DOM ask or DOM bid volume of level 3 is requested.
dvLevel4 | 4 | DOM ask or DOM bid volume of level 4 is requested. This is the default value.

See Also

CQGTFlowBarsRequest.DomAskVolumeLevel Property | CQGTFlowBarsRequest.DomBidVolumeLevel Property


%%PageItemTitle%%

eTickCorrectionType Enumeration

Glossary Item Box

Description

Indicates the tick correction type.

Members

Member | Value | Description
tctDelete | 2 | Delete correction
tctInsert | 1 | Insert correction
tctRegular | 0 | Regular correction. (There is no correction.)
tctUpdate | 3 | Update correction


%%PageItemTitle%%

eTickFilter Enumeration

Glossary Item Box

Description

Specifies which ticks are being requested.

Members

Member | Value | Description
tfAll | 0 | All ticks
tfAsk | 4 | Ask ticks
tfAskLow | 64 | Ask low ticks. This enumerator is obsolete!
tfBid | 2 | Bid ticks
tfBidHigh | 32 | Bid high ticks. This enumerator is obsolete!
tfDefault | 1 | This is the default enumerator and is the same as tfTrade
tfSettlement | 16 | Settlement ticks
tfTrade | 8 | Trade ticks

Remarks

The value for this enumeration should indicate one of the following:

1. tfAll

2. tfDefault

3. Bitmask value indicating any combination of the remaining filters


%%PageItemTitle%%

eTickPriceType Enumeration

Glossary Item Box

Description

Indicates the tick price type.

Members

Member | Value | Description
tptAsk | 128 | Ask price
tptBid | 64 | Bid price
tptSettlement | 192 | Settlement price
tptTrade | 0 | Trade price


%%PageItemTitle%%

eTicksRequestType Enumeration

Glossary Item Box

Description

Indicates the request type of ticks.

Members

Member | Value | Description
trtCurrentNotify | 3 | From the current time, the user will be notified about each new tick.
trtSinceTime | 1 | From start time to the current time, the user will not be notified about each new tick.
trtSinceTimeNotify | 2 | From start time to the current time, the user will be notified about each new tick.
trtTimeRange | 0 | From start time to end time, the user will not be notified about each new tick.

Remarks

This is used in the CQGCEL.RequestTicks method.

See Also

CQGCEL.RequestTicks Method


%%PageItemTitle%%

eTimedBarsRequestOutputs Enumeration

Glossary Item Box

Description

Specifies the outputs for timed bars request.

Members

Member | Value | Description
tbrActualVolume | 0 | Actual volume
tbrAskFlagVolume | 11 | Volume of trade with 'buy' aggressor flag
tbrAskVolume | 2 | Ask volume
tbrBidFlagVolume | 12 | Volume of trade with 'sell' aggressor flag
tbrBidVolume | 3 | Bid volume
tbrCommodityOpenInterest | 10 | Commodity open interest
tbrCommodityTickVolume | 8 | Commodity tick volume
tbrCommodityVolume | 6 | Commodity volume
tbrContractOpenInterest | 9 | Contract open interest
tbrContractTickVolume | 7 | Contract tick volume
tbrContractVolume | 5 | Contract volume
tbrOpenInterest | 4 | Open interest
tbrTickVolume | 1 | Tick volume


%%PageItemTitle%%

eTimeSeriesContinuationType Enumeration

Glossary Item Box

Description

Indicates the time series continuation type.

Members

Member | Value | Description
tsctActive | 3 | Active continuation
tsctActiveByMonth | 4 | Active continuation by month
tsctAdjusted | 5 | Adjusted continuation
tsctAdjustedByMonth | 6 | Adjusted continuation by month
tsctNoContinuation | 0 | No continuation
tsctStandard | 1 | Standard continuation
tsctStandardByMonth | 2 | Standard continuation by month


%%PageItemTitle%%

eTimeSeriesSubscriptionLevel Enumeration

Glossary Item Box

Description

Indicates the time series subscription level.

Members

Member | Value | Description
tslEachBar | 1 | Update on each bar. This is the default value.
tslEachTick | 0 | Update on each tick.
tslEndOfBarAndPeriod | 2 | Recalculate on each tick, each bar, and periodically as specified with the corresponding RecalcPeriod property.

See Also

CQGCustomStudyRequest.SubscriptionLevel Property | CQGExpressionRequest.SubscriptionLevel Property | CQGTradingSystemRequest.SubscriptionLevel Property


%%PageItemTitle%%

eTimeZone Enumeration

Glossary Item Box

Description

Specifies all available time zones.

Members

Member | Value | Description
tzAfghanistan | 175 | (GMT+04:30) Kabul.
tzAlaskan | 3 | (GMT-09:00) Alaska.
tzArab | 150 | (GMT+03:00) Kuwait, Riyadh.
tzArabian | 165 | (GMT+04:00) Abu Dhabi, Muscat.
tzArabic | 158 | (GMT+03:00) Baghdad.
tzAtlantic | 50 | (GMT-04:00) Atlantic Time (Canada).
tzAUSCentral | 245 | (GMT+09:30) Darwin.
tzAUSEastern | 255 | (GMT+10:00) Canberra, Melbourne, Sydney.
tzAzores | 80 | (GMT-01:00) Azores.
tzCanadaCentral | 25 | (GMT-06:00) Saskatchewan.
tzCapeVerde | 83 | (GMT-01:00) Cape Verde Island.
tzCaucasus | 170 | (GMT+04:00) Baku, Yerevan.
tzCenAustralia | 250 | (GMT+09:30) Adelaide.
tzCentral | 20 | (GMT-06:00) Central Time (US & Canada).
tzCentralAmerica | 33 | (GMT-06:00) Central America.
tzCentralAsia | 195 | (GMT+06:00) Astana, Dhaka.
tzCentralEurope | 95 | (GMT+01:00) Belgrade, Bratislava, Budapest, Ljubljana, Prague.
tzCentralEuropean | 100 | (GMT+01:00) Sarajevo, Skopje, Warsaw, Zagreb.
tzCentralPacific | 280 | (GMT+11:00) Magadan, Solomon Islands., New Caledonia.
tzChina | 210 | (GMT+08:00) Beijing, Chongqing, Hong Kong, Urumqi.
tzDateline | 0 | (GMT-12:00) International Date Line West.
tzEAfrica | 155 | (GMT+03:00) Nairobi.
tzEastern | 35 | (GMT-05:00) Eastern Time (US & Canada).
tzEasternNoDST | 40 | (GMT-05:00) Indiana (East).
tzEAustralia | 260 | (GMT+10:00) Brisbane.
tzEEurope | 115 | (GMT+02:00) Bucharest.
tzEgypt | 120 | (GMT+02:00) Cairo.
tzEkaterinburg | 180 | (GMT+05:00) Ekaterinburg.
tzESouthAmerica | 65 | (GMT-03:00) Brasilia.
tzFiji | 285 | (GMT+12:00) Fiji, Kamchatka, Marshall Islands.
tzFLE | 125 | (GMT+02:00) Helsinki, Kyiv, Riga, Sofia, Tallinn, Vilnius.
tzGMT | 85 | (GMT) Greenwich Mean Time : Dublin, Edinburgh, Lisbon, London.
tzGreenland | 73 | (GMT-03:00) Greenland.
tzGreenwich | 90 | (GMT) Casablanca, Monrovia (without daylight saving).
tzGTB | 130 | (GMT+02:00) Athens, Beirut, Istanbul, Minsk.
tzHawaiian | 2 | (GMT-10:00) Hawaii.
tzIndia | 190 | (GMT+05:30) Chennai, Kolkata, Mumbai, New Delhi.
tzIran | 160 | (GMT+03:30) Tehran.
tzJerusalem | 135 | (GMT+02:00) Jerusalem.
tzKorea | 230 | (GMT+09:00) Seoul.
tzMalayPeninsula | 215 | (GMT+08:00) Kuala Lumpur, Singapore.
tzMexico | 30 | (GMT-06:00) Guadalajara, Mexico City, Monterrey.
tzMexico2 | 13 | (GMT-07:00) Chihuahua, La Paz, Mazatlan.
tzMidAtlantic | 75 | (GMT-02:00) Mid-Atlantic.
tzMountain | 10 | (GMT-07:00) Mountain Time (US & Canada).
tzMountainNoDST | 15 | (GMT-07:00) Arizona.
tzMyanmar | 203 | (GMT+06:30) Rangoon.
tzNCentralAsia | 201 | (GMT+06:00) Almaty, Novosibirsk.
tzNepal | 193 | (GMT+05:45) Kathmandu.
tzNewfoundland | 60 | (GMT-03:30) Newfoundland.
tzNewZealand | 290 | (GMT-03:30) Newfoundland.
tzNorthAsia | 207 | (GMT+07:00) Krasnoyarsk.
tzNorthAsiaEast | 227 | (GMT+08:00) Irkutsk, Ulaan Bataar.
tzPacific | 4 | (GMT-08:00) Pacific Time (US & Canada); Tijuana.
tzPacificSA | 56 | (GMT-04:00) Santiago.
tzRomance | 105 | (GMT+01:00) Brussels, Copenhagen, Madrid, Paris.
tzRussian | 145 | (GMT+03:00) Moscow, St. Petersburg, Volgograd.
tzSAEastern | 70 | (GMT-03:00) Buenos Aires, Georgetown.
tzSamoa | 1 | (GMT-11:00) Midway Island, Samoa.
tzSAPacific | 45 | (GMT-05:00) Bogota, Lima, Quito.
tzSAWestern | 55 | (GMT-04:00) Caracas, La Paz.
tzSEAsia | 205 | (GMT+07:00) Bangkok, Hanoi, Jakarta.
tzSouthAfrica | 140 | (GMT+02:00) Harare, Pretoria.
tzSriLanka | 200 | (GMT+06:00) Sri Jayawardenepura.
tzTaipei | 220 | (GMT+08:00) Taipei.
tzTasmania | 265 | (GMT+10:00) Hobart.
tzTokyo | 235 | (GMT+09:00) Osaka, Sapporo, Tokyo.
tzTonga | 300 | (GMT+13:00) Nuku'alofa.
tzUndefined | -1 | Undefined.
tzUTC | 90 | (GMT) The same as tzGreenwich.
tzVladivostok | 270 | (GMT+10:00) Vladivostok.
tzWAustralia | 225 | (GMT+08:00) Perth.
tzWCentralAfrica | 113 | (GMT+01:00) West Central Africa.
tzWestAsia | 185 | (GMT+05:00) Islamabad, Karachi, Tashkent.
tzWestPacific | 275 | (GMT+10:00) Guam, Port Moresby.
tzWEurope | 110 | (GMT+01:00) Amsterdam, Berlin, Bern, Rome, Stockholm, Vienna.
tzYakutsk | 240 | (GMT+09:00) Yakutsk.

Example

In the example the CQGCEL timezone is set to Caucasus timezone.

Timezone Change Copy Code
Dim CurrentConfig As CQGCELConfiguration
CurrentConfig = CEL.Configuration
CurrentConfig.TimeZoneCode = tzCaucasus
CEL.Configuration = CurrentConfig
CEL.Startup


%%PageItemTitle%%

eTradeChangeCategory Enumeration

Glossary Item Box

Description

Indicates the trading system trade change category.

Members

Member | Value | Description
tccAll | 31 | All kinds of changes. The value of this enumerator is tccSignalSet Or tccSignalReset Or tccQuantity Or tccPrice Or tccStopLimitPrice.
tccPrice | 8 | Entry/exit price change.
tccQuantity | 4 | Entry/exit quantity change.
tccSignalReset | 2 | Entry/exit signaled flag reset.
tccSignalSet | 1 | Entry/exit signaled flag set.
tccStopLimitPrice | 16 | Entry/exit stop-limit price change


%%PageItemTitle%%

eTradeSide Enumeration

Glossary Item Box

Description

Indicates the trading system trade side.

Members

Member | Value | Description
tsBuy | 0 | Buy orders
tsOff | 2 | Trade is off
tsSell | 1 | Sell orders

Remarks

This is used in the %CQGTradingSystemTradeDefinition.Side:CQG~CQGTradingSystemTradeDefinition~Side property.

See Also

CQGTradingSystemTradeDefinition.Side Property


%%PageItemTitle%%

eTradingSystemBaseBar Enumeration

Glossary Item Box

Description

Specifies the trading system base bar type.

Members

Member Value Description
bbBar 0 Specifies the base bar type to be Timed Bar.

If this trading system base bar type is set CQGTradingSystemRequest.BaseBarParameters will be empty.

This is the default.

bbConstantVolumeBar 1 Specifies the base bar type to be of CVB bar.

If this trading system base bar type is set, the following base bar parameters will be available in CQGTradingSystemRequest.BaseBarParameters:

  • bbpVolumeLevel
  • bbpVolumeType
  • bbpIncludeFlatTicks
bbPointAndFigureBar 3 Specifies the base bar type to be of PF bar.

If this trading system base bar type is set, the following base bar parameters will be available in CQGTradingSystemRequest.BaseBarParameters:

  • bbpBoxSize
  • bbpBoxUnits
  • bbpReversal
  • bbpDataSource
bbTFlowBar 2
Specifies the base bar type to be of TFlow bar.

If this trading system base bar type is set, the following base bar parameters will be available in CQGTradingSystemRequest.BaseBarParameters:

  • bbpAggregation
  • bbpAggregationLevel


%%PageItemTitle%%

eTradingSystemBaseBarParameter Enumeration

Glossary Item Box

Description

Specifies the Trading System base bar parameters.

Members

Member | Value | Description
bbpAggregation | 7 | Specifies the aggregation parameter for the PF base bar. This is a read/write property of eTfAggregation type.
bbpAggregationLevel | 8 | Specifies the aggregation level parameter for the PF base bar. This is a read/write property of Long type.
bbpBoxSize | 3 | Specifies the volume type parameter for the PF base bar. This is a read/write property of Long type.
bbpBoxUnits | 4 | Specifies the box units parameter for the PF base bar. This is a read/write property of ePfBoxUnits type.
bbpDataSource | 6 | Specifies the data source parameter for the PF base bar. This is a read/write property of ePfDataSource type.
bbpIncludeFlatTicks | 2 | Specifies whether flat ticks are included or not in the CVB base bar. This is a read/write property of Boolean type.
bbpReversal | 5 | Specifies the reversal parameter for the PF base bar. This is a read/write property of Long type.
bbpVolumeLevel | 0 | Specifies the volume level parameter for the CVB base bar. This is a read/write property of Long type.
bbpVolumeType | 1 | Specifies the volume type parameter for the CVB base bar. This is a read/write property of eCvbVolumeType type.


%%PageItemTitle%%

eTradingSystemCommissionType Enumeration

Glossary Item Box

Description

Indicates the type of the commission calculation used in the Trading System.

Members

Member | Value | Description
tscmFixed | 0 | Fixed commission
tscmPerContract | 1 | Per contract commission

Remarks

This is used in the CQGTradingSystemDefinition.CommissionType property.

See Also

CQGTradingSystemDefinition.CommissionType


%%PageItemTitle%%

eTradingSystemStatistic Enumeration

Glossary Item Box

Description

Indicates the trading system statistics.

Members

Member | Value | Description
tssAverageDuration | 5 | Average duration
tssAverageLoss | 9 | Average loss
tssAverageProfit | 6 | Average profit
tssAverageWin | 7 | Average win
tssClosedNetProfit | 1 | Closed net profit
tssCurConsecLosses | 17 | Current consecutive losses
tssCurConsecWins | 15 | Current consecutive wins
tssCurDrawDown | 23 | Current draw down
tssLinearRegression | 25 | Linear regression
tssMaxClosedDraw | 11 | Maximum closed draw
tssMaxConsecLosses | 16 | Maximum consecutive losses
tssMaxConsecWins | 14 | Maximum consecutive wins
tssMaxDrawAmount | 12 | Maximum draw amount
tssMaxDrawDuration | 13 | Maximum draw duration
tssMaximumLoss | 10 | Maximum loss
tssMaximumWin | 8 | Maximum win
tssOpenPosition | 3 | Open position
tssPercentLong | 4 | Percent long
tssPercentWinners | 20 | Percent winners
tssProfitLossRatio | 19 | Profit/loss ration
tssProfitToMaxDraw | 18 | Profit to maximum draw
tssRemoveToNeutral | 21 | Remove to neutral
tssReturnRetracement | 24 | Return retracement
tssTimePercentage | 22 | Time percentage
tssTotalNetProfit | 0 | Total net profit
tssTotalTradeCount | 2 | Total trade count


%%PageItemTitle%%

eUserFormulaParameterType Enumeration

Glossary Item Box

Description

Indicates the user formula parameter type.

Members

Member | Value | Description
ufptChoice | 3 | Parameter type is choice
ufptDouble | 1 | Parameter type is double
ufptInt | 0 | Parameter type is integer
ufptString | 2 | Parameter type is string

Remarks

This is used in the CQGParameterDefinition.Type property.

See Also

CQGParameterDefinition.Type Property


%%PageItemTitle%%

eYieldCompound Enumeration

Glossary Item Box

Description

Indicates the yield compound

Members

Member | Value | Description
ycAnnual | 1 | Annual
ycDefault | 0 | Default
ycSemiAnnual | 2 | Semiannual


%%PageItemTitle%%

eYieldModel Enumeration

Glossary Item Box

Description

Indicates the yield model

Members

Member | Value | Description
ymBraessFangmeyer | 5 | Braess-Fangmeyer
ymDefault | 0 | Default
ymMoosmuller | 4 | Moosmuller
ymSimpleBond | 2 | Simple bond
ymStandardBill | 1 | Standard bill
ymStandardBond | 3 | Standard bond


%%phrase%%

References
Send Feedback

Glossary Item Box